Tích hợp PLM
Giải pháp thiết kế kết hợp giữa Altium Designer và một Altium 365 Workspace cung cấp Tích hợp PLM có thể cấu hình, với hỗ trợ dành cho Windchill®, Arena®, Oracle® Agile™, Aras Innovator®, và Siemens Teamcenter® (cần thiết lập bổ sung). Việc thiết lập tích hợp PLM được thực hiện thông qua giao diện trình duyệt của Altium 365 Workspace, cung cấp một giao diện tự động để dễ dàng cấu hình kết nối liên thông, ánh xạ dữ liệu tham số và chỉ định hướng đồng bộ dữ liệu. Sau khi giao diện đã được thiết lập và cấu hình, các tính năng và chức năng tích hợp PLM sẽ khả dụng khi làm việc trong các khu vực riêng biệt sau:
-
Library (linh kiện) – hỗ trợ đồng bộ một chiều hoặc hai chiều các linh kiện, tham số linh kiện và lựa chọn part giữa Altium 365 Workspace của bạn và phiên bản PLM của bạn. Cấu hình cho phép bạn chỉ định tham số nào được quản lý chính trong hệ thống nào. Ngoài ra, các tham số item cho phép bạn cập nhật thuộc tính ở phía Workspace (có thể cấu hình theo từng trường), mà không cần chính thức phát hành một revision mới của Component Item đó. Một quy trình Yêu cầu Part chuyên dụng cũng khả dụng, hỗ trợ tự động tạo một Component trong phiên bản PLM của bạn, đồng thời chuyển ngược các mã part PLM đã tạo về các linh kiện ở phía Workspace.
-
Design (dự án) – có sẵn một quy trình Tạo Dự án chuyên dụng, cũng hỗ trợ tự động tạo mã part trong phiên bản PLM của bạn, rồi chuyển ngược các tham số này về dự án thiết kế. Các tham số đó có thể được dùng trong các chuỗi đặc biệt (ví dụ: cho chú thích khung viền bản vẽ). Bạn có thể xuất bản thiết kế của mình sang phiên bản PLM như một phần của quá trình chạy Project Releaser trong Altium Designer. Thao tác xuất bản sử dụng một mẫu xuất bản – được định nghĩa như một phần của cấu hình tích hợp phiên bản PLM – để kiểm soát cách dữ liệu được truyền sang PLM. Và nếu bạn xuất bản lần đầu tiên và các mã part (ở phía PLM) chưa được liên kết với dự án, thì các mã part đó sẽ được tạo trong PLM và liên kết với dự án như một phần của lần xuất bản ban đầu đó. Bạn cũng có thể định nghĩa các mục linh kiện cho các linh kiện trong phiên bản PLM như một phần của thao tác xuất bản (tùy chọn, dựa trên cấu hình). Và bạn sẽ luôn có thể xem chính xác những gì đã được tạo, chẳng hạn như các mã part trong phiên bản PLM, như một phần của lịch sử quy trình xử lý (History tab).
Hỗ trợ PLM
Altium 365 Workspace hỗ trợ các hệ thống PLM sau:
-
PTC Windchill® PLM phiên bản 12, 13, và PTC Windchill+ (biến thể SaaS của Windchill).
-
Arena® PLM.
-
Oracle® Agile™ PLM.
-
Aras Innovator® Release 30.
Additional Setup for Aras Innovator
Để đạt được tích hợp PLM với Aras Innovator, máy chủ Altium Workspace của bạn cần được đăng ký với thiết lập Xác thực Aras bằng cách thêm một phần node mới vào client registry của nó. Sau khi đăng ký, một token OAuth duy nhất sẽ được cấp cho Workspace đã kết nối của bạn để xác thực quyền truy cập.
Các thay đổi cấu hình bắt buộc đối với Aras Innovator được thực hiện bằng cách chỉnh sửa tệp client registry OAuth của nó:
-
Trên máy chủ Aras, mở tệp
\OAuthServer\OAuth.configđể chỉnh sửa. -
Xác định và sao chép phần IOMApp – từ dòng
<clientRegistry id="IOMApp" enabled="true">đến dòng</clientRegistry>. -
Dán phần IOMApp đã sao chép ngay sau đó để tạo một phần mới (bản sao).
-
Trong phần node mới này, đổi tên
IOMAppthànhNEXUS– kết quả là<clientRegistry id="NEXUS" enabled="true">.
-
Lưu lại rồi khởi động lại máy Aras.
- Siemens Teamcenter®, với thiết lập tích hợp bổ sung.
- Duro PLM, được triển khai dưới dạng một phiên bản PLM của bên thứ ba – xem phần Hỗ trợ PLM Bên thứ ba bên dưới.
Lựa chọn Giao diện Thiết lập PLM
Kết nối Altium 365 Workspace tới một hệ thống PLM được hỗ trợ có thể được thiết lập thông qua giao diện người dùng bán tự động nâng cao, như trình bày chi tiết bên dưới, hoặc bằng quy trình thủ công dựa trên việc chỉnh sửa các tệp XML cấu hình PLM. Cách sau đòi hỏi hiểu biết về cấu trúc dữ liệu của hệ thống PLM đích và sự quen thuộc với định dạng XML, trong khi hệ thống cập nhật được trình bày dưới đây sẽ tự động lấy dữ liệu cần thiết từ PLM và Altium Workspace để điền vào các lựa chọn menu trong giao diện.
Bạn có thể cấu hình lại Workspace để hiển thị giao diện PLM trước đây – dựa trên việc chỉnh sửa thủ công các tệp XML – bằng cách bỏ chọn tùy chọn Enable new PLM Configuration page trong trang Admin – Settings – PLM Integration của giao diện Workspace. Hãy chắc chắn lưu thay đổi, sau đó đăng xuất rồi đăng nhập lại.
Kết nối tới Phiên bản PLM của bạn
Các Cấu hình PLM được tạo và quản lý trong trang Admin – PLM Integration của giao diện trình duyệt Workspace. Khi bạn đã kết nối thành công tới hệ thống PLM, giao diện cấu hình sẽ cung cấp một loạt tùy chọn tích hợp dựa trên dữ liệu lấy từ cả Workspace và PLM đã kết nối.
Sử dụng nút
để bắt đầu quá trình kết nối và tiếp tục theo hướng dẫn trong slideshow bên dưới.
Mọi lỗi kết nối sẽ được tô đỏ khi đăng nhập vào hệ thống PLM đích. Viền dưới của khung tô sáng sẽ bao gồm chi tiết lỗi – xem ví dụ.
PTC Windchill SSO Support
Khả năng sử dụng ủy quyền Single Sign On (SSO) khi kết nối tới hệ thống Windchill PLM là có sẵn và được thiết lập thông qua giao diện Workspace. Điều này cung cấp một phương thức ủy quyền kết nối đơn giản và an toàn khi thực hiện các quy trình PLM của Workspace như Tạo Dự án và Xuất bản sang PLM. Trên thực tế, cách bố trí này cho phép cấp quyền truy cập Windchill bằng cách sử dụng tiêu chuẩn ủy quyền OAuth thông qua một dịch vụ nhà cung cấp danh tính như PingFederate.
Quyền truy cập vào thiết lập SSO có sẵn trong tab OAuth của trang PLM Integration trong Workspace (Admin - PLM Integration), nơi có thể thêm nhiều phiên bản nhà cung cấp OAuth.
Thiết lập ủy quyền nhà cung cấp OAuth được hoàn tất bằng dữ liệu có sẵn từ nhà cung cấp danh tính đã cấu hình của bạn. Nhập tên và thông tin mà Workspace yêu cầu – ID, token, URL, v.v. – vào các trường trên trang, rồi lưu cấu hình đã hoàn tất.
Phiên bản OAuth Provider mới sẽ khả dụng khi tùy chọn OAuth Connection được bật trong cấu hình Windchill PLM. Chọn từ danh sách thả xuống OAuth Provider nếu có nhiều nhà cung cấp. Hoàn tất thiết lập kết nối bằng nút
và làm theo các nhắc nhở của nhà cung cấp nếu cần.
Hỗ trợ PLM Bên thứ ba
Altium 365 Workspace cung cấp hỗ trợ bổ sung cho các cấu hình hệ thống PLM “không native” do bên thứ ba phát triển. Hỗ trợ này được kích hoạt bằng Generic Connector của Altium, yêu cầu giấy phép Altium 365 PLM Generic Connector Addon.
Khi thêm một Workspace PLM Instance cho hệ thống như vậy, các tệp XML cấu hình sẵn do bên thứ ba cung cấp sẽ được tải lên cấu hình PLM Instance đó thông qua giao diện PLM Integration.
Thiết lập Cấu hình
Sau khi kết nối thành công tới một phiên bản PLM, giao diện Workspace PLM cung cấp các cài đặt cấu hình để xác định cách đồng bộ linh kiện được thực hiện, ánh xạ chéo các tham số linh kiện, và phương thức truyền dùng cho dữ liệu Part Choices. Các tùy chọn đồng bộ này có sẵn trong tab Configuration của giao diện.
Các tùy chọn cài đặt cấu hình dành cho bạn (và nhãn/chức năng của chúng) được xác định bởi loại hệ thống PLM và dữ liệu tham số lấy từ cả Workspace và PLM instance đã kết nối.
Tham số Đồng bộ
Phần giao diện PLM này xác định những loại linh kiện nào sẽ được đồng bộ, nơi và cách các linh kiện mới sẽ được tạo/cập nhật, cũng như mọi ràng buộc dựa trên tiêu chí tham số.
Cách đồng bộ linh kiện được chỉ định riêng lẻ:
- Chọn một Altium Component Type trong danh sách tham số và đặt tùy chọn Sync Direction của nó theo nhu cầu (sang Altium/PLM hoặc cả hai) – các tùy chọn loại linh kiện được lấy từ dữ liệu linh kiện hiện tại của Workspace.
- Chọn tên thuộc tính PLM liên quan từ menu PLM Type – các tùy chọn khả dụng được lấy từ phiên bản PLM đã kết nối.
- Trong trường Altium Target Folder (bên dưới Sync to Altium) duyệt tới và chọn một thư mục linh kiện của Workspace làm vị trí đồng bộ cho linh kiện này.
- Chỉ định một Sync Mode để xác định liệu các linh kiện mới sẽ được tạo trong quá trình đồng bộ hay chỉ cập nhật các linh kiện hiện có – hoặc cả hai.
-
Đặt Component Template sẽ được dùng để xác định kiểu tham số linh kiện khi đồng bộ linh kiện này. Thiết lập này sẽ mặc định theo Altium Component Type đã chọn (ví dụ;
Capacitors) nếu có mẫu Workspace liên kết. - Sử dụng tùy chọn Add Parameter Criteria để chỉ định một giá trị tham số mà việc đồng bộ sẽ bị ràng buộc theo đó. Một linh kiện sẽ không được đồng bộ trừ khi nó thỏa mãn tiêu chí này. Thêm các tiêu chí tham số khác nếu cần.
Các tùy chọn bổ sung khả dụng khi kết nối tới PTC Windchill PLM hỗ trợ hệ thống PartsLInk của Windchill. Hệ thống PartsLink cho phép phân loại part theo nhóm để nhắm mục tiêu thuận tiện và nhanh hơn, đồng thời có thể bao gồm các cặp Thuộc tính/Giá trị liên quan để cung cấp định nghĩa sâu hơn trong Phân loại đó. Xem phần thu gọn bên dưới để biết thêm thông tin.
-
Chọn Add Classification Name Criteria từ menu Filter Criteria để thêm bộ lọc phân loại. Sử dụng menu tên để chọn một nhóm phân loại mà việc đồng bộ sẽ được lọc theo.
-
Để kiểm soát chi tiết hơn, chọn tùy chọn Add Classification Attribute Criteria và chỉ định một Attribute của phân loại cùng với Giá trị liên quan của nó. Trong ví dụ minh họa ở đây, chỉ các tụ điện từ lớp
102-Capacitorscó giá trịCapacitancelà10uFmới được đồng bộ.
More on Windchill PartsLink
Trong chính Windchill, một Phân loại PartsLink được định nghĩa bằng cách tạo một binding attribute có thể áp dụng cho một kiểu part. Sau đó, một Thuộc tính Phân loại part được thêm vào một lớp Phân loại đã xác định.
Các mục linh kiện trong Windchill sẽ bao gồm Phân loại đã định nghĩa của chúng và mọi tham số Thuộc tính Phân loại được chỉ định, và đến lượt chúng sẽ khả dụng cho quy trình đồng bộ linh kiện PLM của Workspace.
Khi một mục linh kiện được đồng bộ từ Windchill sang Workspace và tương tác PartsLink đã được chỉ định trong cấu hình PLM của Workspace, các Thuộc tính Cấu hình của Windchill cho part đó sẽ được truyền sang Altium Designer.
Khi Sync Direction được đặt là To PLM hoặc để đồng bộ hai chiều (To PLM & To Altium), một tùy chọn Add Filter Criteria sẽ xuất hiện dưới Sync To PLM. Sử dụng tùy chọn này để đặt tiêu chí Tham số hoặc Thư mục nhằm kiểm soát những linh kiện Workspace nào sẽ được chuyển sang hệ thống PLM.
Có thể thêm nhiều tiêu chí Tham số để ràng buộc chặt chẽ việc đồng bộ các linh kiện Workspace sang PLM. Các tiêu chí khả dụng cũng bao gồm các tùy chọn điều kiện OR và NOT để thiết lập khả năng kiểm soát chính xác hơn đối với việc lọc các linh kiện được chấp nhận để đồng bộ sang PLM.
Phần Sync to PLM cung cấp các tùy chọn bổ sung về đánh số part và tiền tố/hậu tố khi nhắm tới hệ thống Arena PLM. Các lược đồ PLM định sẵn này khả dụng để chọn trong các menu Numbering Scheme và Code, và sẽ xác định định dạng Item Number của các part được tải lên Arena.
Ánh xạ Tham số Linh kiện
Tiếp tục quy trình tương tự như trên để chỉ định cấu hình tham số đồng bộ cho tất cả các linh kiện mà bạn muốn đồng bộ với PLM. Vì các tham số linh kiện ở phía Workspace không nhất thiết trùng khớp với phía PLM, nên phần giao diện Component Parameter Mapping có thể được sử dụng để ánh xạ tham số giữa hai bên. Lưu ý rằng khi các tham số được ánh xạ, giá trị của chúng sẽ được đồng bộ từ bên này sang bên kia như thể chúng là cùng một tham số.
Sử dụng lệnh Add Parameter của phần này để tạo một mục ánh xạ tham số Workspace/PLM áp dụng cho Altium Component Type đang được chọn (được chọn dưới Sync Parameters). Các tùy chọn Parameter Name của PLM và Altium là những gì khả dụng trong các hệ thống tương ứng. Thiết lập Revision trong cột Item/Revision sẽ khiến một revision linh kiện mới được tạo khi tham số thay đổi, trong khi với thiết lập Item chỉ tham số linh kiện sẽ được cập nhật trong quá trình đồng bộ.
Sử dụng biểu tượng
liên quan để xóa một mục ánh xạ.
Có thể ánh xạ bao nhiêu tham số cũng được theo cách này, tuy nhiên nhiều khả năng sẽ có một loạt tham số Workspace/PLM phổ biến cần được ánh xạ cho mọi linh kiện. Cách tiếp cận ánh xạ toàn cục này khả dụng khi All Types được chọn làm Altium Component Type.
Tạo các mục ánh xạ (Add Parameter) sẽ áp dụng cho tất cả linh kiện bằng cách bao gồm các cặp tham số phổ biến đã biết khớp nhau, và đặt các tùy chọn Item/Revision và Sync Direction theo yêu cầu. Điều quan trọng nữa là chỉ định một mục tham số được ánh xạ làm Primary Key – đây là một cặp tham số phổ biến đóng vai trò là chỉ mục tham chiếu giữa hai tập dữ liệu tham số. Khi đây là Mã part PLM (khuyến nghị), số được tạo ở phía PLM sẽ được chuyển ngược về phía Altium, tạo một liên kết tham chiếu đã biết giữa các tập dữ liệu linh kiện được đồng bộ.
Thuộc tính Phân loại PLM
Đối với các hệ thống PLM được kết nối hỗ trợ nhóm linh kiện dưới dạng Classifications (chẳng hạn như PTC Windchill), các thuộc tính và giá trị PLM liên quan có thể được ánh xạ sang các tham số linh kiện Workspace trong phần này.
Ví dụ với PTC Windchill, để trích xuất một giá trị Thuộc tính Phân loại cụ thể (ví dụ giá trị điện dung cho Tụ điện trong lớp 102-Capacitor), hãy thêm phân loại đó và giá trị của nó (Capacitance) làm PLM Parameter Name, và tham số linh kiện Altium đích (Value) làm Altium Parameter Name. Có thể thêm định nghĩa cho mọi Loại Linh kiện, bao gồm nhiều định nghĩa cho cùng một loại linh kiện.
► Xem thông tin PartsLink ở trên để biết thêm về Phân loại trong Windchill.
Part Choices
Sử dụng menu thả xuống Sync Direction để chỉ định dữ liệu Part Choices của nhà sản xuất sẽ đồng bộ theo hướng nào giữa Workspace và hệ thống PLM, hoặc tắt đồng bộ Part Choices bằng tùy chọn OFF.
Tùy thuộc vào loại PLM được kết nối, tùy chọn Part Choice information sẽ cung cấp đồng bộ ở định dạng tương thích với các part sản xuất được phê duyệt riêng của PLM (Native PLM Manufacturer Parts) hoặc dưới dạng dữ liệu tham số linh kiện thông thường (PLM Part Attributes). Cách sau có thể là nhiều bộ thuộc tính tham số Manufacturer:PartNumber – MFR1:MPN1, MFR2:MPN2, chẳng hạn.
Ví dụ về các part nhà sản xuất PLM “native” (hoặc tích hợp sẵn) bao gồm Vendor Parts trong Arena và Manufacturer Parts trong Windchill.
XML Cấu hình Dự án
Phần này cung cấp danh sách cấu hình XML cơ sở xác định cấu hình PLM ban đầu cho hệ thống PLM đã kết nối. Phiên bản tải xuống của XML thiết lập cơ sở này (Download Sample Configuration) bao gồm các chú thích chi tiết làm nổi bật chức năng của hầu hết các phần Entity và Attribute.
Cuối cùng, thiết lập cấu hình mà bạn định nghĩa trong giao diện PLM Integration được lưu trữ dưới dạng các tệp XML hệ thống, có thể được lưu cục bộ từ lệnh Export Configuration liên kết với chi tiết Server Connection ở đầu trang cấu hình.
Một tùy chọn Import Configuration cũng được bao gồm. Điều này cho phép bạn áp dụng một tệp XML cấu hình hiện có cho một cấu hình PLM mới (hoặc đã chỉnh sửa), và khi đó sẽ sao chép thiết lập cấu hình PLM đó. Ngoài ra, trong trường hợp cần thực hiện các thay đổi chuyên biệt đối với một cấu hình PLM hiện có, tệp XML đã xuất của nó sẽ được chỉnh sửa thủ công rồi nhập trở lại cấu hình. Lưu ý rằng các Parameters, Attributes và Values có trong tệp cấu hình có phân biệt chữ hoa chữ thường.
Thêm Mẫu Xuất bản
Cấu hình PLM yêu cầu bổ sung một Publishing Template dựa trên XML để hỗ trợ các quy trình Workspace gửi toàn bộ dữ liệu dự án – tệp thiết kế, dữ liệu linh kiện và dữ liệu đầu ra sản xuất – đến hệ thống PLM trong một thao tác “publish” duy nhất. Các quy trình này bao gồm Publish to PLM, trong đó người dùng chỉ định dữ liệu đầu ra sẽ được gửi, và Project Releaser with Publish, quy trình gửi dữ liệu đã tạo tới PLM như bước cuối cùng trong Project Release process của Altium Designer.
Thêm một tệp XML Publishing Template phù hợp trong thẻ Publish Template khi tạo hoặc chỉnh sửa cấu hình PLM của bạn. Sử dụng liên kết Sample Project Configurations để tải xuống bộ sưu tập mẫu đã được lưu trữ dành cho các hệ thống PLM được hỗ trợ.
Một Publishing Template bao gồm các tham chiếu cho chi tiết dự án, truyền dữ liệu linh kiện, vị trí nguồn dữ liệu và phân phối tệp của dữ liệu Thiết kế, Lắp ráp và Chế tạo. Các ví dụ được tải xuống bao gồm mẫu cho tất cả các PLM được hỗ trợ; mỗi mẫu sẽ gồm mọi Publishing Rule bổ sung áp dụng cho loại PLM cụ thể đó cùng các chú thích chi tiết để hướng dẫn bạn cần cấu hình gì và cấu hình như thế nào.
Publishing Folder Support for Windchill PLM
Khi cấu hình một phiên bản tích hợp Windchill® PLM Integration sẽ được dùng cho các quy trình Publish to PLM, bạn cũng có thể chỉ định (và tạo) một thư mục Windchill đích cho các tài liệu được publish từ Workspace.
Các tham số thư mục Windchill liên quan được định nghĩa trong tệp XML Publishing Template được áp dụng cho mục tích hợp Windchill PLM của bạn trong Workspace (xem ở trên). Các node định nghĩa thư mục có định dạng thẻ <pt:Folder>xxx</pt:Folder> – trong đó pt là namespace hiện tại và xxx là đường dẫn thư mục đầy đủ – và được đặt như một publishing rule trong phần FileDistribution cho từng loại tài liệu (ví dụ như đầu ra PCB.zip Fabrication).
Một ví dụ về phân cấp cấu trúc XML Publishing sẽ là:
<pt:EntityRule id="FAB">
<pt:FileDistributions>
<pt:FileDistribution archiveName="PCB.zip">
<pt:Folder>PRODUCT/Projects/${project.name}/FAB data</pt:Folder>
Dòng mục cuối cùng sẽ chỉ định (hoặc tạo) một thư mục đích publish cho đầu ra PCB.zip Fabrication với cấu trúc thư mục Windchill (trong đó tên dự án là MyProject):
PRODUCT
Projects
MyProject
FAB data
Lưu ý rằng đường dẫn thư mục được định nghĩa trong tệp XML Publishing là đường dẫn tuyệt đối (thay vì tương đối), và có thể bao gồm các thuộc tính dự án khác như Tên dự án (${project.name}) và Số lắp ráp (${project.PLM_ASSEMBLY_NUMBER}).
Publish to PLM with ECO
Các tệp thiết lập cho các phiên bản Windchill, Agile và Arena PLM cũng hỗ trợ quy trình Change Order (ECO) được chuẩn hóa, được bật trong tệp XML Publishing Template và được định nghĩa trong tệp XML Configuration dưới phần thực thể altiumType="ProjectChangeOrder".
Tùy thuộc vào phiên bản PLM, các định nghĩa cấu hình XML bao gồm lược đồ cho nhận dạng Change Order (đánh số, vị trí, ID, v.v.), các thuộc tính Change Order cụ thể như Tên/Tiêu đề, Mô tả và Độ phức tạp thay đổi (chỉ Windchill), cùng các thiết lập tùy chọn như chiến lược tạo Change Order (không có, mới hoặc tái sử dụng cái hiện có) và thăng cấp trạng thái vòng đời (chỉ Windchill và Agile). Change Order đã định nghĩa được bật trong quá trình publish bằng cách khai báo tham chiếu publishId của nó trong Publishing Template liên quan.
Publishing template cũng hỗ trợ các tập hợp quy tắc xác định cách thức và nơi dữ liệu đầu ra phát hành (dự án, mã nguồn, lắp ráp và dữ liệu chế tạo) được publish tới PLM.
Sau khi được định nghĩa trong các tệp XML Configuration và Publishing Template của máy chủ, Change Order sẽ khả dụng trong các quy trình công việc Project Creation và Publishing to PLM được gọi từ Altium Designer hoặc thông qua Workspace PLM interface. Một biểu mẫu Change Order liên quan sẽ được hiển thị trong luồng đó, nơi các tùy chọn của Change Order được chỉ định.
Hộp thoại của Altium Designer Change Order Required hiển thị bước tạo Project ban đầu và Project Release có bật ECO theo sau.
Trong ví dụ minh họa ở đây, một dự án được tạo trong Altium Designer từ một Template bằng quy trình Create Project with PLM Initialize (tới Arena PLM), với tùy chọn Create change order (ECO) bị tắt. Sau đó dự án được Release bằng quy trình Publish to PLM (User selects) với tùy chọn Create change order được bật (Yes). Ở phía Arena, các mục sau đó được publish theo một Change Order (ECO-00042) và quy trình phê duyệt vốn có của nó.
Tải xuống một tệp lưu trữ ZIP chứa các tệp XML Arena Configuration và XML Publishing Template được sử dụng trong ví dụ này.
Sửa đổi mẫu XLM ví dụ khi cần và tải tệp lên cấu hình PLM của bạn thông qua cửa sổ Add Publish Template, được mở từ nút
. Lưu ý rằng một cấu hình PLM hỗ trợ nhiều Publish Template.
Đồng bộ hóa linh kiện
Việc đồng bộ dữ liệu linh kiện giữa Workspace Altium 365 của bạn và hệ thống PLM được kết nối được xác định bởi ánh xạ tham số và hướng đồng bộ đã bật như nêu ở trên, và sẽ diễn ra khi quy trình đồng bộ được kích hoạt thủ công hoặc tự động theo lịch. Bản thân quá trình đồng bộ được điều khiển bởi một quy trình công việc LibSync tích hợp sẵn.
Trong một phiên bản cấu hình PLM, các tùy chọn đồng bộ liên quan được truy cập trong thẻ Component Synchronization, nơi quy trình có thể được kích hoạt thủ công hoặc đặt theo lịch. Với tùy chọn sau, hãy bật tùy chọn Synchronize on a schedule và chọn khoảng thời gian từ menu thả xuống liên quan.
Bạn có thể sử dụng các tùy chọn menu
để kích hoạt thủ công một quy trình LibSync dưới dạng sự kiện đồng bộ Incremental hoặc Full:
-
Incremental – chỉ áp dụng cho những linh kiện đã được sửa đổi kể từ lần chạy đồng bộ gần nhất (nghĩa là dấu thời gian của chúng muộn hơn ngày đồng bộ gần nhất), và đáp ứng tiêu chí đồng bộ trong cấu hình. Lưu ý rằng đây là chế độ được sử dụng khi một sự kiện đồng bộ được kích hoạt từ điều khiển
trên trang chính PLM Integration – xem bên dưới.
- Full – chế độ này buộc thực hiện đồng bộ toàn bộ. Tất cả linh kiện đáp ứng tiêu chí đồng bộ trong cấu hình sẽ được bao gồm.
Thực hiện đồng bộ hóa linh kiện
Đồng bộ hóa linh kiện (thư viện) có thể được thực hiện như một quy trình thủ công từ một mục phiên bản PLM trên trang Workspace PLM Integration, hoặc như một chu kỳ tự động được chỉ định trong thiết lập phiên bản – xem ở trên. Nhấp vào điều khiển
gắn với phiên bản PLM để gọi thủ công quy trình đồng bộ, quy trình này sẽ tiếp tục thông qua quy trình công việc LibSync bằng cách sử dụng các thiết lập được định nghĩa trong cấu hình PLM liên quan.
Điều khiển Actions sẽ chuyển thành
, cho phép bạn dừng quy trình đồng bộ nếu cần, và mục Sync Status sẽ cho biết rằng một quy trình đang diễn ra. Trạng thái sẽ chuyển thành Completed khi quy trình đồng bộ hoàn tất.
Khi đồng bộ linh kiện được chạy, dù thủ công hay theo lịch, quy trình LibSync sẽ đi qua Workflow được xác định trước cho đến khi hoàn thành hoặc gặp lỗi. Bạn có thể làm mới trình duyệt (F5) để hiển thị trạng thái hiện tại của quy trình đồng bộ.
Để truy cập chi tiết của một sự kiện đồng bộ đã hoàn tất, hãy nhấp vào biểu tượng
trong cột Last Sync để tải xuống tệp nhật ký liên quan (xem ví dụ), hoặc chọn ngày liên quan để mở mục sự kiện trong thẻ Synchronization Status. Lưu ý rằng trong chế độ xem này, các sự kiện đồng bộ đã hoàn tất được liệt kê khi chọn tùy chọn Closed, và mọi sự kiện đang chạy hoặc bị tạm dừng sẽ xuất hiện khi chọn chế độ xem Active.
Các thẻ phụ trong chế độ xem Status cung cấp những thông tin sau:
- Diagram – một đồ họa biểu diễn quy trình công việc của quy trình, với vị trí bước hiện tại của nó được làm nổi bật (hoàn thành hoặc trạng thái lỗi/thất bại).
- Data – bản tóm tắt thông tin về hành động của quy trình, bao gồm thành công hoặc thất bại của các bước của nó và liên kết đến báo cáo quy trình đã được ghi nhật ký – xem ví dụ.
- History – nhật ký thời gian của các sự kiện đồng bộ chính trong Workspace được liệt kê theo trình tự.
Bất kỳ sự kiện đồng bộ nào bị dừng sớm, chẳng hạn khi gặp lỗi, sẽ được liệt kê khi chế độ xem ở chế độ Active. Các mục này có thể được xóa khỏi danh sách bằng điều khiển Terminate , hoặc đúng hơn là được đánh giá và xử lý từ ô Task liên quan được tạo trong Tasks view của Workspace. Lưu ý rằng một sự kiện đồng bộ đã chấm dứt/được xử lý sẽ được chuyển sang danh sách Closed của chế độ xem Synchronization Status với một Status chỉ thị, chẳng hạn như Failed.
Truy cập các quy trình liên quan đến PLM
Các quy trình công việc Process mẫu liên quan đến hệ thống PLM được kết nối có sẵn trong các thẻ chủ đề quy trình trên Workspace Processes page. Nhìn chung, các mẫu này không thể được sử dụng trực tiếp mà phải được lưu lại với tên khác để trở thành hoạt động.
► Xem tài liệu Processes & Workflow để biết thêm thông tin.
Một Quản trị viên Workspace có thể khởi động một phiên bản mới của bất kỳ định nghĩa quy trình đã kích hoạt nào trực tiếp từ danh sách quy trình trên trang Processes bằng cách nhấp vào điều khiển
. Người dùng Workspace không phải quản trị viên cũng có thể khởi tạo các Process đang hoạt động từ Workspace, chẳng hạn như:
-
Một quy trình Part Request with PLM từ nút
trên Part Request page.
-
Một quy trình Publish to PLM từ nút
trên các trang Tasks và Activities của một dự án đang mở.
-
Một quy trình Publish to PLM từ nút
trên trang chính Projects page.
-
Một quy trình Project with Initialize in PLM từ nút
trên trang chính Projects page, hoặc khi Cloning a project từ menu nút
.
Tuy nhiên trên thực tế, các quy trình liên quan đến PLM thường được gọi từ Altium Designer trong quá trình thiết kế và phát triển dự án. Các quy trình liên quan đến PLM được truy cập từ Altium Designer theo những cách sau:
-
Part Request with PLM Part Create – Được truy cập từ các panel Explorer, Manufacturer Part Search và Components của Altium Designer.
► Xem Process-based Part Requests để biết thông tin chi tiết. -
Publish to PLM (User selects) – Được truy cập từ menu con Project » Project Activities cho dự án Altium Designer đang hoạt động.
► Xem Publishing to a PLM – user-selects để biết thông tin chi tiết. -
Project Releaser with Publish – Được truy cập như giai đoạn Project Releaser cuối cùng từ menu con Project » Project Releaser cho dự án Altium Designer đang hoạt động.
► Xem Design Project Release – publishing to PLM để biết thông tin chi tiết. -
Project with initialise in PLM – Được truy cập khi tạo một dự án Altium Designer mới từ menu con File » New » Project in <Workspace>, hoặc khi sao chép một dự án.
► Xem Publishing to a PLM – initialize in PLM để biết thông tin chi tiết.
Quy trình công việc Process
Các định nghĩa quy trình sau đây (và các workflow nền tảng) có sẵn thông qua Workspace để hỗ trợ tích hợp PLM:
-
Part Requests chủ đề quy trình:
- Part Request with PLM Part Create – hỗ trợ tự động tạo một Component trong phiên bản PLM của bạn, sau đó truyền số part đã tạo trở lại linh kiện của Workspace. Sơ đồ workflow được hiển thị bên dưới.
Một điều quan trọng cần lưu ý là khi bạn sửa đổi định nghĩa mẫu này để tạo định nghĩa riêng của mình, bạn phải chỉ định phiên bản PLM nơi các part sẽ được tạo. Chọn thực thể Create Part in PLM trong sơ đồ workflow và chọn phiên bản PLM từ menu thả xuống liên quan đến trường PLM Instance. Menu này liệt kê tất cả các phiên bản PLM hiện được định nghĩa (như đã định nghĩa trên trang PLM Integration của giao diện).
► Xem Creating and Managing Processes để biết thêm thông tin về cách làm việc với process workflow.
- Project Activities chủ đề quy trình:
- Publish to PLM (User selects) – publish các đầu ra dự án được quản lý đã phát hành tới phiên bản PLM tích hợp, trong đó người dùng có thể chọn chính xác đầu ra nào sẽ được publish. Sơ đồ workflow được hiển thị bên dưới.
- Project Releaser with Publish – publish tới phiên bản PLM tích hợp như một giai đoạn bổ sung của Project Releaser. Sơ đồ workflow được hiển thị bên dưới.
-
Project Creations chủ đề quy trình:
- Project with initialise in PLM – hỗ trợ tự động tạo số part trong phiên bản PLM của bạn, sau đó truyền chúng như các Parameter của dự án thiết kế trong Workspace. Sơ đồ workflow được hiển thị bên dưới.
























. 












