生成多板设计的生产数据

Created: June 9, 2022 | Updated: June 9, 2022
All Contents

多板设计的主要目的是将电子产品的所有元素整合成一个系统,为成功生产做好准备。多板项目中子项目的构造和装配输出是为了满足特定模块的生产,但不是为了将整个系统装配成产品。除了子模块PCB和所需的外壳、硬件和布线的设计定义外,系统设计还应该包括与完整产品有关的关键生产数据,如其零部件和装配等等定义。

系统级物料清单

对项目生产数据的概念而言,设计所需元件及其相关数据的材料清单(BOM)有效记录至关重要。Altium Designer提供了先进的ActiveBOM功能,使用项目ActiveBOM文档整理和管理关于制造元件和供应商来源、元件规格、生命周期状态、可用性等方面的实时信息。

► 如需了解处理BOM文件的详细信息,请查看“使用ActiveBOM进行BOM管理”。

在系统设计中,您可以在多板项目中直接创建ActiveBOM文件,为整个多板项目提供单一的源BOM定义,无需从各个子项目的BOM中手动组合这些数据。

要创建系统级BOM文件,请在项目面板的多板项目名称上单击右键,从上下文菜单中选择“添加新项目” » “ActiveBOM”命令。生成的<项目名称>.BomDoc文件将被添加到多板项目层次结构中的最高层。

系统级BOM从多板装配文件中获取元件参数,而多板装配文件又从多板原理图中定义的多板子项目中获取元件信息。因此,它依赖于最新的子项目,子项目原理图与PCB同步,与多板原理图和装配文件相同(“设计” » “更新装配 - <装配文件>”“设计” » “从<多板项目>导入更改”)。

要确保多板装配拥有正确的项目元件数据,请从主菜单中选择“编辑” » “更新所有部件”命令,或者在元件编辑器中点击右键,选择更新所有元件选项。

顶层多板BOM还包括以模块列信息形式列出的每个项目的源项目详情。ModuleAssembly列默认启用,而其他模块参考列可在属性面板标签中查看。

作为整体产品设计的元件信息总参考——一套互联PCB项目模块,系统级BOM包括所有子项目的元件和供应链数据,以及整理后的信息,如特定元件的总价和整体多板设计中所有元件的成本。

注意,子项目内的BOM文件数据不会被系统级BOM文件使用。然而,对子项目BomDoc所做的修改,如修改元件标识符或元件选择,会被项目设计本身所采纳,并反映在多板BomDoc中。

如上所述,在子项目中的任何元件数据变化必须更新到多板装配文件中(更新所有元件),然后这些变化才会反映在系统级多板BomDoc中。

元件选择

ActiveBOM功能的一个强大优势是能够提供由制造商元件数据和可靠供应商来源组成的项目元件实时供应链信息。存储为“元件选择”并在BomDoc中作为映射解决方案实行,系统级BOM可添加与整体产品设计有关的替代元件数据,如机械/机电元件、互连电缆、线束等等。

举例来说,在多板原理图中多板模块的互连电缆以其终端元件来表示。这些电缆连接器元件将列入系统级BOM中,连同其相关的供应链解决方案或作为手动解决方案添加的特定元件/供应品参考。

► 如需了解更多信息,请查看“创建BOM解决方案”。

系统级输出数据

除了为多板设计组成子项目的制造和装配生成的生产输出数据外,系统级设计还需要适用于整体多板元件生产的输出数据。Altium Designer通过生成的报告和图形文件提供系统级输出数据。

BOM报告

BOM报告输出可通过“报告管理器”对话框直接从ActiveBOM文档中生成,“报告管理器”对话框从主菜单中的“报告” » “物料清单”选项中打开。

“报告管理器”对话框(BOM文档的物料清单<BomDoc>)允许您为系统级设计配置并生成一系列输出格式的BOM报告,包括csv、xml、pdf等。报告包括所有ActiveBOM数据,包括每个项目的供应链数据快照。

Draftsman BOM表格

添加到系统级Draftsman文档中的Draftsman BOM表格报告将从多板ActiveBOM文档中提取数据并加以反映。要创建系统级Draftsman文档,请在多板项目名称上单击右键,从上下文菜单中选择“添加新的到项目” »“Draftsman文档”(选择任意子项目作为来源)。

当BOM表格从这个顶层文件(“放置” » “物料清单”)放置时,其内容将包括整个多板设计中的所有元件条目。与ActiveBOM文件一样,额外模块参考参数列可用(如模块装配、标识符、来源和标题)。当在Draftsman编辑器中选择BOM表格时,BOM表格列在属性面板的列标签下进行管理。

多板装配导出

当多板装配为活动文档时,系统级多板装配的表示可以从“文件 » 导出”选项中导出。导出选项包括PARASOLID(*.x_t)、STEP 3D(*.step)和PDF3D(*.pdf)。以下是一个交互式PDF 3D格式的示例。

输出工作

上述所有类型的输出数据都可以添加到Altium Designer输出作业中,生成针对特定文件格式、可用打印机等容器格式的生产数据。将OutJob文件添加到多板项目中,其生成的输出将代表系统级设计。

右键点击输出作业的名称,并从上下文菜单中选择“添加新的到项目” » “输出作业文件”选项,可将其添加到多板项目中。多板OutJob将提供仅适用于系统级设计的输出选项,如上述的文档和报告输出。

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: