Altium NEXUS Documentation

GenerateReport

Modified by Susan Riege on May 15, 2021

Parent page: WorkspaceManager Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: ObjectKind=Netlist|Index=n (where n is in the range 1 to 30)

Summary

This command is used to create a netlist, in the indicated format, from all relevant source documents in the active project.

Access

The related indexed commands are accessed from the Schematic Editor, from the Design » Netlist For Project sub-menu.

The following netlist formats are supported:

  • Cadnetix
  • Calay
  • EDIF for PCB
  • EESof
  • Intergraph
  • Mentor BoardStation
  • MultiWire
  • OrCad/PCB2
  • PADS
  • Pcad for PCB
  • PCAD
  • PCADnlt
  • Protel2
  • Protel
  • Racal
  • RINF
  • SciCards
  • SIMetrix
  • SIMPLIS
  • Tango
  • Telesis
  • Verilog File
  • VHDL File
  • Wirelist
  • XSpice
The majority of command entries to generate netlist formats are only available in the menus, provided the associated functionality is installed as part of your Altium NEXUS installation. To view and change functionality available to your installation, access the Extensions & Updates view (DXP » Extensions and Updates). From the Installed page, click the Configure control at the top-right to access the Configure Platform page. For those netlisters listed in red above, ensure that the Netlisters entry in the Importers\Exporters region is enabled. For the PADS netlister, ensure that the PADS entry in this region is enabled. For the SIMetrix and SIMPLIS netlisters, ensure the SIMetrix entry, in the Platform Extensions region, is enabled. For the XSpice netlister, ensure that the Mixed Simulation entry in this region is enabled. Once the required functionality is enabled, click Apply. You will need to restart Altium NEXUS for the changes to take effect.

Use

First, ensure that one of the relevant source documents, associated with the project you wish to create the netlist for, is the active document in the main design window.

Depending on the format of netlist you have chosen to create, launching the command will either generate the netlist directly, or an intermediate dialog will appear, allowing you to define specific format-related options. The generated file(s) will initially be closed.

Tips

  1. All output files will be written to the output folder specified in the Output Path field, on the Options tab of the Options for Project dialog. By default, the output path is set to a sub-folder of the folder that contains the project file, and has the name Project Outputs for <ProjectName>. The output path can be changed as required. In the Projects panel, the netlist file (<ActiveDocumentName>.NET) will be presented under the Generated\Netlist Files sub-folder. Bear in mind, that if a different format netlist is generated from the same active document, the previous generated netlist file will be overwritten.
  2. If the option to Use separate folder for each output type is enabled (also on the Options tab), output will be written into a further sub-folder, named in accordance with the format of netlist you have chosen to create (e.g. Project Outputs for <ProjectName>\<NetlistFormat> Output). In the Projects panel, output will appear under the Generated (<NetlistFormat> Output) sub-folder. This allows you to generate multiple netlists from the same active document for the project, without any files being overwritten.


Applied Parameters: ObjectKind=Netlist|Index=n|Target=Document (where n is in the range 1 to 30)

Summary

This command is used to create a netlist, in the indicated format, from the active source document.

Access

The related indexed commands are accessed from the Schematic Editor, from the Design » Netlist For Document sub-menu.

The following netlist formats are supported:

  • Cadnetix
  • Calay
  • EDIF for PCB
  • EESof
  • Intergraph
  • Mentor BoardStation
  • MultiWire
  • OrCad/PCB2
  • PADS
  • Pcad for PCB
  • PCAD
  • PCADnlt
  • Protel2
  • Protel
  • Racal
  • RINF
  • SciCards
  • SIMetrix
  • SIMPLIS
  • Tango
  • Telesis
  • Verilog File
  • VHDL File
  • Wirelist
  • XSpice
The majority of command entries to generate netlist formats are only available in the menus, provided the associated functionality is installed as part of your Altium NEXUS installation. To view and change functionality available to your installation, access the Extensions & Updates view (DXP » Extensions and Updates). From the Installed page, click the Configure control at the top-right to access the Configure Platform page. For those netlisters listed in red above, ensure that the Netlisters entry in the Importers\Exporters region is enabled. For the PADS netlister, ensure that the PADS entry in this region is enabled. For the SIMetrix and SIMPLIS netlisters, ensure the SIMetrix entry, in the Platform Extensions region, is enabled. For the XSpice netlister, ensure that the Mixed Simulation entry in this region is enabled. Once the required functionality is enabled, click Apply. You will need to restart Altium NEXUS for the changes to take effect.

Use

First, ensure that the source document from which you wish to create the netlist, is the active document in the main design window.

Depending on the format of netlist you have chosen to create, launching the command will either generate the netlist directly, or an intermediate dialog will appear, allowing you to define specific format-related options. The generated file(s) will initially be closed.

Tips

  1. All output files will be written to the output folder specified in the Output Path field, on the Options tab of the Options for Project dialog. By default, the output path is set to a sub-folder of the folder that contains the project file, and has the name Project Outputs for <ProjectName>. The output path can be changed as required. In the Projects panel, the netlist file (<ActiveDocumentName>.NET) will be presented under the Generated\Netlist Files sub-folder. Bear in mind, that if a different format netlist is generated from the same active document, the previous generated netlist file will be overwritten.
  2. If the option to Use separate folder for each output type is enabled (also on the Options tab), output will be written into a further sub-folder, named in accordance with the format of netlist you have chosen to create (e.g. Project Outputs for <ProjectName>\<NetlistFormat> Output). In the Projects panel, output will appear under the Generated (<NetlistFormat> Output) sub-folder. This allows you to generate multiple netlists from the same active document, without any files being overwritten.


Applied Parameters: ObjectKind=Report|Index=n (where n is in the range 1 to 30)

Summary

This command is used to generate the indicated report for the active project.

Access

The related indexed commands can be accessed as follows:

  • From the Schematic Editor, from the main Reports menu.
  • From the PCB Editor, from the Reports » Project Reports sub-menu.

Use

First, ensure that an associated document (schematic or PCB) for the project that you wish to create the report for, is the active document in the main design window.

After launching the command, the report will either be generated directly, or an intermediate dialog will appear, from where you can set up the report as required. The generated file(s) will initially be closed.

Reports that can be generated using the respective command entry are:

  • Bill of Materials - this report-type document provides an at-a-glance listing of all components required to build the product – including the bare board, which is essentially the base 'component' upon which all other parts are assembled. The BOM acts as a guide for what needs to be procured to build the product as designed. It also provides a means to calculate costing, based on the required number of assembled boards in a requested spin.
  • Component Cross Reference - a report providing information on all components across all schematic source sheets in the project.
The Bill of Matierials and Component Cross Reference reports are highly configurable, through use of a dedicated and powerful report generation engine, the interface to which is the Report Manager dialog. Once the content for the required report is defined and organized as required, the report can be generated - either printed, or exported into one of several file formats - CSV (Comma Delimited) (*.csv), Microsoft Excel Worksheet (*.xls;*.xlsx;*.xlt;*.xltx), Portable Document Format (*.pdf), Tab Delimited Text (*.txt), Web Page (*.htm;*.html), XML Spreadsheet (*.xml). An exported file can be saved in any nominated location. In addition, it can be opened in the relevant software application and/or added to the project after it is created. Use the Report command, from the Report Manager dialog's menus, to access the Report Preview dialog, with the report already loaded. Use the various controls in the window to adjust the view of the report. Click the Print button to launch the Print dialog, from where to determine what is printed and to which printing device the job is sent. The report preview can also be exported into a variety of file formats.
  • Report Project Hierarchy - a report listing all of the source schematic documents for the design, in terms of their hierarchy within the project. The file is generated directly, and is of the format <ActiveDocumentName>.REP.
  • Simple BOM - a simple-formatted BOM, listing components in terms of Comment, Pattern (footprint), Quantity, Components (designators) and Description (if available). The files are generated directly, and are of the format <ActiveDocumentName>.BOM and <ActiveDocumentName>.CSV.
  • Report Single Pin Nets - a report listing all nets that contain only one component pin. The file is generated directly, and is of the format <ActiveDocumentName>.REP.

Tips

  1. The project is automatically compiled before any of the reports are generated.
  2. Because the Report Manager dialog is so highly configurable, it can also be used to generate any format report that you need, such as a pick and place file that needs the data structured in a specific way to suit a certain placement machine.
  3. All output files will be written to the output folder specified in the Output Path field, on the Options tab of the Options for Project dialog. By default, the output path is set to a sub-folder of the folder that contains the project file, and has the name Project Outputs for <ProjectName>. The output path can be changed as required. In the Projects panel, the generated file(s) will be presented under the Generated\Text Documents (.csv, .txt, .xsl, .bom, .rep) or Generated\Documents (.xls, .pdf, .htm, .xml) sub-folders. Bear in mind, that if a different report format is generated from the same active document, the previous generated report file will be overwritten (if it has the same filename).
  4. If the option to Use separate folder for each output type is enabled (also on the Options tab), output will be written into a further sub-folder, named Reports (e.g. Project Outputs for <ProjectName>\Reports). In the Projects panel, output will appear under the Generated (Reports)\Text Documents (.csv, .txt, .xsl, .bom, .rep) or Generated (Reports)\Documents (.xls, .pdf, .htm, .xml) sub-folders. This allows you to generate multiple reports from the same active document, without any files being overwritten.


Applied Parameters: ObjectKind=Report|Kind=BOM_PartType|Target=Document

Summary

This command is used to generate a Bill of Materials report for the active PCB document. This report-type document provides an at-a-glance listing of all components required to build the active board – including the bare board, which is essentially the base 'component' upon which all other parts are assembled. The BOM acts as a guide for what needs to be procured to build the product as designed. It also provides a means to calculate costing, based on the required number of assembled boards in a requested spin.

Access

This command is accessed from the PCB Editor by choosing the Reports » Bill of Materials command, from the main menus.

Use

First, ensure that the PCB document you wish to generate a Bill of Materials report for, is the active document in the main design window.

After launching the command, the Report Manager dialog will appear. Use this highly configurable, dedicated, and powerful report generation engine, to configure the content for the BOM report as required. The report can be generated - either printed, or exported into one of several file formats:

  • CSV (Comma Delimited) (*.csv)
  • Microsoft Excel Worksheet (*.xls;*.xlsx;*.xlt;*.xltx)
  • Portable Document Format (*.pdf)
  • Tab Delimited Text (*.txt)
  • Web Page (*.htm;*.html)
  • XML Spreadsheet (*.xml).

An exported file can be saved in any nominated location. In addition, it can be opened in the relevant software application and/or added to the project after it is created.

Use the Report command, from the Report Manager dialog's menus, to access the Report Preview dialog, with the BOM report already loaded. Use the various controls in the window to adjust the view of the report. Click the Print button to launch the Print dialog, from where to determine what is printed and to which printing device the job is sent. The report preview can also be exported into a variety of file formats.

Tips

  1. The document is automatically compiled before any the report is generated.
  2. All exported output files will be written to the output folder specified in the Output Path field, on the Options tab of the Options for Project dialog. By default, the output path is set to a sub-folder of the folder that contains the project file, and has the name Project Outputs for <ProjectName>. The output path can be changed as required. In the Projects panel, the generated file(s) will be presented under the Generated\Text Documents (.csv, .txt) or Generated\Documents (.xls, .pdf, .htm, .xml) sub-folders.
  3. If the option to Use separate folder for each output type is enabled (also on the Options tab), output can be written into a further sub-folder, named Reports (e.g. Project Outputs for <ProjectName>\Reports). If exported output is saved to this folder, then in the Projects panel, output will appear under the Generated (Reports)\Text Documents (.csv, .txt) or Generated(Reports)\Documents (.xls, .pdf, .htm, .xml) sub-folders.


Applied Parameters: ObjectKind=Report|KInd=SimpleBOM|Target=Document

Summary

This command is used to generate a Bill of Materials report (in simple format) from the active PCB document.

Access

This command is accessed from the PCB Editor by choosing the Reports » Simple BOM command, from the main menus.

Use

First, ensure that the PCB document you wish to generate a simple Bill of Materials report for, is the active document in the main design window.

After launching the command, two reports will be generated in the formats <ActiveDocumentName>.BOM and <ActiveDocumentName>.CSV. Components on the board are listed in terms of Comment, Pattern (footprint), Quantity, Components (designators) and Description (if available).

Tips

  1. The generated files will be written to the output folder specified in the Output Path field, on the Options tab of the Options for Project dialog. By default, the output path is set to a sub-folder of the folder that contains the project file, and has the name Project Outputs for <ProjectName>. The output path can be changed as required. In the Projects panel, the generated files will be presented under the Generated\Text Documents sub-folder.
  2. If the option to Use separate folder for each output type is enabled (also on the Options tab), output will be written into a further sub-folder, named Reports (e.g. Project Outputs for <ProjectName>\Reports). In the Projects panel, output will appear under the Generated (Reports)\Text Documents sub-folder.


Applied Parameters: ObjectKind=Fabrication|Index=n (where n is in the range 1 to 20)

Summary

This command is used to generate the indicated fabrication output directly from the active PCB document.

Access

The related indexed commands are accessed from the PCB Editor, from the File » Fabrication Outputs sub-menu.

Access to the IPC-2581 fabrication output command requires installation of the IPC2581 extension. Extensions can be found on the Purchased tab of the Extensions & Updates view (DXP » Extensions and Updates). You will need to restart Altium NEXUS after installation of an extension, for the changes to take effect.

Use

First, ensure that the PCB document that you wish to generate fabrication output from, is the active document in the main design window.

After launching the command, the output will either be generated directly, or an intermediate dialog will appear, from where you can set up related output options as required.

Fabrication outputs that can be generated using the respective command entry are:

  • Report Board Stack - produces a Board Stack Report in Excel format (<PCBDocumentName>.xls), summarizing the defined layer stacks and the layers used in the stackup (in terms of layer name, material, thickness, and dielectric constant). The height of each stack is also summarized. Running this command will access the Layer Stack Report Setup dialog, with which to configure the measurement units for the report.
  • Composite Drill Guide - produces a predefined composite drill drawing for the source PCB document.
  • Drill Drawings - produces a predefined set of drill drawings and guides for the source PCB document.
  • Final - produces a complete, predefined final artwork print-set for the source PCB document.
  • Gerber Files - produces Gerber-format output suitable for a photoplotter that drafts images onto film. These films are then used to fabricate the individual layers of the physical PCB. Running this command will access the Gerber Setup dialog, with which to configure the required output.
  • Gerber X2 Files - produces Gerber X2-format output. Gerber X2 is a direct, and much advanced evolution of the existing Gerber RS-274X standard, that adds a large range of additional data. This includes critical information such as: Layer stack definitions, Pad and via attributes, and Impedance-controlled tracks. As well as an enriched set of manufacturing data included in the file set, it is backward compatible to the previous standard, providing for a low risk upgrade path. Running this command will access the Gerber X2 Setup dialog, with which to configure the required output.
  • IPC-2581 - produces IPC-2581(Revision A or B)-format output. Related to the existing ODB++ format, IPC-2581 is an open-source standard that offers an XML-based, single file format (<PCBDocumentName>.cvg), that incorporates a rich range of board fabrication data - from layer stackup details though to full pad/routing /component information and the Bill Of Materials (BOM). Running this command will access the IPC-2581 Configuration dialog, with which to configure the required output.
  • Mask Set - produces predefined solder/paste mask drawings for the source PCB document.
  • NC Drill Files - produces drill files which are used during the board fabrication process to drill holes through the PCB. Running this command will access the NC Drill Setup dialog, with which to configure the required output.
  • ODB++ Files - produces an ODB++ manufacturing database that offers a more detailed, robust, and simpler method of transferring PCB data from design through to board manufacture. ODB++ is a CAD-to-CAM data exchange format used in the design and manufacture of printed circuit boards. The format was originally developed by Valor Computerized Systems, Ltd, as an open database that could provide a more information-rich data exchange between PCB design software and Valor CAD-CAM software used by PCB fabricators. Running this command will access the ODB++ Setup dialog, with which to configure the required output.
  • Power-Plane Set - produces predefined power-plane drawings for the source PCB document.
  • Test Point Report - produces a report (in txt and/or csv and/or IPC-D-356A formats) of all pads and vias that are setup for use as fabrication testpoints. Fabrication testing relates to the testing of a printed circuit board at the pre-assembly phase of manufacture, before any components have been placed onto the board. As such, it is often referred to as bare-board testing. This method of testing might typically involve the use of a flying probe device to perform net-by-net testing. Essentially, two probes are programmed to operate in concert, one to pulse a signal through a net and the other to detect the presence (or absence) of that signal. Running this command will access the Fabrication Testpoint Setup dialog, with which to configure the required output.
For the print-based fabrication outputs, running them will give access to the Print Preview dialog, with the printouts loaded. Use this dialog to view the printouts and edit their setup definitions if required, before actually printing. You can also export the current preview as Windows Enhanced Metafiles (*.EMF), using vector objects to render the images in the EMF files.

Tips

  1. The generated files will be written to the output folder specified in the Output Path field, on the Options tab of the Options for Project dialog. By default, the output path is set to a sub-folder of the folder that contains the project file, and has the name Project Outputs for <ProjectName>. The output path can be changed as required. In the Projects panel, the generated files will be presented under the Generated\Text Documents or Generated\CAMtastic! Documents sub-folder, as applicable. Note that the Board Stack Report will not be added to the Projects panel.
  2. If the option to Use separate folder for each output type is enabled (also on the Options tab), output will be written into a further sub-folder:
    1. Gerber/Gerber X2 - the folder will be named Gerber Output (e.g. Project Outputs for <ProjectName>\Gerber Output). In the Projects panel, output will appear under the Generated (Gerber Output) sub-folder.
    2. IPC-2581 - the folder will be named IPC2581 (e.g. Project Outputs for <ProjectName>\IPC2581). In the Projects panel, output will appear under the Generated (IPC2581) sub-folder.
    3. ODB++ - the folder will be named ODB Output (e.g. Project Outputs for <ProjectName>\ODB Output). In the Projects panel, output will appear under the Generated (ODB Output) sub-folder.
    4. NC Drill - the folder will be named NC Drill Output (e.g. Project Outputs for <ProjectName>\NC Drill Output). In the Projects panel, output will appear under the Generated (NC Drill Output) sub-folder.
    5. Test Point - the folder will be named Test Point Output (e.g. Project Outputs for <ProjectName>\Test Point Output). In the Projects panel, output will appear under the Generated (Test Point Output) sub-folder.
  3. When generating Gerber, Gerber X2, ODB++, NC Drill, or Testpoint Report (IPC-D-356A format) output, you can specify that the output be opened automatically in a new CAM document. This is done simply by enabling the Open outputs after compile option, on the Options tab of the Options for Project dialog.
  4. Fabrication output can also be generated from an Output Job Configuration file (*.OutJob). For more detail, see Preparing Multiple Outputs in an Output Job.
  5. The settings defined in the setup dialogs when generating output directly from the PCB are distinct and separate to those defined for the same output type in an Output Job Configuration file. In the case of the former, the settings are stored in the project file, whereas for the latter, they are stored in the OutJob file.


Applied Parameters: ObjectKind=Assembly|Index=n (where n is in the range 1 to 20)

Summary

This command is used to generate the indicated assembly output directly from the active PCB document.

Access

The related indexed commands are accessed from the PCB Editor, from the File » Assembly Outputs sub-menu.

Use

First, ensure that the PCB document that you wish to generate assembly output from, is the active document in the main design window.

After launching the command, the output will either be generated directly, or an intermediate dialog will appear, from where you can set up related output options as required.

Assembly outputs that can be generated using the respective command entry are:

  • Assembly Drawings - produces predefined assembly drawings for the source PCB document. Running this command will give access to the Print Preview dialog, with the printouts loaded. Use this dialog to view the printouts and edit their setup definitions if required, before actually printing. You can also export the current preview as Windows Enhanced Metafiles (*.EMF), using vector objects to render the images in the EMF files.
  • Pick and Place Files - produces a report that details the location, rotation and side of board for each component on the board. The report can be generated in either CSV or text format. All components that have a component type of Standard are included in the report. Components whose type is set to any other value, such as Graphical, are not included. Running this command will access the Pick and Place Setup dialog, with which to configure the required output.
  • Test Point Report - produces a report (in txt and/or csv and/or IPC-D-356A formats) of all pads and vias that are setup for use as fabrication testpoints. Assembly testing relates to the testing of a printed circuit board at the post-assembly phase of manufacture, after the board has been populated with all components specified in its associated Bill of Materials (BOM). As such, it is often referred to as in-circuit or electrical testing. This method of testing typically involves (but is in no way limited to!) the use of a manually-configured bed-of-nails fixture. Depending on the type of testing being performed using the fixture, the board may or may not be powered up. Running this command will access the Assembly Testpoint Setup dialog, with which to configure the required output.

Tips

  1. The structure of the Pick and Place report cannot be changed. If you require a pick and place report in a different format, use Altium NEXUS’s configurable report generation engine - the Report Manager dialog.
  2. The generated files will be written to the output folder specified in the Output Path field, on the Options tab of the Options for Project dialog. By default, the output path is set to a sub-folder of the folder that contains the project file, and has the name Project Outputs for <ProjectName>. The output path can be changed as required. In the Projects panel, the generated files will be presented under the Generated\Text Documents or Generated\CAMtastic! Documents sub-folder, as applicable.
  3. If the option to Use separate folder for each output type is enabled (also on the Options tab), output will be written into a further sub-folder:
    1. Pick and Place - the folder will be named Pick Place Output (e.g. Project Outputs for <ProjectName>\Pick Place Output). In the Projects panel, output will appear under the Generated (Pick Place Output) sub-folder.
    2. Test Point - the folder will be named Test Point Output (e.g. Project Outputs for <ProjectName>\Test Point Output). In the Projects panel, output will appear under the Generated (Test Point Output) sub-folder.
  4. When generating Testpoint Report (IPC-D-356A format) output, you can specify that the output be opened automatically in a new CAM document. This is done simply by enabling the Open outputs after compile option, on the Options tab of the Options for Project dialog.
  5. Assembly output can also be generated from an Output Job Configuration file (*.OutJob). For more detail, see Preparing Multiple Outputs in an Output Job.
  6. The settings defined in the setup dialogs when generating output directly from the PCB are distinct and separate to those defined for the same output type in an Output Job Configuration file. In the case of the former, the settings are stored in the project file, whereas for the latter, they are stored in the OutJob file.


Applied Parameters: Action=Run|ObjectKind=OutputBatch|ExtraAction=GeneratedFilesSetup|ObjectKind=OutputMedium

Summary

This command is used to configure the properties of the currently selected Folder Structure output container, in the active Output Job Configuration file.

Access

With the required Folder Structure output container selected, this command is accessed from the OutputJob Editor by right-clicking in the Output Containers region (over the selected container) and choosing the Properties command, from the context menu.

Use

First, ensure that the Folder Structure container that you wish to configure is selected, in the Output Containers region of the main job configuration window.

After launching the command, the Folder Structure settings dialog will appear. Use the dialog to manage and configure the properties of the selected Folder Structure output container, which will be applied when generating output from its linked output generators.

Tips

  1. The Folder Structure settings dialog can also be accessed by clicking on the Change link, at the top-right of the container's entry in the region.


Applied Parameters: Action=Run|ObjectKind=OutputBatch

Summary

This command is used to generate the outputs that are enabled, and linked to, the selected Folder Structure output container, in the active Output Job Configuration file.

Access

With the required Folder Structure output container selected, and at least one output linked and enabled, this command can be accessed from the OutputJob Editor by:

  • Choosing the Tools » Run command, from the main menus.
  • Clicking the  button on the Job Manager Toolbar toolbar.
  • Using the F9 keyboard shortcut.
  • Right-clicking on the entry for the Folder Structure container, and choosing the Run command from the context menu.

Use

First, ensure that the Folder Structure container whose linked (and enabled) outputs you wish to generate, is selected in the Output Containers region of the main job configuration window.

After launching the command, each of the outputs that are linked to the selected Folder Structure output container, and that are enabled for generation, will be generated. The process of generation proceeds in batch-fashion, and in sequence according to the numbering of the enabled outputs. The output that is currently being generated is distinguished by its number text (in the Enabled field) changing temporarily from black to white.

Generated output will be written to the location defined as part of the settings for the output container. These settings will also control whether the output is opened and/or added to the Projects panel.

Tips

  1. The batch output generation process can also be invoked by clicking on the Generate Content link, at the right of the container's entry in the region.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.