Integración con PLM
La solución de diseño combinada de Altium Designer y un Workspace de Altium 365 ofrece una integración con PLM configurable con soporte disponible para Windchill®, Arena®, Oracle® Agile™, Aras Innovator®, y Siemens Teamcenter® (con configuración adicional). La configuración de la integración con PLM se realiza a través de la interfaz del navegador del Workspace de Altium 365, que proporciona una interfaz automatizada para configurar fácilmente la interconexión, mapear datos de parámetros y especificar la dirección de la sincronización de datos. Una vez configurada la interfaz, las características y funcionalidades de integración con PLM están disponibles al trabajar en las siguientes áreas diferenciadas:
-
Library (componentes) – permite la sincronización unidireccional o bidireccional de sus componentes, parámetros de componentes y selecciones de piezas entre su Workspace de Altium 365 y su instancia de PLM. La configuración le permite especificar qué parámetros se gestionan principalmente en cada sistema. Además, los parámetros de ítems le permiten actualizar propiedades del lado del Workspace (configurable por campo), sin necesidad de liberar formalmente una nueva revisión de ese Component Item. También está disponible un flujo de trabajo específico de solicitud de pieza que admite la creación automática de un componente en su instancia de PLM, así como la propagación de los números de pieza PLM generados de vuelta a los componentes del lado del Workspace.
-
Design (proyectos) – también está disponible un flujo de trabajo específico de creación de proyectos que admite la creación automática de números de pieza en su instancia de PLM y luego la propagación de estos parámetros de vuelta al proyecto de diseño. Dichos parámetros pueden utilizarse en cadenas especiales (por ejemplo, para anotaciones en el marco de la hoja). Tiene la capacidad de publicar su diseño en su instancia de PLM como parte de la ejecución de Project Releaser en Altium Designer. La operación de publicación utiliza una plantilla de publicación —definida como parte de la configuración de integración de la instancia de PLM— para controlar cómo deben propagarse los datos al PLM. Y si está publicando por primera vez y los números de pieza (en el lado del PLM) aún no están asociados con el proyecto, esos números de pieza se crearán en el PLM y se asociarán con el proyecto como parte de esa publicación inicial. También tiene la capacidad de definir entradas de componentes para componentes en la instancia de PLM como parte de la operación de publicación (opcional, según la configuración). Y siempre podrá ver exactamente qué se ha creado, como los números de pieza en la instancia de PLM, como parte del historial del flujo de trabajo del proceso (History pestaña).
Compatibilidad con PLM
El Workspace de Altium 365 ofrece compatibilidad con los siguientes sistemas PLM:
-
PTC Windchill® PLM versión 12, 13 y PTC Windchill+ (la variante SaaS de Windchill).
-
Arena® PLM.
-
Oracle® Agile™ PLM.
-
Aras Innovator® Release 30.
Additional Setup for Aras Innovator
Para lograr la integración con PLM mediante Aras Innovator, el servidor de su Altium Workspace debe registrarse en la configuración de autenticación de Aras añadiendo una nueva sección de nodo a su registro de cliente. Una vez registrado, se concede un token OAuth único para que su Workspace conectado autentique el acceso.
Los cambios necesarios en la configuración de Aras Innovator se realizan editando su archivo de registro de cliente OAuth:
-
En la máquina host de Aras, abra el archivo
\OAuthServer\OAuth.configpara editarlo. -
Localice y copie la sección IOMApp, desde la línea
<clientRegistry id="IOMApp" enabled="true">hasta la línea</clientRegistry>. -
Pegue la sección IOMApp copiada inmediatamente después para crear una nueva sección (duplicada).
-
En esta nueva sección de nodo, cambie el nombre de
IOMAppaNEXUS, dando como resultado<clientRegistry id="NEXUS" enabled="true">.
-
Guarde y luego reinicie la máquina de Aras.
- Siemens Teamcenter®, con configuración de integración adicional.
- Duro PLM, implementado como una instancia de PLM de terceros; vea Compatibilidad con PLM de terceros más abajo.
Elección de la interfaz de configuración de PLM
La conexión del Workspace de Altium 365 a un sistema PLM compatible puede establecerse a través de una interfaz de usuario avanzada semiautomatizada, como se detalla a continuación, o mediante un proceso manual basado en la edición de archivos XML de configuración de PLM. Este último requiere conocimiento de las estructuras de datos del sistema PLM de destino y familiaridad con el formato XML, mientras que el sistema actualizado presentado a continuación extrae automáticamente los datos necesarios del PLM y del Altium Workspace para rellenar las opciones de menú en la interfaz.
Puede reconfigurar el Workplace para presentar la interfaz PLM anterior, basada en la edición manual de archivos XML, desmarcando la opción Enable new PLM Configuration page en la página Admin – Settings – PLM Integration de la interfaz del Workspace. Asegúrese de guardar el cambio y luego cerrar sesión y volver a iniciarla.
Conexión a su instancia de PLM
Las configuraciones de PLM se crean y administran en la página Admin – PLM Integration de la interfaz del navegador del Workspace. Cuando se haya conectado correctamente al sistema PLM, la interfaz de configuración proporcionará una gama de opciones de integración basadas en datos obtenidos tanto del Workspace como del PLM conectado.
Use el botón
para iniciar el proceso de conexión y continúe como se describe en la presentación de diapositivas a continuación.
Cualquier error de conectividad se resaltará en rojo al iniciar sesión en el sistema PLM de destino. El borde inferior del cuadro resaltado incluirá los detalles del error: ver ejemplo.
PTC Windchill SSO Support
La posibilidad de utilizar autorización de inicio de sesión único (SSO) al conectarse a un sistema Windchill PLM está disponible y se configura a través de la interfaz del Workspace. Esto proporciona un método simplificado y seguro de autorización de conexión al ejecutar procesos PLM del Workspace, como Project Creation y Publish to PLM. En la práctica, esta disposición permite conceder acceso a Windchill utilizando el estándar de delegación OAuth a través de un servicio de proveedor de identidad como PingFederate.
El acceso a la configuración de SSO está disponible en la pestaña OAuth de la página PLM Integration del Workspace (Admin - PLM Integration), donde pueden añadirse múltiples instancias de proveedor OAuth.
La configuración de autorización del proveedor OAuth se completa con los datos disponibles de su proveedor de identidad configurado. Introduzca un nombre y la información requerida por el Workspace —ID, tokens, URL, etc.— en los campos de la página y luego guarde la configuración completada.
La nueva instancia del proveedor OAuth pasa a estar disponible cuando la opción OAuth Connection está habilitada en una configuración Windchill PLM. Seleccione en la lista desplegable OAuth Provider cuando haya varios proveedores disponibles. Complete la configuración de la conexión con el botón
y siga las indicaciones del proveedor si es necesario.
Compatibilidad con PLM de terceros
El Workspace de Altium 365 ofrece compatibilidad adicional para configuraciones de sistemas PLM “no nativos” desarrolladas por terceros. Esta compatibilidad está habilitada por el Generic Connector de Altium, que requiere la licencia Altium 365 PLM Generic Connector Addon.
Al añadir una instancia PLM del Workspace para uno de estos sistemas, los archivos XML preconfigurados proporcionados por el tercero se cargan en la configuración de esa instancia PLM a través de la interfaz de integración PLM.
Configuración
Después de una conexión correcta a una instancia de PLM, la interfaz PLM del Workspace ofrece ajustes de configuración para definir cómo se realiza la sincronización de componentes, el mapeo cruzado de parámetros de componentes y el método de transferencia utilizado para los datos de Part Choices. Estas opciones de sincronización están disponibles en la pestaña Configuration de la interfaz.
Las opciones de ajuste de configuración disponibles para usted (y sus etiquetas/funcionalidad) están determinadas por el tipo de sistema PLM y por los datos paramétricos obtenidos tanto del Workspace como de la instancia PLM conectada.
Parámetros de sincronización
Esta sección de la interfaz PLM define qué tipos de componentes se sincronizarán, dónde y cómo se crearán/actualizarán los componentes nuevos y cualquier restricción basada en criterios de parámetros.
La forma en que se sincronizan los componentes se especifica individualmente:
- Seleccione un Altium Component Type en la lista de parámetros y establezca su opción Sync Direction según sea necesario (a Altium/PLM o a ambos); las opciones de tipo de componente se obtienen de los datos actuales de componentes del Workspace.
- Elija un nombre de atributo PLM relacionado en el menú PLM Type; las opciones disponibles se obtienen de la instancia PLM conectada.
- En el campo Altium Target Folder (debajo de Sync to Altium) navegue hasta una carpeta de componentes del Workspace y selecciónela como ubicación de sincronización para este componente.
- Especifique un Sync Mode para determinar si se crearán nuevos componentes durante la sincronización, o si solo se actualizarán los componentes existentes, o ambas cosas.
-
Establezca el Component Template que se utilizará para definir los tipos de parámetros del componente al sincronizar este componente. Este ajuste tomará por defecto el valor del Altium Component Type seleccionado (por ejemplo;
Capacitors) si hay una plantilla de Workspace asociada disponible. - Use la opción Add Parameter Criteria para especificar un valor de parámetro por el que la sincronización estará restringida. Un componente no se sincronizará a menos que cumpla este criterio. Añada más criterios de parámetros según sea necesario.
Hay opciones adicionales disponibles cuando está conectado a un sistema PTC Windchill PLM que admite el sistema PartsLInk de Windchill. El sistema PartsLink permite clasificar piezas en grupos para una selección más cómoda y rápida, y puede incluir pares asociados de Atributo/Valor para proporcionar una definición adicional dentro de esa clasificación. Consulte la sección desplegable a continuación para obtener más información.
-
Seleccione el Add Classification Name Criteria en el menú Filter Criteria para añadir un filtro de clasificación. Use el menú de nombre para elegir un grupo de clasificación por el que se filtrará la sincronización.
-
Para un control más preciso, seleccione la opción Add Classification Attribute Criteria y especifique el Attribute de una clasificación y su valor asociado. En el ejemplo que se muestra aquí, solo los condensadores de la clase
102-Capacitorscon un valorCapacitancede10uFse sincronizarán.
More on Windchill PartsLink
Dentro de Windchill, una clasificación PartsLink se define creando un binding attribute que puede aplicarse a un tipo de pieza. Luego se añade un atributo de clasificación de pieza a una clase de clasificación definida.
Las entradas de componentes en Windchill incorporarán su clasificación definida y cualquier parámetro de atributo de clasificación especificado, que a su vez estarán disponibles para el proceso de sincronización de componentes PLM del Workspace.
Cuando una entrada de componente se sincroniza desde Windchill al Workspace y se ha especificado la interacción con PartsLink en la configuración PLM del Workspace, los atributos de configuración de Windchill para esa pieza se propagarán a Altium Designer.
Cuando Sync Direction se establece como To PLM o para sincronización bidireccional (To PLM & To Altium), se presenta una opción Add Filter Criteria bajo Sync To PLM. Use esta opción para establecer criterios de parámetro o carpeta que controlarán qué componentes del Workspace se propagan al sistema PLM.
Pueden añadirse múltiples criterios de parámetro para restringir estrechamente la sincronización de componentes del Workspace hacia PLM. Los criterios disponibles también incluyen las opciones de cláusula OR y NOT para establecer un control más preciso sobre el filtrado de componentes aceptados para la sincronización con PLM.
La sección Sync to PLM ofrece opciones adicionales de numeración de piezas y de prefijo/sufijo al dirigirse a un sistema Arena PLM. Estos esquemas PLM predefinidos están disponibles para su selección en los menús Numbering Scheme y Code, y determinarán el formato de Item Number de las piezas cargadas en Arena.
Mapeo de parámetros de componentes
Continúe el mismo proceso anterior para especificar la configuración de parámetros de sincronización para todos los componentes que desee sincronizar con PLM. Dado que los parámetros de componentes del lado del Workspace no necesariamente coinciden con los del lado del PLM, la sección de la interfaz Component Parameter Mapping puede utilizarse para mapear parámetros entre ambos. Tenga en cuenta que cuando los parámetros se mapean, su valor se sincronizará de uno a otro como si fueran el mismo parámetro.
Use el comando Add Parameter de la sección para crear una entrada para mapear un parámetro Workspace/PLM que se aplique al Altium Component Type actualmente seleccionado (según lo seleccionado en Sync Parameters). Las opciones Parameter Name de PLM y Altium son las disponibles en los respectivos sistemas. Un ajuste Revision en la columna Item/Revision hace que se cree una nueva revisión del componente cuando el parámetro ha cambiado, mientras que con el ajuste Item solo se actualizará el parámetro del componente durante la sincronización.
Use el icono
asociado para eliminar una entrada de mapeo.
Puede mapearse cualquier cantidad de parámetros de esta manera; sin embargo, es probable que haya una serie de parámetros comunes Workspace/PLM que deban mapearse para todos los componentes. Este enfoque de mapeo global está disponible cuando se selecciona All Types como Altium Component Type.
Cree entradas de mapeo (Add Parameter) que se aplicarán a todos los componentes incluyendo coincidencias de parámetros comunes conocidas, y establezca las opciones Item/Revision y Sync Direction según sea necesario. También es importante especificar una entrada de parámetro mapeado como Primary Key; se trata de un par de parámetros común que sirve como índice de referencia entre los dos conjuntos de datos paramétricos. Cuando este es un número de pieza PLM (recomendado), el número creado en el lado del PLM se propaga de vuelta al lado de Altium, creando un vínculo de referencia conocido entre los conjuntos de datos de componentes sincronizados.
Atributos de clasificación PLM
En los sistemas PLM conectados que admiten agrupación de componentes como Classifications (como PTC Windchill), los atributos y valores PLM relacionados pueden mapearse a parámetros de componentes del Workspace en esta sección.
Por ejemplo, en PTC Windchill, para extraer un valor específico de atributo de clasificación (por ejemplo, el valor de capacitancia para condensadores en la clase 102-Capacitor), añada esa clasificación y su valor (Capacitance) como PLM Parameter Name y el parámetro de componente Altium de destino (Value) como Altium Parameter Name. Pueden añadirse definiciones para todos los tipos de componentes, incluidas múltiples definiciones para el mismo tipo de componente.
► Consulte la información anterior sobre PartsLink para obtener más información sobre las clasificaciones de Windchill.
Part Choices
Use el menú desplegable Sync Direction para especificar en qué dirección se sincronizarán los datos de Part Choices del fabricante entre el Workspace y el sistema PLM, o desactive la sincronización de Part Choices con la opción OFF.
Según el tipo de PLM conectado, la opción Part Choice information ofrecerá sincronización en un formato compatible con las piezas de fabricación aprobadas propias del PLM (Native PLM Manufacturer Parts) o como datos convencionales de parámetros de componente (PLM Part Attributes). Estos últimos pueden ser múltiples conjuntos de atributos de parámetro Manufacturer:PartNumber; MFR1:MPN1, MFR2:MPN2, por ejemplo.
Ejemplos de piezas de fabricante PLM “nativas” (o integradas) incluyen Vendor Parts en Arena y Manufacturer Parts en Windchill.
XML de configuración del proyecto
Esta sección proporciona un listado de la configuración XML base que define la configuración PLM inicial para el sistema PLM conectado. La versión descargada de este XML base de configuración (Download Sample Configuration) incluye comentarios detallados que destacan la función de la mayoría de las secciones de entidad y atributo.
En última instancia, la configuración que defina en la interfaz de integración PLM se almacena como archivos XML del sistema, que pueden guardarse localmente desde el comando Export Configuration asociado con los detalles de Server Connection en la parte superior de la página de configuración.
También se incluye una opción Import Configuration. Esto le permite aplicar un archivo XML de configuración existente a una configuración PLM nueva (o editada), lo que duplicará dicha configuración PLM. Además, en caso de que sea necesario realizar cambios especializados en una configuración PLM existente, su archivo XML exportado se editaría manualmente y luego se importaría de nuevo a la configuración. Tenga en cuenta que los parámetros, atributos y valores incluidos en un archivo de configuración distinguen entre mayúsculas y minúsculas.
Adición de plantilla de publicación
La configuración de PLM requiere la incorporación de un Publishing Template basado en XML para admitir procesos del Workspace que envían datos completos del proyecto —archivos de diseño, datos de componentes y datos de salida de fabricación— al sistema PLM en una sola acción de “publicación”. Estos procesos incluyen Publish to PLM, donde el usuario especifica los datos de salida que se enviarán, y Project Releaser with Publish, que envía los datos generados al PLM como paso final del Project Release process de Altium Designer.
Agregue un archivo XML de plantilla de publicación adecuado en la pestaña Publish Template al crear o editar la configuración de su PLM. Use el enlace Sample Project Configurations para descargar una colección archivada de plantillas para los sistemas PLM compatibles.
Un Publishing Template incluye referencias para detalles del proyecto, transferencia de datos de componentes, ubicaciones de fuentes de datos y distribuciones de archivos de datos de Diseño, Ensamblaje y Fabricación. Los ejemplos descargados incluyen plantillas para todos los PLM compatibles; cada una incluirá cualquier regla de publicación adicional que corresponda a ese tipo específico de PLM, así como comentarios detallados para orientarlo sobre qué configurar y cómo hacerlo.
Publishing Folder Support for Windchill PLM
Al configurar una instancia de integración de Windchill® PLM Integration que se utilizará para procesos de Publish to PLM processes, también puede especificar (y crear) una carpeta de destino en Windchill para los documentos publicados desde el Workspace.
Los parámetros relacionados con la carpeta de Windchill se definen en el archivo XML de la plantilla de publicación que se aplica a la entrada de integración de Windchill PLM en el Workspace (consulte arriba). Los nodos de definición de carpeta usan el formato de etiqueta <pt:Folder>xxx</pt:Folder> – donde pt es el espacio de nombres actual y xxx es la ruta completa de la carpeta – y se colocan como una regla de publicación dentro de la sección FileDistribution para cada tipo de documento (como, por ejemplo, una salida de PCB.zip Fabrication).
Un ejemplo de la jerarquía de la estructura XML de publicación sería:
<pt:EntityRule id="FAB">
<pt:FileDistributions>
<pt:FileDistribution archiveName="PCB.zip">
<pt:Folder>PRODUCT/Projects/${project.name}/FAB data</pt:Folder>
La última línea de entrada especificaría (o crearía) una carpeta de destino de publicación para la salida de PCB.zip Fabrication con la estructura de carpetas de Windchill (donde el nombre del proyecto es MyProject):
PRODUCT
Projects
MyProject
FAB data
Tenga en cuenta que la ruta de carpeta definida en el archivo XML de publicación es absoluta (en lugar de relativa), y puede incluir otras propiedades del proyecto, como el nombre del proyecto (${project.name}) y el número de ensamblaje (${project.PLM_ASSEMBLY_NUMBER}).
Publish to PLM with ECO
Los archivos de configuración para las instancias de Windchill, Agile y Arena PLM también admiten el flujo de trabajo formalizado de Change Order (ECO), que se habilita en el archivo XML de la plantilla de publicación y se define en el archivo XML de configuración en la sección de entidad altiumType="ProjectChangeOrder".
Según la instancia de PLM, las definiciones de configuración XML incluyen el esquema para la identificación de la Change Order (numeración, ubicación, ID, etc.), atributos específicos de la Change Order como Nombre/Título, Descripción y Complejidad del cambio (solo Windchill), y configuraciones de opciones como la estrategia de creación de Change Order (ninguna, nueva o reutilizar una existente) y la promoción del estado del ciclo de vida (solo Windchill y Agile). La Change Order definida se habilita durante la publicación mediante la declaración de su referencia publishId en la plantilla de publicación asociada.
La plantilla de publicación también admite conjuntos de reglas que definen cómo y dónde se publican en PLM las salidas de liberación (datos del proyecto, fuente, ensamblaje y fabricación).
Una vez definidas en los archivos XML de Configuración y Plantilla de Publicación del servidor, las Change Orders están disponibles durante los flujos de trabajo de proceso Project Creation y Publishing to PLM invocados desde Altium Designer o a través de la Workspace PLM interface. Durante el flujo se mostrará un formulario de Change Order asociado, donde se especifican las opciones de la Change Order.
El cuadro de diálogo de Altium Designer Change Order Required que muestra el paso inicial de creación del proyecto y el posterior Project Release con ECO habilitado.
En el ejemplo que se muestra aquí, se crea un proyecto en Altium Designer a partir de una plantilla mediante el proceso Create Project with PLM Initialize (hacia Arena PLM), con la opción Create change order (ECO) deshabilitada. Luego, el proyecto se libera mediante el proceso Publish to PLM (User selects) con la opción Create change order habilitada (Yes). En Arena, los elementos se publican posteriormente con respecto a una Change Order (ECO-00042) y su proceso de aprobación inherente.
Descargue un archivo ZIP que contiene los archivos XML de configuración de Arena y XML de plantilla de publicación utilizados en este ejemplo.
Modifique una plantilla XLM de ejemplo según sea necesario y cargue el archivo en la configuración de su PLM mediante la ventana Add Publish Template, abierta desde el botón
. Tenga en cuenta que una configuración de PLM admite múltiples plantillas de publicación.
Sincronización de componentes
La sincronización de datos de componentes entre su Workspace de Altium 365 y el sistema PLM conectado está determinada por el mapeo de parámetros habilitado y la dirección descrita anteriormente, y se llevará a cabo cuando el proceso de sincronización se active manualmente o automáticamente en un momento programado. El proceso de sincronización en sí está controlado por un flujo de trabajo de proceso LibSync integrado.
Dentro de una instancia de configuración de PLM, las opciones de sincronización relacionadas se encuentran en la pestaña Component Synchronization, donde el proceso puede activarse manualmente o programarse. Para esto último, habilite la opción Synchronize on a schedule y seleccione un intervalo de tiempo en el menú desplegable asociado.
Puede usar las opciones del menú
para activar manualmente un proceso LibSync como un evento de sincronización Incremental o Full:
-
Incremental – aplica únicamente aquellos componentes que han sido modificados desde la última vez que se ejecutó la sincronización (es decir, cuya marca de tiempo es posterior a la fecha de la última sincronización), y que cumplen los criterios de sincronización de la configuración. Tenga en cuenta que este es el modo utilizado cuando un evento de sincronización se activa desde el control
en la página principal de integración PLM; véase a continuación.
- Full – este modo fuerza una sincronización completa. Se incluirán todos los componentes que cumplan los criterios de sincronización de la configuración.
Realización de la sincronización de componentes
La sincronización de componentes (biblioteca) puede realizarse como un proceso manual desde una entrada de instancia PLM en la página de integración PLM del Workspace, o como un ciclo automatizado especificado en la configuración de la instancia; consulte arriba. Haga clic en el control
asociado con la instancia PLM para iniciar manualmente el proceso de sincronización, que continuará a través del flujo de trabajo LibSync utilizando la configuración definida en la configuración PLM asociada.
El control Actions cambiará a
, lo que le permitirá detener el proceso de sincronización si es necesario, y la entrada Sync Status indicará que hay un proceso en curso. El estado cambiará a Completed cuando el proceso de sincronización haya finalizado.
Cuando se ejecuta la sincronización de componentes, ya sea manualmente o como un evento programado, el proceso LibSync avanza por su flujo de trabajo predefinido hasta que se completa o encuentra un error. Puede actualizar el navegador (F5) para mostrar el estado actual del proceso de sincronización.
Para acceder a los detalles de un evento de sincronización completado, haga clic en el icono
en la columna Last Sync para descargar el archivo de registro relacionado (ver ejemplo), o seleccione la fecha asociada para abrir la entrada del evento en la pestaña Synchronization Status. Tenga en cuenta que, en esta vista, los eventos de sincronización completados se muestran cuando se selecciona la opción Closed, y cualquier evento en ejecución o suspendido aparece cuando se selecciona el modo de vista Active.
Las subpestañas de la vista Estado proporcionan la siguiente información:
- Diagram – un gráfico que representa el flujo de trabajo del proceso, con resaltado de la posición del paso actual (completado o estado de error/fallo).
- Data – un resumen informativo de la acción del proceso, incluida la correcta ejecución o el fallo de sus pasos y un enlace al informe del proceso registrado – ver ejemplo.
- History – un registro temporal de los principales eventos de sincronización del Workspace, enumerados en secuencia.
Cualquier evento de sincronización que se haya detenido prematuramente, por ejemplo cuando se encontró un error, se mostrará cuando la vista esté en modo Active. Estas entradas pueden eliminarse de la lista con el control Terminate , o, de forma más adecuada, evaluarse y resolverse desde el mosaico de tarea asociado creado en la vista Tasks del Workspace. Tenga en cuenta que un evento de sincronización terminado/resuelto se moverá a la lista Closed de la vista Synchronization Status con un Status indicativo, como Failed.
Acceso a procesos relacionados con PLM
Hay flujos de trabajo de proceso de ejemplo relacionados con un sistema PLM conectado disponibles en las pestañas de temas de proceso de la Workspace Processes page. En general, los ejemplos no pueden utilizarse directamente, sino que deben volver a guardarse con un nombre diferente para activarse.
► Consulte la documentación de Processes & Workflow para obtener más información.
Un administrador del Workspace puede iniciar una nueva instancia de cualquier definición de proceso activada directamente desde la lista de procesos en la página Processes haciendo clic en el control
. Los usuarios del Workspace que no sean administradores también pueden iniciar procesos activos desde el Workspace, como:
-
Un proceso Part Request with PLM desde el botón
en la Part Request page.
-
Un proceso Publish to PLM desde el botón
en las páginas Tasks y Activities de un proyecto abierto.
-
Un proceso Publish to PLM desde el botón
en la página principal Projects page.
-
Un proceso Project with Initialize in PLM desde el botón
en la página principal Projects page, o al Cloning a project desde el menú del botón
.
Sin embargo, en la práctica, los procesos relacionados con PLM suelen invocarse desde Altium Designer durante el diseño y desarrollo del proyecto. Se accede a los procesos relacionados con PLM desde Altium Designer de las siguientes maneras:
-
Part Request with PLM Part Create – Se accede desde los paneles Explorer, Manufacturer Part Search y Components de Altium Designer.
► Consulte Process-based Part Requests para obtener información detallada. -
Publish to PLM (User selects) – Se accede desde el submenú Project » Project Activities del proyecto activo de Altium Designer.
► Consulte Publishing to a PLM – user-selects para obtener información detallada. -
Project Releaser with Publish – Se accede como la etapa final de Project Releaser desde el submenú Project » Project Releaser del proyecto activo de Altium Designer.
► Consulte Design Project Release – publishing to PLM para obtener información detallada. -
Project with initialise in PLM – Se accede al crear un nuevo proyecto de Altium Designer desde el submenú File » New » Project in <Workspace>, o al clonar un proyecto.
► Consulte Publishing to a PLM – initialize in PLM para obtener información detallada.
Flujos de trabajo de procesos
Las siguientes definiciones de proceso (y flujos de trabajo subyacentes) están disponibles a través del Workspace para respaldar la integración con PLM:
-
Part Requests tema de proceso:
- Part Request with PLM Part Create – admite la creación automática de un componente en su instancia de PLM y luego la propagación del número de pieza generado de vuelta al componente del Workspace. El diagrama de flujo de trabajo se muestra a continuación.
Un aspecto importante a tener en cuenta es que, cuando modifique esta definición de ejemplo para crear la suya propia, debe especificar la instancia de PLM en la que se crearán las piezas. Seleccione la entidad Create Part in PLM en el diagrama de flujo de trabajo y elija la instancia de PLM en el menú desplegable asociado al campo PLM Instance. Este menú enumera todas las instancias de PLM definidas actualmente (según se definen en la página PLM Integration de la interfaz).
► Consulte Creating and Managing Processes para obtener más información sobre el trabajo con flujos de trabajo de procesos.
- Project Activities tema de proceso:
- Publish to PLM (User selects) – publicación de salidas liberadas de proyectos gestionados a la instancia de PLM integrada, donde el usuario puede seleccionar exactamente qué salidas se publicarán. El diagrama de flujo de trabajo se muestra a continuación.
- Project Releaser with Publish – publicación en la instancia de PLM integrada como una etapa adicional de Project Releaser. El diagrama de flujo de trabajo se muestra a continuación.
-
Project Creations tema de proceso:
- Project with initialise in PLM – admite la creación automática de números de pieza en su instancia de PLM y luego la propagación de estos como parámetros del proyecto de diseño del Workspace. El diagrama de flujo de trabajo se muestra a continuación.
























. 












