Integrazione PLM
La soluzione di progettazione combinata di Altium Designer e di un Workspace Altium 365 offre un'integrazione PLM configurabile con supporto disponibile per Windchill®, Arena®, Oracle® Agile™, Aras Innovator® e Siemens Teamcenter® (con configurazione aggiuntiva). La configurazione dell'integrazione PLM viene eseguita tramite l'interfaccia del browser del Workspace Altium 365, che fornisce un'interfaccia automatizzata per configurare facilmente l'interconnessione, mappare i dati dei parametri e specificare la direzione della sincronizzazione dei dati. Una volta impostata e configurata l'interfaccia, le caratteristiche e le funzionalità di integrazione PLM sono disponibili quando si lavora nelle seguenti aree distinte:
-
Library (componenti) – per la sincronizzazione uni- o bidirezionale dei componenti, dei parametri dei componenti e delle scelte parte tra il tuo Workspace Altium 365 e la tua istanza PLM. La configurazione consente di specificare quali parametri sono gestiti come master in quale sistema. Inoltre, i parametri dell'elemento consentono di aggiornare le proprietà lato Workspace (configurabili per campo), senza dover rilasciare formalmente una nuova revisione di quell'elemento componente. È disponibile anche un workflow dedicato di richiesta parte che supporta la creazione automatica di un componente nella tua istanza PLM e anche la propagazione dei numeri parte PLM generati ai componenti lato Workspace.
-
Design (progetti) – è disponibile un workflow dedicato di creazione progetto che supporta anche la creazione automatica di numeri parte nella tua istanza PLM, e quindi la propagazione di questi parametri al progetto di progettazione. Tali parametri possono essere utilizzati in stringhe speciali (ad es. per le annotazioni del cartiglio del foglio). Hai la possibilità di pubblicare il tuo progetto nella tua istanza PLM come parte dell'esecuzione di Project Releaser in Altium Designer. L'operazione di pubblicazione utilizza un modello di pubblicazione – definito come parte della configurazione di integrazione dell'istanza PLM – per controllare come i dati devono essere propagati al PLM. E se stai pubblicando per la prima volta e i numeri parte (lato PLM) non sono ancora associati al progetto, tali numeri parte verranno creati nel PLM e associati al progetto come parte di quella pubblicazione iniziale. Hai anche la possibilità di definire voci di componenti per i componenti nell'istanza PLM come parte dell'operazione di pubblicazione (facoltativo, in base alla configurazione). E sarai sempre in grado di vedere esattamente cosa è stato creato, come i numeri parte nell'istanza PLM, come parte della cronologia del workflow del processo (History scheda).
Supporto PLM
Il Workspace Altium 365 fornisce supporto per i seguenti sistemi PLM:
-
PTC Windchill® PLM versione 12, 13 e PTC Windchill+ (la variante SaaS di Windchill).
-
Arena® PLM.
-
Oracle® Agile™ PLM.
-
Aras Innovator® Release 30.
Additional Setup for Aras Innovator
Per ottenere l'integrazione PLM con Aras Innovator, il server del tuo Altium Workspace deve essere registrato nella configurazione di autenticazione Aras aggiungendo una nuova sezione nodo al relativo registro client. Una volta registrato, al Workspace connesso viene concesso un token OAuth univoco per autenticare l'accesso.
Le modifiche richieste alla configurazione di Aras Innovator vengono effettuate modificando il file del registro client OAuth:
-
Sul computer host di Aras, apri il file
\OAuthServer\OAuth.configper modificarlo. -
Individua e copia la sezione IOMApp – dalla riga
<clientRegistry id="IOMApp" enabled="true">alla riga</clientRegistry>. -
Incolla la sezione IOMApp copiata immediatamente dopo per creare una nuova sezione (duplicata).
-
In questa nuova sezione nodo, rinomina
IOMAppinNEXUS– ottenendo<clientRegistry id="NEXUS" enabled="true">.
-
Salva e quindi riavvia il computer Aras.
- Siemens Teamcenter®, con configurazione di integrazione aggiuntiva.
- Duro PLM, implementato come istanza PLM di terze parti – vedi supporto PLM di terze parti di seguito.
Scelta dell'interfaccia di configurazione PLM
La connessione del Workspace Altium 365 a un sistema PLM supportato può essere stabilita tramite un'interfaccia utente avanzata semi-automatizzata, come descritto di seguito, oppure utilizzando un processo manuale basato sulla modifica di file XML di configurazione PLM. Quest'ultimo richiede la conoscenza delle strutture dati del sistema PLM di destinazione e familiarità con il formato XML, mentre il sistema aggiornato presentato di seguito recupera automaticamente i dati necessari dal PLM e da Altium Workspace per popolare le opzioni di menu nell'interfaccia.
Puoi riconfigurare il Workplace per presentare la precedente interfaccia PLM – basata sulla modifica manuale dei file XML – deselezionando l'opzione Enable new PLM Configuration page nella pagina Admin – Settings – PLM Integration dell'interfaccia del Workspace. Assicurati di salvare la modifica, quindi esci e rientra nuovamente.
Connessione alla tua istanza PLM
Le configurazioni PLM vengono create e gestite nella pagina Admin – PLM Integration dell'interfaccia browser del Workspace. Quando la connessione al sistema PLM è stata stabilita correttamente, l'interfaccia di configurazione fornirà una gamma di opzioni di integrazione basate sui dati provenienti sia dal Workspace sia dal PLM connesso.
Utilizza il pulsante
per avviare il processo di connessione e procedi come illustrato nella presentazione qui sotto.
Eventuali errori di connettività saranno evidenziati in rosso durante l'accesso al sistema PLM di destinazione. Il bordo inferiore del riquadro evidenziato includerà i dettagli dell'errore – visualizza esempio.
PTC Windchill SSO Support
È disponibile la possibilità di utilizzare l'autorizzazione Single Sign On (SSO) durante la connessione a un sistema PLM Windchill ed è configurabile tramite l'interfaccia del Workspace. Ciò fornisce un metodo di autorizzazione della connessione semplificato e sicuro durante l'esecuzione dei processi PLM del Workspace come Creazione progetto e Pubblica su PLM. In pratica, questa impostazione consente di concedere l'accesso a Windchill utilizzando lo standard di delega OAuth tramite un servizio di identity provider come PingFederate.
L'accesso alla configurazione SSO è disponibile nella scheda OAuth della pagina PLM Integration del Workspace (Admin - PLM Integration), dove possono essere aggiunte più istanze di provider OAuth.
La configurazione dell'autorizzazione del provider OAuth viene completata con i dati disponibili dal tuo identity provider configurato. Inserisci un nome e le informazioni richieste dal Workspace – ID, token, URL, ecc. – nei campi della pagina, quindi salva la configurazione completata.
La nuova istanza di OAuth Provider diventa disponibile quando l'opzione OAuth Connection è abilitata in una configurazione PLM Windchill. Seleziona dall'elenco a discesa OAuth Provider dove sono disponibili più provider. Completa la configurazione della connessione con il pulsante
e segui, se necessario, le istruzioni del provider.
Supporto PLM di terze parti
Il Workspace Altium 365 fornisce ulteriore supporto per configurazioni di sistemi PLM "non nativi" sviluppate da terze parti. Questo supporto è abilitato da Generic Connector di Altium, che richiede la licenza Altium 365 PLM Generic Connector Addon.
Quando si aggiunge un'istanza PLM del Workspace per un sistema di questo tipo, i file XML preconfigurati forniti dalla terza parte vengono caricati nella configurazione di quell'istanza PLM tramite l'interfaccia PLM Integration.
Impostazione della configurazione
Dopo una connessione riuscita a un'istanza PLM, l'interfaccia PLM del Workspace offre impostazioni di configurazione per definire come viene eseguita la sincronizzazione dei componenti, la mappatura incrociata dei parametri dei componenti e l'approccio di trasferimento utilizzato per i dati delle Part Choices. Queste opzioni di sincronizzazione sono disponibili nella scheda Configuration dell'interfaccia.
Le opzioni di impostazione della configurazione a tua disposizione (e le relative etichette/funzionalità) sono determinate dal tipo di sistema PLM e dai dati parametrici provenienti sia dal Workspace sia dall'istanza PLM connessa.
Sincronizzazione parametri
Questa sezione dell'interfaccia PLM definisce quali tipi di componenti verranno sincronizzati, dove e come devono essere creati/aggiornati i nuovi componenti e gli eventuali vincoli basati su criteri di parametro.
Il modo in cui i componenti vengono sincronizzati è specificato singolarmente:
- Seleziona un Altium Component Type nell'elenco dei parametri e imposta la relativa opzione Sync Direction secondo necessità (verso Altium/PLM o entrambi) – le opzioni del tipo di componente provengono dai dati correnti dei componenti del Workspace.
- Scegli un nome attributo PLM correlato dal menu PLM Type – le opzioni disponibili provengono dall'istanza PLM connessa.
- Nel campo Altium Target Folder (sotto Sync to Altium) cerca e seleziona una cartella componenti del Workspace come posizione di sincronizzazione per questo componente.
- Specifica un Sync Mode per determinare se durante la sincronizzazione verranno creati nuovi componenti, oppure se verranno aggiornati solo quelli esistenti – o entrambi.
-
Imposta il Component Template che verrà utilizzato per definire i tipi di parametro del componente durante la sincronizzazione di questo componente. Questa impostazione sarà predefinita sul Altium Component Type selezionato (ad esempio;
Capacitors) se è disponibile un template Workspace associato. - Usa l'opzione Add Parameter Criteria per specificare un valore di parametro da cui la sincronizzazione sarà vincolata. Un componente non verrà sincronizzato a meno che non soddisfi questo criterio. Aggiungi ulteriori criteri di parametro secondo necessità.
Sono disponibili opzioni aggiuntive quando si è connessi a un PLM PTC Windchill che supporta il sistema PartsLInk di Windchill. Il sistema PartsLink consente di classificare le parti in gruppi per un'individuazione più comoda e rapida e può includere coppie Attributo/Valore associate per fornire un'ulteriore definizione all'interno di tale classificazione. Per ulteriori informazioni, consulta la sezione comprimibile qui sotto.
-
Seleziona il Add Classification Name Criteria dal menu Filter Criteria per aggiungere un filtro di classificazione. Usa il menu del nome per scegliere un gruppo di classificazione in base al quale filtrare la sincronizzazione.
-
Per un controllo più preciso, seleziona l'opzione Add Classification Attribute Criteria e specifica l'Attribute di una classificazione e il relativo Valore associato. Nell'esempio mostrato qui, verranno sincronizzati solo i condensatori della classe
102-Capacitorscon un valoreCapacitancepari a10uF.
More on Windchill PartsLink
All'interno di Windchill stesso, una classificazione PartsLink viene definita creando un binding attribute che può essere applicato a un tipo di parte. Un attributo di classificazione della parte viene quindi aggiunto a una classe di classificazione definita.
Le voci dei componenti in Windchill incorporeranno la classificazione definita e tutti i parametri specificati dell'attributo di classificazione, che a loro volta saranno disponibili per il processo di sincronizzazione dei componenti PLM del Workspace.
Quando una voce componente viene sincronizzata da Windchill al Workspace e l'interazione PartsLink è stata specificata nella configurazione PLM del Workspace, gli attributi di configurazione di Windchill per quella parte verranno propagati ad Altium Designer.
Quando Sync Direction è impostato come To PLM o per la sincronizzazione bidirezionale (To PLM & To Altium) viene presentata un'opzione Add Filter Criteria sotto Sync To PLM. Usa questa opzione per impostare criteri di parametro o cartella che controlleranno quali componenti del Workspace verranno propagati al sistema PLM.
È possibile aggiungere più criteri di parametro per vincolare in modo rigoroso la sincronizzazione dei componenti del Workspace verso il PLM. I criteri disponibili includono anche le opzioni di clausola OR e NOT per stabilire un controllo più preciso del filtraggio dei componenti accettati per la sincronizzazione verso il PLM.
La sezione Sync to PLM fornisce ulteriori opzioni di numerazione parte e di prefisso/suffisso quando si utilizza un sistema PLM Arena. Questi schemi PLM predefiniti sono resi disponibili per la selezione nei menu Numbering Scheme e Code e determineranno il formato dell'Item Number delle parti caricate in Arena.
Mappatura dei parametri del componente
Continua con lo stesso processo descritto sopra per specificare la configurazione dei parametri di sincronizzazione per tutti i componenti che desideri sincronizzare con il PLM. Poiché i parametri dei componenti lato Workspace non corrispondono necessariamente a quelli lato PLM, la sezione dell'interfaccia Component Parameter Mapping può essere utilizzata per mappare i parametri tra i due. Tieni presente che, quando i parametri vengono mappati, il loro valore verrà sincronizzato da uno all'altro come se fossero lo stesso parametro.
Usa il comando Add Parameter della sezione per creare una voce per la mappatura di un parametro Workspace/PLM applicabile al Altium Component Type attualmente selezionato (come selezionato sotto Sync Parameters). Le opzioni Parameter Name PLM e Altium sono quelle disponibili nei rispettivi sistemi. Un'impostazione Revision nella colonna Item/Revision fa sì che venga creata una nuova revisione del componente quando il parametro è cambiato, mentre con l'impostazione Item verrà aggiornato solo il parametro del componente durante la sincronizzazione.
Usa l'icona
associata per rimuovere una voce di mappatura.
È possibile mappare un numero qualsiasi di parametri in questo modo, tuttavia è probabile che esista una gamma di parametri comuni Workspace/PLM che devono essere mappati per tutti i componenti. Questo approccio di mappatura globale è disponibile quando All Types è selezionato come Altium Component Type.
Crea voci di mappatura (Add Parameter) che si applicheranno a tutti i componenti includendo corrispondenze di parametri comuni note, e imposta le opzioni Item/Revision e Sync Direction secondo necessità. È anche importante specificare una voce di parametro mappato come Primary Key – si tratta di una coppia di parametri comune che funge da indice di riferimento tra i due insiemi di dati parametrici. Quando si tratta di un numero parte PLM (consigliato), il numero creato lato PLM viene propagato di nuovo lato Altium creando un collegamento di riferimento noto tra gli insiemi di dati dei componenti sincronizzati.
Attributi di classificazione PLM
Per i sistemi PLM connessi che supportano il raggruppamento dei componenti come Classifications (come PTC Windchill), in questa sezione è possibile mappare ai parametri dei componenti del Workspace i relativi attributi e valori PLM.
Per PTC Windchill, ad esempio, per estrarre un valore specifico di attributo di classificazione (ad esempio, il valore di capacità per i condensatori nella classe 102-Capacitor) aggiungi quella classificazione e il suo valore (Capacitance) come PLM Parameter Name e il parametro del componente Altium di destinazione (Value) come Altium Parameter Name. È possibile aggiungere definizioni per tutti i tipi di componente, comprese più definizioni per lo stesso tipo di componente.
► Vedi le informazioni PartsLink sopra per ulteriori dettagli sulle classificazioni Windchill.
Part Choices
Usa il menu a discesa Sync Direction per specificare in quale direzione i dati delle Part Choices del produttore verranno sincronizzati tra il Workspace e il sistema PLM, oppure disabilita la sincronizzazione delle Part Choices con l'opzione OFF.
A seconda del tipo di PLM connesso, l'opzione Part Choice information offrirà la sincronizzazione in un formato compatibile con le parti di produzione approvate proprie del PLM (Native PLM Manufacturer Parts) oppure come dati convenzionali dei parametri del componente (PLM Part Attributes). Quest'ultimo può comprendere più insiemi di attributi parametro Manufacturer:PartNumber – MFR1:MPN1, MFR2:MPN2, per esempio.
Esempi di parti del produttore PLM "native" (o integrate) includono Vendor Parts in Arena e Manufacturer Parts in Windchill.
XML di configurazione del progetto
Questa sezione fornisce un elenco della configurazione XML di base che definisce la configurazione PLM iniziale per il sistema PLM connesso. La versione scaricata di questo XML di configurazione di base (Download Sample Configuration) include commenti dettagliati che evidenziano la funzione della maggior parte delle sezioni Entity e Attribute.
In definitiva, la configurazione che definisci nell'interfaccia PLM Integration viene memorizzata come file XML di sistema, che possono essere salvati localmente tramite il comando Export Configuration associato ai dettagli Server Connection nella parte superiore della pagina di configurazione.
È inclusa anche un'opzione Import Configuration. Ciò consente di applicare un file XML di configurazione esistente a una nuova configurazione PLM (o a una configurazione modificata), che quindi duplicherà tale impostazione di configurazione PLM. Inoltre, nel caso in cui sia necessario apportare modifiche specializzate a una configurazione PLM esistente, il relativo file XML esportato può essere modificato manualmente e quindi reimportato nella configurazione. Tieni presente che i parametri, gli attributi e i valori inclusi in un file di configurazione fanno distinzione tra maiuscole e minuscole.
Aggiunta del template di pubblicazione
La configurazione PLM richiede l’aggiunta di un file XML-based Publishing Template per supportare i processi del Workspace che inviano al sistema PLM i dati completi del progetto – file di progettazione, dati dei componenti e dati di output di produzione – in un’unica azione di “publish”. Questi processi includono Publish to PLM, in cui l’utente specifica i dati di output da inviare, e Project Releaser with Publish, che invia i dati generati al PLM come passaggio finale del processo di rilascio del progetto di Altium Designer.
Aggiungere un file XML Publishing Template appropriato nella scheda Publish Template durante la creazione o la modifica della configurazione PLM. Utilizzare il collegamento Sample Project Configurations per scaricare una raccolta archiviata di template per i sistemi PLM supportati.
Un Publishing Template include riferimenti ai dettagli del progetto, al trasferimento dei dati dei componenti, alle posizioni delle sorgenti dati e alla distribuzione dei file dei dati di Design, Assembly e Fabrication. Gli esempi scaricati includono template per tutti i PLM supportati; ciascuno include eventuali Publishing Rules aggiuntive applicabili a quello specifico tipo di PLM e commenti dettagliati per guidare l’utente su cosa configurare e come.
Publishing Folder Support for Windchill PLM
Quando si configura un’istanza di integrazione Windchill® PLM che verrà utilizzata per i processi Publish to PLM processes, è anche possibile specificare (e creare) una cartella Windchill di destinazione per i documenti pubblicati dal Workspace.
I parametri correlati della cartella Windchill sono definiti nel file XML Publishing Template applicato alla voce di integrazione Windchill PLM nel Workspace (vedere sopra). I nodi di definizione della cartella sono nel formato tag <pt:Folder>xxx</pt:Folder> – dove pt è il namespace corrente e xxx è il percorso completo della cartella – e vengono inseriti come regola di pubblicazione all’interno della sezione FileDistribution per ciascun tipo di documento (ad esempio, un output PCB.zipFabrication).
Un esempio della gerarchia della struttura XML di pubblicazione sarebbe:
<pt:EntityRule id="FAB">
<pt:FileDistributions>
<pt:FileDistribution archiveName="PCB.zip">
<pt:Folder>PRODUCT/Projects/${project.name}/FAB data</pt:Folder>
L’ultima riga della voce specificherebbe (o creerebbe) una cartella di destinazione per la pubblicazione dell’output PCB.zipFabrication con la struttura di cartelle Windchill (dove il nome del progetto è MyProject):
PRODUCT
Projects
MyProject
FAB data
Si noti che il percorso della cartella definito nel file XML di pubblicazione è assoluto (anziché relativo) e può includere altre proprietà del progetto, come il nome del progetto (${project.name}) e l’Assembly Number (${project.PLM_ASSEMBLY_NUMBER}).
Publish to PLM with ECO
I file di configurazione per le istanze PLM Windchill, Agile e Arena supportano anche il workflow formalizzato Change OrderEngineering Change Order (ECO), che viene abilitato nel file XML Publishing Template e definito nel file XML Configuration nella sezione entità altiumType="ProjectChangeOrder".
A seconda dell’istanza PLM, le definizioni di configurazione XML includono uno schema per l’identificazione del Change Order (numerazione, posizione, ID, ecc.), attributi specifici del Change Order come Name/Title, Description e Change Complexity (solo Windchill), nonché impostazioni opzionali come la strategia di creazione del Change Order (nessuna, nuovo o riutilizza esistente) e la promozione dello stato del Lifecycle (solo Windchill e Agile). Il Change Order definito viene abilitato durante la pubblicazione tramite la dichiarazione del relativo riferimento publishIdChangeOrder nel Publishing Template associato.
Il template di pubblicazione supporta anche insiemi di regole che definiscono come e dove gli output di rilascio (dati di progetto, sorgente, assembly e fabrication) vengono pubblicati nel PLM.
Una volta definiti nei file XML Configuration e Publishing Template del server, i Change Order sono disponibili durante i workflow di processo Project CreationPublish to PLMProject Creation e Publishing to PLMProject Release with PublishPublishing to PLM richiamati da Altium Designer o tramite l’interfaccia PLM del Workspace. Durante il flusso verrà presentato un modulo Change Order associato, nel quale verranno specificate le opzioni del Change Order.
La finestra di dialogo di Altium Designer Change Order Required mostra la fase iniziale di creazione del progetto e il successivo Project Release con ECO abilitato.
Nell’esempio mostrato qui, un progetto viene creato in Altium Designer da un Template utilizzando il processo Create Project with PLM Initialize (verso Arena PLM), con l’opzione Create change orderEngineering Change OrderCreate change order (ECO) disabilitata. Il progetto viene quindi rilasciato utilizzando il processo Publish to PLM (User selects) con l’opzione Create change orderEngineering Change OrderCreate change order abilitata (Yes). Sul lato Arena, gli elementi vengono quindi pubblicati rispetto a un Change Order (ECO-00042) e al relativo processo di approvazione intrinseco.
Scaricare un archivio ZIP contenente i file XML Arena Configuration e Publishing Template XML utilizzati in questo esempio.
Modificare un template XLM di esempio secondo necessità e caricare il file nella configurazione PLM tramite la finestra Add Publish Template, aperta dal pulsante
. Si noti che una configurazione PLM supporta più Publish Template.
Sincronizzazione dei componenti
La sincronizzazione dei dati dei componenti tra il Workspace Altium 365 e il sistema PLM connesso è determinata dalla mappatura dei parametri abilitata e dalla direzione indicate sopra, e avverrà quando il processo di sincronizzazione viene attivato manualmente o automaticamente a un orario pianificato. Il processo di sincronizzazione stesso è gestito da un Workflow di processo LibSyncintegrato.
All’interno di un’istanza di configurazione PLM, le opzioni di sincronizzazione correlate sono accessibili nella scheda Component Synchronization, dove il processo può essere attivato manualmente o impostato su pianificazione. Per quest’ultimo caso, abilitare l’opzione Synchronize on a schedule e selezionare un intervallo di tempo dal menu a discesa associato.
È possibile utilizzare le opzioni del menu
per attivare manualmente un processo LibSyncComponent Sync come evento di sincronizzazione Incrementalincrementale oppure Fullcompleto:
-
Incremental – applica solo i componenti che sono stati modificati dall’ultima esecuzione della sincronizzazione (ovvero, il cui timestamp è successivo alla data dell’ultima sincronizzazione) e che soddisfano i criteri di sincronizzazione della configurazione. Si noti che questa è la modalità utilizzata quando un evento di sincronizzazione viene attivato dal controllo
nella pagina principale di PLM Integration – vedere sotto.
- Full – questa modalità forza una sincronizzazione completa. Verranno inclusi tutti i componenti che soddisfano i criteri di sincronizzazione della configurazione.
Esecuzione della sincronizzazione dei componenti
La sincronizzazione dei componenti (libreria) può essere eseguita come processo manuale da una voce di istanza PLM nella pagina PLM Integration del Workspace, oppure come ciclo automatico specificato nella configurazione dell’istanza – vedere sopra. Fare clic sul controllo
associato all’istanza PLM per avviare manualmente il processo di sincronizzazione, che procederà attraverso il workflow LibSyncComponent Sync utilizzando le impostazioni definite nella configurazione PLM associata.
Il controllo Actions cambierà in
, consentendo di interrompere il processo di sincronizzazione se necessario, e la voce Sync Status indicherà che è in corso un processo. Lo Status passerà a Completed quando il processo di sincronizzazione sarà terminato.
Quando viene eseguita la sincronizzazione dei componenti, manualmente o come evento temporizzato, il processo LibSyncComponent Sync attraversa il proprio Workflow predefinito fino al completamento o fino al verificarsi di un errore. È possibile aggiornare il browser (F5) per mostrare lo stato corrente del processo di sincronizzazione.
Per accedere ai dettagli di un evento di sincronizzazione completato, fare clic sull’icona
nella colonna Last Sync per scaricare il file di log correlato (vedi esempio), oppure selezionare la data associata per aprire la voce dell’evento nella scheda Synchronization Status. Si noti che in questa vista gli eventi di sincronizzazione completati vengono elencati quando è selezionata l’opzione Closed, mentre gli eventi in esecuzione o sospesi vengono visualizzati quando è selezionata la modalità di visualizzazione Active.
Le sottoschede della vista Status forniscono le seguenti informazioni:
- Diagram – una rappresentazione grafica del workflow del processo, con evidenziata la posizione del passaggio corrente (completato oppure stato di errore/fallimento).
- Data – un riepilogo informativo dell’azione del processo, inclusi il successo o il fallimento dei relativi passaggi e un collegamento al report di processo registrato – vedi esempio.
- History – un registro temporale dei principali eventi di sincronizzazione del Workspace elencati in sequenza.
Eventuali eventi di sincronizzazione che si sono interrotti prematuramente, ad esempio in caso di errore, verranno elencati quando la vista è in modalità Active. Queste voci possono essere rimosse dall’elenco con il controllo Terminate , oppure, più correttamente, analizzate e risolte dal riquadro Task associato creato nella vista Tasks del Workspace. Si noti che un evento di sincronizzazione terminato/risolto verrà spostato nell’elenco Closed della vista Synchronization Status con un Status indicativo, come Failed.
Accesso ai processi correlati al PLM
I workflow di processo di esempio relativi a un sistema PLM connesso sono disponibili nelle schede dei temi di processo nella pagina Workspace Processes. In generale, gli esempi non possono essere utilizzati direttamente, ma devono essere salvati nuovamente con un nome diverso per diventare attivi.
► Vedere la documentazione Processes & Workflow per ulteriori informazioni.
Un amministratore del Workspace può avviare direttamente una nuova istanza di qualsiasi definizione di processo attivata dall’elenco dei processi nella pagina Processes facendo clic sul controllo
. Anche gli utenti del Workspace non amministratori possono avviare Process attivi dal Workspace, ad esempio:
-
Un processo Part Request with PLM dalla pagina
Part Request tramite il pulsante .
-
Un processo Publish to PLM dalle pagine Tasks e Activities di un progetto aperto tramite il pulsante
.
-
Un processo Publish to PLM dalla pagina principale Projects tramite il pulsante
.
-
Un processo Project with Initialize in PLM dalla pagina principale Projects tramite il pulsante
, oppure durante la clonazione di un progetto dal menu del pulsante
.
In pratica, tuttavia, i processi correlati al PLM vengono solitamente richiamati da Altium Designer durante la progettazione e lo sviluppo del progetto. I processi correlati al PLM sono accessibili da Altium Designer nei seguenti modi:
-
Part Request with PLM Part Create – Accessibili dai pannelli Explorer, Manufacturer Part Search e Components di Altium Designer.
► Vedere Process-based Part Requests per informazioni dettagliate. -
Publish to PLM (User selects) – Accessibili dal sottomenu Project » Project Activities per il progetto attivo di Altium Designer.
► Vedere Publishing to a PLM – user-selects per informazioni dettagliate. -
Project Releaser with Publish – Accessibili come fase finale del Project Releaser dal sottomenu Project » Project Releaser per il progetto attivo di Altium Designer.
► Vedere Design Project Release – publishing to PLM per informazioni dettagliate. -
Project with initialise in PLM – Accessibili durante la creazione di un nuovo progetto Altium Designer dal sottomenu File » New » Project in <Workspace>, oppure durante la clonazione di un progetto.
► Vedere Publishing to a PLM – initialize in PLM per informazioni dettagliate.
Workflow di processo
Le seguenti definizioni di processo (e i workflow sottostanti) sono disponibili tramite il Workspace, a supporto dell’integrazione PLM:
-
Part Requests tema di processo:
- Part Request with PLM Part Create – supporta la creazione automatica di un Component nella propria istanza PLM e quindi la propagazione del part number generato al componente del Workspace. Il diagramma del workflow è mostrato di seguito.
Un aspetto importante da notare è che, quando si modifica questa definizione di esempio per crearne una propria, è necessario specificare l’istanza PLM nella quale devono essere creati i part. Selezionare l’entità Create Part in PLM nella rappresentazione del workflow e scegliere l’istanza PLM dal menu a discesa associato al campo PLM Instance. Questo menu elenca tutte le istanze PLM attualmente definite (come definito nella pagina PLM Integration dell’interfaccia).
► Vedere Creating and Managing Processes per ulteriori informazioni sull’uso dei workflow di processo.
- Project Activities tema di processo:
- Publish to PLM (User selects) – pubblicazione degli output rilasciati del progetto gestito nell’istanza PLM integrata, dove l’utente può selezionare esattamente quali output pubblicare. Il diagramma del workflow è mostrato di seguito.
- Project Releaser with Publish – pubblicazione nell’istanza PLM integrata come fase aggiuntiva del Project Releaser. Il diagramma del workflow è mostrato di seguito.
-
Project Creations tema di processo:
- Project with initialise in PLM – supporta la creazione automatica di part number nella propria istanza PLM e quindi la loro propagazione come Parameters del progetto di design del Workspace. Il diagramma del workflow è mostrato di seguito.
























. 












