Altium Designer Documentation

NCドリル出力オプション

Modified by Phil Loughhead on Jun 19, 2017

The NC Drill Setup dialog

Summary

This dialog is used to configure NC Drill file output options.

Access

The NC Drill Setup dialog is accessed in one of the following ways:

  • Using an NC Drill output generator in an OutputJob Configuration file (*.OutJob). The output is generated when the configured output generator is run.
  • In an active PCB document, click File » Fabrication Outputs » NC Drill Files. The output will be generated immediately upon clicking OK in the dialog.
The settings defined in the NC Drill Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an OutputJob Configuration file. In the case of the former, the settings are stored in the project file, whereas for the latter, they are stored in the OutputJob Configuration file.

Options/Controls

Options

  • NC Drill Format - use this region to specify the units and format to be used in the NC Drill output files. 
  • Units
    • Inches - enable this option to use imperial units where all work is done in mils (1/1000 inch).
    • Millimeters - enable this option to use metric units where all work is done in millimeters.
  • Format
    • 2:3 - provides a resolution of 1 mil  (1/1000 inch).
    • 2:4 - provides a resolution of 0.1 mil. 
    • 2:5 - provides a resolution of 0.01 mil. 
If you are using one of the higher resolutions, check that the PCB manufacturer supports that format. The 2:4 and 2:5 formats only need to be chosen if there are holes on a grid finer than 1 mil.
  • Leading/Trailing Zeroes - zero suppression is a technique that reduces the size of the generated data files by removing all zeroes from the start (leading) or end (trailing) of numbers.
    • Keep leading and trailing zeroes - if this option is enabled, all leading and trailing zeroes will appear in the generated NC Drill file.
    • Suppress leading zeroes - if this option is enabled, no leading zeroes will appear in the generated NC Drill file.
    • Suppress trailing zeroes - if this option is enabled, no trailing zeroes will appear in the generated NC Drill file.
  • Coordinate Positions 
    • Reference to absolute origin - use the absolute origin as the reference point.
    • Reference to relative origin - use the relative origin as the reference point.
  • Other​ 
    • Optimize change location commands - check this option to optimize any change location commands.
    • Generate separate NC Drill files for plated & non-plated holes - check this option to create separate drill files for plated and unplated holes.
    • Use drilled slot command (G85) - check this option to use multiple drilled holes to create slots.
    • Generate Board Edge Rout Paths - check this option to create a separate NC Rout file to define the board shape, including board cutouts.
      • Rout Tool Dia - specify the tool size used to rout the board outline. This option is only available when Generate Board Edge Rout Paths is enabled.
    • Generate EIA Binary Drill File (.DRL) - use this option to generate a .DRL file. DRL is a binary format drill file. For a multi-layer PCB that incorporates blind and/or buried vias, a separate drill file for each layer pair is created with a unique file extension.
The NC Drill files should be created with the same format as the Gerber files. For example, if the Gerber files have been configured to use the 2:4 format, then the corresponding NC Drill files should use the same format. If Gerber files have been generated with the coordinate position on the film set to use either the absolute or relative origin, the NC Drill files should ideally be generated using the same origin reference.

Tips

Generated NC Drill Files

Filename Description
FileName.DRL Binary format drill file. For a multi-layer PCB that incorporates blind and/or buried vias, a separate drill file for each layer pair is created with a unique file extension.
FileName.DRR Drill report - detailing the tool assignments, hole sizes, hole count and tool travel.
FileName.TXT ASCII format drill file. For a multi-layer PCB that incorporates blind and/or buried vias, a separate drill file for each layer pair is created with a unique file extension.
FileName-Plated.TXT ASCII format drill file. Specifically for plated holes in a PCB design. A separate file will be created for each hole type - slotted, square or round.
FileName-NonPlated.TXT ASCII format drill file. Specifically for non-plated holes in a PCB design. A separate file will be created for each hole type - slotted, square or round.
FileName-BoardEdgeRout.TXT ASCII format rout file. Specifically for board outline including board cutouts.
FileName.LDP ASCII format drill pair report. Used by the CAM Editor to detect blind and buried vias.

Once generated, the output will be added to the project and appear in the Projects panel under the Generated folder in an appropriately-named sub-folder. If you have used a separate folder for each output type, then corresponding (separate) Generated folders will be added to the Projects panel (e.g., Generated (NC Drill Output)).

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder. The naming and folder structure is defined in the Output Container that the NC Drill File output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name Project Outputs for <ProjectName>. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, the NC Drill files will be written to a further sub-folder named NC Drill Output.

Automatically Opening the Generated Output

When generating NC Drill outputs, you can specify that the output be opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the NC Drill Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。