CoDesigner를 통한 직접적인 ECAD-MCAD 설계

이 CoDesigner 문서를 활용하려면 다음이 필요합니다:

  • 지원되는 Altium 설계 클라이언트:

  • Altium 워크스페이스. 지원되는 워크스페이스는 다음과 같습니다:

    • Altium 365 워크스페이스

    • Altium Enterprise Server 워크스페이스. Note:온프레미스 서버를 사용 중이며 라이선스 관련 기능이 변경된 경우, 서버 브라우저 인터페이스의 Admin – Licenses 페이지에서 라이선스를 삭제한 후 다시 추가하여 라이선스를 갱신하세요.

  • 지원되는 MCAD 설계 소프트웨어와 적합한 버전의 CoDesigner Addin.

동영상으로 학습하는 것을 선호한다면 MCAD CoDesign 사용법 동영상 페이지를 확인해 보세요.

전자 제품 설계 및 개발 분야에서 주목할 만한 발전 중 하나는 제품의 일부가 되는 플라스틱 성형물과 같은 기판에 전자 회로를 직접 인쇄할 수 있다는 점입니다. Altium은 3D 구조에서 직접 레이아웃 및 라우팅을 수행하여 인쇄 전자회로 및 몰드 상호연결 소자(MID)의 설계를 지원하는 기술을 개발하고 있습니다. 현재 CoDesigner는 서로 다른 설계 접근 방식이 필요하기 때문에 ECAD와 MCAD 간 인쇄 전자회로 설계 전송을 지원하지 않습니다. 개발은 계속 진행 중이며, 향후 업데이트에서 지원이 추가될 예정입니다.

CoDesign이란?

전자 설계와 기구 설계 영역을 넘나들며 작업할 때는 고유한 과제에 직면하게 됩니다. ECAD 및 MCAD 도구는 설계 목표가 서로 다르며, 데이터 저장 및 관리 방식도 서로 다른 방향으로 발전해 왔습니다.

하지만 오늘날의 설계에서는 이러한 과제를 해결해야 합니다. 작고 복잡한 제품 인클로저 안에 불규칙한 형태의 인쇄 회로 기판 여러 개를 수용해야 하기 때문입니다. 이러한 제품을 성공적으로 설계하려면 설계자들이 ECAD와 MCAD 영역 간에 설계 변경 사항을 주고받으며 협업할 수 있어야 합니다.

서로 다른 설계 소프트웨어 간에 복잡하고 세밀한 설계 변경 사항을 전달하는 것은 단순히 데이터를 다른 형식으로 저장하는 것 이상의 작업입니다. 전자 설계팀과 기구 설계팀은 독립적으로 작업하며, 설계 프로세스의 어느 시점에서든 변경 사항을 전달할 수 있어야 합니다. 각 팀의 일상적인 설계 작업에 영향을 주지 않으면서 팀 간에 오가는 변경 사항을 어떻게 관리할 수 있을까요? 한 팀이 최신 변경 사항을 수락할 때까지 다른 팀이 작업을 멈추고 기다려야만 양쪽 모두 작업을 진행할 수 있는 상황은 설계팀이 가장 피하고 싶은 일입니다.

CoDesigner는 ECAD와 MCAD 설계 영역 간에 인쇄 회로 기판 설계를 전송하는 인터페이스로, 이러한 협업 설계 과제를 해결합니다.

작동 방식

ECAD 및 MCAD 소프트웨어에 CoDesigner 플러그인을 추가하면 CoDesigner는 Altium 워크스페이스를 통해 설계 변경 사항을 주고받을 수 있습니다. 아래 그림과 같이 워크스페이스는 ECAD와 MCAD 영역을 연결하는 다리 역할을 합니다.

PCB design data can be transferred in both directions between ECAD and MCAD through an Altium Managed Content Server

워크스페이스를 통해 설계 변경 사항을 전달하면 업데이트 프로세스가 stateless 방식으로 이루어진다는 장점이 있습니다. 즉, 각 팀은 상대 팀의 설계 진행 상황을 신경 쓸 필요 없이 독립적으로 작업을 계속할 수 있습니다.

예를 들어 MCAD 설계자가 보드 형상을 정의하면 어셈블리를 워크스페이스로 Push할 수 있습니다. 그러면 ECAD 설계자에게 대기 중인 변경 사항이 있다는 알림이 자동으로 전달됩니다. ECAD 설계자가 Pull을 클릭하면 해당 보드와 워크스페이스의 MCAD 보드 정의가 비교되고, 보드를 워크스페이스 버전과 동기화하는 데 필요한 변경 사항 목록이 생성됩니다. 그런 다음 ECAD 설계자는 원하는 변경 사항을 활성화하고 보드에 Apply할 수 있습니다. 이어서 ECAD 설계자는 레이어 스택에 필요한 다양한 구리 레이어와 기타 제조 레이어를 구성하고 보드 두께를 정의한 다음, 업데이트된 보드를 MCAD 설계자에게 다시 Push하여 배치 위치가 중요한 메카트로닉스 부품을 배치할 준비를 마칠 수 있습니다.

워크스페이스란?

Altium 워크스페이스는 모든 설계 콘텐츠를 호스팅하고 관리하는 전용 서버로, 설계 소프트웨어에 직접 연결됩니다. Altium의 설계 소프트웨어는 워크스페이스와 원활하게 연동되어 무결성을 안전하게 유지하면서 설계 데이터를 관리할 수 있는 효과적인 방법을 제공합니다.

  • Altium 워크스페이스는 구매한 Altium 솔루션에 따라 Altium Develop Workspace 또는 Altium Agile Workspace 라는 이름으로 제공됩니다. 이 문서에서는 두 워크스페이스 유형을 모두 Altium Workspace 또는 이와 유사한 일반 용어로 지칭합니다.

  • Altium 365 플랫폼의 보안, 안정성, 개인정보 보호 및 규정 준수에 대한 최신 정보는 Altium 365 신뢰 센터를 방문하세요.

  • ITAR 및 EAR과 같은 미국 정부 보안 규정을 준수해야 하는 조직을 위해 Altium은 미국에 기반을 둔 Altium 365 GovCloud를 제공합니다. 이 서비스는 AWS GovCloud 리전에서 운영되며 추가적인 데이터 보호 조치를 제공합니다. 자세한 내용은 Altium 365 GovCloud 및 관련 FAQ를 참조하세요.

Altium의 설계 소프트웨어는 다음 워크스페이스에 연결할 수 있습니다:

  • Altium 365 Workspace - Altium 365 클라우드 기반 인프라 플랫폼에서 호스팅되는 워크스페이스입니다. 워크스페이스는 설계, 제조 및 공급 영역을 원활하게 연결하고 이들 간에 데이터를 이동할 수 있는 체계를 제공합니다. 클라우드 기반 Altium 365 플랫폼에서만 이용할 수 있는 다양한 글로벌 공유 및 협업 기능을 활용할 수 있으므로 클라우드 기반 워크스페이스를 권장합니다.
  • Altium On-Prem Enterprise Server Workspace - 설계팀이 클라우드에서 호스팅되는 워크스페이스를 사용할 수 없는 경우, Altium은 현장에 설치하고 사내 IT 부서에서 관리하는 온프레미스 Enterprise Server도 지원합니다.

연결된 워크스페이스를 활용한 설계에 대해 자세히 알아보기

개인 공간이란?

Altium Live에 등록한 모든 설계자는 자신만의 Altium 365 개인 공간도 이용할 수 있습니다. 개인 공간은 무료이며 워크스페이스에서 제공되는 협업 기능 중 일부를 제공합니다. 또한 개인 공간은 Altium CircuitMaker와 Autodesk Fusion 간에 작업하는 설계자를 위한 ECAD-MCAD 전송 인터페이스로도 사용됩니다.

Altium 365 개인 공간

에 대해 자세히 알아보기Altium CircuitMaker와 Autodesk Fusion 간 협업에 대해 자세히 알아보기

CoDesigner가 사용 중인 MCAD 소프트웨어와 호환되는지 궁금하신가요? 지원되는 MCAD 소프트웨어 목록은 Altium MCAD CoDesigner 설치 및 구성 페이지에서 확인하세요.

설계 데이터 전송

워크스페이스의 역할

MCAD CoDesigner는 Altium 워크스페이스를 통해 설계 변경 사항을 푸시하고 풀하여 ECAD와 MCAD 간에 설계를 전송합니다. ECAD에서 푸시를 수행할 때는 PCB 파일을 Altium 워크스페이스로 보내는 것이 아니라, 특수한 ECAD-MCAD 데이터 패키지를 보냅니다. 이 패키지에는 보드 데이터, 레이어 형상, Parasolid 형식의 컴포넌트 3D 모델(MCAD에서 3D 모델의 이름이 지정되는 방식 자세히 알아보기), 그리고 활성화된 경우 구리 형상이 포함됩니다.

ECAD 또는 MCAD에서 푸시를 수행하면 CoDesigner는 먼저 로컬 하위 폴더인 <DesignName>-EDM에 데이터 패키지를 준비합니다. MCAD 측에서는 EDM 폴더가 MCAD 데이터를 저장하는 데도 사용됩니다. 그런 다음 이 데이터 패키지가 Altium 워크스페이스의 Mechatronic 3D Models이라는 특수 폴더로 전송됩니다. 이 폴더는 MCAD CoDesigner에서 ECAD-MCAD 데이터를 저장하는 용도로만 사용됩니다. MCAD CoDesigner를 사용하는 경우 이 폴더를 삭제하거나 이동하지 말고, 전기 및 기계 엔지니어의 액세스를 제한하지 마세요.

메카트로닉스 3D 모델 전송에 대해 자세히 알아보기

ECAD-MCAD 객체 변환

보드 설계가 ECAD와 MCAD 간에 오갈 때 한 설계 공간의 객체는 다른 설계 공간의 동등한 객체로 변환되어야 합니다. 일부 객체는 변환이 간단합니다. 예를 들어 ECAD의 장착 홀은 MCAD의 홀로 변환되고, MCAD의 보드 파트는 ECAD의 보드 형상으로 변환됩니다.

다른 객체의 경우에는 이 과정이 그만큼 직접적이지 않습니다. 예를 들어 ECAD 컴포넌트에는 실크스크린과 Pad(구리 및 솔더 마스크와 같은 레이어별 세부 정보와 홀 포함) 등 제작된 보드의 일부가 되는 풋프린트 요소뿐 아니라, PCB 조립 중 해당 풋프린트에 실장되는 컴포넌트의 3D 모델도 포함됩니다. MCAD에서는 ECAD 컴포넌트의 모든 보드 관련 요소가 MCAD 보드 파트의 일부가 되고, 3D 모델은 MCAD 컴포넌트가 됩니다. 

이러한 객체 변환은 처음에는 혼동을 일으킬 수 있습니다. 예를 들어 MCAD에서 컴포넌트를 이동하면 컴포넌트의 Pad와 홀은 원래 위치에 남습니다. 보드를 ECAD로 다시 푸시한 다음 MCAD로 다시 풀하면 해당 Pad의 위치가 컴포넌트의 새 위치에 맞게 업데이트됩니다.

이해를 돕기 위해 아래의 접을 수 있는 섹션에 각 방향으로 객체가 변환되는 방식을 요약했습니다.

서버에 저장할 때 CoDesigner에서 자동으로 푸시

ECAD에서 Save을 수행하면 설계 파일이 프로젝트의 작업 폴더에 로컬로 저장됩니다. Save to Server을 수행하면 파일이 로컬에 저장된 다음 프로젝트의 워크스페이스 폴더에도 저장됩니다.

이러한 작업은 MCAD CoDesigner에서 Push을 수행하는 것과는 별개입니다. MCAD 푸시와 서버에 저장 작업이 분리되어 있어 혼동이 생길 수 있습니다. 예를 들어 전기 엔지니어는 하루 일과가 끝날 때 서버에 저장 작업을 수행하면 해당 설계 데이터에 액세스해야 하는 다른 모든 사람도 최신 데이터를 바로 사용할 수 있다고 생각할 수 있습니다.

파일 동기화 과정을 간소화하기 위해, 프로젝트를 MCAD로 한 번 이상 가져온 후에는 ECAD에서 프로젝트에 대해 Save to Server을 수행할 때마다 워크스페이스가 자동으로 푸시를 수행합니다.

프로젝트를 서버에 저장하면 MCAD 푸시가 자동으로 수행됩니다.프로젝트를 서버에 저장하면 MCAD 푸시가 자동으로 수행됩니다.

  • 워크스페이스는 MCAD로 처음 가져오기를 수행한 이후부터 자동 푸시를 수행합니다.

  • 현재 자동 푸시는 Altium 365 워크스페이스에서만 활성화됩니다. 온프레미스 Enterprise Server 워크스페이스에 대한 지원은 곧 추가될 예정입니다.

  • 자동 푸시는 PCB, 하네스 및 멀티보드 ECAD 프로젝트에서 지원됩니다. 하네스 프로젝트 지원은 MCAD CoDesigner 3.14에서 추가되었습니다.

MCAD 엔지니어가 가져오기를 수행하면 아래 슬라이드에 표시된 것처럼 마지막 MCAD 푸시가 자동으로 수행되었다는 알림이 표시됩니다.

ECAD에서 프로젝트를 워크스페이스에 저장하면 MCAD로도 자동 푸시됩니다.

푸시 중 경고나 오류가 발생하면 플래그가 표시됩니다.

클릭하면 경고 또는 오류의 세부 정보가 표시됩니다.

 

자동 푸시를 수행할 수 없는 경우 MCAD 엔지니어에게 가져오는 데이터 버전이 최신 버전이 아니라는 경고가 표시됩니다().

다음과 같은 경우에는 자동 푸시가 수행되지 않습니다.

  • The ECAD project has only been saved to the working folder – 프로젝트가 아직 서버에 저장되지 않은 경우. 서버에 저장을 수행한 후 기계 엔지니어가 워크스페이스에서 처음 가져오기를 수행하면 자동 푸시가 시작됩니다.

  • The ECAD project has failed CoDesigner's validation checks – 자동 또는 수동 MCAD 푸시를 수행하려면 먼저 이러한 문제를 해결해야 합니다.

  • There are multiple PCB files in the ECAD project, which have all been Saved to the Server – MCAD CoDesigner가 자동 푸시할 PCB를 판단할 수 없는 경우. ECAD 엔지니어가 올바른 PCB에서 수동 MCAD 푸시를 수행하여 이 문제를 해결해야 합니다.

MCAD CoDesigner의 작업 진행 상황 로그 위치

MCAD CoDesigner는 ECAD 및 MCAD 작업의 모든 측면에 대한 상세 정보를 로그 파일에 기록합니다. 로그 파일은 다음 위치에 있습니다.

C:\Users\<>\AppData\Local\Altium\Altium CoDesigner\

이 위치에서:

  • ECAD 이벤트 기록 위치: AltiumDesignerExtension.log

  • MCAD 이벤트 기록 위치: <McadName>Addin.log

협업 설계 인터페이스

Altium 소프트웨어와 MCAD 소프트웨어는 각각 소프트웨어 내의 패널(탭)을 통해 서로 연결됩니다. Altium 소프트웨어에서는 MCAD CoDesigner 패널이라고 하며, MCAD 소프트웨어에서는 Altium CoDesigner 패널 또는 탭이라고 합니다.

MCAD CoDesigner / Altium CoDesigner Panel

ECAD에서는 MCAD CoDesigner 패널에서 설계 변경 사항을 푸시하고 가져옵니다. 

MCAD에서는 Altium CoDesigner 패널에서 설계 변경 사항을 푸시하고 가져옵니다.

 
  • Altium 설계 소프트웨어에서 MCAD CoDesigner 패널은 설계 변경 사항을 양방향으로 푸시하고 가져오며 메시지를 표시하는 데 사용됩니다.

  • MCAD 소프트웨어에서 Altium CoDesigner 패널은 다음 용도로 사용됩니다.

    • 새 협업 프로젝트 생성

    • 기존 협업 프로젝트 열기

    • 협업 옵션 구성

    • 설계 변경 사항을 양방향으로 푸시 및 가져오기

    • 메시지 표시

MCAD 도구마다 패널(탭)을 활성화하는 방법이 다릅니다. Altium CoDesigner 패널에 액세스하는 방법에 대한 자세한 내용은 Altium MCAD CoDesigner 설치 및 구성 섹션의 해당 페이지에서 확인할 수 있습니다.

CoDesigner Panel에서 작업하기

전반적인 개념은 같지만 Altium CircuitMaker와 Autodesk Fusion의 작업 방식에는 몇 가지 차이점이 있습니다.

CircuitMaker와 Autodesk Fusion 간 협업에 대해 자세히 알아보세요.

CoDesigner 패널에서 제공하는 기능은 ECAD와 MCAD에서 기본적으로 동일합니다. 패널에는 항상 ECAD에서 수행한 마지막 변경 사항과 MCAD에서 수행한 마지막 변경 사항이 표시됩니다.

모든 공동 설계 작업은 CoDesigner 패널을 통해 수행됩니다.모든 공동 설계 작업은 CoDesigner 패널을 통해 수행됩니다.

ECAD의 최신 변경 사항 / MCAD의 최신 변경 사항

  • 이 두 섹션에는 ECAD에서 수행한 마지막 변경 사항과 MCAD에서 수행한 마지막 변경 사항이 표시됩니다.

  • 삼각형 아이콘을 클릭하면 패널이 확장되어 마지막 변경 사항의 세부 정보가 표시됩니다 .

  • 다른 도메인에서 새 변경 사항을 푸시하면 아래와 같이 배너가 자동으로 나타납니다.
    패널에는 다음과 같은 세부 정보가 표시됩니다.

    • 푸시를 수행한 엔지니어의 로그인 이름

    • 푸시할 때 선택적으로 입력한 설명

변경 사항을 푸시하면 새 변경 사항 알림 배너가 나타납니다.변경 사항을 푸시하면 새 변경 사항 알림 배너가 나타납니다.

  • Pull 버튼을 클릭하면 CoDesigner는 현재 열려 있는 설계를 다른 설계 도메인에서 워크스페이스로 마지막으로 푸시한 버전과 비교합니다. 감지된 각 차이점은 아래와 같이 Panel의 Changes 목록에 표시됩니다. 목록에서 변경 사항을 선택하면 가능한 경우 해당 변경 사항의 영향이 보라색으로 강조 표시됩니다.

목록에서 변경 사항을 클릭하면 해당 변경 사항의 영향이 강조 표시됩니다.목록에서 변경 사항을 클릭하면 해당 변경 사항의 영향이 강조 표시됩니다.

  • 적용하지 않으려는 변경 사항의 체크박스를 선택 해제합니다.
  • 적용할 수 없는 변경 사항이 있을 수 있습니다. 이 경우 해당 변경 사항과 체크박스가 회색으로 비활성화됩니다. 이러한 차이점은 변경 사항을 적용한 후에도 남아 있으므로 이를 푸시한 엔지니어와 논의해야 합니다.
  • 준비가 되면 Apply 버튼을 클릭하여 활성화된 모든 변경 사항을 현재 열려 있는 설계에 적용합니다.

변경 이력 및 거부 Comment 지원

모든 변경 사항의 전체 이력이 유지됩니다. 이력을 확인하려면 아래와 같이 Latest from the ECAD/MCAD 드롭다운 오른쪽에 있는 이력 링크를 클릭합니다.

변경 이력을 통해 양측 엔지니어는 변경 사항에 대한 서로의 대응을 쉽게 파악할 수 있습니다.변경 이력을 통해 양측 엔지니어는 변경 사항에 대한 서로의 대응을 쉽게 파악할 수 있습니다.

각 변경 사항 집합에는 다음 정보가 자세히 기록됩니다.

  1. 해당 푸시() 또는 풀() 작업을 수행한 사용자와 작업이 수행된 설계 도메인( ECAD 또는  MCAD)

  2. 해당 작업이 수행된 날짜와 시간

  3. 다른 도메인에서 변경 사항을 푸시할 때 선택적으로 입력한 요약 설명

  4. 각 변경 사항의 상세 목록. 수락된 변경 사항에는 체크 표시가, 거부된 변경 사항에는 X 표시가 표시됩니다.

  5. 특정 변경 사항을 거부한 이유에 대한 선택적 설명 

  6. Panel의 History 모드에서 버튼을 클릭하면 Latest Changes 모드로 돌아갑니다.

  7. View Project in Browser 버튼을 클릭하면 워크스페이스에서 프로젝트를 볼 수 있습니다. 

  8. 브라우저에서 왼쪽의 History 링크를 클릭하면 아래 이미지와 같이 프로젝트 이력을 볼 수 있습니다. CoDesigner 푸시에 대한 각 이력 이벤트 타일의 제목은 MCAD Changes Suggested이며, 푸시를 수행한 사용자의 이름, 날짜와 시간, 그리고 메시지가 입력된 경우 해당 메시지가 포함됩니다. 이 정보를 사용하여 CoDesigner Panel과 이력 보기를 상호 참조할 수 있습니다. 

    프로젝트 이력에 대한 자세한 내용은 Altium 365 워크스페이스 또는 Enterprise Server 워크스페이스를 참조하세요.

변경 이력은 워크스페이스에서도 볼 수 있습니다.변경 이력은 워크스페이스에서도 볼 수 있습니다.

CoDesigner 이력 이벤트 타일이 다른 이유는 무엇인가요?

ECAD에서 CoDesigner 푸시는 데이터를 워크스페이스에 저장하지만, 이 CoDesigner 데이터는 원본 Schematic 및 PCB 프로젝트 문서와는 별개입니다. CoDesigner 푸시 중에는 원본 Schematic 및 PCB 프로젝트 문서가 수정되거나 저장되지 않으며, 프로젝트도 Commit되지 않습니다. 프로젝트 Commit only은 ECAD 엔지니어가 Save to Server를 수행할 때 발생하며, 이러한 이벤트는 짙은 회색 이벤트 타일에 표시됩니다.

MCAD CoDesigner 이력이 일반 프로젝트 Commit 이벤트의 이력에 영향을 미치지 않음을 나타내기 위해 MCAD 변경 사항은 보라색 타일에 제안 사항으로 기록됩니다. 이 타일은 타임라인에 직접 연결되지 않으며, 대신 방향 화살표가 전체 프로젝트 이력에서 해당 이벤트가 속하는 위치를 나타냅니다. 현재는 MCAD CoDesigner 푸시 이벤트만 지원됩니다.

혼동을 방지하고 워크플로를 간소화하기 위해 Save to Server를 수행하면 CoDesigner 푸시도 자동으로 수행되어 ECAD 및 MCAD 엔지니어 모두가 최신 설계 데이터에 액세스할 수 있습니다. 자동 CoDesigner 푸시에 대해 자세히 알아보세요.

설치된 MCAD CoDesigner에서 프로젝트 이력 기능을 사용할 수 있는지에 대한 정보는 오른쪽 창의 Note를 참조하세요.

PCB 정의 - 보드 영역

설계에는 MCAD 엔지니어가 정의하여 ECAD 엔지니어에게 전달해야 하는, 특별한 주의가 필요한 보드 영역이 있을 수 있습니다. 예를 들어 제품을 조립할 때 인클로저의 전도성 부품이 보드 표면과 접촉하므로 구리가 없어야 하는 보드 표면 영역이 있을 수 있습니다. 이를 지원하기 위해 MCAD 엔지니어는 Altium CoDesigner 리본의 버튼을 사용하여 Keep Out Areas 및 Text Note Rooms을 정의할 수 있습니다.

MCAD에서 이러한 객체 중 하나를 보드에 배치하면 CoDesigner Panel의 PCB Definitions 섹션에 있는 Board Areas 목록에 표시됩니다.

  • Keep Out Area - MCAD에서 정의한 Keep Out Area는 ECAD에서 PCB Keepout이 됩니다. PCB Keepout은 특정 ECAD 객체의 배치를 제한하도록 구성된 보드 영역입니다. Keepout은 보드의 한쪽 면에 정의하거나 모든 PCB 레이어에 적용할 수 있습니다. ECAD PCB의 이 영역에 배치하지 않아야 하는 객체는 Altium CoDesigner MCAD Panel에서 Keepout Restriction 속성으로 선택합니다. 필요에 따라 구성하세요. MCAD에서 Keep Out Area 배치에 대해 자세히 알아보세요.

  • Text Note Room - MCAD에서 정의한 Text Note Room은 ECAD에서 PCB Room이 됩니다. PCB Room은 특정 컴포넌트를 배치하거나 배제해야 하는 영역을 정의하는 데 사용되는 Design Rule입니다. 이 Rule의 일반적인 용도는 Room이 차지하는 보드 영역의 컴포넌트 높이 제한을 정의하는 것입니다. 일반적으로 Room Rule은 개별 컴포넌트 또는 컴포넌트 클래스에 적용됩니다. Altium CoDesigner MCAD Panel에서 Text Note Room 정의를 클릭하여 선택한 다음 ECAD 엔지니어를 위한 지침이나 정보를 입력합니다. 이 텍스트는 ECAD PCB Editor에서 해당 Room의 Comment 필드가 됩니다. MCAD에서 Text Note Room 배치에 대해 자세히 알아보세요.

Board Areas와 Text Note Rooms는 MCAD 엔지니어가 정의한 후 ECAD 엔지니어에게 푸시하는 특수 영역입니다. 

  • 기구 엔지니어에게 불필요한 시각적 정보를 줄이기 위해 ECAD에서 생성하거나 변경한 Keepout과 Room은 MCAD에서 기본적으로 표시되지 않습니다. 필요할 때 MCAD에서 다시 표시할 수 있습니다.

  • MCAD에서는 구리 영역을 정의할 수 없습니다. MCAD 엔지니어가 구리 영역을 정의해야 하는 경우 MCAD의 적절한 레이어에 Keep Out Area를 배치한 다음, ECAD에서 Tools » Convert » Convert Selected Keepouts to Primitives 명령을 사용하여 Keepout 영역 객체를 구리 영역 객체로 변환합니다.

PCB 정의 - 보드 인클로저

CoDesigner는 MCAD에서 장치 어셈블리 수준의 작업과 보드 및 인클로저를 MCAD에서 ECAD로 함께 전송하는 기능을 지원합니다.

CoDesigner는 보드와 인클로저가 장치 어셈블리에 추가되었음을 인식합니다.CoDesigner는 보드와 인클로저가 장치 어셈블리에 추가되었음을 인식합니다.

장치 어셈블리에서의 작업 및 MCAD에서 ECAD로 인클로저 푸시에 대해 자세히 알아보세요.

CoDesigner MCAD 설정 메뉴

CoDesigner 설정 메뉴는 MCAD 소프트웨어에서 CoDesigner를 구성하는 데 사용됩니다.

Altium CoDesigner Panel 오른쪽 상단의 아래쪽 화살표를 클릭하여 메뉴를 엽니다.

메뉴 옵션을 사용하여 다음 작업을 수행할 수 있습니다.

  • 현재 로그인한 서버/워크스페이스를 확인합니다.
  • 현재 로그인한 서버/워크스페이스에서 로그아웃합니다.
  • CoDesigner Settings 대화 상자를 열어 모델을 저장할 중앙 위치를 구성하고 실제 구리 형상 지원을 활성화할 수 있습니다.
  • Custom 서버에 접속합니다. Use Custom Server 옵션을 클릭하면 현재 워크스페이스에서 로그아웃되고 Altium CoDesigner Panel의 로그인 모드로 돌아갑니다.

버전 번호가 표시되지 않는 이전 버전의 CoDesigner에서 버전 번호를 확인하려면 Windows 제어판에서 프로그램 및 기능을 엽니다.

CoDesigner MCAD 리본

MCAD 소프트웨어에 CoDesigner 애드인을 설치하면 인터페이스에 Altium CoDesigner 리본이 추가됩니다. Altium CoDesigner 탭을 클릭하면 리본에 액세스할 수 있으며, 이 리본을 통해 ECAD-MCAD CoDesign 과정에서 필요한 일반적인 PCB 전용 설계 객체에 쉽게 접근할 수 있습니다. 이 버튼들을 사용하면 호환되는 ECAD 객체를 생성하는 데 올바른 MCAD 객체 유형이 사용됩니다.

CoDesigner 리본을 사용하여 ECAD에서 사용할 수 있는 방식으로 PCB의 객체를 정의합니다.CoDesigner 리본을 사용하여 ECAD에서 사용할 수 있는 방식으로 PCB의 객체를 정의합니다.

권장 협업 워크플로

ECAD-MCAD CoDesign은 유연한 프로세스로, 반드시 따라야 하는 정해진 방식은 없습니다. 보드 형상은 일반적으로 MCAD에서 설계하지만, 다양한 PCB 레이어 재료를 선택하고 구성하는 곳은 ECAD이므로 보드 두께는 ECAD에서 정의해야 must 합니다. 이러한 요구 사항에 따른 권장 설계 흐름은 아래와 같습니다.

ECAD에서 협업 프로세스 시작하기

In ECAD:

  1. 프로젝트를 생성합니다.

  2. PCB를 추가합니다.

  3. 레이어 스택을 정의하여 보드 두께를 설정합니다.

  4. MCAD CoDesigner Panel을 엽니다(설계 공간 오른쪽 하단의 Panels 버튼을 클릭하고 Panel 이름을 선택하거나 View » Panels 하위 메뉴를 사용).

  5. PushMCAD CoDesigner Panel의 버튼을 사용하여 보드를 푸시합니다. 이렇게 하면 ECAD-MCAD 교환 데이터가 워크스페이스로 푸시될 뿐만 아니라 프로젝트와 보드 파일도 워크스페이스에 저장됩니다. 저장된 프로젝트와 보드는 ECAD 설계자의 작업 파일이 됩니다.


In MCAD:

  1. Altium CoDesigner Panel을 엽니다. Panel을 여는 단계는 사용하는 MCAD 소프트웨어에 따라 다릅니다. 자세한 내용은 해당하는 MCAD 소프트웨어에 CoDesigner 설치 링크를 참조하세요.

  2. Pull Altium CoDesigner Panel에서 보드를 가져옵니다. 그러면 워크스페이스의 보드 정의를 기반으로 MCAD 보드 어셈블리가 생성됩니다.

  1. 보드를 장치 어셈블리에 삽입합니다.
  2. 인클로저에 맞게 보드 형상을 구성합니다.
  3. 장착 홀을 정의합니다.
  4. 위치가 중요한 메카트로닉스 컴포넌트를 배치합니다.
  5. 필요한 배치 금지 영역 또는 텍스트 메모 룸을 정의합니다.
  6. MCAD 어셈블리를 저장합니다.

    보드 형상 정의, 홀 추가, 컴포넌트 배치에 대한 자세한 내용은 기구 엔지니어를 위한 권장 사항 섹션을 참조하세요.

Pushing from MCAD back to ECAD:

  1. MCAD CoDesigner Panel의 버튼을 사용하여 보드를 워크스페이스로 Push합니다. 그러면 보드 정의, 홀 및 배치된 컴포넌트의 세부 정보가 MCAD-ECAD 교환 데이터로 저장됩니다.

Pulling into ECAD:

  1. 보드를 열고 Pull을 수행하여 워크스페이스에서 업데이트된 보드 정의와 컴포넌트 세부 정보를 불러옵니다.

In MCAD or ECAD:

  1. 어셈블리 또는 PCB 파일을 다시 열어 설계 작업을 계속합니다.

MCAD에서 협업 프로세스 시작하기

Starting the Board in MCAD:

  1. MCAD에서 PCB 설계 프로세스를 시작할 수는 있지만 권장되지는 않습니다. 지원되는 모든 MCAD 환경에서 프로세스는 동일합니다.

푸시 및 공유로 기계 엔지니어 초대하기(Altium 365에서 호스팅되는 워크스페이스)

ECAD의 MCAD CoDesigner Panel에서 Push을 클릭하면 MCAD CoDesigner Panel에서 다른 엔지니어와 프로젝트를 Share할 수도 있습니다.

CoDesigner는 Altium 워크스페이스를 통해 특수 ECAD-MCAD 데이터 패키지를 주고받으며 보드 설계를 푸시하고 풀합니다. Share 체크박스를 활성화하면 초대된 엔지니어가 특수 ECAD-MCAD 데이터 패키지를 포함한 프로젝트에 액세스할 수 있도록 워크스페이스 액세스 및 프로젝트 권한을 구성하는 프로세스가 시작됩니다. 초대된 엔지니어는 MCAD 소프트웨어의 Altium CoDesigner Panel에 있는 푸시/풀 기능을 통해 액세스할 수 있으며, Altium 계정이 있거나 초대 과정에서 계정을 생성하는 경우 웹 브라우저를 통해서도 액세스할 수 있습니다.

Share 체크박스의 선택 여부는 Mechanical Engineers 역할이 할당된 워크스페이스 멤버의 존재 여부에 따라 결정됩니다. 해당 멤버가 없으면 기본적으로 체크박스가 On 상태가 됩니다.

프로젝트 워크스페이스의 기존 멤버인지 여부나 Altium 계정 보유 여부와 관계없이 누구와든 프로젝트를 공유할 수 있습니다. 아래 표는 공유를 수행할 당시 초대 대상자의 권한 상태에 따른 프로젝트 액세스를 요약합니다.

Existing Altium Account Status Existing Workspace Status Permissions Assigned During Share Notes
활성 Altium 계정 없음 프로젝트 워크스페이스의 멤버가 아님 편집 권한이 있는 프로젝트 게스트 액세스 부여

초대 대상자는 Altium 계정을 생성할 수 있는 링크가 포함된 이메일을 받습니다. 계정을 생성하면 게스트는 자신의 개인 공간에 있는 나와 공유됨 섹션을 통해 브라우저에서도 프로젝트에 액세스할 수 있습니다.

단, 초대 대상자는 MCAD 소프트웨어에서는 프로젝트에 액세스할 수 없습니다. 사용자를 워크스페이스 멤버로 추가하고 편집 권한을 할당하면 이 문제를 해결할 수 있습니다.

활성 Altium 계정 있음 프로젝트 워크스페이스의 멤버가 아님 프로젝트 워크스페이스의 멤버가 되고 Mechanical Engineer 역할이 할당되며, 보기 권한으로 프로젝트가 공유됨

새 워크스페이스 멤버에게 Mechanical Engineer 역할이 할당됩니다. 이제 ME 역할이 할당된 워크스페이스 멤버가 있으므로 공유 체크박스는 더 이상 자동으로 활성화되지 않습니다.

기계 엔지니어가 MCAD에서 푸시를 수행하려면 프로젝트 권한을 편집으로 높여야 합니다.

활성 Altium 계정 있음 이미 프로젝트 워크스페이스의 멤버임 편집 권한으로 프로젝트가 공유됨  

공유 프로세스

Share 체크박스가 활성화되어 있으면 MCAD CoDesigner Panel에서 Send 버튼을 클릭할 때 Share with a Mechanical Engineer 대화상자가 열립니다.

프로젝트를 공유할 사람의 Email Address을 입력하고 선택적으로 Note도 입력한 다음, 대화상자에서 Share 버튼을 클릭합니다. 초대 대상자가 아직 워크스페이스 멤버가 아닌 경우, 초대된 사용자가 조직 외부의 사람일 수 있음을 경고하는 Share with a Mechanical Engineer 알림 대화상자가 나타납니다.

이 대화상자에서 OK을 클릭하거나 초대 대상자가 이미 워크스페이스 멤버인 경우, 알림 이메일이 생성되어 초대 대상자에게 전송됩니다.

이메일 알림 기능을 사용하려면 워크스페이스에서 Enable Mail Notifications 옵션을 활성화해야 합니다().

잠시 후 성공 대화상자가 나타납니다.

이제 프로젝트가 기계 엔지니어와 공유됩니다.

푸시 및 공유 수행 시 참고 사항

  • 브라우저에서 워크스페이스에 로그인한 후, 프로젝트 Share 대화상자()에서 초대된 기계 엔지니어에게 Edit permissions이 할당되어 있는지 확인해야 합니다. 기계 엔지니어는 보기 권한만 있어도 보드를 풀할 수 있지만, the project이 편집 권한으로 공유되지 않으면 보드 설계 변경 사항을 푸시할 수 없습니다. ECAD-MCAD CoDesign은 특정 도구에 종속되지 않는 중간 파일을 통해 이루어지고 기계 엔지니어는 실제 PCB 설계 파일에 대해 읽기 전용 액세스만 가지므로, 공유에 따른 위험은 낮습니다.

  • 워크스페이스의 모든 관리자는 초대 대상자(이메일 주소로 식별됨)가 프로젝트에 초대되었다는 알림 이메일을 받습니다.

  • 초대 대상자에게 Altium 계정이 없는 경우, Altium 계정에 가입/등록하기 위한 중간 양식으로 안내하는 이메일이 전송됩니다. 등록을 완료하면 프로젝트가 Edit permissions을 가진 Guest로 해당 사용자와 공유됩니다. Altium 계정이 없던 초대 대상자는 가입 시 자체적인 개인 조직으로 취급됩니다. 해당 사용자는 워크스페이스의 멤버로 추가되지 않습니다.

  • 푸시 및 공유를 수행한 Altium Designer 엔지니어에게 워크스페이스 관리자 권한이 없으면 프로세스에 추가 단계가 포함됩니다. 먼저 모든 워크스페이스 관리자에게 공유 요청이 통지됩니다. 관리자가 초대 요청()을 승인하면 위에서 설명한 대로 초대가 처리되며, 최초 초대를 보낸 사람에게도 이메일로 알림이 전송됩니다. 자세한 내용은 Altium 365 워크스페이스에 다른 사용자 초대하기를 참조하십시오.

MCAD와 ECAD 간 작업

현재 CoDesigner가 감지하는 변경 사항의 정밀도는 선형 치수의 경우 0.5 mils (0.0127 mm), 각도 치수의 경우 0.5 degrees입니다. 이 정밀도는 향후 CoDesigner 업데이트에서 향상될 예정입니다.

설계 프로세스 중 언제든지 CoDesigner Panel을 사용하여 MCAD 도구와 ECAD 도구 간에 변경 사항을 전달할 수 있습니다.

변경 사항은 CoDesigner Panel을 통해 MCAD 도구와 ECAD 도구 간에 푸시 및 풀됩니다. Changes to the board and component detail are Pulled from MCAD in the MCAD CoDesigner panel 변경 사항은 CoDesigner Panel을 통해 MCAD 도구와 ECAD 도구 간에 푸시 및 풀됩니다.

  1. 설계 변경 사항을 전달하려면 해당 Panel에서 Push 버튼을 클릭합니다.
  2. Push 버튼을 클릭하면 소스 Editor의 Panel 상단에 편집 창이 나타납니다. 설계 변경 사항에 대한 메시지를 입력한 다음 Send을 클릭합니다.
  3. 보내기를 클릭하면 다음과 같이 처리됩니다.
    • 수정된 PCB 파일의 작업 사본이 현재 저장되지 않은 상태라면 자동으로 저장됩니다.
    • 변경 사항이 워크스페이스에 기록됩니다.
    • 게시된 메시지가 소스 Editor의 CoDesigner Panel에 있는 메시지 스레드에 표시됩니다.
    • 타겟 Editor의 Panel에는 다음에 설계 파일의 작업 사본을 열 때 보류 중인 변경 사항이 있다는 메시지가 표시됩니다.
  4. 타겟 Editor의 Panel에서 Pull을 클릭하면 설계를 다시 동기화하는 데 필요한 각 변경 사항의 세부 목록이 표시됩니다.

변경 목록으로 작업하기

Pull 버튼을 클릭하면 아래와 같이 작업 파일을 워크스페이스의 스냅샷과 동기화하기 위해 수행해야 하는 각 변경 사항이 나열됩니다.

Incoming changes are detailed in the CoDesigner panel, these can be selectively enabled as required

  • 현재 설계와 워크스페이스에 저장된 스냅샷 사이에서 감지된 각 차이는 변경 목록에 변경 사항으로 자세히 표시됩니다.
  • 변경 사항을 반드시 수락할 필요는 없습니다. 변경 사항을 무시하면 다음에 같은 방향으로 업데이트할 때 변경 목록에 다시 나타납니다. 예를 들어 장착 홀 이동과 같은 변경 사항을 무시한 후 설계 변경 사항을 푸시하면, 현재 버전에서는 장착 홀이 이전 위치에 있으므로 무시한 변경 사항을 덮어쓸 수 있습니다. MCAD 설계자는 장착 홀 이동을 수락하지 않음으로써 자신의 변경 사항이 손실되는 것을 방지할 수 있습니다.
  • 컴포넌트 위치 변경과 같은 하나의 설계 변경이 변경 목록에서는 여러 변경 사항으로 나타날 수 있습니다. PCB 컴포넌트를 이동하면 MCAD에서는 컴포넌트의 위치, 컴포넌트 오버레이에 생성되는 형상, 상단 및 하단 구리 레이어에 생성되는 형상이 변경됩니다. 관련된 변경 사항은 모두 함께 적용해야 합니다.
  • 목록에는 타겟 환경에서 적용할 수 없는 변경 사항이 포함될 수 있습니다. 이 경우 변경 사항은 표시되지만 체크박스는 사용할 수 없으며, 이는 해당 차이를 해결할 수 없음을 나타냅니다.
  • 가능한 경우 변경 목록에서 변경 사항을 클릭하면 설계 공간에서 해당 변경 사항이 강조 표시됩니다.
  • Apply을 클릭하여 체크된 변경 사항을 적용합니다.

보드 형상 정의, 홀 추가, 컴포넌트 배치에 대한 자세한 내용은 기계 엔지니어를 위한 권장 사항 섹션을 참조하세요.

다음 유형의 PCB는 ECAD에서 MCAD로 not 전송됩니다.

  • Rigid-Flex 보드는 Autodesk Inventor, Autodesk Fusion 또는 Siemens NX에서 지원되지 않으며, MCAD에서 하나의 Rigid 구조로 로드됩니다. SOLIDWORKS와 PTC Creo에서는 Rigid-Flex 보드가 지원됩니다. 자세한 내용은 Rigid-Flex 보드 동기화를 참조하세요.

  • CoDesigner에서 멀티보드 어셈블리의 풀 및 푸시를 지원하는 MCAD 패키지는 PTC Creo와 SOLIDWORKS뿐입니다. 자세한 내용은 Altium MCAD CoDesigner를 사용한 멀티보드 어셈블리 동기화를 참조하세요.

MCAD 좌표 Grid

CoDesigner는 보드를 ECAD에서 MCAD로 푸시할 때 ECAD 절대 원점을 기준으로 사용합니다. CoDesigner 2.4에는 MCAD 원점이 ECAD의 기본(절대) 원점과 다를 경우, ECAD로 풀할 때 MCAD Origin 개체를 포함하는 새로운 MCAD Coordinates Grid를 생성하는 기능이 도입되었습니다. 이를 통해 전기 엔지니어는 다양한 보드 개체의 위치에 대해 기계 엔지니어와 더 쉽게 소통할 수 있습니다.

MCAD Coordinates Grid의 표시 방식은 ECAD에서 사용자 지정할 수 있습니다. Properties 패널에서 해당 항목을 두 번 클릭하여 Grid Editor 대화 상자를 엽니다. 자세한 내용은 PCB Grid 시스템을 참조하세요.

MCAD에서 정의한 좌표 Grid는 ECAD에서도 사용자 지정할 수 있습니다.MCAD에서 정의한 좌표 Grid는 ECAD에서도 사용자 지정할 수 있습니다.

MCAD에서 보드 외곽선의 위치를 변경할 때는 컴포넌트와 기타 객체를 배치하기 전에 수행해야 합니다. 그렇지 않으면 이러한 객체의 위치를 수동으로 복원해야 할 수 있습니다.

컴포넌트 배치를 위한 MCAD 평면

CoDesigner 2.2.0부터는 MCAD에서 컴포넌트를 더 쉽게 배치할 수 있도록 보드를 풀할 때 MCAD에 상단 및 하단 컴포넌트 평면이 생성됩니다. ECAD에서 푸시한 컴포넌트는 솔더 마스크 레이어의 두께를 무시하도록 MCAD에 배치됩니다.

CoDesigner의 구리, 마스크 및 오버레이 레이어 처리 방식

CoDesigner는 보드 형상과 컴포넌트뿐 아니라 상단 및 하단의 구리, 솔더 마스크, 컴포넌트 오버레이 레이어도 ECAD에서 MCAD로 전송합니다.

데칼로 표현되는 ECAD 레이어

기본적으로 이러한 레이어는 개별 SVG 이미지로 ECAD에서 워크스페이스로 푸시됩니다. 보드 어셈블리를 MCAD로 풀하면 CoDesigner가 SVG 이미지를 PNG 이미지로 변환합니다. 그런 다음 상단 PNG 이미지 세트를 하나의 상단 데칼로, 하단 이미지 세트를 하나의 하단 데칼로 결합합니다. MCAD로 풀하는 동안 이 두 데칼이 보드의 상단 및 하단 표면에 적용됩니다.

상단 및 하단 데칼은 MCAD에서 보드의 각 면에 적용됩니다. 상단 및 하단 데칼은 MCAD에서 보드의 각 면에 적용됩니다.

Autodesk Fusion - 스케치 프로파일로 표현되는 ECAD 레이어

상단/하단 구리 및 컴포넌트 오버레이 레이어를 ECAD에서 Autodesk Fusion으로 전송할 때는 다른 방식이 사용됩니다. Autodesk Fusion에서는 이러한 레이어를 보드 객체에 그려진 스케치 프로파일로 가져옵니다. Autodesk Fusion의 Altium CoDesigner 리본에서 Advanced Geometry ( ) 버튼을 클릭하여 이 레이어 세트의 표시를 켜거나 끌 수 있습니다. 또는 Autodesk Fusion의 가시성 아이콘을 사용하여 각 레이어를 선택적으로 숨기거나 표시할 수 있습니다.

Autodesk Fusion에서는 컴포넌트 오버레이와 표면 구리 레이어가 스케치 프로파일로 생성됩니다.Autodesk Fusion에서는 컴포넌트 오버레이와 표면 구리 레이어가 스케치 프로파일로 생성됩니다.

상단/하단 솔더 마스크 레이어는 Autodesk Fusion으로 전송되지 않습니다. 대신 보드 객체에 ECAD 상단 솔더 마스크 레이어의 색상이 적용됩니다.

MCAD의 고급 구리 형상

CoDesigner는 MCAD에서 구리 + 마스크 + 오버레이 레이어를 데칼(이미지)로 표시하는 대신, 실제 구리 형상(Advanced Copper Geometry)과 3D 마스크 레이어를 MCAD로 전송할 수도 있습니다. 이 기능은 현재 PTC Creo, Autodesk Inventor, SOLIDWORKS 및 Siemens NX에서 지원됩니다. CoDesigner 2.7부터는 컴포넌트 오버레이(실크스크린) 데칼이 솔더 마스크 돌출 형상의 면에 적용됩니다.

필요한 경우 구리 레이어를 MCAD로 전송할 수 있습니다. 위 이미지에서는 상단 구리 레이어를 제외한 나머지 레이어와 컴포넌트가 숨겨져 있습니다.필요한 경우 구리 레이어를 MCAD로 전송할 수 있습니다. 위 이미지에서는 상단 구리 레이어를 제외한 나머지 레이어와 컴포넌트가 숨겨져 있습니다.

고급 구리 형상을 포함하려면 Altium CoDesigner Settings 대화 상자에서 Build 3D geometry for Copper and Solder Mask 옵션을 활성화합니다(필요한 경우 Build Vias 옵션도 활성화). 설정 대화 상자는 Altium CoDesigner 패널의 CoDesigner 메뉴()에서 열 수 있습니다.

MCAD 어셈블리에 이러한 레이어를 포함하려면 구리 및 솔더 마스크의 3D 형상 생성 옵션을 활성화합니다(Autodesk Inventor 대화 상자).MCAD 어셈블리에 이러한 레이어를 포함하려면 구리 및 솔더 마스크의 3D 형상 생성 옵션을 활성화합니다(Autodesk Inventor 대화 상자).

구리 형상 및 3D 마스크 레이어 작업 시 참고 사항:

  • 구리 및 마스크 레이어는 MCAD 하위 어셈블리로 포함됩니다.
  • 레이어 스택에 존재하는 모든 PCB 구리 레이어가 포함됩니다. 구리 레이어 두께에는 표면 마감과 같은 도금 레이어 데이터가 포함되지 않습니다. 이는 향후 업데이트에서 추가될 예정입니다.
  • Build 3D geometry for Copper and Solder Mask 옵션을 활성화하면 스루홀 패드 배럴이 포함됩니다.
  • Build 3D geometry for Copper and Solder Mask 옵션을 활성화하면 비아 표면 형상도 포함됩니다. 비아 구리 배럴을 포함하려면 Build Vias 옵션을 활성화합니다.
  • Build 3D geometry for Copper and Solder Mask 옵션을 활성화하면 컴포넌트 오버레이(실크스크린) 데칼이 솔더 마스크 돌출 형상의 면에 적용됩니다.
  • 설계의 복잡도에 따라 구리 형상과 비아를 포함하면 파일 크기와 설계를 MCAD로 풀하는 데 걸리는 시간이 significantly increase 수 있습니다.
  • 구리 및 마스크 데이터는 항상 ECAD에서 푸시됩니다. MCAD에서 Build 3D geometry for Copper and Solder Mask 및 Build Vias 옵션을 활성화하더라도 ECAD에서 다시 푸시할 필요는 없습니다. 보드를 닫고 워크스페이스에서 다시 풀하면 됩니다.

Notes:

  • 설치된 MCAD CoDesigner에서 Advanced Copper Geometry 기능을 사용할 수 있는지 확인하려면 오른쪽 창의 Note을 참조하세요. 사용할 수 없는 경우에는 위에서 설명한 이미지 기반 데칼을 사용할 수 있습니다.
  • 구리 형상은 ECAD에서만 편집할 수 있으며, MCAD에서 편집한 내용은 ECAD로 푸시되지 않습니다.

솔더 마스크의 정확한 표현

업데이트 2.5부터 CoDesigner는 Build 3D Copper 옵션이 활성화되어 있으면 패드 개구부를 포함한 정밀한 솔더 마스크 모델을 MCAD에 별도 객체로 생성합니다. 마스크가 구리 사이의 에칭된 영역을 채우므로, MCAD에서 마스크 레이어의 두께는 ECAD에 정의된 상단 구리 레이어 두께와 솔더 마스크 레이어 두께의 합입니다.

솔더 마스크가 트랙, 패드 및 비아 사이의 에칭된 영역을 채우므로, MCAD에서 솔더 마스크의 총두께는 ECAD에 정의된 구리 레이어 두께와 솔더 마스크 두께의 합입니다.솔더 마스크가 트랙, 패드 및 비아 사이의 에칭된 영역을 채우므로, MCAD에서 솔더 마스크의 총두께는 ECAD에 정의된 구리 레이어 두께와 솔더 마스크 두께의 합입니다.

앞서 언급했듯이, MCAD에서는 컴포넌트가 상단 및 하단 컴포넌트 평면에 배치됩니다. 이 평면은 보드를 가져올 때 MCAD에 생성됩니다. 이 평면은 상단 및 하단 구리 레이어의 바깥쪽 표면에 있으므로, ECAD에서 푸시된 컴포넌트는 솔더 마스크 레이어의 두께를 고려하지 않은 상태로 MCAD에 배치됩니다. 이로 인해 컴포넌트와 솔더 마스크 레이어 사이에 간섭이 발생합니다. 이러한 간섭이 설계상의 문제가 된다면, 컴포넌트가 사실상 솔더 마스크 레이어의 바깥쪽 표면에 놓이도록 PCB 두께를 일시적으로 줄이세요. 향후 업데이트에서는 MCAD에서 솔더 마스크 레이어를 숨기는 옵션이 추가되어 이 문제가 해결될 예정입니다.

Keepout 및 Room 지원

Altium CoDesigner 리본을 사용하면 MCAD에서 Keepout 및 Room을 비롯한 일반적인 PCB 전용 설계 객체에 쉽게 접근할 수 있습니다. 이 버튼을 사용하면 호환되는 ECAD 객체를 생성하는 데 적합한 MCAD 객체 유형이 사용됩니다.

Keepout 지원

PCB Keepout은 특정 ECAD 객체의 배치를 제한하도록 설정된 보드 영역입니다. Keepout은 보드의 어느 한쪽 면에 정의하거나 모든 PCB 레이어에 적용할 수 있습니다. 이 영역에 배치하지 않을 객체는 Keepout 제한 속성에서 선택합니다.

MCAD에서 Keepout 정의하기:

  • Altium CoDesigner 리본에서 Keep Out Area 버튼을 클릭합니다.
  • 면, 곡면 또는 평면을 선택하라는 메시지가 표시되면 Keepout이 필요한 보드 면을 클릭합니다. Keepout을 모든 레이어에 적용하려면 어느 쪽 면에 그려도 됩니다.
  • Rectangle과 같은 적절한 MCAD 스케치 도구를 클릭하여 Keepout을 정의합니다. 스케치에는 윤곽선이 하나만 있어야 하며, 내부 윤곽선은 지원되지 않습니다.
  • Keepout에 필요한 형상을 그립니다.
  • Sketch 모드를 종료합니다.
  • 이제 피처의 속성을 편집할 수 있습니다. Keepout을 해당 영역을 둘러싼 울타리로 생각하고, Depth을 1mm와 같은 작은 값으로 설정합니다.
  • 이 Keepout은 MCAD에서 그린 레이어에 해당하는 ECAD 레이어 전용 Keepout이 됩니다. 모든 레이어에 적용되는 Keepout을 정의하려면 MCAD에서 Keepout이 양방향으로 돌출되도록 설정하고, 두 번째 방향의 Depth을 보드를 관통하여 돌출될 만큼 충분히 큰 값으로 설정합니다.
  • MCAD의 확인 버튼 을 클릭하여 피처 정의 과정을 마칩니다. 필요한 경우 피처 트리에서 피처 이름을 변경할 수 있습니다.
  • Altium CoDesigner 패널에서 PCB Definition 탭을 선택하고 필요에 따라 Keepout 제한을 설정합니다. 이제 Keepout을 ECAD로 푸시할 수 있으며, ECAD에는 Keepout Region으로 추가됩니다. MCAD에서 설정한 방식에 따라 상단 레이어 Keepout, 하단 레이어 Keepout 또는 Keepout 레이어 Keepout이 됩니다. 필요한 경우 ECAD에서 Keepout 형상을 조정한 후 MCAD로 다시 푸시할 수 있습니다.

Room 지원

PCB Room은 특정 컴포넌트를 배치하거나 배제해야 하는 영역을 정의하는 설계 규칙입니다. 이 규칙은 일반적으로 Room이 차지하는 보드 영역에 컴포넌트 높이 제한을 정의하는 데 사용됩니다. 보통 Room 규칙은 개별 컴포넌트 또는 컴포넌트 클래스에 적용됩니다.

MCAD에서 Room 정의하기:

  • Altium CoDesigner 리본에서 Text Note Room 버튼을 클릭합니다.

  • 면, 곡면 또는 평면을 선택하라는 메시지가 표시되면 Room이 필요한 보드 면을 클릭합니다.

  • Rectangle과 같은 적절한 MCAD 스케치 도구를 클릭하여 Room을 정의합니다. 스케치에는 윤곽선이 하나만 있어야 하며, 내부 윤곽선은 지원되지 않습니다.

  • Room에 필요한 형상을 그립니다.

  • Sketch 모드를 종료합니다.

  • MCAD의 확인 버튼 을 클릭하여 피처 정의 과정을 마칩니다. 필요한 경우 피처 트리에서 피처 이름을 변경할 수 있습니다.

  • Altium CoDesigner 패널에서 PCB Definition 탭을 선택하고, ECAD 엔지니어가 Room의 용도를 알 수 있도록 설명을 입력합니다. 이제 Room을 ECAD로 푸시할 수 있으며, MCAD에서 그린 레이어에 Placement Room 설계 규칙으로 추가됩니다. MCAD와 ECAD 간에 전송할 수 있는 유일한 속성은 Comment이며, 이는 Placement Room 설계 규칙의 설명이 됩니다.

  • 이제 ECAD에서 필요에 따라 Placement Room 설계 영역을 설정할 수 있습니다.

MCAD에서 Keepout 영역과 Room을 정의하고 ECAD로 푸시할 수 있습니다.MCAD에서 Keepout 영역과 Room을 정의하고 ECAD로 푸시할 수 있습니다.

보드 영역 전송 시 참고 사항:

  • Fill 및 솔리드 Region 형태의 ECAD Keepout Region이 지원됩니다.
  • CoDesigner는 ECAD에서 Keepout 및 Room의 잠금 상태를 감지하여 MCAD에서 가져오기를 수행할 때 이들이 이동하지 않도록 합니다.
  • ECAD Keepout 객체에는 고유 식별자나 객체 이름이 없으므로, ECAD에서 MCAD로 Keepout 변경 사항을 전달할 때는 기존 객체를 제거하고 새 객체를 새 MCAD 이름으로 추가합니다.
  • ECAD Room의 변경 사항도 ECAD에서 MCAD로 전달될 때 제거 및 추가로 표시되지만, 이름과 Comment는 유지됩니다.
  • ECAD에서 생성하거나 변경한 Keepout 및 Room은 MCAD에서 기본적으로 표시되지 않으므로, 기구 엔지니어에게 불필요한 시각적 정보를 줄여줍니다. 필요한 경우 MCAD에서 다시 표시할 수 있습니다.

Important Note about Versions: ECAD 확장 기능은 업데이트되었지만 MCAD 플러그인은 업데이트되지 않았을 가능성이 있다면, MCAD의 변경 사항을 ECAD에 적용할 때 주의하세요. ECAD의 PCB에 Keepout 및 Room이 정의되어 있으면 CoDesigner가 이를 삭제하도록 제안합니다. 이 경우 ECAD에서 해당 변경 사항을 거부하면 Keepout 및 Room을 그대로 유지할 수 있습니다.

MCAD로 가져올 컴포넌트 수 제어

컴포넌트 수가 많은 보드에서 작업할 때 성능을 개선하기 위해, CoDesigner는 ECAD에서 가져올 때 사용자 정의 높이보다 낮은 컴포넌트를 제외하는 기능을 지원합니다. 높이 기준값에는 ECAD의 컴포넌트 속성에 정의된 높이를 사용합니다. 이는 PCB 컴포넌트의 Height 속성이며, 컴포넌트 풋프린트에 추가된 3D 모델의 높이()가 아니라는 점에 유의하세요.

CoDesigner가 검사하는 높이 임계값은 아래 이미지와 같이 Altium CoDesigner Settings 대화상자에서 정의됩니다. 이 대화상자는 MCAD의 Altium CoDesigner Panel에서 열 수 있습니다. Panel 메뉴에서 Settings을 선택하면 대화상자가 열립니다. 아래 이미지는 Autodesk Fusion의 설정을 보여주며, 지원되는 모든 MCAD에서 동일한 설정을 사용할 수 있습니다.

높이 임계값보다 작은 컴포넌트를 무시하도록 설정하면 MCAD로 가져올 때 작은 컴포넌트를 제외할 수 있습니다.높이 임계값보다 작은 컴포넌트를 무시하도록 설정하면 MCAD로 가져올 때 작은 컴포넌트를 제외할 수 있습니다.

ECAD에서 컴포넌트 높이 구성하기

아래 동영상은 Height가 정의되지 않은 PCB 컴포넌트(기본값 0)를 찾고 여러 컴포넌트의 높이 값을 빠르게 업데이트하는 방법을 보여줍니다. 이어서 MCAD에서 Ignore components setting smaller than을 설정하는 방법과 ECAD에서 가져올 때 MCAD CoDesigner가 이를 처리하는 방법을 보여줍니다. 

잘못된 컴포넌트 높이 값은 ECAD에서 빠르게 감지하고 수정할 수 있습니다.

MCAD의 스마트 스케치 변경

ECAD 엔지니어가 보드 형상을 수정해야 하고, 해당 형상에 MCAD에서 치수와 구속조건이 적용되어 있는 상황을 생각해 보겠습니다. 이전에는 보드를 MCAD로 다시 가져오면 MCAD 스케치의 치수와 구속조건이 손실되었습니다. 이제 CoDesigner는 가져오기 중에 ECAD에서 변경된 스케치 요소만 다시 그리므로, 변경되지 않은 요소와 관련된 치수 및 구속조건은 그대로 유지됩니다.

복잡한 기계적 구속조건이 있는 경우와 같은 일부 상황에서는 이 동작으로 인해 형상이 예기치 않게 변경될 수 있습니다. 이러한 경우에는 새로운 스마트 스케치 지원 기능을 비활성화하고 다시 가져온 다음, 치수와 구속조건을 다시 생성하는 편이 더 효율적일 수 있습니다(이전 버전의 CoDesigner에서 필요했던 방식). MCAD의 Altium CoDesigner Settings 대화상자에서 Smart Sketch Change 옵션을 비활성화하면 됩니다.

설계 변경의 영향을 받지 않는 스마트 치수는 ECAD에서 가져오는 동안 유지됩니다.

MCAD에서 PCB 라우팅 공구 경로 관리하기

보드 설계에서는 보드 형상의 외곽을 따라 밀링 경로를 정의하는 경우가 많습니다. 이 경로에는 작은 구멍이 여러 줄로 배치되는 경우가 많으며, 이를 "마우스 바이트"라고 합니다. 구멍 주변에 남아 있는 재료는 제작 패널 안에서 보드 형상을 고정할 수 있을 만큼 충분합니다. PCB 조립이 완료되면 주변의 불필요한 재료에서 보드를 떼어낼 수 있습니다.

"마우스 바이트" 구멍을 포함하여 보드 외곽을 따라 형성된 라우팅 경로를 확인하세요.

라우팅 공구 경로는 ECAD에서 라우팅 공구 경로 레이어로 구성된 기계 레이어에 정의됩니다.

 

라우팅 공구 경로는 제작에 필수적이지만, 기구 엔지니어가 보드를 제품 인클로저에 맞추는 작업에 집중해야 하는 MCAD 설계 과정에서는 필요하지 않은 경우가 많습니다. MCAD CoDesigner 3.13 업데이트에서는 Altium CoDesigner Settings 대화상자에 Build Route Tool Path 옵션이 도입되어, 기구 엔지니어가 라우팅 공구 경로를 MCAD로 가져올지 여부를 제어할 수 있게 되었습니다(경로는 항상 ECAD에서 푸시됩니다). 

MCAD로 가져올 때 라우팅 공구 경로를 포함할지 선택합니다.MCAD로 가져올 때 라우팅 공구 경로를 포함할지 선택합니다.

Variant가 있는 PCB 공동 설계하기

Altium Designer를 사용하면 전자 설계자가 설계 중인 제품의 여러 변형을 만들 수 있습니다. 지원되는 변형에는 컴포넌트를 미장착으로 표시하거나, 보드에 실크스크린으로 인쇄되는 컴포넌트 값을 비롯한 컴포넌트 파라미터를 수정하거나, 컴포넌트를 대체 컴포넌트로 교체하는 작업이 포함됩니다. 대체 컴포넌트는 다른 풋프린트를 사용할 수도 있고 사용하지 않을 수도 있습니다.

Altium Designer에는 보드 설계가 하나만 존재합니다. 대체 컴포넌트의 세부 정보와 같은 Variant 정보는 프로젝트 파일에 저장되며, Projects Panel에서 Variant를 선택하면 보드에 적용됩니다. 보드의 [No Variations] 버전은 PcbDoc으로 저장됩니다.

Altium Designer에서 보드 설계의 여러 변형을 만들 수 있습니다. Projects Panel에서 Variant를 선택한 다음 CoDesigner Panel에서 MCAD로 푸시합니다.Altium Designer에서 보드 설계의 여러 변형을 만들 수 있습니다. Projects Panel에서 Variant를 선택한 다음 CoDesigner Panel에서 MCAD로 푸시합니다.

ECAD에서 Variant 작업하기

에 대해 자세히 알아보기

기구 엔지니어를 위한 권장 사항

이 섹션에서는 기구 엔지니어가 CoDesigner를 사용할 때 알아야 할 기능과 동작을 자세히 설명합니다.

MCAD에서 ECAD 참조 Designator 표시하기

Altium MCAD CoDesigner는 각 MCAD 도구에서 서로 다른 방식으로 참조 Designator를 표시합니다:

  • Autodesk Fusion – ECAD Properties Panel을 열어 현재 선택한 파트의 속성을 표시합니다().
  • Autodesk Inventor – 참조 Designator는 기본적으로 모델 트리에 표시됩니다().
  • PTC Creo – Panel의 Model Tree 모드에서 Tree Columns 버튼을 클릭하여 Model Tree Columns 대화 상자를 엽니다. Not Displayed Type을(를) ECAD Params(으)로 설정하고, ECAD_REF_DES 파라미터를 찾은 다음 Add Column 버튼을 클릭합니다().
  • SOLIDWORKS – 참조 Designator는 기본적으로 모델 트리에 표시됩니다().
  • Siemens NX – Assembly Navigator에서 열 이름이 표시되는 위치를 right-click하여 컨텍스트 메뉴를 연 다음, Columns » Component Name을(를) 선택하여 컴포넌트 이름 열을 표시합니다().

기구 엔지니어 간 변경 사항 동기화

  1. CoDesigner는 Altium 365 워크스페이스와 같은 Altium 워크스페이스를 통해 기구 PCB 어셈블리를 ECAD로 전송합니다. 워크스페이스를 통해 푸시/풀되는 변경 사항에는 방향성이 있습니다. MCAD에서 푸시되고 ECAD로 풀되는 PCB 어셈블리는 ECAD에서 푸시되고 MCAD로 풀되는 PCB 어셈블리와 워크스페이스에 별도로 저장됩니다. 따라서 다른 기구 엔지니어는 한 기구 엔지니어가 방금 워크스페이스에 푸시한 수정된 보드를 풀할 수 없으며, 대신 마지막으로 푸시된 ECAD 데이터를 풀하게 됩니다. MCAD 구속 조건은 해당 구속 조건이 생성된 MCAD 어셈블리에만 존재한다는 점에 유의하세요. 보드를 MCAD에서 ECAD로 푸시하면 구속 조건에 따른 컴포넌트 위치는 푸시되지만 구속 조건 자체는 푸시되지 않습니다. 따라서 보드를 새 MCAD 어셈블리로 풀하면 이전 MCAD 엔지니어가 생성한 구속 조건은 포함되지 않습니다.

ECAD와 MCAD의 변경 사항은 워크스페이스에 별도로 저장됩니다.ECAD와 MCAD의 변경 사항은 워크스페이스에 별도로 저장됩니다.

다른 기구 엔지니어가 변경 사항을 확인할 수 있도록 하려면 다른 어셈블리와 마찬가지로 양쪽 모두 액세스할 수 있는 공용 저장소에 PCB 어셈블리를 저장하세요. 이 방법을 사용하면 MCAD 구속 조건이 유지됩니다. 또는 ECAD 설계자가 데이터를 ECAD로 풀하고 저장한 다음, 업데이트된 설계를 다시 MCAD로 푸시하도록 할 수 있습니다. 하지만 앞서 설명한 것처럼 이 방법을 사용하면 MCAD 구속 조건은 포함되지 않습니다.

  1. 또 다른 중요한 점은 여러 기구 엔지니어가 동일한 PCB 어셈블리에 적용한 변경 사항은 푸시 시 병합되지 않는다는 것입니다. 어떤 기구 엔지니어든 가장 최근에 푸시한 변경 사항이 다른 기구 엔지니어가 이전에 푸시한 변경 사항을 덮어쓰게 됩니다.

Altium 워크스페이스는 여러 MCAD 엔지니어가 변경 사항을 동기화하는 수단으로 사용하도록 만들어진 것이 아닙니다. 이러한 동기화는 적절한 MCAD 제품 데이터 관리 시스템을 통해 수행해야 합니다. 사용 가능한 PDM이 없어 Altium 워크스페이스를 사용하는 경우, MCAD 엔지니어 2가 MCAD 엔지니어 1의 변경 사항을 풀하여 확인하려면 ECAD 엔지니어가 먼저 해당 변경 사항을 풀하여 수락한 다음 업데이트된 보드를 워크스페이스로 다시 푸시해야 한다는 점을 기억하세요(아래 설명 참조).

그림으로 보는 동기화 프로세스

ECAD와 MCAD는 각자의 변경 사항을 워크스페이스의 서로 다른 저장 위치에 푸시합니다. 즉, 각 엔지니어는 상대 엔지니어가 푸시한 변경 사항만 풀할 수 있습니다. 자신의 변경 사항이 여기에 포함되려면 상대 엔지니어가 푸시하기 전에 해당 변경 사항을 이미 수락한 상태여야 합니다.

예를 들어 ECAD에서 보드를 생성하여 워크스페이스로 푸시한 다음 MCAD로 풀하는 경우입니다.

ECAD에서 설계를 변경합니다

변경 사항을 MCAD로 푸시하면(워크스페이스에 저장됨)

MCAD에서 해당 변경 사항을 풀할 수 있습니다

 

이후 ECAD 엔지니어가 컴포넌트를 추가하고 AND MCAD 엔지니어가 홀을 추가한 상태에서, AND 각자 자신의 보드를 푸시한 다음 상대방의 보드를 풀하면 CoDesigner는 MCAD 엔지니어의 보드에서 홀을 제거하고 ECAD 엔지니어의 보드에서 컴포넌트를 제거하려고 합니다.

ECAD와 MCAD 양쪽에서 변경 작업을 진행합니다

두 엔지니어가 상대방의 변경 사항을 풀하기 전에 각자의 변경 사항을 푸시하면

상대방의 설계 변경 사항이 손실됩니다

 

각 엔지니어는 제안된 변경 사항 중 특정 항목을 거부할 수 있습니다. 예를 들어 ECAD 엔지니어는 홀 추가는 수락하되 컴포넌트 삭제는 거부할 수 있습니다. 하지만 보드나 변경 사항이 복잡한 경우 이러한 방식은 관리하기 어려울 수 있습니다. 또 한 가지 유의할 점은 CoDesigner가 데칼에 대한 모든 변경 사항을 하나의 변경 사항으로 인식하므로, 개별적으로 수락하거나 거부할 수 없고 전체를 한꺼번에 수락하거나 거부해야 한다는 것입니다.

더 나은 방법은 아래와 같이 한 엔지니어가 변경 작업을 수행하고 보드를 푸시한 다음, 다른 엔지니어가 자신의 변경 작업을 시작하기 전에 해당 보드를 풀하는 것입니다.

 

 

 

 

 

 

 

 

 

ECAD와 MCAD 간 설계 변경 사항을 전달할 때는 순환 방식으로 진행하세요.

MCAD의 보드 형상에 필렛 및 모따기 포함하기

기구 엔지니어는 보드 모서리의 형상을 다듬기 위해 모따기와 필렛을 적용하는 경우가 많습니다. 이러한 요소가 MCAD에서 3D 개체로 정의되어 있으면, ECAD PCB Editor는 보드 형상을 두께가 있는 2D 객체로 정의하므로 CoDesigner가 이를 ECAD로 전송할 수 없습니다. 이를 해결하기 위해 CoDesigner는 이러한 3D 개체를 감지하면 2D 개체로 변환하여 보드 스케치에 포함하는 옵션을 제공합니다. 

Z축 방향 모서리에 적용된 3D MCAD 필렛과 모따기는 CoDesigner를 통해 2D로 변환하여 ECAD로 푸시할 수 있습니다.Z축 방향 모서리에 적용된 3D MCAD 필렛과 모따기는 CoDesigner를 통해 2D로 변환하여 ECAD로 푸시할 수 있습니다.

  • 필렛 및 모따기 변환은 단방향 프로세스라는 점에 유의하세요. 한 번 변환하면 더 이상 3D 개체로 편집할 수 없습니다. 
  • 3D 개체를 2D로 변환하는 기능은 초기에는 MCAD에서 보드 형상의 수직 모서리(Z축 방향 모서리)에 생성한 3D 필렛과 모따기를 지원합니다.
  • CoDesigner 3.9 이전 버전에서는 이러한 개체가 존재하면 기구 엔지니어에게 경고를 표시했지만, 해당 개체는 무시되었습니다.

필렛 및 모따기 지원 범위:

  • 반지름이 일정한 일반적인 원형 필렛을 지원합니다().
  • 모서리로부터의 거리가 동일하게 정의된 모따기(대칭 거리-거리)를 지원합니다().
  • 각도-거리() 또는 비대칭 거리-거리로 정의된 모따기는 지원하지 않습니다.
  • 직선이 아닌 측면 모서리에 정의된 필렛과 모따기, 또는 다른 필렛과 모따기 위에 정의된 필렛과 모따기는 지원하지 않습니다.
  • Rigid-Flex 설계에 정의된 필렛과 모따기는 지원하지 않습니다.

ECAD에서 보드 윤곽 문제 해결

ECAD에서 보드를 푸시하면 CoDesigner가 보드 윤곽을 확인하고, 미세 세그먼트 문제가 있거나 자체 교차하는 윤곽이 발견되면 사용자에게 경고합니다. 보드를 MCAD로 풀하면 CoDesigner가 이러한 문제의 해결을 시도합니다. 해결되지 않는 문제는 ECAD에서 해결해야 합니다.

미세 세그먼트 자동 제거

CoDesigner 2.4에는 보드 Outline의 미세 세그먼트를 감지하고 해결하는 자동 기능이 도입되었습니다. 미세 세그먼트가 감지되면 아래와 같이 문제 해결을 제안하는 대화상자가 나타납니다. Yes을 클릭하면 감지된 문제가 자동으로 해결됩니다. No을 클릭하고 대화상자를 닫으면 문제 위치를 자세히 보여 주는 오류 대화상자가 나타나며, 이 경우 아래 설명에 따라 수동으로 해결해야 합니다.

이 기능은 새로운 API를 사용하므로 Altium Designer 21.3.x 이상에서만 사용할 수 있습니다.

자동 기능으로는 보드 Outline 또는 보드 컷아웃에서 감지된 자체 교차를 해결할 수 없습니다. 이러한 문제는 아래에 설명된 수동 방법으로 해결할 수 있습니다.

미세 세그먼트 및 자체 교차 수동 제거

자동으로 해결되지 않았거나 보드 컷아웃에서 감지된 미세 세그먼트 및 자체 교차는 수동으로 해결해야 합니다.

ECAD에서 문제를 해결하려면:

  1. 문제가 있는 위치의 좌표를 참조할 수 있도록 대화상자의 오류 정보를 텍스트 편집기에 복사합니다.

  2. 꼭짓점 위치를 미세하게 변경할 수 있도록 Snap Grid(Gtrl+G 단축키)를 작은 값(예: 0.001 mil)으로 설정합니다.

  3. View » Board Planning Mode으로 전환합니다.

  4. 문제가 있는 위치를 확대합니다. 또는 Jump Location 명령(Edit » Jump » New Location 또는 J, L 단축키)을 사용하여 Jump to Location 대화상자에 좌표를 입력합니다. 현재 보드 단위와 다른 단위를 사용하는 경우 값에 단위(mm 또는 mil)를 포함할 수 있습니다. Arc로 인해 문제가 발생한 경우 문제 위치가 Arc의 중심점일 수 있습니다. 이 경우 보드 Outline에서 짧고 곡률이 작은 Arc가 있는지 육안으로 확인합니다.

  5. Design » Edit Board Shape 명령(D, D 단축키)을 실행합니다. 보드 Outline의 각 모서리 끝과 중앙에 꼭짓점이 표시됩니다. 서로 매우 가까이 있는 여러 꼭짓점과 곡률이 매우 작은 Arc가 있는지 확인합니다. 다음 팁을 참고하여 문제를 해결하세요.

    1. 모서리나 꼭짓점을 클릭하고 드래그하여 형상을 수정합니다. 편집 중에는 모서리 분할(Break edge), 모서리 이동(슬라이드)(Move (slide) edge), 모서리 굽히기(Incurvate (bend) edge)의 세 가지 형상 수정 모드를 사용할 수 있습니다. 편집 중 Shift+Space을 누르면 모드가 순환 전환됩니다. 현재 모드는 상태 표시줄에 표시됩니다.
    2. 짧은 모서리 끝의 꼭짓점을 약간 이동한 다음 마우스 버튼을 놓습니다. 대부분의 경우 이 작업만으로 소프트웨어가 짧은 모서리 문제를 해결하고 해당 모서리를 제거할 수 있습니다.
    3. 짧고 곡률이 작은 Arc는 Incurvate 모드에서 중앙 꼭짓점을 드래그하여 평평하게 만들면 직선 모서리로 변환할 수 있습니다. 마우스 버튼을 놓으면 직선 모서리로 대체됩니다.
    4. 이동 중인 모서리 또는 Arc의 현이 기존 모서리와 정렬되면 녹색 정렬 안내선이 표시됩니다.
    5. 꼭짓점을 클릭한 상태에서 Delete을 누르면 해당 꼭짓점이 제거됩니다. 꼭짓점을 추가하려면 Ctrl을 누른 상태로 모서리를 클릭한 다음 커서를 원하는 위치로 이동하고 놓습니다.

     

  6. 보드를 다시 푸시합니다.

보드를 MCAD로 푸시하려면 먼저 보드 윤곽의 자체 교차와 미세 세그먼트 문제를 해결해야 합니다.

위 동영상은 Altium Designer에서 보드 Outline 및 보드 컷아웃 문제를 해결하는 방법을 보여 줍니다. 다른 Altium 설계 소프트웨어에서도 절차는 기본적으로 동일합니다.

꼭짓점 편집 모드에 대해 자세히 알아보기

보드 형상 정의에 대해 자세히 알아보기

문제 하나를 해결하면 ECAD가 보드 또는 컷아웃의 전체 윤곽을 다시 계산하며, 이 과정에서 다른 문제가 자동으로 해결될 수 있습니다. 따라서 문제를 하나 해결할 때마다 푸시하는 것이 좋습니다.

PCB의 이전 리비전을 MCAD로 풀하기

ECAD 보드를 빈 MCAD 어셈블리로 풀하려면 Altium CoDesigner Panel에서 Pull 버튼을 클릭하여 Select Project from Company Workspace 대화상자를 엽니다. 기본적으로 이 대화상자에는 마지막으로 푸시된 보드가 표시됩니다. PCB 설계의 이전 릴리스 또는 리비전을 열어야 하는 경우 대화상자의 ECAD Push to Open 섹션에서 변경을 클릭하여 Select Push 대화상자i를 엽니다.

이 대화상자에는 이전의 모든 푸시가 나열됩니다. 필요한 항목을 선택하고 OK을 클릭합니다. ECAD 커밋에 태그가 지정되어 있는 경우 Select Push 대화상자에서 Only show tagged commits 옵션을 활성화하여 목록을 빠르게 필터링할 수 있습니다.

Select Push 대화상자를 사용하여 ECAD에서 푸시된 모든 리비전 중 원하는 이전 리비전을 선택합니다.Select Push 대화상자를 사용하여 ECAD에서 푸시된 모든 리비전 중 원하는 이전 리비전을 선택합니다. 

  • 워크스페이스는 MCAD로 처음 풀한 이후부터 자동 푸시를 수행합니다. 자동 푸시에 대해 자세히 알아보세요.

ECAD 측 변경 사항 표시

MCAD 소프트웨어에서는 PCB 어셈블리가 장착될 Parent 장치/어셈블리가 아니라 PCB 어셈블리 자체를 열어야 합니다. PCB 어셈블리를 열면 ECAD 측에서 변경하고 푸시한 내용이 Altium CoDesigner Panel에 자세히 표시됩니다. Parent 장치/어셈블리를 열면 Panel에 변경 사항이 자세히 표시되지 않습니다.

ECAD에서 PCB 어셈블리 변경 사항 가져오기

  1. MCAD에서 PCB 어셈블리를 별도 파일로 엽니다(루트 어셈블리로 열기).
  2. Altium CoDesigner Panel을 엽니다.
  3. Pull을 클릭합니다.
  4. 표에서 변경 사항을 검토하고 적용할 항목을 활성화한 다음 Apply 버튼을 클릭합니다.

ECAD에서 MCAD로 전송되기 전에 3D 컴포넌트 모델은 Parasolid 형식으로 변환됩니다(MCAD에서 3D 모델의 이름이 지정되는 방식에 대해 자세히 알아보기). 일부 모델은 변환되지 않을 수 있습니다. 이러한 모델은 MCAD에서 해당 모델의 바운딩 박스로 대체되며, CoDesigner가 이에 대한 경고 메시지를 표시합니다.

또는 ECAD에서 이러한 모델을 싱글 바디 Parasolid 모델로 대체할 수 있습니다. 이 모델은 변환 없이 ECAD와 MCAD 간에 직접 전송됩니다. 문제가 있는 모델 해결에 대해 자세히 알아보세요.

MCAD에서 PCB 어셈블리를 처음 열었을 때

  1. PCB 어셈블리를 장치의 어셈블리에 추가합니다.
  2. 적절한 mates/구속조건을 적용하여 고정합니다.

If a contour of the PCB does not correspond to the shape of your enclosure:

  1. 보드 파트 편집을 시작합니다.
  2. 보드 돌출부의 스케치를 편집하고 인클로저에 맞게 형상을 조정합니다.

PCB 형상을 변경하는 한 가지 방법은 전체 Outline을 삭제한 다음, 인클로저의 해당 윤곽에서 오프셋을 적용하여 처음부터 다시 만드는 것입니다.

MCAD에서 PCB 설계 변경하기

다음은 MCAD에서 사용한 설계 형상과 객체가 보드를 ECAD로 푸시할 때 지원되도록 하기 위한 몇 가지 팁입니다.

보드 Outline 형상 편집하기

  1. 보드 파트 편집을 시작합니다.
  2. 보드 돌출부의 스케치를 편집합니다.

Notes:

  • Creo 및 Inventor의 보드 Outline 스케치나 SolidWorks의 Rigid-Flex 보드 Outline 스케치에 내부 윤곽을 포함하지 마세요. 컷아웃과 홀에는 각각 돌출 컷 또는 홀 피처를 사용하세요.

  • Inventor의 보드 Outline 스케치에 여러 프로파일을 만들지 마세요. CoDesigner가 이를 예측할 수 없는 방식으로 해석할 수 있습니다.

  • Autodesk Fusion에서 Project 명령으로 기존 인클로저 윤곽을 투영하여 MCAD에서 보드 형상을 다시 만드는 경우, Autodesk Fusion의 PROJECT 대화 상자에서 Projection Link 옵션을 비활성화해야 합니다. Projection Link 옵션이 활성화되어 있으면 참조 윤곽의 크기가 변경될 때마다 투영된 윤곽의 크기도 자동으로 변경됩니다. 현재 CoDesigner는 이 기능을 지원하지 않습니다.

MCAD 보드 원점 변경하기

  1. 필요한 경우 기구 엔지니어는 보드 정의 초기 단계에서 베어 보드의 MCAD 원점을 변경할 수 있습니다. 이를 위해 보드 파트 내에서 보드 Outline의 전체 sketch을(를) 이동하거나 다시 그리면 됩니다. 보드 파트는 보드 어셈블리 내에서 “고정” 제약 조건이 적용되어 있으며, 파트의 원점은 어셈블리의 원점과 일치합니다. 따라서 “MCAD 원점”은 보드 파트 원점과 보드 어셈블리 원점 모두를 의미합니다.

예측할 수 없는 변경이 발생할 수 있으므로 이 제약 조건을 수정하거나 해제하지 않을 것을 강력히 권장합니다.

Notes:

  • 컴포넌트가 이미 배치되어 있다면 보드 어셈블리 내에서 그에 맞게 이동해야 합니다.
  • ECAD의 “전기적” 보드 원점은 별도로 처리되므로 변경되지 않습니다.

장착 홀 생성/편집하기

  1. 보드 파트 편집을 시작합니다.
  2. 보드 파트의 윗면이나 아랫면에 Hole 피처를 생성/편집합니다.

Notes:

  • 피처 패턴은 지원되지 않습니다.
  • 홀 위치가 보드 가장자리를 기준으로 정의된 경우, 이후 ECAD에서 보드 Outline을 수정하고 MCAD로 다시 가져오면 이러한 관계가 사라집니다. 홀 작업에 대한 자세한 내용은 아래의 제약 조건 및 치수 작업하기 섹션을 참조하세요.

컷아웃 생성/편집하기

  1. 보드 파트 편집을 시작합니다.
  2. 보드 파트의 윗면이나 아랫면을 기준으로 Extruded Cut 피처를 생성/편집합니다.

Notes:

  • PTC Creo 또는 Autodesk Inventor에서는 여러 윤곽이 포함된 스케치를 지원하지 않으므로 사용하지 마세요.*
  • 피처 패턴은 지원되지 않습니다.
  • 돌출 컷의 스케치가 보드 가장자리를 기준으로 정의된 경우, 이후 ECAD에서 보드 Outline을 수정하고 MCAD로 다시 가져오면 이러한 관계가 사라집니다.

컴포넌트 배치 편집하기

  1. 보드 어셈블리 편집을 시작합니다.
  2. 컴포넌트를 이동/회전/뒤집거나 메이트/제약 조건을 적용합니다.

Notes:

  • MCAD에서 컴포넌트를 이동해도 컴포넌트 홀과 실크스크린은 함께 이동하지 않습니다. 이와 같이 컴포넌트에 종속된 변경 사항을 반영하려면 보드를 ECAD로 푸시하고 그곳에서 변경 사항을 적용한 다음, ECAD에서 MCAD로 보드를 다시 푸시하여 컴포넌트 홀과 실크스크린을 업데이트하세요.
  • ECAD에서 보드 형상을 수정하면 보드 가장자리를 참조하는 MCAD mates/제약 조건이 해제될 수 있습니다.

MCAD의 고정 또는 제약 상태를 ECAD의 잠금 상태와 동기화하기

MCAD에서 컴포넌트가 고정되어 있거나 제약 조건이 적용되어 있으면 ECAD에서 잠금 상태가 됩니다(해당 제약 조건이 PCB 어셈블리 내에서 이동을 허용하는지 여부와 무관). ECAD에서 컴포넌트가 잠겨 있으면 MCAD에서 이미 제약 조건이 적용되어 있지 않은 한 고정 상태가 됩니다. 잠금/고정 상태의 변경 사항은 MCAD와 ECAD 간에 동기화됩니다.

ECAD 컴포넌트 파라미터를 MCAD로 전송하기

ECAD PCB 컴포넌트 파라미터는 MCAD에서 생성된 해당 모델로 전송됩니다. 단, 원래 MCAD에서 배치한 컴포넌트는 포함되지 않습니다.

MCAD에서 제약 조건 및 치수 작업하기

보드 Outline에 적용된 제약 조건

  1. 기구 엔지니어는 보드 Outline의 요소에서 다른 보드 Outline 요소, 데이텀/참조 피처, 상위 어셈블리의 파트 또는 컴포넌트로 제약 조건을 적용할 수 있습니다. CoDesigner는 이러한 제약 조건을 수정하지 않습니다. 그러나 ECAD 측에서 보드 Outline이 변경되면 MCAD에서 보드 파트의 스케치가 다시 그려지고 모든 가장자리 ID가 변경됩니다. ECAD에서 보드 Outline의 어느 부분이든 변경하면 MCAD에서 전체 보드가 다시 그려지고 모든 보드 가장자리 ID가 변경된다는 점에 유의하세요. 해당 가장자리나 그로부터 파생된 면에 제약 조건이 적용되어 있었다면 해당 제약 조건이 해제됩니다. MCAD에서 보드는 제자리에 유지되며, 필요한 경우 제약 조건을 수동으로 복원할 수 있습니다.

제약 조건을 다시 정의하는 데 걸리는 시간을 고려하면 only make changes to the board outline in MCAD을(를) 권장합니다.

Note: CoDesigner는 기구 엔지니어 간에 변경 사항을 전달하는 데 사용할 수 없다는 점을 기억하세요(기구 엔지니어 간 변경 사항 동기화하기 참조).

컴포넌트에 적용된 제약 조건

  1. 기구 엔지니어는 컴포넌트에서 보드, 인클로저 또는 다른 컴포넌트로 제약 조건을 적용할 수 있습니다. 해당 컴포넌트의 모델을 로컬에서 찾을 수 있다면 이러한 제약 조건은 정상적으로 유지됩니다(다른 폴더에서 PCB 어셈블리를 처음부터 생성하지 않거나 모델 저장용 공용 폴더가 설정되어 있는 경우). 그러나 ECAD 측에서 컴포넌트가 이동하면 MCAD 측의 배치 변경이 해당 이동과 일치하지 않을 수 있으므로 수동으로 확인해야 합니다(이러한 상황에서는 CoDesigner가 알림을 제공합니다). ECAD 풋프린트가 있는 컴포넌트의 경우 컴포넌트 스탠드오프(Z 방향의 보드 표면 기준 위치)는 항상 풋프린트 내 STEP 모델의 위치에 따라 정의됩니다. MCAD로 풀할 때 CoDesigner는 충돌하는 MCAD 제약 조건을 항상 재정의하려고 시도합니다.

Note: mates/제약 조건을 적용하는 위치에 주의하세요. 예를 들어 PCB 어셈블리를 장치 어셈블리 내에 고정하지 않은 상태에서 PCB 컴포넌트와 인클로저 사이에 제약 조건/메이트를 적용하면 설계에 예측할 수 없는 변경이 발생할 수 있습니다.

MCAD에서 ECAD로 전송되지 않는 변경 사항

  • 베어 보드 두께 - ECAD의 레이어 스택에서 정의됩니다.

    Note: MCAD에서 변경한 보드 두께는 ECAD에서 적용할 수 없는 변경 사항으로 표시되므로, ECAD 설계자는 제안된 변경 사항을 확인할 수 있습니다.

  • 일정한 반경으로 정의된 3D 필렛 및 모서리로부터 동일한 거리로 정의된 3D 모따기 (z축 방향으로 정의됨)가 지원되며, 보드의 z축 방향으로 생성된 구멍과 돌출 컷도 지원됩니다. 각도-거리 모따기와 같이 보드 파트에 적용된 그 밖의 3D 형상 피처는 무시됩니다. 필렛 및 모따기 작업에 대해 자세히 알아보세요.
  • 보드의 z축 방향으로 생성된 구멍과 돌출 컷을 제외하고, 보드 파트에 적용된 그 밖의 형상 피처(예: 3D 모따기/필렛).
  • 보드 어셈블리 컨텍스트에서 생성된 그 밖의 형상 피처(예: 어셈블리 컨텍스트에서 생성된 구멍). 단, 해당 피처가 파트로 전파된 경우는 제외됩니다.
  • 컴포넌트와 별도로 이동한 컴포넌트 구멍의 위치.
  • 컴포넌트 구멍의 크기.
  • 피처 패턴.
  • 여러 윤곽선이 있는 컷아웃 스케치(PTC Creo 및 Autodesk Inventor).
  • 돌출된 구리에 대한 변경 사항.
  • 실크스크린에 대한 변경 사항.
  • 컴포넌트 삭제. 컴포넌트의 위치 변경은 ECAD로 전송되므로, MCAD 엔지니어는 컴포넌트를 보드 영역 밖으로 이동하여 삭제를 표시할 수 있습니다(컴포넌트 삭제가 지원되지 않는 이유 알아보기). 

장치 어셈블리 컨텍스트에서 작업하기

CoDesigner 2.2.0에서는 MCAD의 장치 어셈블리 수준에서 작업한 다음 인클로저를 보드와 함께 ECAD로 전송하는 기능이 추가되었습니다. 아래 동영상은 보드 어셈블리를 장치 인클로저에 포함하고 인클로저를 ECAD로 전송하는 과정을 보여줍니다.

설치된 MCAD CoDesigner에서 인클로저 교환 기능을 사용할 수 있는지 확인하려면 오른쪽 창의 Note을 참조하세요. 이 기능을 사용할 수 없는 경우, 이 동영상에서 인클로저를 전송하는 대체 방법을 확인할 수 있습니다.

장치 어셈블리 컨텍스트에서의 작업 개요.

인클로저 작업 팁:

  • 보드 어셈블리를 인클로저에 배치한 후 Altium CoDesigner 패널에서 Recognize 버튼을 클릭합니다. CoDesigner는 보드와 인클로저 간의 관계를 감지하고, 장치 인클로저에 추가된 모든 보드 어셈블리의 이름을 패널 상단에 표시합니다.

  • 관계가 감지되면 마지막 단계로 인클로저를 보드에 추가합니다. 방법은 다음과 같습니다.

    • 모델 트리에서 인클로저를 선택합니다.
    • Altium CoDesigner 리본을 표시합니다.
    • 리본에서 Enclosure 버튼을 클릭합니다.
    • Altium CoDesigner 패널을 열거나 표시한 다음, Altium CoDesigner 패널의 Board Enclosure 섹션에서 인클로저가 보드에 연결되어 있는지 확인합니다.
  • 이제 보드와 함께 인클로저를 ECAD로 푸시할 수 있습니다.

변경 사항이 포함된 PCB 어셈블리를 ECAD로 보내기

  • MCAD에서 PCB 어셈블리가 별도의 문서(루트 어셈블리)로 열려 있는지 확인합니다.
  • Altium CoDesigner 패널로 이동합니다.
  • Push를 클릭합니다.

* 이 동작은 향후 업데이트에서 개선될 예정입니다.

MCAD 데이터 관리 시스템 사용하기

설치된 MCAD CoDesigner에서 ECAD-MCAD 컴포넌트 연결 기능을 사용할 수 있는지 확인하려면 오른쪽 창의 Note을 참조하세요.

CoDesigner는 PCB를 ECAD에서 푸시하고 MCAD로 풀할 때 네이티브 MCAD 컴포넌트를 배치하는 기능을 지원합니다. 이를 위해 CoDesigner는 MCAD 소프트웨어에 MCAD 데이터 관리 시스템에서 모델 이름을 기준으로 컴포넌트 모델을 가져오도록 요청한 다음, ECAD에서 가져온 모델 대신 해당 컴포넌트를 MCAD PCB 어셈블리에 배치합니다.

현재 ECAD-MCAD 네이티브 컴포넌트 연결은 다음 환경에서 지원됩니다.

  • ECAD 컴포넌트와 네이티브 MCAD 컴포넌트 간의 연결은 Altium 워크스페이스에서 정의됩니다. ECAD 컴포넌트에서 MCAD 컴포넌트로 연결하기에 대해 자세히 알아보세요.
  • Altium 워크스페이스는 여러 MCAD 엔지니어 간에 변경 사항을 동기화하기 위한 수단으로 사용하도록 설계되지 않았습니다. 동기화는 적절한 MCAD 제품 데이터 관리 시스템을 통해 수행해야 합니다. 사용 가능한 PDM이 없어 Altium 워크스페이스를 사용하는 경우, MCAD 엔지니어 2가 변경 사항을 풀하여 확인하려면 먼저 ECAD 엔지니어가 MCAD 엔지니어 1의 변경 사항을 풀하여 수락한 다음, 업데이트된 보드를 워크스페이스로 다시 푸시해야 합니다.

SOLIDWORKS PDM 사용하기

CoDesigner는 SOLIDWORKS® PDM Professional 환경에서 개발 및 테스트되었습니다.

SOLIDWORKS PDM에서 네이티브 MCAD 컴포넌트 배치하기

보드 설계가 ECAD에서 SOLIDWORKS MCAD로 전송될 때, CoDesigner는 ECAD 컴포넌트를 SOLIDWORKS PDM 시스템의 동등한 네이티브 MCAD 컴포넌트로 대체하는 기능을 지원합니다. 이를 위해 다음 설정을 구성해야 합니다.

  • MCAD - 여기에 설명된 대로 PDM 설정과 CoDesigner 모델 저장소를 구성하고 동기화 요구 사항을 파악합니다.
  • ECAD - 올바른 구문을 사용하여 ECAD 컴포넌트에서 MCAD 모델을 참조합니다. MCAD 컴포넌트 참조는 ECAD 컴포넌트에 파라미터로 정의해야 하며, 파라미터 값은 다음 형식을 사용해야 합니다.
    <vault>:folder\folder\component.sldprt 여기서 <vault>은 SOLIDWORKS PDM 볼트의 이름입니다.
  • Workspace - 네이티브 MCAD 컴포넌트를 사용하도록 워크스페이스 옵션을 구성하고, 동등한 MCAD 컴포넌트를 참조하는 데 사용할 ECAD 컴포넌트 파라미터를 정의합니다. ECAD 컴포넌트에서 MCAD 컴포넌트로 연결하기에 대해 자세히 알아보세요.

기존 PCB 어셈블리로 변경 사항을 풀하기 전

  • 모델 저장용 공통 폴더 컴포넌트 폴더의 로컬 사본을 서버와 동기화합니다(SOLIDWORKS PDM의 Get latest version 명령 사용).
  • 다음 파일을 체크아웃합니다.
    • 보드 어셈블리
    • 보드 파트
    • Rigid-Flex 2.0 어셈블리의 경우 - 모든 보드 파트 및 하위 어셈블리
    • 3D 구리가 생성된 경우 - 3D 구리 및 솔더 마스크와 관련된 어셈블리 및 파트
    • PDM에 저장된 경우 데칼 PNG

Note: 일반적으로 컴포넌트 모델을 PDM에서 체크아웃할 필요는 없습니다.

ECAD에서 MCAD로 변경 사항을 가져올 때

  • CoDesigner가 적용하려는 컴포넌트 속성 변경 사항에 주의하십시오. 해당 문자열은 SOLIDWORKS의 Altium CoDesigner Panel에 있는 변경 사항 목록 표에서 노란색으로 강조 표시됩니다.

변경 사항이 발생하는 일반적인 이유는 MCAD에서 컴포넌트 모델을 생성할 때 CoDesigner가 ECAD의 컴포넌트 라이브러리에 저장된 컴포넌트 속성을 MCAD 모델 속성에 기록하기 때문입니다. 그러나 이러한 속성 중 일부(예: Description 및 Material)는 이후 MCAD 또는 PDM에 의해 자동으로 변경될 수 있습니다. 따라서 속성값의 차이가 감지되면 CoDesigner는 해당 값을 변경하도록 제안합니다.

그러나 이러한 변경 사항을 적용하려고 하면 MCAD는 영향을 받는 각 모델을 PDM에서 체크아웃하거나 다른 이름으로 저장하도록 요구합니다. 이를 방지하려면 Altium CoDesigner Panel에서 컴포넌트 속성 변경과 관련된 변경 사항의 체크를 해제하십시오. 컴포넌트 속성이 서로 다른 이유를 확인하고 MCAD와 ECAD 양쪽의 속성을 동기화하는 것이 좋습니다.

변경 사항 적용 후

  • 새로 생성된 컴포넌트, 보드 어셈블리, 하위 어셈블리 및 부품을 PDM에 체크인하십시오.

MCAD PCB 복제

기계적 치수와 참조를 유지하면서 기존 MCAD PCB 어셈블리를 복제하여 새 PCB 프로젝트에서 재사용하고 싶으신가요? MCAD 어셈블리의 복제본에서 두 가지 속성을 편집하면 가능합니다.

MCAD PCB 어셈블리는 ManagedProjectGUID 및 ManagedProjectName 두 속성을 통해 ECAD 프로젝트와 연결됩니다. 이 속성은 MCAD PCB 어셈블리의 Properties 대화 상자에서 확인하고 편집할 수 있습니다. 아래 이미지는 SOLIDWORKS의 Properties 대화 상자를 보여줍니다.

두 속성이 MCAD 어셈블리를 ECAD 프로젝트에 연결합니다.두 속성이 MCAD 어셈블리를 ECAD 프로젝트에 연결합니다.

  1. 기존 MCAD PCB 어셈블리를 새 ECAD 프로젝트와 연결하려면 MCAD 어셈블리에서 이 속성들을 새 ECAD 프로젝트에 맞게 업데이트해야 합니다.
  • ManagedProjectName - ECAD PCB 프로젝트 파일 이름: <ManagedProjectName>.PrjPcb

  • ManagedProjectGUID - GUID는 다음 중 한 곳에서 찾아 복사할 수 있습니다.

    1. 워크스페이스 브라우저 주소 표시줄 – 프로젝트가 저장된 Altium 워크스페이스를 연 다음, 프로젝트를 두 번 클릭하여 별도의 브라우저 탭에서 엽니다. 브라우저 주소 표시줄의 URL에는 ManagedProjectGUID ()가 포함되어 있습니다. 또는 다음 위치에서 복사할 수 있습니다.

    2. ECAD 프로젝트 파일 – 텍스트 편집기에서 프로젝트 파일을 엽니다(확장자는 .PrjPcb입니다). ManagedProjectGUID는 파일 상단의 [Design] 섹션에 있습니다(). ManagedProjectGUID를 복사하되, 텍스트 편집기에서 파일을 do not modify or save .PrjPcb.

  1. MCAD 소프트웨어에서 MCAD PCB 어셈블리를 열고, 두 속성의 Value를 편집한 다음, MCAD 어셈블리를 저장하고 닫습니다.

  2. 복제된 MCAD 어셈블리를 다시 열고 Altium CoDesigner Panel 상단을 확인합니다. 이제 1단계에서 복제 파일에 입력한 ManagedProjectName 속성이 표시되어야 합니다. 해당 속성이 표시되면 복제가 성공한 것이며, 이제 MCAD 소프트웨어에서 보드 정의를 워크스페이스로 Pushed할 수 있습니다.

    ManagedProjectName 및 ManagedProjectGUID 속성을 편집하면 CoDesigner Panel에 업데이트된 프로젝트 이름이 반영됩니다.ManagedProjectName 및 ManagedProjectGUID 속성을 편집하면 CoDesigner Panel에 업데이트된 프로젝트 이름이 반영됩니다.

 

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

Contents