Integracja z PLM
Połączone rozwiązanie projektowe Altium Designer oraz obszaru roboczego Altium 365 oferuje konfigurowalną integrację PLM z dostępną obsługą systemów Windchill®, Arena®, Oracle® Agile™, Aras Innovator® oraz Siemens Teamcenter® (z dodatkową konfiguracją). Konfiguracja integracji PLM jest wykonywana za pośrednictwem interfejsu przeglądarkowego obszaru roboczego Altium 365, który udostępnia zautomatyzowany interfejs do łatwego konfigurowania połączenia, mapowania danych parametrów oraz określania kierunku synchronizacji danych. Po skonfigurowaniu interfejsu funkcje i możliwości integracji PLM są dostępne podczas pracy w następujących odrębnych obszarach:
-
Library (komponenty) – umożliwia jednokierunkową lub dwukierunkową synchronizację komponentów, parametrów komponentów i wyborów części między obszarem roboczym Altium 365 a instancją PLM. Konfiguracja pozwala określić, które parametry są nadrzędnie zarządzane w którym systemie. Dodatkowo parametry pozycji umożliwiają aktualizację właściwości po stronie Workspace (konfigurowalnie dla każdego pola), bez konieczności formalnego zwalniania nowej rewizji tego elementu komponentu. Dostępny jest również dedykowany workflow żądania części, który obsługuje automatyczne tworzenie komponentu w instancji PLM, a także propagację wygenerowanych numerów części PLM z powrotem do komponentów po stronie Workspace.
-
Design (projekty) – dostępny jest dedykowany workflow tworzenia projektów, który obsługuje również automatyczne tworzenie numerów części w instancji PLM, a następnie propagację tych parametrów z powrotem do projektu. Takie parametry mogą być używane w specjalnych ciągach (np. do adnotacji obramowania arkusza). Masz możliwość publikowania projektu do instancji PLM w ramach uruchamiania Project Releaser w Altium Designer. Operacja publikowania używa szablonu publikowania — zdefiniowanego jako część konfiguracji integracji instancji PLM — do sterowania sposobem propagacji danych do PLM. Jeśli publikujesz po raz pierwszy i numery części (po stronie PLM) nie są jeszcze skojarzone z projektem, te numery części zostaną utworzone w PLM i skojarzone z projektem w ramach tej początkowej publikacji. Masz również możliwość definiowania wpisów komponentów dla komponentów w instancji PLM jako części operacji publikowania (opcjonalnie, zależnie od konfiguracji). I zawsze będziesz mógł dokładnie zobaczyć, co zostało utworzone, na przykład numery części w instancji PLM, jako część historii workflow procesu (History karta).
Obsługa PLM
Obszar roboczy Altium 365 zapewnia obsługę następujących systemów PLM:
-
PTC Windchill® PLM w wersjach 12, 13 oraz PTC Windchill+ (wariant SaaS systemu Windchill).
-
Arena® PLM.
-
Oracle® Agile™ PLM.
-
Aras Innovator® Release 30.
Additional Setup for Aras Innovator
Aby uzyskać integrację PLM z Aras Innovator, serwer Altium Workspace musi zostać zarejestrowany w konfiguracji Aras Authentication przez dodanie nowej sekcji węzła do rejestru klienta. Po zarejestrowaniu przyznawany jest unikalny token OAuth dla podłączonego Workspace, umożliwiający uwierzytelnienie dostępu.
Wymagane zmiany w konfiguracji Aras Innovator wprowadza się przez edycję pliku rejestru klienta OAuth:
-
Na komputerze hosta Aras otwórz plik
\OAuthServer\OAuth.configdo edycji. -
Znajdź i skopiuj sekcję IOMApp — od wiersza
<clientRegistry id="IOMApp" enabled="true">do wiersza</clientRegistry>. -
Wklej skopiowaną sekcję IOMApp bezpośrednio za nią, aby utworzyć nową (zduplikowaną) sekcję.
-
W tej nowej sekcji węzła zmień nazwę
IOMAppnaNEXUS— w wyniku czego otrzymasz<clientRegistry id="NEXUS" enabled="true">.
-
Zapisz zmiany, a następnie uruchom ponownie komputer Aras.
- Siemens Teamcenter®, z dodatkową konfiguracją integracji.
- Duro PLM, zaimplementowany jako instancja PLM strony trzeciej — patrz obsługa PLM stron trzecich poniżej.
Wybór interfejsu konfiguracji PLM
Połączenie obszaru roboczego Altium 365 z obsługiwanym systemem PLM można ustanowić za pomocą zaawansowanego, częściowo zautomatyzowanego interfejsu użytkownika, opisanego poniżej, lub za pomocą procesu ręcznego opartego na edycji plików XML konfiguracji PLM. Ta druga metoda wymaga znajomości struktur danych docelowego systemu PLM oraz formatu XML, podczas gdy zaktualizowany system przedstawiony poniżej automatycznie pobiera wymagane dane z PLM i Altium Workspace, aby wypełnić opcje menu w interfejsie.
Możesz ponownie skonfigurować Workspace tak, aby prezentował poprzedni interfejs PLM — oparty na ręcznej edycji plików XML — przez odznaczenie opcji Enable new PLM Configuration page na stronie Admin – Settings – PLM Integration w interfejsie Workspace. Pamiętaj, aby zapisać zmianę, a następnie wylogować się i zalogować ponownie.
Łączenie z instancją PLM
Konfiguracje PLM są tworzone i zarządzane na stronie Admin – PLM Integration w interfejsie przeglądarkowym Workspace. Po pomyślnym połączeniu z systemem PLM interfejs konfiguracji udostępni szereg opcji integracji opartych na danych pobranych zarówno z Workspace, jak i z podłączonego PLM.
Użyj przycisku
, aby rozpocząć proces połączenia, i postępuj zgodnie z instrukcjami pokazanymi w poniższym pokazie slajdów.
Wszelkie błędy łączności zostaną wyróżnione na czerwono podczas logowania do docelowego systemu PLM. Dolna krawędź pola wyróżnienia będzie zawierać szczegóły błędu — zobacz przykład.
PTC Windchill SSO Support
Dostępna jest możliwość użycia autoryzacji Single Sign On (SSO) podczas łączenia z systemem Windchill PLM; konfigurację przeprowadza się za pośrednictwem interfejsu Workspace. Zapewnia to uproszczoną i bezpieczną metodę autoryzacji połączenia podczas wykonywania procesów Workspace PLM, takich jak tworzenie projektu i publikowanie do PLM. W praktyce rozwiązanie to pozwala na przyznanie dostępu do Windchill przy użyciu standardu delegacji OAuth za pośrednictwem usługi dostawcy tożsamości, takiej jak PingFederate.
Dostęp do konfiguracji SSO jest dostępny na karcie OAuth na stronie PLM Integration Workspace (Admin - PLM Integration), gdzie można dodać wiele instancji dostawców OAuth.
Konfiguracja autoryzacji dostawcy OAuth jest wykonywana na podstawie danych dostępnych u skonfigurowanego dostawcy tożsamości. Wprowadź nazwę oraz informacje wymagane przez Workspace — identyfikatory, tokeny, adresy URL itd. — w polach strony, a następnie zapisz ukończoną konfigurację.
Nowa instancja dostawcy OAuth staje się dostępna po włączeniu opcji OAuth Connection w konfiguracji Windchill PLM. Wybierz ją z listy rozwijanej OAuth Provider, jeśli dostępnych jest wielu dostawców. Dokończ konfigurację połączenia przyciskiem
i w razie potrzeby postępuj zgodnie z monitami dostawcy.
Obsługa PLM stron trzecich
Obszar roboczy Altium 365 zapewnia dodatkową obsługę konfiguracji „nienatywnych” systemów PLM opracowanych przez strony trzecie. Obsługa ta jest realizowana przez dodatek Altium Generic Connector, który wymaga licencji Altium 365 PLM Generic Connector Addon.
Podczas dodawania instancji Workspace PLM dla takiego systemu do konfiguracji tej instancji PLM przesyłane są za pośrednictwem interfejsu PLM Integration wstępnie skonfigurowane pliki XML dostarczone przez stronę trzecią.
Konfiguracja ustawień
Po pomyślnym połączeniu z instancją PLM interfejs Workspace PLM oferuje ustawienia konfiguracyjne do definiowania sposobu synchronizacji komponentów, wzajemnego mapowania parametrów komponentów oraz metody transferu danych Part Choices. Te opcje synchronizacji są dostępne na karcie Configuration interfejsu.
Dostępne opcje ustawień konfiguracyjnych (oraz ich etykiety/funkcjonalność) zależą od typu systemu PLM oraz danych parametrycznych pobranych zarówno z Workspace, jak i z podłączonej instancji PLM.
Parametry synchronizacji
Ta sekcja interfejsu PLM definiuje, które typy komponentów będą synchronizowane, gdzie i w jaki sposób mają być tworzone/aktualizowane nowe komponenty oraz wszelkie ograniczenia oparte na kryteriach parametrów.
Sposób synchronizacji komponentów określa się indywidualnie:
- Wybierz Altium Component Type na liście parametrów i ustaw jego opcję Sync Direction zgodnie z potrzebami (do Altium/PLM lub do obu) — opcje typów komponentów pochodzą z bieżących danych komponentów Workspace.
- Wybierz powiązaną nazwę atrybutu PLM z menu PLM Type — dostępne opcje pochodzą z podłączonej instancji PLM.
- W polu Altium Target Folder (w sekcji Sync to Altium) przejdź do folderu komponentów Workspace i wybierz go jako lokalizację synchronizacji dla tego komponentu.
- Określ Sync Mode, aby zdecydować, czy podczas synchronizacji będą tworzone nowe komponenty, czy aktualizowane tylko istniejące — albo oba te działania.
-
Ustaw Component Template, które będą używane do definiowania typów parametrów komponentu podczas synchronizacji tego komponentu. To ustawienie domyślnie przyjmie wybrane Altium Component Type (na przykład;
Capacitors), jeśli dostępny jest powiązany szablon Workspace. - Użyj opcji Add Parameter Criteria, aby określić wartość parametru, która będzie ograniczać synchronizację. Komponent nie zostanie zsynchronizowany, jeśli nie spełni tego kryterium. W razie potrzeby dodaj kolejne kryteria parametrów.
Dodatkowe opcje są dostępne po połączeniu z systemem PTC Windchill PLM, które obsługują system PartsLInk firmy Windchill. System PartsLink umożliwia klasyfikowanie części w grupach w celu wygodniejszego i szybszego ich wskazywania, a także może obejmować powiązane pary atrybut/wartość w celu dalszego doprecyzowania w ramach tej klasyfikacji. Więcej informacji znajduje się w rozwijanej sekcji poniżej.
-
Wybierz Add Classification Name Criteria z menu Filter Criteria, aby dodać filtr klasyfikacji. Użyj menu nazwy, aby wybrać grupę klasyfikacji, według której będzie filtrowana synchronizacja.
-
Aby uzyskać dokładniejszą kontrolę, wybierz opcję Add Classification Attribute Criteria i określ Attribute klasyfikacji oraz powiązaną z nią wartość. W pokazanym tutaj przykładzie tylko kondensatory z klasy
102-Capacitorso wartościCapacitancerównej10uFbędą synchronizowane.
More on Windchill PartsLink
W samym Windchill klasyfikacja PartsLink jest definiowana przez utworzenie binding attribute, który może zostać zastosowany do typu części. Następnie do zdefiniowanej klasy klasyfikacji dodawany jest atrybut klasyfikacji części.
Wpisy komponentów w Windchill będą zawierały zdefiniowaną klasyfikację oraz wszelkie określone parametry atrybutów klasyfikacji, które z kolei są dostępne dla procesu synchronizacji komponentów Workspace PLM.
Gdy wpis komponentu zostanie zsynchronizowany z Windchill do Workspace i w konfiguracji PLM Workspace określono interakcję z PartsLink, atrybuty konfiguracji Windchill dla tej części zostaną przeniesione do Altium Designer.
Gdy Sync Direction jest ustawione jako To PLM lub dla synchronizacji dwukierunkowej (To PLM & To Altium), opcja Add Filter Criteria jest prezentowana w sekcji Sync To PLM. Użyj tej opcji, aby ustawić kryteria parametrów lub folderów, które będą kontrolować, które komponenty Workspace są propagowane do systemu PLM.
Można dodać wiele kryteriów parametrów, aby ściśle ograniczyć synchronizację komponentów Workspace do PLM. Dostępne kryteria obejmują także opcje klauzul OR i NOT, zapewniające bardziej precyzyjną kontrolę filtrowania komponentów akceptowanych do synchronizacji z PLM.
Sekcja Sync to PLM udostępnia dodatkowe opcje numeracji części oraz prefiksów/sufiksów podczas pracy z systemem Arena PLM. Te predefiniowane schematy PLM są dostępne do wyboru w menu Numbering Scheme i Code i określają format numeru pozycji części przesyłanych do Arena.
Mapowanie parametrów komponentów
Kontynuuj ten sam proces co powyżej, aby określić konfigurację parametrów synchronizacji dla wszystkich komponentów, które chcesz synchronizować z PLM. Ponieważ parametry komponentów po stronie Workspace niekoniecznie odpowiadają tym po stronie PLM, sekcja interfejsu Component Parameter Mapping może zostać użyta do mapowania parametrów między tymi dwoma stronami. Pamiętaj, że po zmapowaniu parametrów ich wartość będzie synchronizowana z jednego systemu do drugiego tak, jakby był to ten sam parametr.
Użyj polecenia Add Parameter w tej sekcji, aby utworzyć wpis mapowania parametru Workspace/PLM, który ma zastosowanie do aktualnie wybranego Altium Component Type (wybranego w sekcji Sync Parameters). Opcje Parameter Name PLM i Altium to te dostępne w odpowiednich systemach. Ustawienie Revision w kolumnie Item/Revision powoduje utworzenie nowej rewizji komponentu po zmianie parametru, natomiast przy ustawieniu Item podczas synchronizacji aktualizowany będzie tylko parametr komponentu.
Użyj powiązanej ikony
, aby usunąć wpis mapowania.
W ten sposób można mapować dowolną liczbę parametrów, jednak prawdopodobnie istnieje zestaw wspólnych parametrów Workspace/PLM, które należy zmapować dla wszystkich komponentów. To podejście do mapowania globalnego jest dostępne po wybraniu All Types jako Altium Component Type.
Utwórz wpisy mapowania (Add Parameter), które będą miały zastosowanie do wszystkich komponentów, uwzględniając znane zgodności wspólnych parametrów. i ustaw opcje Item/Revision oraz Sync Direction zgodnie z potrzebami. Ważne jest również określenie zmapowanego wpisu parametru jako Primary Key — jest to wspólna para parametrów służąca jako indeks odniesienia między dwoma zestawami danych parametrycznych. Jeśli jest to numer części PLM (zalecane), numer utworzony po stronie PLM zostanie propagowany z powrotem do strony Altium, tworząc znane łącze referencyjne między zestawami zsynchronizowanych danych komponentów.
Atrybuty klasyfikacji PLM
Dla podłączonych systemów PLM, które obsługują grupowanie komponentów jako Classifications (takich jak PTC Windchill), powiązane atrybuty i wartości PLM mogą być mapowane w tej sekcji na parametry komponentów Workspace.
Na przykład w przypadku PTC Windchill, aby wyodrębnić określoną wartość atrybutu klasyfikacji (powiedzmy wartość pojemności dla kondensatorów w klasie 102-Capacitor), dodaj tę klasyfikację i jej wartość (Capacitance) jako PLM Parameter Name, a docelowy parametr komponentu Altium (Value) jako Altium Parameter Name. Definicje można dodawać dla wszystkich typów komponentów, w tym wiele definicji dla tego samego typu komponentu.
► Zobacz powyższe informacje o PartsLink, aby dowiedzieć się więcej o klasyfikacjach Windchill.
Part Choices
Użyj listy rozwijanej Sync Direction, aby określić kierunek synchronizacji danych producenta Part Choices między Workspace a systemem PLM, lub wyłącz synchronizację Part Choices za pomocą opcji OFF.
W zależności od typu podłączonego PLM opcja Part Choice information będzie oferować synchronizację w formacie zgodnym z własnymi zatwierdzonymi częściami produkcyjnymi PLM (Native PLM Manufacturer Parts) lub jako konwencjonalne dane parametrów komponentu (PLM Part Attributes). Ten drugi format może obejmować wiele zestawów atrybutów parametrów Manufacturer:PartNumber — MFR1:MPN1, MFR2:MPN2, na przykład.
Przykłady „natywnych” (lub wbudowanych) części producenta PLM obejmują Vendor Parts w Arena oraz Manufacturer Parts w Windchill.
XML konfiguracji projektu
Ta sekcja zawiera listę bazowej konfiguracji XML definiującej początkową konfigurację PLM dla podłączonego systemu PLM. Pobrana wersja tego bazowego XML konfiguracji (Download Sample Configuration) zawiera szczegółowe komentarze, które objaśniają funkcję większości sekcji Entity i Attribute.
Ostatecznie konfiguracja zdefiniowana w interfejsie PLM Integration jest przechowywana jako systemowe pliki XML, które można zapisać lokalnie za pomocą polecenia Export Configuration powiązanego ze szczegółami Server Connection u góry strony konfiguracji.
Dostępna jest również opcja Import Configuration. Umożliwia ona zastosowanie istniejącego pliku XML konfiguracji do nowej (lub edytowanej) konfiguracji PLM, co spowoduje powielenie tej konfiguracji PLM. Ponadto w sytuacji, gdy trzeba wprowadzić specjalistyczne zmiany w istniejącej konfiguracji PLM, wyeksportowany plik XML można ręcznie edytować, a następnie ponownie zaimportować do konfiguracji. Pamiętaj, że parametry, atrybuty i wartości zawarte w pliku konfiguracji rozróżniają wielkość liter.
Dodawanie szablonu publikowania
Konfiguracja PLM wymaga dodania opartego na XML Publishing Template, aby obsługiwać procesy Workspace, które wysyłają pełne dane projektu — pliki projektowe, dane komponentów oraz dane wyjściowe produkcyjne — do systemu PLM w ramach pojedynczej akcji „publikowania”. Procesy te obejmują Publish to PLM, w którym użytkownik określa dane wyjściowe do wysłania, oraz Project Releaser with Publish, który wysyła wygenerowane dane do PLM jako końcowy krok w procesie Project Release w Altium Designer.
Dodaj odpowiedni plik XML Publishing Template na karcie Publish Template podczas tworzenia lub edycji konfiguracji PLM. Użyj odsyłacza Sample Project Configurations, aby pobrać spakowany zbiór szablonów dla obsługiwanych systemów PLM.
Publishing Template zawiera odwołania do szczegółów projektu, transferu danych komponentów, lokalizacji źródeł danych oraz dystrybucji plików danych Design, Assembly i Fabrication. Pobrane przykłady zawierają szablony dla wszystkich obsługiwanych systemów PLM, z których każdy obejmuje wszelkie dodatkowe Publishing Rules dotyczące danego typu PLM oraz szczegółowe komentarze pomagające zrozumieć, co i jak skonfigurować.
Publishing Folder Support for Windchill PLM
Podczas konfigurowania instancji integracji Windchill® PLM Integration, która będzie używana w procesach Publish to PLM, można również określić (i utworzyć) docelowy folder Windchill dla dokumentów publikowanych z Workspace.
Powiązane parametry folderu Windchill są zdefiniowane w pliku XML Publishing Template zastosowanym do wpisu integracji Windchill PLM w Workspace (zobacz wyżej). Węzły definicji folderów mają format znacznika <pt:Folder>xxx</pt:Folder> — gdzie pt to bieżąca przestrzeń nazw, a xxx to pełna ścieżka folderu — i są umieszczane jako reguła publikowania w sekcji FileDistribution dla każdego typu dokumentu (na przykład dla danych wyjściowych PCB.zip Fabrication).
Przykład hierarchii struktury XML publikowania:
<pt:EntityRule id="FAB">
<pt:FileDistributions>
<pt:FileDistribution archiveName="PCB.zip">
<pt:Folder>PRODUCT/Projects/${project.name}/FAB data</pt:Folder>
Ostatni wpis określałby (lub tworzył) docelowy folder publikowania dla danych wyjściowych PCB.zip Fabrication ze strukturą folderów Windchill (gdzie nazwa projektu to MyProject):
PRODUCT
Projects
MyProject
FAB data
Zwróć uwagę, że ścieżka folderu zdefiniowana w pliku XML Publishing jest ścieżką bezwzględną (a nie względną) i może zawierać inne właściwości projektu, takie jak nazwa projektu (${project.name}) oraz numer zespołu (${project.PLM_ASSEMBLY_NUMBER}).
Publish to PLM with ECO
Pliki konfiguracyjne dla instancji Windchill, Agile i Arena PLM obsługują również sformalizowany przepływ pracy Change Order (ECO), który jest włączany w pliku XML Publishing Template i definiowany w pliku Configuration XML w sekcji encji altiumType="ProjectChangeOrder".
W zależności od instancji PLM definicje konfiguracji XML obejmują schemat identyfikacji Change Order (numeracja, lokalizacja, ID itd.), specyficzne atrybuty Change Order, takie jak Name/Title, Description i Change Complexity (tylko Windchill), a także ustawienia opcji, takie jak strategia tworzenia Change Order (brak, nowy lub ponowne użycie istniejącego) oraz promocja statusu Lifecycle (tylko Windchill i Agile). Zdefiniowany Change Order jest włączany podczas publikowania przez deklarację jego odwołania publishId w powiązanym Publishing Template.
Szablon publikowania obsługuje również zestawy reguł definiujących, jak i gdzie dane wyjściowe wydania (projekt, źródła, dane assembly i fabrication) są publikowane do PLM.
Po zdefiniowaniu w plikach Configuration i Publishing Template XML serwera, Change Orders są dostępne podczas przepływów procesów Project Creation i Publishing to PLM wywoływanych z Altium Designer lub przez interfejs Workspace PLM. Podczas tego przebiegu zostanie wyświetlony powiązany formularz Change Order, w którym określa się opcje Change Order.
Okno dialogowe Altium Designer Change Order Required pokazujące początkowy krok tworzenia projektu oraz następujący po nim Project Release z włączonym ECO.
W pokazanym tutaj przykładzie projekt jest tworzony w Altium Designer z szablonu przy użyciu procesu Create Project with PLM Initialize (do Arena PLM), z wyłączoną opcją Create change order (ECO). Następnie projekt jest wydawany przy użyciu procesu Publish to PLM (User selects) z włączoną opcją Create change order (Yes). Po stronie Arena elementy są następnie publikowane względem Change Order (ECO-00042) i powiązanego z nim procesu zatwierdzania.
Pobierz archiwum ZIP zawierające pliki Arena Configuration XML i Publishing Template XML użyte w tym przykładzie.
Zmodyfikuj przykładowy szablon XLM zgodnie z wymaganiami i prześlij plik do konfiguracji PLM za pośrednictwem okna Add Publish Template, otwieranego przyciskiem
. Należy pamiętać, że konfiguracja PLM obsługuje wiele Publish Templates.
Synchronizacja komponentów
Synchronizacja danych komponentów między Twoim Workspace Altium 365 a podłączonym systemem PLM jest określana przez włączone mapowanie parametrów i kierunek opisane powyżej, i będzie wykonywana, gdy proces synchronizacji zostanie uruchomiony ręcznie albo automatycznie o zaplanowanej porze. Sam proces synchronizacji jest sterowany przez wbudowany przepływ procesu LibSync.
W instancji konfiguracji PLM powiązane opcje synchronizacji są dostępne na karcie Component Synchronization, gdzie proces można uruchomić ręcznie lub ustawić harmonogram. W drugim przypadku włącz opcję Synchronize on a schedule i wybierz przedział czasu z powiązanej listy rozwijanej.
Możesz użyć opcji menu
, aby ręcznie uruchomić proces LibSync jako zdarzenie synchronizacji Incremental lub Full:
-
Incremental — stosuje tylko te komponenty, które zostały zmodyfikowane od czasu ostatniego uruchomienia synchronizacji (to znaczy ich znacznik czasu jest późniejszy niż data ostatniej synchronizacji) i które spełniają kryteria synchronizacji w konfiguracji. Zwróć uwagę, że jest to tryb używany, gdy zdarzenie synchronizacji jest wywoływane z kontrolki
na głównej stronie PLM Integration — patrz poniżej.
- Full — ten tryb wymusza pełną synchronizację. Uwzględnione zostaną wszystkie komponenty spełniające kryteria synchronizacji w konfiguracji.
Wykonywanie synchronizacji komponentów
Synchronizacja komponentów (biblioteki) może być wykonywana ręcznie z poziomu wpisu instancji PLM na stronie Workspace PLM Integration lub jako zautomatyzowany cykl określony w konfiguracji instancji — patrz wyżej. Kliknij kontrolkę
powiązaną z instancją PLM, aby ręcznie wywołać proces synchronizacji, który zostanie wykonany w ramach przepływu LibSync przy użyciu ustawień zdefiniowanych w powiązanej konfiguracji PLM.
Kontrolka Actions zmieni się na
, umożliwiając zatrzymanie procesu synchronizacji w razie potrzeby, a wpis Sync Status będzie wskazywać, że proces jest w toku. Po zakończeniu procesu synchronizacji status zmieni się na Completed.
Gdy synchronizacja komponentów jest uruchamiana ręcznie lub jako zdarzenie czasowe, proces LibSync przechodzi przez swój zdefiniowany przepływ pracy, aż do ukończenia lub wystąpienia błędu. Możesz odświeżyć przeglądarkę (F5), aby wyświetlić bieżący stan procesu synchronizacji.
Aby uzyskać dostęp do szczegółów zakończonego zdarzenia synchronizacji, kliknij ikonę
w kolumnie Last Sync, aby pobrać powiązany plik dziennika (zobacz przykład), lub wybierz odpowiednią datę, aby otworzyć wpis zdarzenia na karcie Synchronization Status. Należy pamiętać, że w tym widoku zakończone zdarzenia synchronizacji są wyświetlane po wybraniu opcji Closed, a wszelkie zdarzenia uruchomione lub wstrzymane pojawiają się po wybraniu trybu widoku Active.
Podkarty widoku Status udostępniają następujące informacje:
- Diagram — grafika przedstawiająca przepływ pracy procesu, z wyróżnioną bieżącą pozycją kroku (ukończony lub stan błędu/niepowodzenia).
- Data — podsumowanie informacji o działaniu procesu, w tym o powodzeniu lub niepowodzeniu jego kroków oraz odsyłacz do zarejestrowanego raportu procesu — zobacz przykład.
- History — dziennik czasu głównych zdarzeń synchronizacji Workspace wymienionych w kolejności.
Wszelkie zdarzenia synchronizacji, które zostały przedwcześnie zatrzymane, na przykład z powodu napotkania błędu, będą wyświetlane, gdy widok jest w trybie Active. Te wpisy można usunąć z listy za pomocą kontrolki Terminate lub — poprawniej — przeanalizować i rozwiązać z poziomu powiązanego kafelka zadania utworzonego w widoku Tasks w Workspace. Należy pamiętać, że zakończone/rozwiązane zdarzenie synchronizacji zostanie przeniesione do listy Closed widoku Synchronization Status z odpowiednim oznaczeniem Status, takim jak Failed.
Dostęp do procesów związanych z PLM
Przykładowe przepływy procesów związane z podłączonym systemem PLM są dostępne na kartach motywów procesów na stronie Workspace Processes. Zasadniczo przykładów tych nie można używać bezpośrednio — aby stały się aktywne, należy je zapisać ponownie pod inną nazwą.
► Zobacz dokumentację Processes & Workflow, aby uzyskać więcej informacji.
Administrator Workspace może uruchomić nową instancję dowolnej aktywowanej definicji procesu bezpośrednio z listy procesów na stronie Processes, klikając kontrolkę
. Użytkownicy Workspace niebędący administratorami również mogą inicjować aktywne procesy z Workspace, na przykład:
-
Proces Part Request with PLM z przycisku
na stronie Part Request.
-
Proces Publish to PLM z przycisku
na stronach Tasks i Activities otwartego projektu.
-
Proces Publish to PLM z przycisku
na głównej stronie Projects.
-
Proces Project with Initialize in PLM z przycisku
na głównej stronie Projects lub podczas Cloning a project z menu przycisku
.
W praktyce jednak procesy związane z PLM są zwykle wywoływane z poziomu Altium Designer podczas projektowania i opracowywania projektu. Procesy związane z PLM są dostępne z poziomu Altium Designer w następujący sposób:
-
Part Request with PLM Part Create — dostępne z paneli Explorer, Manufacturer Part Search i Components w Altium Designer.
► Zobacz Process-based Part Requests, aby uzyskać szczegółowe informacje. -
Publish to PLM (User selects) — dostępne z podmenu Project » Project Activities dla aktywnego projektu Altium Designer.
► Zobacz Publishing to a PLM – user-selects, aby uzyskać szczegółowe informacje. -
Project Releaser with Publish — dostępne jako końcowy etap Project Releaser z podmenu Project » Project Releaser dla aktywnego projektu Altium Designer.
► Zobacz Design Project Release – publishing to PLM, aby uzyskać szczegółowe informacje. -
Project with initialise in PLM — dostępne podczas tworzenia nowego projektu Altium Designer z podmenu File » New » Project in <Workspace> lub podczas klonowania projektu.
► Zobacz Publishing to a PLM – initialize in PLM, aby uzyskać szczegółowe informacje.
Przepływy procesów
Następujące definicje procesów (i bazowe przepływy pracy) są dostępne przez Workspace w celu obsługi integracji z PLM:
-
Part Requests motyw procesu:
- Part Request with PLM Part Create — obsługuje automatyczne tworzenie komponentu w instancji PLM, a następnie przekazanie wygenerowanego numeru części z powrotem do komponentu Workspace. Diagram przepływu pracy pokazano poniżej.
Jedna ważna kwestia: gdy modyfikujesz tę przykładową definicję, aby utworzyć własną, musisz określić instancję PLM, w której mają być tworzone części. Wybierz encję Create Part in PLM na diagramie przepływu pracy i wybierz instancję PLM z menu rozwijanego powiązanego z polem PLM Instance. To menu zawiera listę wszystkich aktualnie zdefiniowanych instancji PLM (zgodnie z definicją na stronie PLM Integration interfejsu).
► Zobacz Creating and Managing Processes, aby uzyskać więcej informacji o pracy z przepływami procesów.
- Project Activities motyw procesu:
- Publish to PLM (User selects) — publikowanie danych wyjściowych wydanego zarządzanego projektu do zintegrowanej instancji PLM, przy czym użytkownik może wybrać dokładnie, które dane wyjściowe mają zostać opublikowane. Diagram przepływu pracy pokazano poniżej.
- Project Releaser with Publish — publikowanie do zintegrowanej instancji PLM jako dodatkowy etap Project Releaser. Diagram przepływu pracy pokazano poniżej.
-
Project Creations motyw procesu:
- Project with initialise in PLM — obsługuje automatyczne tworzenie numerów części w instancji PLM, a następnie przekazanie ich jako parametrów projektu projektowego Workspace. Diagram przepływu pracy pokazano poniżej.
























. 












