Design Project Release
W skrócie
- Dowiedz się, jak są porządkowane i przechowywane dane źródłowe, dane do produkcji PCB i dane montażowe, w tym pliki montażowe dla wariantów projektu.
- Poznaj sposób, w jaki kontrola wersji, wydawanie w ramach jednej operacji oraz opcjonalne kontrole walidacyjne pomagają chronić integralność wydania.
- Dowiedz się, jak przygotować projekt do wydania i uzyskać dostęp do narzędzia Project Releaser, przejrzeć wygenerowane pliki wynikowe przed zatwierdzeniem oraz udostępniać wydane dane za pomocą obsługiwanych opcji publikowania.
Gdy projekt jest już gotowy, by trafić do szerszego grona odbiorców, należy go wydać — a znaczenie tego procesu często bywa niedoceniane.
Bez uporządkowanego i opartego na solidnych podstawach procesu wydawania śledzenie rozwoju produktu w czasie może wiązać się z licznymi pułapkami. Wyobraź sobie, że musisz wrócić do wcześniejszej rewizji produktu i ponownie ją wydać, ale okazuje się, że do tamtego wydania nigdy nie dołączono migawki wszystkich wymaganych plików źródłowych projektu! Nic straconego — wystarczy pobrać wygenerowane pliki wyjściowe z odpowiednich folderów tego wydania: niezawodne pliki Gerber oraz dodatkowe informacje dotyczące produkcji i montażu. Przecież tylko tego potrzeba. A co, jeśli te „niezawodne” pliki zostały nadpisane lub w jakiś sposób uszkodzone? Gdyby tylko proces wydawania był bardziej niezawodny.
Altium Designer odpowiada na tę potrzebę, oferując zaawansowane zarządzanie wydaniami projektów, które zapewnia wysoki poziom integralności danych. Proces wydawania projektu jest zautomatyzowany, co pozwala wydawać projekty bez ryzyka związanego z procedurami ręcznymi. Podczas wydawania danego projektu tworzona jest migawka jego plików źródłowych, która jest następnie archiwizowana wraz ze wszystkimi wygenerowanymi plikami wyjściowymi — odpowiadającymi fizycznemu produktowi wytwarzanemu na podstawie tego projektu i sprzedawanemu przez firmę. Dane wydania są przechowywane we wskazanym folderze lub archiwum ZIP na dysku twardym albo w rewizjach odpowiedniego elementu powiązanego z projektem w docelowej przestrzeni roboczej:
- Source Data (PCB Project Design Item) — opatrzona znacznikiem czasu kopia (migawka) podstawowych plików projektu, obejmująca wszystkie dokumenty źródłowe. Jest wydawana jako osobny element w przestrzeni roboczej, co pozwala oddzielić cenną własność intelektualną od wygenerowanych danych produkcyjnych i montażowych, których podmioty zewnętrzne potrzebują do wytworzenia produktu.
- Fabrication Data (PCB Fabrication Data Item) — zestaw danych wymaganych przez producenta płytek do wykonania nieobsadzonej płytki drukowanej (pliki Gerber, pliki wierceń NC itp.).
- Assembly Data (PCB Assembly Data Item) — zestaw danych wymaganych przez zakład montażowy do obsadzenia płytki wskazanymi komponentami zgodnie z zestawieniem materiałowym (pliki Pick and Place, rysunki montażowe, zestawienia materiałowe itp.). Dla projektu bazowego (w pełni obsadzonego) oraz każdego zdefiniowanego wariantu projektu (wariantu montażowego) używany jest osobny element.

Dane wygenerowane z projektu są bezpiecznie przechowywane w przestrzeni roboczej w rewizjach elementów powiązanych z projektem. Te dane o wysokiej integralności są następnie wykorzystywane w łańcuchu dostaw do wytworzenia wymaganej rewizji produktu.
Efektem jest zarządzanie wydaniami projektów zapewniające najwyższy możliwy poziom integralności. Nie tylko sam projekt jest ściśle monitorowany, objęty kopiami zapasowymi i kontrolą wersji — w podobny sposób zarządzane są również wydania jego danych w docelowej przestrzeni roboczej. Całość jest niezawodna, bezpieczna i chroniona przed nieuprawnionym dostępem.
Najważniejsze korzyści
- Integracja z kontrolą wersji. Jeśli projekt jest objęty kontrolą wersji, system wymaga, aby przed wydaniem wszystkie pliki zostały zaewidencjonowane w repozytorium i były aktualne. Dzięki temu żadna „prywatna kopia” istotnego dokumentu projektowego nie pozostanie wyłącznie na dysku twardym inżyniera, gdzie mogłaby zostać utracona. Ta prosta zasada pozwala w przyszłości zaoszczędzić wiele godzin kosztownych poszukiwań właściwego zestawu dokumentów projektowych użytych do wygenerowania wydanego produktu.
- „Jednorazowe wydawanie”. System umożliwia wydanie danych do danej rewizji elementu docelowego tylko raz. Pomyślne wydanie powoduje zatwierdzenie (zapisanie) danych wydania we wskazanej rewizji elementu, a następnie jej zamknięcie. Nie można już wygenerować ani wydać do tej samej rewizji żadnych kolejnych danych.
- Zautomatyzowany i powtarzalny proces wydawania projektu. Wydawanie jednym kliknięciem — bez etapów ręcznych i związanego z nimi ryzyka. Od utworzenia migawki plików projektu, przez weryfikację, aż po generowanie plików wyjściowych nie jest wymagana żadna interakcja. Jeśli którykolwiek etap procesu zakończy się niepowodzeniem, wydanie również się nie powiedzie. To takie proste. Ponadto przed ostatecznym zatwierdzeniem danych wydania w rewizji elementu w docelowej przestrzeni roboczej można przejrzeć wszystkie wygenerowane dane.
-
Możliwość weryfikacji projektu jako integralnej części procesu jego wydawania. Proces wydawania korzysta z zablokowanej przed zmianami migawki źródeł projektu (wraz z zależnościami), a weryfikacja przed wydaniem najprawdopodobniej została już przeprowadzona przed rozpoczęciem tego procesu. Aby jednak zyskać dodatkową pewność i zapewnić integralność danych projektu, można opcjonalnie dodać kontrole weryfikacyjne do przebiegu procesu wydawania za pomocą odpowiednio skonfigurowanych zadań generowania plików wyjściowych (Output Job). Obejmują one standardowe sprawdzanie ERC schematów źródłowych i DRC płytki PCB, a także możliwość sprawdzenia synchronizacji projektu źródłowego z płytką PCB oraz porównania footprintów na płytce z ich biblioteką źródłową, aby upewnić się, że są aktualne i zgodne. Jeśli którakolwiek z kontroli weryfikacyjnych nie zostanie zakończona pomyślnie, wydanie nie powiedzie się.
- Nazwy wszystkich plików danych wygenerowanych w procesie wydawania projektu można opcjonalnie poprzedzić identyfikatorem elementu i identyfikatorem jego rewizji, co pozwala jednoznacznie określić, do wytworzenia której rewizji którego elementu mają zostać użyte te dane.
- Publikowanie. Możliwość publikowania danych wydania bezpośrednio z przestrzeni roboczej we współdzielonej przestrzeni dyskowej, takiej jak Amazon S3, serwery FTP, Box.com lub zwykły folder sieciowy. Ułatwia to bezpieczne udostępnianie danych przestrzeni roboczej bez przyznawania podmiotom zewnętrznym dostępu do samej przestrzeni.
Narzędzie Project Releaser
Altium Designer zapewnia zaawansowane zarządzanie wydaniami projektów z zachowaniem wysokiej integralności danych dzięki Project Releaser. Intuicyjny interfejs użytkownika pozwala jednocześnie generować wszystkie dane produkcyjne projektu — dane do wytwarzania PCB, dane montażowe, źródła projektu itp. Project Releaser umożliwia również jednoczesne generowanie danych montażowych dla wielu wykrytych wariantów projektu PCB. Nie musisz się nawet martwić, jeśli nie masz utworzonych plików Output Job — narzędzie utworzy je za Ciebie, jeśli je o to poprosisz!
Dzięki Project Releaser możesz w prosty sposób generować dane produkcyjne z zachowaniem najwyższej integralności. Możesz też sprawdzić wyniki generowania przed ostatecznym zatwierdzeniem wydania (na przykład przeglądając dane Gerber/ODB++ w edytorze CAM), aby mieć pewność, że wygenerowane dane są dokładnie tymi, których potrzeba do terminowego wyprodukowania projektu — bez poprawek.
Warunki wstępne wydania projektu do przestrzeni roboczej:
- Altium Designer jest połączony z przestrzenią roboczą, w której znajduje się docelowe repozytorium wydania.
- Projekt zawiera odpowiednie zadania wyjściowe (Output Jobs) — generatory danych wyjściowych projektu (takich jak wydruki, pliki lub dokumenty PDF). Jeśli nie ma dostępnych plików OutJob, narzędzie Project Releaser zaproponuje utworzenie odpowiednich plików OutJob na potrzeby tego procesu.
- Projekt wykorzystywany jako źródło w procesie wydawania zawiera wszystkie wymagane elementy — dane źródłowe są poprawne i aktualne, użytkownik ma wystarczające uprawnienia do wydania projektu do przestrzeni roboczej itp.
Dostęp do narzędzia Project Releaser
Sam proces wydawania jest realizowany za pomocą Project Releaser w Altium Designer, a jego interfejs użytkownika jest dostępny w dedykowanym widoku — Release. Można go otworzyć w następujący sposób:
- Wybierając polecenie Project » Project Releaser z menu głównego (gdy dokument źródłowy danego projektu jest otwarty jako aktywny dokument).
- Klikając prawym przyciskiem myszy pozycję danego projektu w panelu Projects i wybierając polecenie Project Releaser z menu kontekstowego.

Widok Release — interfejs użytkownika Project Releaser.
Publikowanie w systemie PLM
Related page: Integracja z PLM (przestrzeń robocza Altium 365, przestrzeń robocza Enterprise Server)
Jeśli w ramach Project Releaser masz aktywowany proces publikowania w instancji PLM, będzie on widoczny w podmenu Project Releaser projektu. Uruchomienie tego procesu doda do widoku dodatkowy etap służący właśnie do tego celu.
Przykładowa definicja procesu Publish to PLM (User selects) jest dostępna w przestrzeni roboczej — w ramach kategorii procesów Project Activities — i służy do standardowego publikowania (czyli nie w ramach Project Releaser, jak opisano wcześniej). Proces ten umożliwia publikowanie wydanych danych wyjściowych projektu w zintegrowanej instancji PLM, przy czym użytkownik może dokładnie wybrać, które dane zostaną opublikowane. Schemat przepływu pracy przedstawiono poniżej.

Schemat przepływu pracy domyślnej Publish to PLM (User selects) przykładowej definicji procesu
Standardowe procesy publikowania w PLM są dostępne w Altium Designer z poziomu podmenu Project » Project Activities aktywnego projektu.

Dostęp z poziomu Altium Designer do aktywowanego procesu standardowego publikowania wydanych danych projektu z przestrzeni roboczej w instancji PLM.
Tryb i miejsce docelowe wydania
Project Releaser obsługuje wszystkie typy projektów — lokalne/nieobjęte kontrolą wersji, objęte kontrolą zewnętrznego systemu VCS lub natywną kontrolą wersji połączonej przestrzeni roboczej — oferując dwa tryby pracy:
- Managed (Online) Mode — wydawanie wszystkich wygenerowanych danych do rewizji elementów w docelowej przestrzeni roboczej. Nie musisz nawet pamiętać o zwiększaniu numerów rewizji elementów — wszystko odbywa się automatycznie. Jeśli masz zdefiniowany proces wydawania do instancji PLM za pośrednictwem Project Releaser, jego uruchomienie doda do widoku dodatkowy etap służący właśnie do tego celu.
- Unmanaged (Offline) Mode — wydawanie wszystkich wygenerowanych danych do struktury folderów, którą można opcjonalnie spakować do pojedynczego pliku ZIP.
Project Releaser próbuje automatycznie wykryć tryb wydawania oraz miejsce docelowe wydania. Gdy istnieje możliwość wyboru — zwykle wtedy, gdy projekt został wydany do jednej przestrzeni roboczej, a aktualnie masz połączenie z inną — system przedstawi dostępne opcje.
Wykrywanie plików Output Job
Podstawową metodą generowania danych wyjściowych projektu w Altium Designer jest korzystanie z szeregu dostępnych generatorów danych wyjściowych, które tworzą pliki danych i dokumentację graficzną potrzebne do fizycznej realizacji projektu — innymi słowy: wydruki schematów i PCB, pliki produkcyjne Gerber i NC Drill, zestawienie materiałowe (BOM), pliki montażowe Pick and Place, rysunki produkcyjne itp., niezbędne do wytworzenia i montażu płytki.
Wybrane generatory danych wyjściowych oraz konkretne pliki wyjściowe, które mają utworzyć dla projektu, są definiowane zbiorczo za pomocą Output Job Editor. Zapisuje on konfiguracje przypisania generatorów do wyjść w pliku Output Job (*.OutJob), tworzonym za pomocą polecenia File » New » Output Job File.
Jako podstawowy mechanizm zbiorczego generowania plików produkcyjnych projektu, zadania Output Job w Altium Designer oferują następujące dodatkowe możliwości:
- Do danego projektu można dodać dowolną liczbę plików OutJob, aby udostępnić konfiguracje dla konkretnych zadań, takich jak generowanie danych do wytwarzania PCB, montażu, archiwizacji, zaopatrzenia i dokumentacji.
-
Pliki OutJob są przenośne i można je stosować w dowolnym projekcie wymagającym ustandaryzowanego zestawu danych wyjściowych. Na przykład wybierz
[Project]jako opcję źródła dokumentu zamiast konkretnego pliku projektu, aby utworzyć uniwersalne (a zatem przenośne) zadanie Output Job. - Zadania OutJob mogą zawierać pliki do kontroli poprawności projektu, takich jak kontrola reguł elektrycznych (ERC), kontrola reguł projektowych (DRC) oraz porównywanie obudów ze źródłem. Zadania wyjściowe kontroli poprawności stanowią więc szczególny „aktywny” przypadek, w którym projekt jest sprawdzany, a wynikowy plik wyjściowy (na przykład dokument PDF) przedstawia wyniki procesu weryfikacji.
- Pliki OutJob obsługują warianty projektu zmontowanej płytki, w których do produkcji alternatywnych wersji projektu wymagane są różne zestawy plików wyjściowych — na przykład wersji standardowej lub wersji o podwyższonych parametrach, wykorzystującej dodatkowe komponenty lub komponenty innego typu. Więcej informacji o wariantach projektu płytki można znaleźć w sekcji Warianty projektu.
Jeśli z projektem nie są obecnie powiązane żadne pliki Output Job, Project Releaser wykryje ten fakt i zapyta, czy dodać pliki domyślne. Jeśli wyrazisz zgodę, zostaną utworzone następujące pliki:
-
W przypadku projektu PCB:
-
Assembly.OutJob— ze zdefiniowanymi następującymi danymi wyjściowymi:-
Documentation Outputs:
PCB 3D Print,Schematic Prints -
Assembly Outputs:
Generates pick and place files,Assembly Drawings -
Report Outputs:
Bill of Materials -
Export Outputs:
Export STEP
-
Documentation Outputs:
-
Fabrication.OutJob— ze zdefiniowanymi następującymi danymi wyjściowymi:-
Documentation Outputs:
PCB Prints -
Fabrication Outputs:
Gerber Files,NC Drill FilesorazIPC-2581 -
Validation Outputs:
Design Rules Check,Footprint Comparison Report -
Export Outputs:
Save As/Export PCB
-
Documentation Outputs:
Te domyślne pliki Output Job pochodzą z następującego domyślnego folderu instalacyjnego:
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs. -
-
W przypadku projektu wiązki przewodów:
-
Assembly.OutJob— ze zdefiniowanymi następującymi danymi wyjściowymi:- Documentation Outputs: Draftsman
-
Report Outputs:
Bill of Materials -
Validation Outputs:
Electrical Rules Check
Ten domyślny plik Output Job pochodzi z następującego domyślnego folderu instalacyjnego:
\Users\Public\Documents\Altium\AD<Solution/Version>\OutputJobs\Harness. -
Wykrywanie wariantów
W przypadku projektów PCB szczególnie przydatną funkcją narzędzia Project Releaser jest wykrywanie wariantów zdefiniowanych dla projektu i tworzenie dla każdego z nich zestawów danych montażowych gotowych do wydania. Każdy zestaw danych montażowych będzie wyświetlany z domyślną nazwą elementu docelowego w postaci:
PCBA-[ProjectName]-[VariantName]
Przyrostek [VariantName] zapewnia użycie właściwego wariantu podczas generowania danych z przypisanych plików OutJob.

Dodatkowe zestawy danych montażowych utworzone na podstawie wykrytych wariantów zdefiniowanych dla projektu.
Proces wydawania
Proces wydawania przebiega etapami, a pozycje po lewej stronie widoku Release pozwalają od razu sprawdzić, na którym etapie obecnie się znajdujesz.
Aby dowiedzieć się więcej o procesie wydawania w trybie online, zapoznaj się ze stroną Wydawanie do przestrzeni roboczej. Aby dowiedzieć się więcej o specyfice trybu offline, zapoznaj się ze stroną Wydawanie lokalne.
Publikowanie wydanych danych
Related page: Praca z miejscami docelowymi publikacji
Wydane dane wygenerowane z projektu PCB (wyłącznie dane produkcyjne PCB, dane montażowe PCB i elementy projektu PCB) można publikować bezpośrednio z przestrzeni roboczej lub pliku Output Job w miejscu przechowywania, takim jak Box.com, Amazon S3, serwer FTP lub zwykły folder w udostępnionej lokalizacji sieciowej. Zapewnia to niezrównane korzyści w zakresie dystrybucji i współpracy w świecie, w którym członkowie całego „zespołu produktowego” — projektanci, zespół produkcyjny oraz wszystkie inne osoby uczestniczące w procesie przekształcania pomysłu w gotowy produkt — są często rozproszeni po całym świecie.
Publikowanie polega na zdefiniowaniu Publishing Destination, a następnie przesłaniu do tego miejsca wydanych danych wymaganej rewizji elementu. Od zakładu produkcyjnego w Chinach, przez zespoły projektowe w Kijowie, Stanstead Abbotts i San Diego, po dyrektora projektu lecącego gdzieś nad Pacyfikiem — każda osoba, która powinna wiedzieć o nowym wydaniu, może otrzymać zaproszenie z łączem do opublikowanego folderu. Zapewnia to współdzielony i kontrolowany dostęp umożliwiający przeglądanie, omawianie i wykorzystywanie danych potrzebnych do wytworzenia elementu.

Publikuj wydane dane w miejscu przechowywania i udostępniaj informacje członkom zespołu na całym świecie.
Globalne udostępnianie danych pakietu produkcyjnego
Kluczową cechą projektów przechowywanych w przestrzeni roboczej Altium 365 jest możliwość tworzenia i udostępniania innym osobom Build Package wydania. Po udostępnieniu go bezpośrednio producentowi można go traktować jako Manufacturing Package, ponieważ jest to pakiet, który producent może przeglądać, pobierać i wykorzystywać do produkcji oraz montażu płytki.
Aby umożliwić udostępnianie takiego pakietu innym osobom, w tym producentowi (który zazwyczaj nie należy do Twojej organizacji), platforma Altium 365 udostępnia dedykowany Manufacturing Package Viewer — element obsługi Global Sharing na platformie. Umożliwia on innym osobom przeglądanie pakietu produkcyjnego w dowolnej przeglądarce internetowej, z dowolnego miejsca na świecie, ale poza Twoją przestrzenią roboczą, dzięki czemu same projekty i inna cenna własność intelektualna pozostają niedostępne.
Każdy użytkownik, któremu udostępniono pakiet, otrzyma wiadomość e-mail z zaproszeniem i łączem do przeglądania pakietu produkcyjnego za pomocą Manufacturing Package Viewer. Udostępnione pakiety produkcyjne są prezentowane na stronie Shared with Me przeglądarkowego interfejsu platformy Altium 365.
Sam Manufacturing Package Viewer umożliwia najważniejszym uczestnikom projektu — przede wszystkim pracownikom produkcji — zapoznanie się z podsumowaniem projektu zawierającym kluczowe dane płytki, a także przeglądanie struktury danych źródłowych, produkcyjnych i montażowych oraz pobieranie w razie potrzeby dowolnych pojedynczych plików. Przeglądarka oferuje również podstrony danych produkcyjnych, montażowych i BOM. Strona danych produkcyjnych zawiera przeglądarkę plików Gerber i umożliwia dodawanie komentarzy wszystkim użytkownikom, którym udostępniono pakiet.
Ostatecznie pracownicy produkcji mogą z dowolnej strony przeglądarki pobrać pakiet wykonawczy oglądanego wydania, aby na jego podstawie fizycznie wykonać daną rewizję płytki.
Przeglądarka internetowa
Related page: Web Viewer (Przestrzeń robocza Altium 365, Przestrzeń robocza Enterprise Server)
Interfejs Web Viewer przestrzeni roboczej zapewnia powszechny dostęp do dokumentów projektu PCB za pośrednictwem standardowej przeglądarki internetowej. To znacznie więcej niż zwykła przeglądarka dokumentów online — zaawansowana technologia przeglądarkowa Web Viewer's umożliwia użytkownikom poruszanie się po strukturze projektu, interakcję z dokumentami projektowymi, uzyskiwanie informacji o elementach projektu oraz wyróżnianie obszarów lub obiektów w celu dodawania komentarzy.
Podczas przeglądania dokumentów ich format internetowy nie obniża jakości wyświetlania schematów i płytek PCB, a jednocześnie zapewnia pełną obsługę przesuwania i powiększania widoku oraz możliwość wyszukiwania, wskazywania krzyżowego, zaznaczania i sprawdzania komponentów oraz sieci w całym projekcie.

Interfejs Web Viewer przestrzeni roboczej zapewnia wygodne, interaktywne środowisko do przeglądania na przykład źródłowych dokumentów schematów i PCB w projekcie. Na ilustracji pokazano schemat w interfejsie Web Viewer Altium 365 — najedź kursorem na obraz, aby zobaczyć płytkę PCB w widoku 3D.
Jako niezależna platforma przeglądania działająca w przeglądarce internetowej interfejs Web Viewer oferuje interaktywny dostęp do dokumentów projektowych w trybie tylko do odczytu, bez konieczności otwierania projektu w środowisku edycji. Działania wykonywane w obszarze Web Viewer nie wpływają na inne osoby pracujące nad projektem, takie jak inżynier odpowiedzialny za projekt — z wyjątkiem powiązanych powiadomień o komentarzach.
