Integração com PLM
A solução de design composta pelo Altium Designer e por um Workspace do Altium 365 oferece PLM Integration configurável, com suporte disponível para Windchill®, Arena®, Oracle® Agile™, Aras Innovator®, e Siemens Teamcenter® (com configuração adicional). A configuração da integração com PLM é realizada por meio da interface do navegador do Workspace do Altium 365, que fornece uma interface automatizada para configurar facilmente a interconexão, mapear dados de parâmetros e especificar a direção da sincronização de dados. Com a interface configurada, os recursos e funcionalidades da integração com PLM são disponibilizados ao trabalhar nas seguintes áreas distintas:
-
Library (componentes) – atendendo à sincronização unidirecional ou bidirecional dos seus componentes, parâmetros de componentes e opções de peças entre o seu Workspace do Altium 365 e a sua instância de PLM. A configuração permite especificar quais parâmetros são controlados em qual sistema. Além disso, os parâmetros do item permitem atualizar propriedades no lado do Workspace (configurável por campo), sem a necessidade de liberar formalmente uma nova revisão desse Item de Componente. Um fluxo de trabalho dedicado de Part Request workflow também está disponível, com suporte à criação automática de um Componente na sua instância de PLM, bem como à propagação dos números de peça gerados no PLM de volta para os componentes no lado do Workspace.
-
Design (projetos) – um fluxo de trabalho dedicado de Project Creations workflow está disponível, com suporte também à criação automática de números de peça na sua instância de PLM e, em seguida, à propagação desses parâmetros de volta para o projeto de design. Esses parâmetros podem ser usados em special strings (por exemplo, para anotações de borda da folha). Você tem a capacidade de publicar seu design na sua instância de PLM como parte da execução do Project Releaser no Altium Designer. A operação de publicação usa um publishing template — definido como parte da configuração da integração da instância de PLM — para controlar como os dados devem ser propagados para o PLM. E, se você estiver publicando pela primeira vez e os números de peça (no lado do PLM) ainda não estiverem associados ao projeto, esses números de peça serão criados no PLM e associados ao projeto como parte dessa publicação inicial. Você também tem a capacidade de definir entradas de componente para componentes na instância de PLM como parte da operação de publicação (opcional, com base na configuração). E você sempre poderá ver exatamente o que foi criado, como números de peça na instância de PLM, como parte do histórico do fluxo de trabalho do processo (guia History).
Suporte a PLM
O Workspace do Altium 365 oferece suporte aos seguintes sistemas PLM:
-
PTC Windchill® PLM versão 12, 13 e PTC Windchill+ (a variante SaaS do Windchill).
-
Arena® PLM.
-
Oracle® Agile™ PLM.
-
Aras Innovator® Release 30.
Additional Setup for Aras Innovator
Para obter integração com PLM com o Aras Innovator, o servidor do seu Altium Workspace precisa ser registrado na configuração de Aras Authentication setup, adicionando uma nova seção de nó ao registro de cliente. Depois de registrado, um token OAuth exclusivo é concedido ao seu Workspace conectado para autenticar o acesso.
As alterações necessárias na configuração do Aras Innovator são feitas editando o arquivo de registro do cliente OAuth:
-
Na máquina host do Aras, abra o arquivo
\OAuthServer\OAuth.configpara edição. -
Localize e copie a seção IOMApp — da linha
<clientRegistry id="IOMApp" enabled="true">até a linha</clientRegistry>. -
Cole a seção IOMApp copiada imediatamente depois para criar uma nova seção (duplicada).
-
Nesta nova seção de nó, renomeie
IOMAppparaNEXUS— resultando em<clientRegistry id="NEXUS" enabled="true">.
-
Salve e reinicie a máquina do Aras.
- Siemens Teamcenter®, com configuração de integração adicional.
- Duro PLM, implementado como uma instância de PLM de terceiros — consulte Third Party PLM Support abaixo.
Escolha da interface de configuração de PLM
A conexão do Workspace do Altium 365 a um sistema PLM compatível pode ser estabelecida por meio de uma interface de usuário avançada e semiautomatizada, conforme detalhado abaixo, ou usando um processo manual baseado na edição de arquivos XML de configuração de PLM. Este último exige conhecimento das estruturas de dados do sistema PLM de destino e familiaridade com o formato XML, enquanto o sistema atualizado apresentado abaixo obtém automaticamente os dados necessários do PLM e do Altium Workspace para preencher as opções de menu na interface.
Você pode reconfigurar o Workspace para apresentar a interface PLM anterior — baseada na edição manual de arquivos XML — desmarcando a opção Enable new PLM Configuration page na página Admin – Settings – PLM Integration page da interface do Workspace. Certifique-se de salvar a alteração e, em seguida, sair e entrar novamente.
Conectando-se à sua instância de PLM
As Configurações de PLM são criadas e gerenciadas na página Admin – PLM Integration da interface do navegador do Workspace. Quando você tiver se conectado com sucesso ao sistema PLM, a interface de configuração fornecerá uma variedade de opções de integração com base em dados obtidos tanto do Workspace quanto do PLM conectado.
Use o botão
para iniciar o processo de conexão e prossiga conforme descrito na apresentação de slides abaixo.
Quaisquer erros de conectividade serão destacados em vermelho ao entrar no sistema PLM de destino. A borda inferior da caixa de destaque incluirá os detalhes do erro — ver exemplo.
PTC Windchill SSO Support
A capacidade de usar autorização Single Sign On (SSO) ao se conectar a um sistema Windchill PLM está disponível e é configurada por meio da interface do Workspace. Isso fornece um método simplificado e seguro de autorização de conexão ao executar processos de PLM do Workspace, como Project Creation e Publish to PLM. Na prática, essa configuração permite conceder acesso ao Windchill usando o padrão de delegação OAuth por meio de um serviço de provedor de identidade, como o PingFederate.
O acesso à configuração de SSO está disponível na guia OAuth da página PLM Integration do Workspace (Admin - PLM Integration), onde várias instâncias de provedor OAuth podem ser adicionadas.
A configuração de autorização do provedor OAuth é concluída com base nos dados disponíveis no seu provedor de identidade configurado. Insira um nome e as informações exigidas pelo Workspace — IDs, tokens, URLs etc. — nos campos da página e, em seguida, salve a configuração concluída.
A nova instância de Provedor OAuth fica disponível quando a opção OAuth Connection é habilitada em uma configuração de Windchill PLM. Selecione na lista suspensa OAuth Provider quando houver vários provedores disponíveis. Conclua a configuração da conexão com o botão
e siga as instruções do provedor, se necessário.
Suporte a PLM de terceiros
O Workspace do Altium 365 oferece suporte adicional a configurações de sistemas PLM “não nativos” desenvolvidas por terceiros. Esse suporte é habilitado pelo Generic Connector da Altium, que requer a licença Altium 365 PLM Generic Connector Addon.
Ao adicionar uma Instância de PLM do Workspace para esse tipo de sistema, arquivos XML pré-configurados fornecidos pelo terceiro são carregados para a configuração dessa Instância de PLM por meio da interface PLM Integration interface.
Configuração
Após uma conexão bem-sucedida com uma instância de PLM, a interface PLM do Workspace oferece definições de configuração para definir como a sincronização de componentes é executada, o mapeamento entre parâmetros de componentes e a abordagem de transferência usada para dados de Part Choices. Essas opções de sincronização estão disponíveis na guia Configuration da interface.
As opções de configuração disponíveis para você (e seus rótulos/funcionalidade) são determinadas pelo tipo de sistema PLM e pelos dados paramétricos obtidos tanto do Workspace quanto da instância de PLM conectada.
Parâmetros de sincronização
Esta seção da interface PLM define quais tipos de componentes serão sincronizados, onde e como novos componentes devem ser criados/atualizados e quaisquer restrições com base em critérios de parâmetros.
Como os componentes são sincronizados é especificado individualmente:
- Selecione um Altium Component Type na lista de parâmetros e defina sua opção Sync Direction conforme necessário (Para Altium/PLM ou ambos) — as opções de tipo de componente são obtidas dos dados atuais de componentes do Workspace.
- Escolha um nome de atributo de PLM relacionado no menu PLM Type — as opções disponíveis são obtidas da instância de PLM conectada.
- No campo Altium Target Folder (em Sync to Altium), navegue até uma pasta de componentes do Workspace e selecione-a como local de sincronização para esse componente.
- Especifique um Sync Mode para determinar se novos componentes serão criados durante a sincronização, ou se apenas componentes existentes serão atualizados — ou ambos.
-
Defina o Component Template que será usado para definir tipos de parâmetros de componente ao sincronizar esse componente. Essa configuração assumirá por padrão o valor do Altium Component Type selecionado (por exemplo;
Capacitors) se um template associado do Workspace estiver disponível. - Use a opção Add Parameter Criteria para especificar um valor de parâmetro pelo qual a sincronização será restringida. Um componente não será sincronizado a menos que satisfaça esse critério. Adicione mais critérios de parâmetro conforme necessário.
Opções adicionais estão disponíveis quando conectado a um PTC Windchill PLM com suporte ao sistema PartsLInk system do Windchill. O sistema PartsLink permite classificar peças em grupos para uma segmentação mais conveniente e rápida, e pode incluir pares Atributo/Valor associados para fornecer definição adicional dentro dessa Classificação. Consulte a seção recolhível abaixo para mais informações.
-
Selecione o Add Classification Name Criteria no menu Filter Criteria para adicionar um filtro de classificação. Use o menu de nome para escolher um grupo de classificação pelo qual a sincronização será filtrada.
-
Para um controle mais refinado, selecione a opção Add Classification Attribute Criteria e especifique o Attribute de uma classificação e seu Valor associado. No exemplo mostrado aqui, apenas Capacitores da classe
102-Capacitorscom um valor deCapacitanceigual a10uFserão sincronizados.
More on Windchill PartsLink
No próprio Windchill, uma Classificação PartsLink é definida pela criação de um binding attribute que pode ser aplicado a um tipo de peça. Em seguida, um Atributo de Classificação de peça é adicionado a uma classe de Classificação definida.
As entradas de componentes no Windchill incorporarão sua Classificação definida e quaisquer parâmetros de Atributo de Classificação especificados, que por sua vez ficam disponíveis para o processo de sincronização de componentes PLM do Workspace.
Quando uma entrada de componente é sincronizada do Windchill para o Workspace e a interação do PartsLink foi especificada na configuração de PLM do Workspace, os Atributos de Configuração do Windchill para essa peça serão propagados para o Altium Designer.
Quando Sync Direction estiver definido como To PLM ou para sincronização bidirecional (To PLM & To Altium), uma opção Add Filter Criteria é apresentada em Sync To PLM. Use essa opção para definir critérios de Parâmetro ou Pasta que controlarão quais componentes do Workspace serão propagados para o sistema PLM.
Vários critérios de Parâmetro podem ser adicionados para restringir rigidamente a sincronização de componentes do Workspace com o PLM. Os critérios disponíveis também incluem opções de cláusula OR e NOT para estabelecer um controle mais preciso sobre a filtragem dos componentes aceitos para sincronização com o PLM.
A seção Sync to PLM fornece opções adicionais de numeração de peças e prefixo/sufixo ao direcionar para um sistema Arena PLM. Esses esquemas predefinidos de PLM ficam disponíveis para seleção nos menus Numbering Scheme e Code e determinarão o formato do Número do Item das peças enviadas ao Arena.
Mapeamento de parâmetros de componentes
Continue o mesmo processo acima para especificar a configuração de parâmetros de sincronização para todos os componentes que você deseja sincronizar com o PLM. Como os parâmetros de componentes no lado do Workspace não correspondem necessariamente aos do lado do PLM, a seção da interface Component Parameter Mapping pode ser usada para mapear parâmetros entre os dois. Observe que, quando os parâmetros são mapeados, seu valor será sincronizado de um para o outro como se fossem o mesmo parâmetro.
Use o comando Add Parameter da seção para criar uma entrada de mapeamento de um parâmetro do Workspace/PLM que se aplica ao Altium Component Type atualmente selecionado (conforme selecionado em Sync Parameters). As opções de Parameter Name do PLM e do Altium são aquelas disponíveis nos respectivos sistemas. Uma configuração Revision na coluna Item/Revision faz com que uma nova revisão do componente seja criada quando o parâmetro for alterado, enquanto com a configuração Item apenas o parâmetro do componente será atualizado durante a sincronização.
Use o ícone
associado para remover uma entrada de mapeamento.
Qualquer número de parâmetros pode ser mapeado dessa forma; no entanto, é provável que haja uma faixa de parâmetros comuns Workspace/PLM que precise ser mapeada para todos os componentes. Essa abordagem de mapeamento global está disponível quando All Types é selecionado como o Altium Component Type.
Crie entradas de mapeamento (Add Parameter) que se aplicarão a todos os componentes incluindo correspondências conhecidas de parâmetros comuns, e defina as opções Item/Revision e Sync Direction conforme necessário. Também é importante especificar uma entrada de parâmetro mapeado como o Primary Key — este é um par de parâmetros comum que serve como índice de referência entre os dois conjuntos de dados paramétricos. Quando se trata de um Número de Peça do PLM (recomendado), o número criado no lado do PLM é propagado de volta para o lado do Altium, criando um vínculo de referência conhecido entre os conjuntos de dados sincronizados de componentes.
Atributos de classificação de PLM
Para sistemas PLM conectados que oferecem suporte ao agrupamento de componentes como Classifications (como o PTC Windchill), os atributos e valores relacionados do PLM podem ser mapeados para parâmetros de componentes do Workspace nesta seção.
Para o PTC Windchill, por exemplo, para extrair um valor de Atributo de Classificação específico (por exemplo, o valor de capacitância para Capacitores na classe 102-Capacitor), adicione essa classificação e seu valor (Capacitance) como o PLM Parameter Name e o parâmetro de componente Altium de destino (Value) como o Altium Parameter Name. As definições podem ser adicionadas para todos os Tipos de Componente, incluindo várias definições para o mesmo tipo de componente.
► Veja as informações sobre PartsLink acima para mais detalhes sobre Classificações do Windchill.
Part Choices
Use o menu suspenso Sync Direction para especificar em qual direção os dados de Part Choices do fabricante serão sincronizados entre o Workspace e o sistema PLM, ou desative a sincronização de Part Choices com a opção OFF.
Dependendo do tipo de PLM conectado, a opção Part Choice information oferecerá sincronização em um formato compatível com as próprias peças de fabricação aprovadas do PLM (Native PLM Manufacturer Parts) ou como dados convencionais de parâmetros de componente (PLM Part Attributes). Esta última pode consistir em vários conjuntos de atributos de parâmetro Manufacturer:PartNumber — MFR1:MPN1, MFR2:MPN2, por exemplo.
Exemplos de peças de fabricante de PLM “nativas” (ou integradas) incluem Vendor Parts no Arena e Manufacturer Parts no Windchill.
XML de configuração do projeto
Esta seção fornece uma listagem da configuração XML base que define a configuração inicial de PLM para o sistema PLM conectado. A versão baixada desse XML de configuração base (Download Sample Configuration) inclui comentários detalhados que destacam a função da maioria das seções de Entidade e Atributo.
Em última análise, a configuração que você define na interface PLM Integration é armazenada como arquivos XML do sistema, que podem ser salvos localmente a partir do comando Export Configuration associado aos detalhes Server Connection na parte superior da página de configuração.
Uma opção Import Configuration também está incluída. Isso permite aplicar um arquivo XML de configuração existente a uma configuração de PLM nova (ou editada), o que então duplicará essa configuração de PLM. Além disso, quando for necessário fazer alterações especializadas em uma configuração de PLM existente, o arquivo XML exportado poderá ser editado manualmente e depois importado de volta para a configuração. Observe que os Parameters, Attributes e Values incluídos em um arquivo de configuração diferenciam maiúsculas de minúsculas.
Adição de template de publicação
A configuração de PLM requer a adição de um Publishing Template baseado em XML para oferecer suporte aos processos do Workspace que enviam dados completos do projeto — arquivos de design, dados de componentes e dados de saída de fabricação — para o sistema PLM em uma única ação de “publicação”. Esses processos incluem Publish to PLM, em que o usuário especifica os dados de saída a serem enviados, e Project Releaser with Publish, que envia os dados gerados para o PLM como etapa final do processo de Project Release do Altium Designer.
Adicione um arquivo XML de Publishing Template adequado na guia Publish Template ao criar ou editar sua configuração de PLM. Use o link Sample Project Configurations para baixar uma coleção arquivada de templates para sistemas PLM compatíveis.
Um Publishing Template inclui referências para detalhes do projeto, transferência de dados de componentes, localizações de fontes de dados e distribuições de arquivos de dados de Design, Assembly e Fabrication. Os exemplos baixados incluem templates para todos os PLMs compatíveis, em que cada um incluirá quaisquer regras adicionais de publicação aplicáveis àquele tipo específico de PLM, além de comentários detalhados para ajudar a orientar o que configurar e como fazer isso.
Publishing Folder Support for Windchill PLM
Ao configurar uma instância de integração com Windchill® PLM Integration que será usada para processos de Publish to PLM, você também pode especificar (e criar) uma pasta de destino no Windchill para documentos publicados a partir do Workspace.
Os parâmetros relacionados à pasta do Windchill são definidos no arquivo XML de Publishing Template aplicado à entrada de integração com Windchill PLM no Workspace (veja acima). Os nós de definição de pasta estão no formato de tag <pt:Folder>xxx</pt:Folder> — em que pt é o namespace atual e xxx é o caminho completo da pasta — e são posicionados como uma regra de publicação dentro da seção FileDistribution para cada tipo de documento (como uma saída de PCB.zipFabrication, por exemplo).
Um exemplo da hierarquia da estrutura XML de Publishing seria:
<pt:EntityRule id="FAB">
<pt:FileDistributions>
<pt:FileDistribution archiveName="PCB.zip">
<pt:Folder>PRODUCT/Projects/${project.name}/FAB data</pt:Folder>
A última linha de entrada especificaria (ou criaria) uma pasta de destino de publicação para a saída de PCB.zipFabrication com a estrutura de pastas do Windchill (em que o nome do projeto é MyProject):
PRODUCT
Projects
MyProject
FAB data
Observe que o caminho da pasta definido no arquivo XML de Publishing é absoluto (e não relativo) e pode incluir outras propriedades do projeto, como o Nome do projeto (${project.name}) e o Número da montagem (${project.PLM_ASSEMBLY_NUMBER}).
Publish to PLM with ECO
Os arquivos de configuração para instâncias de Windchill, Agile e Arena PLM também oferecem suporte ao fluxo de trabalho formalizado de Change Order(ECO), que é habilitado no arquivo XML de Publishing Template e definido no arquivo XML de Configuration na seção da entidade altiumType="ProjectChangeOrder".
Dependendo da instância de PLM, as definições de configuração XML incluem o esquema para identificação de Change Order (numeração, localização, ID etc.), atributos específicos de Change Order, como Nome/Título, Descrição e Complexidade da alteração (somente Windchill), e configurações de opção, como estratégia de criação de Change Order (nenhuma, nova ou reutilizar existente) e promoção de status de Lifecycle (somente Windchill e Agile). A Change Order definida é habilitada durante a publicação pela declaração de sua referência publishId no Publishing Template associado.
O template de publicação também oferece suporte a conjuntos de regras que definem como e onde as saídas de liberação (dados de projeto, fonte, assembly e fabrication) são publicadas no PLM.
Depois de definidas nos arquivos XML de Configuration e Publishing Template do servidor, as Change Orders ficam disponíveis durante os fluxos de trabalho dos processos Project Creation e Publishing to PLM, invocados a partir do Altium Designer ou pela interface PLM do Workspace. Um formulário de Change Order associado será apresentado durante o fluxo, no qual as opções da Change Order são especificadas.
A caixa de diálogo Change Order Required do Altium Designer mostrando a etapa inicial de criação do projeto e o Project Release subsequente com ECO habilitado.
No exemplo mostrado aqui, um projeto é criado no Altium Designer a partir de um Template usando o processo Create Project with PLM Initialize (para o Arena PLM), com a opção Create change order(ECO) desabilitada. O projeto é então liberado usando o processo Publish to PLM (User selects) com a opção Create change order habilitada (Yes). No lado do Arena, os itens são posteriormente publicados em relação a uma Change Order (ECO-00042) e seu processo de aprovação inerente.
Baixe um arquivo ZIP contendo os arquivos XML de Arena Configuration e Publishing Template usados neste exemplo.
Modifique um template XLM de exemplo conforme necessário e carregue o arquivo para sua configuração de PLM pela janela Add Publish Template, aberta a partir do botão
. Observe que uma configuração de PLM suporta vários Publish Templates.
Sincronização de componentes
A sincronização de dados de componentes entre seu Workspace do Altium 365 e o sistema PLM conectado é determinada pelo mapeamento e direção de parâmetros habilitados descritos acima, e ocorrerá quando o processo de sincronização for acionado manualmente ou automaticamente em um horário agendado. O próprio processo de sincronização é conduzido por um fluxo de trabalho de processo LibSync integrado.
Dentro de uma instância de configuração de PLM, as opções de sincronização relacionadas são acessadas na guia Component Synchronization, onde o processo pode ser acionado manualmente ou definido para execução agendada. Para este último caso, habilite a opção Synchronize on a schedule e selecione um intervalo de tempo no menu suspenso associado.
Você pode usar as opções do menu
para acionar manualmente um processo LibSync como um evento de sincronização Incremental ou Full:
-
Incremental – aplica apenas os componentes que foram modificados desde a última execução da sincronização (ou seja, cujo timestamp é posterior à data da última sincronização) e que atendem aos critérios de sincronização na configuração. Observe que este é o modo usado quando um evento de sincronização é acionado pelo controle
na página principal de integração PLM — veja abaixo.
- Full – este modo força uma sincronização completa. Todos os componentes que atendem aos critérios de sincronização na configuração serão incluídos.
Executando a sincronização de componentes
A sincronização de componentes (biblioteca) pode ser realizada como um processo manual a partir de uma entrada de instância PLM na página de integração PLM do Workspace, ou como um ciclo automatizado especificado na configuração da instância — veja acima. Clique no controle
associado à instância PLM para invocar manualmente o processo de sincronização, que prosseguirá pelo fluxo de trabalho LibSync usando as configurações definidas na configuração PLM associada.
O controle Actions mudará para
, permitindo que você interrompa o processo de sincronização, se necessário, e a entrada Sync Status indicará que um processo está em andamento. O Status mudará para Completed quando o processo de sincronização for concluído.
Quando a sincronização de componentes é executada, manualmente ou como um evento agendado, o processo LibSync percorre seu Workflow predefinido até ser concluído ou encontrar um erro. Você pode atualizar o navegador (F5) para mostrar o estado atual do processo de sincronização.
Para acessar detalhes de um evento de sincronização concluído, clique no ícone
na coluna Last Sync para baixar o arquivo de log relacionado (ver exemplo) ou selecione a data associada para abrir a entrada do evento na guia Synchronization Status. Observe que, nesta visualização, os eventos de sincronização concluídos são listados quando a opção Closed é selecionada, e quaisquer eventos em execução ou suspensos aparecem quando o modo de visualização Active é selecionado.
As subguias da visualização Status fornecem as seguintes informações:
- Diagram – um gráfico que representa o fluxo de trabalho do processo, com a posição da etapa atual destacada (Concluído ou o estado de erro/falha).
- Data – um resumo informativo da ação do processo, incluindo o sucesso ou falha de suas etapas e um link para o relatório de processo registrado — ver exemplo.
- History – um registro temporal dos principais eventos de sincronização do Workspace listados em sequência.
Quaisquer eventos de sincronização que tenham parado prematuramente, como quando um erro foi encontrado, serão listados quando a visualização estiver no modo Active. Essas entradas podem ser removidas da lista com o controle Terminate ou, mais corretamente, avaliadas e resolvidas a partir do bloco de tarefa associado criado na visualização Tasks do Workspace. Observe que um evento de sincronização encerrado/resolvido será movido para a lista Closed da visualização Synchronization Status com um Status indicativo, como Failed.
Acessando processos relacionados ao PLM
Exemplos de fluxos de trabalho de Process relacionados a um sistema PLM conectado estão disponíveis nas guias de temas de processo na página Workspace Processes. Em geral, os exemplos não podem ser usados diretamente, mas devem ser salvos novamente com um nome diferente para se tornarem ativos.
► Consulte a documentação de Processes & Workflow para mais informações.
Um administrador do Workspace pode iniciar uma nova instância de qualquer definição de processo ativada diretamente da listagem de processos na página Processes, clicando no controle
. Usuários do Workspace que não sejam administradores também podem iniciar Processes ativos a partir do Workspace, como:
-
Um processo Part Request with PLM a partir do botão
na página Part Request.
-
Um processo Publish to PLM a partir do botão
nas páginas Tasks e Activities de um projeto aberto.
-
Um processo Publish to PLM a partir do botão
na página principal Projects.
-
Um processo Project with Initialize in PLM a partir do botão
na página principal Projects, ou ao clonar um projeto pelo menu do botão
.
Na prática, porém, os processos relacionados ao PLM normalmente são invocados a partir do Altium Designer durante o design e o desenvolvimento do projeto. Os processos relacionados ao PLM são acessados a partir do Altium Designer das seguintes formas:
-
Part Request with PLM Part Create – Acessados nos painéis Explorer, Manufacturer Part Search e Components do Altium Designer.
► Consulte Process-based Part Requests para informações detalhadas. -
Publish to PLM (User selects) – Acessados a partir do submenu Project » Project Activities do projeto ativo no Altium Designer.
► Consulte Publishing to a PLM – user-selects para informações detalhadas. -
Project Releaser with Publish – Acessados como a etapa final do Project Releaser a partir do submenu Project » Project Releaser do projeto ativo no Altium Designer.
► Consulte Design Project Release – publishing to PLM para informações detalhadas. -
Project with initialise in PLM – Acessados ao criar um novo projeto no Altium Designer a partir do submenu File » New » Project in <Workspace>, ou ao clonar um projeto.
► Consulte Publishing to a PLM – initialize in PLM para informações detalhadas.
Fluxos de trabalho de processo
As seguintes definições de processo (e fluxos de trabalho subjacentes) estão disponíveis por meio do Workspace, em suporte à integração com PLM:
-
Part Requeststema de processo:
- Part Request with PLM Part Create – oferecendo suporte à criação automática de um Component na sua instância de PLM e, em seguida, à propagação do número de peça gerado de volta para o componente do Workspace. O diagrama do fluxo de trabalho é mostrado abaixo.
Um ponto importante a observar é que, ao modificar esta definição de exemplo para criar a sua própria, você deve especificar a instância de PLM na qual as peças serão criadas. Selecione a entidade Create Part in PLM no diagrama do fluxo de trabalho e escolha a instância de PLM no menu suspenso associado ao campo PLM Instance. Esse menu lista todas as instâncias de PLM atualmente definidas (conforme definido na página PLM Integration da interface).
► Consulte Creating and Managing Processes para mais informações sobre como trabalhar com fluxos de trabalho de processo.
- Project Activitiestema de processo:
- Publish to PLM (User selects) – publicação das saídas liberadas do projeto gerenciado para a instância PLM integrada, em que o usuário pode selecionar exatamente quais saídas serão publicadas. O diagrama do fluxo de trabalho é mostrado abaixo.
- Project Releaser with Publish – publicação na instância PLM integrada como uma etapa adicional do Project Releaser. O diagrama do fluxo de trabalho é mostrado abaixo.
-
Project Creationstema de processo:
- Project with initialise in PLM – oferecendo suporte à criação automática de números de peça na sua instância de PLM e, em seguida, à propagação deles como parâmetros do projeto de design do Workspace. O diagrama do fluxo de trabalho é mostrado abaixo.
























. 












