Altium Designer Documentation

Улучшения в управлении структурой слоев

Последнее изменение: Pavel Demidov; 11.06.2019
Эта страница документации относится к Altium Vault – продукту, который больше не поддерживается. Altium Vault и его функциональные возможности по управлению компонентами теперь доступны в Altium Concord Pro.

Краткое описание нововведения

Определение структуры печатной платы является очень важным элементом успешного проектирования электронного устройства. Процесс трассировки многих современных плат осуществляется как проектирование ряда элементов цепи, или линий передач, а не простых проводников, которые переносят электрическую энергию.

Для успешного проектирования быстродействующей конструкции необходимо грамотно подобрать материалы и задать структуру слоев, а также настроить параметры трассировки, чтобы достичь подходящего импеданса трассировки одиночных цепей и дифференциальных пар.

Существует также ряд других аспектов, которые необходимо учитывать при проектировании современной быстродействующей платы: парность слоев, переходные отверстия, требования к обратному высверливанию, требования к гибко-жестким платам, балансировка проводников, симметрия структуры слоев, соответствие материалов.

Новый менеджер структуры слоев Layer Stack Manager разработан для учета всех этих требований в едином редакторе. Менеджер Layer Stack Manager открывается как отдельный документ, подобно документу схемы, платы и др.

Менеджер структуры слоев Layer Stack Manager открывается в отдельной вкладке.

Работа с менеджером структуры слоев Layer Stack Manager

Выберите команду Design » Layer Stack Manager из меню редактора плат, чтобы открыть вкладку менеджера Layer Stack Manager.

Вкладку менеджера Layer Stack Manager (LSM) можно оставить открытой при работе с платой, чтобы переключаться между платой и менеджером структуры слоев. Поддерживаются все стандартные действия над вкладкой, такие как разделение экрана и открытие на отдельном мониторе. Обратите внимание, что в Layer Stack Manager необходимо выполнить сохранение (команда Save), чтобы изменения были отражены в документе платы.

Сводка функциональных возможностей

  • Слои отображены в таблице менеджера Layer Stack Manager. Свойства слоев можно изменять, когда выбрана вкладка Stackup в нижней части менеджера Layer Stack Manager.
  • Свойства выбранного слоя можно редактировать непосредственно в таблице или на вкладке General панели Properties (в режиме Layer Stack Manager). Нажмите кнопку , чтобы открыть панель Properties. Подробнее – в разделе Структура слоев.
  • Настройка видимости столбцов осуществляется в диалоговом окне Select columns. Чтобы открыть диалоговое окно, щелкните ПКМ по заголовку существующего столбца и выберите команду Select columns. Можно создавать пользовательские столбцы.
  • У менеджера Layer Stack Manager есть несколько режимов: Stackup (Структура), Impedance (Импеданс) и Via Types (Типы переходов). Выбор режима осуществляется с помощью вкладок в нижней части менеджера Layer Stack Manager. Доступны два дополнительных режима, Printed Electronics и Back Drills, когда включены соответствующие функциональные возможности.
  • На вкладке Via Types осуществляется настройка того, какие слои могут быть соединены с помощью переходных отверстий в плоскости Z. Свойства размещаемых отверстий (диаметр площадки, диаметр сверловки и т.д.) задаются правилами проектирования или вручную. Подробнее – в разделе Типы переходных отверстий.
  • Выбранная ячейка в таблице может быть отредактирована: как текстовое поле, с помощью выпадающего списка или с помощью кнопки , расположенной в ячейке Material.
  • Копирование и вставка осуществляется на уровне ячеек – используйте копирование/вставку отдельных свойств между слоями.
  • Включение возможностей по проектированию печатной электроники, обратного высверливания и гибко-жестких печатных плат осуществляется с помощью кнопки или команд меню Tools » Features. Подробнее об этих возможностях ниже.

Структура слоев

  • Используйте ПКМ или команду Edit » Add Layer для добавления слоя. При добавлении проводящего слоя будет автоматически добавлен диэлектрический слой, если соседний слой также является проводящим.
  • Если включен параметр Stack Symmetry (панель Properties, область Board), будут добавлены парные слои симметрично центральному диэлектрическому слою.
  • Материал слоя можно ввести в выбранной ячейке Material либо выбрать в диалоговом окне Select Material , которое открывается с помощью кнопки .
  • Проводящему слою может быть добавлено дополнительное медное покрытие с помощью меню Layer и добавления слоя Copper plating.
  • Используйте команды Layer Up/Layer Down для перемещения выбранного слоя вверх или вниз по слоям того же типа.
  • Область Board панели Properties включает в себя параметры для включения использования симметрии структуры и соответствия библиотеке – подробнее об этом ниже.
  • В области Board панели Properties также отображена сводка информации по текущему стеку (или подстеку гибко-жесткого проекта).
  • Свойства выбранного слоя отображены в области Layer Properties панели Properties. Набор полей, отображаемых в панели, зависит от типа выбранного слоя.

Расчет импеданса

Ключевым элементом проектирования быстродействующей конструкции является точный контроль над импедансом трасс сигнальных цепей – подход, который называется трассировкой с контролируемым импедансом. Этот подход направлен на поддержание целостности сигналов и сокращение потенциального электромагнитного излучения.

Импеданс сигнала является функцией от свойств проводящих и диэлектрических материалов, структуры и размеров проводников и их возвратных путей и свойств сигнала.

Новая поддержка расчета импеданса основана на программном обеспечении Simberian®.

Расчет импеданса выбранного профиля, S50, для слоя L1.

Другой расчет импеданса выбранного профиля, D90, для слоя L3.

  • Нажмите вкладку Impedance в нижней части менеджера Layer Stack Manager для настройки требований к профилю импеданса. Требуемый профиль импеданса затем можно выбрать в правиле проектирования Routing Width или Differential Pairs Routing.
  • Нажмите , чтобы добавить новый профиль импеданса и определить его тип (Type), целевой импеданс (Target Impedance) и целевую точность (Target Tolerance). Информация о выбранном в данный момент профиле импеданса отображается в верхней части панели Properties. Задайте тип Type, целевой импедансе Target Impedance и целевую точность Target Tolerance.
  • Для каждого сигнального слоя в стеке также отображается слой в области справа. Используйте флажки, чтобы включить текущий профиль импеданса для требуемого слоя.
  • Когда слою назначен профиль импеданса, редактирование отсчетных слоев осуществляется в столбцах Top Ref и Bottom Ref. Обратите внимание, что отсчетным слоем (слоями) может быть сигнальный или экранный.
  • Когда выбран слой, для которого включен профиль импеданса, все слои в стеке затеняются, за исключением тех, которые используются для расчета импеданса выбранного сигнального слоя.
  • При щелчке по слою в области профиля импеданса, расчеты импеданса для сигналов на этом слое, с использованием текущего профиля, отображаются в панели Properties.
  • Поддерживаются прямые и обратные расчеты. Введите целевой импеданс Target Impedance, и расчетная ширина трассы Trace Width изменится автоматически, и наоборот – введите ширину трассы Trace Width, и автоматически изменится целевой импеданс Target Impedance.
  • Для расчетов дифференциального импеданса заблокируйте ширину трассы Trace Width или зазор для трасс Trace Gap с помощью соответствующей кнопки – незаблокированная переменная будет рассчитана при изменении значения целевого импеданса Target Impedance. Либо измените незаблокированную переменную, чтобы изменить целевой импеданс Target Impedance.
  • Показатель травления Etch Factor = Толщина/[(W1-W2)/2]
  • Расчет импеданса поддерживает множество смежных диэлектрических слоев, если они имеют одинаковые диэлектрические свойства. Прилегающие диэлектрические слои, которые имеют различные свойства, в данный момент не поддерживаются.
  • Расчет дифференциального импеданса поддерживает асимметричную полосковую линию, как показано на нижнем из двух изображений выше.
  • Копланарные линии в данный момент не поддерживаются.
  • Все расчеты используют частоту 2 ГГц.

Типы переходных отверстий

Переходные отверстия обеспечивают передачу сигнала между слоями. Обычно переходные отверстия высверливаются после изготовления слоев, поэтому они должны проходить от одной стороны платы до другой.

Сверление переходных отверстий на определенной стадии технологического процесса сделало доступным соединение переходом только двух соседних слоев. Такие переходные отверстия называются глухими (начинающихся с поверхности) и скрытыми (полностью внутри платы).

Улучшения технологических процессов и применение лазерного сверления позволили создавать очень малые (<10 милов) переходные отверстия, формируемые с поверхностного слоя до следующего сигнального слоя. Эти отверстия называются микропереходами (µVias). Благодаря созданию микропереходов в ходе технологического процесса теперь доступно формировать микропереходы, обеспечивающие бесшовную передачу сигналов между слоями.

Все эти типы переходных отверстий поддерживаются.

  • Вкладка Via Types (Типы переходных отверстий) используется для определения требований к тому, какие слои в проекте могут быть соединены с помощью переходных отверстий.
  • Диаметр и размер переходных отверстий (свойства X&Y), размещаемых в проекте, управляются настройками по умолчанию, если переходное отверстие размещается вручную, либо применяемым правилом Routing Style, если переходное отверстие размещается в процессе интерактивной трассировки.
  • Стек новой платы включает в себя одно определение сквозного перехода на вкладке Via Types менеджера Layer Stack Manager. Для двухслойной платы, название переходного отверстия по умолчанию Thru 1:2 – название отражает тип переходного отверстия, а также первый и последний слой, который этот переход соединяет. Удалить сквозной переход по умолчанию нельзя.
  • Нажмите кнопку , чтобы добавить дополнительный тип переходного отверстия. Название нового определения будет содержать <Тип_перехода> <Первый_слой>:<Последний_слой> (например, Thru 1:2). Определение слоев, которые соединяет переходное отверстие, осуществляется в панели Properties.
  • Система автоматически определит тип переходного отверстия на основе выбранных слоев и задаст соответствующее название.
  • Если необходим микропереход, включите флажок µVia. Этот параметр будет доступен, когда переходное отверстие соединяет смежные слои, либо разделенные одним слоем (так называемые Skip via). Перейдите на страницу Поддержка микропереходов, чтобы получить более подробную информацию.
  • Если в стеке слоев включен параметр Stack Symmetry (Симметрия стека), станет доступен параметр Mirror (Зеркальное отображение) для свойств выбранного переходного отверстия (Via Properties). Если он включен, то будет создано зеркальное отображение текущего переходного отверстия, соединяющее симметричные слои в стеке.
  • Свойства размещенных переходных отверстий теперь включают в себя выпадающий список Name, который содержит в себе все типы переходных отверстий, заданных в менеджере Layer Stack Manager. В проекте могут быть переходные отверстия только тех типов, которые определены в менеджере Layer Stack Manager.
  • При изменении слоя в процессе интерактивной трассировки:
    • В панели Properties будет отображен применяемый тип перехода (показать).
    • Если для соединяемых слоев доступно множество подходящих типов переходов, нажимайте клавишу 6 для циклического переключения между доступными типами.
    • Информация о предлагаемом типе перехода отображается в строке состояния (показать).

Обратное высверливание

В быстродействующем проекте, если проводящий материал переходного отверстия выходит за пределы сигнальных слоев, на которых расположена трассировка сигналов, могут произойти отражения сигналов. Это ведет к искажению сигналов и проблемам целостности сигналов. Одним из способов решения является высверливание неиспользуемого проводящего материала переходного отверстия с помощью сверления контролируемой глубины, или так называемой технологии обратного высверливания.

  • Обратное высверливание включается в меню Tools » Features. Настройка свойств обратного высверливания затем осуществляется на вкладке Back Drills, которая появляется после вкладки Via Types.
  • Вкладка Back Drills используется для определения соединения слоев, к которым необходимо применить обратное высверливание, если присутствуют отрезки проводящего материала в контактных площадках и переходных отверстий. Эти настройки используются в сочетании с правилом проектирования Max Via Stub Length, где определяются значения максимального отрезка и увеличения размера сверления. В этом правиле можно использовать параметр Where the Object Matches для ограничения области действия правила, например, для его применения к определенным цепям, на которых необходимо протестировать обратное высверливание.
  • Нажмите кнопку , чтобы добавить новое определение обратного высверливания. Название определения будет задано в соответствии с первым (First layer) и последним (Last layer) слоями, выбранными в разделе Drill Properties панели Properties, например BD 1:3. Параметр First layer определяет первый слой, который необходимо высверлить, параметр Last layer определяет слой, перед которым останавливается сверление (т.е. Last layer – это первый слой в стеке, который не будет высверлен).
  • Если в области Substack Properties включен параметр Stack Symmetry (Симметрия стека), в разделе Drill Properties станет доступен параметр Mirror (Зеркальное отображение). Если он включен, будет создано зеркальное отображение текущего обратного высверливания, например BD 1:3 | 6:4.

Гибко-жесткие конструкции

Печатная плата может быть произведена как жесткая конструкция, как гибкая конструкция или как сочетание гибких и жестких областей. Для таких конструкций необходимо определить множество стеков слоев, для каждой области платы с собственными требованиями к структуре.

Если включен параметр Rigid/Flex, появляются кнопки с названиями стеков. Щелкните, чтобы выбрать и настроить стек. Наведите курсор мыши на изображение, чтобы увидеть гибкий стек.

  • Дополнительные стеки слоев определяются выбором параметра Tools » Features » Rigid/Flex, либо с помощью кнопки .
  • Если параметр Rigid/Flex включен, в верхней части менеджера Layer Stack Manager отображаются кнопки с названиями стеков. На изображении выше кнопка используется для переключения между жестким и гибким стеком.
  • Нажмите кнопку , чтобы добавить новый стек. Новый стек будет выделен в кнопке Substack Selection:
    • Измените имя стека Stack Name и, если необходимо, включите параметр Is Flex в панели Properties. Именование стека может помочь при его назначении области на плате.
    • Используйте флажки слоев, чтобы включить в стек только требуемые слои.
  • Для добавления ламината гибкому стеку:
    • Используйте кнопку Substack Selection для выбора стека, затем нажмите ПКМ в таблице слоев и выберите команду Insert layer above / below » Bikini Coverlay из контекстного меню.
    • Ламинат будет автоматически добавлен выше или ниже внешних проводящих слоев. Используйте флажки, чтобы включить слои ламината в гибкий стек.
    • Для ввода значения отступа ламината включите столбец Coverlay Expansion. Для этого щелкните ПКМ по заголовку существующего столбца и выберите команду Select columns из контекстного меню. Эти слои являются рассчитанными объектами, которые формируются при включенном параметре Custom Coverlays в диалоговом окне Board Region, подробнее см. ниже.

После того, как в менеджере Layer Stack Manager определен стек для каждой области платы с собственными требованиями к структуре, можно определить область поверхности, которую будет занимать каждый стек – для этого нужно переключить рабочее пространство в режим Board Planning Mode (меню View) и разделить плату на отдельные области (Design » Define Split Line). После того, как регионы стеков определены, следует дважды щелкнуть по каждому региону, чтобы открыть диалоговое окно Board Region, где можно задать название региона, назначить стек и включить пользовательские защитные слои, если необходимо (эти слои отображаются в режиме Board Planning Mode). Также доступны управление и просмотр областей в режиме Layer Stack Regions панели PCB.

Печатная электроника

Эволюцией в разработке и технологии электронных изделий является возможность печатать электронные цепи прямо на основании, подобно литью пластмасс, так, что они становятся частью изделия.

Для «печати» цепей существует ряд технологий, в том числе: лазерное напыление, 3D-печать, штамповка. При использовании печатной электроники нет необходимости в стеклотекстолитовой подложке. Вместо этого, цепи формируются прямо на изделии, и проводники повторяют форму и контуры его поверхности.

  • Настройка стека слоев для печатной электроники осуществляется выбором параметра Tools » Features » Printed Electronics.
  • В печатной электронике не используются традиционные диэлектрические слои, вместо них используются локальные диэлектрические области в тех местах, где пересекаются трассы. Когда параметр Printed Electronics включен, в менеджере Layer Stack Manager из текущего стека удаляются все диэлектрические слои.
  • Сигнальные медные слои называются проводящими, диэлектрические слои называются непроводящими.
  • Диэлектрические области определяются размещением областей подходящей формы на непроводящих слоях.
  • Перейдите на страницу Печатная электроника, чтобы получить более подробную информацию.

Актуальная проверка стека и выделение ошибок

Ошибки отмечаются восклицательным знаком. Наведите курсор, чтобы получить подробности об ошибке.

  • Менеджер Layer Stack Manager непрерывно проверяет все настройки и изменения.
  • При обнаружении ошибки она сразу помечается восклицательным знаком ().
  • Ошибки выделяются в том месте менеджера Layer Stack Manager, где они появляются, а также на уровне вкладки менеджера. Наведите курсор на метку, чтобы получить информацию об ошибке.

Библиотека материалов и соответствие библиотеке

Страница диалогового окна: Altium Material Library

Предпочтительные материалы стека слоев могут быть предварительно заданы в библиотеке материалов. Библиотека включает в себя множество материалов, с возможностью определения новых материалов.

  • В менеджере Layer Stack Manager выберите Tools » Material Library, чтобы открыть диалоговое окно Altium Material Library, где можно просмотреть существующие материалы и добавить новые материалы.
  • Для добавления пользовательского материала, выберите нужный тип материала в дереве слева, например Foil (Фольга), и станет доступна кнопка New. У новых материалов в свойстве Source (Источник) будет указано User (Пользователь).
  • Если были определены пользовательские материалы, их можно сохранить в файл базы данных библиотеки материалов. Для этого нажмите кнопку Save.
  • Пользовательские материалы можно загрузить из внешней базы данных библиотеки материалов. Для этого нажмите кнопку Load.
  • Для использования определенного материала в качестве материала слоя, нажмите по кнопке в ячейке Materials этого слоя. Будет открыто диалоговое окно Select Material (Выберите материал), где будут отображены только те материалы библиотеки, которые подходят для выбранного слоя.
  • Если в менеджере Layer Stack Manager включен параметр Library Compliance (Соответствие библиотеке), то для каждого слоя, материал которого был выбран в библиотеке, будет происходить проверка значений его свойств на соответствие значениям свойствам материала в библиотеке. Несоответствующие свойства будут отмечены. Выберите материал повторно (), чтобы обновить значения согласно настройкам в библиотеке материалов.

Симметрия стека слоев

Если необходимо, чтобы структура платы была симметричной, включите параметр Stack Symmetry в разделе Substack Properties панели Properties. После этого будет осуществляться проверка на симметричность относительно центрального диэлектрического слоя. Если будет обнаружено отличие в равноудаленных от центра слоях, будет открыто диалоговое окно Stack is not symmetric (Стек не симметричен).

В верхней части диалогового окна отображается подробная информация обо всех найденных конфликтах в симметрии структуры.

Для достижения симметрии структуры доступны следующие параметры:

  • Mirror top half down (Отразить верхнюю половину вниз) – настройки каждого слоя выше центрального диэлектрического слоя будут скопированы вниз в симметричный ему слой.
  • Mirror bottom half up (Отразить нижнюю половину вверх) – настройки каждого слоя ниже центрального диэлектрического слоя будут скопированы наверх в симметричный ему слой.
  • Mirror whole stack down (Отразить весь стек вниз) – после последнего проводящего слоя будет добавлен дополнительный диэлектрический слой, затем все сигнальные и диэлектрические слои будут скопированы и отражены ниже этого нового диэлектрического слоя.
  • Mirror whole stack up (Отразить весь стек вверх) – перед первым проводящим слоем будет добавлен дополнительный диэлектрический слой, затем все сигнальные и диэлектрические слои будут скопированы и отражены выше этого нового диэлектрического слоя.

Если параметр Stack Symmetry включен:

  • Изменение свойства слоя автоматически применяется и к симметричному слою.
  • Добавление слоя автоматически добавляет соответствующий симметричный слой.

Используйте параметр Stack Symmetry для быстрого определения симметричной платы – определите половину стека слоев, включите параметр Stack Symmetry, затем используйте одну из опций отражения всего стека для копирования этого набора слоев.

Визуализация стека слоев

Эффективным способом проверки стека слоев является его визуализация в 3D.

  • В менеджере Layer Stack Manager выберите Tools » Layerstack Visualizer, чтобы открыть инструмент визуализации Layerstack Visualizer.
  • Используйте элементы управления для настройки отображения стека слоев.
  • Используйте перетаскивание с зажатой ПКМ для вращения платы в инструменте визуализации.
  • Щелкните ЛКМ по изображению, затем нажмите Ctrl+C, чтобы скопировать изображение в буфер обмена Windows.

Работа с шаблонами стеков

  • Используйте команды Load Template (Загрузить шаблон) и Save Template (Сохранить шаблон) в меню File, чтобы загрузить шаблон стека или сохранить текущей стек как шаблон.

 

 

 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.