Altium NEXUS Documentation

Настройка связи с данными от поставщиков_AD

Created: 24.10.2020 | Updated: 27.10.2020
Вы просматриваете версию 3.1. Для самой новой информации, перейдите на страницу Настройка связи с данными от поставщиков для версии 5
На этой странице документации упоминается Altium NEXUS/NEXUS Client (часть развернутого решения NEXUS), поддержка которого прекращена. Все ваши потребности в проектировании печатных плат, управлении данными и совместной работе теперь могут быть реализованы с помощью Altium Designer (с подпиской Altium Designer Enterprise) и подключенного рабочего пространства Altium 365 Workspace. Посетите страницу часто задаваемых вопросов (FAQs) для получения дополнительной информации.

Главная страница: Подробнее о компонентах и библиотеках

Altium NEXUS обеспечивает связь компонентов в проекте с физическими, реальными компонентами, что позволяет получить доступ к данным от поставщиков в процессе проектирования. Благодаря прямому подключению к веб-службам Altium для получения данных о компонентах, вы можете осуществлять поиск по компонентам производителей и выбирать поддерживаемых поставщиков этих компонентов. Эту динамическую информацию о цепочке поставок затем можно интегрировать в процесс проектирования – при создании библиотек, при проектировании и при формировании выходных данных. В общем, эта возможность позволяет осуществлять доступ к базам данных поставщиков из Altium NEXUS для поиска и выбора компонентов производителей.

Параметры, ссылки на даташиты, цены и информацию о запасах любого найденного компонента производителя и связанных с ним компонентов поставщиков можно импортировать в качестве параметров целевого компонента в библиотеке (SchLib, DbLib, SVNDbLib) или компонента, размещенного на листе схемы. Кроме того, можно задать данные для новых компонентов в целевой библиотеке непосредственно из выбранного компонента производителя.

Информация о связанном компоненте и данные от поставщика также будут включены (либо их можно добавить) в состав изделия при выпуске проекта, что особенно полезно с точки зрения процесса закупки.

Возможность настройки связи с данными от поставщиков не требует входа в учетную запись Altium. Поиск по компонентам производителей и поставщиков обеспечивается веб-службами Altium. Тем не менее, для отображения информации о ценах в альтернативных валютах, курсы обмена обновляются ежедневно, и для этого необходим вход в учетную запись.

В этом документе рассмотрена настройка связи с данными от поставщиков для компонентов в библиотеках SchLib, DbLib и SVNDbLib. Если вы используете сервер Altium и серверные управляемые компоненты, то схожая, но отдельная и более функциональная связь между компонентами и цепочкой поставок задается с помощью вариантов выбора компонентов (Part Choices).

► Перейдите на страницу Управление цепочкой поставок для получения более подробной информации о централизованной настройке поставщиков в Altium NEXUS.

Поддерживаемые поставщики

Краеугольным камнем доступа к динамическим данным от поставщиков является расширение Altium Parts Provider. Это расширение обеспечивает доступ к службе, агрегирующей данные от поставщиков, и динамической информации о компонентах от обширного ряда поставщиков.

Расширение Altium Parts Provider.Расширение Altium Parts Provider.

Это расширение устанавливается вместе с Altium NEXUS по умолчанию, но если вы отказались от его установки или случайно удалили его, его можно найти на вкладке Purchased страницы Extensions & Updates. После успешной загрузки и установки расширения перезапустите Altium NEXUS.

Вы также можете обратить внимание на другое расширение, которое устанавливается с Altium NEXUS по умолчанию – Custom Database Parts Provider. Это расширение обеспечивает интерфейс с подключением к любой базе данных компонентов, заданной на сервере Altium, например, подключение ко внутренней базе данных компонентов предприятия (напрямую либо через интерфейс ODBC или OLE-DB). Для получения доступа к этим данным о компонентах необходимо войти на сервер Altium. Эта функциональность не доступна для возможности настройки связи с данными от поставщиков для файловых библиотек компонентов.

Для получения более подробной информации о централизованной настройке поставщиков в Altium NEXUS, в том числе о настройке интерфейса с базой данных компонентов, перейдите на страницу Управление цепочкой поставок.

Настройки поставщиков

Центром управления настройкой того, какие поставщики будут доступны при поиске данных о компонентах, а также других аспектов, связанных с подключением данных от поставщиков, является страница Data Management – Parts Providers диалогового окна Preferences.

Задайте опции, относящиеся к связи с данными от поставщиков, в настройках Altium NEXUS.Задайте опции, относящиеся к связи с данными от поставщиков, в настройках Altium NEXUS.

Когда установлено расширение Altium Parts Provider, используйте раздел Altium Parts Options этой страницы для настройки службы необходимым вам образом.

Опции для настройки поставщиков – доступны, когда установлено расширение Altium Parts Provider.Опции для настройки поставщиков – доступны, когда установлено расширение Altium Parts Provider.

Доступны следующие опции:

  • Location (Расположение) – включите географические регионы, из которых служба будет собирать информацию о компонентах. Многие поставщики относятся к нескольких регионам, но если компонент доступен только в определенном расположении, он будет отображен только при включении этого региона. Для определения приоритета использования перетаскивайте строки расположений в списке с зажатой ЛКМ.
  • Currency (Валюта) – включите международные валюты, которые будут доступны для выбора при поиске компонентов и изучении результатов. Для определения приоритета использования перетаскивайте иконки валют в списке с зажатой ЛКМ.
  • Supplier (Поставщик) – включите поставщиков, которые будут учитываться при выполнении поиска по данным от поставщиков. Будут отображены компоненты только от этих поставщиков. При использовании большего количества поставщиков вы сможете сравнивать и выбирать более выгодные предложения компонентов, необходимых в вашем проекте. Символ в столбце Verified поставщика означает, что служба получает данные непосредственно от этого поставщика.
Обратите внимание, что если вы вошли на сервер из Altium NEXUS, область Altium Parts Options будет доступна только для чтения, и настройки будут определяться сервером, что обозначается иконкой рядом с названием страницы в дереве навигации диалогового окна.

Поиск данных от поставщиков компонентов

Главным элементов интерфейса к доступным компонентам производителей и связанным с ними данным от поставщиков является панель Manufacturer Part Search. Панель использует эффективные функции поиска компонентов, и она выступает в роли прямого портала к физическим компонентам, предлагаемых различными поставщиками, которые были включены. Чтобы открыть панель, выберите команду View » Panels » Manufacturer Part Search из главного меню или команду Manufacturer Part Search из меню кнопки в нижней правой части окна приложения.

Поиск физических компонентов от поставщиков осуществляется через панель Manufacturer Part Search.Поиск физических компонентов от поставщиков осуществляется через панель Manufacturer Part Search.

Как показано здесь, панель можно разделить на три функциональные области:

  • Поиск, типы и фильтры компонентов:
    • В поле Search вверху введите одно или несколько ключевых слов, которые относятся к компоненту. Результаты поиска будут включать в себя ссылки на поставщиков для каждого компонента производителя.
    • Используйте выпадающий список Categories (), чтобы ограничить результаты поиска компонентами выбранного типа.
    • Включите нужные опции параметров в области Filters слева (нажмите , чтобы отобразить ее), чтобы отфильтровать результаты поиска и показать только те компоненты, которые соответствуют указанным значениям параметров.

      Функции, описанные выше, могут быть использованы вместе для быстрого и точного поиска необходимых компонентов и динамических данных от соответствующих поставщиков, доступных для этих компонентов.
  • Результаты поиска:
    • В средней области панели приводятся все компоненты производителей, которые соответствуют текущим критериям поиска, категории и фильтра. В столбце Supply Info приводится сводка данных от поставщиков для каждого элемента: цена за единицу, минимальный заказ и запас от наиболее подходящего поставщика. Цветная полоска, связанная с каждым из компонентов производителей, позволяет быстро оценить статус жизненного цикла этого компонента. Например, зеленая полоска означает, что этот компонент подходит для серийного производства, а красная – что компонент считается устаревшим.
    • Запись выбранного компонента включает в себя ссылку на данные поставщика в столбце Manufacturer Part (например, 12 SPNs), которая открывает таблицу вариантов выбора поставщиков для этого компонента производителя. Каждая ячейка в этой таблице относится к определенному поставщику и предоставляет информацию о текущем уровне запасов, цене и номере компонента поставщика. См. раздел Настройка связи с данными поставщика ниже, чтобы получить информацию о том, как эти данные применяются к компонентам в проекте.
    • Настройки панели, доступные по нажатию кнопки в верхней правой части панели, позволяют задать отображение результатов поиска:
      • Меню Currency (Валюта) – валюта, используемая для отображения информации о ценах в панели, определена настройками приоритета валют на странице Data Management – Parts Providers. Чтобы быстро изменить настройку валюты панели, выберите другую валюту из выпадающего меню.
      • Опция Exclude Invalid SPNs (Исключить некорректные компоненты от поставщиков) – включите эту опцию, чтобы исключить из столбца Manufacturer Part ссылки на данные поставщиков, если эти данные не пригодны для использования – например, если нет информации о ценах или запасах.
      • Ссылка Part Providers Preferences (Настройки поставщиков компонентов) – открывает страницу Data Management – Parts Providers диалогового окна Preferences. Только те поставщики, которые включены на этой странице настроек, будут отображаться в списке поставщиков у компонента производителя.
  • Информация о компоненте:
    • Область Details панели (нажмите вверху справа, чтобы отобразить ее) показывает все доступные данные о выбранном компоненте, включая его параметры, модели, даташиты и ссылки на информацию о компоненте поставщика.
    • Эта область также включает в себя опции загрузки для просмотра/сохранения спецификаций компонента производителя () и локального сохранения самого компонента ().

► Перейдите на страницу панели Manufacturer Part Search для получения подробной информации о ее возможностях.

Настройка связи с данными поставщика

В основе связи с данными от поставщиков лежит ссылка на поставщика (Supplier Link). Эта фундаментальная сущность обеспечивает динамическую связь компонента Altium NEXUS с объектом, поставляемым доступным поставщиком.

Создание ссылки на поставщика включает в себя автоматическое добавление в целевой компонент Altium NEXUS двух параметров:

  • Supplier n
  • Supplier Part Number n

Здесь n – это целочисленный суффикс, используемый для различия объектов поставщиков, если в один компонент добавлено множество ссылок.

Создание ссылки между компонентом в проекте и данными поставщиков можно выполнить путем перетаскивания ячейки поставщика из панели Manufacturer Part Search в целевой компонент или с помощью команды Add Supplier Link. Доступные опции настройки связи зависят от типа компонента, что описано в следующих разделах.

Компонент схемной библиотеки (SchLib)

Когда схемная библиотека открыта в качестве активного документа, есть три области, в которые можно перетащить ячейку поставщика из панели Manufacturer Part Search для создания ссылки:

  • В любое место рабочей области редактора схемных библиотек (убедитесь, что целевой компонент находится в фокусе).
  • На название нужного компонента в области Components панели SCH Library.
  • В область Supplier Links панели SCH Library (убедитесь, что целевой компонент находится в фокусе).

    Добавление ссылки на поставщика в компонент схемной библиотеки путем перетаскивания с зажатой ЛКМ. Два получаемых параметра, которые делают эту связь возможной, можно просмотреть в панели Properties выделенного компонента.

Помимо перетаскивания, ссылку можно добавить следующими способами:

  • Нажмите кнопку в области Supplier Links панели SCH Library, как показано на видео выше. Будет открыто диалоговое окно Add Supplier Links – модальная версия панели Manufacturer Part Search, где будет автоматически осуществлен поиск по параметру Comment выбранного компонента. См. раздел Выполнение поиска – Предлагаемые ключевые слова ниже для получения информации об автоматизированном поиске. Диалоговое окно Add Supplier Links также можно открыть, щелкнув ПКМ в редакторе символа и выбрав команду Supplier Links.
  • Выберите команду Add Supplier Link To <компонент> из контекстного меню ячейки поставщика в панели Manufacturer Part Search, где <компонент> относится к выбранному в данные момент в панели SCH Library компоненту.

    Обратите внимание, что команда Add Supplier Link To <компонент> также доступна при щелчке ПКМ по строке компонента производителя, а не ячейке поставщика этой строки. В этой случае, в целевой компонент будут добавлены данные от поставщика с наивысшим приоритетом (первый в списке, обозначен как 'Best').

Компонент библиотеки на основе базы данных (DbLib, SVNDbLib)

Когда файл DbLib/SVNDbLib открыт в качестве активного документа, ссылку на поставщика можно добавить в компонент базы данных следующими способами:

  • Перетащите с зажатой ЛКМ ячейку поставщика из панели Manufacturer Part Search в запись нужного компонента на вкладке Table Browser.
  • Выделите запись целевого компонента в таблице и выберите команду Add Supplier Link To <компонент> из контекстного меню ячейки поставщика в панели Manufacturer Part Search.
  • Выделите запись компонента на вкладке Table Browser и выберите команду Edit Supplier Links из контекстного меню. Так же, как и для схемной библиотеки, будет открыто диалоговое окно Add Supplier Links, где можно найти и выбрать информацию от поставщика.

Во всех случаях, в таблицу базы данных будут добавлены нужные параметры Supplier n и Supplier Part Number n.

Добавление ссылки на поставщика в запись компонента в базе данных, подключенной с помощью файла DbLib.

Компонент, размещенный на листе схемы

Когда лист схемы открыт в качестве активного документа, ссылку на поставщика можно добавить в размещенный компонент следующими способами:

  • Перетащите с зажатой ЛКМ ячейку поставщика из панели Manufacturer Part Search на схемный символ размещенного компонента.
  • Щелкните ПКМ по компоненту, выберите команду Supplier Links из контекстного меню и добавьте новую запись () в диалоговое окно Supplier Links for <компонент>. Будет открыто диалоговое окно Add Supplier Links, где будет автоматически осуществлен поиск по параметру Comment выбранного компонента. Выберите ячейку данных поставщика для добавления. См. раздел Выполнение поиска – Предлагаемые ключевые слова ниже для получения информации об автоматизированном поиске.
  • Выберите команду Add Supplier Link To Part из контекстного меню ячейки поставщика в панели Manufacturer Part Search, после чего с помощью перекрестия в редакторе схем выберите размещенный компонент (или последовательно выберите множество компонентов).

    Обратите внимание, что команда Add Supplier Link To <компонент> также доступна при щелчке ПКМ по строке компонента производителя, а не ячейке поставщика этой строки. В этой случае, в целевой компонент будут добавлены данные от поставщика с наивысшим приоритетом (первый в списке, обозначен как 'Best').

Во всех случаях, в компонент будут добавлены нужные параметры Supplier n и Supplier Part Number n.

Добавление ссылки на поставщика в компонент, размещенный на листе схемы.

Выполнение поиска – Предлагаемые ключевые слова

При использовании диалогового окна Add Supplier Links для поиска и выбора данных от поставщиков система автоматически ищет компонент производителя на основе параметров, извлеченных из целевого компонента. Это показано в примере выше, где значение параметра Comment компонента автоматически применено в качестве поискового ключевого слова.

Поисковая запись, используемая системой, определена в области Suggested Keywords на странице Data Management – Parts Providers диалогового окна Preferences, которая позволяет настроить применяемое поисковое выражение в соответствии со структурой вашей библиотеки компонентов. Вы можете полностью управлять тем, какие параметры компонентов будут использоваться в качестве ключевых слов, и в каком порядке.

Ключевые слова, предлагаемые по умолчанию, используемые при автоматическом поиске компонентов по базам данных поставщиков.Ключевые слова, предлагаемые по умолчанию, используемые при автоматическом поиске компонентов по базам данных поставщиков.

В области Suggested Keywords диалогового окна, назначенные по умолчанию приоритеты (где наивысший приоритет отображается вверху списка) означают, что сначала в качестве критерия поиска будет использоваться значение параметра Comment. Если у целевого компонента нет комментария, будет использоваться значение параметра Description. Если оно также отсутствует, будет использоваться значение параметра Name компонента.

Вы можете добавлять собственные параметры с помощью кнопки Add. Новая строка параметра (с именем по умолчанию Parameter Name) будет добавлена в низ списка (т.е. с наименьшим приоритетом), и новый параметр будет готов для изменения имени. Чтобы изменить имя существующего параметра, щелкните ЛКМ один раз, чтобы активировать его, затем введите нужное имя. Либо выберите параметр, щелкнув ЛКМ по соответствующему полю приоритета, и нажмите кнопку Edit.

Щелкните ЛКМ где-нибудь в столбце Priority, чтобы применить изменение названия. Также можно нажать Enter, но имейте в виду, что это подтвердит изменение и закроет диалоговое окно Preferences.

Используйте кнопки Move Up и Move Down для перемещения выделенного в данный момент параметра соответственно вверх и вниз в списке и увеличения или уменьшения назначенного приоритета (Priority).

Пример добавленного пользовательского параметра, которому был задан наивысший приоритет.Пример добавленного пользовательского параметра, которому был задан наивысший приоритет.

Хотя параметры по умолчанию можно изменять или удалять, их можно восстановить с помощью выпадающего списка, связанного со строкой параметра.

Импорт данных от поставщика

Параметры, ссылки на даташиты, информацию о ценах и запасах из любого компонента производителя и поставщика, найденного через панель Manufacturer Part Search, можно импортировать в качестве параметров в целевой компонент в библиотеке (SchLib, DbLib, SVNDbLib) или в компонент, размещенный на листе схемы. Информация импортируется с помощью команды Add Supplier Link and Parameters to Part (или ..to <компонент>, если целевым является компонент в библиотеке), доступной из компонента производителя или поставщика в панели, либо это можно делать поэтапно, из списка параметров в области Details панели.

Опции импорта параметров

Перед импортом каких-либо параметров компонентов, информации о ценах и запасах из компонентов поставщиков вы можете определить сопоставление имен. Это особенно полезно, когда, например, определенные параметры уже заданы в компонентах в библиотеках и имена этих существующих параметров отличаются от тех, которые использует поставщик в своих данных. Вместо импорта данных в новый/отдельный параметр, данные можно импортировать в существующий параметр, благодаря настроенному сопоставлению имен. Например, импортировать параметр Resistance от поставщика в целевой параметр Value.

Сопоставление имен параметров определяется в настройках Parameter Import Options страницы Data Management – Parts Providers диалогового окна Preferences.

Настройка опций импортируемых параметров на странице Data Management – Parts Providers диалогового окна настроек Altium NEXUS.Настройка опций импортируемых параметров на странице Data Management – Parts Providers диалогового окна настроек Altium NEXUS.

При импорте параметров система проверит, задано ли в настройках сопоставление для этого параметра, в поле Imported Parameter Name. Если это поле пустое или если параметра нет в списке, параметр будет импортирован с именем, используемым поставщиком. Если в этом поле есть значение, данные будут импортированы в новый или существующий параметр с этим именем. Если параметр существует, данные в нем будут перезаписаны, т.е. значение параметра будет изменено. Существующие параметры не удаляются.

Опции Supplier Link применяются при создании нового компонента в библиотеке из данных от поставщика или при одновременном добавлении ссылки на поставщика и параметров. Для каждого параметра в списке проектировщик может задать его исключение из импорта, а также определить, будет ли использоваться числовой суффикс, что полезно при импорте параметров от множества поставщиков в один компонент Altium NEXUS. Суффикс указывает, что параметр принадлежит определенной ссылке на поставщика – например, импортированный параметр Stock 1 указывает, что он взят из первого поставщика (Supplier 1). Используйте опцию Visible, чтобы определить, должен ли импортированный параметр отображаться в рабочей области.

По умолчанию определено несколько основных параметров, которые все включены для импорта при создании нового компонента по данным от поставщика или при импорте параметров вместе со ссылкой на поставщика. Для этих параметров (кроме параметров Supplier и Supplier Part Number) можно изменять опции, в том числе определять импортируемые имена. Эти параметры по умолчанию не могут быть удалены.
При создании нового компонента из компонента от поставщика или при импорте параметров вместе со ссылкой на поставщика, если параметра для этого компонента нет в списке, он будет импортирован по умолчанию. Чтобы определенный параметр не импортировался, его необходимо явно исключить путем добавления строки в список (в поле Supplier Parameter Name) и включения опции Exclude.

Импорт всех данных о компоненте и поставщике

Самым простым и полным способом импорта данных из компонента производителя и поставщика в локальный компонент является использование функции Add Supplier Link and Parameters To панели Manufacturer Part Search.

Эта команда используется также, как и команда Add Supplier Link To, о которой сказано выше, но она добавит все доступные параметры, ссылки на даташиты, информацию о ценах и запасах из компонента производителя и поставщика, а также ссылку на поставщика, в одно действие.

На изображениях ниже показан пример работы функции для компонента в схемной библиотеке, где команда добавляет данные о компоненте и поставщике в компонент, выбранный в панели SCH Library. В этом случае, у компонента в библиотеке изначально нет параметров, что видно в панели Properties.

Чтобы импортировать все данные в выбранный компонент, найдите нужный компонент в панели Manufacturer Part Search и выберите команду Add Supplier Link And Parameters To <компонент> из контекстного меню ячейки поставщика. Как видно в панели Properties, в целевой компонент будут добавлены все параметры компонента производителя и поставщика, в том числе текущая информация о цене (Pricing) и запасах (Stock). Также импортируются доступные даташиты, которые можно найти в разделе Links вкладки General панели Properties.

  • Импортируемые параметры будут следовать настройкам сопоставления и правилам, указанным в разделе Parameter Import Options страницы Data Management – Parts Providers диалогового окна Preferences.
  • Команда Add Supplier Link And Parameters To также доступна из контекстного меню компонента производителя, а не ячейки поставщика. При ее использовании, в компонент будут добавлены параметры (текущая цена и запасы) от поставщика с наивысшим приоритетом (т.е. от первого в списке поставщика, обозначенного как 'Best').

Добавление ссылки на поставщика и параметров в компонент в базе данных или в размещенный компонент осуществляется схожим образом – выбором целевого компонента и использованием команды Add Supplier Link And Parameters To в панели Manufacturer Part Search.

  • Для компонента в базе данных, необходимо выбрать строку целевого компонента на вкладке Table Browser открытого файла DbLib или SVNDbLib.
  • Для размещенного компонента, где команда называется Add Supplier Link And Parameters To Part, используйте перекрестие курсора, чтобы выбрать компонент (либо последовательно выбрать несколько компонентов) в открытом документе схеме.

Импорт определенных параметров

Заданные параметры производителя/поставщика могут быть импортированы из панели Manufacturer Part Search в библиотеку или в размещенный компонент с помощью команды Add Parameter(s) To, которая доступна в области Details панели – нажмите кнопку , чтобы открыть ее.

Для этого выберите компонент производителя или один из его поставщиков в списке результатов поиска в панели, затем выделите нужные параметры в области Details панели. Щелкните ПКМ по строке одного из выделенных параметров и выберите команду Add Parameter(s) To, чтобы добавить эти параметры в целевой компонент.

  • Для компонента в библиотеке, целевым компонентом является тот, который выбран в панели SCH Library или, для компонента в базе данных, на вкладке Table Browser.
  • Для размещенного компонента, целевой компонент выбирается с помощью перекрестия курсора в редакторе схем.

Что следует отменить касательно добавления пар "параметр-значение":

  • Если параметр уже существует в целевом компоненте, его значение будет обновлено – см. Voltage Rating в примере на изображениях выше.
  • Если параметра еще нет, в целевой компонент будет добавлена пара "параметр-значение" – Tolerance и Material на изображении выше.
  • Процесс следует настройкам, указанным в разделе Parameter Import Options страницы Data Management – Parts Providers диалогового окна Preferences. Например, если параметр Capacitance сопоставлен с параметром Value, то именно параметр Value будет добавлен в целевой в качестве значения емкости – Value 1nF.
  • Параметры от поставщика, такие как Stock и Pricing, доступны в области Details панели Manufacturer Part Search, только если в качестве источника выбрана ячейка поставщика, а не компонент производителя.
  • Так же, как и другие параметры, добавленные данные от поставщика обновят существующие параметры поставщика в целевом компоненте. Суффиксом данных от поставщика останется 1, и последующие добавления не увеличат значение суффикса, в отличие от использования команд Add Supplier Link And Parameters To из исходной записи компонента/поставщика, где можно добавить данные от множества поставщиков (как описано в предыдущих разделах).

Создание нового компонента в библиотеке из компонента от поставщика

Помимо добавления параметров и данных от поставщиков в существующий компонент в библиотеке, как описано выше, вы также можете создать новый компонент в библиотеке путем импорта данных из панели Manufacturer Part Search в целевую библиотеку. Этот процесс добавляет все доступные данные в новый компонент, и номер компонента поставщика (Manufacturer Part Number, MPN) будет добавлен в качестве значения параметра Name компонента. Чтобы новый компонент можно было использовать в проектах, ему понадобится добавить символ и посадочное место.

Чтобы выполнить импорт, откройте целевую схемную библиотеку или библиотеку на основе базы данных, выберите нужный компонент производителя и одного из его поставщиков в панели Manufacturer Part Search, затем выберите команду Import Into из контекстного меню:

  • Для схемной библиотеки, новый компонент будет добавлен в список в панели SCH Library.
  • Для библиотеки на основе базы данных (DbLib, SVNDbLib), новый компонент будет добавлен в список на вкладке Table Browser библиотеки.

Возможность создать новый компонент непосредственно из компонента поставщика позволяет быстро с нуля заполнить библиотеку, тесно связанную с физическими компонентами. Возможность создать новый компонент непосредственно из компонента поставщика позволяет быстро с нуля заполнить библиотеку, тесно связанную с физическими компонентами.

  • При использовании команды Import Into из контекстного меню компонента производителя, а не ячейки поставщика, в новый компонент будут добавлены параметры от поставщика с наивысшим приоритетом (т.е. от первого в списке поставщика, обозначенного как 'Best').
  • Для параметров и информации о ценах и запасах, процесс импорта будет следовать настройкам, указанным в разделе Parameter Import Options страницы Data Management – Parts Providers диалогового окна Preferences.

Просмотр и редактирование ссылок на поставщиков

Ссылки на поставщиков, заданные в компоненте в библиотеке или на схеме, можно просмотреть и изменить с помощью диалогового окна Supplier Links for. Открыть диалоговое окно можно следующими способами:

  • Для компонента в схемной библиотеке – щелкните ПКМ в любом месте рабочей области и выберите команду Supplier Links из контекстного меню.
  • Для компонента в библиотеке на основе базы данных – щелкните ПКМ по строке компонента на вкладке Table Browser соответствующего файла DbLib/SVNDbLib и выберите команду Edit Supplier Links из контекстного меню.
  • Для компонента, размещенного на листе схемы – щелкните ПКМ по компоненту и выберите команду Supplier Links из контекстного меню.

Все определенные на текущий момент ссылки на поставщиков в компоненте схемной библиотеки также можно просмотреть и изменить непосредственно в панели SCH Library. Ссылки на поставщиков выбранного компонента отображаются в разделе Supplier Links панели, а подробные сведения для выбранной ссылки на поставщика отображаются в разделе Supplier Information.

Чтобы добавить дополнительную ссылку на поставщика, нажмите кнопку в разделе Supplier Links. Будет открыто диалоговое окно Add Supplier Links, которое можно использовать для поиска и добавления ссылки на нужный объект. Используйте кнопку , чтобы удалить выбранную ссылку на поставщика из компонента в библиотеке.

Количество и цена

Как правило, поставщики предлагают различные цены в зависимости от количества приобретаемых компонентов. Значения количества компонентов, при которых цена за единицу значительно уменьшается, отличаются не только у различных поставщиков, но и у различных компонентов у одного и того же поставщика. При выборе данных от поставщика в панели Manufacturer Part Search, сводку этой информации можно отобразить в ячейке поставщика нажатием по ссылке Show more. Это позволит выбрать ссылку на поставщика, исходя из текущей цены (и запасов).

Цены на поставщиков и уровни запасов могут меняться. Имейте в виду, что существует задержка обновления информации от поставщиков в базе данных агрегирующей службы Altium Parts Provider. Наведите курсор мыши на символ в ячейке поставщика, чтобы увидеть, когда информация была обновлена последний раз.

Ссылки на поставщиков, добавленные в компонент в библиотеке, позволяют увидеть подробные сведения о ценах в зависимости от количества в разделе Supplier Information панели SCH Library, где эта информация относится к данным от поставщика, выбранным в разделе Supplier Links панели. При изменении значения в поле Order Quantity, цена, отображаемая в столбце Unit Price, изменится цену для этого количества компонентов, указанную в разделе Supplier Information.

Пример отображаемой цены за единицу (Unit Price) в зависимости от указанного объема заказа (Order Quantity), где заказ 100 единиц компонента снижает цену с 0,1 до 0,018 центов за один конденсатор. Пример отображаемой цены за единицу (Unit Price) в зависимости от указанного объема заказа (Order Quantity), где заказ 100 единиц компонента снижает цену с 0,1 до 0,018 центов за один конденсатор.

Конвертация валют

Разные поставщики работают в разных регионах (часто, во множестве регионов), и поэтому часто необходимо узнать цены в других валютах. Altium NEXUS позволяет преобразовать отображение этих цен в одну из поддерживаемых валют.

Чтобы быстро отобразить все цены в одной валюте в панели Manufacturer Part Search, выберите нужную валюту в выпадающем меню Currency, которое отображается при нажатии кнопки в панели. Чтобы цены отображались в валютах по умолчанию, используемых поставщиками, выберите в меню пункт None.

Конвертация валют происходит на основе соответствующих курсов обмена. Эти курсы обновляются ежедневно (раз в сутки), и для применения текущих курсов обмена необходим вход в учетную запись Altium.

Чтобы задать настройки использования валют в Altium NEXUS, включите/отключите валюты и укажите их приоритет на странице Data Management – Parts Providers диалогового окна Preferences.

► Перейдите в раздел Настройки поставщиков выше для получения более подробной информации.

Добавление данных от поставщиков в состав изделия

Ссылки на данные от поставщиков, добавленные в компонент в проекте, или ссылки, добавленные в компонент в библиотеке, который затем был размещен, сохраняются с проектом и становятся доступными для включения в состав изделия – Bill of Materials (BOM).

Отчет BOM

В самом простом случае, ссылки на поставщиков компонента доступны в отчете BOM, сформированном из проекта. Выберите команду Reports » Bill of Materials, чтобы открыть диалоговое окно Bill of Materials for Project, где можно настроить отчет и сформировать его в одном из доступных форматов (Excel, PDF, HTML и т.д.). Отчет BOM также может быть добавлен в качестве выходного отчета в файле Output Job проекта.

► Перейдите на страницу Настройка BOM в менеджере отчета для получения более подробной информации.

Простой отчет BOM покажет параметры из данных от поставщиков компонентов, которые включают в себя ссылки на поставщиков.Простой отчет BOM покажет параметры из данных от поставщиков компонентов, которые включают в себя ссылки на поставщиков.

Если в проекте присутствует документ ActiveBOM (см. ниже), отчет BOM извлечет данные ссылок на поставщиков из этого документа, а не из документов проекта.

Документ ActiveBOM

Более эффективным (и рекомендуемым) подходом к управлению ссылками на производителей и поставщиков в составе изделия проекта является добавление в проект документа ActiveBOM (команда File » New » ActiveBOM Document). Обратите внимание, что наибольшую пользу от такого подхода можно получить при использовании серверных управляемых компонентов.

► Перейдите на страницу Управление составом изделия с помощью ActiveBOM для получения более подробной информации.

ActiveBOM использует решения (Solutions) данных о компонентах для добавления обширного набора динамической информации о компонентах, таких как сведения о компоненте производителя (в том числе статус жизненного цикла), а также цены и уровни запасов поставщиков. Существующие в компоненте ссылки на поставщиков, добавленные ранее в библиотеку или документ схемы, автоматически преобразуются в решения ActiveBOM.

Следующим шагом после решений, полученных из существующих ссылок на поставщиков, является добавление новых решений компонентов в интерфейс ActiveBOM. Решения ActiveBOM, ориентированные на данные от производителей, обеспечивают расширенное сопоставление данных между компонентами в проекте, компонентами производителей и всеми подходящими поставщиками этого компонента. Динамические данные из решений доступны прямо в процессе проектирования, и они становятся источником данных для всех выходных документов, относящихся к составу изделия.

Используйте команду Create/Edit Manufacturer Links из меню кнопки , чтобы добавить решение ActiveBOM в выбранный компонент. Нажмите кнопку в открывшемся диалоговом окне Edit Manufacturer Links, затем выберите подходящий компонент производителя в диалоговом окне Add Part Choices. После подтверждения (кнопка OK), эта ссылка на компонент будет добавлена в виде новой строки в диалоговом окне Edit Manufacturer Links.

После подтверждения этого добавления в диалоговом окне (кнопка ), в строку компонента BOM добавляется решение ActiveBOM. Обратите внимание, что в этом случае решение будет включать в себя полный список доступных поставщиков, где выделена (показана зеленым цветом) опция, обозначенная как лучший выбор поставщика для этого компонента производителя.

Используйте панель Properties для настройки ActiveBOM, в том числе выбора используемой валюты, источника данных о ссылках на производителей, видимых столбцы данных, группирования элементов состава изделия, проверок состава изделия и т.д.

► Перейдите на страницу Управление составом изделия с помощью ActiveBOM для получения более подробной информации.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: