Altium NEXUS Documentation

Управление проектами в Altium NEXUS

Последнее изменение: Pavel Demidov; 08.05.2020
Эта страница документации относится к Altium Vault – продукту, который больше не поддерживается. Altium Vault и его функциональные возможности по управлению компонентами теперь доступны в Altium Concord Pro.

Начальной точкой любого устройства, создаваемого в Altium NEXUS, является проект. Проект Altium NEXUS объединяет набор документов, которые, в конечном итоге, определяют то, что вы хотите создать. Например, документы схемы и платы в проекте платы составляют набор файлов, необходимых для изготовления печатной платы, а документы схемы и физической сборки проекта Multi-board составляют набор файлов, необходимых для изготовления и сборки изделия, состоящего из нескольких соединенных между собой печатных плат.

Набор документов, которые составляют проект, может быть собран в любом доступном ресурсе, локальном для компьютера или нет. Изменения над каким-либо отдельным документом проекта синхронизируются с другими документами при компиляции проекта, что позволяет передавать изменения между различными аспектами проекта, например, между схемой и платой.

Проект Altium NEXUS и его файл проекта (*.Prjxxx, где xxx обозначает тип проекта) определяют связь между входящими в этот проект документами, а также сохраняют настройки и данные на уровне проекта. Файл проекта и типы его документов зависят от типа создаваемого проекта.

Файлы проекта

Altium NEXUS поддерживает ряд проектов различных типов:

  • PCB Project (*.PrjPcb) – набор проектных документов, необходимых для изготовления печатной платы.
  • Multi-board Project (*.PrjMbd) – набор проектных документов и ссылок на дочерние проекты, необходимых для создания изделия из множества взаимосвязанных печатных плат.
  • Integrated Library (*.LibPkg) – набор проектных документов, необходимых для создания интегрированной библиотеки (*.IntLib).
  • Script Project (*.PrjScr) – набор проектных документов, которые хранят один или множество скриптов Altium NEXUS.

Подробнее о типах проектов

PCB Project (Проект печатной платы)

В проекте печатной платы осуществляется ввод электрической схемы, которая формируется из компонентов, размещаемых из библиотек и связываемых между собой.

После этого проект передается в редактор плат, где каждый компонент представлен посадочным местом, а цепи становятся линиями соединения между точками. Здесь задается форма печатной платы, а также структура ее слоев. Правила проектирования задают требования к конструкции, такие как ширина и зазоры трасс. Компоненты размещаются в пределах контура платы, а линии соединения затем заменяются трассами, вручную или автоматически.

По завершении проекта формируется набор выходных файлов, которые можно использовать для изготовления печатной платы, настройки сборочного станка и т.д.

Altium NEXUS также поддерживает концепцию проектов, которые полностью управляются через сервер Altium. Проекты могут быть созданы как управляемые проекты (или преобразованы в такие проекты), и они будут храниться в надежном репозитории в системе контроля версий сервера. Этот подход в значительной степени упрощает управление хранением проектов, контроль версий, управление жизненными циклами и совместное проектирование.

► Узнайте подробнее: Управляемые проекты.

Проекты, которые управляются с сервера, отображаются с соответствующей иконкой, например для управляемого проекта платы.

Multi-board Project (Проект устройства из нескольких электронных модулей)

В проекте Multi-board ввод проекта осуществляется с помощью документа схемы, который соединяет вместе модули дочерних проектов, представляющие существующие проекты плат. Затем данные со схемы Multi-board передаются в документ сборки Multi-board, где осуществляется сборка физических плат, заданных в дочерних проектах, их позиционирование друг с другом и с добавленным корпусом.

Проект Multi-board (*.PrjMbd) по сути определяет электрическую и физическую связность между существующими проектами плат с помощью документа схемы (*.MbsDoc) и синхронизированного с ним документа сборки (*.MbaDoc). Как и проекты других типов, проект Multi-board может быть сохранен на сервере Altium.

► Узнайте подробнее о Проектах Multi-board.

Integrated Library (Интегрированная библиотека)

Интегрированная библиотека создается в проекте пакета библиотеки (*.LibPkg), где в библиотеке SchLib (*.SchLib) создаются схемные символы, а ссылки задают соответствующие модели для других областей проектирования. Моделями, на которые указывают ссылки, могут быть посадочные места, модели для имитации, модели целостности сигналов и трехмерные механические модели.

Файлы, которые содержат модели (PCBLib и т.д.) добавляются в пакет интегрированной библиотеки (*.LibPkg), либо задаются пути поиска для определения их места. Исходные библиотеки схемных символов и требуемые модели затем компилируются в единый файл (*.IntLib), который называется интегрированной библиотекой.

Компоненты также могут храниться на сервере Altium и браться из него как из расширенного решения для управления данными о компонентах. Сервер Altium обеспечивает надежное хранение проектных данных, наряду с дополнительными возможностями, такими как управление жизненным циклом и актуальной информацией о цепочке поставок.

► Узнайте подробнее об управляемых компонентах.

Script Project (Проект скрипта)

Скрипт (*.pas) содержит набор инструкций (автоматизированных команд), которые интерпретируются и исполняются в Altium NEXUS. Написание и отладка скриптов осуществляется в среде соответствующего редактора.

Существует два типа скриптов: блок скрипта (Script Unit) и форма скрипта (Script Form). Блок скрипта может использовать интерфейс API платформы X2 для изменения объектов в документах проекта и управления ими. Форма скрипта содержит в себе элементы управления интерфейса и использует API X2 для формирования диалоговых окон, которые работают в активных проектных документах.

Блоки, формы и модели данных содержатся в проекте скрипта (*.PrjScr), доступ к которому может быть осуществлен локально, либо он может быть сохранен на сервере Altium.

Открытие проекта

Хранение и последующее открытие проектов Altium NEXUS доступно во множестве расположений. Соответствующие команды меню для открытия проекта могут зависеть от типа и места хранения проекта. Тем не менее, команда File » Open Project, которая открывает диалоговое окно Open Project, подходит для большинства случаев.

В этом диалоговом окне предлагается выбор источника проекта (как правило, на жестком диске, где также установлено ПО), сервер, к которому в данный момент подключен Altium NEXUS, и список недавно открытых проектов. Также предлагается возможность найти и открыть проект (*.Prjxxx) через стандартное диалоговое окно Open Windows. При открытии серверного управляемого проекта меню кнопки диалогового окна позволяет определить пользовательский путь извлечения для локальных файлов, который отличается от пути, указанного в настройках системы.

Установка Altium NEXUS включает в себя несколько примеров проектов, которые находятся в папке Examples в области документов Windows – например, для Altium NEXUS, установленного в системе Windows®, перейдите в C:\Users\Public\Documents\Altium\xxx\Examples, где xxx обозначает версию Altium NEXUS.

Открытие проекта из проектного репозитория SVN

Чтобы открыть проект из проектного репозитория SVN, выберите команду File » Check Out из главного меню. Будет открыто диалоговое окно Check Out, где вы можете выбрать один из доступных репозиториев SVN (верхнее выпадающее меню) и указать папку проекта для извлечения локальной рабочей копии.

Настройка и подключение проектных репозиториев осуществляется на странице Data Management - Design Repositories диалогового окна Preferences. Путь извлечения по умолчанию задан в диалоговом окне SVN Design Repository, которое открывается с помощью кнопки на этой странице.

Настройки проекта

Набор настроек проекта будет зависеть от типа проекта. Настройки проекта задаются в диалоговом окне Project Options. Вы можете открыть его с помощью команды Project » Project Options главного меню или щелкнуть ПКМ по имени проекта в панели Projects и выбрать команду Project Options контекстного меню.


Настройки проекта задаются в диалоговом окне Options for Project. Нажмите F1 в какой-либо вкладке, чтобы получить справку по ней.

Подробнее о настройках проекта

Настройки, заданные в диалоговом окне Options for Project, сохраняются в файле проекта (*.PrjPcb). Настройки проекта, которые задаются в других диалоговых окнах и сохраняются в файле проекта:

  • Настройки аннотирования схемы.
  • Настройки выходных документов, таких как отчеты, распечатки, файлы Gerber и т.д. Обратите внимание, что здесь идет речь о настройках выходных документов, доступных через меню редакторов схем и плат, а не о настройках, определяемых в файле OutJob.

Обратите внимание, что серверные параметры хранятся с управляемым проектом на его сервере Altium.

Панель Projects

Панель Projects является центром управления для работы с проектами и их документами в Altium NEXUS. Все открытые документы, которые не были созданы в рамках какого-либо проекта или которые были добавлены в открытый существующий проект, также будут приведены в этой панели.

Чтобы открыть панель, используйте команду View » Panels » Projects или нажмите кнопку в нижней правой части окна приложения и выберите Projects.


Содержимое панели Projects отражает логическую структуру открытого проекта.

Решение большинства связанных с локальными и серверными (управляемыми) проектами задач доступно из панели Projects, которая в сочетании с панелью Storage Manager обеспечивает полное управление проектами всех типов и из любых источников.

► Для получения более подробной информации о панели, в том числе о настройках отображения и иконках, перейдите на страницу панели Projects.

► Для получения более подробной информации о возможностях навигации по панели и предварительного просмотра панели перейдите на страницу Навигация по проекту.

Группа проектов

В Altium NEXUS вы можете открывать и редактировать множество проектов и, если необходимо, сохранять набор проектов в качестве группы проектов ( *.DsnWrk).

В частности, это может быть полезно, если проекты тесно связаны между собой. Создание группы проектов, которая включает в себя все связанные проекты, позволяет открывать, сохранять и управлять множеством проектов как единой сущностью.

Подробнее о группе проектов

  • В панели Projects самая верхняя запись отображает текущую группу проектов – либо по умолчанию (Project Group 1.DsnWrk), либо то, которое вы создали или открыли.
  • Чтобы сохранить открытый набор проектов в качестве группы, выберите File » Save Project Group As из главного меню или щелкните ПКМ в панели Projects и выберите команду Save Project Group As из контекстного меню.
  • Чтобы открыть существующую группу проектов, выберите команду File » Open Project Group из главного меню или щелкните ПКМ в панели Projects и выберите команду Open Project Group из контекстного меню.
  • Чтобы закрыть группу проектов, выберите команду Window » Close All из главного меню.
  • Чтобы закрыть все документы в группе проектов, выберите Window » Close Documents из главного меню.
  • Чтобы создать новую группу проектов, выберите команду File » New » Design Project Group из главного меню – будет загружена пустая группа проектов по умолчанию (Project Group 1.DsnWrk). Тот же самый метод используется для закрытия файла текущей группы проектов.
  • При открытии другой группы текущая группа будет закрыта. У вас будет запрошено сохранение любых несохраненных документов, проектов и изменений текущей группы.
  • Чтобы добавить проект в группу проектов, откройте или создайте проект, затем сохраните текущую группу проектов. Либо щелкните ПКМ в панели и выберите команду Add Existing Project.


Работа с набором связанных проектов как с группой проектов.

Создание нового проекта

Создание нового проекта Altium NEXUS осуществляется через диалоговое окно Create Project, которое может быть открыто из главного меню (File » New » Project) или через контекстного меню панели Projects (Add New Project).

В диалоговом окне доступен выбор из трех вариантов целевого расположения хранения (Locations) для структуры нового проекта:

Используйте опции диалогового окна для определения настроек создания проекта, таких как используемый шаблон, название проекта, путь локальных файлов и связанные параметры. Прочие опции, такие как целевой репозиторий, доступны для серверных (управляемых) проектов и проектов VCS.

► Для получения более подробной информации о настройках диалогового окна перейдите на страницу Create Project.

При создании нового проекта его запись появляется в панели Projects, и все документы, которые являются частью этого проекта, отображаются в иерархической структуре и/или группируются в подпапки, соответствующие назначению и типам этих документов. Панель будет включать в себя только документ проекта, если не использовался шаблон проекта, либо все документы, определенные шаблоном, который был указан на этапе создания проекта.

Создание проекта через интерфейс сервера

Новый управляемый проект может быть создан непосредственно через веб-интерфейс сервера Altium, после чего он может быть открыт в Altium NEXUS.

Для этого сначала нажмите кнопку на странице Project Management сервера (выберите Projects в главном меню). В открывшемся окне Add Project укажите название нового проекта, шаблон и т.д., затем нажмите кнопку для подтверждения. Структура нового проекта станет доступна в Altium NEXUS как управляемого проекта, который может быть открыт с сервера обычным образом.

  • Документы, включенные в новый управляемый проект, соответствуют шаблону проекта, который был выбраны в процессе создания проекта.
  • На этом этапе проектные документы являются экземплярами примененных шаблонов (по сути, пустыми), которые еще не полностью переданы в контроль версий, что обозначено иконкой у каждого документа.

Работа с проектными документами

После того, как проект создан и сохранен в нужное расположение, можно добавлять проектные документы в активный проект, редактировать их и удалять из проекта.

Эти действия можно осуществить в панели Projects, которая отражает структуру проекта и входящих в него проектных документов. Большинство команд, необходимых для работы с проектными документами, доступны в контекстных меню панели.

► Для получения более подробной информации перейдите на страницу панели Projects.

Обратите внимание, что представление документов в панели Projects не отражает того, как документы сохранены на жестком диске или где-либо еще. Содержимое панели следует рассматривать как логическое представление проекта, где физическое расположение и организация хранения файлов документов (и ее тип) зависит от вас – документы могут быть сохранены в папке на локальном компьютере или в локальной сети, в локальном или удаленном репозитории под управлением системы контроля версий или быть управляемыми проектами на сервере Altium.

► Для получения информации об управлении проектными документами с точки зрения хранения файлов перейдите на страницу панели Storage Manager.

При работе с проектными документами в Altium NEXUS, панель Projects с помощью иконок состояния каждого проектного документа и файла проекта отображает, какие файлы документов изменены, сохранены или скрыты. Иконки документов и их значения приведены ниже:

[пусто] Закрыт – документ не открыт.
Открыт – Документ открыт в качестве вкладки в главном окне.
Скрыт – документ скрыт (открыт, но не отображается в рабочей области).
Изменен – документ открыт и изменен (еще не сохранен).
Изменен (проект) – иконка появляется рядом с главным документом проекта, когда его структура изменена (еще не сохранен).
Измененный документ или проект, который еще не сохранен, также отличается символом звездочки рядом со своей записью в панели. Измененные документы также обозначаются звездочкой внутри своих вкладок в главном окне.

Добавление и удаление проектного документа

Проще всего добавить новый или существующий проектный документ в проект, щелкнув ПКМ по имени проекта в панели Projects и выбрав команду Add New to Project или Add Existing to Project соответственно из контекстного меню.


Добавление документа определенного типа в проект.

В проект также можно добавить другие относящиеся к проекту документы, такие как текстовые файлы, PDF, электронные таблицы и т.д. Для этого выберите команду Add Existing to Project и задайте в выпадающем меню диалогового окна обзора Choose Document to Add тип файлов All Files (*.*), чтобы стали доступными файлы всех типов.

Чтобы удалить документ из структуры проекта, щелкните ПКМ по его названию в панели Projects и выберите команду Remove from Project контекстного меню. Обратите внимание, что этот процесс удаляет лишь ссылку на этот документ из проекта, но не удаляет сам исходный документ.

Изменение порядка документов проекта

Документы в панели Projects автоматически группируются в логические группы, или "папки", такие как исходные документы (схемы, платы и т.д.), документы настроек (определения жгутов, файлы Outjob и т.д.) и, в случае иерархического проекта, документы схем верхнего уровня. Документы в каждой их этих групп отображаются по умолчанию в том порядке, в котором они были добавлены, но внутри группы их порядок можно изменять перетаскиванием мышью.

В случае нового иерархического проекта, взаимосвязь между документами будет отображена в панели после компиляции проекта. Обратите внимание, что эту взаимосвязь нельзя определить с помощью перетаскивания документов схем мышью, поскольку соединения между листами и иерархия проекта, по сути, определяются символами листов (Sheet Symbol) и портами (Port).

► Для получения более подробной информации об иерархии проекта перейдите на страницу Создание связности и в справку о разделе Net Identifier Scope вкладки Options диалогового окна Project Options.

Использование документов во множестве проектов

Поскольку проект Altium NEXUS определяет и сохраняет ссылки на файлы документов, может быть создано любое количество проектов, которые ссылаются на одни и те же файлы документов.

Хотя такой способ повторного использования проектных документов может быть удобен (например, стандартная схема источника питания добавляется в несколько проектов), такой подход не является рекомендуемым, поскольку изменение в этих документах повлияет на все проекты, которые ссылаются на них. Намного лучшим подходом повторного использования проектных данных является использование управляемых листов Managed Sheets.

► Для получения более подробной информации о повторном использовании проектных документов и управляемых листах перейдите на страницу Управляемые листы в разделе Повторное использование проектных данных.

Сохранение документа под новым именем

Проектный документ можно сохранить под новым именем с помощью команды File » Save As, которая создает копию файла документа под указанным новым именем. Эта команда доступна, когда документ открыт.

Этот процесс автоматически добавляет копию нового документа в активный проект вместо существующего (исходного) документа. Таким образом, команда выполняет роль переименования документа, но изначальный документ остается неизменным, и он заменяется в проекте новой переименованной копией. Если открытый документ не является частью какого-либо проекта (является свободным документом), то в редакторе будет просто открыто новая копия вместо изначального документа.

Если нужно просто сделать резервную копию документа, используйте команду File » Save Copy As. Будет создана копия файла документа с новым именем, без изменения проекта.

Сохранение документа проекта под новым именем

Так же, как и в процессе, описанном выше, сохранение документа проекта под новым именем создает копию файла проекта и соответствующим образом обновляет его ссылки – новая копия проекта будет ссылаться на те же самые проектные документы, что и изначальный проект.

Этот процесс не создает копию всего проекта, даже если файл проекта сохраняется в другом месте. Для создания полной копии проекта используйте операционную систему, чтобы скопировать директорию проекта в новое расположение, или средство Project Packager Altium NEXUS (см. ниже).

Панель Storage Manager

Чтобы обеспечить контроль над файлами документов в проекте с точки зрения их хранения, в Altium NEXUS присутствует отдельная панель Storage Manager. Панель Storage Manager отображает вид файлов/папок документов активного проекта и включает в себя подробную информацию о каждом документе, в том числе его состояние в системе управления версиями и, когда документ выделен, его историю изменений.

Чтобы открыть панель Storage Manager, нажмите кнопку в нижней части окна приложения и выберите пункт Storage Manager либо используйте команду View » Panels » Storage Manager из главного меню.

Панель Storage Manager предоставляет доступ к командам и опциям для управления проектными документами из одного расположения. Используйте контекстное меню, чтобы осуществить операции, относящиеся к контролю версий (фиксация, обновление и т.д.), и стандартные действия по управлению файлами (открытие, копирование, переименование и т.д.). В нижней части панели отображается временная шкала выделенного документа, и контекстное меню здесь предлагает расширенные действия, такие как сравнение версий файла и возврат к предыдущей версии документа.

Некоторые возможности, доступные в панели Storage Manager, также доступны и в других панелях, например в панели Projects (управление файлами и контроль версий), и в диалоговом окне Local History (сравнение версий) – Project » Local History » Show Local History. Тем не менее, панель панель Storage Manager объединяет эти и многие другие возможности в одно расположение для управления файлами проектных документов.

► Чтобы получить более подробную информацию, перейдите на страницу Storage Manager

Средство Project Packager

Средство Project Packager применимо в ситуациях, когда необходимо создать резервную копию всего проекта или передать его в другое расположение.

Средство в формате мастера архивирует весь проект Altium NEXUS, дерево проектов или пространство Design Workspace (и входящие в него проекты) в указанное расположение в качестве единого архива с отметкой времени. Открытие мастера осуществляется из главного меню (Project » Project Packager) или с помощью команды Project Packager контекстного меню проекта.


Используйте средство Project Packager для передачи всего проекта (или дерева проектов) и связанных документов в zip-файл с отметкой времени.

Мастер предлагает опции для определения:

  • Где необходимо сохранить архив.
  • Как необходимо обработать пути к директориям файлов.
  • Должны ли быть включены выходные, системные или внешние файлы.
  • Должна ли быть включена история проекта.
  • Какие связанные с проектом документы необходимо включать в конечный архив.

Смотрите также

Навигация по проекту

Автоматическое сохранение и локальная история

Управление версиями и проектные репозитории

Варианты проекта

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.