Altium NEXUS Documentation

Testpoint Setup

Modified by Susan Riege on May 18, 2019

Assembly Testpoint Setup dialog  Fabrication Testpoint Setup dialog   The two variations of the Testpoint Setup dialog

Summary

The Assembly/Fabrication Testpoint Setup dialog is used to configure testpoint reports. The banner of this dialog will change (either Assembly or Fabrication) depending on whether it was accessed to configure options for an Assembly or a Fabrication Testpoint report.

Testpoints are assigned manually or can be detected automatically by running the Testpoint Manager

Access

Testpoint output can be generated in one of two ways:

  • By using an Assembly or Fabrication Test Point Report output generator in an OutputJob Configuration file (*.OutJob). Output is generated when the configured output generator is run.
  • Directly from within the active PCB document using File » Fabrication Outputs » Test Point Report or File » Assembly Outputs » Test Point Report. Output will be generated immediately upon clicking OK in the dialog.
The settings defined in the Testpoint Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an Output Job Configuration file. In the former, the settings are stored in the project file; for the latter, they are stored in the Output Job Configuration file.

Options/Controls

Report Formats

  • Text - enable for standard text format in the report.
  • CSV - enable for standard comma separated value format, which can be imported into a spreadsheet application, such as Excel, for further processing.
  • IPC-D-356A - enable for an IPC netlist file which carries blind and buried via information as well as differentiating between through-hole vias and free pads. When imported into a CAM document along with image and drill data, it facilitates the recovery of original net names used in the PCB design, making the PCB easier to understand and manage within the CAM Editor.

Test Point Layers 

These selections allow you to specify a scope for the report:

  • Top layer - check to include valid testpoints assigned on the top of the board.
  • Bottom layer - check to include valid testpoints assigned on the bottom of the board.

Units

  • Imperial - check to output coordinates in inches.
  • Metric - check to output coordinates in millimeters.

Coordinate Positions

  • Reference to absolute origin - select to use the absolute origin as the reference point for testpoint coordinates.
  • Reference to relative origin - select to use the relative origin as the reference point for testpoint coordinates.

IPC-D-356A Options 

This region of the dialog becomes available only when the IPC-D-356A Report Format option is enabled.
  • Adjacency Information - check to include a list of nets that could possibly be shorted then enter the adjacency criteria in the text box.
  • Board Outline - check to permit the description of outlines and other segment type data that are not connected to a specific net then use the drop-down to select the desired data.
  • Conductor Traces - Refer to the IPC-D-356A spec for more detail.
  • Merge Net-Tie Nets - when enabled, if a design contains nets connected by Net-Tie components, these nets will report as distinguished single nets in the netlist.

Generated Files

All generated testpoint files are named first by type (Fabrication or Assembly), then by filename. For example: Fabrication Testpoint Report for BoardFileName. The following file extensions are used, depending on which of the Report Formats is enabled: .txt, .CSV, .IPC (note that this is an ASCII file).

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder. The naming and folder structure is defined in the Output Container that the Testpoint output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name: Project Outputs for ProjectName. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, then the Testpoint files will be written to a further sub-folder named Testpoint Output.

Automatically Opening the Generated Output

When generating Testpoint output, you can specify that the output be opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the IPC-D-356A Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。