Altium Designer Documentation

BOM Management with ActiveBOM

Modified by Phil Loughhead on Aug 17, 2018

Good component selection underlies the success of every electronic product - so just how does the designer go about choosing the most appropriate component? Gone are the days of the design engineer thumbing through their dog-eared component data book, jotting down a part number on a paper parts list, and throwing that parts list over the wall to purchasing when it is time for the first production run.

Not only are the components chosen to fulfill the necessary technical requirements, the designer must also consider the price, the availability and lead time, as well as the requirements of that component during the assembly and testing phases. Choosing the wrong component can be costly, not just in terms of the final unit price, it can also impact the product delivery schedule, or even the ultimate success or failure of the product in the market!

While the highly compressed design/test/manufacture product development cycle means the designer has very little room for error as they select the components, the tightly enmeshed nature of the component information stream - from the manufacturer, to the supplier, to the search aggregator portal, means that accurate component-choice information can be placed right on the designer's screen, as she scrolls through a list of potential components. Altium recognizes the critical role that component selection plays in the design process, and develops software technologies, products and teams that help deliver easy-to-use, detailed and accurate component data and component selection systems, directly in to the designer's workspace.

In the design process, the project BOM is one of the first documents created, as the key components are costed for the first project pricing estimate, and it is one of the last documents to be finalized as the project is handed over for fabrication, assembly and test. And that BOM is much more than a list of the electronic components fitted to the board - it must also detail every screw, standoff, sticker, heatsink and tube of glue required to finish the sub-assembly that the PCB becomes a part of.

ActiveBOM, a powerful Bill of Materials management editor, helps the designer manage this unique set of challenges.

Solving the Component Management Challenge

Ultimately, every single part used in the design must have detailed supply chain information. In the past, designers had to add this information into each component during library creation or design capture, or post-process their design BOM to add the supply chain details in later. With the release of the new ActiveBOM this constraint is removed - the designer can now add supply chain information to the components at any time during the design cycle, entering it directly into the BOM instead of the schematic components, if they choose.

This ability to inject supply chain details directly into the BOM changes the role of the BOM document in the PCB project. No longer a simple output file, ActiveBOM raises the component management process to sit alongside the schematic capture and PCB design processes, where ActiveBOM's BomDoc becomes the source of all Bill Of Materials data for the PCB project, for all BOM-type outputs. ActiveBOM is now the recommended approach to BOM management.

As well as the components placed in the schematic, additional components and BOM-specific data can be added directly in ActiveBOM, for example; yet-to-be-detailed parts, fasteners, the blank board, or the mounting glue. Custom columns can also be added, including a specific Line number column, which supports both auto and manual numbering, with full copy/paste support.

For design components that include manufacturer information, ActiveBOM can use the Altium Cloud Services to access detailed and up-to-date supply chain information. This support extends beyond components placed from a managed content server, also supporting Supplier-linked parts, as well as parts that already have suitable manufacturer details in their parameters.

ActiveBOM presents the list of Items in the BOM at the top, with the supply chain status of the selected Item shown below.

Creating the BOM Document

ActiveBOM's working BOM document is referred to as a BomDoc. Add a new BOM to the project via the File » New sub-menu, or right-click on the project in the Projects panel. Note that each PCB project can only include one BomDoc.

When you add a new BomDoc to your project, the schematic is automatically compiled and all of the existing components are listed in the BomDoc. If there is supply chain data available, suitable manufacturer parts are detailed in the lower region of the interface, as explained in The Supply Chain section below.

As additional components are placed on the schematic they are automatically added into the BomDoc. Additional BOM Items and additional parameters can also be manually added directly in ActiveBOM, via the Add new button, located above the component list. Refer to the Custom BOM Items and Columns section to learn more.

When the BomDoc is opened the project is automatically compiled, and the list of design parts and their supply chain details refreshed. This can take some time when a large design is initially opened and can result in the BomDoc being flagged as a modified file, even though it was just opened.

Each PCB project can only include one BomDoc.

The BOM Items List

The upper region of the BomDoc is a tabular list of all of the components detected in the PCB design project, as well as additional BOM Items you have added directly into the BomDoc. This region is referred to as the BOM Items list.

The components, or BOM Items list, displayed in Base view.

There are 3 view modes available to the display the BOM Items, select the required mode using the buttons located above the list:

 Flat view - a row for every component.

 Base view - a row for each unique component in the project, the Designator column lists the designators of all components of this type. Multiple presentation options are available for grouped designators, select the required Designator Grouping mode in the Properties panel.

 Consolidated view - used when the project includes variants, to display a consolidated BOM for all variants.

The component list supports a number of spreadsheet-like editing features, including:

  • Use the Column tab of the Properties panel to display/hide a column, and define a name Alias for a column.
  • Drag and drop to change the order of columns.
  • Sort by any column, hold Shift to sub-sort on subsequent column(s).
  • Click the Filter icon to filter by column values
  • Select cells using standard Windows selection techniques.
  • Copy cell contents from ActiveBOM, and paste values from an external spreadsheet editor into custom ActiveBOM columns.
  • Click the Set line numbers button , in Base view, to add a line number to each row. Click the dropdown icon on the right of the button to open the Line # Options dialog, where the start and increment values can be defined. Refer to the Line Number Column section to learn more.
  • Click the Add New drop down  to add additional rows or columns. Refer to the Custom BOM Items and Columns section to learn more.
  • Use the standard Windows shortcuts to scroll through the list of BOM Items:
    • Vertical scroll = MouseWheel Roll
    • Horizontal scroll = Shift + MouseWheel Roll

Many of the configuration and BOM display options are set in the ActiveBOM Properties panel.

  • The default grouping for the Base and Consolidated views is by the component ItemID for managed components, or Library Reference for unmanaged components. This can be refined by enabling additional or alternative parameters in the Component Grouping dialog, accessed from the Properties panel.
  • There are a number of display modes available for grouped designators, select the required Designator grouping mode in the Properties panel.

Custom BOM Items and Columns

BOM management for a PCB design project requires the management of components and BOM Items beyond those placed in the schematic and PCB. There are many cases when custom BOM Items or parameters will be used in the PCB design project. For these situations, ActiveBOM supports adding additional BOM Items and columns (parameters), which can then be included in the generated BOM:

  • Custom row -  an easy way to add a custom BOM Item that needs to be accounted for in the design (bare board, glue, etc). All fields in a custom row are user-defined. Custom rows are not managed by ActiveBOM, for example if the quantity is set to 3, there will not be 3 separate items displayed in Flat view. Supply chain searching is also not supported for custom rows.
  • Custom column - additional BOM column, managed in ActiveBOM, that can contain any user-defined text.
  • Custom Item - an additional BOM Item, this is typically for those items that will be needed but are as yet not fully known or do not yet exist in the library. This allows these items to have their cost included in the overall board costing estimation.
  • Vault Item - an additional BOM Item, that is managed manually in the BOM document. An initial Vault Item is chosen when adding this item to the BOM, but can be changed to a different Vault Item at any time via the right-click menu.

After adding a Custom Item or a Vault Item, right-click on it and select the Add Instances of command to define the designator prefix and separator, and the quantity. All other parameters, such as the Description, can be edited directly in the BOM Items grid.

To edit the designator, or to remove an instance of a Custom Item or a Vault Item, right-click on it and select the Edit item command, the Change / Remove dialog will open.

  • Use the Column tab of the Properties panel to quickly find, view and manage column visibility, name or aliases. When there is an alias defined for a column name, this is displayed in the BOM Items grid.
  • All additional BOM Items and parameters added in ActiveBOM are available for other BOM-outputs, and also via the software API.

Data Sources

The default data sources available in ActiveBOM are the schematic component parameters (), the server component parameters for managed Items (), and data added directly into the BOM (). From these sources, ActiveBOM generates the main project BOM Item grid. Data sources are enabled and their display controlled in the Columns tab of the ActiveBOM Properties panel.

By enabling the Sources buttons, the BOM can also include information taken from the following additional data sources:

 From the PCB - enable these to include PCB location / rotation / side of board data in the available Columns, for the each of the components.

 From a Database - to load additional component parameters from an external database (via *.DbLib, *.SVNDbLib, or *.DbLink).

 Altium Cloud Services - enable this to access a broad range of additional component data, for those BOM Items that have been identified by the Altium Parts Provider and show a supply chain solution.

 Document Parameters - enable this to include all detected schematic document parameters, across all schematics in the PCB project, in the available Columns.

The source of each parameter is indicated by the icon in the list of columns.

To display the Properties panel, select View » Panels » Properties, or click the  button at the bottom right of the workspace.

Use the checkboxes below the column list to toggle the visibility of each column type.

Data from the Altium Cloud Services requires the Altium Parts Provider extension to be installed, and an internet connection available.

As well as using the Altium Parts Provider it is also possible to connect to an existing company database, via an ODBC connection. This is achieved by installing the Custom Database Parts Provider extension and enabling it as a provider in the Data Management - Parts Providers. This extension effectively allows the company database to behave as a Managed Content Server parts provider. To learn more, read about Custom Database Parts Providers in the Supply Chain Management page, or watch this video.

Line Number Column

For PCB designs with assembly drawings, or for BOM data exchange between design engineers, cost engineers or purchasing specialists, the BOM line number (BOM Item position No) is a simple method used to individually distinguish BOM lines, which can then be used to explicitly identify or find the corresponding callout, component and depiction in the design.

As the project BOM data source, ActiveBOM supports user-defined Line #’s for the project BOM, and has both manual and automatic Line # (BOM Item position No) management features.

  • To automatically set the position number for the all project BOM Items (components), click the Set Line # button. Line numbers are displayed in the Line # column, in the Item Details group of columns. Click the dropdown icon on the right of the button to open the Line # Options dialog, where the start and increment values can be defined.
  • To manually change Line #'s, switch to Base view mode, select the required cell(s) in the Line # column, and:
    • press Delete on the keyboard to clear the cells, then
    • manually type in new values, or
    • paste a range of values from Windows clipboard.
  • To renumber or continue numbering from a custom added number, click on the required item Line #, then click the Set Line # button to open the Line Numbering dialog, where you can Continue numbering or Renumber all. The base and increment values last defined in the Line # Options dialog Enter and select a seed value in a Line # cell to control the number format.

The Line # management features are available in Base view mode.

The Column Groups

The ActiveBOM components list has distinct groups of columns that present in each view mode, the image above shows the Base view.

The BOM Items grid is clustered into the following major groups:

  1. Item Details (orange highlight in the image) - these columns display parametric component details, such as the Designator, Description, Library Reference and other component parameters.
  2. Solutions (cyan highlight in the image) - the highest ranked manufacturer + supplier(s) from the Supply Chain. The number of solutions (manufacturer parts), and the number of suppliers of each solution, are configured in the ActiveBOM Properties panel - these are indicated by a  solid, colored banner in the supplier tile. Ranking is automatic, and can also be manually defined, as discussed in The Supply Chain section below.
  3. BOM Status (green highlight in the image) - an indication of the current risk associated with each component. Hover over an icon for a description, or alternatively, enable the detailed BOM Status column in the Properties panel to display the description.
  4. Variant Details - in Consolidated View, an additional Group, titled Variants, is added just before the BOM Status column. This group includes a column for the base design, and one for each variant, displaying the quantity (per unit) of each component. Refer to the Working with Variants section for more information.

The display of a columns and the definition of Aliases can be managed in the Columns section of the ActiveBOM Properties panel. To add a custom row, component or column, click the Add new button above the component list.

BOM Verification

ActiveBOM includes a comprehensive set of BOM checks, that are automatically performed each time the BOM is updated.

BOM Status

Each BOM Item is checked for violations, and its status displayed in the BOM Status column. This column is always visible on the right side of the BOM Items list, displaying an icon that indicates that item's status. Note that a BOM Item can fail more than one of the BOM checks, the icon indicates the most severe failure.

BOM Status Icons:

  • Clear - component has solutions, these solutions have suppliers with sufficient stock, and at least one solution has been ranked.
  •   Warning
  • Error
  • Fatal Error

Hover over the icon for a summary of that part's status. Alternatively, enable the display of the detailed BOM Status column to display detailed information. The column can be enabled either via the ActiveBOM Properties panel, which includes a handy search box, or by right-clicking in the column header area of the BOM Items list and choosing the Select Columns command.

Configuring the BOM Checks

The BOM Items are automatically checked for:

  • Violations associated with Design Items: this includes tests such as parts whose BOM parameters do not match the library parameters (ambiguous parameters), and duplicate designators.
  • Violations associated with Part Choices: this includes tests such as an unranked MPN (system assigned ranking only), no suppliers, or a missed target price.

The severity level (report mode) of each BOM check is configured in the BOM Checks dialog. Click the Gear icon  below the BOM Checks detected violations list in the Properties panel (as shown in the image below) to open the dialog.

Filtering the BOM Items List by BOM Status

The Properties panel displays a list of detected BOM check violations that are present in the current BomDoc. Click the Filter icon (as shown below) to filter the main BOM Items list so that it only displays those BOM Items that fail that BOM check. Note that a BOM Item can fail multiple BOM checks.

Click to filter out all BOM Items except those that fail this BOM check.
Click the Gear icon to configure the BOM Checks.

Use the Filter feature to quickly identify all BOM Items that fail a specific BOM Check.

The Supply Chain

Component selection is often a process of juggling availability, unit price, and manufacturing volume. One of the great strengths of ActiveBOM is its ability to bring detailed, up-to-date supply chain information right into the design environment. Having access to this information means the designer can easily monitor their component choices, and adapt these as required.

If a design component includes a recognized manufacturer's part number (MPN), ActiveBOM can access the Altium Cloud Services and attempt to locate supply chain information about the part. A key feature of the cloud services is the Altium Parts Provider, which aggregates live parts information from an extensive list of external suppliers, funneling back information such as price, stock levels, minimum order quantities, into ActiveBOM. 

The Solution

Within ActiveBOM, when a design component has access to this supply chain information, it is presented in the lower region of the ActiveBOM interface. The manufacturer part is shown on the left, with available suppliers detailed to the right.

Each of these rows is referred to as a Solution. Each solution is a specific manufacturer part, often referred to as the MPN (Manufacturer Part Number), with details of one or more suppliers that can deliver that part.

Each row represents a Solution - a manufacturer part and the available suppliers of that part.

Refer to the Including Supply Chain Information in the Parts section to learn more.

  1. Manufacturer details:
    • Part image
    • Manufacturer name
    • Manufacturer Part Number (linked to the part on the Manufacturer's website)
    • Description
  2. Priority of solution (Primary, Secondary 1, Secondary 2, etc)
  3. Stock total: sum of the stock available from the favorite suppliers (global availability). Red if stock < order quantity.
  4. Minimum unit price. Red if no prices or price = 0
  5. Manufacturer Lifecycle: data from Altium cloud services, where:
    • Gray = Default, unknown or no information
    • Green = New or Volume production states
    • Orange = Not Recommended For New Designs
    • Red = Obsolete or EOL
  6. Link to datasheet (Octopart)
  7. Quantity of available favorite Suppliers
  8. User Rank, click to set

Interpreting the Lifecycle State

Use the lifecycle status to help select the most suitable part.

The current lifecycle status is displayed for each solution (as shown in the image above).

The lifecycle status is designed to be used as an indicator, for a number of reasons:

  1. Altium maintains a database of many millions of components, produced by thousands of component manufacturers. Since there is no single, consistent method used by those manufacturers to reflect a component's lifecycle state, the status is based on information aggregated from manufacturers, global distributors and global sales analysis.
  2. A part is only reported as EOL or Obsolete when there is at least one authorized distributor or manufacturer that has confirmed this status.
  3. Determining the Not Recommended for New Design (NRND) status is more complex. Manufacturers sometimes just report if a part is active or not, and may not give advance warning that a part is to be discontinued or replaced. Therefore this lifecycle status does not always concur with the status provided by the manufacturer. The status algorithm uses various information, including real time and historical stock availability from all distributors, to try to determine the availability of the part. Parts which have consistently poor availability (when they have been generally available in the past), or cannot be sourced over a period of time after having previously having good availability, will eventually be flagged as NRND (if they are not already EOL or Obsolete).
  4. The idea of the lifecycle status indicator is to provide simple-to-understand information that helps you to make more informed decisions about a part, by highlighting those parts which may be problematic. However, due to the sheer volume of data and number of components that are managed, there is always a chance that the Altium status lags behind the instantaneous manufacturer status, and is therefore not up-to-date. It is not possible for Altium to guarantee the accuracy of the lifecycle status, it is recommended that if there is any doubt that you double-check with the manufacturer for authorized lifecycle information.

To report a component with an incorrect lifecycle state, visit ciiva.com. Log into Ciiva using your AltiumLive credentials and then search for the part. Down the bottom of each part's result page there is a Report an Error link. Click this to open the Error Report form and enable the Lifecycle Status Indicator checkbox, as shown in this image.

Refer to the MPN Information collapsible section above for details about the colors used to reflect the lifecycle status.

Ranking the Solutions

If multiple manufacturer parts are available - meaning there are multiple solutions - the solutions are automatically ranked from highest to lowest, based on the part's availability, price and manufacturer lifecycle state.

If you prefer to use a lower ranked solution, for example to use a specific manufacturer, you can override the automatic ranking by defining a User Rank, using the star feature, as shown in the image below.

Click on a star to define a user ranking for a solution.

The default settings for BOM Checks will display a warning flag against all unranked parts. This is done to encourage the designer to examine the automatic ranking, and accept or override as they see fit.

The Suppliers

To the right of the manufacturer part details are the available suppliers, with each supplier detailed on a separate tile. These tiles are also referred to as the SPNs (Supplier Part Numbers).

The SPNs are automatically ranked by availability and price. Each SPN tile includes a colored banner, the color reflects the risk associated with choosing that SPN (detailed below). Because the availability and price data can be refreshed at any time from the Altium Parts Provider, the order of the SPN tiles can change.

The SPN tile includes detailed information about the part and its availability.

  1. Tile banner, including: locking pin, supplier name, tile sequence dropdown, where the banner color indicates:
    • Green = Best
    • Orange = Acceptable
    • Red = Risky
      (solid banner indicates a used solution, configured in the Properties panel)
  2. Supplier part number (linked to the part on the Supplier's website)
  3. Last updated icon with details displayed in the tooltip, color indicates:
    • Gray = Default, updated less than one week ago
    • Orange = 1 week < last update < month ago
    • Red = last update > 1 month ago
  4. Part source, details displayed in the tooltip, possible values includes: Altium Parts Provider, Custom Parts Provider, Manual Solution
  5. Stock, red if available stock < order quantity
  6. Order quantity, orange if Minimum Order Quantity (MOQ) > order quantity, information on any surplus displayed in the tooltip
  7. Unit price, red if no price available or price = 0. Unit price includes currency icon, currency is set in the ActiveBOM Properties panel
  8. Order price, red if 0 (meaning no stock or no unit price)
  9. Available price breaks, with MOQs

The available suppliers are defined: in the Data Management - Parts Provider page of the Preferences dialog for this installation of the software, this list can also be filtered down in ActiveBOM in the Favorite Suppliers dialog.

Ranking the Suppliers

The default state for a new BOM Item is that the Suppliers are ranked automatically. Note that this ranking can change over time, as the price and availability of a particular part changes. If required, you can lock an SPN tile to a specific position by clicking the pin icon on the left of the SPN tile banner. The automatic ordering of the SPNs can also be manually overridden, use the drop down on the right of the tile banner to set the required position. If you use the dropdown to manually set the position of an SPN tile, the locking pin is automatically applied.

To learn how to apply supplier-priority to the ranking, refer to the Configuring the Available Suppliers section.

Including Supply Chain Information in the Parts

Through a tightly coupled set of services and teams, Altium maintains a vast catalog of components and component supply chain data. This data is delivered as part of the Altium Cloud Services, coupling into your software installation through the Altium Parts Provider extension.

As well as supporting managed components that already include supply chain information, such as those placed from an Altium Managed Content Server, the new ActiveBOM is also able to search for supply chain data for other components.

To summarize, the components you use in your design can access supply chain data in the following ways:

  1. Parts placed from the Altium Content Vault or a company Managed Content Server (managed parts) - Parts placed from the Altium Content Vault or a company Managed Content Server are already linked to comprehensive supply chain data, via their Parts Choice List.
  2. Parts placed from local libraries that include supply chain information - For parts that already include the manufacturer name and part number, for example parts placed from a company Database Library which includes this information, ActiveBOM can search for that part through the Altium Parts Provider. To do this, ActiveBOM needs to know which component parameters hold those manufacturer details. Click the Manufacturer Link  button in the ActiveBOM Properties panel to open the Define Manufacturer Link Fields dialog, where you define the part parameters that hold the manufacturer details, then click the ActiveBOM  button to initiate the search. Note that this search process can take some time when there are many parts. Refer to the Configuring the Manufacturer Link Fields section for more information.
  3. Parts placed from local libraries that have no supply chain information - These parts can have supply chain information added:
    1. During design capture - using the Part (Supplier) Search feature, which can be performed from the Part Search panel.
    2. Directly in the BOM - by adding a manual solution in ActiveBOM. The advantage of this approach is that it uncouples the supply chain definition process from the schematic capture process.

Each solution's supply chain source is shown in the Manufacturer Lifecycle n column.

Click the button to update all available supply chain data, for all components in the ActiveBOM.

Configuring the Available Suppliers

Supply chain data is delivered through the Altium Parts Provider. The Altium Parts Provider can access details for a vast number of component suppliers, distributed all over the globe. The set of available suppliers is configured at two levels:

  • For this software installation - configure the suppliers in the Data Management - Parts Provider page of the Preferences dialog.
  • For the current project - click the Favorite Suppliers List  button in the ActiveBOM Properties panel to define the suppliers you want to be available in this project. Refer to the Favorite Suppliers dialog page for more information.

Prioritizing by Supplier

ActiveBOM's default behavior is to select suppliers for the chosen manufacturer part based on item availability and price, from those suppliers enabled in the Favorite Suppliers dialog. To prioritize supplier over price, enable the Use supplier priority checkbox in the Favorite Suppliers dialog. When this option is enabled, only solutions available from the enabled suppliers are listed. The exception to this are user-defined manual solutions, which are always shown.

Configuring the Manufacturer Link Fields

If you have unmanaged parts (parts that have not been placed from a Managed Content Server or the Altium Content Vault), ActiveBOM can search for suitable suppliers automatically if the components include manufacturer and part number details somewhere in their parameters. For ActiveBOM to be able to query the Altium Parts Provider for suitable supply chain details for unmanaged parts, it needs to know which of the part's parameters hold the Manufacturer Name and the Manufacturer Part Number. These are configured in the Define Manufacturer Link Fields dialog, click the Manufacturer Link  button to open the dialog. Multiple Name / Part Number parameter pairs can be defined.

Refer to the Define Manufacturer Link Fields dialog page for more information.

Adding a New Solution

Each combination of manufacturer + manufacturer part number, along with the details of the suppliers that can deliver that part, is called a solution, the image below shows 2 solutions for a BOM Item.

Additional solutions can be manually added.

Adding a Manual Solution

As well as the solutions automatically detected by ActiveBOM, you can also add manual solutions to any BOM Item.

To add a manual solution, click the  button located above the Supply Chain solutions, and select the Add Manual Solution command. The Add New Parts Choice dialog will open, where you can search the available suppliers, and add a suitable part. 

In ActiveBOM, manual solutions are supplier-centric. That is, when you add a part, only the chosen supplier is added. Additional SPNs can be added to the same solution, by adding an another solution and choosing the same MPN, as shown in the image below. In this image, two different MPNs have been added to create two solutions, then a second supplier of each MPN has been added to each of them.

Manual solutions are indicated by the Manual solution string in the MPN region, and also by the icon on each SPN tile.

If you add a second supplier of the same manufacturer part (MPN) it will appear as a second SPN for the same solution, rather than as another solution.

Editing or Deleting a Manual Solution

A manual solution can be deleted or its properties edited, by clicking the triangle icon in the SPN, as shown in the image below. Selecting the Edit command will reopen the same dialog that was used to add the manual solution, where you can perform a new search to locate a new MPN and supplier.

An existing manual solution can be deleted or edited.

Create / Edit Part Choice List

For managed components (components sourced from a Managed Content Server), the solutions are detailed in each Item's Parts Choice List (PCL). Additional solutions can be added to a managed part by adding them into the PCL, via the ActiveBOM » Create/Edit PCL command.

This command opens the Part Choices dialog, where you can:

  • Search for and add additional manufacturer parts using the fields on the left of the dialog.
  • Remove an existing solution from the Part Choice List using the Remove button located at the bottom of the Manufacturer Part Choices list on the right of the dialog.

Additional solutions can be added to a PCL stored in your own Managed Content Server, they cannot be added to a BOM Item sourced from the Altium Content Vault.

The PCL defines the manufacturer parts, the suppliers are detected in real-time via the Altium Parts Provider.

Working with Variants

ActiveBOM supports PCB projects that include Design Variants. The Design Variants feature allow a single base PCB design to be created, which is then populated (loaded) in different ways. Each different loading of the assembled board is called a design variant.

Working with Design Variants:

  • Design variants are configured in the Variant Management dialog (Project » Variants).
  • To examine a variant, double-click on its name in the project's Variants folder in the Projects panel, as shown in the image below.

ActiveBOM supports variants in the following ways:

  • Display the BOM for a specific variant in Base view mode or Flat view mode
  • Option to include the Not Fitted items in the BOM Items list
  • Display a consolidated list of all parts used in all variants, in Consolidated view mode
  • Define manual solutions for both base components and varied components

Variants in Base View Mode

For the selected variant, enable the Show Not Fitted option in the Properties panel to include these parts in the BOM Items grid. When this option is enabled, the Fitted column is automatically displayed in the Item Details.

In Base view mode the Fitted column will display either Fitted or Not Fitted. If a part is varied (an alternate part was chosen in this variant), the details of the alternate part are automatically displayed for that BOM Item.

Note that the current variant is displayed in the ActiveBOM status line.

Variants in Consolidated View Mode

The Consolidated view mode displays all components used in all variants. The Consolidated view offers the following features:

  • If a component is varied, there will be a BOM Item for each alternate component that is used, with each of these BOM Items having the same designator. For example, in the image below components DS1 and DS2 are each list twice, as the BGA variant uses a different colored LED from the TSOP variant. Component R1 appears three times, because both the BGA and TSOP variants use a different value resistor than the original value in the base design.
  • In Consolidated view mode, when the Show Not Fitted option is enabled the Fitted column will display Fitted or Varied. Because the Consolidated view shows all components used in all variants, every component displayed
  • For each variant, there is a <VariantName> - Qty column (indicating how many of this component are used in this variant) and a <VariantName> - Price column, which is the unit price times the value in the quantity column.
  • Because some designers create build documentation off the base design as well as the variants, there is also a Quantity column, reflecting the number of instances of this component used in a build of the base design. Hide this column if you do not generate build documentation off the base design.

To learn more about variants, refer to the Design Variants page.

Working Between the BomDoc, the Schematic and the PCB

There are two features available to help you work between the BomDoc, the schematic and the PCB design: Cross Select and Cross Probe. The behavior of these features is configured in the System - Navigation page of the Preferences dialog.

Both of these features can be used to locate the same component in other documents. The difference between Cross Select and Cross Probe is that Cross Select Mode selects the component in the target document but does not actively present that document, whereas Cross Probe actively presents the target document, and can also switch and make the target document's editor the active editor.

You can Cross Select or Cross Probe from the BomDoc to the schematic and PCB, you can not Cross Select or Cross Probe from the schematic or PCB, to the BomDoc.

Cross Select Mode

Cross Select Mode must be enabled in each editor that you wish to use it in, select the Tools » Cross Select Mode command (Shift+Ctrl+X). When Cross Select Mode is enabled the menu icon will be highlighted with an outline .

Cross Select Mode requires the target document to be open. When you select a component in the BOM Items list of the BomDoc, that component will be selected and centered in the target schematic and PCB documents (if Zooming is enabled in the Cross Select Mode options in the Preferences dialog). Note that the target document will not present as the active document.

If the BomDoc is in Base view mode, then all instances of that part are selected on the schematic and PCB, as shown in the image below.

Use the Cross Select feature to locate and select the component chosen in the BOM Item list, in the schematic and on the PCB.

Cross Probing

Where Cross Select is simply a mode, which when enabled, displays the result each time you click in the BOM Items list, Cross Probe is a deliberate action.

Right-click on a BOM Item and select Cross Probe from the context menu to cross probe to that component on the schematic, the PCB component will also be cross probed to if the board file is open.

A key feature of Cross Probe is the ability to switch to the target document's editor. To Cross Probe and switch editors, hold the Ctrl key as you select the Cross Probe command.

Right-click to access the Cross Probe command, there will be an entry for the designator of each component present in that BOM Item.

Generating a BOM

The BOM can be generated directly from the ActiveBOM editor, select the Reports » Bill of Materials command to open the Report Manager dialog and generate the BOM.

The Report Manager presents the BOM data as it will be output. From ActiveBOM it is used to configure the output format and select a template.

The Report Manager is the standard BOM output setup dialog, the same dialog that is opened when Bill of Materials is selected from the schematic or PCB editor's Report menu, or when a BOM is configured in an OutputJob.

The Report Manager will automatically open with the same configuration of columns that are currently displayed in the BomDoc, when:

  • the Report Manager is opened from a BomDoc, or
  • the Report Manager is opened from the schematic or PCB editor's Reports menu, and there is a BomDoc in the project, or
  • if the OutputJob Data Source is set to ActiveBOM Document.

To learn more about configuring the Report Manager, refer to the page BOM Configuration in the Report Manager.

Mapping Design Data into the BOM

Design data can be passed from from the board design process into an Excel Bill Of Materials, by including Field and Column declarations in the Excel template that is applied to the BOM during creation.

  • Fields - Field declarations are used to pass system, document and project parameters into the BOM, such as: filenames, quantity, currency, and so on, that need to be displayed once in the BOM. The Field declaration is replaced by the passed value, as shown in the image below.
  • Columns - Column declarations are used to pass information that appears in all BOM Items, such as the: designator, description, user-defined parameters, and so on. This can also include: line numbers, PCB location data, and custom column data entered into the BomDoc. The Column declaration is replaced by the ColumnName string, with each row below being populated by that column value for a BOM Item, as shown in the image below.

Design data mapped into an Excel spreadsheet, by defining them in the Excel template.

To learn more, refer to the page Including Design Data in the Excel BOM.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.


Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.