Board Insight System

Board Insight is a configurable system of features that gives you complete control over viewing and working with your PCB design. A complex multi-layer board makes for a visually dense and often difficult to interpret design space. Altium Designer's Board Insight system makes it easier to view and understand the objects in your design. It consists of an integrated set of features developed to meet your view management needs.

Integrated with Board Insight are enhanced Single Layer mode and 3D visualization features. In Single Layer mode, you can see clearly what is on a given layer, but also have a perspective as to what is on other layers. 

To the casual observer, a PCB design is quite unintelligible and looks like a mass of lines, circles, arcs, and strings in different colors all jumbled on top of one another. Even with a highly-trained eye, it can be difficult to make sense of the vast amount of design detail. Altium Designer includes a number of features to help find, identify, and manage the display of design content. Collectively these features are known as the Board Insight system.

Board Insight Pop-up Mode

The Board Insight pop-up mode is an excellent tool for viewing objects under the cursor. Press Shift+X (Tools » Browse Objects) to view detailed information about any components and nets located under the cursor, as well as objects that belong to them, for example, pads and tracks. Use Shift+V (Tools » Browse Violations) to view information about violations (of defined Design Rules) currently under the cursor. A graphic of the selected object or violation currently chosen in the pop-up is also displayed. The list is hierarchical allowing you, for example, to drill down for complete detail on the primitive objects associated with a particular violation. You can view detailed information about, select, or zoom to the object/violation by clicking on the object/violation to open a pop-up menu or by using the icons on the right. The options available are:

  • Properties or  - opens the Properties panel for that object or the Violation Details dialog for the violation.
  • Select or  - selects the object or violation in the design space.
  • Zoom or  - zooms in to the object/violation.
Since the pop-up acts on objects under the cursor, it is advised to access the command using its shortcut.

Heads Up Display

The Heads Up Display gives you real-time feedback about objects currently under the cursor in the PCB design space. The Heads Up Display is configurable and can include cursor location, delta information (distance from the last mouse click), current layer, and current-snap grid. As well as the information content, the display font and colors can also be configured. The Heads Up Display can be parked anywhere on the screen or you can have it follow the cursor.

If you pause for a moment as you are moving the cursor, the Heads Up Display will switch to Hover mode. Extra information is displayed in this mode, which can include a summary, available shortcuts, rule violations, net, component, and primitive details.

You can configure the Heads Up Display on the PCB Editor - Board Insight Modes page of the Preferences dialog.

In the Heads Up column of the grid, enable the property option(s) you want to be displayed in the Heads Up display. Font settings for those options can also be configured in the grid.

The following commands of the View » Board Insight menu (can also be accessed by pressing F2 in the design space) can be used to configure the Heads Up Display: 

  • Toggle Heads Up Display (Shift+H) - toggles the Heads Up Display on or off. 
  • Toggle Heads Up Tracking (Shift+G) - toggles the location of the Heads Up Display to be at a fixed position on the board or allows it to be moved with the cursor. The HUD will not jump to the cursor but rather move in relation to where the cursor was when tracking was enabled. It is advised to position the cursor in relation to the current HUD position before using this command.
  • Resets Heads Up Delta Origin (Ins) - resets the Delta Origin to the current mouse coordinates. The distance horizontally and vertically the mouse is moved from the Delta Origin can be displayed in the Heads Up Display. The Delta Origin can also be reset by using the left-click mouse button. This setting can be configured in the PCB Editor - Board Insight Modes page of the Preferences dialog.

    The ability and controls that are used to set the Delta Origin point follow the Insert Key Resets Heads Up Delta Origin and Mouse Click Resets Heads Up Delta Origin options on the PCB Editor - Board Insight Modes page of the Preferences dialog. If both of these options are disabled, the Delta Origin feature is effectively disabled and the delta coordinates will remain at 0,0 as you move the mouse.
  • Toggle Heads Up Delta Origin (Shift+D) - toggles the display of the Delta Origin coordinates. The delta coordinates display the distance horizontally (dx) and vertically (dy) from the Delta Origin coordinates - a point that can be user-defined within the design space. Use the Delta coordinates to gauge distance relative to a position on your board.
Changes made to the Board Insight system affect the PCB domain design space, and therefore, affect all PCB and PCB footprint documents on which you work.

Live Highlighting

Making sense of a complex PCB design is not easy with dense component placements, tight routing, and multiple signal layers. Altium Designer includes a number of net highlighting features to help you examine the routing.

Use the Live Highlighting region of the PCB Editor - Board Insight Display page of the Preferences dialog to configure this feature. 

Use Ctrl+Click to highlight any net on the board. Everything in the design that is not part of that net is dimmed, making the routing stand out on all signal layers, as shown in the image below. To highlight multiple nets, hold the Shift key as you Ctrl+Click on each net. Ctrl+Click in any free space to restore the display.

Net highlighting can also be used dynamically, meaning that as you move the cursor over a net, it will be highlighted. This method uses an outline highlight, which is configurable and does not affect the display of the remainder of the PCB. The image below shows a net highlighted using live highlighting.

The image below is an example of a net being highlighted using Ctrl+Click

Visual Pick List Pop-up

The Visual Pick List pop-up makes it easy to choose the correct object in a crowded design space. A multi-layer PCB design makes for a dense and visually crowded design space with many objects on top of one another. The Visual Pick List pop-up makes object selection simple. Double-click when there are multiple objects under the cursor to display the Visual Pick List pop-up. As you move the mouse through the list, the current object will be displayed in the pop-up, allowing easy identification. The objects in the Visual Pick List pop-up are sorted by layer.

The  icon at the right of a primitive name means that this primitive is part of a PCB component, and the parent PCB component has its primitives locked (the component's Primitives property is in its  state).

Active Layer Control

The PCB editor is a multi-layer environment with only one layer being currently active. There are a few ways to change which layer is currently the active layer. Note that the current layer selection applies only to the 2D viewing mode.

  • Click on the Layer tab at the bottom of the design space.
  • Use the Active Layer drop-down in the Layers region on the Layers & Colors tab of the View Configuration panel.
  • Move through the layers using the following shortcuts.
    • Ctrl+Shift+Mouse wheel - next layer/previous layer
    • + (numeric keypad) - next layer
    • - (numeric keypad) - previous layer
    • * (numeric keypad) - next signal layer

Net Name Displayed on Tracks

Another handy feature to help you work more efficiently is the ability to display net names on the tracks (configured on the View Options tab in the Additional Options region of the View Configuration panel). To use this feature, enable the Repeated Net Names on Tracks option in the Additional Options region. Wherever you are working on the board, you can instantly be sure if the routing you are looking at is the net in which you are interested. 

Displaying net names on the tracks makes it easy to 'read' the routing.Displaying net names on the tracks makes it easy to "read" the routing.

Pad and Via Detail Display Options

You can control the display of pad and via details using the Pad and Via Display Options region of the PCB Editor - Board Insight Display page of the Preferences dialog. You can configure the color, background and font for pad and via information. Strings are automatically presented as right-reading, and aligned in the direction that maximizes the area available to display them. The Use Smart Display Color option automatically selects a font color that renders good contrast so that the text can be easily read.

Locked Objects Display Options

You can control how locked objects are displayed in the design space, making them easier to identify visually. Use the controls in the Show Locked Texture on Objects region on the PCB Editor - Board Insight Display page of the Preferences dialog.

Example of the Only When Live Highlighting option enabled. Example of the Only When Live Highlighting option enabled.

3D Board Insight

3D Board Insight includes projection modes, which display the board either in Perspective or Orthographic projection. Use the Projection region when in 3D viewing mode on the View Options tab of the View Configuration panel to select the desired display mode.

Select Orthographic to see the exact position of objects and text on the PCB without being obscured by surrounding objects. Choose Perspective to see a more realistic 3D view of the PCB.

Note

The features available depend on your level of Altium Designer Software Subscription.

Content