Defining Bending Lines - Advanced Mode

There are two rigid-flex design modes available in Altium's PCB design software. The original, or standard mode, referred to as Rigid-Flex, supports simple rigid-flex designs. If your design has more complex rigid-flex requirements, such as overlapping flex regions, then you need the Advanced Rigid-Flex mode (also known as rigid-flex 2.0). The mode is chosen in Tools menu in the Layer Stack Manager.

The fundamental difference between the modes is that in the original mode, the board shape is split into separate board regions by placing a Split Line, and that Split Line remains as an object defining where one board region ends and another begins. In the Advanced mode each board region is placed separately, or if a larger region is Sliced it becomes two separate region objects. In the Advanced mode, the edges of adjacent board regions define where those two regions meet, not the presence of a Split Line. Because of this difference, there is no Split Line object when the board is in the Advanced Rigid-Flex mode.

Learn more about Designing a Rigid-Flex PCB

The View menu has three PCB editor working modes with easy-to-remember shortcuts, allowing you to quickly switch between:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

The default behavior when switching between 2D and 3D view modes is to retain separate zoom and orientation settings for each view mode. If you want to see the same location and orientation of the board as you switch, press Ctrl+Alt+2 or Ctrl+Alt+3, instead of 2 or 3.

You've just opened a PCB and are wondering if it is using the standard rigid-flex mode or the advanced rigid-flex mode?

You could open the Layer Stack Manager to check. Alternatively, switch to Board Planning Mode (1 shortcut) and have a look at the Active Bar:

Standard Rigid-Flex mode
Advanced Rigid-Flex mode

To define how a flex board should bend, you place one or more Bending Lines. The Bending Line defines where on the surface of the flex region bending is to take place. The Bending Line also defines the angle and radius of the bend. The width of the strip of board surface that is being bent is displayed in orange, this width is calculated from the bend angle and radius (learn more about the bending line properties). Bending Lines are placed and edited with the PCB editor in Board Planning Mode (View » Board Planning Mode, or press the 1 shortcut).


A Bending Line is placed over the flexible region and configured so the board can fold 180 degrees. This video demonstrates placing a Bending Line in Advanced Rigid-Flex mode.

Placing a Bending Line

To place a Bending Line:

  1. Select View » Board Planning Mode or press the 1 shortcut to enter Board Planning Mode.
  2. Select the Place » Define Bending Line command, or click the  button on the Active Bar.
  3. A Bending Line is placed over the required Board Region, it does not attach to it (Bending Lines are associated with one or more Board Regions by the Stack Regions property). Click near the edge of the Board Region to define the Bending Line start location.
  4. Move the cursor to the required end location and click to place the Bending Line. Note that at least one end of the Bending Line must touch or cross the boundary of the Board Region that it applies to.
  5. You remain in Bending Line placement mode, ready to place another Bending Line if required. If not, right-click or press Esc to exit Bending Line placement mode.

The properties of a selected Bending Line can be edited in the Properties panel. Because the Bending Line is on top of a region, you might find that when you click on the Bending Line the region underneath it selects instead. Without moving the cursor, click a second time to select the Bending Line instead of the Board Region.

The properties of the selected Bending Line are displayed in the Properties panel.
The properties of the selected Bending Line are displayed in the Properties panel.

  • It is not critical to exactly start or finish the Bending Line on the edge of the Board Region, the software will automatically extend or shrink the Bending Line so that it is defined from one edge of the region to the other edge.
  • Ensure that the correct Board Region is enabled in the Stack Regions section of the Properties panel.

Moving a Bending Line

To modify the location of an existing Bending Line:

  1. Select View » Board Planning Mode (or press the 1 shortcut) to enter Board Planning Mode.
  2. Click and hold on the vertex at either end of the Bending Line, then drag that vertex to the required location and release the mouse button. The cursor will be constrained to the current cursor snap settings, press Ctrl+E to change the settings as you work.
  3. The bend location will be redefined by the Bending Line's new position.

Select and drag a Bending Line vertex to change the Bending Line's position on the board - the cursor will be constrained by the current cursor snap settings.
Select and drag a Bending Line vertex to change the Bending Line's position on the board - the cursor will be constrained by the current cursor snap settings.

Precisely Locating a Bending Line

When the handle of a Bending Line is moved the handle will snap in accordance with the current snap settings. Press Ctrl+E during movement to pop up the snap setting interactive control panel, as shown in the image below. Press Esc after changing settings to apply the settings and close the panel.

As well as snapping to the snap grid and workspace guides, the Bending Line can also be snapped to existing design objects, such as lines on a mechanical layer. The image below shows a Bending Line handle being positioned on the end vertex of a line on a Mechanical layer. Note that the current Hotspot Snap setting applies (shown on the Status bar) during movement, if the mechanical layer is not the active design layer Hotspot Snap must be configured to All Layers for this snap behavior to work. Press the Shift+E shortcut to cycle the Hotspot Snap setting through the available modes, as you work.

The handle of a Bending Line is being snapped to the vertex of a track placed on a mechanical layer.
The handle of a Bending Line is being snapped to the vertex of a track placed on a mechanical layer.

Removing a Bending Line

To remove a Bending Line:

  1. Select View » Board Planning Mode (or press the 1 shortcut) to enter Board Planning Mode.
  2. Click and hold on one of its vertices to select the Bending Line, then press the Delete key.

Configuring the Bending Line Properties

To edit the properties of a Bending Line in the Properties panel:

  1. Switch to Board Planning Mode (press 1).
  2. Click anywhere within the orange band of the Bending Line to select it.
  3. The Bending Line can be edited in the Properties panel.

The defined bends can be applied when the board is displayed in 3D mode, press the 5 shortcut to fold the board. The rigid Board Region that has the 3D Locked checkbox enabled is the physical ground reference for the 3D display mode (where Z = 0). If the board does not fold as expected, check that the correct rigid region has the 3D Locked checkbox enabled. Note that it is not necessary to uncheck the option in one Board Region before enabling it in another.

Note

The features available depend on your level of Altium Designer Software Subscription.

Content