Altium Designer Documentation

Embedded Board Array

Created: April 19, 2016 | Updated: June 16, 2017
Now reading version 16.0. For the latest, read: Embedded Board Array for version 17.1


The Embedded Board Array dialog.

Summary

This dialog allows you to create a PCB panel (representing the physical board that the PCB is to be manufactured from) as part of your PCB design project. This is also known as panelization . You can use this panel to hold an array of PCBs on using the embedded board array command. You cannot edit the PCBs directly from the board array, only through their original files.

Access

This dialog can be accessed prior to entering placement mode, from the PCB Editor - Defaults page of the Preferences dialog (DXP » Preferences) by double-clicking on Embedded Board under the list of Primitives. This allows you to change the default properties for the object, which will be applied when placing subsequent Objects.

The dialog can also be accessed by selecting Place » Embedded Board Array/Panelize from the toolbar.

After placement, the dialog can be accessed in the following ways:

  • Double-clicking on the object.
  • Placing the cursor over the object and selecting Properties from the right-click context menu.
  • Run command Edit » Change, then click an existing object.

Options/Controls

  • Corner to Corner Spacing  - Shows the current corner to corner spacing between the corners of PCBs in the array. Values can be defined in either mm or mil units. To specify the units when entering a number, add the mm or mil suffix to the value. Default units (metric or imperial) are determined by the Measurement Unit setting in the Board Options dialog (Design » Board Options), and are used if no units are specified.
  • Edge to Edge Spacing  - Shows the current edge to edge spacing between edges of PCBs in the array. Values can be defined in either mm or mil units. To specify the units when entering a number, add the mm or mil suffix to the value. Default units (metric or imperial) are determined by the Measurement Unit setting in the Board Options dialog (Design » Board Options), and are used if no units are specified.
  • Row Spacing - Shows the current vertical pitch between PCBs in the array. The space between two adjacent boards is the pitch minus the height of one board. Edit this field to change the board pitch. Values can be defined in either mm or mil units. To specify the units when entering a number, add the mm or mil suffix to the value. Default units (metric or imperial) are determined by the Measurement Unit setting in the Board Options dialog (Design » Board Options), and are used if no units are specified.
  • Column Spacing - Shows the current horizontal pitch between PCBs in the array. The space between two adjacent boards is the pitch minus the width of one board. Edit this field to change the board pitch. Values can be defined in either mm or mil units. To specify the units when entering a number, add the mm or mil suffix to the value. Default units (metric or imperial) are determined by the Measurement Unit setting in the Board Options dialog (Design » Board Options), and are used if no units are specified. 
  • Location X - Shows the current X (horizontal) coordinate of the bottom left corner of the board array relative to the absolute origin of the PCB document that the board array will be placed on. Edit the field to change the position of the coordinate, which can be entered in either mm or mil units. To specify the units when entering a number, add the mm or mil suffix to the value. Note: The reference point (indicated by a red cross) of the board array is defined by the PCB document linked to the board array. To change the reference point (origin) of the linked board object in the original PCB document of the linked board, select Edit » Origin » Reset / Set menu items to set the origin marker. Default units (metric or imperial) are determined by the Measurement Unit setting in the Board Options dialog (Design » Board Options), and are used if no units are specified.
  • Location Y - Shows the current Y (vertical) coordinate of the bottom left corner of the board array relative to the absolute origin of the PCB document that the board array will be placed on. Edit the field to change the position of the coordinate, which can be entered in either mm or mil units. To specify the units when entering a number, add the mm or mil suffix to the value. Note: The reference point (indicated by a red cross) of the board array is defined by the PCB document linked to the board array. To change the reference point (origin) of the linked board object, in the original PCB document of the linked board, select Edit » Origin » Reset / Set menu items to set the origin marker. Default units (metric or imperial) are determined by the Measurement Unit setting in the Board Options dialog (Design » Board Options), and are used if no units are specified.
  • Rotation - Rotates the board array in increments of 90°. Click to view and select a rotation angle. Enter a value for the board array to be rotated. Note: When selected, you can rotate the board array on the PCB document using the Spacebar hotkey, flip it using the L hotkey, and horizontally mirror it using the X hotkey.
  • Status Message - Layer stack compatibility is checked as the source board is added, and child/parent design layer compatibility is reported at the bottom the the dialog. Layer stack compatibility is automatically checked, and the software will also attempt to resolve any layer stack compatibility issues. During this automatic layer stack synchronization process, the software attempts to: ensure that all required child board layer stack ordered layers exist in the parent board (the PCB file containing the embedded board array), modify the parent board layer in an attempt to achieve synchronization (a child board is never modified), and make only additive or layer type modifications to the parent board (layers are never removed).

Properties

  • PCB Document - Shows the filepath to the current reference PCB document that will be used to populate the array. Click the  button to browse for a different PCB document.
  • Column Count - Shows the number of columns in the board array. Edit this field to define the number of columns in the array.
  • Row Count - Shows the number of rows in the board array. Edit this field to define the number of rows in the array.
  • Locked - Enable to protect the board array from being re-positioned graphically. If you try to edit a primitive that is locked, you will be informed of the locking and asked if you wish to proceed with the action. If this checkbox is disabled, the primitive can be freely edited without confirmation. Note: If the Protect Locked Objects option is enabled in the PCB Editor - General page of the Preferences dialog (Tools » Preferences), and the Locked option for this design object is enabled as well, then it cannot be edited.
  • Mirrored - Enable to horizontally mirror the board array.
  • Link Location To Embedded Board Origin - Enable to reference the board array/panelization from the origin of the embedded board. Disable (default) to build the array based on the bottom left point of the objects in the referenced board's workspace.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: