Using Internal Power & Split Planes with Your PCB in Altium Designer

Created: April 12, 2022 | Updated: June 15, 2022

Parent page: Polygons & Copper Regions

Power Planes

Power planes are special solid copper internal layers that are typically used to provide an electrically-stable ground or power reference throughout the PCB. 

The PCB editor supports up to 16 internal power planes. You can assign a net to each of these layers or share a power plane between a number of nets by splitting it into two or more isolated areas. Pad and via connections to power planes are controlled by the Plane design rules. Power planes are created in the negative. Objects placed on the power plane layer become voids in the copper; the remaining regions will become solid copper.

PCBs are fabricated from an even number of copper layers, so you may need to add another signal or plane layer to return to an even number of layers.

Creating Internal Planes

Internal power planes are added to a PCB design through the Layer Stack Manager (Design » Layer Stack Manager). To add a new internal plane, highlight the existing layer that you want the internal layer created under then select Insert layer below » Plane. A new internal plane is added to the layer stack. Use the Layer Stack Manager mode of the Properties panel to define the properties of the selected internal plane layer.

Viewing Planes

To view an internal plane in the design space, including power types, you must first enable the display of the plane layer on the Layer & Colors tab in the View Configuration panel. 

If necessary, select Tools » Split Planes » Rebuild Split Planes on Current Layer or Rebuild Split Planes on All Layers to recalculate and redraw planes. You may find displaying the pad holes layer and multilayer useful as well. Use the Shift+S shortcut keys to toggle various Single Layer Mode settings that help highlight objects of interest.

In 3D viewing mode (shortcut 3), you can see physical representations of all internal plane objects. In addition to viewing, the 3D environment enables you to travel through the board, making the inspection of internal planes very easy. If you click on an internal plane, the entire area within the pullback tracks is highlighted. You can also select internal planes and their contents to view using the Split Plane Editor mode available from the drop-down menu at the top of the PCB panel.

3D view of a thermal relief connection on a split plane.
3D view of a thermal relief connection on a split plane.

Pullbacks and Power Planes

When a power plane is added, a set of pullback tracks are automatically created around the board shape to pull back the plane from the edge of the board. Pullback tracks cannot be edited on screen as their width is defined in the Layer Stack Manager. If the pullback value for an internal plane has been changed, these tracks will be regenerated automatically.

Creating Blow Out Sections

To 'blow out' sections of a plane, i.e. create copper-free regions, you can place lines, arcs or fills using the Place commands to build up the no-copper region.

Connecting Pads and Vias to a Power Plane

Connections to pads and vias are displayed on a power plane according to the Plane design rules set in the PCB Rules and Constraints Editor dialog (Design » Rules). You can create additional rules for pads and vias that have a specific connection or non-connection requirements.

Thermal Relief and Direct Connections

Through-hole pads and vias can be connected to a power plane by either a direct connection or a thermal relief connection. Thermal relief connections are used to thermally isolate the connected pin from the solid copper plane when the board is soldered. The design rules in the PCB editor allow you to define the thermal relief shape of each or all pads connecting to the power plane.

The Power Plane Connect Style design rule specifies the style of the connection from a component pin to a power plane. Three connection options are available

  • Relief Connect
  • Direct Connect
  • No Connect

Special support is also provided for connecting SMD power pins to power plane layers. SMD pads on a net that is connected to a power plane are automatically tagged as connected to the appropriate plane. The auto-router completes the physical connection for these pads by placing a fanout, which is a short track and via that is a relief or direct connection to the plane layer.

Thermal Relief connection to a pad on a power plane. The colored regions indicate areas of no copper.
Thermal Relief connection to a pad on a power plane. The colored regions indicate areas of no copper.

When a net is assigned to a power plane, a small cross will appear at each pad on the net on the appropriate power plane layer. The cross is displayed as '+' for a relief connection and as an 'x' for a direct connection. As direct connected pads have solid copper to the pin, they show the plane color up to the pad hole.

Pads That Do Not Connect to a Power Plane

Pads not connecting to the plane are isolated from it by a region of no copper. This region of no copper is specified in the Power Plane Clearance design rule as a radial expansion around the pad hole.

Design rules are hierarchical so you can add new rules to override others. Make sure you set the priority order in the PCB Rules and Constraints Editor dialog, i.e. the order in which multiple design rules of the same type are applied.

Connecting Vias to Power Planes

Like pads, vias automatically connect to an internal power plane layer of the same net name. The via will connect in accordance with the applicable Power Plane Connect Style design rule. If you do not want vias to connect to power planes, add a Power Plane Connect Style design rule with a connection style of No Connect and a scope query of IsVia.

Fabrication Considerations

Check with your fabricator for suitable dimensional properties for any thermal relief connections. Also, check that pads or vias that do no connect do not completely surround a connected pad as this may accidentally cause the connected pad to become isolated and disconnected. Ensure to not remove too much copper and that a balance is struck between maximum copper and affordable manufacture.

Disconnecting Pads and Vias from the Plane

You can use queries in the Power Plane Connect Style design rules to further limit which pads or vias connect or not to a power plane. Pads can be targeted by the designator's name or physical properties, such as the pad size. Since vias have no designators, they must be targeted by physical properties, such as the via diameter.

Scoping Specific Pads and Vias That Do Not Connect to a Power Plane

To disconnect, for example, only pads with a specific designator name starting with U7, you could use the (ObjectKind = 'Pad') and (Name Like 'U7-*') query to set the scope for a Power Plane Connect Style design rule. The connection style would be set to No Connect. Another query such as (ObjectKind = 'Pad') and (HoleSize = 25) would target only those pads with a hole size of 25mils.

When working with vias that you do not want to connect, you could modify vias to contain a special property to uniquely identify them, such as a different via diameter then scope a new Power Plane Connect Style design rule with a No Connect connection style to match only those vias. The query (ObjectKind = 'Via') And (ViaDiameter = '24') could be used to target vias with a diameter of 24mil, for example. The query InNet('VCC') and IsVia could be used to target just vias that are attached to the net VCC.

Alternatively, if you cannot select vias using the methods above, you can convert them to free pads then use pad names to set the scope. To do this, select the vias you do not want to connect, convert them to free pads (Tools » Convert » Convert Selected Vias to Free Pads) and assign the same Designator name to them all, e.g., NoPlaneConnect. Then add a new Power Plane Connect Style design rule and specify the scope (ObjectKind = 'Pad') and (Name = 'Free‑NoPlaneConnect') for the rule. Also, select No Connect as the Connect Style. All free pads named NoPlaneConnect will be disconnected from all of the power plane layers.

Removing Internal Power Planes

To remove an internal plane, right-click on the layer in the Layer Stack Manager then choose Delete layer from the context menu. A confirmation dialog opens warning that all primitives on the layer will be removed with the layer deletion. Click Yes to confirm.

Split Planes

A split plane is an enclosed region on an internal plane that divides the plane into separate electrically isolated areas. Each region is defined by placing boundary lines to encompass all the pins on that net. Each area is then assigned to a different net that creates two or more split planes on one internal power plane layer.

Power planes can be split into any number of separate regions. This splitting process is like cutting or slicing the plane into sections where the width of the line you place defines the separation distance. Power planes are constructed in the negative, so these special boundary lines become a strip of no copper, hence, creating the separation between this net and the adjacent net(s) on the plane.

Split planes on an internal plane
Split planes on an internal plane

Typically, the net with the greatest number of pads is first assigned to the internal plane, then regions are defined (split off) for the other nets that you want to connect via this plane. Any pads that cannot be encompassed in the split plane region continue to display a connection line, indicating that they must be connected on a signal layer.

Split power planes are fully supported by the Design Rule Checker. However, they are not recognized by Signal Integrity as the power plane is assumed to be a continuous copper layer in Signal Integrity. Netlist extraction in the CAM Editor does not support Altium Designer mode split planes because it is unable to define the polyline that describes each region.

Using Multiple Split Planes in a Design

Splits within splits (nested splits or islands) are supported so you do not need to wrap an outer split around the inner split. If you want to further divide a split plane, you can continue to add objects on the power plane layer inside an existing split plane to create other electrically-isolated regions.

Display Tips when Defining a Split Plane

When you define a split area in a power plane, it can sometimes be difficult to see all the pads that the split area needs to encompass. To make the pads for the net that you want to connect to the split plane more visible, the following techniques are suggested before you start.

  • Recalculate and redraw internal planes by selecting Tools » Split Planes » Rebuild Split Planes on Current Layer / Rebuild Split Planes on All Layers from the main menus.
  • Use 3D mode (shortcut 3) to view the physical representation of the planes, including void areas and thermal relief connections. To make moving around the board in 3D easier, scale the board thickness to increase the vertical distance between layers. The Board thickness (Scale) control is located in the 3D Settings region on the View Options tab of the View Configuration panel.

  • Display only a minimum of layers (e.g., the Keep Out layer, the Multi-layer, any mechanical layers needed) and the power plane that is being used. Disable the other layers in the View Configuration panel.
  • Hide all the connection lines (View » Connections » Hide All). On occasions, it may be useful to display an individual net that you want to create a split plane for (View » Connections » Show Net).
  • Set the color attribute of each net on the split plane to a different color by selecting Nets in the PCB panel then double-click on a net name to open the Edit Net dialog.
  • To display all pads associated with a net, click on that net on the internal plane in the PCB panel to mask out all other pads.
  • Assign the net with the largest number of pads to the internal power plane then use queries such as InNet('A') or InNet('B') in the PCB List panel to show the nets, e.g., some with thermal relief and some without, to distinguish between the pads to be included in a new split plane.
  • To display only the objects and primitives on internal planes, use the query OnPlane in the PCB Filter panel.

Defining Split Planes

In Altium Designer, you can place any configuration of lines, arcs, tracks, and fills across an internal power plane to define a split plane. As soon as these isolate a portion of the plane from the rest, a new split plane is created. A net is then associated with the new split plane. The easiest way to define split planes is to use the Place » Line command then draw the boundary of the split plane on the power plane.

Creating a split plane using the Place » Line command.Creating a split plane using the Place » Line command.

This creates a line in the artwork to leave off copper which, in turn, splits the planes. The line width becomes the separation width. When you right-click to exit line placement mode, the plane is analyzed and the independent split region is created. To change the separation width between the split plane and the internal power plane during line placement, press Tab to open the Line Constraints dialog and change the Line Width value.

To divide a power plane into two split planes, you can draw a line straight across the board from pullback track to pullback track. As long as the lines connect to the pullback tracks, they will form an isolated area and, therefore, create the polygon type object that identifies the split plane. Make sure the lines connect; the cursor changes to a large circle in a cross when lines connect.

Check with your fabricator if you are unsure of minimum no copper regions.

You can create an enclosed shape out of the lines, arcs, and fills to define an unusually-shaped split plane. You also can use existing lines, arcs, fills, or tracks on the internal layer to form part of the boundary. As long as they connect to form an enclosed area, a split plane is formed.

Using Arcs, Fills, and Tracks

It is recommended if you use arcs to split the plane, you place a short track segment between the arc segments. Note that using a fill (Place » Fill) will not create a split plane; it will only create a void area. You could use fills to create the outside edges of the split plane by placing them instead of lines, for example.

If you place tracks instead of lines using the Place » Interactive Routing command, make sure the tracks are set to No Net and the split plane is associated with the appropriate net name instead.

Assigning a Net to a Split Plane

To check if each split region is correctly defined, click once on a split; if it is a closed region, only that area will highlight.

A split plane highlighted.
A split plane highlighted.

If the area highlights, double-click to open the Split Plane dialog to check or set the net assignment. Select the split plane's net name from the drop-down list in the dialog.

The color of the split plane is a darker, semi-translucent shade of the net color. Change the net colors by selecting Nets in the PCB panel then double-click on a net name to open the Edit Net dialog.

Using Polygons on Power Planes

Traditionally, a PCB power plane is designed as a negative, that is, the objects placed on a power plane layer become voids in the copper when the board is fabricated. This approach is used because it is more efficient to generate the output data this way, as the bulk of a plane layer is normally copper; voids in the copper are only needed in specific locations such as around non-connected pads, or as separation voids when the plane is divided into different voltage regions.

As part of improving support for more complex power plane design, it is now possible to define power planes as polygons. Working in this mode does not affect the approach to designing a power plane; they are still defined in the negative - so placing an object creates a void in the copper, and they continue to be split into separate regions by placing a split line.

The advantage of using polygons is that copper islands, narrow necks and dead copper can automatically be detected and removed.

Although the layer appears the same, using polygons on the plane layers allows for more comprehensive checking of the integrity of the copper.Although the layer appears the same, using polygons on the plane layers allows for more comprehensive checking of the integrity of the copper.

Notes about the Polygons on Plane mode:

  • After enabling the option, review each plane layer and repour the plane polygon(s) with the polygon options configured to suit your design needs.
  • Connections and Clearances for plane layers are defined by the PlaneConnect and PlaneClearance design rules.
  • After modifying a plane (connect or clearance) design rule, repour at least one polygon on each plane layer, to update the connections/clearances on that layer.
  • Edits made on a plane layer, such as modifying the location of a split line, cause an automatic repour of polygons on that plane layer.

To use the polygons on planes feature, enable the PCB.SplitPlanes.Pouring option in the Advanced Settings dialog (accessed by clicking the Advanced button on the System - General page of the Preferences dialog).

Placing Tracks on Power Planes

Since power plane layers are constructed in the negative, a track placed on a power plane layer creates a void in the copper, and therefore, no connection is made. Due to this, you cannot use a single track on a plane layer to route a net. If you want to route a net on a power plane layer, you have to create a very thin island of copper that is the size of the track you want to use. By creating a boundary of lines around the area that will act like a track (Place » Line), you create a split plane that can then be assigned to the net required.

Alternatively, if there are a number of connections to be routed on the same layer as the plane, it is probably more efficient to use a signal layer to route the connections and then use a polygon plane (copper pour) to create the power plane.

Reviewing and Editing Split Planes using the PCB - Split Plane Editor Panel

The PCB panel’s Split Plane Editor mode allows you to easily view and manage split planes of the current PCB design. This mode of the panel is divided into three sections:

  • Layers - this region displays all internal plane layers currently defined in the design and how many split planes exist per layer.
  • Split Planes - this region is filled with split planes contained in a selected entry from the Layers region.
  • Pads/Vias On Split Plane - this region is populated with Pads and Vias from a selected entry in the Split Planes region of the panel.

Layers

The Layers section of the panel displays all internal plane layers currently defined for the design. Within the section, the Split Count column indicates how many split planes exist for the corresponding plane layer. A split count of '1' means that the layer has not been split and the layer itself is considered to be a single split.

Split Planes

After selecting an entry in the Layers section, all of the split planes on that plane layer and their assigned nets will be loaded into the Split Planes section of the panel.

To view only nets associated with split planes in this section, ensure that the Show Split Plane Nets Only option is enabled on the right-click menu.

For each entry, a Node Count is displayed. This value reflects the total number of pads and vias that are connected to that split plane region.

Double-click (or right-click and select Properties from the context menu) on a Net with split planes to open the Split Plane dialog, which can be used to change to which net the split plane is assigned.

Note that if the selected net has no split planes, the Edit Net dialog will open instead.

Pads/Vias On Split Plane

Right-clicking on Pad or Via in the Split Planes section of the panel then selecting Properties from the context menu will open the associated Properties panel for that primitive.

In 3D viewing mode (shortcut 3), you can see physical representations of all internal plane objects. The 3D environment enables you to move easily through the board, making true plane inspection very easy. Recalculate and redraw internal planes after editing by selecting Tools » Split Planes » Rebuild Split Planes on Current Layer or Rebuild Split Planes on All Layers.

Deleting Split Planes

Since a split is formed when a region on a plane is isolated, removing any object that forms the split boundary will remove that split. Therefore, to delete split planes, delete the bounding primitives, e.g. the lines or other primitives creating the outline of the split plane. Remember that pullback tracks can only be deleted by removing the internal plane from the layer stack.

Design Rule Checking Split Planes

You can check and report on split planes during Batch design rule checking (DRC) for the following rules:

  • Broken planes
  • Dead copper regions
  • Starved thermal connections.

These options are available in the DRC Report Options in the Design Ruler Checker dialog, which is accessed by selecting Tools » Design Rule Check from the main menus. Enable the desired options to have them checked and reported during Batch DRC.

When the report is created, any breaches of these rules are displayed in the report. Click in the report to display the associated error in the PCB editor.

Broken Planes

Broken planes occur when an area of the plane that has connectivity to the net becomes electrically disconnected from the rest of the plane. An example where this might occur is a connector that is placed across a split plane but not connected to it. The voids around the pins join to completely cut through the plane copper, effectively breaking it into two parts.

Broken plane showing DRC error (bright green).
Broken plane showing DRC error (bright green).

Dead Copper

Dead copper refers to sections of copper that have no connectivity to the net and that also become electrically disconnected from the original plane. An example where this might occur is a connector (not connected to the plane) with closely-spaced pins in which the voids around the pins join to isolate areas of plane copper from the rest of the plane.

Dead copper region showing DRC error (bright green).
Dead copper region showing DRC error (bright green).

Starved Thermal Connections

Thermals are connections to the plane with thermal relief 'cutouts' around them to reduce heat conductivity to the plane copper. Thermals can become 'starved' when the surface area of the copper spokes connecting it to the plane is reduced by void areas. This rule also checks the surface area for the thermal (not just the spokes) against any void areas that encroach into the thermal.

Starved thermal connection showing DRC error (bright green).
Starved thermal connection showing DRC error (bright green).

Refer to Constraining the Design - Design Rules for more information.

Notes About Split Planes

  • Split plane DRC checks are Batch mode only.
  • You need to run Batch DRC again to remove error markers or select Tools » Reset Error Markers from the main menus.
  • Recalculate and redraw internal planes after editing by selecting Tools » Split Planes » Rebuild Split Planes on Current Layer/Rebuild Split Planes on All Layers from the main menus.
  • Broken planes and dead copper checks require the Un-Routed Net rule (Electrical category) to be Batch enabled.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: