Setting Up a CAM Document in Altium Designer

Created: February 8, 2023 | Updated: February 8, 2023
Applies to Altium Designer versions: 23 and 24

Parent page: Inspecting Fabrication Data with the CAM Editor

Your View of the CAM Document

The CAM editor includes a number of tools facilitating navigation through your active CAM document. Use the following commands of the View main menu to control the view of the CAM document.

  • View » Area (also accessible by right-clicking within the design space and choosing the Area command from the context menu) – redefine the display area in the current document. After launching the command, the cursor will change to a crosshair and you will be prompted to select the first corner of the zoom window. Position the cursor and click to anchor this corner. You will then be prompted to select the second corner. Move the cursor to size the zoom area and click to anchor this second corner. The display will change, with the specified area zoomed and centered in the design space. Continue redefining the display area in the design space, or press Esc to exit.
  • View » All (also accessible by right-clicking within the design space and choosing the All command from the context menu; shortcut: Home) – display all objects on all enabled layers, in the current document. After launching the command, the view of the design window will change to include all objects in the design space, and on all enabled layers.
  • View » Around Point (also accessible by right-clicking within the design space and choosing the Around Point command from the context menu; shortcut: Shift+P) – redefine the display area about a specified point in the current document. After launching the command, you will be prompted to select a new center point for the main design window. Simply position the cursor at the required location in the workspace and click to define this center point. The view in the design space will change, with this selected point now at the center. Continue to change the view by selecting different points to center, or press Esc to exit. This command will not affect the current zoom-level applied to the document.
  • View » Zoom In (also accessible by right-clicking within the design space and choosing the Zoom In command from the context menu; shortcut: PgUp) – bring the design closer to you, relative to the cursor position, in the current document. Use the command repeatedly to zoom in to a greater extent (even while another process is running). You can also zoom in by pressing Ctrl whilst rolling the mouse wheel upwards.
  • View » Zoom Out (also accessible by right-clicking within the design space and choosing the Zoom Out command from the context menu; shortcut: PgDn) – move the design away from you, relative to the cursor position, in the current document. Use the command repeatedly to zoom out to a greater extent (even while another process is running). You can also zoom in by pressing Ctrl whilst rolling the mouse wheel downwards.
  • View » Zoom Last (also accessible by right-clicking within the design space and choosing the Zoom Last command from the context menu; shortcut: Shift+V) – return the display to the previous view of the screen, in the current document. Use the command repeatedly to cycle back through further previous views. This command behaves rather like an Undo command for the view of the document.
  • View » Refresh (also accessible by right-clicking within the design space and choosing the Refresh command from the context menu; shortcut: End) – refresh the design space, in effect performing a redraw of the current document, to remove any undesired drawing update effects. All enabled layers are redrawn, according to the layer order and options defined in the View/Change Layers Order dialog (accessed through the Layers Table dialog (Tables » Layers)). This command does not affect the current view setting of the design space.
  • View » Dynamic (shortcut: D) – control the panning action in the current document dynamically, using the mouse. After launching the command, you will be prompted to select a drag point in the design space. The dynamic pan feature will use this point as its initial panning point. Simply position the cursor at the required location and click-and-hold. Drag the mouse in any direction to pan the document. The cursor can be moved to another initial drag point within the design space, or right-click, or press Esc, to exit dynamic panning mode.
  • View » Zoom » Dynamic (also accessible by right-clicking within the design space and choosing the Dynamic command from the context menu) – control the zooming action in the current document dynamically, using the mouse. After launching the command, you will be prompted to select a zoom point in the design space. The dynamic zoom feature will use this point as its central zoom point. Simply position the cursor at the required location and click-and-hold. Drag the mouse upwards to zoom in, or downwards to zoom out. The cursor can be moved to another zoom point within the design space, or press Esc to exit dynamic zoom mode.
  • View » Zoom » Dcode (shortcut: Alt+Home) – view and highlight all objects drawn with the current Dcode. First, ensure that the Dcode you wish to view is selected in the Dcode field on the CAMtastic panel. After launching the command, the view of the design window will change to fit all objects, on all enabled layers, that use the current Dcode. These objects will be highlighted.
  • View » View Film Box (shortcut: Shift+B) – toggle the display of the current film box. A film box is a rectangle used as a visible reference, and can be a time saving feature when used to set up defined views of the document. The current film box is selected on the CAM Editor - Film Box page of the Preferences dialog. To change the display of the design space to show the current film box and its contents, use the Ctrl+Home shortcut.

Controlling Layer Visibility

Use commands from the View » Layers menu to control visibility of the layers in your CAM document:

  • View » Layers » All ON – turn the visibility of all layers in the current document to ON. The design space will display the objects associated to the layers, and the checkbox next to each layer entry in the Layers list of the CAMtastic panel, will be checked. You can also turn all layers on from the CAMtastic panel, by right-clicking anywhere in the Layers list and choosing the All ON command from the context menu. Alternatively, select a layer in the list and use the Right Arrow keyboard shortcut.
  • View » Layers » All OFF – turn the visibility of all layers in the current document to OFF. The design space will appear empty, and the checkbox next to each layer entry in the Layers list of the CAMtastic panel, will be unchecked. You can also turn all layers off from the CAMtastic panel, by right-clicking anywhere in the Layers list and choosing the All OFF command from the context menu.
  • View » Layers » Isolate Object Layer – isolate and display layers upon which selected objects reside. After launching the command, the cursor will change to a square and you will be prompted to select objects. Simply click on an object to select it. Clicking away from an object allows you to drag a selection area, for including multiple objects in the selection. Selection is cumulative. Once all required objects have been selected, right-click. Only the layers upon which the selected objects reside will be displayed. All other layers will be turned OFF. Continue to select further objects to isolate the remaining layers still further, or right-click, or press Esc, to exit.
  • View » Layers » Select Object Layer OFF – turn off the layer upon which a selected object resides. After launching the command, you will be prompted to select an object. Simply position the cursor over an object whose associated layer you wish to turn OFF, and click. The layer will be turned OFF and this will be confirmed in the Layers list of the CAMtastic panel, by the checkbox for the layer's entry becoming unchecked. Continue selecting further objects in order to turn off further layers, or right-click, or press Esc, to exit.

    If you select an object that resides on the current layer, an information dialog will appear alerting you to the fact that the current layer will be turned OFF.
  • View » Layers » View Layer Order – run the View/Change Layers Order dialog, from where you can define the drawing order for the layers in the current document. The main area of the dialog lists all of the layers in the current document. The default order is that of the logical layer order, as viewed in the Layers list on the CAMtastic panel. This order defines the sequence in which the layers are drawn when, for example, a View » Refresh is issued.

    Change the position of any individual layer in the order, simply by dragging and dropping it to a new position. Quickly reverse the order of the layers by clicking the Reverse Layers Order button.

    Should you wish, you can also define that the current layer is always drawn last of all, by enabling the Draw Current Layer Last option.

You can also use the K or Alt+K keyboard shortcut to access the Set Layers OFF dialog, from where you can specify which layers you wish to turn OFF, or the Set Layers ON dialog, from where you can specify which layers you wish to turn ON, respectively.

You can specify individual layers, or layer ranges, separated by commas. For example, to turn OFF/ON layers 2, 6, and layers 9 through 15, you would enter:

2,6,9-15

You can also specify layers that you don't want to be included, using the exclamation mark as a prefix. Using the above example, if you did not really want to turn OFF/ON layers 11 and 12, you would enter:

2,6,9-15,!11-12

Leave the field blank if you want to turn all layers OFF/ON.

Displaying Items of the CAM Document

The following commands of the View » Views main menu allow you to control the visibility of different elements in your CAM document:

  • View » Views » Difference – compare two or more layers and show the differences between them. First, enable only the layers that you wish to compare in the layers list of the CAMtastic panel. After launching the command, the layers will be compared and each object that is not found to be precisely the same on at least one other layer, will be displayed as a difference.

  • View » Views » Extent Box (shortcut: Shift+E) – toggle the display of the Extents Box. This box is used to display the drawing extents within the design space. When displayed, the box boundaries are dotted red lines.

    The CAMtastic Editor allows 260 by 260 inches for design work. When you move the cursor outside the bounding edges of the Extents Box, you will see "Out of Limits!" in the Coordinates field in the CAMtastic panel.
  • View » Views » Fill (shortcut: Shift+E) – toggle the view of the current document between active fill and outline sketch modes. By default the document is in active fill mode, which means that trace widths, flashes, and polygons, are all filled in. When the document is in outline sketch mode, all the flashes and polygons are displayed as outlines only, and traces as zero-width lines. Custom apertures are not affected by this command.
  • View » Views » Highlight Dcode (shortcut: Shift+H) – toggle the highlighting of objects based on the current Dcode. In this way, you can interrogate exactly which objects a particular Dcode is associated with.

    • First, ensure that the Dcode for the objects you wish to highlight is selected in the Dcode field on the CAMtastic panel.
    • Highlighting only affects objects drawn with the current Dcode. If you change the current Dcode in the CAMtastic panel and run the command again, only those objects for this selected (now current) Dcode will be highlighted.
  • View » Views » Negative (shortcut: N) – toggle the display of the current document between Negative and Standard views. When in the Negative view, the background is changed to red and all objects are displayed in black.
  • View » Views » Origin – toggle the view of the origin marker for the current document. After launching the command, the origin marker will either be displayed as a small marker, crosshairs or not displayed at all, depending on the current display status. Use the command repeatedly to cycle through the available origin display states.
  • View » Views » Translucent (shortcut: Shift+T) – toggle translucent display mode ON or OFF. This mode displays objects in the current document with a transparent effect, allowing you to see objects partially or entirely overlapped by other objects.

    • The translucent view mode, while powerful and useful, can also be a hazard. Stacked objects are sometimes displayed in white - a color seen only in object selections. This can be confusing when making selections, as some overlapping objects may appear to be selected when they are not.
    • The editing redraw speed is also somewhat slower when translucent mode is enabled.

Setting the Origin and Grid

The origin marker is used as a visual reference to mark the currently set origin for the design space, as reflected by the XY coordinates (0.000000:0.000000). Choose the Edit » Objects » Set Origin command from the main menus (shortcut: Ctrl+I) to set a new origin point for the current document. After launching the command, you will be prompted to select the new user origin. Position the cursor at the required location in the design space and click. This point will become the new origin, as reflected by the XY coordinates (0.000000:0.000000) in the CAMtastic panel.

You can toggle the view of the origin marker using the View » Views » Origin command.

The Snap Grid of the CAM document facilitates manual movement and placement in the current document. To set the Snap Grid:

  • Use the G keyboard shortcut, then choose a value command from the pop-up menu. The value for both the X Grid and Y Grid properties of the Snap Grid will be set to the selected value, and the grid will update accordingly in the design space.
  • Use the Ctrl+G keyboard shortcut or use the G keyboard shortcut, then choose the Set Snap Grid command from the pop-up menu to access the Enter Grid (1..1000mil) dialog will appear. Enter the same, or different values to be used for the X Grid and Y Grid properties of the Snap Grid, and click OK - the grid will update accordingly in the design space.
  • Display of the grid (On/Off), as well as grid sizing (Size X:Y), can also be managed from the CAM Editor - Drawing Modes page of the Preferences dialog. The size drop-down field lists previously used grid values, or simply enter new sizing directly, as required.
  • The snap grid is used when the Object Snap mode is set to Grid. The object snapping mode can be changed on the CAMtastic panel, or on the CAM Editor - Drawing Modes page of the Preferences dialog. With the mode set to Grid, the cursor automatically snaps to the grid, positioning the reference point of the object being placed onto the nearest grid location.
  • To toggle between the Off snap mode and the previously selected snap mode (other than Off), you can right-click within the design space and choose the Snap Change command from the context menu (shortcut: Shift+S).
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: