View Configuration Panel (PCB)

Now reading version 1.0. For the latest, read: View Configuration Panel (PCB) for version 4

This documentation page references Altium NEXUS/NEXUS Client (part of the deployed NEXUS solution), which has been discontinued. All your PCB design, data management and collaboration needs can now be delivered by Altium Designer and a connected Altium 365 Workspace. Check out the FAQs page for more information.

 

Parent page: PCB Panels

Display related settings are configured in the View Configuration panel.
Display related settings are configured in the View Configuration panel.

Summary

The View Configuration panel is used to configure what is currently displayed in the workspace and how it is displayed. This includes layer visibility and color, object visibility and transparency, masking and dimming levels, the current single layer mode, and a number of additional workspace display features, such as the display of net names on pads, via and tracks.

The panel is also used to add mechanical layers to the design, up to 32 mechanical layers can be added. Mechanical layers can also be paired in the View Configuration panel to function as special-purpose Component Layers, for roles such as component courtyards or glue dots.

Panel Access

The panel is accessed from the PCB editor in the following ways:

  • Click View » Panels » View Configuration.
  • Click the button at the bottom-right of the workspace then select the View Configuration option.
  • Click the color swatch  on the Layer Sets control at the bottom left of the workspace.
  • Press the L shortcut key to open the panel with the Layers & Colors tab displayed.
  • Press the Ctrl+D shortcut keys to open the panel with the View Options tab displayed.

Content and Use

The panel content is divided into two tabs. Click on a tab at the top of the panel to display the options available on that tab:

  • Layers and Colors tab - includes options to control the visibility of available layers, and add, rename or delete mechanical layers.
  • View Options tab - includes options to select, save or load the Configuration of layer colors/visibility, configure the visibility of object-types, control the masking and dimming levels, and configure other display related options.

Within each tab, the content is arranged in collapsible sections that are opened and closed using the arrow icon associated with each section heading. The information included is arranged by matching sections and each collapsible section is opened/closed in the same manner. The options that are available will depend on the current Layout Mode.

Setting the Color

Each layer includes a small color button; click to display the color selector as shown below.

The panel includes:

  • A history row, showing (up to) the last ten color choices that were used.
  • A grid of 10 x 8 predefined color buttons. Click a button to select that color.
  • A Custom Color row of up to ten custom colors.

Custom colors can be defined by performing the following:

  • Click Define Custom Colors to expand the color palette to also display the Custom Color Palette.
  • Use the horizontal slider in the center of the Custom Color Palette to select a base color then click anywhere on the palette to brighten or darken that color.
  • Alternatively, enter the Hex or RGB values into the appropriate fields in the Custom Color Palette.
  • Click the Apply button to add the new color to the Custom Color row and apply that color to the layer being edited.

Displaying or Hiding a Layer

Each layer or system attribute (such as selections or DRC errors), can be displayed or hidden. Click the visibility icon () to toggle the visibility off and on.

Where appropriate, each group also includes a visibility icon (). For example, in the image above:

  • To the left of the string Component Layers (C) there is a visibility icon; click this to toggle the visibility of all component layers on/off.
  • To the left of the string Top there is a visibility icon; click this to show/hide all top side component layers. The Bottom side layers can also be displayed/hidden in the same way.

Controlling Visibility from the Keyboard

In a busy PCB design, layers are often toggled on and off during the design process. To help with this, layer visibility can be changed using keystrokes in the following way:

  • Press the L shortcut to display/make the Layers & Colors tab of the View Configuration panel active. The panel's title bar will become colored indicating that it is the active element in the software.
  • Press the appropriate Shortcut key on the keyboard to access a layer or set of layers; the shortcut key is displayed in parentheses next to each layer or layer set. For example, the C shortcut in the image above accesses the Component Layer set of layers.
  • If you have accessed a set of layers, press Spacebar to toggle the visibility of all layers in that set.
  • If you have accessed a layer, its visibility will toggle immediately and the Spacebar can then be used to toggle it again.
  • Press the Up or Down arrow keys to move up or down through the list, for example, to access a specific mechanical layer or a pair of component layers. You can then use the Spacebar to toggle the visibility of that layer/layer pair.

Including a Layer in the Single Layer Mode Display

To include a layer in the Single Layer Mode display, perform a Ctrl+Click on the eye icon associated with the desired layer to add that layer into Single Layer Mode display; a square will appear behind the eye icon () to denote that layer wil be displayed in Single Layer Mode.

Layers & Colors Tab

View Options Tab

 

Content