電子システム設計
電子設計の初期段階では、概念/機能レベルで設計を定義することが重要です。この最初のステップは、開発プロセス全体の重要な土台となり、システムのアーキテクチャと主要要素の全体像を高いレベルで示します。適切に作成されたブロック図は、電子システムの主要な機能ユニットを明確にし、それらの相互接続を示します。これにより、個々の部品実装の複雑な詳細にとらわれることなく、設計の各部分がどのように相互作用するかを視覚化できます。このような抽象化によって、システム全体の動作やモジュール間の関係に集中でき、必要な機能がすべて考慮され、システムのアーキテクチャが設計要件に適合していることを確実にできます。
Electronic System Design(ESD)ドキュメントを使用すると、システムレベルのブロック図を設計し、関係者と共同作業を行うことができます。
新しいESDドキュメントの作成
新しいESDドキュメントは、Renesas 365 Workspace にあるソリューションの一部として作成できます。ソリューションの詳細ページで、右上の
ボタンをクリックし、表示されるメニューからSystem Designを選択し、Create ESDウィンドウを開きます。
このウィンドウは、最初は簡易表示で表示され、次のフィールドがあります。
-
Name– ESDドキュメントに必要な名前を入力します。
-
Description– ESDドキュメントの説明を必要に応じて入力します。
さらに多くのコントロールにアクセスするには、
ボタンをクリックします。Parent Folderフィールドが表示されます。このフィールドでは、Workspace のフォルダー構造内のどこに ESD ドキュメントを作成するかを指定します。デフォルトでは、Projectsフォルダーです。フィールド右側のChangeリンクをクリックすると、Workspace のフォルダー構造にアクセスでき、ドキュメントの保存先として別のフォルダーを選択できます(
)。
必要に応じて新しいESDドキュメントを定義したら、
をクリックします。ソリューションの詳細ページに戻り、新しく作成されたESDドキュメントのタイルが表示されます。
ESDドキュメントを開くには、そのタイル内の名前をクリックするか、
ボタンをクリックして表示されるメニューからOpenを選択します。あるいは、目的のESDドキュメントのタイルを直接ダブルクリックします。
ESDドキュメントの定義
ESDドキュメントでは、特定の機能、操作、またはデバイス(信号処理や MPU など)はfunctional blocksで表されます。構造および視覚表現の観点では、機能ブロックはコンテナーであり、グラフィカルな図形/画像(ラベル付き)、ハードウェア/ソフトウェアオブジェクトで表される機能の主要コンポーネント、ポート、その他のブロックを含めることができます。Portsは機能ブロックのインターフェース(たとえば MPU の I2C インターフェース)を表すために使用でき、機能ブロック間のconnection lines(ブロックまたはそのポートの間に直接配置)は相互接続(たとえば異なるデバイスのインターフェース間を流れる信号)を表します。
配置および編集の共通操作
以下の折りたたみ可能なセクションでは、ESDドキュメントエディターでの作業方法について詳しく説明します。
Controlling the View of the Document
メイン表示領域の閲覧コントロールは次のとおりです。
-
Right-Click, Hold&Dragドキュメントをパンします。 -
Mouse Wheel縦方向にスクロールします。 -
Shift+Mouse Wheel縦方向にスクロールします。 -
Ctrl+Mouse Wheelズームイン/ズームアウトします。
Selecting Objects
ESDドキュメント内に配置したオブジェクトに対して、位置やサイズの編集、クリップボード操作(切り取り/コピー)、削除などの操作を行う前に、そのオブジェクトを選択する必要があります。
最も基本的な方法では、カーソルをオブジェクトの上に移動してクリックすることで、個々の設計オブジェクトを選択できます。選択されると、特定の設計オブジェクトはサイズや形状をグラフィカルに変更できます。オブジェクトが選択状態になり、周囲の各編集ポイントに編集ハンドルが表示されます。オブジェクトの形状やサイズを変更するには、編集ハンドルをクリックしてドラッグします。具体的にどのような変更になるかは、編集しているオブジェクトによって異なります。
選択中のオブジェクト以外の場所をクリックするか、Escを押すと選択解除されます。
なお、クリックによる選択は累積されません。別のオブジェクトをクリックすると、現在選択されているオブジェクトは選択解除されます。複数のオブジェクトを選択するには、Shiftキーを押したまま、選択または選択解除したいオブジェクトを順にクリックします。つまり、Shift+Clickショートカットは、カーソル下のオブジェクトの選択状態だけを切り替え、他のオブジェクトの状態には影響を与えません。
設計ドキュメント内の特定の領域にある複数のオブジェクトを選択するには、選択矩形を使用できます。Click and Holdオブジェクトのない場所で、選択したいオブジェクト群を囲む仮想矩形の一方の角から、反対側の角までドラッグします。選択矩形内に完全に含まれる表示中のオブジェクトと、選択矩形に接しているオブジェクトがすべて選択されます。
ESDドキュメント内のすべてのオブジェクトを選択するには、Ctrl+Aショートカットも使用できます。
Using Cut/Copy and Paste
ESDドキュメント内、またはESDドキュメント間でオブジェクトを切り取り/コピーして貼り付けることができます。切り取り/コピーしたいオブジェクトを選択し、デザインスペース内で右クリックして、コンテキストメニューからCut(ショートカット:Ctrl+X)/Copy(ショートカット:Ctrl+C)コマンドを選択します。最後に切り取り/コピーした内容をドキュメント内に配置するには、デザインスペース内で右クリックし、コンテキストメニューからPaste コマンドを選択します(ショートカット:Ctrl+V)。
Arranging Objects
ESDドキュメントに配置されたオブジェクトは、自動的にレイヤー状に積み重ねられます。各オブジェクトは作成順に応じて異なるレイヤーに配置されるため、オブジェクトを重ねて配置することが可能です。新しく作成または追加されたオブジェクトは、常に最上位レイヤーになります。
右クリックメニューのArrangeサブメニューにある次のコマンドを使用すると、重なり合うオブジェクトのスタック内で、そのオブジェクトの位置を移動できます。
-
Bring to Front(
Ctrl+Alt+])/Send to Back(Ctrl+Alt+[)– 重なり合うオブジェクトのスタックに含まれるオブジェクトを、そのスタック内の他のすべてのオブジェクトの最前面/最背面へ移動します。コマンドを起動したら、移動したいオブジェクトをクリックします。x 座標や y 座標を変更することなく、そのオブジェクトは重なっている他のすべてのオブジェクトの前面/背面に移動します。 -
Bring Forward(
Ctrl+])/Send Backward(Ctrl+[)– 重なり合うオブジェクトのスタック内で、あるオブジェクトを別のオブジェクトの前面/背面へ移動します。コマンドを起動したら、まず移動したいオブジェクトをクリックし、次にそのオブジェクトを前面/背面に移動したい「対象」オブジェクトをクリックします。最初のオブジェクトは、x 座標や y 座標を変更することなく、その対象オブジェクトの前面/背面に移動します。
Aligning Objects
オブジェクトをデザインスペース内に正確に配置し、他のオブジェクトに対して縦方向および/または横方向に整列させるために、オブジェクト(またはオブジェクト群)を配置またはドラッグして他のオブジェクトと整列すると、ガイドラインが表示されます。また、近くに配置されているオブジェクトの間隔に合うようにオブジェクトを配置/ドラッグすると、矢印も表示されます。
整列コマンドを使用してオブジェクトを整列させることもできます。これを行うには、整列対象にしたいすべてのオブジェクトを選択し、選択されているオブジェクトの上で右クリックして、Alignメニューから必要なコマンドを選択します。
-
Align Left/Align Right/Align Top/Align Bottomコマンドを使用すると、選択した設計オブジェクトをそれぞれ左端/右端/上端/下端で整列できます。コマンドを起動すると、最も左/右/上/下にあるオブジェクトの左端/右端/上端/下端が基準として使用され、選択内の他のすべてのオブジェクトは左右または上下に移動して、その左端/右端/上端/下端がこの基準に揃うようになります。
-
Align Horizontal Centers/Align Vertical Centersコマンドを使用すると、選択したオブジェクトを単一の列/行に配置し、水平方向/垂直方向の中心で整列できます。コマンドを起動すると、選択内のオブジェクトは水平方向/垂直方向に移動して単一の列/行を形成し、それぞれの水平方向/垂直方向の中心で整列されます。列の垂直中心線は、選択内で最も左にあるオブジェクトと最も右にあるオブジェクトの中間点です。行の水平中心線は、選択内で最も上にあるオブジェクトと最も下にあるオブジェクトの中間点です。
-
Distribute Horizontally/Distribute Verticallyコマンドを使用すると、選択したオブジェクト間の水平方向/垂直方向の間隔を均等にできます。コマンドを起動すると、選択内で最も左と右、または最も上と下のオブジェクトはその位置に固定されたまま、他のすべてのオブジェクトがその間に等間隔で配置されます。オブジェクトの垂直方向/水平方向の位置は変更されません。
Matching Object Size
配置済みオブジェクトのサイズは、選択した状態で手動調整できますが、あるオブジェクトの幅および/または高さを他の配置済みオブジェクトに適用して、サイズを揃えることもできます。これを行うには、サイズを揃えたいオブジェクト(機能ブロック、ポート、ハードウェアコンポーネント、ソフトウェアコンポーネント、長方形、楕円、テキスト、画像)を選択し、基準となるオブジェクトを右クリックして、Match sizeコンテキストメニューから必要なコマンドを選択し、基準オブジェクトの幅(Width)、高さ(Height)、またはその両方(Both width and height)を選択内の他のオブジェクトに適用します。
Grouping Objects
ESDドキュメントに配置したオブジェクトはグループ化できます。グループ化すると、グループ内のいずれか1つのメンバーを移動したときに、すべてのグループメンバーをすばやく選択/選択解除したり、一緒に移動したりできます。
現在選択されているオブジェクトをグループ化するには、デザインスペース内で右クリックし、コンテキストメニューからGroupコマンドを選択します。選択されているオブジェクトをメンバーとするグループが作成されます。
グループを解除(解散)するには、そのグループのメンバーであるオブジェクトを右クリックし、コンテキストメニューからUngroupコマンドを選択します。
Changing Object Style
ESDドキュメントで1つ以上のオブジェクトが選択されているときは、上部ツールバーのコントロールを使用してそのスタイル(デザインスペース上の見た目)を変更できます。
-
Font settings– これらのコントロールを使用して、テキストを含む選択中のオブジェクト(機能ブロック、ポート、コンポーネント、テキスト)のフォント(フォントファミリー、フォントサイズ、太字/斜体/下線属性、文字色、配置)を設定します。
-
Color– これらのコントロールを使用して、選択中のオブジェクトの塗りつぶし色(該当する場合)と輪郭色を設定します。
-
Line – これらのコントロールを使用して、選択中のオブジェクトの線種と線幅を設定します。これは線種オブジェクト(接続線およびポリライン)と、その他のオブジェクトの輪郭に適用されます。
あるオブジェクトのスタイルを別のオブジェクトにすばやく適用するには、スタイルをコピーしたい元のオブジェクトを選択し、デザインスペース内で右クリックして、コンテキストメニューからCopy Styleコマンドを選択します(ショートカット:Ctrl+Alt+C)。コピーしたスタイルを1つ以上のオブジェクトに適用するには、それらのオブジェクトを選択し、選択部分を右クリックして、コンテキストメニューからPaste Style コマンドを選択します(ショートカット:Ctrl+Alt+V)。
オブジェクトを右クリックして、コンテキストメニューからSet Default Styleコマンドを選択することもできます。このオブジェクトのスタイルは、同じタイプの後続オブジェクトを配置するときに適用されます。
配置済みオブジェクトは、選択してドラッグすることで移動できます。個々のノードを選択して移動し、オブジェクトの形状やサイズを変更することもできます。
Undoing and Redoing Operations
Ctrl+ZおよびCtrl+Yのショートカットを使用すると、それぞれ、直前の操作前の状態にESDドキュメントを戻すこと、およびドキュメント内で取り消し機能によって戻した変更を再適用することができます。
Object Locking
オブジェクトの右クリックメニューにあるLock/Unlockサブメニューのコマンドを使用して、そのサイズと位置、および/または内容をロック/ロック解除できます。
-
Lock/Unlock – このコマンドを使用すると、オブジェクトのサイズと位置(グラフィカルに変更できなくなります。サイズと位置がロックされたオブジェクトは削除もできません)、スタイル(つまりグラフィカルな外観)、および内容(たとえば機能ブロックのテキスト)をロック/ロック解除できます。
-
Lock size and position/Unlock size and position – このコマンドを使用すると、オブジェクトのサイズと位置のみをロック/ロック解除できます。
-
Lock style/Unlock style – このコマンドを使用すると、オブジェクトのスタイルのみをロック/ロック解除できます。
-
Lock content/Unlock content – このコマンドを使用すると、オブジェクトの内容のみをロック/ロック解除できます。
オブジェクトが完全にロックされている場合(つまり、サイズと位置、スタイル、内容がすべてロックされている場合)、選択時にオブジェクトの周囲に赤い点線が表示されます。一部のみがロックされている場合(たとえばスタイルのみがロックされている場合)は、選択時にオブジェクトの周囲に黄色の点線が表示されます。
Accessing Object Properties
配置済みオブジェクトのプロパティにアクセスするには、デザインスペース内でそのオブジェクトを選択し、右上の
ボタンをクリックしてPropertiesペインを開きます。あるいは、配置済みオブジェクトを右クリックし、表示されるメニューからPropertiesコマンドを選択します。
デザインスペース内で何も選択されていない場合、PropertiesペインにはESDドキュメント自体のプロパティが表示されます。
PropertiesペインのParameters領域では、選択したオブジェクト(機能ブロック、ハードウェアコンポーネント、ソフトウェアコンポーネント、ポート、または接続)のパラメーター、または何も選択されていない場合はESDドキュメント自体のパラメーターを管理できます。開いたPropertiesペインで、
ボタンと
ボタンを使用して、それぞれパラメーターの追加と削除を行います。パラメーター名または値をクリックして編集できます。
PropertiesペインのDocumentation & Resources領域には、ソリューションおよびその要素に関連するリソース(Renesas のドキュメント、PDF)へのリンク一覧が自動的に生成されて表示されます。
Special Strings
ESD ドキュメントでは、テキスト(テキストオブジェクト、機能ブロック名など)を使って静的なユーザー定義テキストを表示できるだけでなく、ドキュメントやオブジェクトのパラメーターのプレースホルダーとして使用することもできます。ESD ドキュメントで特殊文字列を使用するには、オブジェクトのテキスト内にパラメーター名を含めます。特殊文字列は接頭辞 = によって識別されます(例: =ControlAlgorithm、=MotorType など)。
複数の特殊文字列は、通常のテキスト(固定文字列)とともに、次のルールに従って 1 つのテキスト文字列に連結できます。
| 要素 | 機能 | 例 |
|---|---|---|
=(等号) |
後続の文字列が、解釈されるべき式であることを示します。 | =MotorType |
+(プラス) |
文字列内で必要な特殊文字列要素と固定文字列要素を連結するために使用します。 | =MotorType + NumberOfMotors |
' '(一重引用符) |
必要な文字列内の任意の位置に固定文字列を含めるために使用します。 | =MotorType + ' Motor (x' + NumberOfMotors + ')' |
機能ブロックの配置と設定
ESD ドキュメントに新しい機能ブロックを配置するには、下部ツールバーの
ボタンをクリックします(または、Library pane の Standard 領域にあるボタンを使用します)。設計スペース内でクリックしたままにして、機能ブロック矩形の最初の角を固定し、次にカーソルを移動して矩形のサイズを調整し、左マウスボタンを放して配置を完了します。あるいは、設計スペースをクリックして、デフォルトサイズの機能ブロックを配置することもできます。機能ブロック名を変更するには、その機能ブロックをダブルクリックし、必要な名前を入力して Enter を押すか、機能ブロックの外側をクリックします。
機能ブロックにハードウェアコンポーネントを追加するには、下部ツールバーの
ボタンをクリックします。カーソルは十字カーソルに変わり、コンポーネントのプレビューが付随します。機能ブロックの境界内をクリックしてコンポーネントを配置します。配置済みコンポーネントをダブルクリックし、開いたポップアップウィンドウの検索バーを使ってコンポーネントを検索します。検索結果一覧でコンポーネントを選択すると、そのコンポーネント名が機能ブロックのグラフィック内に表示されます。
機能ブロック内にポートを配置するには、下部ツールバーの
ボタンをクリックします(または、Library pane の Standard 領域にあるボタンを使用します)。カーソルは十字カーソルに変わり、デフォルトポートが付随します。機能ブロックの境界内をクリックしてポートを配置します。機能ブロックの外側をクリックすることもでき、その場合は新しいデフォルト機能ブロックが自動的に作成されます。ポート名を変更するには、ポートをダブルクリックし、必要な名前を入力して Enter を押すか、ポートの外側をクリックします。
RA Explorer の使用
Renesas RA family の MCU を検索する際は、RA Explorer ウィンドウを使用して必要なコンポーネントを見つけることができます。ハードウェアコンポーネントを配置した後、検索バーに RA または Renesas を入力し、ポップアップ上部の Explorer Mode リンクを使用してウィンドウを開くと、適合するコンポーネントの一覧が表示されます。デフォルトでは、この一覧は機能ブロック内に配置されたポートに基づいて絞り込まれます。現在のポート一覧はウィンドウ上部に表示されます。Add Port コントロールを使用して他の種類のポートを追加したり、ドロップダウンを使って各種類に必要なポート数を編集したりできます。一覧で目的のコンポーネントをクリックすると選択され、ウィンドウ右側にそのピンマップが表示されます。目的のコンポーネントを選択した状態で
ボタンをクリックすると、ハードウェアコンポーネントオブジェクトに適用されます。
RA MCU がハードウェアコンポーネントオブジェクトに適用されたら、それを選択して Properties pane を開き、そのプロパティを確認します。必要に応じて
ボタンをクリックし、RA Explorer ウィンドウを開いて別の MCU を選択できます。
Device Configuration の使用
Device Configuration 機能では、hardware component のポート、パッケージ情報、周辺機能、ピン割り当てを参照および管理できます。ハードウェアコンポーネントが選択されているときに、Properties pane の Device Configuration 領域を展開すると、現在のデバイス構成の詳細を確認できます。
Device Configuration 領域見出しの右側にある Edit コントロールをクリックすると、Device Configuration ウィンドウが開きます。
ハードウェアコンポーネントに割り当てられている現在のポート一覧がウィンドウ上部に表示され、現在のデバイス構成がその左側に表示されます。Add Port コントロールを使用して他の種類のポートを追加したり、ドロップダウンを使って各種類に必要なポート数を編集したりでき、デバイス構成への変更はウィンドウ右側に表示されます。
ウィンドウの Modified 領域で、該当エントリの右側にある x をクリックしてポートを削除することもできます。
ハードウェアコンポーネントに割り当てられたポートが、機能ブロック内のポートと一致しない場合(種類および/または数)、コンポーネントの Properties pane の Device Configuration 領域に通知が表示されます。また、そのコンポーネントは設計スペース内でオレンジ色のドットとオレンジ色の枠線で強調表示されます。この差異を解消するには、Device Configuration ウィンドウの
コントロールを使用すると、ソフトウェアが機能ブロックのポートに従ってハードウェアコンポーネントへポートを割り当てます。
または、ハードウェアコンポーネントに割り当てられたポートに合わせて機能ブロックのポートを更新したい場合は、ウィンドウ左下の Update Functional Block with ports from Device Model オプションを有効にします。
変更後のデバイス構成がサポートされていない場合、その旨を通知するメッセージが Device Configuration ウィンドウ上部に表示されます(この場合、変更を適用できません)。ポートの組み合わせを手動で変更するか、メッセージバナー内の Undo Last Change コントロールを使用して、ウィンドウで直前に行った変更を元に戻します。
デバイス構成に必要な変更を加えたら、
ボタンをクリックして、それらをハードウェアコンポーネントに適用します。
機能ブロックの接続
接続線は、機能ブロックの境界、ポートの境界、矩形の境界、画像の境界、別の接続線、または ESD ドキュメント内の空きスペースで開始および終了できます。接続線を配置するには、下部ツールバーの
ボタンをクリックします(または、Library pane の Standard 領域にあるボタンを使用します)。接続線を開始したい点をクリックします。カーソルを配置してからクリックし、接続線の形状を定義する一連の頂点を固定します。接続線は自動的に機能ブロックを横切らないように回避する点に注意してください。ドキュメントの空きスペースで右クリックすると、接続線の配置が完了します。機能ブロック、ポート、または既存の接続上に頂点を配置すると、現在の接続の配置は自動的に完了します。
配置済みの接続線を選択すると、次の編集ハンドルが使用できます。
-
A をクリックしてドラッグすると、接続線の端点を再配置できます。
-
B をクリックしてドラッグすると、接続線のセグメントを再配置できます。端点は固定されたままです。
接続線の一方または両方の端(ソースおよびターゲット)は、矢印ありまたは矢印なしで表示できます。接続線を選択した状態で、上部ツールバーの
ボタンをクリックし、表示されるポップアップメニューから必要なスタイルを選択します。
配置済み接続線のデジグネーターを定義するには、接続線をダブルクリックして必要なデジグネーターを入力します。デジグネーターを選択した状態では、右上のハンドルを使用して回転できます(
)。
接続線のセグメントの編集ハンドルをドラッグするか、そのセグメントを右クリックして表示されるメニューから Pin Segment を選択することで、そのセグメントを固定できます。固定されたセグメントの編集ハンドルは青色で塗りつぶされて表示されます(
)。固定されたセグメントの現在の水平または垂直位置は、接続線の他のセグメントを移動しても変化しません。固定を解除するには、セグメントの右クリックメニューから Unpin Segment を選択します。
ブランケットの配置
ESD ドキュメントエディターでは、システム設計をさらに文書化するために、ESD ドキュメント内へブランケットオブジェクトを配置できます。ハードウェアブランケットおよびソフトウェアブランケットは、それぞれ PCB プロジェクトまたはソフトウェアプロジェクトにリンクすることもでき、システム設計の特定部分のコンテキストを ESD ドキュメント上で把握できます。
下部ツールバーのブランケットオブジェクトメニューを使用して、ブランケット(
)、ハードウェアブランケット(
)、またはソフトウェアブランケット(
)を配置します(または、Library pane の Standard 領域にあるボタンを使用します)。
ハードウェアブランケットを PCB プロジェクトに、またはソフトウェアブランケットをソフトウェアプロジェクトにリンクするには、設計スペース内でブランケットを選択し、Properties pane の
ボタンをクリックします。ソリューションにリンクされたハードウェア/ソフトウェアプロジェクトを一覧表示する Select Project to link ウィンドウが開きます。ブランケットにリンクするプロジェクトを選択し、
ボタンをクリックします。リンクされたプロジェクトの情報が Properties pane に表示されます。
ボタンをクリックすると、リンクされたプロジェクトが新しいブラウザータブで開きます。
Board Support Package の生成
ソフトウェアブランケットでは、BSP(board support package)を生成できます。ソフトウェアブランケットのプロパティで
ボタンをクリックします。
ソリューションの SDM が自動的にプッシュされ(learn more)、変更はリンクされたソフトウェアプロジェクトに適用されます。まだ存在しない場合は、先に新しいソフトウェアプロジェクトが作成されます。
参照設計がソリューションにインポートされており(learn more)、その参照設計にリンクされたハードウェアブランケットが、ソフトウェアブランケットが存在する機能ブロックの周囲に配置されている場合、BSP 生成時に eval kit コンテキストが取得されます。boardName がデバイスモデルに追加され、指定された eval kit ボードと互換性のある構成を生成するためのソフトウェア生成に使用されます。
テキストの配置
ESD ドキュメントエディターでは、テキスト文字列を配置できます。必要に応じて、テキスト文字列にリンクを追加することもできます。
テキスト文字列を配置するには、下部ツールバーの
アイコンをクリックします(または、Library pane の Standard 領域にあるボタンを使用します)。
配置済みのテキスト文字列を編集するには、それをダブルクリックし、必要なテキストを入力して Enter を押すか、テキストオブジェクトの外側をクリックします。
配置済みテキストにリンクを追加するには、まず対象のテキストオブジェクトを選択し、次に上部ツールバーの
ボタンをクリックします。表示されるポップアップフィールドに必要な URL を入力し、Enter を押します。
追加したリンクは、テキストオブジェクトにカーソルを合わせてから、表示されるポップアップ内のリンクをクリックすることでアクセスできます。
リンクを編集するには、ポップアップ内の
ボタンをクリックし、必要に応じて URL を変更して Enter を押すか、
ボタンをクリックしてテキストオブジェクトからリンクを削除します。
グラフィカルオブジェクトの配置
ESD ドキュメントエディターには、ESD ドキュメント内に基本的なフリーフォーム描画要素を配置するための各種グラフィカル要素ツールが用意されています:
-
矩形(
)
-
楕円(
)
-
線(
)
-
画像(
)
下部ツールバーのグラフィカルオブジェクトメニューを使用して必要なオブジェクトを配置します(または、Library pane の Standard 領域にあるボタンを使用します)。
メニューから必要なコマンドを選択した後、設計スペース内でクリック&ドラッグしてグラフィック要素を配置し、その位置とサイズを決定します。たとえば矩形では対角の頂点間距離でサイズが決まります。ポリラインの場合は、最初の頂点を配置するためにクリックし、その後の頂点を配置するためにさらにクリックして形状を決定します。
配置済みのグラフィカルオブジェクトは、選択してドラッグすることで移動できます。個々のノードを選択して移動することもできます。
ライブラリからのオブジェクト配置
ESD ドキュメントエディターでは、Library pane で利用可能なライブラリから、よく使われる要素を配置することもできます。アクセスするには、設計スペース左上の
ボタンをクリックします。
pane には次の領域があります:
-
Standard – この領域で使用できるボタンを使って、基本オブジェクト(functional block、connection line など)を配置します。
-
Hardware Blocks – この領域で使用できるボタンを使って、あらかじめ定義された名前を持つ functional block を配置します。
-
Software Components – この領域で使用できるボタンを使って、あらかじめ定義された名前を持つ software component を配置します。
この領域にソフトウェアコンポーネントを追加するには、+ ボタンをクリックします。開く Software Components ウィンドウには、現在のソフトウェアコンポーネント一覧が表示されます。
ボタンをクリックして Create Component ウィンドウを開き、Library pane での表示名となるコンポーネント名を Component name フィールドに入力し、FSP specification フィールドを使用して必要なコンポーネントを選択します。
ボタンをクリックして、設定済みコンポーネントを Software Components ウィンドウ内の一覧に追加し、その表示アイコン(
)を有効にすると、Library pane で利用可能になります。
ボタンコマンドを使用して、対応するソフトウェアコンポーネントを管理します:
-
Edit – これを選択すると Edit Component ウィンドウが開き、コンポーネントの Component name および/または FSP specification を編集できます。
-
Remove – これを選択すると、コンポーネントが一覧から削除されます(そのコンポーネントが Library pane で表示されるよう設定されていた場合、そこからも削除されます)。
ソフトウェアコンポーネントを Library から非表示にするにはpane の場合は、Software Components ウィンドウ(
)でその表示を無効にするか、Library ペイン内のコンポーネントのボタンを右クリックして Remove を選択します。
-
-
Symbols – この領域で使用できるボタンを使って、定義済みの画像オブジェクトを配置します。
必要なオブジェクトのアイコンを Library ペインでクリックすると、ドキュメント内に配置されます。
SDM のプッシュとプル
ソリューションのあらゆる側面を相互に同期した状態に保つため、ESD エディターにはソリューションの System Data Model(SDM)をプッシュおよびプルする機能があります。これを行うには、ESD ドキュメント右上にある the
ボタンメニューの対応するコマンドを使用します。
-
Push SDM – このコマンドを使用して、ESD ドキュメントから SDM をプッシュします。ソリューションの SDM は ESD ドキュメントで行った変更と同期され、その後、これらの変更を Altium Designer のハードウェアプロジェクト(詳細はこちら)や e2 studio のソフトウェアプロジェクトなど、他のドメインへプルできます。
-
Pull SDM – このコマンドを使用して、SDM を ESD ドキュメントにプルします。ソリューションの SDM と同期するために ESD ドキュメントへ適用すべき変更がある場合は、Engineering Change Order ウィンドウが開きます。 Enabled 列のチェックボックスを使用して ESD ドキュメントに適用したい変更を選択し、
ボタンをクリックします。
ESD ドキュメントの管理
ボタンメニューのその他のコマンドを使用すると、ドキュメントを管理できます。
-
Settings – このコマンドを使用して Edit Project ウィンドウを開き、ESD ドキュメントの Name および Description (
)を変更するためのコントロールにアクセスします。
ボタンをクリックすると、Parent Folder フィールドと Workspace Parameters にアクセスできます。Parent Folder フィールドは編集できず、情報表示専用です。親フォルダーを変更するには、Move コマンドを使用する必要があります。変更を確定するには、
ボタンをクリックします。
-
Move – このコマンドを使用して Move to ウィンドウを開き、Workspace のフォルダー構造内で ESD ドキュメントを別の親フォルダーの下へ移動(再配置)するためのコントロールにアクセスします(
)。このウィンドウを使用して新しい親フォルダーを選択します。
ボタンをクリックして移動を実行します。
-
Clone – このコマンドを使用して Clone - ESD ウィンドウを開き、ESD ドキュメントの完全なコピーを作成するためのコントロールにアクセスします(
)。このウィンドウを使用して、ESD ドキュメント名と任意の説明を指定します。デフォルトでは、元のドキュメント名に – Copyという接尾辞が付加されます。
ボタンをクリックすると Parent Folder フィールドにアクセスできます。デフォルトでは、これは元のドキュメントが保存されているフォルダーに設定されます。フィールド右側の Change リンクをクリックすると、その Workspace の Workspace フォルダー構造が開き、複製ドキュメントを保存する別のフォルダーを選択できます。
必要に応じて各フィールドを設定したら、
ボタンをクリックすると、元のドキュメントが複製されます。作成された ESD ドキュメントのコピーは、その後 Renesas 365 Workspace 内の該当ソリューションの詳細ページから必要なソリューションにリンクできます。– 詳細はこちら。
-
Download – このコマンドを使用して、ESD ドキュメントを
*.jsonファイルとしてダウンロードします。
コメント
ESD ドキュメントエディターは、ESD ドキュメントへのコメント機能をサポートしています。コメントはユーザーが追加するメモで、特定のポイント、オブジェクト、または領域に割り当てられ、他のユーザーが返信できます。コメントは共有データ自体を変更することなくユーザー間のコラボレーションを促進します。これは、コメントがそのデータとは独立して Workspace に保存されるためです。 コメント内では、1 人または複数のユーザーやグループにメンションできます。コメントは Workspace メンバーに割り当てることもできます。
コメントの投稿、返信、および管理は、コンテキストコメントウィンドウを使用してドキュメントのデザインスペース内で直接行います。 コメントは Comments and Tasks ペインにも表示されます。このペインは右側に表示され、操作インターフェースというよりは概要表示やナビゲーションのための手段を提供します。
コメントを配置するには、ESD ドキュメント右上のツールバーにある
ボタン、ドキュメントのデザインスペースの右クリックメニューにある Add Comment コマンド、または Comments and Tasks ペイン内の
ボタンを使用します。
ESD ドキュメントの共有
ESD ドキュメントは、Workspace 外部のユーザーと閲覧権限付きで共有できます。ESD ドキュメント右上の
ボタンをクリックして Share Item ウィンドウを開きます。Share Item With フィールドを選択し、ユーザーの完全なメールアドレスを入力します。 そのユーザーは、自身の Workspace または Personal Space を通じて、共有された ESD ドキュメントに Guest-level アクセスできます。






)
)
)
)。

)またはその機能ブロック内に配置されたハードウェアコンポーネント(
)を選択したときに、Properties pane からも RA Explorer ウィンドウにアクセスできます。必要なコンポーネントを RA Explorer ウィンドウで選択すると、ハードウェアコンポーネントは自動的に機能ブロック内に配置され(まだ配置されていない場合)、選択したコンポーネントがそれに適用されます。







)。










