特定のプロジェクトの管理

Workspaceでは、製造を重視した高度なCAD中心のプロジェクトビューを利用できます。この管理インターフェースには、設計、タスク、履歴など、次のビューが用意されています。

  • Design – ソースプロジェクトの設計ドキュメントを表示して移動し、設計オブジェクトのプロパティを確認して、レビューコメントを追加できます。このビューでは、Web Viewerインターフェースを使用し、ソース回路図、基板の2D表示、基板の3D表示、Draftsmanドキュメント、部品表という5つのデータサブビューで設計を表示します。プロジェクトの特定のリリースではなく、ソースプロジェクトデータの最新バージョンを表示するため、作業中(WIP)のビューと捉えることができます。基本設計と、定義済みの各バリアントの両方をレビューできます。

    Workspaceのプロジェクト履歴ビューに表示されるコミットイベントまたはリリースイベントから、設計の以前のバージョンを表示することもできます。そのためには、コミットイベントタイルのメニューコマンド、またはリリースイベントタイルのコマンドから、Viewオプションを選択します。

  • Simulation – 現在のプロジェクトにシミュレーション結果ファイルをアップロードできます。アップロードしたファイルは、プロジェクトへのアクセス権を持つすべてのユーザーが確認またはダウンロードできます。

  • Tasks – 現在のプロジェクトに適用される、割り当て済みのタスク作業依頼を表示および管理できます。プロジェクトドキュメントに関連するタスクは、Altium DesignerまたはWorkspaceのコメントシステムを通じて担当者を割り当てることで作成されます。このプロジェクトに適用されるものの、特定のドキュメントやコメントには関連しないタスクは、このページで一般タスクとして作成できます。

  • Releases – プロジェクトのリリースを表示できます。リリースデータ全体、または特定のアセンブリパッケージを開くことができ、Manufacturing Portalを介して別のタブに表示されます。このポータルでは、リリース済みのファイルデータの表示や移動、BOMの確認に加え、リリースデータの元となった設計自体のスナップショットの表示やコメントの追加が可能です。Releases ビュー、または特定のリリースのManufacturing Portalから、製造データをさまざまな単位(データセット全体から個々の生成済み出力ファイルまで)でダウンロードするためのコントロールにアクセスできます。選択したリリースは、Manufacturing Packageとして製造業者に直接送信することもできます。また、リリース間またはローカルで生成したファイルセットとのガーバーデータの比較、リリース間の回路図データの比較、リリース間のBOMデータの比較も可能です。

  • Activities – 現在のプロジェクトに関連付けられた、進行中または終了済みのProject Activity プロセスワークフローを表示できます。プロセスの一覧には、開始者、担当者、開始日時、ワークフローの現在の段階など、各プロセスの状況の概要が表示されます。プロセスのエントリを選択すると、注釈付きのワークフロー図、関連するプロセスデータの概要、ワークフローイベントの時系列履歴などの詳細を確認できます。

  • Design Reviews – プロセスに沿った正式なプロジェクト設計レビューを作成し、実施できます。設計レビューは開始者が設定し、指名されたレビュー担当者が実施します。オプションのチェックリスト、設計ソースのスナップショット、コメント機能、および進捗に関連するタスクを含みます。Workspace管理者は、この構造化されたレビューのプロセスワークフロー自体にアクセスし、設計レビュープロセスを新規作成または変更できます。

  • History – プロジェクトの作成、コミット、リリース、クローン作成、MCADとのデータ交換など、プロジェクトに関連する主要なイベントを時系列で参照できます。プロジェクトに関連して対応イベントが発生するたびに、そのイベントが専用タイルとしてタイムラインに追加され、必要に応じて各種操作を実行できます。また、リリース間またはローカルで生成したファイルセットとのガーバーデータの比較、リリースイベントやコミットイベント間の回路図データの比較、リリースイベント間のBOMデータの比較(ファイルのダウンロード)も可能です。

  • Assembly Assistant – BOMの項目とそれに対応するグラフィックを連動させた、視覚的な基板実装アプリケーションにアクセスできます。実施記録を残しながら順を追って進めるプロセスを開始でき、PCBの物理的な実装作業を段階的に進めるのに役立ちます。各プロセスのステップには、DoneまたはSkipped(後で完了する項目)という状態を設定できます。これにより、1か所で追跡可能な実装進捗ビューが提供され、手作業や紙ベースの複雑な基板実装確認プロセスを回避できます。

プロジェクトの詳細管理ページを開くには、対象のプロジェクトを選択し、プロジェクト一覧の上にあるコントロールをクリックして、表示されるメニューからOpen 項目を選択します。または、一覧内の目的のプロジェクトのエントリを直接ダブルクリックします。ページは新しいブラウザータブで開きます。

Projectsページのグラフィカルビューでも、目的のプロジェクトのタイルを選択し、コントロールをクリックして、コンテキストメニューからOpenコマンドを選択することでアクセスできます。または、タイル内のプロジェクト名をクリックします。Projects ページがリストビューで表示されている場合は、目的のプロジェクトのエントリの右端にあるコントロールをクリックし、表示されるメニューからOpen コマンドを選択します。

プロジェクトの詳細管理ページへのアクセス。プロジェクトの詳細管理ページへのアクセス。

Workspace Web Viewerは、マルチボードプロジェクト独自の構造ビューと設計ビューにも対応しています。詳細については、以下の折りたたみセクションを開いてください。

プロジェクトの詳細管理ページには、Altium Designer内からもアクセスできます。アクティブな管理対象プロジェクトの場合は、メインメニューからProject » Show in Web Browserコマンドを使用します。または、Projectsパネルでプロジェクトのエントリを右クリックし、コンテキストメニューからShow in Web Browserコマンドを選択します。Altium DesignerのExplorerパネルでプロジェクトを参照している場合は、パネルがClassic ViewではなくデフォルトのProject Viewに設定されていれば、ボタンをクリックして詳細管理ページにアクセスできます。

以降のセクションでは、詳細管理ページに表示される、プロジェクトの設計とそのデータに関する5つの主要なビューについて詳しく説明します。

設計

Related page: Web Viewer

Designビューでは、プロジェクトの設計ドキュメントや、ドキュメント内のオブジェクトのプロパティデータにインタラクティブにアクセスできるほか、ドキュメント内の指定した位置に共同でコメントを追加できます。このビューは、プロジェクトの特定のリリースではなく、ソースプロジェクトデータの最新バージョンを対象としているため、作業中(WIP)のビューと考えることができます。基本設計と、定義されている各バリアントの両方を確認できます。

設計全体および該当する各サブビューで、コンポーネントやネットを検索、選択、クロスプローブ、検査できます。また、基板を2Dで表示している場合は、測定も行えます。

 
Designビューでは、Altium 365のWeb Viewer機能を使用し、設計プロジェクトのソース回路図およびPCBドキュメントを、臨場感のあるインタラクティブな環境でレビューできます。ここでは、回路図に続いてPCBの3D表示を示しています。

高度なWebグラフィックスエンジンとインターフェースであるWeb Viewerにより、設計とそのオブジェクトを見つけて視覚的に検査するために必要な機能がすべて提供されます。このビューには、完全にレンダリングされた2Dおよび3DのPCBレイアウト表示、オブジェクトの検索、選択、クロスプローブ機能、ツリー形式の設計ドキュメントナビゲーションも含まれています。また、設計スペースと動的に連携するアクティブなコメントシステムへのインターフェースと、選択した設計オブジェクトの包括的なプロパティ一覧も提供されます。

作業中の設計プロジェクト(基本設計)のスナップショットを含むZipアーカイブのダウンロードに加え、各種の派生出力を生成してダウンロードすることもできます。これらの出力には、該当するOutput Jobファイルが存在する場合、その設定情報が直接使用されます。出力には、GerberファイルとNCドリルファイル、回路図PDFとアセンブリPDF、CSV形式のBOMデータが含まれます。

ドキュメントとデータのダウンロードオプションの詳細については、Web Viewer – ダウンロードを参照してください。

Design ビュー機能全般の詳細については、Web Viewerページを参照してください。

シミュレーション

Simulationページは、現在のプロジェクトまたはプロジェクトリリースに関連付ける回路シミュレーション結果ファイルの保存場所です。インポートされたシミュレーションファイルは、実質的にプロジェクトへの添付ファイルとなり、Workspaceのメンバーは、現在開いているプロジェクトに関連するシミュレーション結果ドキュメントを確認したり、ダウンロードしたりできます。

Simulationページには、汎用のシミュレーションファイル(Uploads)とAnsys®のシミュレーション結果ファイル(Ansys)用のサブロケーション(実質的なフォルダー)が含まれています。

Uploadsフォルダー

シミュレーションファイルは、WorkspaceのSimulation - Uploadsフォルダーにアップロードできます。このフォルダーは、PDF、XLS、HTML、アーカイブ(Zip、7zなど)をはじめとする幅広いデータファイル形式に対応しています。最初のシミュレーション結果ファイルをアップロードするには、ローカルファイルをページにドロップするか、choose from your computerオプションでローカルファイルを参照して選択します。以降のアップロードには、ページ上部のボタンを使用します。

さまざまなファイル形式のシミュレーション結果をプロジェクトにアップロードし、Workspaceメンバーがアクセスできるようにします。さまざまなファイル形式のシミュレーション結果をプロジェクトにアップロードし、Workspaceメンバーがアクセスできるようにします。

アップロードされたファイルは、ファイルエントリのRelated to列に示されるとおり、最新のプロジェクトコミット、つまりプロジェクトの現在のリビジョンに関連付けられます。付随するアイコンをクリックすると、関連付けられたプロジェクトコミットが開きます。

WorkspaceのReleasesページから、特定のプロジェクトリリースにファイルをアップロードすることもできます。この場合は、リリースエントリのメニューにあるAttach Simulationsオプションを使用して、ローカルファイルを選択し、アップロードします。追加したシミュレーションファイルは、そのリリースに含まれるファイルとして一覧に表示され、リリースに追加されるアイコンでその存在が示されます。

シミュレーション結果ファイルを特定のプロジェクトリリースに直接アップロードします。シミュレーション結果ファイルを特定のプロジェクトリリースに直接アップロードします。

開いたプロジェクトリリースにも、そのリリースに関連するSimulationファイルの一覧が表示されます。プロジェクトのメインのシミュレーション一覧と同様に、添付されたシミュレーション結果ファイルをアップロードおよび管理できますが、ここでは、その特定のプロジェクトリリースが対象となります。

メインのSimulationページに戻ると、現在のプロジェクトに追加されたすべてのアップロード済みファイルが、プロジェクトリリースにアップロードされたものも含め、Uploads一覧に表示されます。

コミットとリリースの両方に関連するアップロード済みファイルは、Simulationsページに表示されます。このページでは、ファイル管理オプションも利用できます。コミットとリリースの両方に関連するアップロード済みファイルは、Simulationsページに表示されます。このページでは、ファイル管理オプションも利用できます。

各エントリのドロップダウンメニューから、次のファイルコマンドにアクセスできます。

  • Open – ファイルを開いて表示(PDFのみ)またはダウンロードします。

  • Edit – ファイル名を変更し、説明を追加します。説明は、エントリのファイル名の下に表示されます。

  • Download – ブラウザーのデフォルトのダウンロード先にファイルを即座にダウンロードします。なお、他のファイル参照では、ファイル名にダウンロードアイコン()が付いています。

  • Delete – 選択したファイルとそのすべての関連付けをWorkspaceから完全に削除します。

Simulationsページの一覧にある各エントリのRelated toセルには、関連するコミットまたはリリースへの直接リンク()が含まれています。

Ansysフォルダー

WorkspaceのSimulation – Ansysフォルダーは、Ansys®設計シミュレーションプラットフォームで生成されたDesign Summaryファイル(シミュレーション結果)を受け入れるための専用の場所です。AltiumのAnsys CoDesigner統合によって、WorkspaceはAltium DesignerとAnsys Electronics Desktop™アプリケーションをつなぐ双方向のブリッジとして機能し、設計およびシミュレーションの変更データを交換できるようにします。

詳細については、Altium DesignerのAnsys CoDesignerページを参照してください。

Ansys Electronic Desktop側でInclude Simulation Resultオプションを有効にしてデータのPushを実行すると、AnsysフォルダーにAnsys Design Summary PDFファイルが格納されます。シミュレーション結果ファイルをダブルクリックすると、WorkspaceのPDFビューアーで開いて表示できます。

Ansysシミュレーションフォルダーには、Ansys CoDesignプロセスの一環としてAnsysのシミュレーション側からプッシュされたシミュレーション結果ファイルが格納されます。Ansysシミュレーションフォルダーには、Ansys CoDesignプロセスの一環としてAnsysのシミュレーション側からプッシュされたシミュレーション結果ファイルが格納されます。

タスク

Related information: Workspaceタスクの操作、Web Viewer – コメントウィンドウ。

このビューでは、現在開いている設計プロジェクトに適用されるTasks(作業依頼)にアクセスし、管理できます。タスクはカンバンボード形式で表示され、タスクの各行内で進捗状態(ToDo、InProgress、Resolved)が移動します。1行は汎用タスク(設計ドキュメントに関連付けられていないタスク)用に確保され、残りの各行には特定のプロジェクトドキュメントのタスクが表示されます。汎用タスクはダッシュボード内()で作成し、ドキュメント固有のタスクはプロジェクトのコメントにWorkspaceメンバーを割り当てることで作成します。

Altium 365 WorkspaceのTasksダッシュボードで、共同作業のタスクを管理、実行できます。Altium 365 WorkspaceのTasksダッシュボードで、共同作業のタスクを管理、実行できます。

WorkspaceのTasksダッシュボードは、比較的シンプルなインターフェースでありながら、外部システムではなく実際の設計環境内でワークフローを柔軟かつ効率的に管理、追跡できます。このページはプロジェクト固有のタスクビューで、開いているWorkspaceプロジェクトで現在アクティブなタスクが表示されます。一方、Workspaceのメインナビゲーションツリーからアクセスできる全体のタスクビューには、Workspace内のすべてのプロジェクトでアクティブなタスクが表示されます。

リリース

Releasesビューには、設計スペースから生成されたすべてのプロジェクトリリースパッケージが表示されます(設計プロジェクトのリリースを参照)。各パッケージには、リリースされたソースデータ、基板製造データ、実装データが含まれます。

Releasesビューでは、リリース済みのデータパッケージにアクセスできます。専用のManufacturing Portalでパッケージを開いて詳細を確認したり、リリースをManufacturing Packageとして製造業者に送信したりすることもできます。Releasesビューでは、リリース済みのデータパッケージにアクセスできます。専用のManufacturing Portalでパッケージを開いて詳細を確認したり、リリースをManufacturing Packageとして製造業者に送信したりすることもできます。

このビューでは、次の操作が可能です。

  • リリースに含まれる任意のデータセット、またはすべてのデータセットをダウンロードします。リリースに対応するボタンをクリックすると、ダウンロードするデータセットを指定するウィンドウが開きます。ボタンをクリックすると、選択したデータセットごとのフォルダーを含む単一のZIPアーカイブが、ブラウザーの既定のダウンロードフォルダーにダウンロードされます。

    • Full Release ウィンドウには、以前のリリースから今回のリリースで更新されていないファイルを含めるためのチェックボックスも用意されています ( クリックしてドラッグで移動​)。

    • Show Filesコントロールをクリックして、リリースを構成する各データセットのファイルを参照することもできます。データセット全体から、特定のフォルダーや出力の種類、個々のファイルまで、あらゆる単位でダウンロードできます。項目にカーソルを合わせてボタンをクリックすると、ダウンロードが開始されます。データセットや特定の出力フォルダーの場合は、ZIPアーカイブがダウンロードされます。個々のファイルの場合は、そのファイルが圧縮されずにダウンロードされます。

  • リリースを開くと、別のタブのManufacturing Portalに表示されます。このポータルでは、リリースされたファイルデータの表示や閲覧、BOMの確認、さらにリリースデータの元となる設計自体のスナップショットの表示やコメントの追加ができます。また、データセット全体から個々の生成済み出力ファイルまで、さまざまな単位で製造データをダウンロードするためのコントロールも利用できます。

  • 選択したリリースをManufacturing Packageとして製造業者に直接送信します。

  • リリース項目のメニューからCreate Managed BOMオプションを選択して、特定のリリースからManaged BOMを生成します。

  • 基板製造データまたは回路図データを比較し(それぞれガーバー比較および回路図比較)、BOM比較データをZIPファイルとしてダウンロードします。

  • リリース内の任意のデータセットのライフサイクル状態を変更します。

  • 適用対象外のリビジョン状態にあるデータセットを1つ以上含むリリースの表示を切り替えます(Show hidden releasesコントロールを使用)。

以降のセクションでは、これらの各種機能について詳しく説明します。

リリースパッケージの参照

リリースパッケージ全体を開いて表示するには、対応するボタンをクリックします。または、ボタンをクリックし、リリースパッケージ全体(Full Release)または特定の実装(バリアント)のどちらを表示するかを選択します。開いたリリースパッケージは、新しいManufacturing Portal ブラウザータブに表示されます。

専用のManufacturing Portalタブにアクセスして、管理対象プロジェクトの特定のリリースを詳しく確認できます。専用のManufacturing Portalタブにアクセスして、管理対象プロジェクトの特定のリリースを詳しく確認できます。

Manufacturing Portalには、リリースパッケージのPCB設計データが次のビューで表示されます。

上記の2つのビューでは、次の操作が可能です。

  • ビュー右上のボタンをクリックすると、リリースに含まれるデータセットのライフサイクル状態を変更するためのコントロールや、Gerber比較、回路図比較、BOM比較の各機能にアクセスできます。

  • ボタンをクリックすると、プロジェクトのリリースをManufacturing Packageとして製造業者に送信できます。Sending to Manufacturerウィンドウが表示され、パッケージの内容と送信先を設定できます。詳細については、次のセクションを参照してください。

SimulationビューとAssembly Assistantビューには、プロジェクトの共同作業者向けの追加機能があります。インポートされたシミュレーション結果ファイルは、そのリリース固有のものとなります。同様に、Assembly Assistantで使用されるBOMと実装データも、その特定のリリースに関連するものとなります。

製造業者へのデータの送信

管理対象プロジェクトの特定のリリースの製造データをダウンロードして製造業者に渡すこともできますが、Altium 365プラットフォームを通じてパッケージを製造業者と直接共有すれば、より協調的かつインタラクティブに作業を進められます。この方法では、送信するプロジェクトのリリースを指定し、データの内容を設定したうえで、そのパッケージ(以降、Manufacturing Packageと呼びます)を目的の製造業者に送信できます。実際には、パッケージがその製造業者と共有され、製造業者には招待メールが届きます。製造業者は専用のManufacturing Package Viewerを使用して、Altium 365プラットフォームインターフェース(https://365.altium.com)からパッケージを直接表示できます。

Altium 365プラットフォームには、Global Sharingサポートの一部として専用のManufacturing Package Viewerが用意されています。これにより、他のユーザーは世界中のどこからでも、任意のWebブラウザーで製造パッケージを表示できます。表示はWorkspaceの外部で行われるため、設計やその他の貴重な知的財産へのアクセスは制限されたままです。詳細については、グローバル共有と製造パッケージビューアーを参照してください。

プロジェクトの詳細管理ページのReleases ビューでは、特定のリリースのエントリーにあるボタンをクリックすることで、そのリリースをManufacturing Packageとして製造業者に送信できます。

Sending to Manufacturerウィンドウが表示され、パッケージの内容と送信先を設定できます。

プロジェクトの特定のリリースを製造業者に直接送信(共有)できます。プロジェクトの特定のリリースを製造業者に直接送信(共有)できます。

製造パッケージは、次の項目を設定して定義します。

  1. Data – 製造パッケージの内容、つまりパッケージに含めるリリースデータを定義する必要があります。デフォルトでは、基板製造データセットと実装データセットがパッケージに追加されています。パッケージをさらに設定するには、Configure コントロールをクリックします。表示されるポップアップウィンドウで、含めたいデータセット(ソース設計のスナップショット、基板製造データセット、実装データセット)を有効にします。すべてのデータセットをまとめて含めるには、リストの先頭にあるエントリーを有効にします。
パッケージ内に少なくとも1つのデータセットを定義するまでは、製造パッケージを製造業者に送信できません(Send ボタンは使用できない状態のままになります – )。

製造パッケージに含めるデータセットを定義する必要があります。製造パッケージに含めるデータセットを定義する必要があります。

必要なデータセットを有効にしたら、ボタンをクリックします。それらのデータセットのエントリーが、Sending to Manufacturerウィンドウの上部に表示されます。

データセットをすばやく削除するには、そのタイルの右上にある削除用の×をクリックします。
  1. Package Name – 初期値はPCBアセンブリ自体の名前です。必要に応じて変更できます。
  2. Revision – このフィールドは、同じリリースから作成した複数の製造パッケージを区別するために使用できる、単純な文字列属性です。初期値として「1」が入力されていますが、すべてのパッケージ間で一意であれば、必要な値を入力できます。同じリリースデータから次のパッケージを生成するたびに、このフィールドには次に使用可能な(未使用の)整数がデフォルトで入力されます。
  3. Description – パッケージで提供する内容の説明を入力します。これにより、製造業者はパッケージに何が含まれているかを理解しやすくなります。
  4. Manufacturer Email – このフィールドに製造業者のメールアドレスを入力します(フィールドの外をクリックするか、Enter を押すと、そのメールアドレスが追加されます)。通常は製造担当の窓口を1名指定し、その担当者がパッケージ内のデータを使用して基板の製造から実装までを進めます。ただし、必要に応じて複数の異なるメールアドレスを追加することもできます。追加したメールアドレスを削除するには、その右側の×をクリックします。

パッケージの定義が完了したら、ボタンをクリックします。パッケージは、作成者であるあなた、指定した製造業者、およびプロジェクトを共有しているすべてのWorkspaceメンバーと共有されます。ReleasesビューのSent領域に、Name.Revision形式の名前を持つタイルとして表示されます。

製造パッケージを送信すると、Releases ビューのSent 領域に、そのパッケージのエントリーが表示されます。製造パッケージを送信すると、Releases ビューのSent 領域に、そのパッケージのエントリーが表示されます。

製造業者によるパッケージへのアクセス

パッケージの送信先である製造業者には、Altium 365を通じてそのパッケージにアクセスするための招待メールが届きます。メール内の ボタンをクリックすると、Altium 365 Sign In ページに移動します(プラットフォームまたはAltium Accountにすでにサインインしている場合を除く)。サインインすると、共有パッケージが読み込まれた Manufacturing Package Viewer に移動します。

  • 製造業者がAltium Accountを持っていない場合は、まずアカウントを登録する必要があります。登録用のリンクは Altium 365 Sign In ページにあります。

  • 登録が完了すると、製造業者は 外部共有ゲストとなり、アクセスできる範囲は、共有された Manufacturing Package と、その製造業者に明示的に共有されたその他のアイテムのみに厳しく制限されます。

製造業者が受信した招待メールから、共有された製造パッケージにアクセスする様子。製造業者が受信した招待メールから、共有された製造パッケージにアクセスする様子。

送信された製造パッケージは、Altium 365プラットフォームインターフェースの Shared with Me ページから利用できます。製造パッケージは、タイル内の アイコンで示されます。

Altium 365プラットフォームインターフェースにサインインしたユーザーの Shared with Me ページから、すぐに利用できる製造パッケージの例。Altium 365プラットフォームインターフェースにサインインしたユーザーの Shared with Me ページから、すぐに利用できる製造パッケージの例。

直接リンクをコピーして製造業者に送信している場合、製造業者はそのリンクを使用してパッケージにアクセスすることもできます。

設計データの比較

Related page: 設計データの比較

Workspaceのプロジェクトビューでは、異なるプロジェクトのリリース間やコミット間で、ガーバー、回路図、BOMデータに生じた変更をすばやく確認できます。データ比較機能は、プロジェクト開発中の更新を追跡するのに最適で、Releases ページ、History ページ、およびリリースパッケージの表示時に直接アクセスできます。

  • Gerber Comparison – ガーバー比較機能では、異なるリリースのガーバーファイル間、または既存のファイルセットとの間で、レイヤーごとに表示を制御しながらデータをグラフィカルに比較できます。変更箇所には番号が付けられ、対話型のナビゲーションペインから確認できるほか、表示領域でハイライトされます。

詳細については、データの比較 – ガーバーを参照してください。

  • Schematic Comparison – 回路図比較機能は、プロジェクトのリリース間やコミット間におけるコンポーネントおよびネットのデータ変更を検出し、グラフィカルにハイライトします。比較結果はプロジェクト内のすべての回路図について確認でき、変更内容は対話型の差分ペインに一覧表示されます。

詳細については、データの比較 – 回路図を参照してください。

  • BOM Comparison – 部品表(BOM)比較機能は、指定したプロジェクトのリリース間またはコミット間のBOMデータの差分を検出します。結果はWorkspaceのデータ比較インターフェースに表示され、比較対象間で変更されたBOMアイテムが色分けされたエントリの一覧として示されます。検出されたすべての変更の詳細な概要を含むCSV形式のファイルをダウンロードすることもできます。

詳細については、データの比較 – BOMを参照してください。

ライフサイクル状態の変更

プロジェクトのリリースでは、そのリリースに含まれる各データセット(Workspaceにリリースされたアイテム)のライフサイクル状態を、Releases ビューから直接変更できます。この操作は Change Lifecycle State ウィンドウで行います。このウィンドウを開くには、リリースに対応する ボタンをクリックし、メニューから Change Lifecycle State を選択します。

リリースパッケージ内のデータセットのライフサイクル状態を、Releases ビューから直接変更します。リリースパッケージ内のデータセットのライフサイクル状態を、Releases ビューから直接変更します。

各データセットは、名前、現在のライフサイクル状態、および次の状態とともに一覧表示されます。Next State セル内をクリックすると、そのアイテムに使用されているライフサイクル定義に従って、選択可能な状態の一覧が表示されます。データセットをリストから除外して状態が変更されないようにするには、右端の コントロールをクリックします。

Next State セルのドロップダウンリストには、遷移可能なすべての状態が表示されます。これらは Current State(ここでは2つの例を表示)に基づき、親のライフサイクル定義の一部として定義されています。Next State セルのドロップダウンリストには、遷移可能なすべての状態が表示されます。これらは Current State(ここでは2つの例を表示)に基づき、親のライフサイクル定義の一部として定義されています。

必要に応じて状態の変更を設定したら、 をクリックします。メインの Releases ビューに戻ると、そのリリースで変更対象となった各データセットのライフサイクル状態情報が更新されています。

リリース内のすべてのデータセットのライフサイクル状態を2回変更し、New From Design から In Prototype を経て、最終的に In Production にした例。リリース内のすべてのデータセットのライフサイクル状態を2回変更し、New From Design から In Prototype を経て、最終的に In Production にした例。

Altium Designer 21以降では、リリース内の各データセットのライフサイクル状態を変更するこの機能は、Explorerパネルでプロジェクトを Project View(Classic View ではありません)で表示しているときに利用できます。

該当しないリリースの非表示

Releases ビューでは、「利用対象外」と見なされるリリースの表示を切り替えることができます。これにより、適用できないライフサイクル状態(例:Deprecated、Obsolete、Abandoned)のデータセットを1つ以上含むリリースパッケージを非表示にできます。これは、適用されているライフサイクル定義自体によって決まります。この定義では、特定の状態を設計で使用できないように設定できます。

手順は次のとおりです。

  1. 次の画像には、あるプロジェクトの2つのリリースが表示されており、どちらも構成データセットがIn Production状態になっています。古いリリースは廃止済み(使用不可)と見なされるため、非表示にして、最新のリリースだけを表示する必要があります。

設計の後続リリースが量産に移行したため、古いリリースを廃止済みにして、Releases ビューで非表示にする必要があります。 設計の後続リリースが量産に移行したため、古いリリースを廃止済みにして、Releases ビューで非表示にする必要があります。

  1. リスト内でのリリースの表示は、データアイテムが特定のライフサイクル状態に移行した際に、設計での使用が許可されるかどうかに基づいて決まります。適用されるライフサイクル定義(Admin – Lifecycle Definitions)では、状態プロパティAllowed to be used in designsによって制御されます。このプロパティが無効になっている場合、リリースのデータアイテムのいずれかがそのライフサイクル状態に移行すると、デフォルトでそのリリースが非表示になります。この例では、リリース済みの設計アイテムに適用されるライフサイクル定義の「廃止済み」状態で、このプロパティが無効になっていることを確認するだけです。状態の図形をダブルクリックして、State Propertiesウィンドウを開きます。

「廃止済み」状態でAllowed to be used in designsプロパティが無効になっていることを確認します。これが、Releases ビューでリリースを非表示にするための重要な設定です。「廃止済み」状態でAllowed to be used in designsプロパティが無効になっていることを確認します。これが、Releases ビューでリリースを非表示にするための重要な設定です。

  1. 次に、古いリリースのデータアイテムのライフサイクル状態を「廃止済み」に変更します。前のセクションで説明したように、Change Lifecycle Stateウィンドウを使用して変更します(リリースに対応するボタンをクリックし、メニューからChange Lifecycle Stateを選択します)。これにより、廃止済みで使用すべきでない設計リリースをユーザーが利用できなくなります。

データアイテムを使用が許可されないライフサイクル状態に変更すると、そのリリースはReleases ビューで非表示になります。データアイテムを使用が許可されないライフサイクル状態に変更すると、そのリリースはReleases ビューで非表示になります。

  1. これらの非表示リリースの表示を切り替えるには、Releasesビューの右上にあるShow hidden releasesコントロールを使用します。

 
Show hidden releasesコントロールを使用して、利用対象外のリリースの表示と非表示を切り替えます。ここでは、適用可能なリリースのみを表示する、コントロールのデフォルト状態を示しています。画像にカーソルを合わせると、コントロールが有効になり、適用できないリリースも表示された状態を確認できます。

Altium Designer 21以降では、ExplorerパネルでプロジェクトをProject View(Classic Viewではありません)で表示しているときに、非表示リリースの表示を切り替えることができます。

設計レビュー

Related information: 設計レビューページ

プロジェクトのDesign Reviewページでは、体系的なプロジェクトレビューを作成・管理し、他のユーザー(レビュー担当者)に評価を依頼できます。レビュー作成者(開始者)は、テキストベースのチェックリスト項目、添付ファイル、関連コメントを含めるようにレビュープロセスを設定できます。レビュー担当者は、取得された設計のスナップショットを開き、レビューのチェックリスト項目を完了し、関連するコメントを追加し、設計比較を実行して、最終的にプロセスをAccepted/Rejected状態まで進めることができます。その後、レビュー開始者が自身のCompleted/Rejected評価とコメントを加えてプロセスを完了します。

設計レビューは、設計上の問題を明確にし、設計が社内のコンプライアンス要件を満たしていることを確認するための便利な方法です。レビュー中およびレビュー後は、Workspaceのすべてのメンバーがレビューを参照でき、プロジェクトのタスクページからもアクセスできます。

プロジェクトの表示中に設計レビューのオプションを選択すると、現在のプロジェクトに対して、設定可能なピアレビューを作成、参照、管理できます。プロジェクトの表示中に設計レビューのオプションを選択すると、現在のプロジェクトに対して、設定可能なピアレビューを作成、参照、管理できます。

Altimade

Altimade機能は招待制です。組織で有効になっている場合は、Altium DesignerとAltium 365 Workspaceの両方のインターフェースからアクセスできます。この機能は、提携するハードウェア製造プラットフォームと直接連携し、設計したハードウェアの見積もりと製造を行う、効率的で自動化された設計・製造システムを提供します。

注文の事前処理と発注はAltium Designerで行い、その後はWorkspaceのAltimadeページで管理します。

Altium Designerでの注文準備の手順については、Altimadeによるワンクリック注文ページを参照してください。

Altium 365 Workspaceでの支払い機能と管理機能については、Altimadeの注文管理ページを参照してください。

アクティビティ

Activitiesビューには、プロジェクトに関連付けられたレビュー/公開のプロジェクトアクティビティプロセスと、その現在の進捗状況の詳細な概要が表示されます。進捗状況は、ワークフロー図内で担当ユーザーが強調表示されたタスクステップとして示されます。ページヘッダーのOpen/Closedメニューオプションを使用して、進行中または完了済みのプロジェクトアクティビティを一覧表示できます。上部のSearchフィールドでは、日付以外の列のフィールドに含まれる文字列で一覧を絞り込めます。また、ボタンを使用すると、有効なプロセスのリストから新しいプロセスアクティビティを開始できます。

このビューには、アクティビティの流れと状態を示す注釈付きの図(Diagramモード)に加えて、アクティビティに関連するパラメーターデータ(関連ユーザー、プロジェクト情報など)を一覧表示するData表示モードと、ワークフローイベントの順序(開始、準備、タスク完了など)を表示するHistoryモードがあります。

プロジェクトアクティビティは通常、Altium DesignerのProject » Activitiesメニューから利用可能なプロセスを選択して開始します。その後、アクティビティに、利用可能なプロジェクトとデータ、レビューを担当するユーザー、必要に応じてレビューコーディネーターとなる指定ユーザーを割り当てます。これらのユーザーにはタスクが自動的に作成され、Altium DesignerのTasklistパネルとWorkspaceのタスクページに表示されます。

Ad-hoc、Milestone、Handoffのレビューなどのプロジェクトアクティビティは、Workspace管理者がProcesses Managementページ(Admin – Processes)で有効化および設定します。上記のActivitiesビューでは、管理者は実行中のプロセスをキャンセル(Terminate)したり、一覧に表示されているすべてのアクティビティの情報を含むCSVファイルをダウンロード()したりすることもできます。

履歴

Related page: プロジェクト履歴

Historyビューには、プロジェクトに関連する主要なイベント(作成、コミット、リリース、クローン作成、MCADとのデータ交換)が時系列で表示され、該当する場合は各種操作を実行できます。

この機能を最大限に活用するには、プロジェクトをWorkspaceのVCS(Git)で管理する必要があります。これは、Altium Designerで新規プロジェクトを作成する際、または既存のプロジェクトをオンラインで利用可能にする際に有効にできます。ローカルプロジェクトが外部のバージョン管理下にある場合は、オンラインで利用可能にする際にバージョン管理ストレージへ移行オプションを選択します。

History ビューには、プロジェクトの進展に伴って発生した基本的なイベントがタイムラインで表示されます。History ビューには、プロジェクトの進展に伴って発生した基本的なイベントがタイムラインで表示されます。

このビューは、基本的に次の3つの主要なセクションに分かれています。

  1. Main trunk of the timeline。イベントは下から上へ時系列順に並びます。最初のイベントであるプロジェクトの作成は、タイムラインの最下部に表示されます。その後のイベントは上に追加され、最新のイベントがタイムラインの最上部に表示されます。

  2. Events。プロジェクトに関連するサポート対象のイベントが発生するたびに、そのイベントが専用のタイルとしてタイムラインに追加されます。タイルの色はイベントの種類ごとに異なり、タイムラインの幹に直接接続されるか、MCAD Exchangeイベントのように横に追加のアイコンが表示されます。コミットイベントでは設計の差分表示がサポートされており、現在のコミットと前回のコミットの間で変更された内容の基本情報(ファイル、コンポーネント、ネット、PCB構造、バリアントなど)を確認できます。次の2種類のイベントでは、イベントタイルから追加の操作を実行できます。

    1. Commit event – そのバージョンの設計を使用したプロジェクトのクローンの作成、そのバージョンの設計のソースファイル(コミットのスナップショット)の表示やダウンロード、およびそのコミットと別のコミットやリリースの設計データとの比較が可能です。

    2. Release event – 製造ポータルでリリースパッケージを開いて表示したり、リリースパッケージ全体、またはそのリリースパッケージの作成に使用された設計バージョンのソースファイルをダウンロードしたりできます。また、ガーバー比較、回路図比較、BOM比較の各機能も利用できます。

  3. Search。ビューの右上にあるコントロールをクリックすると、プロジェクト履歴の基本的な検索を行うための検索フィールドが表示されます。検索文字列を入力するとタイムラインにフィルターが適用され、検索に関連するイベントのみが表示されます。

プロジェクトに関連するサポート対象のイベントが発生すると、そのイベントが自動的に検出され、History ビューで利用できるようになります。イベントの発生後まもなく、ビューの下部に通知が表示されます。コントロールをクリックすると、新しいイベントがタイムラインに反映されます。ビューの右上にあるコントロールをクリックして、手動で更新することもできます。

組み立てアシスタント

Related page: 組み立てアシスタント

このビューでは、プロジェクトの詳細なBOMデータと2D/3D組み立てビューを統合した、基板組み立て支援アプリケーションを利用できます。この2つの組み立て情報が連携するため、BOMの要素とPCBビュー(2Dまたは3D)上のグラフィック表示の間で直接クロスプローブできます。

このアプリケーションには、対話的に組み立て情報を参照するモードに加え、実際の組み立て手順に合わせて進捗を記録できる、体系的な基板組み立てプロセスモードが用意されています。これにより、基板の組み立て工程の確認と監査を、1か所で効率的かつ自動的に行えます。

 

Assembly Assistantは自由に参照できるモードで開き、ボタンから所定の組み立てプロセスモードに切り替えることができます。詳細は、組み立てプロセスの流れを参照してください。このモードでは、対話形式で手順を進めながら、実際の基板の組み立てに合わせてBOMの項目にDoneまたはSkippedのマークを付けることができます。PCBのグラフィック表示は該当するコンポーネントにズームし、必要に応じて基板表示が反転します。

  • コンポーネントは、Doneのマークが付けられるまでは基板上の位置で示され、マークが付くと3D表示に切り替わります。

  • キーボードショートカットを使用すれば、マウス操作なしで組み立てプロセスを進められます。

  • すべてのコンポーネントにDoneのマークが付くと、所要時間や実装したピンの数などの概要情報が表示されます。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

Contents