Интеграция с PLM
Комплексное решение для проектирования на базе Altium Designer и Workspace в Altium 365 предлагает настраиваемую PLM Integration с доступной поддержкой Windchill®, Arena®, Oracle® Agile™, Aras Innovator®, и Siemens Teamcenter® (с дополнительной настройкой). Настройка интеграции PLM выполняется через браузерный интерфейс Workspace в Altium 365, который предоставляет автоматизированный интерфейс для простой настройки соединения, сопоставления данных параметров и указания направления синхронизации данных. После настройки интерфейса функции и возможности интеграции PLM доступны при работе в следующих отдельных областях:
-
Library (компоненты) – обеспечивает одно- или двунаправленную синхронизацию ваших компонентов, параметров компонентов и вариантов выбора деталей между вашим Workspace в Altium 365 и экземпляром PLM. Конфигурация позволяет указать, какие параметры являются мастер-данными в какой системе. Кроме того, параметры элементов позволяют обновлять свойства на стороне Workspace (с настройкой по каждому полю) без необходимости формально выпускать новую ревизию этого элемента компонента. Также доступен специализированный рабочий процесс Part Request workflow, который поддерживает автоматическое создание компонента в вашем экземпляре PLM, а также передачу сгенерированных номеров деталей PLM обратно компонентам на стороне Workspace.
-
Design (проекты) – доступен специальный рабочий процесс Project Creations workflow, который также поддерживает автоматическое создание номеров деталей в вашем экземпляре PLM и последующую передачу этих параметров обратно в проект разработки. Такие параметры могут использоваться в специальных строках (например, для аннотаций рамки листа). У вас есть возможность публиковать проект в экземпляр PLM в рамках запуска Project Releaser в Altium Designer. Операция публикации использует publishing template — определенный как часть конфигурации интеграции экземпляра PLM — для управления тем, как данные должны передаваться в PLM. И если вы публикуете проект впервые и номера деталей (на стороне PLM) еще не связаны с проектом, эти номера деталей будут созданы в PLM и связаны с проектом в рамках этой начальной публикации. У вас также есть возможность определять записи компонентов для компонентов в экземпляре PLM в рамках операции публикации (необязательно, в зависимости от конфигурации). И вы всегда сможете точно увидеть, что было создано, например номера деталей в экземпляре PLM, в составе history рабочего процесса (History вкладка).
Поддержка PLM
Workspace в Altium 365 поддерживает следующие PLM-системы:
-
PTC Windchill® PLM версии 12, 13 и PTC Windchill+ (вариант SaaS для Windchill).
-
Arena® PLM.
-
Oracle® Agile™ PLM.
-
Aras Innovator® Release 30.
Additional Setup for Aras Innovator
Чтобы обеспечить интеграцию PLM с Aras Innovator, серверу вашего Altium Workspace необходимо быть зарегистрированным в настройке Aras Authentication setup путем добавления нового раздела узла в его реестр клиентов. После регистрации для подключенного Workspace предоставляется уникальный токен OAuth для аутентификации доступа.
Необходимые изменения в конфигурации Aras Innovator вносятся путем редактирования файла реестра клиентов OAuth:
-
На хост-машине Aras откройте файл
\OAuthServer\OAuth.configдля редактирования. -
Найдите и скопируйте раздел IOMApp — от строки
<clientRegistry id="IOMApp" enabled="true">до строки</clientRegistry>. -
Вставьте скопированный раздел IOMApp сразу после него, чтобы создать новый (дублированный) раздел.
-
В этом новом разделе узла переименуйте
IOMAppвNEXUS— в результате получится<clientRegistry id="NEXUS" enabled="true">.
-
Сохраните изменения, а затем перезапустите машину Aras.
- Siemens Teamcenter®, с дополнительной настройкой интеграции.
- Duro PLM, реализованный как сторонний экземпляр PLM — см. раздел Third Party PLM Support ниже.
Выбор интерфейса настройки PLM
Подключение Workspace в Altium 365 к поддерживаемой PLM-системе может быть выполнено через расширенный полуавтоматизированный пользовательский интерфейс, как описано ниже, либо с помощью ручного процесса на основе редактирования XML-файлов конфигурации PLM. Последний вариант требует знания структур данных целевой PLM-системы и знакомства с форматом XML, тогда как обновленная система, представленная ниже, автоматически получает необходимые данные из PLM и Altium Workspace для заполнения пунктов меню в интерфейсе.
Вы можете перенастроить Workspace так, чтобы отображался предыдущий интерфейс PLM, основанный на ручном редактировании XML-файлов, сняв флажок Enable new PLM Configuration page в Admin – Settings – PLM Integration page интерфейса Workspace. Обязательно сохраните изменение, затем выйдите из системы и войдите снова.
Подключение к вашему экземпляру PLM
Конфигурации PLM создаются и управляются на странице Admin – PLM Integration интерфейса Workspace в браузере. После успешного подключения к PLM-системе интерфейс конфигурации предоставит ряд параметров интеграции на основе данных, полученных как из Workspace, так и из подключенной PLM.
Используйте кнопку
, чтобы начать процесс подключения, и действуйте в соответствии с приведенным ниже слайд-шоу.
Любые ошибки подключения будут выделены красным цветом при входе в целевую PLM-систему. В нижней границе блока выделения будут указаны сведения об ошибке — пример просмотра.
PTC Windchill SSO Support
Доступна возможность использовать авторизацию Single Sign On (SSO) при подключении к системе Windchill PLM; она настраивается через интерфейс Workspace. Это обеспечивает упрощенный и безопасный метод авторизации подключения при выполнении процессов Workspace PLM, таких как создание проекта и публикация в PLM. На практике это позволяет предоставлять доступ к Windchill с использованием стандарта делегирования OAuth через сервис поставщика удостоверений, такой как PingFederate.
Доступ к настройке SSO осуществляется на вкладке OAuth страницы PLM Integration в Workspace (Admin - PLM Integration), где можно добавить несколько экземпляров поставщика OAuth.
Настройка авторизации поставщика OAuth выполняется на основе данных, доступных у настроенного поставщика удостоверений. Введите имя и требуемую Workspace информацию — идентификаторы, токены, URL и т. д. — в поля страницы, затем сохраните завершенную конфигурацию.
Новый экземпляр OAuth Provider становится доступным, когда в конфигурации Windchill PLM включен параметр OAuth Connection. Если доступно несколько поставщиков, выберите нужный из раскрывающегося списка OAuth Provider. Завершите настройку подключения кнопкой
и при необходимости следуйте подсказкам поставщика.
Поддержка сторонних PLM
Workspace в Altium 365 также обеспечивает дополнительную поддержку конфигураций «ненативных» PLM-систем, разработанных сторонними поставщиками. Эта поддержка обеспечивается с помощью Generic Connector Altium, для которого требуется лицензия Altium 365 PLM Generic Connector Addon.
При добавлении экземпляра Workspace PLM для такой системы предварительно настроенные XML-файлы, предоставленные сторонним поставщиком, загружаются в конфигурацию этого экземпляра PLM через интерфейс PLM Integration interface.
Настройка конфигурации
После успешного подключения к экземпляру PLM интерфейс Workspace PLM предлагает параметры конфигурации для определения того, как выполняется синхронизация компонентов, сопоставление параметров компонентов и подход к передаче данных Part Choices. Эти параметры синхронизации доступны на вкладке Configuration интерфейса.
Доступные вам параметры конфигурации (и их метки/функциональность) определяются типом PLM-системы и параметрическими данными, полученными как из Workspace, так и из подключенного экземпляра PLM.
Параметры синхронизации
Этот раздел интерфейса PLM определяет, какие типы компонентов будут синхронизироваться, где и как должны создаваться/обновляться новые компоненты, а также любые ограничения на основе критериев параметров.
Способ синхронизации компонентов задается индивидуально:
- Выберите Altium Component Type в списке параметров и задайте для него параметр Sync Direction по мере необходимости (в Altium/PLM или в обе стороны) — варианты типов компонентов берутся из текущих данных компонентов Workspace.
- Выберите связанное имя атрибута PLM в меню PLM Type — доступные варианты берутся из подключенного экземпляра PLM.
- В поле Altium Target Folder (в разделе Sync to Altium) найдите и выберите папку компонентов Workspace как место синхронизации для этого компонента.
- Укажите Sync Mode, чтобы определить, будут ли новые компоненты создаваться во время синхронизации, или будут обновляться только существующие компоненты, либо и то и другое.
-
Задайте Component Template, который будет использоваться для определения типов параметров компонентов при синхронизации этого компонента. Этот параметр по умолчанию будет соответствовать выбранному Altium Component Type (например;
Capacitors), если доступен связанный шаблон Workspace. - Используйте параметр Add Parameter Criteria, чтобы указать значение параметра, которым будет ограничена синхронизация. Компонент не будет синхронизирован, если не соответствует этому критерию. При необходимости добавьте дополнительные критерии параметров.
При подключении к PTC Windchill PLM доступны дополнительные параметры, поддерживающие систему PartsLInk в Windchill. Система PartsLink позволяет классифицировать детали по группам для более удобного и быстрого выбора, а также может включать связанные пары атрибут/значение для более точного определения внутри этой классификации. Дополнительную информацию см. в раскрывающемся разделе ниже.
-
Выберите Add Classification Name Criteria в меню Filter Criteria, чтобы добавить фильтр классификации. С помощью меню имени выберите группу классификации, по которой будет фильтроваться синхронизация.
-
Для более точного управления выберите параметр Add Classification Attribute Criteria и задайте Attribute классификации и связанное с ним значение. В приведенном здесь примере будут синхронизироваться только конденсаторы из класса
102-Capacitorsсо значениемCapacitance, равным10uF.
More on Windchill PartsLink
В самом Windchill классификация PartsLink определяется созданием binding attribute, который можно применить к типу детали. Затем к определенному классу классификации добавляется атрибут классификации детали.
Записи компонентов в Windchill будут включать определенную для них классификацию и любые заданные параметры атрибутов классификации, которые, в свою очередь, доступны процессу синхронизации компонентов Workspace PLM.
Когда запись компонента синхронизируется из Windchill в Workspace и в конфигурации PLM Workspace указано взаимодействие с PartsLink, атрибуты конфигурации Windchill для этой детали будут переданы в Altium Designer.
Когда Sync Direction задан как To PLM или для двунаправленной синхронизации (To PLM & To Altium), в разделе Sync To PLM появляется параметр Add Filter Criteria. Используйте его для задания критериев параметров или папок, которые будут определять, какие компоненты Workspace будут передаваться в PLM-систему.
Можно добавить несколько критериев параметров, чтобы жестко ограничить синхронизацию компонентов Workspace с PLM. Доступные критерии также включают варианты выражений OR и NOT для более точного управления фильтрацией компонентов, допущенных к синхронизации с PLM.
Раздел Sync to PLM предоставляет дополнительные параметры нумерации деталей и префиксов/суффиксов при работе с системой Arena PLM. Эти предопределенные схемы PLM доступны для выбора в меню Numbering Scheme и Code и будут определять формат Item Number для деталей, загружаемых в Arena.
Сопоставление параметров компонентов
Продолжайте тот же процесс, что и выше, чтобы задать конфигурацию параметров синхронизации для всех компонентов, которые вы хотите синхронизировать с PLM. Поскольку параметры компонентов на стороне Workspace не обязательно совпадают с параметрами на стороне PLM, для сопоставления параметров между двумя сторонами можно использовать раздел интерфейса Component Parameter Mapping. Обратите внимание, что при сопоставлении параметров их значения будут синхронизироваться из одной системы в другую так, как если бы это был один и тот же параметр.
Используйте команду Add Parameter этого раздела, чтобы создать запись для сопоставления параметра Workspace/PLM, которая применяется к текущему выбранному Altium Component Type (выбранному в разделе Sync Parameters). Параметры Parameter Name PLM и Altium — это варианты, доступные в соответствующих системах. Настройка Revision в столбце Item/Revision приводит к созданию новой ревизии компонента при изменении параметра, тогда как при настройке Item во время синхронизации будет обновляться только параметр компонента.
Используйте связанный значок
, чтобы удалить запись сопоставления.
Таким образом можно сопоставить любое количество параметров, однако, вероятно, будет существовать ряд общих параметров Workspace/PLM, которые требуется сопоставить для всех компонентов. Этот подход глобального сопоставления доступен, когда All Types выбран в качестве Altium Component Type.
Создайте записи сопоставления (Add Parameter), которые будут применяться ко всем компонентам, включая известные совпадения общих параметров. И задайте параметры Item/Revision и Sync Direction по мере необходимости. Также важно указать одну запись сопоставленного параметра как Primary Key — это общая пара параметров, которая служит опорным индексом между двумя наборами параметрических данных. Если это номер детали PLM (рекомендуется), номер, созданный на стороне PLM, будет передан обратно на сторону Altium, создавая известную ссылку между наборами синхронизированных данных компонентов.
Атрибуты классификации PLM
Для подключенных PLM-систем, которые поддерживают группировку компонентов как Classifications (например, PTC Windchill), связанные атрибуты и значения PLM можно сопоставить параметрам компонентов Workspace в этом разделе.
Например, для PTC Windchill, чтобы извлечь значение определенного атрибута классификации (скажем, значение емкости для конденсаторов в классе 102-Capacitor), добавьте эту классификацию и ее значение (Capacitance) как PLM Parameter Name, а целевой параметр компонента Altium (Value) как Altium Parameter Name. Определения можно добавлять для всех типов компонентов, включая несколько определений для одного и того же типа компонента.
► См. приведенную выше информацию о PartsLink для получения дополнительных сведений о классификациях Windchill.
Part Choices
Используйте раскрывающееся меню Sync Direction, чтобы указать, в каком направлении данные производителя Part Choices будут синхронизироваться между Workspace и PLM-системой, либо отключите синхронизацию Part Choices с помощью параметра OFF.
В зависимости от типа подключенной PLM параметр Part Choice information будет предлагать синхронизацию в формате, совместимом с собственными утвержденными производственными деталями PLM (Native PLM Manufacturer Parts) или как обычные данные параметров компонентов (PLM Part Attributes). Во втором случае это может быть несколько наборов атрибутов параметров Manufacturer:PartNumber — MFR1:MPN1, MFR2:MPN2, например.
Примеры «нативных» (или встроенных) деталей производителя в PLM включают Vendor Parts в Arena и Manufacturer Parts в Windchill.
XML конфигурации проекта
Этот раздел содержит список базовой XML-конфигурации, определяющей исходную конфигурацию PLM для подключенной PLM-системы. Загружаемая версия этого базового XML настройки (Download Sample Configuration) содержит подробные комментарии, поясняющие функции большинства разделов Entity и Attribute.
В конечном итоге определенная вами в интерфейсе PLM Integration конфигурация хранится в виде системных XML-файлов, которые можно сохранить локально с помощью команды Export Configuration, связанной с данными Server Connection в верхней части страницы конфигурации.
Также предусмотрен параметр Import Configuration. Он позволяет применить существующий XML-файл конфигурации к новой (или отредактированной) конфигурации PLM, что приведет к дублированию этой настройки PLM. Кроме того, если в существующую конфигурацию PLM необходимо внести специализированные изменения, ее экспортированный XML-файл можно отредактировать вручную, а затем импортировать обратно в конфигурацию. Обратите внимание, что параметры, атрибуты и значения, включенные в файл конфигурации, чувствительны к регистру.
Добавление шаблона публикации
Конфигурация PLM требует добавления XML-основанного Publishing Template, чтобы поддерживать процессы Workspace, которые отправляют полные данные проекта — файлы проекта, данные компонентов и выходные производственные данные — в систему PLM одним действием «публикации». Эти процессы включают Publish to PLM, где пользователь указывает выходные данные для отправки, и Project Releaser with Publish, который отправляет сгенерированные данные в PLM как заключительный шаг в Project Release process Altium Designer.
При создании или редактировании конфигурации PLM добавьте подходящий XML-файл Publishing Template на вкладке Publish Template. Используйте ссылку Sample Project Configurations, чтобы скачать архивную коллекцию шаблонов для поддерживаемых систем PLM.
Publishing Template содержит ссылки на сведения о проекте, передачу данных компонентов, расположения источников данных и распределение файлов данных Design, Assembly и Fabrication. Загруженные примеры включают шаблоны для всех поддерживаемых PLM, и каждый из них содержит все дополнительные Publishing Rules, применимые к конкретному типу PLM, а также подробные комментарии, которые помогут вам понять, что и как нужно настраивать.
Publishing Folder Support for Windchill PLM
При настройке экземпляра интеграции Windchill® PLM Integration, который будет использоваться для процессов Publish to PLM, вы также можете указать (и создать) целевую папку Windchill для документов, публикуемых из Workspace.
Связанные параметры папки Windchill определяются в XML-файле Publishing Template, примененном к записи интеграции Windchill PLM в Workspace (см. выше). Узлы определения папки имеют формат тега <pt:Folder>xxx</pt:Folder> — где pt является текущим пространством имен, а xxx — полным путем к папке — и размещаются как правило публикации в разделе FileDistribution для каждого типа документа (например, для выходных данных PCB.zip Fabrication).
Пример иерархии структуры Publishing XML:
<pt:EntityRule id="FAB">
<pt:FileDistributions>
<pt:FileDistribution archiveName="PCB.zip">
<pt:Folder>PRODUCT/Projects/${project.name}/FAB data</pt:Folder>
Последняя строка записи будет указывать (или создавать) целевую папку публикации для выходных данных PCB.zip Fabrication со структурой папок Windchill (где имя проекта — MyProject):
PRODUCT
Projects
MyProject
FAB data
Обратите внимание, что путь к папке, заданный в файле Publishing XML, является абсолютным (а не относительным) и может включать другие свойства проекта, такие как имя проекта (${project.name}) и номер сборки (${project.PLM_ASSEMBLY_NUMBER}).
Publish to PLM with ECO
Файлы настройки для экземпляров Windchill, Agile и Arena PLM также поддерживают формализованный рабочий процесс Change Order (ECO), который включается в XML-файле Publishing Template и определяется в файле Configuration XML в разделе сущности altiumType="ProjectChangeOrder".
В зависимости от экземпляра PLM, XML-определения конфигурации включают схему для идентификации Change Order (нумерация, расположение, ID и т. д.), конкретные атрибуты Change Order, такие как Name/Title, Description и Change Complexity (только для Windchill), а также параметры, такие как стратегия создания Change Order (none, new или reuse existing) и повышение статуса Lifecycle (только для Windchill и Agile). Определенный Change Order включается во время публикации объявлением его ссылки publishId в связанном Publishing Template.
Шаблон публикации также поддерживает наборы правил, определяющих, как и куда выходные данные релиза (данные проекта, исходные данные, данные сборки и производства) публикуются в PLM.
После определения в файлах Configuration XML и Publishing Template XML сервера Change Orders становятся доступны в рабочих процессах Project Creation и Publishing to PLM, запускаемых из Altium Designer или через интерфейс Workspace PLM interface. Во время этого процесса будет показана соответствующая форма Change Order, в которой задаются параметры Change Order.
Диалоговое окно Altium Designer Change Order Required, показывающее начальный шаг создания проекта и последующий Project Release с включенным ECO.
В показанном здесь примере проект создается в Altium Designer из шаблона с использованием процесса Create Project with PLM Initialize (в Arena PLM), при этом параметр Create change order (ECO) отключен. Затем проект выпускается с использованием процесса Publish to PLM (User selects) с включенным параметром Create change order (Yes). На стороне Arena элементы затем публикуются в рамках Change Order (ECO-00042) и связанного с ним процесса утверждения.
Скачайте ZIP-архив, содержащий файлы Arena Configuration XML и Publishing Template XML, использованные в этом примере.
При необходимости измените пример шаблона XLM и загрузите файл в конфигурацию PLM через окно Add Publish Template, открываемое кнопкой
. Обратите внимание, что конфигурация PLM поддерживает несколько Publish Templates.
Синхронизация компонентов
Синхронизация данных компонентов между вашим Workspace Altium 365 и подключенной системой PLM определяется включенным сопоставлением параметров и направлением, описанными выше, и происходит при ручном или автоматическом запуске процесса по расписанию. Сам процесс синхронизации управляется встроенным рабочим процессом LibSync.
В экземпляре конфигурации PLM соответствующие параметры синхронизации доступны на вкладке Component Synchronization, где процесс можно запустить вручную или настроить по расписанию. Для последнего варианта включите параметр Synchronize on a schedule и выберите интервал времени в соответствующем раскрывающемся меню.
Вы можете использовать параметры меню
для ручного запуска процесса LibSync как события синхронизации Incremental или Full:
-
Incremental — применяются только те компоненты, которые были изменены с момента последнего запуска синхронизации (то есть их метка времени позже даты последней синхронизации) и соответствуют критериям синхронизации в конфигурации. Обратите внимание, что именно этот режим используется, когда событие синхронизации запускается элементом управления
на главной странице PLM Integration — см. ниже.
- Full — этот режим принудительно выполняет полную синхронизацию. Будут включены все компоненты, соответствующие критериям синхронизации в конфигурации.
Выполнение синхронизации компонентов
Синхронизация компонентов (библиотеки) может выполняться вручную из записи экземпляра PLM на странице Workspace PLM Integration или автоматически по циклу, заданному в настройках экземпляра — см. выше. Нажмите элемент управления
, связанный с экземпляром PLM, чтобы вручную запустить процесс синхронизации, который будет выполняться через рабочий процесс LibSync с использованием настроек, заданных в связанной конфигурации PLM.
Элемент управления Actions изменится на
, что позволит при необходимости остановить процесс синхронизации, а запись Sync Status будет указывать, что процесс выполняется. После завершения процесса синхронизации статус изменится на Completed.
Когда выполняется синхронизация компонентов — вручную или как событие по времени — процесс LibSync проходит через свой предопределенный Workflow, пока не завершится или не встретит ошибку. Вы можете обновить браузер (F5), чтобы увидеть текущее состояние процесса синхронизации.
Чтобы получить сведения о завершенном событии синхронизации, нажмите значок
в столбце Last Sync, чтобы скачать соответствующий файл журнала (view example), или выберите связанную дату, чтобы открыть запись события на вкладке Synchronization Status. Обратите внимание, что в этом представлении завершенные события синхронизации отображаются при выборе параметра Closed, а все выполняющиеся или приостановленные события — при выборе режима просмотра Active.
Подвкладки представления Status предоставляют следующую информацию:
- Diagram — графическое представление рабочего процесса с подсвеченным текущим шагом (Completed или состояние ошибки/сбоя).
- Data — сводная информация о действии процесса, включая успех или неудачу его шагов и ссылку на зарегистрированный отчет процесса — view example.
- History — журнал времени основных событий синхронизации Workspace, перечисленных по порядку.
Все события синхронизации, которые были преждевременно остановлены, например при возникновении ошибки, будут перечислены в режиме просмотра Active. Эти записи можно удалить из списка с помощью элемента управления Terminate , либо, что более правильно, оценить и устранить через соответствующую плитку Task, созданную в представлении Tasks view Workspace. Обратите внимание, что завершенное/устраненное событие синхронизации будет перемещено в список Closed представления Synchronization Status с соответствующим индикатором Status, например Failed.
Доступ к процессам, связанным с PLM
Образцы Process workflows, относящихся к подключенной системе PLM, доступны на вкладках тем процессов на Workspace Processes page. В общем случае образцы нельзя использовать напрямую — чтобы они стали активными, их необходимо пересохранить под другим именем.
► Дополнительные сведения см. в документации Processes & Workflow.
Администратор Workspace может запустить новый экземпляр любого активированного определения процесса непосредственно из списка процессов на странице Processes, нажав элемент управления
. Пользователи Workspace без прав администратора также могут запускать активные Processes из Workspace, например:
-
Процесс Part Request with PLM с кнопки
на странице Part Request page.
-
Процесс Publish to PLM с кнопки
на страницах Tasks и Activities открытого проекта.
-
Процесс Publish to PLM с кнопки
на главной странице Projects page.
-
Процесс Project with Initialize in PLM с кнопки
на главной странице Projects page или при Cloning a project из меню кнопки
.
Однако на практике процессы, связанные с PLM, обычно запускаются из Altium Designer в ходе проектирования и разработки проекта. Доступ к процессам, связанным с PLM, из Altium Designer осуществляется следующими способами:
-
Part Request with PLM Part Create — доступ из панелей Altium Designer Explorer, Manufacturer Part Search и Components.
► Подробные сведения см. в Process-based Part Requests. -
Publish to PLM (User selects) — доступ из подменю Project » Project Activities для активного проекта Altium Designer.
► Подробные сведения см. в Publishing to a PLM – user-selects. -
Project Releaser with Publish — доступ как заключительный этап Project Releaser из подменю Project » Project Releaser для активного проекта Altium Designer.
► Подробные сведения см. в Design Project Release – publishing to PLM. -
Project with initialise in PLM — доступ при создании нового проекта Altium Designer из подменю File » New » Project in <Workspace> или при клонировании проекта.
► Подробные сведения см. в Publishing to a PLM – initialize in PLM.
Рабочие процессы
Следующие определения процессов (и лежащие в их основе рабочие процессы) доступны через Workspace для поддержки интеграции с PLM:
-
Part Requestsтема процессов:
- Part Request with PLM Part Create — поддерживает автоматическое создание Component в вашем экземпляре PLM, а затем передачу сгенерированного номера детали обратно в компонент Workspace. Схема рабочего процесса показана ниже.
Важно отметить следующее: когда вы изменяете это примерное определение для создания собственного, необходимо указать экземпляр PLM, в котором должны создаваться детали. Выберите сущность Create Part in PLM на схеме рабочего процесса и выберите экземпляр PLM из раскрывающегося меню, связанного с полем PLM Instance. Это меню перечисляет все определенные в данный момент экземпляры PLM (как задано на странице PLM Integration интерфейса).
► Дополнительные сведения о работе с рабочими процессами см. в Creating and Managing Processes.
- Project Activitiesтема процессов:
- Publish to PLM (User selects) — публикация выходных данных выпущенного управляемого проекта в интегрированный экземпляр PLM, при которой пользователь может точно выбрать, какие именно выходные данные будут опубликованы. Схема рабочего процесса показана ниже.
- Project Releaser with Publish — публикация в интегрированный экземпляр PLM как дополнительный этап Project Releaser. Схема рабочего процесса показана ниже.
-
Project Creationsтема процессов:
- Project with initialise in PLM — поддерживает автоматическое создание номеров деталей в вашем экземпляре PLM, а затем передачу этих номеров как Parameters проекта Workspace design. Схема рабочего процесса показана ниже.
























. 












