CustomizeResources

Последнее изменение: Tania Mashkoory; 11.06.2019

Parent page: Client Commands

The following pre-packaged resources, derived from this base command, are available:

Applied Parameters: Action=Toggle | ObjectKind=Panel | ID=List

Summary

This command is used to quickly toggle the display of the SCH List panel.

Access

This command is accessed from the Schematic Editor by using the Shift+F12 keyboard shortcut.

Use

After launching the command, the SCH List panel will either disappear or reappear, depending on whether it is currently visible or not.

Tips

  1. If the panel is part of a group of panels, using this command will make it the active panel in the group - bringing it to the front in docked or floating modes, and popping it out in pop-out mode.
  2. Using this command will toggle the display of the panel in the position and mode in which it was last placed.
  3. A currently visible panel will have a 'tick' icon next to its menu entry.
  4. The panel can also be toggled, with respect to its visibility, using the View » Panels » SCH List command, or by clicking the Panels button (available on the right of the Status Bar) and choosing the SCH List menu entry.

Applied Parameters: Action=Toggle | ObjectKind=Panel | ID=LibList

Summary

This command is used to quickly toggle the display of the SCHLIB List panel.

Access

This command is accessed from the Schematic Library Editor by using the Shift+F12 keyboard shortcut.

Use

After launching the command, the SCHLIB List panel will either disappear or reappear, depending on whether it is currently visible or not.

Tips

  1. If the panel is part of a group of panels, using this command will make it the active panel in the group - bringing it to the front in docked or floating modes, and popping it out in pop-out mode.
  2. Using this command will toggle the display of the panel in the position and mode in which it was last placed.
  3. A currently visible panel will have a 'tick' icon next to its menu entry.
  4. The panel can also be toggled, with respect to its visibility, using the View » Panels » SCHLIB List command, or by clicking the Panels button (available on the right of the Status Bar) and choosing the SCHLIB List menu entry.

Applied Parameters: Action=Toggle | ObjectKind=Panel | ID=Filter

Summary

This command is used to quickly toggle the display of the SCH Filter panel.

Access

This command is accessed from the Schematic Editor by using the F12 keyboard shortcut.

Use

After launching the command, the SCH Filter panel will either disappear or reappear, depending on whether it is currently visible or not.

Tips

  1. If the panel is part of a group of panels, using this command will make it the active panel in the group - bringing it to the front in docked or floating modes, and popping it out in pop-out mode.
  2. Using this command will toggle the display of the panel in the position and mode in which it was last placed.
  3. A currently visible panel will have a 'tick' icon next to its menu entry.
  4. The panel can also be toggled, with respect to its visibility, using the View » Panels » SCH Filter command, or by clicking the Panels button (available on the right of the Status Bar) and choosing the SCH Filter menu entry.

Applied Parameters: Action=Toggle | ObjectKind=Panel | ID=LibFilter

Summary

This command is used to quickly toggle the display of the SCHLIB Filter panel.

Access

This command is accessed from the Schematic Library Editor by using the F12 keyboard shortcut.

Use

After launching the command, the SCHLIB Filter panel will either disappear or reappear, depending on whether it is currently visible or not.

Tips

  1. If the panel is part of a group of panels, using this command will make it the active panel in the group - bringing it to the front in docked or floating modes, and popping it out in pop-out mode.
  2. Using this command will toggle the display of the panel in the position and mode in which it was last placed.
  3. A currently visible panel will have a 'tick' icon next to its menu entry.
  4. The panel can also be toggled, with respect to its visibility, using the View » Panels » SCHLIB Filter command, or by clicking the Panels button (available on the right of the Status Bar) and choosing the SCHLIB Filter menu entry.

Applied Parameters: Action=Toggle | ObjectKind=Panel | ID=PCBExpressionFilter

Summary

This command is used to quickly toggle the display of the PCB List panel (when the active document is a PCB), or PCBLIB List panel (when the active document is a PCB Library).

Access

This command is accessed from the PCB Editor, and PCB Library Editor, by using the Shift+F12 keyboard shortcut.

Use

After launching the command, the PCB List panel (or PCBLIB List panel) will either disappear or reappear, depending on whether it is currently visible or not.

Tips

  1. If the panel is part of a group of panels, using this command will make it the active panel in the group - bringing it to the front in docked or floating modes, and popping it out in pop-out mode.
  2. Using this command will toggle the display of the panel in the position and mode in which it was last placed.
  3. A currently visible panel will have a 'tick' icon next to its menu entry.
  4. The panel can also be toggled, with respect to its visibility, by:
    1. PCB Editor - using the View » Panels » PCB List command, or by clicking the Panels button (available on the right of the Status Bar) and choosing the PCB List menu entry.
    2. PCB Library Editor - using the View » Panels » PCBLIB List command, or by clicking the Panels button (available on the right of the Status Bar) and choosing the PCBLIB List menu entry.

Applied Parameters: Action=Toggle | ObjectKind=Panel | ID=PCBFilter

Summary

This command is used to quickly toggle the display of the PCB Filter panel.

Access

This command is accessed from the PCB Editor by using the F12 keyboard shortcut.

Use

After launching the command, the PCB Filter panel will either disappear or reappear, depending on whether it is currently visible or not.

Tips

  1. If the panel is part of a group of panels, using this command will make it the active panel in the group - bringing it to the front in docked or floating modes, and popping it out in pop-out mode.
  2. Using this command will toggle the display of the panel in the position and mode in which it was last placed.
  3. A currently visible panel will have a 'tick' icon next to its menu entry.
  4. The panel can also be toggled, with respect to its visibility, using the View » Panels » PCB Filter command, or by clicking the Panels button (available on the right of the Status Bar) and choosing the PCB Filter menu entry.

Applied Parameters: Action=Toggle | ObjectKind=Panel | ID=PCBLibFilter

Summary

This command is used to quickly toggle the display of the PCBLIB Filter panel.

Access

This command is accessed from the PCB Library Editor by using the F12 keyboard shortcut.

Use

After launching the command, the PCBLIB Filter panel will either disappear or reappear, depending on whether it is currently visible or not.

Tips

  1. If the panel is part of a group of panels, using this command will make it the active panel in the group - bringing it to the front in docked or floating modes, and popping it out in pop-out mode.
  2. Using this command will toggle the display of the panel in the position and mode in which it was last placed.
  3. A currently visible panel will have a 'tick' icon next to its menu entry.
  4. The panel can also be toggled, with respect to its visibility, using the View » Panels » PCBLIB Filter command, or by clicking the Panels button (available on the right of the Status Bar) and choosing the PCBLIB Filter menu entry.

Applied Parameters: Action=Toggle | ObjectKind=Panel | ID=SDInteractivePropertiesPanelView

Summary

This command is used to quickly toggle the display of the Properties panel, while working with a Multi-board Schematic document (*.MbsDoc).

Access

This command is accessed from the Multi-board Schematic Editor by using the F11 keyboard shortcut.

Use

After launching the command, the Properties panel will either disappear or reappear, depending on whether it is currently visible or not.

Tips

  1. If the panel is part of a group of panels, using this command will make it the active panel in the group - bringing it to the front in docked or floating modes, and popping it out in pop-out mode.
  2. Using this command will toggle the display of the panel in the position and mode in which it was last placed.
  3. A currently visible panel will have a 'tick' icon next to its menu entry.
  4. The panel can also be toggled, with respect to its visibility, using the View » Panels » Properties command, or by clicking the Panels button button (available on the right of the Status Bar) and choosing the Properties menu entry.

Applied Parameters: None

Summary

This command is used to run the Customizing Editor dialog, for the Editor associated with the active document. From here, you can edit the resources available for the editor, or add your own customized new ones.

Resources in an editor are the menu bars, toolbars and shortcut key tables. All the commands available from the menus are also available for adding to, or deleting from, these resources.

Access

This command can be accessed from any editor, by:

  • Choosing the View » Toolbars » Customize command from the main menus.
  • Double-clicking in free space of the main menu/toolbar area.
  • Right-clicking in the main menu/toolbar area, and choosing the Customize command from the context menu.
The command can also be accessed from certain editors (e.g. schematic, schematic library, PCB, PCB Library, Output Job) by pressing B to access the Toolbar pop-up, and choosing the Customize entry.

Use

After launching the command, the Customizing Editor dialog will appear. The dialog lists all default commands that are available for that editor (from menus, toolbars, shortcuts) and all bars that are currently defined.

Use the dialog to edit existing default commands, or create customized new ones. Also define which bar is to be used as the main menu bar, which is to be used as the shortcut table, and which of the toolbars - default and customized - are to be made active by default when opening any document associated to that editor.

Tips

  1. You cannot delete any of the default commands or bars that have been defined for an Editor.
  2. Behind each resource item, such as a toolbar icon or menu item, there is a pre-packaged process launcher that activates a command when its resource item is selected. The pre-packaged process launchers bundle together the process that runs when the command is selected, plus any parameters, bitmaps (icons), captions (the name of an item that displays on a resource), descriptions and associated shortcut keys. If a process launcher is modified, every linked instance of the command on any bar will be updated.
  3. When the Customizing dialog is open, you can click and drag commands around between the active menus and toolbars.
  4. Customizations are stored in the file \Users\<ProfileName>\AppData\Roaming\Altium\Altium NEXUS <GUID>\DXP.rcs (for a default installation of the software).

Applied Parameters: Action=Show   | ObjectKind=Window | Index=n (where n is in the range 1 to 9)

Summary

This command is used to make the indicated, open document, the active document in the main design window.

Access

The related indexed commands are accessed from most editors, from the bottom of the main Window menu. Up to a maximum of nine documents can be accessed in this manner.

Use

After launching the command, the indicated document will become the active document in the main design window.

Tips

  1. The list of documents on the Windows menu reflects only documents that are currently open. The documents are listed in the order that they were opened.
  2. A far more convenient method by which to make a document active, is to simply click on its tab, at the top of the main design window.


Applied Parameters: Action=Show | ObjectKind=Panel | ID=Altium.Edp.ComponentSearch.Plugin

Summary

This command is used to provide quick access to the Components panel from where you can browse and place a PCB 2D/3D component model from any of those available onto the current document. A PCB 2D/3D component model is the representation of a physical device on a PCB. It includes a 2D footprint (with such items as pads for connecting to the pins of a device, a physical outline of the package, and device mounting features) and any 3D information (through the association of one or more 3D Bodies). The Components panel offers advanced search functions and the ability to drag and drop a component from the panel directly onto the active PCB document.

For detailed information about this object type, see Component.

Access

This command can be accessed from the PCB Editor by:

  • Choosing the Place » Component command from the main menus.
  • Right-clicking in the workspace then choosing the Place » Component command from the context menu.

Use

After launching the command, the Components panel will open.

Tips

  1. If the panel is part of a group of panels, using this command will make it the active panel in the group - bringing it to the front in docked or floating modes and popping it out in pop-out mode.
  2. The panel can also be toggled, with respect to its visibility, using the View » Panels » Components command or by clicking the Panels button (available at the bottom right of the main editor) then choosing the Components menu entry.


Applied Parameters: Action=Show| ObjectKind=Panel| ID=Altium.Edp.ComponentSearch.Plugin| ShowState=False

Summary

This command is used to provide quick access to the Components panel from where you can browse and place a PCB 2D/3D Component model from any of the Available File-based Libraries onto the current document. A PCB 2D/3D Component model is the representation of a physical device on a PCB. It includes a 2D footprint (with such items as pads for connecting to the pins of a device, a physical outline of the package, and device mounting features) and any 3D information (through the association of one or more 3D Bodies). The Components panel offers advanced search functions and the ability to drag and drop a component from the panel directly onto the active PCB document.

For detailed information about this object type, see Component.

Access

This command can be accessed from the PCB Editor by:

  • Locating and using the Component (Component button) button on the Active Bar.
Click and hold on the active button to access a menu of all associated commands for that grouping. If the command has been recently used from the Active Bar, it will become the active/visible button. When other commands are available it is indicated by a triangle at the bottom-right corner of the button.

Use

After launching the command, the Components panel will open. 

Tips

  1. If the panel is part of a group of panels, using this command will make it the active panel in the group - bringing it to the front in docked or floating modes and popping it out in pop-out mode.
  2. The panel can also be toggled, with respect to its visibility, using the View » Panels » Components command or by clicking the Panels button (available at the bottom right of the main editor) then choosing the Components menu entry.

 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.