Дополнительные функциональные возможности и улучшения

This documentation page references Altium NEXUS/NEXUS Client (part of the deployed NEXUS solution), which has been discontinued. All your PCB design, data management and collaboration needs can now be delivered by Altium Designer and a connected Altium 365 Workspace. Check out the FAQs page for more information.

 

Улучшения управления данными

Улучшен приоритет результатов поиска в панели Components

Были улучшены приоритеты результатов поиска в панели Components в соответствии с введенным критерием поиска.

Новая функция объединения типов компонентов

Эта новая функция позволяет вам объединять выбранные типы компонентов в один определенный тип. Доступ к этой функции осуществляется на странице Data Management - Component Types диалогового окна Preferences путем выделения одного или множества типов компонентов, щелчком ПКМ и выбора команды Merge. Будет открыто диалоговое окно Merging, которое работает следующим образом:

  • Если был выделен один тип компонентов, используйте выпадающее меню Merge to для выбора нужного целевого типа компонентов (как показано на первом изображении ниже).
  • Если было выделено несколько типов компонентов (с помощью сочетания клавиш Shift+Ctrl), в том числе целевой тип, используйте выпадающее меню Merge to для выбора целевого типа из выделенных ранее (как показано на втором изображении ниже).
Как сказано в диалоговом окне, объединение нельзя отменить, поэтому будьте внимательны при нажатии кнопки Merge в этом диалоговом окне.

Когда выделен один тип компонентов, будет открыто диалоговое окно Merging со всеми доступными типами компонентов в выпадающем меню.Когда выделен один тип компонентов, будет открыто диалоговое окно Merging со всеми доступными типами компонентов в выпадающем меню.

Когда выделено множество типов компонентов, будет открыто диалоговое окно Merging с выделенными типами компонентов в выпадающем меню.Когда выделено множество типов компонентов, будет открыто диалоговое окно Merging с выделенными типами компонентов в выпадающем меню.

Новая функция сопоставления для типов компонентов

Была добавлена новая функция, которая позволяет вам управлять сопоставлением типов компонентов и шаблонов компонентов. Доступ к этой функции осуществляется на странице Data Management - Component Types диалогового окна Preferences по нажатию кнопки Templates. В открывшемся диалоговом окне Edit templates щелкните в поле Component Type типа, который вы хотите изменить, затем используйте выпадающее меню для назначения типа компонента соответствующему шаблону.

Добавлена поддержка клавиш со стрелками для списка категорий в панели Components

Добавлена возможность использования клавиш со стрелками для перемещения по категориям в области Category панели Components (показано на изображении ниже). Используйте стрелки вверх/вниз для перемещения по списку и стрелки влево/вправо для открытия и закрытия веток.

Добавлена возможность передачи настроек отображения столбцов из родительской категории в дочерние

Была добавлена новая команда, которая позволяет передавать настройки отображения столбцов из родительской категории во все дочерние категории. Доступ к этой команде осуществляется щелчком ПКМ по выбранной категории, у которой есть хотя бы одна дочерняя категория, и выбором команды Apply Column Visibility to Child Categories. При выборе команды, порядок и видимость столбцов в дочерних категориях станут такими же, как и в выбранной родительской категории.

Передача настроек панели Components

Добавлена возможность передачи настроек панели Components между установками с помощью файлов настроек DXP.

Добавлена возможность редактирования посадочного места при наличии корректного посадочного места в схемной библиотеке

Раздел Models панели Components теперь позволяет изменять посадочное место, если в схемной библиотеке есть корректное подключенное посадочное место.

Возможность добавлять отчет о составе изделия при отсутствии схемы

В раздел Report Outputs файла Outjob (*.OutJob) была добавлена возможность добавлять отчет о составе изделия при отсутствии документов схемы в проекте. В этом случае, источником данных о составе изделия является плата.

BOM report for Outjob when no schematic is present

Доступ к Altium Content Vault удален из панели Explorer

Была удалена возможность просматривать содержимое Altium Content Vault непосредственно через панель Explorer. На самом деле, содержимое Altium Content Vault используется при поиске компонентов производителей, что обозначается в панели Manufacturer Part Search иконкой . Для записей компонентов, обозначенных этой иконкой, заданы схемный символ и посадочное место, и, соответственно, такие компоненты можно разместить в проекте, загрузить или получить на сервер. Панель Manufacturer Part Search позволяет проводить комплексный поиск среди физических компонентов на основе категорий и параметрических фильтров. Панель использует источники данных производителей и поставщиков службы Altium Parts Provider для поиска наиболее подходящих и актуальных данных о компонентах. Выбранный в панели компонент можно загрузить как библиотеку или получить на сервер управляемых данных, либо можно добавить его параметры и даташиты к существующему в проекте компоненту.

Если доступ прежним способом всё ещё необходим, вы можете включить параметр Explorer.ShowContentVault в диалоговом окне Advanced Settings. Тем не менее, это не рекомендуется. Чтобы открыть диалоговое окно Advanced Settings, нажмите кнопку Advanced на странице System - General диалогового окна Preferences. Если в настройки в диалоговом окне Advanced Settings вносятся какие-либо изменения, ПО необходимо перезапустить, чтобы изменения вступили в силу.

Улучшения редактора схем

Восстановлено размещение эллиптических дуг на схемах

Объекты Elliptical Arc теперь снова можно размещать в документах схем.

Elliptical Arc Placement

Возможность навигации по объектам в интерактивном документе схемы Smart PDF

В документе схемы Smart PDF теперь можно щелкнуть мышью по объекту и перейти к дочерней странице, порту или входу в лист или соответствующему межлистовому соединителю. Эта новая возможность навигации включает в себя следующее:

  • Щелчок мышью по символу листа для перехода к дочернему листу схемы.
  • Щелчок мышью по входу в лист для перехода к порту на дочернем листе схемы.
  • Щелчок мышью по порту для перехода к соединенному порту или входу в лист.
  • Щелчок мышью по межлистовому соединителю для перехода к соответствующему межлистовому соединителю.

Если объект, по которому вы щелкнули мышью, соединен более чем с одним объектом (например, символ листа многоканальной схемы, несколько портов с одинаковыми именами и т.п.), вы перейдете к первому из этих объектов.

Добавлена настройка для исключения определенных параметров компонентов в Smart PDF Wizard

В мастер Smart PDF Wizard (File » Smart PDF) была добавлена настройка, которая позволяет исключить определенные параметры компонентов из формируемого документа PDF. Новая кнопка Exclusions находится на странице Additional PDF Settings мастера, как показано ниже.

Additional PDF Settings page of the Smart PDF Wizard

Нажмите кнопку Exclusions, чтобы открыть диалоговое окно Exclude Parameters. Здесь введите название параметра, который вы хотите исключить, затем нажмите кнопку Add. Введите дополнительные параметры, если необходимо, нажимая Add после ввода каждого из них.

Exclude Parameters dialog

Улучшения редактора плат

Добавлен параметр 'Tented' в правило SolderMaskExpansion

Когда этот параметр включен, у контактной площадки/переходного отверстия не будет вскрытия паяльной маски на верхней/нижней стороне платы.

Добавлена возможность применять команду на скрытие или отображение цепей для множества выделенных компонентов

Теперь возможно отображать и скрывать одинаковые цепи для множества выделенных компонентов. Доступ к этой функциональной возможности осуществляется путем выделения множества компонентов, щелчком ПКМ и выбором команды Component Actions » Show Nets/Hide Nets.

Добавлена возможность создавать 3D-модели из выделенных примитивов в документе PCBLIB

Возможность создать 3D-модель из выделенных примитивов была доступна ранее в документе платы, и в новой версии она теперь так же доступна в документе PCBLIB. Доступ к этой новой функциональной возможности осуществляется путем выбора команды Tools » Convert » Create 3D Body From selected primitives в документе PCBLIB.

Добавлена возможность размещать позиционные обозначения для сборочных чертежей

Строку .Designator теперь можно автоматически добавить всем компонентам с помощью команды Tools » Add Designators for Assembly Drawing. Строки добавляются в соответствии с текущими настройками по умолчанию для примитива Designator (страница PCB Editor - Defaults диалогового окна Preferences), и они размещаются в геометрическом центре компонента. Используйте эту команду в редакторе плат для ее применения ко всем компонентам на плате или в редакторе библиотек посадочных мест для применения ко всем посадочным местам в библиотеке. Строка .Designator размещается на верхнем слое пары механических слоев компонента, у которой задан тип Designator. Если подходящая пара слоев компонента отсутствует, она может быть добавлена автоматически.

Новая команда 'Delete Selected Unions'

В панель PCB в режиме Unions была добавлена команда Delete Selected Unions. Доступ к команде осуществляется путем выделения одного или множества объединений в панели PCB в режиме Unions, щелчком ПКМ и выбором Delete Selected Unions. При щелчке мышью по команде Delete Selected Unions выделенные объединения будут удалены из панели.

Добавлено измерение 3D-объектов в библиотеке посадочных мест

В режиме 3D Layout Mode редактора библиотек посадочных мест (View » 3D Layout Mode или клавиша 3) меню Reports теперь содержит в себе команду Measure 3D Objects, которая позволяет удостовериться, что 3D-модель компонента представляет корректную высоту, указанную в даташите.

Улучшения рабочего пространства

Новая программа улучшения качества программного обеспечения

Новая программа улучшения качества программного обеспечения (Altium Customer Experience Improvement Program, ранее известная как программа улучшения продукта Altium Product Improvement Program) позволяет вам принять участие в процессе сбора аналитической информации, который помогает нам улучшать наши продукты на основе понимания того, как эти продукты используются. В процессе новой установки появляется страница, показанная ниже, которая является последним шагом перед началом установки. Отметьте Yes, I want to participate, чтобы передавать в Altium информацию, относящуюся к использованию вами наших настольных и облачных продуктов. Отметьте Don't Participate, чтобы отказаться.

Настройка группирования панелей в мозаику

В диалоговое окно Advanced Settings (доступно со страницы System - General диалогового окна Preferences) был добавлен новый параметр – UI.DisableFractalMode. Когда этот параметр включен, становится невозможным дальнейшее группирование панелей в мозаику. Обратите внимание, что панели, которые уже были сгруппированы в мозаику на момент включения параметра, не будут разделены – вам понадобится самостоятельно вынести панели из существующих групп, разделив мозаику. После включения параметра и настройки расположения панелей желаемым образом панели больше не будут группироваться в мозаику (пока параметр UI.DisableFractalMode включен).

Добавлена возможность включать и отключать полосы прокрутки в редакторах PCB/PCBLIB и SCH/SCHLIB

В Advanced Settings был добавлен параметр, который позволяет включать/отключать полосы прокрутки в редакторах PCB/PCBLIB и SCH/SCHLIB. Когда параметр UI.UseScrollbarsInEditors включен, полосы прокрутки отображаются справа от рабочей области.

Восстановлен параметр 'Multiline documents bar' на странице System - View настроек

На страницу System - View диалогового окна Preferences был добавлен параметр Multiline documents bar. Этот параметр полезен, если вкладки открытых документов не помещаются в одну строку. В этом случае, появится дополнительная строка вкладок документов. Когда этот параметр отключен, вкладки документов будут располагаться только на одной строке; в случае, если открытые вкладки документов не помещаются в одну строку, будут отображаться две стрелки для перемещения вдоль строки вкладок.

Multiline document bars option

Новая команда Refresh для панелей Navigator и Projects

Панели Navigator и Projects теперь включают в себя команду Refresh. Используйте эту команду для отображения изменений в соответствующей панели. Доступ к команде осуществляется следующим образом:

  • В панели Navigator: щелкните ПКМ в панели и выберите Refresh.
  • В панели Projects: щелкните ПКМ в верхнем разделе панели и выберите Refresh.

Navigator and Projects panels new Refresh command

Восстановлена панель To-Do

Была восстановлена панель To-Do. Панель отображает все элементы списка задач, которые определены в данный момент для активного проекта. Элемент списка задач может быть добавлен в диалоговом окне Edit To-Do Item. Этот элемент используется в качестве напоминания о задаче, которую необходимо выполнить для документа. Доступ к панели осуществляется нажатием по кнопке Panels в нижней правой части рабочей области и выбором To-Do. Панель также можно открыть из главного меню с помощью команды View » Panels » To-Do.

To-Do Panel

Для доступа к панели, поле Value параметра UI.PanelToDoList в диалоговом окне Advanced Settings должно быть включено (оно отключено по умолчанию). Чтобы открыть диалоговое окно Advanced Settings, нажмите кнопку Advanced на странице System - General диалогового окна Preferences. Если в настройки в диалоговом окне Advanced Settings вносятся какие-либо изменения, ПО необходимо перезапустить, чтобы изменения вступили в силу.

Восстановлена панель Clipboard

В новой версии восстановлена панель Clipboard. В этой панели хранятся и отображаются скопированные объекты, которые в любой момент можно добавить (вставить) в документ Altium NEXUS, что позволяет осуществлять множество операций копирования/вставки.

Для доступа к панели, поле Value параметра UI.PanelClipboard в диалоговом окне Advanced Settings должно быть включено (оно отключено по умолчанию). Чтобы открыть диалоговое окно Advanced Settings, нажмите кнопку Advanced на странице System - General диалогового окна Preferences. Если в настройки в диалоговом окне Advanced Settings вносятся какие-либо изменения, ПО необходимо перезапустить, чтобы изменения вступили в силу.

Дополнительный программный модуль 'Mechanical CAD Collaboration' переименован в 'MCAD IDX Exchange'

Дополнительный программный модуль Mechanical CAD Collaboration был переименован в MCAD IDX Exchange. Этот модуль можно найти на странице Extensions & Updates (открывается по нажатию кнопки  User drop-down в верхней правой части рабочей области и выбором команды Extensions and Updates меню). Для получения информации об установке дополнительных программных модулей обратитесь к странице Расширение функциональных возможностей Altium NEXUS.

MCAD IDX Exchange extension

Улучшения диалоговых окон

В диалоговое окно Open Project добавлен раздел подробной информации о проекте и поиск проектов

Диалоговое окно Open Project было улучшено – теперь здесь отображается подробная информация о проекте, что избавляет от необходимости открывать проект и что помогает быстрее находить нужные проекты.

Подробная информация о проекте

В диалоговом окне Open Project теперь отображается подробная информация о выделенном проекте. Эта информация показана в правой части диалогового окна, и она включает в себя изображение проекта, дату и время последнего изменения, связанные с проектом параметры и прочую информацию о проекте. Включение и отключение области подробной информации осуществляется щелчком мышью по кнопке  / .

Поиск проекта

Теперь вы можете осуществлять поиск проекта путем ввода локального расположения в поле поиска в верхней части диалогового окна. Кроме того, вы можете использовать кнопку  в поле поиска для перехода к папке на один уровень выше. Чтобы перейти вверх, вы можете также использовать сочетание клавиш Alt+Стрелка вверх.

Новый параметр 'Change System Component Parameters' в диалоговом окне Project Options

На вкладку ECO Generation диалогового окна Project Options был добавлен новый параметр Change System Component Parameters (Изменить системные параметры компонентов). Этот параметр можно использовать для управления тем, следует ли при выполнении процесса Engineering Change Order формировать запросы на изменение системных параметров компонентов или игнорировать их. По умолчанию новый параметр выставлен в состояние Generate Change Orders (Формировать запросы на изменение).

Относительные координаты добавлены в диалоговое окно Jump To Location редактора плат

Для более быстрого создания линий, полигонов и т.п. в диалоговое окно Jump To Location (Edit » Jump » New Location) были добавлены относительные координаты (Delta X и Delta Y). При изменении параметра Delta X или Delta Y поля X и Y обновляются соответствующим образом.

Jump To Location (PCB) Dialog

Новый параметр Thermal Relief Overrides

В диалоговое окно Component(s) Update Options был добавлен новый параметр Thermal Relief Overrides (Переопределения термобарьеров). Когда этот параметр включен, изменения термобарьеров в библиотеке посадочных мест будут игнорироваться. Этот параметр включен по умолчанию.

Thermal Relief Overrides option

Группирование полигонов по слоям в диалоговом окне Polygon Pour Manager

В диалоговое окно Polygon Pour Manager была добавлена возможность группировать полигоны по слоям. В списке Pour Order (Порядок заливки) будут представлены только полигоны, которые размещены на том же слое, что и выделенный в данный момент полигон (или первый выделенный полигон, если выделено множество полигонов на различных слоях).

Добавлены элементы управления в диалоговое окно Edit Component Variation

Диалоговое окно Edit Component Variation теперь включает в себя дополнительную информацию об альтернативных компонентах, которая зависит от того, как было открыто диалоговое окно. Кроме того, новая кнопка Replace Component (Заменить компонент) открывает диалоговое окно Replace Component (File-based), в котором отображаются готовые к размещению компоненты с сервера управляемых данных и из файловых библиотек.

Новый параметр 'Skip Hidden 3D Bodies' в диалоговых окнах Export Options

Во все вариации диалогового окна Export Options был добавлен параметр Skip Hidden 3D Bodies. Включите этот параметр, чтобы пропустить (т.е. не экспортировать) скрытые 3D-модели.

 

Добавлен поиск в диалоговое окно PCB Rules and Constraints

Диалоговое окно PCB Rules and Constraints теперь включает в себя элемент Search. С его помощью вы можете быстро найти необходимые правила. Введите текстовую строку, чтобы применить фильтр к диалоговому окну и отобразить только те правила, которые содержат этот текст.

Улучшено диалоговое окно PCB Library Footprint

В диалоговое окно PCB Library Footprint была добавлена возможность изменять его размер, добавлено поле Area (Площадь), а также добавлено больше места для поля Name (Название).

Использование посадочного места по умолчанию для альтернативного компонента в диалоговом окне Variant Management

Теперь при выборе альтернативного компонента в диалоговом окне Variant Management поле посадочного места не остается пустым, а используется посадочное место по умолчанию.

Новые параметры в диалоговом окне Unused Pad Shapes

В диалоговое окно Unused Pad Shapes добавлено два новых параметра. В поле Scope (Область действия) был добавлен параметр Both (Оба). При выборе этого параметра будут обработаны контактные площадки и переходные отверстия. Область Operation (Операция) теперь включает в себя параметр Update unused (Обновить неиспользуемые), которая восстанавливает, затем удаляет неиспользуемые формы контактных площадок.

Новый пункт Copper Area в диалоговом окне Board Report

В диалоговое окно Board Report был добавлен пункт Copper Area (Площадь металлизации), который может быть включен в отчет.

Исправленное выравнивание метки 'Height' в диалоговом окне Cartesian Grid Editor

Метка поля Height в диалоговом окне Cartesian Grid Editor была корректно выровнена с соответствующим текстовым полем.

Новый параметр 'Apply to All Libraries' в диалоговом окне Extract Sources or Install

Новый параметр Apply to all libraries (Применить ко всем библиотекам) в диалоговом окне Extract Sources or Install позволяет вам применить выбранное действие (извлечь исходные данные или установить библиотеку) ко всем файловым библиотекам.

Улучшения панелей

Панель PCB List

Была восстановлена возможность изменять слой компонентов в панели PCB List. В панели PCB List в режиме Edit используйте выпадающий список поля Layer для выбора нужного слоя.

Улучшения панели View Configuration

Определение прозрачности выбранных примитивов

Панель View Configuration теперь позволяет вам определять прозрачность выбранных примитивов на всех слоях. Эта функция была добавлена в раздел Object Visibility вкладки View Options. Вы можете использовать ползунок Transparency для определения прозрачности или щелкнуть мышью по значению и ввести нужный процент вручную, от 0 до 100 (0% соответствует полностью видимому объекту, 100% – полностью прозрачному, невидимому объекту). Нажмите кнопку Advanced, чтобы открыть диалоговое окно и увидеть таблицу, где строки представляют слои платы, а столбцы – типы объектов. Диалоговое окно позволяет вам задавать общий уровень прозрачности для определенного типа объектов на разных слоях, а также задавать разным объектам разное значение прозрачности на определенном слое.

Новое диалоговое окно Object Visibility

Диалоговое окно Object Visibility позволяет задавать прозрачность для каждого из типов объектов в отдельности или по слоям. Выделите объект (объекты) и слой (слои) в таблице и используйте ползунок Transparency for selected для определения нужной прозрачности. Чем правее расположен ползунок, тем выше прозрачность. Значение 0% соответствует полностью видимому объекту, 100% – полностью прозрачному (невидимому) объекту. Вы можете включить параметр Only show used layers для отображения только тех слоев, которые используются в текущей конструкции платы.

Улучшение панели Projects для записей серверов

Были улучшены команды контекстного меню записи сервера в панели Projects. Щелкните ПКМ и выберите Open Project, чтобы открыть диалоговое окно Open Project для выбора проекта, который нужно открыть. Используйте команду Show in Explorer, чтобы открыть панель Explorer. Используйте команду Show in Web Browser, чтобы открыть сервер в веб-браузере.

Новое предупреждение в панели Messages при удалении файла из проекта

В панели Messages теперь отображается предупреждение при открытии проекта, из которого был неявно удален файл. Это помогает прояснить причину изменения проекта.

Потерянные файлы

Сообщения о файлах, не найденных в открытом проекте, теперь отображаются в панели Messages, а не диалоговых окнах.

Content