NC Drill Setup

Последнее изменение: Susan Riege; 08.03.2018


The NC Drill Setup dialog

Summary

This dialog is used to configure NC Drill file output options.

Access

The NC Drill Setup dialog is accessed in one of the following ways:

  • Using an NC Drill output generator in an OutputJob Configuration file (*.OutJob). The output is generated when the configured output generator is run.
  • In an active PCB document, click File » Fabrication Outputs » NC Drill Files. The output will be generated immediately upon clicking OK in the dialog.
The settings defined in the NC Drill Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an OutputJob Configuration file. In the case of the former, the settings are stored in the project file, whereas for the latter, they are stored in the OutputJob Configuration file.

Options/Controls

Options

  • NC Drill Format - use this region to specify the units and format to be used in the NC Drill output files. 
  • Units
    • Inches - enable this option to use imperial units where all work is done in mils (1/1000 inch).
    • Millimeters - enable this option to use metric units where all work is done in millimeters.
  • Format
    • 2:3 - provides a resolution of 1 mil  (1/1000 inch).
    • 2:4 - provides a resolution of 0.1 mil. 
    • 2:5 - provides a resolution of 0.01 mil. 
If you are using one of the higher resolutions, check that the PCB manufacturer supports that format. The 2:4 and 2:5 formats only need to be chosen if there are holes on a grid finer than 1 mil.
  • Leading/Trailing Zeroes - zero suppression is a technique that reduces the size of the generated data files by removing all zeroes from the start (leading) or end (trailing) of numbers.
    • Keep leading and trailing zeroes - if this option is enabled, all leading and trailing zeroes will appear in the generated NC Drill file.
    • Suppress leading zeroes - if this option is enabled, no leading zeroes will appear in the generated NC Drill file.
    • Suppress trailing zeroes - if this option is enabled, no trailing zeroes will appear in the generated NC Drill file.
  • Coordinate Positions 
    • Reference to absolute origin - use the absolute origin as the reference point.
    • Reference to relative origin - use the relative origin as the reference point.
  • Other​ 
    • Optimize change location commands - check this option to optimize any change location commands.
    • Generate separate NC Drill files for plated & non-plated holes - check this option to create separate drill files for plated and unplated holes.
    • Use drilled slot command (G85) - check this option to use multiple drilled holes to create slots.
    • Generate Board Edge Rout Paths - check this option to create a separate NC Rout file to define the board shape, including board cutouts.
      • Rout Tool Dia - specify the tool size used to rout the board outline. This option is only available when Generate Board Edge Rout Paths is enabled.
    • Generate EIA Binary Drill File (.DRL) - use this option to generate a .DRL file. DRL is a binary format drill file. For a multi-layer PCB that incorporates blind and/or buried vias, a separate drill file for each layer pair is created with a unique file extension.
The NC Drill files should be created with the same format as the Gerber files. For example, if the Gerber files have been configured to use the 2:4 format, then the corresponding NC Drill files should use the same format. If Gerber files have been generated with the coordinate position on the film set to use either the absolute or relative origin, the NC Drill files should ideally be generated using the same origin reference.

Tips

Generated NC Drill Files

Filename Description
FileName.DRL Binary format drill file. For a multi-layer PCB that incorporates blind and/or buried vias, a separate drill file for each layer pair is created with a unique file extension.
FileName.DRR Drill report - detailing the tool assignments, hole sizes, hole count and tool travel.
FileName.TXT ASCII format drill file. For a multi-layer PCB that incorporates blind and/or buried vias, a separate drill file for each layer pair is created with a unique file extension.
FileName-Plated.TXT ASCII format drill file. Specifically for plated holes in a PCB design. A separate file will be created for each hole type - slotted, square or round.
FileName-NonPlated.TXT ASCII format drill file. Specifically for non-plated holes in a PCB design. A separate file will be created for each hole type - slotted, square or round.
FileName-BoardEdgeRout.TXT ASCII format rout file. Specifically for board outline including board cutouts.
FileName.LDP ASCII format drill pair report. Used by the CAM Editor to detect blind and buried vias.

Once generated, the output will be added to the project and appear in the Projects panel under the Generated folder in an appropriately-named sub-folder. If you have used a separate folder for each output type, then corresponding (separate) Generated folders will be added to the Projects panel (e.g., Generated (NC Drill Output)).

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder. The naming and folder structure is defined in the Output Container that the NC Drill File output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name Project Outputs for <ProjectName>. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, the NC Drill files will be written to a further sub-folder named NC Drill Output.

Automatically Opening the Generated Output

When generating NC Drill outputs, you can specify that the output be opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the NC Drill Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).

 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.