ODB Setup

Последнее изменение: Susan Riege; 18.05.2019

The ODB++ Setup dialog
The ODB++ Setup dialog

Summary

This dialog provides controls to completely configure ODB++ file output options. ODB++ is a CAD-to-CAM data exchange format used in the design and manufacture of printed circuit boards. The format was originally developed by Valor Computerized Systems, Ltd., as an open database that could provide a more information-rich data exchange between PCB design software and Valor CAD-CAM software used by PCB fabricators.

Access

The ODB++ Setup dialog is accessed in one of the following ways:

  • Using an ODB output generator in an OutputJob Configuration file (*.OutJob). The output is generated when the configured output generator is run.
  • In an active PCB document, click File » Fabrication Outputs » ODB++ Files. The output will be generated immediately upon clicking OK in the dialog.
The settings defined in the ODB++ Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an OutputJob Configuration file. In the case of the former, the settings are stored in the project file, whereas for the latter, they are stored in the OutputJob Configuration file.

Options/Controls

Layers to Plot

Check the box next to each specific layer(s) you wish to plot as part of the generated output.

Mechanical Layer(s) to Add to All Plots

Check the box next to each mechanical layer(s) you want added to all plots.

Miscellaneous Options

  • ​Include unconnected mid-layer pads - check to allow unconnected pads in the mid-layer on ODB++ plots.
  • Generate DRC Rules export file (.RUL) - check to generate a .RUL file that contains all design rules defined for the source document from which the ODB++ data is being generated.
  • Export only the objects inside the board outline - check to specify the source that is to be used to create the ODB++ profile layer. The profile layer contains the enclosing boundary of the board. By default, this field is set to Board Outline (also referred to as the board shape, it is a closed polygonal shape that defines the boundary, or extents, of the PCB). Created with each new PCB, this is perhaps the best source for creation of the Profile layer. If your design has no associated board shape, you can choose which source PCB layer has been used to define the closed polygon representing the boundary of the board (e.g., the KeepOut layer or a specific Mechanical layer). This option is only available when the source document contains an embedded board array object and it provides control over the extent of objects exported. Note that if an object (e.g., text) is outside of, but touching the board outline and this option is enabled, that object will still be exported.
  • Merge Net-Tie Nets - when enabled, if a design contains nets connected by Net-Tie components, these nets will report as distinguished single nets in the netlist.
  • Select the PCB layer / Board Outline that will be used to create the ODB++ 'profile' layer - use the drop down to select the desired layer/board outline:

Plot Layers

Use the drop-down, or right-click in the Layers to Plot section, to easily select a group of layers to plot:

  • All On - click to check all boxes in the Plot column (ODB++ data will be created for all checked layers).
  • All Off - click to clear all checked boxes in the Plot column (no ODB++ data will be created). 
  • Used On - click to check all boxes in the Plot column of the layers that are used in the project.

Additional Options

Right-clicking in the Layers Plot section or Mechanical Layer(s) to Add to All Plots section will display:

  • Add Layer Class - click to add a layer class.
  • Edit Layer Class - click to edit the layer class name.

Tips

Generating from an Embedded Board Array

When generating an ODB++ output from a PCB design that contains an embedded board array, the following statements apply:

  • The design is analyzed automatically for layer stackup violations.
  • Embedded boards that are flipped will display their layer stacks as flipped.
  • Mid-signal layers and internal planes that are different can still appear on the same mid-layer panel.
  • Mid-signal layers and internal planes can be flipped against each other.

When generating ODB++ output from the PCB design, all objects on all layers enabled for plotting will be exported. If you only want to export design objects residing within the board outline, ensure that all additional layers containing objects outside of this boundary are disabled for plotting.

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder. The naming and folder structure is defined in the Output Container that the ODB++ output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name Project Outputs for <ProjectName>. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, then the ODB++ files will be written to a further sub-folder named ODB++ Output.

Automatically Opening the Generated Output

When generating ODB++ output, you can specify that the output be opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the ODB++ Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.