Altium Designer Documentation

Draftsman_AD

Created: December 20, 2016 | Updated: March 30, 2017
您正在阅读的是16.1版本。 关于最新版本,请前往Draftsman阅读21版本

Draftsman是为PCB板设计生产提供图形文档的替代方法。通过专用文件格式和一组绘图工具,Draftsman绘图系统提供了一种交互式方法,将生产制造图和装配图与自定义模板、注释、尺寸、标注和注释组合在一起。

通过Altium Designer Extension应用获得新的Draftsman PCB绘图功能,并通过Altium Designer自动安装。扩展可手动安装/删除或从Altium Designer Extension & Updates 网页(DXP » Extensions and Updates)更新。可参见Installed选项卡和Updates选项卡下的Draftsman扩展,来查看是否有新的可用的软件更新。

主要功能

Draftsman绘图应用程序可以充当使用传统输出生成图形PCB生产文档的辅助工具,甚至替代方法。该应用程序可以按要求自动化布置装配和制造图,包括用于添加重要细节和高亮强调部分到多页文档的各种手动绘图工具。

该工具的主要功能包括:

  • 自动从PCB源文档提取图纸数据。
  • 创建多页文档。
  • 将单独的模板用于文档各页。
  • 自动由自定义模板生成图纸。
  • 使用常见和附加图纸视图(装配视图、制造视图、截面视图或钻孔视图)。
  • 装配视图包含3D模型生成的图形(不需要占用特殊PCB层)。
  • 可定制板层堆栈图例,可有选项添加板层详细信息。
  • 材料清单(BOM)能够显示所有的电路板项目或仅显示所选装配图的项目。
  • 添加标注,注明物料清单条目位置或来自备注列表的条目。
  • 支持装配变量。
  • 用户首选设置绘图对象和功能(DXP » Preferences)。
  • 打印和导出,以PDF形式输出。
  • 包含在OutJobs,且OutJobs中Draftsman PCB绘图文件能够添加作为新的文档输出。

将图纸视图、对象和自动注释置于单页或多页Draftsman文档上。 将图纸视图、对象和自动注释置于单页或多页Draftsman文档上。

采用文档和模板工作

由Altium Draftsman应用程序创建和保存PCB绘图文件(*.PCBDwf),并使用具体的模板格式定义图表(页面)属性(*.DwsDot)和文档内容(*.DwfDot)。配置‘智能’文档模板,以便自动将指定PCB图纸视图和信息文本填充至文档。初始创建时,文档模板可以使用当前的图表模板定义页面属性(尺寸、样式、边距等)。

创建新文档

可以使用File » New » Draftsman Document命令打开New Draftsman Document对话框在Altium Designer中创建新的Draftsman文档。

可以在对话框中选择预定义的文档模板(提供了三个模板)或用于创建空白A4文档的默认选项—注:一旦创建了新文档,即可使用图表模板。利用Draftman Preferences对话框中的  按钮打开Templates页,该页定义了模板目录的位置。

为指定项目和PCB创建空白的或基于模板的Draftsman文档。 为指定项目和PCB创建空白的或基于模板的Draftsman文档。

当Altium Designer中打开多个文件时,特定的项目和电路板源文件可以随所需的Draftsman模板一起选择。新的文档与指定项目有关,即可从指定项目中提取数据,使其变为当前活动项目。新创建的文档将被添加至指定项目中。

使用制造文档模板时,由对话框中的Layers复选框确定在文档中(每页一个)使用哪一个电路板层(由层堆栈定义)生成Fabrication图。始终包括绘图层。

文档图表

PCB Draftsman文件为多页格式,允许文档包含指定为特殊类型电路板项目生产信息的单独页面(图表)。可以通过Tools » Add sheetTools » Remove sheet命令或右键单击快捷菜单上的命令添加和删除当前文档中的图表。

文档中当前活动图表的数量和图表总数显示于工作区底部的状态栏中。

图表属性

可在Sheet Properties对话框中定义Draftsman文档的页面属性—选择Tools » Sheet Properties或在文档的右键选项中选择Sheet Properties

通过Sheet Properties对话框中的设置确定文档当前页面或所有页面的基础结构(尺寸、边框设置等)。另外,可通过加载(自定义)图表模板文档确定页面格式。

图表样式属性可以采用标准或自定义设置或图表模板中的设置。 图表样式属性可以采用标准或自定义设置或图表模板中的设置。

格式和尺寸

选择对话框中的Format & Size选项卡,以手动或根据模板设置文档页面尺寸/内容。选项包括:

  • Custom template – 使用预定义图表模板的页面设置。将模板中定义的图形与图表尺寸、设置、区域和边框定义一起加载至页面。提供了一系列PCB Draftsman扩展标准模板,而自定义图表模板则可以通过将现有文档保存为*.DwsDot格式创建—参见下文。

    使用   按钮直接从另一处打开替代图表模板。

  • Standard sheet size – 使用从下拉菜单中选择的标准图表尺寸。
  • Custom size sheet – 使用输入的自定义图表尺寸。

使用Apply to选项设置应用到当前活动页面(Current Page)还是所有页面。

边距和区域

选择对话框中的Margins & Zone选项卡,设置页边框和图形分区。

  • Margins – 规定了页面边缘到各边框线的距离。
  • Zones – 输入边框内水平和垂直参考分区的数量。

使用Apply to选项设置应用到当前活动页面(Current Page)还是所有页面(Entire Document)。

创建模板

Altium Draftsman文档可以使用模板定义其页面属性(图表模板)和新文档的一系列预定内容(文档模板)。两种类型的模板均可由PCB绘图文件(PCBDwf类)创建,且在将文档保存为一种模板类型(DwsDot或DwfDot)后PCB绘图文件在编辑器内呈打开状态。要修改文档内容和属性,可以重新打开、编辑和保存模板文档。

图表模板

图表(页面)模板包含页面的图形信息,例如图表尺寸、参数以及区域和边框设置。由编辑器的图形工具(例如线、矩形、圆和文本)创建的对象也包含在内——例如构建的标题栏和内容。图表模板可用于定义新的或现有绘图文档的图形格式,并保存为文档模板的一部分。

要将当前绘图文档的格式保存为图表模板,选择File » Save Copy As(或仅选择Save As)命令,并从保存对话框的Save as type选择过滤器中选择Altium Draftsman Sheet Templates (*.DwsDot)。删除与图表模板格式不兼容的所有元素,例如布置的图纸或附加页面。保存前,警告对话框将对是否有不兼容元素这一未决项进行详细说明。

与其他Altium Designer文档(原理图、PCB等)一样,通过Save As命令,用新保存的文件(图表模板文件)替换项目中现有的源文件(此处为Draftsman绘图文档)。源文档(*.PCBDwf)并未从磁盘上的项目文件夹中删除。


更好的方法是使用Save Copy As选项,可以将新模板保存至指定目录,同时保持源文档(和项目内容)不变。

请注意,通过Sheet Properties对话框可将保存的图表模板应用于Draftsman文档页——选择对话框中的  按钮,找到和加载指定的图表模板。

文档模板
文档模板定义了Draftsman文档的内容及其(可选地)样式属性。该模板支持多页文档、主文档的属性(表格、列表和图纸类型等)数据以及由图纸编辑器创建不依赖于PCB设计内容的元素。
 

要将当前绘图文档的格式保存为文档模板,选择File » Save Copy As(或仅选择Save As)命令,并从保存对话框的Save as type选择过滤器中选择Altium Draftsman Document Templates (*.DwfDot)。除非涉及到从PCB设计提取的数据,否则现有文档的所有内容和属性将保存为文档模板。如果绘图源文档具有特定的页面样式(正如图表模板使用的),这些图形元素和属性将和新的文档模板一起保存。

删除与文档模板格式不兼容的所有元素。保存前,警告对话框将对是否有不兼容元素这一未决项进行详细说明。

只有一种类型的电路板制造视图可以保存在文档模板中。这是因为使用该模板创建新的Draftsman绘图文档时,生成的各制造图(每页一个)的层和内容取决于具体的PCB设计。

多页Draftsman文档通常包含装配图、钻孔表、钻孔图、层堆栈表、材料清单和制造图。保存为文档模板时,保留来自当前PCB的数据用来定义图纸内容‘外壳’。

随后用作新绘图文档的模板时,项目当前的PCB数据代替模板PCB数据载入外壳内,从而重新创建文档格式及其内容的类型。

编辑模板

在Altium Designer中,图表模板和文档模板均可以打开作为自由文档,并进行相应编辑。选择File » Open,并在浏览器过滤器选项中选择Altium Draftsman Sheet Templates (*.DwsDot)Altium Draftsman Document Templates (*.DwfDot),打开模板。

打开的文档模板包括创建模板时使用的PCB设计数据和处于活动状态的图表模板属性。如果图表模板定义了文档模板中的页面属性,而且图表模板在此期间发生变化,则需要使用新的图表模板。

文档选项

通过Tools » Document Options菜单命令进入Draftsman Document Options对话框,在该对话框中设置PCB Draftsman文档的选项。请注意,文档选项适用于整个绘图文档,而Sheet Properties设置适用于单独的文档页面。文档选项和图表属性均和当前Draftsman文档一起保存。

Draftsman文档属性适用于绘图文档的所有页面。 Draftsman文档属性适用于绘图文档的所有页面。

Draftsman Document Options对话框提供了当前Draftsman文档的以下设置:

  • General 选项卡 - 一般设置:
    • Source – 与图纸同步的项目电路板文件。
      • PCB Document下拉菜单提供了在当前项目中可用的选中所有电路板的一个选项,新选项重新定义了绘图文档和PCB间的链接。
      顶层/底层装配层(Top/Bottom Assembly Layer)菜单允许选择板的任何机械层(Mechanical Layer)作为元件几何形状(Geometry)和参考定位(RefDes)的数据来源。 当在元件显示属性对话框中选择装配视图(AssemblyDrawing)选项作为元件的几何源或位置源时,此备用元件数据方可被采用。
    • Grids – 网格颜色和网格分区间的距离(尺寸),以及如何将分区分为细线组和粗线组(乘积)。
    • Variants – 如何显示不匹配当前选择的电路板变量的元件(隐藏或以可定义的网格填充样式)。在Draftsman Properties面板的Board Assembly View模式中,从Variation菜单(View下)选择电路板变量选项。
    • Zones – 适用于文档边框内区域分区的字符指标的定位规则。
    • Scale, etc – 设置新放置文档的比例:当前文档中所有工作表的视图、字体和图纸/边框颜色属性。
  • Parameters tab - 查看、添加和删除可以在标题栏或表格等绘图文档中使用的自定义参数。
    • Add/Remove 参数 – 使用  及  按钮创建或删除自定义参数(Custom Parameters)。
    • 参数过滤 – 检查System/Project/PCB Parameter选项以过滤显示的列表(始终列出Custom Parameters)。 请注意,除Custom Parameters之外的所有选项均是只读的,并标有星号后缀(*)。
  • Snapping tab - 可整体关闭(Shift+E)或单独选择的快速绑定选项;
    • Vertices – 矩形、线终端处或截面等的转角。
    • Line centers – 线的中心点。
    • Circle centers – 定义圆的中心点。
    • Grid – 网格分区,与对话框中General选项卡下Grids设置定义的一样。
    • Boundaries – 对象边缘或中心的延长线。
    • Snapping Distance – 定义了快速绑定操作中的距离区域。
  • Line Styles tab - 定义了可在文档中使用的线的粗细和虚线样式。
    • 虚线模式 – 虚线选项中的线/间距定义,单位为0.02mm(公制模式下)。例如,模式值为20,10,20时,虚线则是0.4mm、0.2mm和0.4mm的重复短线,循环长度为1mm(50个单元)。可通过  按钮创建自定义虚线选项。
    • 线的粗细 可用线的宽度或粗细选项。使用  按钮恢复默认值。
  • Units单位选项卡 - 设置文档使用的单位和数字精度类型。
    • 测量单位 – 将文档测量单位设置为英制或公制。
    • 精度—设置绘图文档的标准测量精度和公差定义(小数点右侧有效位数,其中最后一位数字采用四舍五入)。 通过在面板的Tolerance部分选择公差类型选项,可以在Draftsman Properties面板上显示所选测量的公差。

使用图纸视图工作

Altium Draftsman应用程序允许直接将一系列自动化生产图纸置于Draftsman绘图文档。从编辑器的Drawing Views图标集合中或通过从Place主菜单选择一种图纸类型选取将要放置的图纸的类型。

Draftsman属性面板

置于文档中时,可以在页面内操作图纸,并且可以在专用Draftsman Properties面板上编辑它们的属性。如果面板尚未打开,可以通过双击放置的图纸视图、在选中的图纸视图中右键单击选项菜单选择Properties、或单击工作区底部的  按钮激活面板。

面板自动更改其模式和内容来匹配选择的图纸视图或对象。 面板自动更改其模式和内容来匹配选择的图纸视图或对象。

通过面板,可以对位于绘图文档中的对象的详细属性进行编辑。在面板中仅可以选择一个对象或视图查看其属性。

许多面板配置区域(选项组)与大多数视图模式相同,均是通过选择绘图对象进行操作。包括:

  • Position – 将对象的旋转方向设置为以90º为等级选择。
  • Scale – 将对象的可见尺寸设置为预设比例(缩放菜单)选项或与1成比例的具体数字,其中0.9表示90%(使用自定义缩放选项)。
  • Title – 视图的标题名称、字体/颜色和可视化设置。可以在标题中使用系统或自定义参数。“使用文档字体(Use Document Font)”复选框强制放置的视图必须采用在全局Draftsman Document Options对话框中规定的字体样式。

装配视图

指定项目PCB的装配视图通过 Place » Board Assembly View 命令,或Drawing Views选项下的  图标布局在文档中。

可以从不同的侧面移动、缩放和查看放置的电路板装配视图。 可以从不同的侧面移动、缩放和查看放置的电路板装配视图。

视图显示了电路板的外形,包括切口、孔和元件的图形以及附加的注释。元件图形为自动生成,优先使用以下来源的数据:

  1. 电路板元件三维模型(3D模型)投影—默认使用。
  2. 来自顶部/底部丝印层的元件丝印图形—3D模型不可用时使用。
  3. 来自元件焊盘(边界框)的元件尺寸图形—3D模型和没有丝印时使用。

可以在Component Display Properties对话框中改变元件的可见性、位号属性以及用于形成图形的几何源(上述选项1、2或3),而该对话框可从Draftsman Properties面板打开—参见下文。

图纸视图的自动生成不取决于附加电路板层是否可用(例如,顶部/底部装配)。

装配视图属性

Draftsman Properties面板中的Board Assembly View模式提供了以下设置(使用  按钮展开/折叠选项组):

  • Position – 装配视图在图表上的朝向。
  • Scale – 图纸比例(缩放),通过预设比例或自定义值设置。
  • Title – 视图的标题名称、字体/颜色和可视化设置。
  • Styles – 设置电路板和元件外形的颜色和线条宽度/样式。
  • Font – 元件名称的字体设置,同时也定义了自动缩放的最小和最大尺寸,以适应元件图形。The font style for individual components can be overridden in the Component Display Properties dialog.
  • View – 视图设置,包括:
    • View – 视图的方向(顶部、底部、从侧面等)。
    • Display holes – 用于显示孔的过滤器,可以设置为显示所有孔(All)、仅显示施工孔(Pads Only)、仅显示大孔(Minimum diameter Only)或不显示孔(None)。
    • Minimum Diameter – 尺寸阈值设置为最小直径孔可见性选项(如上所述)。
    • Variation – 按照相关文档选项设置确定的,如果有的话,选中项目PCB变量进行显示—省略的变量元件不显示或显示为(绿)网格。
    • Component Caption – 选择与元件相关的文本字幕的参数源(名称或材料清单项目参考)。
    • Show SMD Pads – 勾选该选项,显示图纸中的表面贴装元件焊盘。使用相关的下拉菜单选择渲染颜色。
    • Show Through-Hole Pads – 勾选该选项,显示图纸中存在的通孔型焊盘。使用相关的下拉菜单选择渲染颜色。
    • Components 按钮 – 打开Component Display Properties对话框,设置元件显示选项。勾选Show Component Pads,在元件上绘制焊盘图形。

元件显示属性

可通过Properties面板的Board Assembly View中的  按钮打开Component Display Properties对话框,并在该对话框中配置各元件在装配视图中的显示模式。

通过Show菜单,可选定Component Display Properties对话框,并根据元件、类和封装的分组选择以及材料清单条目显示不同格式的元件属性(在下图中选定封装分组)。该对话框允许控制各元件的可见性和图形,包括以下选项:

  • Visible – 切换元件图形的可见性。
  • Geometry Source – 用于渲染元件图形的数据源:
    • Default – 将按照优先顺序从以下三个选项中选取元件图形(3D模型、丝印层或边界框)。
    • Body projection – 元件的3D模型(如果有)。
    • Silk screen – 丝网印刷层。
    • Bounding box – 元件接触焊盘的尺寸。
    • AssemblyDrawing – 在“文档选项Document Options)”对话框中指定的机械层(Mechanical Layer)上包含的元件图形数据。
  • Color – 元件图形的色彩。
  • Reference marker display – 启用/禁用元件的可视基准点(一般为指明元件引脚1的点)。
  • Show Designator – 切换元件标号注释的可见性。
  • Location – 元件标号的位置设置。
    • CenterFit (default) – 标号被置于元件图形中央,并自动缩放至合适的大小。
    • Center, TopLeft, Left, Right 等 – 元件位号标识符放置在靠近元件外框的所处位置。
    • AssemblyDrawing – 位号标示符,其位置和大小由指定机械层(Mechanical Layer)上的元件位号标示符(通常来自于.Designator特殊字符串)的属性定义。
  • Font – 元件标号的选定字体(选择Center/Fit选项后将自动缩放字体大小,所以此项不适用)。请注意,当位号标示符来自板机械层(装配视图位置Assembly View Location选项)时,字体样式由Font选项确定,但字体大小将反映板机械层上的由位号标示符定义的字体大小。
  • Hatching Pattern – 用于渲染元件剖面的可视图像和色彩,如电路板截面视图中显示的内容。

配置元件图形和注释,以便在装配视图中显示最合适的状态。 配置元件图形和注释,以便在装配视图中显示最合适的状态。

为便于对多个条目进行定位和变更,Component Display Properties对话框也提供智能过滤功能。该功能可通过各列排针处的  图标激活。在过滤器下拉列表中选定所需条目,从而限制(过滤)对话框内容,筛选出符合选定属性的元件。可启用多个过滤选项,之后可通过对话框下侧边缘的过滤条目复选框禁用或清除这些选项。

使用特定的文本查询对数据进行自动过滤,从而对元件条目进行分组,或者使用全文查询方式进行自定义过滤(见下图)。 使用特定的文本查询对数据进行自动过滤,从而对元件条目进行分组,或者使用全文查询方式进行自定义过滤(见下图)。

如需创建更高级的约束条件或复合型过滤约束条件,可从过滤器下拉列表中选定Custom选项。

制造视图

放置项目PCB板的制造视图可通过 Place » Board Fabrication View 命令,或Drawing Views选项下的  图标置入文件。

Draftsman制造视图可从任何一侧显示(或翻看),并使用实心的或空心的敷铜填充物进行渲染。 Draftsman制造视图可从任何一侧显示(或翻看),并使用实心的或空心的敷铜填充物进行渲染。

制造视图属性

放置好从编辑器中选定的制造图形后,Properties面板中的Board Fabrication View模式将提供以下设置:

  • Position – 制造视图的位置和在图表上的朝向。
  • Scale – 绘图比例尺(缩放)。
  • Title – 视图的标题名称、字体和可视化设置。注意:文本属性字段中可能使用系统或自定义参数,例如下图中的Title所用的层名和比例尺参数。
  • View – 视图设置,包括:
    • Layer – 该视图中显示的电路板层。
    • View – 视图的方向(顶部或底部)。
    • Drawing Mode – 电路板导体的显示方法:实心和完全渲染的形式(Full)或线条形式(Simplified)。
    • Polygon Fill Mode – 多边形的显示方法:实心(Filled),线条填充(Hatched)或空心(Outline)。
    • Board Line Style – 定义电路板周长的线条的类型、色彩和权重选项。

钻孔图纸视图

选定的PCB板的钻孔图纸视图可通过Place » Drill Drawing View命令,或Drawing Views选项下的  图标置入相应的图纸文件。

放置好的钻孔图纸可从任何一侧显示,显示具体钻孔对(如果有)的相应孔洞,并通过已定义的孔洞组符号进行渲染。 放置好的钻孔图纸可从任何一侧显示,显示具体钻孔对(如果有)的相应孔洞,并通过已定义的孔洞组符号进行渲染。

钻孔图纸视图属性

放置好从编辑器中选定的钻孔图纸图形后,Properties面板的Drill Drawing View模式将提供标准的图纸视图设置,如位置、标题和视图。该面板模式的其他属性设置如下:

  • Layer PairsView 标题下) – 从PCB钻孔层对的列表中选定(如可用),以便在图纸视图中进行显示。
  • Configurations (Drill Symbols标题下) – 通过Drill Symbol Configurations 对话框设置各种孔型组对应的钻孔符号图形和大小(见下图)。

钻孔符号配置

Drill Symbol Configuration对话框以列表形式显示了PCB孔数据,其中,孔型基于可选参数(列数据)进行分组,并分别指定了标准符号。在Drill Drawing View模式下,该对话框通过Properties面板的  按钮激活(见上图)。

根据特定孔型组的属性设置相应的孔洞符号图形。从Grouping下拉菜单选择可选孔参数后,符合选定标准的孔型将被纳入同一符号下。 根据特定孔型组的属性设置相应的孔洞符号图形。从Grouping下拉菜单选择可选孔参数后,符合选定标准的孔型将被纳入同一符号下。

对话框中的孔洞数据表提供了一种灵活指定钻孔图纸符号的孔型,同时设置该符号显示的图形和大小的方法。

以上图为例,图中的标准配置为通过大小、电镀状态和公差对孔洞进行分组,所以,所有具有这些参数值的孔洞均被纳入一种钻孔符号下。相比之下,如果分组标准设置为“钻孔层对”,所有孔洞均将被纳入同一种钻孔符号下—因为在该PCB板中,所有孔洞均具有这一参数(本PCB设计中只采用一种钻孔层对)。

在钻孔视图(Drill Drawing View)和放置的钻孔表(Drill Table)中显示的孔洞组的钻孔符号(Drill Symbol)都取决于在Drill Symbol Configuration对话框中的Symbol Graphics菜单中进行的选择。支持的符号包括一系列图形形状和字母字符。

详细视图

启动Draftsman文件的详细视图功能后,可为图纸中已定义的区域提供该区域细节的浮动放大视图。可在Properties面板的Board Detail View模式下配置详细视图的放大倍数(比例尺)、标签和线条属性。

选择 Place » Board Detail View 命令或点击Drawing Views工具选项中的 图标可放置详细视图。其布局过程如下:

  • 点击图纸上的某个点,从而指定详细图纸目标区域的中心。
  • 移动鼠标并点击,从而指定视图区域半径范围(详细视图源)。
  • 再次点击,从而确定详细视图的扩展位置。
  • 通过Properties面板上的ViewStyle选项(电路板详细视图模式下)设置详细视图和源区域之间的关联。

所有图形化的电路板视图均可能设置详细视图,包括装配视图、制造视图、截面视图或钻孔图纸视图。

截面视图

截面视图显示的是通过已置入的PCB装配视图从指定“剖切”点截取的剖面切片或截面图纸。截面视图生成器从当前的PCB板中获取可用的3D数据,从而创建指定剖切点的相应独立截面图纸。可根据装配视图创建任意数量的截面视图,并且可在放置这些截面视图后修改截面参数。

如需创建截面视图,可使用Place » Board Sectional View命令或选定Drawing Views工具栏中的 图标。可按以下步骤创建下图中的截面B-B:

  1. 定位装配视图上的指针,随着指针移动,会形成一条垂直的剖切线(最初为A-A)—通过空格键切换垂直和水平剖切线。
  2. 点击并设置剖切线的位置。
  3. 在剖切线任意一侧移动指针,从而设置视图方向(按照剖切线箭头所示方向设置),并点击确认。
  4. 将新的截面视图拖拽并放置在所需位置。

放置截面视图后,可将其拖拽至新位置,或者可将该视图对应的剖切线移动至装配视图的另一位置。如需采取上述的第二种行动,可选定截面视图,然后将其剖切线拖拽至装配视图上的新位置—截面视图图形也会随之更新。

Properties面板的Board Section View模式下,可为选定的截面视图提供其他选项,包括比例尺、标签、类型和朝向。

  • 可通过PositionScale选项定义现有截面视图的大小和旋度(90º等级)。
  • 可通过View选项控制剖切和截面显示,其中:
    • 可通过Positional Mode切换水平或垂直剖切朝向;可通过Flip View Direction选项变更选定截面线的定向视图(即“视线”来源方向)。剖切线的方向箭头将随之改变。
    • 可通过Slice Section选项禁用剖切线后方对象的可见性—该选项将“背景”对象从截面视图中移除。
    • 可通过Board Cut Fill Style选项设置剖切对象上叠加的图形化模式的属性,因此,也可设置切片对象的外观。
    • 可通过Display Mode选项设置剖切线末端箭头类型,而Show Connector Line可切换切线箭头之间的线条。
  • 可通过Styles选项确定装配视图中的剖切线的可视类型,其中:
    • Cutting Line Style选项可定义线条权重、类型和色彩,而Connector Line Style可设置切线箭头之间的线条属性。
    • Arrow Style选项可设置切线箭头的形状和权重。

层堆栈图例

Draftsman文件的层堆栈图例视图可作为放大的截面视图展现电路板的内部结构。该视图包括堆栈中各层的详细描述和信息,如与各层相关的Gerber文件。

在默认模式下,各层信息派生于电路板层堆栈按Layer Stack Manager对话框设置的相应属性(电路板编辑器中的Design » Layer Stack Manager),但可通过Properties面板的Layer Stack Legend模式编辑和扩展层描述属性——见下图。

如需将层堆栈图例视图置入图纸文件,可使用Place » Layer Stack Legend命令或从Drawing View工具栏选定 图标。

放置的层堆栈图例从指定PCB板的层堆栈获取数据,并能与相关层的厚度和钻孔对一起显示。 放置的层堆栈图例从指定PCB板的层堆栈获取数据,并能与相关层的厚度和钻孔对一起显示。

层堆栈图例属性

如需配置数据在层堆栈视图中的显示方式,可双击放置的视图,或点击右键,并在展开的选项中选定Properties,从而启动Properties面板的Layer Stack Legend模式。该面板模式提供广泛的分组属性设置,可对已置入的层堆栈图例视图进行细节微调。可通过  按钮展开/收缩面板选项组。

该面板模式中,较重要的设置如下:

  • View WidthLayer HeightsView Styles选项下)—确定层堆栈图形的尺寸,其中,高度(Heights)选项可设置标准的一维视图,该视图中的层深度(高度)与实际层厚度成正比,并且能设置与表格中每行内容一致的固定层高度。
  • Show Drill PairsView Styles选项下)—通过图形表现电路板的指定钻孔层对之间的钻孔(按照PCB设计的层堆栈定义指定)。
  • ScaleView Styles选项下)—设置堆栈层与实际厚度之间的比例尺(Layer Heights选项必须处于“实际宽度”模式下)。通过最小/最大层高度设置确定层高度比例尺的尺寸范围。
  • SourceData选项下)—视图中所包含的数据的来源,可以在用不同的结构区域处理电路板设计时,选取多个堆栈的数据源,如刚柔结合PCB板。
  • ConfigurationsSettings选项下)—通过  按钮打开Layer Information对话框,可在该对话框中编辑层表中的数据和信息 。
  • 面板中,大多数其他选项的作用均不言自明。可通过变更值和切换选项浏览这些选项的作用。

层堆栈图例信息

可通过Layer Information对话框控制Layer Stack Legend视图表中显示的层信息。如需打开该对话框,在Properties面板的Layer Stack Legend模式下点击Settings下的  按钮。

Layer Information对话框中可启用以下编辑选项:

  • 切换外层的可见性(助焊层和丝印层)。
  • 定义各层的显示色彩。
  • 隐藏、移动和重命名表中各列。可添加或删除列,也能创建新的自定义列。
  • 单独编辑表格单元格中的内容。这些单元格最初由电路板层堆栈数据填充,但经过手动编辑的单元格不会根据电路板数据更新(Tools » Update Board)。
  • 定义Total 的信息数据,这些数据显示在表的页脚处。默认显示电路板总厚度,但可进行重命名,或设置为自定义值 --- 注意,可通过Properties面板中Table Styles下的Show Footer切换页脚可见性。

注意:层堆栈显示和信息选项定义放置在图纸文件中的层堆栈图例视图的结构和内容,并且不影响PCB编辑器中定义的电路板层堆栈配置。

注释和绘图工具

Altium Draftsman额外提供一系列用于向Draftsman图纸文件添加重要信息的绘图和注释工具。这些工具包括自动注解和高亮显示系统,以及自由形态的绘图功能。其中的尺寸工具用于已置入的Assembly Drawing视图,可通过Place主菜单启用这些工具,也可通过Drawing Annotations工具栏中各工具对应的图标启用这些工具。

尺寸

对象的尺寸图形可放置在装配图纸视图中,以便指明对象边框的长度、大小和角度,或指明指定对象之间的距离—也可向装配图纸的截面视图添加尺寸项。如需放置尺寸图形,从Place菜单,或从工具栏的尺寸下拉菜单 ()选定所需类型。

线性尺寸

可向对象的边框外缘或两个对象点之间添加线性尺寸。按以下步骤设置尺寸:

  1. 选择线性尺寸工具:
  2. 如需标注对象边缘的尺寸,可在该位置悬停指针,直到所需边框高亮显示,然后点击选中。定位尺寸图形,然后点击,将该图形锁定到位。
  3. 如需标注两点之间的尺寸,可在第一点位置悬停指针,直到该点高亮显示(打点),然后点击选中。在第二点处重复上述步骤,然后定位尺寸图形并点击,将该图形锁定到位。

已置入的尺寸图形也可移动,但只能在斜平面内移动(水平、垂直等)。对于已置入的尺寸,在Properties面板的尺寸模式下可编辑其中大多数项目—选定已置入的尺寸即可启用相关的面板模式。

面板的尺寸模式下可使用的主要选项包括:

  • Value – 用基本文件单位(值)显示已测量的尺寸,但可通过Override Value With选项使用替代值进行替换。
  • Units – 设置本对象实例的单位类型(欲知更多信息,见下文Measurement units注释)。
  • Tolerance – 改变尺寸文本,以便显示指定的+/-公差值。
  • View – 改变尺寸文本和箭头与尺寸指示线的相对位置。
  • Appearance – 改变箭头图形类型和线宽尺寸、类型和色彩。
  • Text prefix/suffix – 添加尺寸文本的前缀和/或后缀文本。例如,当尺寸值为10.5时,添加~和nom后创建的文本为~10.5nom。当在面板的Units部分启用该选项后,文本中会显示mm等单位名称后缀。

测量单位:

注意:用于Drafstman文件的单位系统(公制或英制)通过Draftsman Document Options对话框中的Measurement Unit设置定义(Tools » Document Options)。然而,对于线性/径向尺寸、钻孔/材料清单表和层堆栈图例等单独对象而言,它们的默认单位可能在Draftsman中预设为英制或公制—Preferences对话框Primitive Defaults页面(DXP » Preferences)。当置入该类型的新对象时,这些设置将覆盖文件的基本单位设置。

反之,已置入对象使用的单位可通过Draftsman的Properties面板中的Units选项在本地进行改变。

径向尺寸

可向装配图纸上的圆孔对象添加径向尺寸。按以下步骤设置尺寸:

  1. 选择径向尺寸工具:
  2. 在所需孔洞区域悬停指针,以便高亮显示该孔洞,然后点击选定。
  3. 定位尺寸图形,然后点击,将该图形锁定到位。

可通过处理线性尺寸图形的类似方法移动(选定和拖拽)或编辑径向尺寸测量图形。同样,对于已置入的尺寸,在Properties面板的径向尺寸模式下可编辑其中大多数项目—选定已置入的径向尺寸即可启用相关的面板模式。

注意:Altium Designer将自动检测(并在必要时转换)添加了特定单位后缀并且手动输入的尺寸—本应用程序中为mm或mil。如输入的尺寸没有合适的后缀,则假定该数值使用为相关文件或对象配置的单位。

角度尺寸

可在装配图纸上的两个对象边缘之间添加角度尺寸。按以下步骤设置尺寸:

  1. 选择角度尺寸工具:  
  2. 在第一条边缘位置悬停指针,直到该线条高亮显示,然后点击选定。在第二条线的位置重复上述步骤。
  3. 定位尺寸图形并点击,将该图形锁定到位。注意:该图形可与两条边缘线的交叉内侧或外侧保持一致。

可通过处理线性尺寸图形的类似方法移动(选定和拖拽)或编辑角度尺寸测量图形。对于已置入的尺寸,在Properties面板的角度尺寸模式下可编辑其中大多数项目—选定已置入的角度尺寸即可启用相关的面板模式。

标注

可在图纸视图上进行Draftsman文档标注,以提供元件和一般对象相关的更多信息,或在材料清单条目和注释项的同步指示器装配图视图上进行Draftsman文档标注。同样地,标注的源文本可为自定义条目、特定注释条目的链接或材料清单项的自动参考。

要进行标注:

  1. 选择标注工具: 
  2. 要用自定义文本进行标注,选择未突出绘图要素的一个点,点击放置标注指针,然后定位并放置标注端。在Properties面板中编辑标注文本。通过在面板的Source组(如下)的Source Type中选择该选项,可将现有标注更改为Custom Text类型。
  3. 要放置自动材料清单元件链接,选择元件的突出外框边缘,然后定位标注端并点击布置。如果已将材料清单置于图纸上,标注链接将显示该元件相应的材料清单条目编号。
  4. 要创建注释条目的参考,在所需点进行标注,然后在属性对话框的Source组(如下)中选择Note Item作为Source Type。从Note Item下拉列表中选择一个注释编号—注释列表条目必须已经存在于图纸上。

可放置并配置智能标注文本,以读取元件的匹配材料清单条目,参考现有的注释项条目,或仅显示自定义文本。

进行标注时,根据选择的源对象自动选择其类型,如下:

  • 选择一个开放(未突出)区域将形成Custom Text标注(参见以上第2步)。
  • 选择元件外框将创建BOM Item标注(参见以上第3步)。

要创建Note Item参考,或将现有标注更改为另一类型,在Properties面板的Callout模式的Source部分中选择适当的Source Type

注释

可将Draftsman文档注释项列表作为自由文本条目置于任何位置。标注(见上文)可引用这些条目,并在Properties面板的注释模式中同时配置和编辑。

要放置注释项,选择Insert Note工具 ,然后点击并在绘图空间放置默认注释条目。选择列表中的一个条目,编辑其文本内容和编号Properties面板中的图标样式。使用添加/删除按钮以纳入并删除列表条目,使用向上/向下按钮配置文本条目的顺序。

选择注释项中的单个条目,以便在Properties对话框中编辑其内容。 选择注释项中的单个条目,以便在Properties对话框中编辑其内容。

例如,添加采用预定文档参数中的一个新注释条目:

  1. 选择文档上的注释项,然后选择Properties面板中的 按钮。
  2. 纳入适当文本,然后选择 按钮开启文档参数对话框。
  3. 从列表选择现有(系统)参数或自定义参数。注意在Draftsman Document Options对话框的Parameters选项卡中可添加自定义参数(Tools » Document Options)。
  4. 确认对话框操作(OK),以便将参数参考添加到新的注释条目(见以下注4)。

材料清单和钻孔表

PCB Draftsman文档将材料清单(BOM)和钻孔符号/数据表放置在图纸上并在Properties面板中配置。列表数据的直接来源是项目PCB文件,并提供了一种简单直观的方式传递关键信息供PCB制造和装配过程。

Place菜单下的材料清单/钻孔布局选项可用,或可从Drawing Annotations工具条上各自的图标使用。

材料清单表

要放置材料清单表,选择材料清单表布局工具  并点击将表格放置在绘图文档上。

选择放置好的表以启用Properties对话框的Bill of Materials模式,其为材料清单表的大多数提供配置选项,包括其可见Properties和数据内容。Data Filtering选项使材料清单内容反映出选定的电路板设计变量,和/或过滤置于文档的任何装配视图的内容(默认为‘所有’内容)。

请注意,新放置的BOM表的属性(包括其包含的列)由Draftsman的首选项(DXP » Preferences – Draftsman)定义。

使用面板Columns部分管理表格数据列,然而,其分组和内容将取决于如何配置材料清单本身,如下所述。

处理Properties面板Columns部分中放置的材料清单表列。 处理Properties面板Columns部分中放置的材料清单表列。

Bill Of Materials Configuration对话框中设置材料清单表的可用内容和数据分组,其可从Configurations部分的Properties面板的  按钮开启。对话框提供了以下材料清单配置选项:

  • Data Source – 确定用于获取材料清单项列表的PCB数据文件内容。Project选项将从指定PCB项目的所有电路板中提取材料清单数据。
  • Grouping Key – 确定用于分组所有材料清单项(在单独一行中)的元件属性内容。通常设置为Comment(或Footprint),以便相同类型的元件组合在一起。

Data Source菜单中选择Project选项以启用所有项目数据,数据包括项目原理图文档中的自定义的元件参数Parameters。

Properties面板的部分使用Up/Down按钮重新排列列的顺序,删除列(视觉上不可见)或增加新的列。使用 按钮将新的自定义或现有数据列纳入表中 – 每次单击Add按钮时都会添加下一个可用的数据列。使用  按钮重置数据Column列。

钻孔表

要放置钻孔表,选择钻孔表放置工具  并点击将表置于绘图文档上。

选择放置好的表启动Properties对话框的Drill Table模式,其提供钻孔表的大多数配置选项,包括其可见Properties和数据内容(通过Data Filtering和Column选择)。注意面板的Units部分允许将也具有精度设定值的尺寸条目(如Hole Size列的尺寸条目)设置为一个或两个可用单位(mm或mil)。

采用面板的Columns部分管理表数据的排序顺序以及列的可见性和位置。排序顺序按钮()关闭升序和降序模式 模式之间的切换,且排序可用于多列。

设置钻孔表列数据的可见性、顺序和排序。钻孔符号的定义如放置的钻孔图纸视图所示(Configuration按钮)。 设置钻孔表列数据的可见性、顺序和排序。钻孔符号的定义如放置的钻孔图纸视图所示(Configuration按钮)。

通过由面板的  按钮(Drill Symbols下)开启的Drill Symbol Configurations对话框中的设定值确定钻孔表符号样式以及在这些符号下进行的钻孔类型分组。这是在Drill Drawing View模式中从面板激活的相同对话框,但在这种情况下,仅显示为钻孔表激活的这些列(可见)--注意两个Drill Symbol Configuration对话框版本来自相同的来源,因此可进行交互。

图形工具

Draftsman提供了图形要素工具的范围,图形元素工具可用于在文档中放置基本的自由形式的绘图元素。从主Place菜单或Drawing Annotations工具条上的图形工具下拉菜单()访问工具。

通过点击放置其首个节点然后在放置其第二个节点来放置图形元素,从而确定其大小——也就是说,线路长度、圆半径、矩形或文本框对顶点之间的距离,或布置的图像图形尺寸。节点将对齐其他对象的节点或导向,也可对准文档捕获网格(如果启用)。

可通过选择和拖动来移动放置的图形元素,或在选定多个元素(Ctrl-shift + click,或通过捕捉)时批量操作。也可选择和移动单个节点。对于更多的选项,选择放置的图形元素在Draftsman Properties面板中启动其相关模式--注意在面板中定义文本框内容,可包含文档参数。

DXF Import

Draftsman通过导入标准DXF文件提供进一步的图形选项,根据DXF菜单通过File » Import命令将这些文件载入绘图空间。 使用Windows文件浏览器选择* .DXF或* .DWG文件,然后从打开的DXF Import Settings对话框中配置导入选项:

  • 单位 —— 选择公制或英制单位以最佳地匹配源文件
  • 默认线宽 —— 为导入图形文件中的所有对象选择默认线宽,其中0.2mm对应于Draftsman的“正常”线宽设置。
  • 默认字体 —— 选择将用于表示源文件中任何文本的默认字体。

请注意,DXF源图形是使用Draftsman的标准图形形状对象(线、圆、矩形、文本)来构成的,因此所有单独对象均可以在Draftsman 属性Properties面板中编辑。

文档输出

可打印Draftsman文档或按Altium Designer其他基于图形的文档(原理图、PCB等)相同的方式生成作为输出文件。将新的Draftsman文档(一旦保存)自动添加到相关的PCB项目,因此,可用于所有正常文档生成和打印过程。

打印或导出为PDF

要打印目前激活的绘图文档,选择从主菜单(或Ctrl+PFile » Print,并以正常方式选择打印选项。对于Draftsman文档,打印对话框包括带页面导航选择器的可扩展打印预览。

要将绘图文档导出为单个或多个PDF文件(按文档结构的规定),从主菜单选择File » Export to PDF

添加到Outjob

通过首次打开现有输出作业文件或创建新的输出文档—File » New » Output Job File将Draftsman绘图文档添加到Outjob。

要将Draftsman添加到输出作业文件,在Documentation Outputs部分下选择Add New Documentation选项并选择PCB Drawing。通过选择集合选项然后检查绘图文档相关的启用选项将新添加的输出文件(*.PCBDwF)指定为PDF输出。

安装和优选设置

在Altium Designer中通过Draftsman软件扩展启用Altium Draftsman PCB绘图能力,与其他软件扩展的方式(如Vault Explorer)一样,其可与Altium Designer一同自动安装。

要手动安装扩展,选择Extension Manager(DXP » Extensions and Updates)中Purchased选项卡并定位Draftsman扩展。点击其 图标以下载和安装扩展,然后重启Altium Designer以启用软件的所有功能。

一旦安装,新版本可用于下载时,Draftsman图标也将出现在Updates选项卡(Extensions & Updates以下)中。 一旦安装,新版本可用于下载时,Draftsman图标也将出现在Updates选项卡(Extensions & Updates以下)中。

一旦安装和准备使用,Extension Manager的Installed选项卡下将出现扩展。原理图或PCB项目文档打开时,可提供Draftsman绘图功能,包括创建新Draftsman文档文件的能力。

如果您更希望Draftsman扩展不与Altium Designer的更新一同自动安装,取消选中Extension Manager的Configure Platform页面—–DXP » Extension and Updates, Installed选项卡Configure链接中的Draftsman扩展选项。点击 确认更改。注意配置更改也将卸载Draftsman扩展。

 

优选设置

Altium Designer的Preferences对话框的Draftsman部分可提供扩展的优选设置(DXP » Preferences)。

Draftsman优选设置的Primitives Defaults页面允许为放置在Draftsman文档中的图纸和对象配置默认值和设定值。一旦将对象或视图放置在文档中,可在Draftsman Properties面板中对这些默认设定值进行覆盖。

Draftsman优选设置的设定值确定视图及放置在PCB文档上的对象的默认配置—这些会受到Draftsman Properties面板中进行的更改的影响。 Draftsman优选设置的设定值确定视图及放置在PCB文档上的对象的默认配置—这些会受到Draftsman Properties面板中进行的更改的影响。

Preferences对话框中Draftsman - 模板页面用于定义Draftsman 图纸和文档模板的位置。

Draftsman - 模板参数页面用于定义Draftsman模板的位置。 Draftsman - 模板参数页面用于定义Draftsman模板的位置。

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: