Altium NEXUS Documentation

RotateSelectedObjects

Created: September 26, 2017 | Updated: July 17, 2018

Parent page: PCB Commands

The following pre-packaged resource, derived from this base command, is available:


Applied Parameters: None

Summary

This command is used to rotate selected objects in the workspace counterclockwise or clockwise and by a specified angle of rotation.

Access

This command can be accessed from the PCB Editor and PCB Library Editor when configured in 2D Layout Mode by:

  • Choosing the Edit » Move » Rotate Selection command from the main menus.
The current viewing mode for the PCB document (or PCB Library document) can be changed using the corresponding commands from the main View menu. To switch to 2D Layout Mode, use the command of the same name or use the 2 keyboard shortcut.

Use

Ensure that only the objects you wish to rotate are selected in the main design workspace.

After launching the command, the Rotation Angle (Degrees) dialog will open. Enter the required angle of rotation from 0.001° to 360.00°. Enter a positive value for counterclockwise rotation or a negative value for clockwise rotation. Click OK to close the dialog then position the cursor and click to define the reference point for rotation. The selected objects will be rotated about the reference point by the entered angle.

Tips

  1. The Undo command can be used to restore the rotated selection.


Applied Parameters: None

Summary

This command is used to rotate selected objects in the workspace counterclockwise or clockwise and by a specified angle of rotation.

Access

This command can be accessed from the PCB Editor and PCB Library Editor when configured in 2D Layout Mode by:

  • Locating and using the Rotate Selection command on the Active Bar.
Click and hold on the active button to access a menu of all associated commands for that grouping. If the command has been recently used from the Active Bar, it will become the active/visible button. When other commands are available it is indicated by a triangle at the bottom-right corner of the button. 
The current viewing mode for the PCB document (or PCB Library document) can be changed using the corresponding commands from the main View menu. To switch to 2D Layout Mode, use the command of the same name, or use the 2 keyboard shortcut.

Use

Ensure that only the objects you want to rotate are selected in the main design workspace.

After launching the command, the Rotation Angle (Degrees) dialog will open. Enter the required angle of rotation, from 0.001° to 360.00°. Enter a positive value for counterclockwise rotation or a negative value for clockwise rotation. Click OK to close the dialog then position the cursor and click to define the reference point for rotation. The selected objects will be rotated about the reference point by the entered angle.

Tips

  1. The Undo command can be used to restore the rotated selection.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: