Altium NEXUS Documentation

InsertObject

Modified by Susan Riege on Jan 22, 2019

Parent page: WorkspaceManager Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: ObjectKind=Netlist|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Netlist Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Netlist Outputs sub-menus.
  • From the menus associated with the [Add New Netlist Output] control, at the bottom of the Netlist Outputs region, in the main job configuration window.
Each sub-menu relates to a specific format of netlist, n, while each entry on a netlist format sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Netlist Output, with chosen Data Source, will be added to the bottom of the list of Netlist Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Simulator|Index=n|DataSource=m (n=1-20, m=1-99)

Summary

This command is used to add the indicated Simulator Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Simulator Outputs sub-menus.
  • From the menus associated with the [Add New Simulator Output] control, at the bottom of the Simulator Outputs region, in the main job configuration window.
Each sub-menu relates to a specific simulator, n, while each entry on a simulator sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Simulator Output, with chosen Data Source, will be added to the bottom of the list of Simulator Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Documentation|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Documentation Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Documentation Outputs sub-menus.
  • From the menus associated with the [Add New Documentation Output] control, at the bottom of the Documentation Outputs region, in the main job configuration window.
Each sub-menu relates to a specific type of document, n, while each entry on a document type sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Documentation Output, with chosen Data Source, will be added to the bottom of the list of Documentation Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Assembly|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Assembly Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Assembly Outputs sub-menus.
  • From the menus associated with the [Add New Assembly Output] control, at the bottom of the Assembly Outputs region, in the main job configuration window.
Each sub-menu relates to a specific type of assembly output, n, while each entry on an assembly output type sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Assembly Output, with chosen Data Source, will be added to the bottom of the list of Assembly Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Fabrication|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Fabrication Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Fabrication Outputs sub-menus.
  • From the menus associated with the [Add New Fabrication Output] control, at the bottom of the Fabrication Outputs region, in the main job configuration window.
Each sub-menu relates to a specific type of fabrication output, n, while each entry on a fabrication output type sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Fabrication Output, with chosen Data Source, will be added to the bottom of the list of Fabrication Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Report|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Report Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Report Outputs sub-menus.
  • From the menus associated with the [Add New Report Output] control, at the bottom of the Report Outputs region, in the main job configuration window.
Each sub-menu relates to a specific type of report, n, while each entry on a report type sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Report Output, with chosen Data Source, will be added to the bottom of the list of Report Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Validation|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Validation Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Validation Outputs sub-menus.
  • From the menus associated with the [Add New Validation Output] control, at the bottom of the Validation Outputs region, in the main job configuration window.
Each sub-menu relates to a specific type of validation, n, while each entry on a validation type sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Validation Output, with chosen Data Source, will be added to the bottom of the list of Validation Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Export|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Export Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Export Outputs sub-menus.
  • From the menus associated with the [Add New Export Output] control, at the bottom of the Export Outputs region, in the main job configuration window.
Each sub-menu relates to a specific export format, n, while each entry on an export format sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Export Output, with chosen Data Source, will be added to the bottom of the list of Export Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=PostProcess|Index=n|DataSource=m (n=1-20, m=1-99)

Summary

This command is used to add the indicated Post Process Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Post Process Outputs sub-menus.
  • From the menus associated with the [Add New PostProcess Output] control, at the bottom of the PostProcess Outputs region, in the main job configuration window.
Each sub-menu relates to a specific post process type, n, while each entry on a post process type sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Post Process Output, with chosen Data Source, will be added to the bottom of the list of PostProcess Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=OutputMedium|Index=n (where n is in the range 1 to 20)

Summary

This command is used to add the indicated output container to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Output Medium sub-menu.
  • From the menu associated with the [Add New Output Container] control, at the bottom of the Output Containers region, in the main job configuration window.

Use

After launching the command, the indicated output container will be added to the bottom of the list of containers, in the Output Containers region within the main job configuration window.

The output container will initially be added with all configuration options set to defaults. Rename the new container and/or configure its setup as required.

Tips

  1. An output container can be configured through its associated settings dialog. Quick access to this dialog can be made simply by double-clicking on the container's entry, or by clicking the Change control, at the top-right of the container. Alternatively, right-click on the output container's entry, and choose the Properties command from the context menu.


Applied Parameters: ObjectKind=PrintJob|Index=n (where n is in the range 1 to 20)

Summary

This command is used to add the indicated print job to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Print Job sub-menu.
  • From the menu associated with the [Add New Print Job] control, at the bottom of the Hard Copy region, in the main job configuration window.

Use

After launching the command, the indicated print job will be added to the bottom of the list of print jobs, in the Hard Copy region within the main job configuration window.

The print job will initially be added with all configuration options set to defaults. Rename the new job and/or configure its setup as required.

Tips

  1. A print job can be configured through the Printer Configuration dialog. Quick access to this dialog can be made simply by double-clicking on the job's entry, or by clicking the Change control, at the top-right of the job. Alternatively, right-click on the print job's entry, and choose the Properties command from the context menu.


Applied Parameters: ObjectKind=OutputDuplicate

Summary

This command is used to make an identical copy (duplicate) of the selected output, in the active Output Job Configuration file. This enables you to quickly define a new output that may differ only slightly from an existing one.

Access

With the required output selected, this command can be accessed from the Output Job Editor by:

  • Choosing the Edit » Duplicate command, from the main menus.
  • Clicking the  button on the Job Manager Toolbar toolbar.
  • Using the Ctrl+D keyboard shortcut.
  • Right-clicking on the entry for the output and choosing the Duplicate command from the context menu.
This command can only be used to duplicate an individual selected output. If multiple outputs are selected, the command will be grayed-out.

Use

First, ensure that the output that you wish to duplicate is selected in the main job configuration window.

After launching the command, the duplicate output will be created and added to the bottom of the associated outputs list. It will have a default name in the format Copy of <NameofOriginal>. Edit the name and configuration of this new output as required.


Applied Parameters: ObjectKind=Project

Summary

This command is used to add one or more existing design documents to the active project.

Access

This command is accessed from the active document's editor by choosing the Project » Add Existing to Project command, from the main menus.

Use

First, ensure that the project to which you wish to add documents to, is made active. Do this by opening one of its source documents as the active document in the main design window.

After launching the command, the Choose Documents to Add to Project dialog will appear. Navigate to, and select, the document(s) that you wish to add, and click Open. The selected documents will be added to the project, and the Projects panel will be updated accordingly.

Tips

  1. The project will be marked as modified. A modified project is flagged by an asterisk suffix next to its entry in the Projects panel.


Applied Parameters: ObjectKind=FocusedProject

Summary

This command is used to add one or more existing design documents to the focused project.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required project and choosing the Add Existing to Project command, from the context menu.

Use

First, ensure that the project to which you wish to add documents to, is focused the Projects panel.

After launching the command, the Choose Documents to Add to Project dialog will appear. Navigate to, and select, the document(s) that you wish to add, and click Open. The selected documents will be added to the project, and the Projects panel will be updated accordingly.

Tips

  1. The project will be marked as modified. A modified project is flagged by an asterisk suffix next to its entry in the Projects panel.


Applied Parameters: ObjectKind=FocusedDocument

Summary

This command is used to add a currently open free document to the active project.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required free document, and choosing the Add to Project <ActiveProjectName> command from the context menu.

Use

First, ensure that the project to which you wish to add the free document to, is made active. Do this by opening one of its source documents as the active document in the main design window.

After launching the command, the free document will be added to the active project, and the Projects panel updated accordingly.

Tips

  1. You can also drag-and-drop a free document into any open project in the Projects panel. Similarly, you can drag-and-drop any document between open projects in the panel.


Applied Parameters: ObjectKind=DatabaseLink

Summary

This command is used to add a new component record to the currently selected table in the active DbLib/SVNDbLib file.

Access

This command is accessed from the Database Library Editor, and SVN Database Library Editor, by right-clicking within the Table Browser tab, and choosing the Add New Component command, from the context menu.

Use

First, ensure that the database table, to which you wish to add a new component, is selected in the Tables region of the main document window. Also, ensure that the Table Browser tab is the active tab.

After launching the command, the New Component dialog will appear. The dialog lists all of the fields defined in the parent database table. You now need to define the component, by supplying information for each of these fields if/as required. Simply click on a Field Value entry to edit it. After defining values for all required fields, click OK - the new component will be committed to the table in the external database, and reflected back on the Table Browser tab.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 免费试用
Altium Designer Free Trial
我们开始吧!首先,您或者您的公司已经在使用Altium Designer了吗?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

既然您在使用Altium Designer,为何仍需要试用?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,实际上您无需下载一个试用版本。

点击下方按钮下载最新版本的Altium Designer安装包

下载Altium Designer 安装包

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

填写下方表格,获取Altium Designer最新报价。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

如果您是Altium维保期内客户,您不需要下载试用版本。

如果您不是Altium维保客户,请填写下方表格免费试用。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

您为何想要试用Altium Designer?

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

那您来对地方了!请填写下方表格申请试用吧。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。

好棒!创作是一件超酷的事情,我们可以为您提供完美的设计软件。

Upverter是一个社区导向的交流平台,专为您这样的创客量身定做。

点击这里看看吧!

如果您有任何需求,请点击这里联系获取当地办公室销售代表联系方式。.
Copyright © 2019 Altium Limited

好的,您可以下载免费的Altium Designer Viewer查看文档,有效期6个月。

请填写下方表格申请。

点击[获取免费试用],并同意我们的隐私政策。您会接收到来自Altium的资讯,并允许其改变您的通知首选项。