Altium Designer Documentation

Altium Designer UI - FAQs

Modified by Jason Howie on Jan 4, 2018
All Contents

Parent page: A Fresh User Interface

Altium Designer 18.0 delivers on a comprehensive review of the user interface, and the experience of using that interface. The interface is fresher, more logical, and also streamlined - enabling you reach your optimal productivity quickly and efficiently, without sifting through countless menus, toolbars and dialogs. Features that were seldom used, legacy, or redundant, have been cut loose, and options for documents and their objects are now defined through a single Properties panel. In effect, an interface that has undergone a quantum refurbishment, resulting in a design environment that is cleaner, leaner, and more visually appealing - with all the powerful features and functionality you have come to rely on, made ever more accessible.

This page collates a number of frequently asked questions relating to the new UI, fed back by you, our Beta Users.

For a detailed look at the changes brought about by the new user interface, take a look at the document A Fresh User Interface.

General

It is not possible to change the color theme, however changes will continue to be made to the icons and other elements to improve the contrast levels.

The Active Bar can be disabled through the Advanced Settings dialog accessed through the System - General Preferences dialog. As with other menus and toolbars, the Active Bar can be customized via the Customizing Editor dialog – note that the Active Bar entries will dock to the top menu bar during this process.

This area will be used to display various types of notifications, such as product updates, in a single go-to point, rather than popping up dialogs.

This functionality will be implemented in the next update.

You can access the License Management page, Extensions and Updates page, and Preferences dialog using the buttons towards the top-right of the application.

For more details, see the section DXP Menu Removed on the page A Fresh User Interface.

These have been removed - replaced by the new Properties panel.

The Selection Memory menus and shortcuts are still available.  Use the Ctrl+Q shortcut to open the dialog.

This functionality is currently not possible. It will be restored in a future build.

Yes - use the commands available on the File » Recent Design Workspaces sub-menu. This menu can also be accessed by right-clicking on the active workspace (*DsnWrk) in the Projects panel.

You can run most processes directly through the search box (at the top-right of the application). Currently you can only open the Process Browser dialog when in menu\toolbar Customization.

This has been renamed Duplicate, but still uses the Ctrl+R keyboard shortcut.

This is likely to be due to the current configuration of the Selection Filter - accessed and defined through the Properties panel, when no objects are currently selected in the design workspace. Try resetting the filter - to allow all object types to be selected - by clicking the All Objects button.

Absolutely - and the applicable panel can be accessed from the Schematic Editor, Schematic Library Editor, PCB Editor, and PCB Library Editor by clicking the Panels button at the bottom-right of the main application window then choosing the respective entry from the menu.

When using Microsoft Access as the backend database for your components, there is one important difference between using 32-bit and 64-bit versions of Altium Design Software:

  • 64-bit Altium Design Software (Altium Designer 18.0 and later; Altium NEXUS) - requires 64-bit Microsoft Access Database Engine to be able to use MS Access DbLibs.
  • 32-bit Altium Design Software (Altium Designer 17.1 and earlier) - requires 32-bit Microsoft Access Database Engine to be able to use MS Access DbLibs.

Typically, the appropriate version of Microsoft Office would be installed, of which Access is a constituent part. However, it is likely that many users will have both 32-bit and 64-bit versions of Altium Design Software running on the same computer. The issue is that Microsoft does not officially support, nor endorse, the coexistence of both 32-bit and 64-bit Office applications and drivers on the same computer. For information on three possible solutions, see Using Database Libraries with 32-bit and 64-bit Altium Design Software on the same Computer.

Use the following temporary workaround while a solution is sought with 3DConnexion:

  1. If it exists, remove the file X2.EXE.xml from the \Users\<ProfileName>\AppData\Roaming\3Dconnexion\3DxWare\Cfg folder.
  2. Edit the file AltiumDesigner.xml (in the \Program Files\3Dconnexion\3DxWare\3DxWinCore64\Cfg folder), by adding the X2 executable to the <Signature> section as shown below:

Solution from 3DConnexion:

  1. Download and unzip the AltiumDesignerX2.xml.zip file.
  2. Stop the driver: 3DxService.exe.
  3. Copy the AltiumDesignerX2.xml driver configuration file to the same location as the original AltiumDesigner.xml driver configuration file (in the \Program Files\3Dconnexion\3DxWare\3DxWinCore64\Cfg folder).
  4. Restart the driver: 3DxService.exe.

After following this procedure, the driver should identify X2.exe as expected.

While the Clear command has indeed been removed, its functionality has been refactored into the existing Delete command, available as before from the Edit menu. The Delete command now functions in two modes, catering for whether or not object(s) are currently selected in the workspace.

After launching the command, what happens next depends on whether object(s) are currently selected in the workspace:

  • Object(s) currently selected - the selection will be removed from the document.
  • No object(s) currently selected - the cursor changes to a crosshair and you will enter object deletion mode. Simply position the cursor over an object and click or press Enter to delete it. Continue deleting further objects, or right-click, or press Esc, to exit object deletion mode.

Schematic-only

Select a placed No ERC object in the workspace to open the Properties panel in No ERC mode. Under the Suppressed Violations region of the Properties panel, click Specific Violations then click the Add button to open the No ERC dialog which allows you to specify violation types.

While the Hyperlink object has been removed, its functionality has been absorbed into the Text String object - use the URL field of the Properties panel.

PCB-only

This functionality is now located on the View Options tab of the View Configuration panel in the General Settings region (when 3D is set to On).

The information for the active PCB that used to be presented in the PCB Information dialog (Reports » Board Information) can now be found in the Board Information section of the Properties panel - available as part of the options for the board when no design object is currently selected in the design workspace.

Guides are now defined and managed through the Guide Manager section of the Properties panel in Board mode when no objects are selected in the design workspace.

These options are now available through the Snap Options section of the Properties panel in Board mode when no objects are selected in the design workspace.

The mask-related slider controls are now available through the Mask and Dim Settings section, on the View Options tab of the View Configuration panel.

This functionality is located on the View Options tab of the View Configuration panel in the General Settings region.

No longer available from the main View menu. This is now in the Additional Options region of the View Configuration panel. The F5 keyboard shortcut is still available.

32 - the same as was available in previous versions of the software.

In relation to the use of embedded components, the Flipped on layer property has been removed from a component's properties in Altium Designer 18.0. The approach now is to define the component orientation for the layer, in the Layer Stack Manager dialog. Choose to have the components oriented toward the Top or Bottom of the board. This setting will then be applied for all components on that layer.

Note that using the X or Y keyboard shortcuts while placing or moving a component simply mirror that component's geometry about the X- or Y-axis. This does not perform the same action as the now-removed Flipped on layer property.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.


Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.