Altium Designer Documentation

A Fresh User Interface

Modified by Phil Loughhead on Oct 17, 2018

Contents

All Contents
Altium Designer 18.0 is a major update to one of the world's most popular electronic product design environments. This release not only includes a broad range of new and improved features, there also has been a major focus on optimizing the productivity of the designer.
 

Altium Designer 18.0 delivers productivity improvements through:

  • Substantial performance improvements - computationally intensive tasks, such as an ActiveRoute of 100 nets and analyzing a complex ground net, are significantly faster. 
  • Enhanced responsiveness allows greater fluidity when rotating and zooming your 3D PCB. 
  • Comprehensive review of the user interface and the experience of using that interface.

Altium Designer 18.0 also presents an entirely new look and feel that will enhance your board design experience. From the color scheme of the main editors, to the new and more comprehensive panels, to a quicker route to your Preferences and managed content server, this updated version of Altium Designer gives you more streamlined ways to work as you build your designs.

A few of the changes include:

  • A new color scheme. Altium Designer now presents with a dark background, with lighter text. Studies have shown that, while a text-oriented interface generally works best with dark text on a light background, an image-intensive interface is better for the eyes with light content on a dark background.
  • The new Properties panel removes the need for object dialogs in editors and therefore makes placing and editing objects much quicker and easier. The new panel also brings in parent and child properties into one streamlined access point.
  • A new Active Bar provides placement controls for PCB, schematic, Draftsman, and library documents at your fingertips. 
  • Panels and Preferences have been streamlined by eliminating some elements that are not often utilized.
  • The Vaults panel has been retitled the Explorer panel.

The purpose of this document is to provide an overview of the key user interface changes found in Altium Designer 18.0. Detailed information regarding new features and functionality in this release, as well as enhancements and improvements to existing features, will be covered in other documents. This document discusses the improved user interface and the benefits it brings. Read on to explore the key changes to the software's appearance - changes that collectively reinvigorate the design workspace and enhance your design productivity.

New Color Theme

We have changed the overall color theme of Altium Designer to a charcoal background. This new theme allows for a more defined workspace. Panels and some dialogs have been given the new color theme as well. 


The new Altium Designer workspace

      The new Altium Designer panels color scheme (Projects panel and PCB List panel shown as examples)


The new color scheme has been applied to some dialogs (Project Options shown as an example).

Menu Changes

DXP Menu Removed

The DXP menu has been replaced with buttons and commands that quickly get you to where you want to go by relocating common-used elements to a more easily accessible and standard location. The significant changes are explained in the following sections.

My Account Page Renamed License Management

The My Account page, which is used to configure your license usage for Altium Designer, has been renamed License Management to more appropriately describe the use of the page.

Accessing Preferences

Altium Designer Preferences are easily accessible using by clicking the  button located in the upper-right corner of the workspace as shown in the following images. 

Click the highlighted control to access Preferences


Access to Altium Designer Preferences

Accessing License Management

Access the License Management page by clicking the drop-down in the upper-right corner of the workspace then selecting License Management as shown in the following images. 


Click the highlighted drop-down then click License Management to access the License Management page. 

Accessing the License Management age.

Accessing Extensions & Updates 

Access the Extensions & Updates page by clicking the drop-down in the upper-right corner of the workspace then selecting Extensions and Updates as shown in the following images.

Click the highlighted drop-down then click Extensions and Updates to access the Extensions & Updates page

Accessing the Extensions & Updates page. 

Accessing a Managed Content Server

Signing In/Out of a Managed Content Server​

Sign into a managed content server by using the drop-down in the upper-right corner of the workspace then selecting Sign in as shown in the following image. 


Signing into a server.

When you are signed into a server, the upper-right corner of the workspace displays your account credentials as shown in the following image.


Account credentials are displayed when you are signed into a server.

To sign out of a server, use the drop-down located in the upper-right corner of the workspace, then select Sign out as shown in the following image.


Signing out of a server.

Managed Content Server Access

Once signed into a managed content server, you now can access the newly-named Explorer panel by using the drop-down in the upper-right corner of the workspace then selecting your managed content server.

The Explorer panel is also accessible by clicking the Panels tab at the bottom-right of the workspace then clicking Explorer.

Accessing Altium Forums

Altium Forums, where you can discuss and ask questions about the use and workings of Altium Designer as well as offer feedback, now are accessible by clicking Help » User Forums from the main menus as shown in the following image.


Accessing User Forums

Accessing Search 

The Search function is now located in the upper-right corner of the workspace as shown in the following image.

 Location of the Search function. 

Additional Commands

  • The Customize command now is available by right-clicking in the menu bar.
  • The Run Process command was removed due to low usage.

Removed Schematic Main Menu Commands

The following is a list of schematic commands that have been removed along with the rationale for removal. In some cases, the command's functionality has been relocated to a panel, etc., which also is explained below.

  • Design » Add/Remove Library - functionality located in the Libraries panel.
  • Design » Document Options menu - located in the Properties panel when no objects are selected.
  • Edit » Change - superseded by selecting one or more objects to edit in the Properties panel.
  • Edit » Clear - low usage.
While the Clear command has indeed been removed, its functionality has been refactored into the existing Delete command, available as before from the Edit menu. The Delete command now functions in two modes, catering for whether or not object(s) are currently selected in the workspace:
Object(s) currently selected - the selection will be removed from the document.
No object(s) currently selected - the cursor changes to a crosshair and you will enter object deletion mode. Simply position the cursor over an object and click or press Enter to delete it. Continue deleting further objects, or right-click, or press Esc, to exit object deletion mode.
  • Edit » Duplicate - redundant with Rubber Stamp command.
  • Edit » Rubber Stamp - rebadged Duplicate.
  • File » Link Sheet to Vault - superseded by direct editing paradigm.
  • File » Release Manager - superseded by direct editing paradigm.
  • Place » Manual Junction - not required as auto-junctions are added automatically.
  • Place » Hyperlink - this functionality is now part of the Text String object.
  • Place » Directives » PCB Layout - low usage.
  • Place » Directives » Net Class - can now be done using the generic Place » Directives » Parameter Set command.
  • Place » Directives » Stimulus - low usage.
  • Place » Directives » Test Vector Index - low usage.
  • Place » Directives » Probe.
  • Place » Directives » Instrument Probe.
  • Place » Drawing Tools » Pie Chart - low usage.
  • Place » Drawing Tools » Elliptical Arc - low usage.
  • Place » Notes » Ellipse - low usage.
  • Place » Notes » Rectangle - low usage. 
  • Place » Notes » Polygon - low usage. 
  • Tools » NoERC Manager - low usage.
  • Tools » Harness Definition Problem Finder - low usage.

Removed PCB Main Menu Commands

The following is a list of PCB commands that have been removed along with the rationale for removal. In some cases, the command's functionality has been relocated to a panel, etc., which also is explained below.

  • Edit » Build Query (Shift+B) - low usage; functionality available when working with Rules and Filters.
  • Edit » Clear - low usage.
While the Clear command has indeed been removed, its functionality has been refactored into the existing Delete command, available as before from the Edit menu. The Delete command now functions in two modes, catering for whether or not object(s) are currently selected in the workspace:
Object(s) currently selected - the selection will be removed from the document.
No object(s) currently selected - the cursor changes to a crosshair and you will enter object deletion mode. Simply position the cursor over an object and click or press Enter to delete it. Continue deleting further objects, or right-click, or press Esc, to exit object deletion mode.
  • Edit » Change - low usage.
  • Edit » Rubber Stamp - renamed Duplicate.
  • Place » Coordinate - replaced by tools in Draftsman.
  • View » Net Color Override - now accessible in the Additional Options section on the View Options tab of the View Configuration panel. 

  • Tools » Component Placement » Auto Placer - deprecated technology.
  • Tools » Component Placement » Stop Auto Placer - deprecated technology.
  • Tools » Component Placement » Shove - deprecated technology.
  • Tools » Component Placement » Shove Depth - deprecated technology.
  • Tools » Density Map - deprecated technology.
  • Tools » Grid Manager - grids are now defined in the Grid Manager section of the Properties panel in Board mode (when no objects are selected).

  • Tools » Guide Manager - guides are now defined in the Guide Manager section of the Properties panel in Board mode (when no objects are selected).

  • Tools » Legacy Tools - superseded by newer tools.
  • Design » Board Layers & Colors - functionality now available in the View Configuration panel. 
  • Design » Board Options menu - some options have been moved to the Properties panels or removed due to replacement by Draftsman capabilities.
  • Reports » Board Information - presented in the Board Information section of the Properties panel in Board mode (when no objects are selected).

File Menu 

The File menu accessed from the main menus has been streamlined to include only commands that are specific to files.

Example of File menu for a schematic document.

Streamlined Project Creation Commands

The new sub-menu for creating a new project (accessed by clicking File » New » Project) has been reorganized and made more concise to  display the available main types of projects. The selections include:

  • PCB Project - select to create a new PCB project. A new PCB_Project.PrjPCBd entry appears in the Projects panel.
  • Multi-board Design Project - select to create a new multi-board project. A new MultiBoard_Project.PrjMbd entry appears in the Projects panel.
  • Integrated Library - select to create a new integrated library project. A new Integrated_Library.LibPkg entry appears in the Projects panel.
  • Project - when this option is selected, the New Project dialog opens in which you can specify the details of your new project. 

New File Types Than Can Be Created

  • Multi-board Schematic (*.MbsDoc) - available when a multi-board project is the active document.
  • Mutli-board Assembly (*.MbaDoc) - available when a multi-board project is the active document.

New File Types Removed

  • Text Document (*.txt)
  • Component Library (*.CmpLib)
  • PCB3D Library (*.PCB3DLib) - superseded by the powerful 3D editing environment.
  • Java Script Unit (*.js)
  • Java Script Form (*.js)
  • TCL Script Unit (*.tcl)
  • Enable Basic Script Unit (*.bas)
  • VB Script Unit (*.vbs)
  • VB Script Form (*.vbs)
Although it is no longer possible to create the above listed file types through the File » New command, the files still can be edited if used in previous designs.

Right-click Menu Changes

Right-click context menus in the schematic and PCB editing domains have been cleaned up and streamlined to leave only the commands you really need.

          
Right-click menu from a negative space area in a schematic (left menu) and a PCB (right menu), for Altium Designer 17 (light menus) and Altium Designer 18 (dark menus).

Removed Schematic Right-click Menu Commands

  • Refactor
  • Grid
  • View
  • Workspace Panels
  • Find Component
  • Place Part
  • Options
Removed Wire Right-click Menu Commands
  • Wire
  • Bus Entry
  • Break Wire

Removed Bus Right-click Menu Commands

  • Bus
  • Bus Entry
  • Break Wire

Removed Signal Harness Right-click Menu Commands

  • Break Wire

Added Schematic Right-click Menu Commands 

  • Project Options - opens the Project Options dialog.
  • Preferences - opens the Preferences dialog.

Changes to Preferences

New Preferences Pages

Data Management - Servers 

You can use the Data Management - Servers Preferences page to configure current managed content server usage and project release options.


The Data Management - Servers page of the Preferences dialog

Data Management - Component Rule Checks 

The Data Management - Component Rule Checks Preferences page is used to configure component error reporting.


The Data Management - Component Rule Checks page of the Preferences dialog

Multi-board Schematic - Defaults

The Multi-board Schematic - Defaults Preferences page is used to configure the primitive defaults for multi-board schematics.


The Multi-board Schematic - Defaults page of the Preferences dialog (showing Text selected)

Multi-board Assembly - General

The Multi-board Assembly - General Preferences page is used to configure what is to be imported from the PCB.


The Multi-board Assembly - General page of the Preferences dialog

Multi-board Assembly - View Configuration

The Multi-board Assembly - View Configuration Preferences page is used to configure colors and display options.


The Multi-board Assembly - View Configuration page of the Preferences dialog

Updated Preferences Pages

Defaults Pages

Defaults pages have been updated to include default settings for most primitives. The below image shows the Blanket primitive of the Schematic - Defaults page as an example.


The Blanket primitive default settings region of the Schematic - Defaults page of the Preferences dialog

System - General

Hover over the image to see the previous version of the System - General Preferences page.

  • The Open Home Page if no documents open option has been removed from the Startup region.

  • The Enable debug memory manager option in the General region has been removed.

  • An Advanced button has been added that opens the Advanced Settings dialog that allows you to configure advanced settings as shown below.


The new Advanced Settings dialog

As stated in the dialog, changing these settings could cause instability in Altium Designer. Proceed with caution when making any changes. 

System - View

Hover over the image to see the previous version of the System - View Preferences page.

  • Exclusions option of the Desktop region has been removed.
  • You now can load or save or reset layouts in the Desktop region.
  • The Show Navigation Bar As region has been removed.
  • The Show full path in title bar option of the General region has been removed.
  • Favorites panel options have been removed (Favorites panel has been removed). 
  • Auto-hide the documents bar and Multiline documents bar options in the Documents Bar region have been removed.
  • A new UI Theme region has been added in which you can set the UI theme as well as see a preview of your choice.

System - Navigation

Hover over the image to see the previous version of the System - Navigation Preferences page.

  • The Masking option has been removed and now is accessed in the SCH Filter panel.
  • The Dimming option has been added along with a slider bar for dimming control.
  • The Masking option in the Cross Select Mode region has been renamed Dimming.

System - Projects Panel

Hover over the image to see the previous version of the System - Projects Panel Preferences page.

  • Under the General region, the Show open/modified status and Show Grid options have been removed.
  • The Grouping region has been renamed Documents Grouping. The options remain the same.
  • The Structure View region has been removed.
  • A new region named Components Grouping has been added. The options in this region allow you to group components by designator, comment, or the owner sheet or not group at all.

System - New Document Defaults

Hover over the image to see the previous version of the System - New Document Defaults Preferences page.

  • FPGA-related document defaults have been removed.

Data Management - Version Control

Hover over the image to see the previous version of the Data Management - Version Control Preferences page.

  • The CVS - Concurrent Versions System Provider has been removed.

Data Management - Parts Providers

Hover over the image to see the previous version of the Data Management - Parts Providers (Suppliers) Preferences page.

  • The title of the Data Management - Suppliers Preferences page has been changed to Data Management - Parts Providers to align with the Altium Parts Providers extension.
  • In the Altium Parts Options region, the Move Up/Down and Filter options have been removed.

Schematic - General

Hover over the image to see the previous version of the Schematic - General Preferences page.

  • Units options have been added (previously on the Schematic - Default Units page). Options are Mils or Millimeters only.

Schematics previously created in Imperial units will be opened in Mils; schematics previously created in Metric units will be opened in Millimeters.

  • The No-ERC Markers and Notes options have been removed from the Include with Clipboard options. Those items will be included with the clipboard by default if the parent item is enabled (checked).
  • The Document scope for filtering and selection option has been removed since the current document is selected by default.

Schematic - Graphical Editing

Hover over the image to see the previous version of the Schematic - Graphical Editing Preferences page.

  • The Convert Special Strings option has been removed since the string is always displayed; if null, then the parameter name is displayed.
  • A Display Names of Special Strings that have No Value Defined option has been added. You can select the color for these strings in the Color Options region in the Special Strings with No Value option.
  • The Double Click Runs Inspector option has been removed (as a result of Inspector panels being removed).
  • An Enable Auto Pan option has been added to the Auto Pan Options region.
  • The Undo/Redo region has been removed. The option can now be configured through the Value and Default Value settings of the Schematic.UndoStackSize options under Preference Name in the Advanced Settings dialog (accessed by clicking the Advanced button on the System - General Preferences page).  

Schematic - Compiler

Hover over the image to see the previous version of the Schematic - Compiler Preferences page.

  • Manual Junctions Connection Status options have been removed.
  • The Dim level for read-only objects in compiled documents tabs slider bar has been removed. (A Dimming control for the Schematic Editor tab is located on the System - Navigation page of the Preferences dialog.) 

Schematic - AutoFocus

Hover over the image to see the previous version of the Schematic - AutoFocus Preferences page.

  • The Dim Level slider bar in the Dim Unconnected Objects region has been removed.

Schematic - Grids

Hover over the image to see the previous version of the Schematic - Grids Preferences page.

  • Snap Distance has been added.
  • Electrical Grid has been removed.

PCB Editor - General

Hover over the image to see the previous version of the PCB Editor - General Preferences page.

  • The Double Click Runs Inspector option has been removed (as a result of Inspector panels being removed).
  • The Undo/Redo options in the Other region have been removed. The option can now be configured through the Value and Default Value settings of the PCB.UndoStackSize options under Preference Name in the Advanced Settings dialog (accessed by clicking the Advanced button on the System - General Preferences page).  
  • An Enable Auto Pan option has been added to the Autopan Options region. If enabled, when you are performing any editing action and the cross-hair cursor is active, moving the cursor past any edge of the document view window will cause the document to pan in the relevant direction. 

  • A new option to Repour all dependent polygons after editing has been added in the Polygon Rebuild region.

  • In the Collaboration region, the DXP App Server option has been removed.

PCB Editor - Display

Hover over the image to see the previous version of the PCB Editor - Display Preferences page.

  • Default PCB View Configurations and 3D Bodies options have been removed. Configurations and 3D bodies are now displayed depending on the General Settings options on the View Options tab of the View Configuration panel. 

  • The Flyover Zoom, Alpha Blending, and Ordered Blending options have been removed.
  • You now can use the Antialiasing On/Off option to enable/disable 3D anti-aliasing.
  • The Layer Drawing Order region has been added to specify the layer order.

PCB Editor - Board Insight Display

Hover over the image to see the previous version of the PCB Editor - Board Insight Display Preferences page.

  • The Live Highlighting options are now more concise. Enable Live Highlighting only when Shift Key Down to enable live highlighting when holding down the Shift key.

PCB Editor - DRC Violations Display

Hover over the image to see the previous version of the PCB Editor - DRC Violations Display Preferences page.

  • The Show Violation Detail region has been removed.

Removed Preferences Pages

  • System - Altium Vault - options are now located on the new Data Management - Servers Preferences page.
  • System - Desktop Layouts -  options are more intuitive using the View menu.
  • Data Management - Vaults - options are now located on the new Data Management - Servers Preferences page.
  • Schematic - Default Units - options are now located on the Schematic - General Preferences page.
  • PCB Editor - Board Insight Lens - low usage.
  • PCB Editor - PCB Legacy 3D - legacy item.
  • All Wave Preferences pages - low usage.

Changes to Project Options

  • Options for FPGA-related items have been removed from the Error Reporting tab due to FPGA designs having been removed from the installation. Hover the cursor over the image below to view the previous version of the Error Reporting tab.

Hover over the image to view the previous version of the Error Reporting tab with removed items marked with a red "X".

The following is a list of the items that have been removed:

  • Violations Associated with Buses region removed items:
    • Arbiter loop in OpenBus document
    • Cascaded interconnects in OpenBus document
    • Forbidden OpenBus Link
    • Mismatching Address/Data Widths of OpenBus Ports
  • Violations Associated with Code Symbols region - all items.
  • Violations Associated with Configuration Constraints region - all items.
  • Violations Associated with Documents region removed items:
    • Conflicting Constraints
    • HDL Identifier Renamed
    • Missing child HDL entity for sheet symbol
    • Missing Configuration Target
    • Missing sub-Project sheet for component
    • Multiple Configuration Targets

Panel Changes 

Panel Access

Use the Panels tab at the bottom right of the workspace to access panels that are available in the current editor (PCB, schematic, Draftsman, library, etc.,).


Access Panels using the Panels tab.

Panels also are accessible using the sub-menu commands by clicking View » Panels from the main menus.

Post-Selection Filter

A new filter tool has been added at the top-right of panels as shown in the image below.

This tool enables you to filter the information that is displayed in the open panel. Use the drop-down associated with the filter icon to access a drop-down as shown in the image below.

You can click objects in the drop-down (as shown below) and the panel will not display information for those filtered objects.

The filter can be disabled/enabled in total by clicking the filter icon itself as shown below.

New Panels

Properties Panel

     The Properties panel showing schematic Component and PCB Board configurations as examples.

The new Properties panel contains information and controls that pertain to the item currently selected in the workspace. If nothing is selected in the current workspace, when accessed from a PCB document, the panel presents board options; when accessed from a schematic document, document options are presented; library options are presented when accessed from a library document; and multi-board options are presented when accessed from a multi-board document. The panel also presents the currently active BOM document (*.BomDoc). This allows you to change general document options quickly and on-the-fly. The panel also appears when placing objects (arc, text string, wire, etc.,) on the workspace. You can use the Properties panel to configure objects before placement. The Selection Filter section allows control over what you can and cannot select in the workspace.

Placing Items

When placing an item using the Place command or the new Active Bar, you can click the Tab key after making your selection of the item to be placed to open the Properties panel in order to make any desired updates before placement. When you are ready to leave "placement mode", click the "Pause" symbol that appears on the workspace to leave placement mode.

The Search function at the top of the Properties panel (highlighted in the following image) allows you to search within the panel for desired items.

You can use the two buttons at the top-right of the Properties panel to control the contents of the panel. 

Click the  button (button on the left) to include in the Properties panel all types of objects from any open documents of the same project.

Click the  button (button on the right) to include in the Properties panel all types of objects from the current document only.

View Configuration Panel

The View Configuration panel allows you to edit and control the layers of the PCB and their associated colors and settings, and configure visibility, 3D settings, and masking. The panel also improves usability of more complex behaviors, such as layer pairs.

The View Configuration panel includes controls that allow you to configure the layers of a PCB document.

The Search function at the top of the panel allows you to search within the panel for desired items.

Enabling/Disabling Layers

You can enable or disable one layer, multiple layers, or all layers by toggling controls in each layer group as shown in the following images.  


Use the highlighted controls to enable or disable layer groups. Component Layers are shown as all enabled in this example.

Use the top control to toggle the enable/disable for the entire layer as shown in the following image.


Clicking the control highlighted will toggle the control for the entire group. All items are disabled for Component Layers in the above image.

You also can enable or disable individual items in each group by toggling the control as shown in the following image.


The highlighted individual items in the Component Layers group have been disabled.

Object Visibility

Use the Object Visibility region on the View Options tab to control the transparency of objects.

3D Settings

The 3D Settings region on the View Options tab are used to configure 3D views.

In order to access the 3D Settings region, the 3D setting in the General Settings region must be set to On as shown in the image below.

Mask and Dim Settings

Use the Mask and Dim Settings region on the View Options tab to configure masking, dimming, and highlighting settings.

Additional Options

The Additional Options regions on the View Options tab includes controls that allow you to configure various display settings including Net Color Override.

Changes to Existing Panels

Projects Panel

  • The Projects panel now includes many of the functions also located in the Navigator panel. 
  • New controls located in the upper-left of the Projects panel allow you to perform functions with one click.

Projects panel controls

  • Use the  button to save the current document. This option is available only if changes have been made to the current document.
  • Use the  button to compile the current project.
  • Use the  button to open the Project Options dialog.
  • Use the  button to access a drop-down (shown in the following image) in which you can configure panel settings.

  • The new Search function allows you to search for specific documents in the panel. The function works as a "filter" as you enter text in the Search text box.

    The new Search feature of the Projects panel (left image); showing the new Search feature in action (right image).

  • Folders for Components and Nets will display in the Projects panel after the project has been compiled.


Components and Nets folders display in the Projects panel after the project is compiled.

  • Document Status - the indicators to the right of the document name showing open and modified status have been removed.

Projects Panel Right-click Menu

The right-click menus of the Projects panel have been streamlined to include commands that are specific to the item on which the right-click is performed as described below.

  • Right-click menu for a Workspace

  • Right-click menu for a Project

  • Right-click menu for a schematic document

  • Right-click menu for a PCB document

  • You can view the Properties panels for both an open schematic document and an open PCB document at the same time. This is especially helpful when using two monitors - one monitor for the schematic and one for the PCB. The individual open Properties panels for each document allow you to make changes and view them in real-time for each document.

PCB ActiveRoute Panel


A more powerful PCB ActiveRoute panel.

The PCB ActiveRoute panel has been enhanced and made much more powerful to make your routing more comprehensive. 

SCH Filter Panel  

 

  • A slider bar has been added to the Mask out option to control the level.

Removed Panels

  • 3D Visualization - low usage.
  • Board Insight - low usage.
  • Clipboard - low usage.
  • Compiled Object Debugger - low usage.
  • Favorites - low usage.
  • Files - low usage.
  • PCB Inspector - superseded by the Properties panel.
  • PCBLIB Inspector - superseded by the Properties panel.
  • Sch Inspector - superseded by the Properties panel.
  • SCHLIB Inspector - superseded by the Properties panel.
  • Sheet - low usage.
  • Shortcuts - context sensitive shortcuts are now detailed in the Properties panel.
  • To-Do - low usage.

Object Removals

Removed Schematic Objects

  • Hyperlink - low usage. Functionality has been absorbed into Text String.
  • Elliptical Arc - low usage.
  • Manual Junction - low usage.
  • Test Vector Index Directive - low usage.
 Although it is no longer possible to place the above listed objects in the schematic editor, the objects will still exist if used in previous designs, however, the objects and their properties will not be editable. 

Removed PCB Objects

  • Coordinate
  • Design View

The following Dimension objects have been removed:

  • Baseline Dimension
  • Center Dimension
  • Datum Dimension - essentially replaced with the Ordinate dimension object.
  • Linear Diameter Dimension
  • Radial Diameter Dimension

Flipped on Layer Property Removed

The Flipped on Layer property has been removed from a component's properties. The component Orientation for the layer is now defined in the Layer Stack Manager dialog.

Controls for Working with Variants

The use of variants now is controlled through the Projects panel (the Variants toolbar has been removed). Just as before, you can access the Variant Management dialog by right-clicking on the desired project in the Projects panel then choosing the Variants command from the context menu. Define your variants as required then click OK. A Variants folder will be added to the panel for that project. The folder contains entries for the base design ([No Variations]), as well as all variants you have defined. The current variant is displayed in bold, white text as shown in the following image. To make any listed variant the current variant, you can either double-click the desired variant in the panel, or right-click the desired variant and choose Set as current.

The current variant is shown in bold, white text in the Projects panel.

Active Bar

You now can access a few commonly-used placement and routing commands using the new Active Bar. The Active Bar allows you to easily place objects in schematic, PCB, Draftsman, and library documents, and to perform routing in PCB documents with one easy click rather than using the main menus. The controls of the toolbar are dependent upon the editor in which you are currently working (examples are shown in the following images). The toolbar is displayed at the upper center of the design workspace.

When you click on a control in the toolbar, you are immediately in placement mode and the cursor changes to a cross-hair ready for placement.

To access the drop-down of a control (denoted by a small triangle in the lower-right corner of the control), right-click over the control or hover the cursor over the control then hold down the left mouse button. You can then choose any of the available options. The cursor will change to a cross-hair for placement.

After an object has been recently used from the Active Bar, that object becomes the active/visible button. 


The new Active Bar of a schematic document showing the Place Wire drop-down.


The Active Bar of a PCB document showing Place Polygon drop-down.


The Active Bar of a Draftsman document showing Line drop-down.

 


The Active Bar of a schematic library document showing Place Line drop-down.

Quick Access Bar

A Quick Access bar is located in the upper-left corner of the workspace. The bar allows quick access to often used commands, such as saving the currently focused document, opening any existing document using the appropriate button, and undo and redo functions. You also can use the  button to save all documents with one click. 

Use the Quick Access bar to quickly save and open documents, and undo or redo recent commands.

System Notifications

A new Notifications button is accessible in the upper-right corner of the workspace as shown in the following image. Click the  to access Altium Designer system notifications. The icon displays with a number when notifications are available. 


Use the Notifications button to access system notifications.

Additional GUI Changes

  • The Snap button has been removed from the PCB Editor. Snap Options are now set through the Properties panel in Board mode when no objects are selected in the workspace.


Snap Options in the Properties panel

  • Dimming for the Schematic Editor tab is now defined in the Highlight Methods region on the System - Navigation page of the Preferences dialog.

  • The Mask Level button has been removed from the PCB Editor. Masking (as well as dimming and highlighting for the PCB) is now defined in the Mask and Dim Settings region on the View Options tab of the View Configuration panel.


Mask and Dim Settings in the View Configuration panel

  • The Linked To Sheet option for mechanical layers has been removed.
  • ​The ability to hide a document(s) has been removed from the right-click menu of a document tab. 
  • The Clear button has been removed. 
  • The Home page has been removed, which, in turn, removed the Start, Workspace (often referred to as the "Sea of Documents"), Documentation, and Admin tabs. Refer to the Accessing License Management section of this document for access to information that was previously located on the Admin tab.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.


Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.