Altium Designer Documentation

Defining Board Regions and Bending Lines

Modified by Phil Loughhead on Apr 3, 2019

A Board Region is the term used to describe a user-defined area of the board that can have a unique layer stack assigned to it.

When a new board is created, it defaults to having a single board region - the outline of the board shape. If the board design requires multiple layer stacks, then you can split the single default board region into multiple regions, and assign a unique layer stack to each of those regions.

In the image below, the board shape has been divided into three distinct board regions: the upper circle, the center strip, and the lower circle. These regions have been created by placing the two horizontal dashed blue Split Lines. Note the orange dashed lines; these are bending lines since this rigid-flex design is going to be folded when it is assembled.


Note the shape has been divided into three distinct board regions, created by the two horizontal dashed blue Split Lines.

Splitting the Board into Regions

You divide a board into two regions by placing a split line. This is done with the PCB editor in Board Planning Mode.

The View menu has three PCB editor working modes with easy-to-remember shortcuts, allowing you to quickly switch between:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

The editor menus will populate with relevant commands for the respective modes. So if you are used to finding board shape commands on the Design menu and cannot see them anymore, make sure you are in the right mode!

Placing a Split Line

To place a Split Line:

  1. Select View » Board Planning Mode (or press the 1 shortcut) to enter Board Planning Mode.
  2. Select Design » Define Split Line to enter Split Line placement mode.
  3. Click within the board shape to begin the Split Line definition process. One end of the line will attach to the closest point on the board shape outline to where you clicked, the other end of the line will attach to the cursor.
  4. Position the cursor in the required location then click once to place the second end. 


A board is split into distinct regions by placing a Split Line, which runs from one edge of the board shape to another edge.


The board has been split into a number of distinct regions by placing Split Lines. Note that bending lines have also been placed.

Moving a Split Line

To move a Split Line:

  1. Select View » Board Planning Mode or press the 1 shortcut to enter Board Planning Mode.
  2. To relocate the end of a line, click, hold and drag it to the required location around the perimeter of the board shape. The cursor will be constrained to the current snap grid.

The Split Line will remain blue while dragging to a permitted location that will still result in a valid split. If the new location for the end being moved is invalid, for example on the same edge of the board shape as the anchored end, the Split Line will turn red. Attempting to place while the line is red will result in the removal of the Split Line.

Removing a Split Line

To delete a Split Line:

  1. Select View » Board Planning Mode or press the 1 shortcut to enter Board Planning Mode.
  2. Click and hold by one of its end points, then press the Delete key. Alternatively, click, hold then move an endpoint to a point around the board shape that results in the split turning red (signifying an invalid split), then release.

Assigning a Layer Stack and Editing the Board Region Name

Related article: Defining the Layer Stack

When a new board is created it will have a single region, named Default Layer Stack Region. This region will be assigned the default layer stack named Board Layer Stack.

When you split a board shape into multiple regions, each new region is also assigned the default layer stack. If the required layer stacks have been defined in the Layer Stack Manager, then each region can have its stack assigned and also can be given a meaningful name.

Each region displays a label that shows its name and the name of the layer stack assigned to it in the form Region Name - Layer Stack Name. If the layer stack is flex-enabled, this will also be indicated by (flex). Enabling the flex setting for a stack is done in the Layer Stack Manager.

To assign a layer stack and name a region:

  1. Select View » Board Planning Mode or press the 1 shortcut to enter Board Planning Mode.
  2. Double click on the board region to open the Board Region dialog.
  3. Assign the Layer Stack by selecting the required stack from the Layer stack drop-down.
  4. Edit the Name as required.
  5. Click OK to accept the settings and close the dialog.


Double-click on a board region to define the region's name and assign a layer stack.

Placing and Positioning a Bending Line

To define how a flex board should bend, you place one or more Bending Lines. The Bending Line defines where on the surface of the flex region that the bend is to take place. The Bending Line also defines the angle and radius of the bend as well as the width of the strip of board surface that is being bent. Bending Lines are placed and edited with the PCB editor in Board Planning Mode (View » Board Planning Mode, or press the 1 shortcut).

A Bending Line can only be placed on a region that is configured as a Flex region in the Layer Stack Manager.

Placing a Bending Line

To place a Bending Line:

  1. Select View » Board Planning Mode or press the 1 shortcut to enter Board Planning Mode.
  2. Select the Design » Define Bending Line command.
  3. Click inside the board region where the Bending Line is to be placed, one end of the line will attach to the edge of the region closest to the click location, the other end will attach to the cursor.
  4. Position the second end in the required location then click once to place it.
  5. You remain in Bending Line placement mode, ready to place another Bending Line if required. If not, right-click or press Esc to exit Bending Line placement mode.

The PCB panel in Layer Stack Regions mode displays Bending Lines data. Double-click on an entry to open the Bending Line dialog. 


Three Bending Lines have been placed on this flex board region. The width of the orange strip is the Affected area width.

When a board region is set to use a Flex layer stack, a Bending Line is automatically added vertically down its geometric center. Remove or reposition and configure this Bending Line as required.

Moving a Bending Line

To modify the location of an existing Bending Line:

  1. Click once to select the Board Region the contains the Bending Line. The handles for all bending lines within that region will be displayed.
  2. Click and hold on the Bending Line handle, move it to the new location, then release the mouse button.

Precisely Locating a Bending Line

When a Bending Line is moved, the handle will snap to locations on the current Snap Grid. As it is moved, it can also be snapped to existing design objects, such as lines on a mechanical layer. The image below shows a Bending Line handle being positioned on the end of a line on layer Mechanical 2 (highlighted by the number 1). Note that the mechanical layer must be the active design layer for the snap behavior to work.


The number 1 refers to a Bending Line handle being snapped to a line on Mechanical 2; note that this layer is the active layer.

To show the above process in more detail, the images below show the construction lines that have been placed on Mechanical 2 in 2D Layout Mode that accurately define upper and lower reference points that can be used to place a 45 degree Bending Line.

The board in 2D Layout Mode showing the construction lines to help accurately place the diagonal Bending Lines.

The board in Board Planing Mode showing the diagonal Bending Lines that were snapped to the construction lines on Mechanical 2.

Removing a Bending Line

To delete a Bending Line, click and hold by one of its end points then press the Delete key.

When a board region is set to use a Flex layer stack, a Bending Line is automatically added, vertically down its geometric center. Remove, or reposition and configure this Bending Line as required.

Configuring the Bending Line Properties

Board regions, Split Lines and Bending Lines are examined and edited in Board Planning Mode (press 1). Bending Lines can be edited interactively in the workspace or they can be edited via the PCB panel when it is set to Layer Stack Regions mode. To display the panel, click the PCB button on the bottom right of the workspace then select PCB from the menu. In the panel, select Layer Stack Regions in the drop-down at the top of the panel.

When entering Board Planning Mode, the PCB panel will automatically be configured to Layer Stack Regions mode.

To edit the properties of a Bending Line in the PCB panel:

  1. Bending Lines can be edited in either 2D Layout Mode (press 2) or Board Planning Mode (press 1).
  2. Enable the Select box at the top of the panel.
  3. Select the required region in the Stackup Regions section of the panel.
  4. All Bending Lines within the selected region will be listed in the Bending Lines section of the panel. Double-click on a Bending Line in the panel to open the Bending Line dialog as shown in the image below.

  1. In the Bending Line dialog, edit two of the first three properties, for example the Radius and the Bending Angle. The third property will be calculated automatically (more on this below). Note that each Bending Line's Affected area width is displayed as an orange shaded region.
  2. In the Bending Line dialog, set the Fold Index as required to define the sequence that the bends are folded when the Fold State slider in the PCB panel or View » Fold/Unfold command is used, which are used to fold the board in 3D mode.

One board region must have the 3D Locked checkbox enabled in the Board Region dialog to define the physical ground reference for the 3D display mode (where Z = 0). If this is not done, the Affected area width for each defined Bending Line will not be displayed.

The Bending Line dialog can also be accessed by pressing Tab while placing or moving a Bending Line handle, or by double-clicking on a Bending Line handle.

Bending Lines have the following inter-related properties:

  • Bending Angle (a) - the angle the surface of the Flex region is to bend.
  • Radius (r) - the distance away from the bend surface that the bending center-point is located.
  • Affected area width (w) - the width of surface area that will be bent for the given Radius and Bending Angle.

The relationship between the Bending Angle, Radius and Affected area width can be expressed as:

  • w = a/360 * 2*Pi*r
  • or in words, Affected area width = Fraction of the circumference being bent * Circumference

3D Display of a Rigid-Flex Board

Altium Designer includes a powerful 3D rendering engine that allows the presentation of a highly realistic three-dimensional representation of the loaded circuit board. This engine also supports rigid-flex circuits and when it is used in combination with the Fold State slider, it allows you to examine their rigid-flex design in the flat state, the fully folded state, and anywhere in between.

To switch to the 3D display mode, use the View » 3D Layout Mode command or press the 3 shortcut key (press 2 to return to 2D, or 1 to return to Board Planning Mode). The board will be displayed in 3D and if the component footprints include 3D Body objects that define the mounted component, these also will  be displayed. 

To apply the Bending Lines, slide the Fold State slider in the PCB panel when set to Layer Stack Regions mode. The bends are applied in the order defined by their Sequence number displayed in the PCB panel. Bending Lines can share the same sequence number; it means that those bends will be folded at the same time when the Fold State slider is used. The board can also be folded/unfolded by running the View » Fold/Unfold command (press the 5 shortcut).

You can only fold a board if one of the rigid sections has the 3D Locked checkbox enabled in the Board Region dialog. Altium Designer needs this to know which section of the board must remain fixed during the folding process. 

3D Movie Maker Support for Rigid-Flex Designs

Main article: 3D PCB Video

The ability to fold a rigid-flex design can also be captured as a 3D movie. It is simple to do and does not require the use of movie key frames during the folding sequence.

Refer to the main article referenced above for a detailed description of how to make a 3D movie. As a basic guide:

  1. Switch the PCB editor to 3D mode.
  2. Open the PCB 3D Movie Editor panel then create and name a new Movie Title in the top section of the panel.
  3. Create an initial Key Frame, showing the board in its unfolded state.
  4. Slide the Fold State slider to show the rigid-flex design in its folded state, then position the folded board as required.
  5. Now, create a second Key Frame for this view and set the time. Consider how long you want it to take to fold the rigid-flex design (the Duration(s) setting). Typically this would be only a few seconds.
  6. To check that the video captures the folding process correctly, press the  button.
  7. To generate a movie file, add a PCB 3D Video Documentation Output in an Output Job file. Remember to configure the video format options in the Video settings dialog.
  8. Click the Generate Content link the Output Job file to create the movie file.

The video shown below was created using this process, it has the two key frames described above, plus one additional key frame that was added at the end to hold the final position for a second.


A simple 3D movie created from three key frames; the folding behavior is defined by the Bending Line Sequence values.

STEP Export of the Folded Rigid-Flex Board

Altium Designer supports exporting a rigid-flex design as a 3D STEP file (File » Export » STEP 3D). This support includes being able to define the fold state during STEP export, which defaults to the current fold state configured in the PCB editor, as shown below.

The current fold state defined in the PCB editor is used as the fold state during STEP export, set the Rate as required in the Export Options dialog.

Multi-board Assembly Support for Rigid-Flex

In earlier versions of Altium Designer, when a rigid-flex board is included in a Multi-board assembly it would be in the flat, or unfolded state.

Now when a rigid-flex board is included in a multi-board assembly it is included in the fully folded state, to better model how it will be in the final assembly.

Note how the rigid-flex board is fully folded in the Multi-board assembly, to better model how its state in the final assembly.

 

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.