Altium Designer Documentation

LinkDocumentToReleaseVault

Created: March 31, 2017 | Updated: April 11, 2017

Parent page: PCB Commands

The following pre-packaged resource, derived from this base command, is available:


Applied Parameters: None

Summary

This command is used to quickly access the Board Options dialog, from where you can enable and configure the link to the required target Altium Vault. A PCB 2D/3D component model within a PCB Library document (*.PcbLib) is mapped to a PCB Component Item in an Altium Vault. Each release of the library stores the model data into a new revision of that Item. The PCB Library file needs to be linked to the required target vault, and a specific folder within that vault, before the model can then be released into the next planned revision of the corresponding target Item.

A PCB 2D/3D component model can be edited and released into the initial revision of a newly-created Footprint Item, courtesy of the vault's support for direct editing. Direct editing frees you from the shackles of separate version-controlled source data. You can simply edit a supported Item type using a temporary editor loaded with the latest source direct from the vault itself. And once editing is complete, the entity is released (or re-released) into a subsequent planned revision of its parent Item, and the temporary editor closed. There are no files on your hard drive, no questioning whether you are working with the correct or latest source, and no having to maintain separate version control software. The Altium Vault handles it all, with the same great integrity you've come to expect, and in a manner that greatly expedites changes to your data. For more information, see Managed PCB Footprint Models in an Altium Vault.

Access

This command is accessed from the PCB Library Editor by choosing the File » Link Library to Vault command, from the main menus.

Use

After launching the command, the Board Options dialog will appear. Enable the Link To Vault option towards the bottom-left of this dialog to access link controls.

Use the Target Vault field to nominate the vault into which you want to store released data for the model within the library. The drop-down associated to the field displays all vaults that you currently have an active connection to. If you have not connected to a vault, click the Vault Admin button to access the Data Management – Vaults page of the Preferences dialog, from where you can make a connection to the required vault as necessary.

Use the Target Folder field to nominate the folder into which the corresponding Item for the model being released will be created. Click the Choose button to access the Choose Folder dialog. This dialog essentially provides you with a folder-specific view into the target vault. Either browse to, and select an existing folder in the vault, or add a new folder. (Using the Show in Explorer button will quickly access the Vaults panel, with the chosen folder made active).

When creating the folder in which to store the model, you can specify the folder's type. This has no bearing on the content of the folder – releasing PCB 2D/3D component models will always result in Footprint Items. It simply provides a visual 'clue' as to what is stored in a folder and can be beneficial when browsing a vault for particular content. To nominate a folder's use as a container for Footprint Items, set its Folder Type as Footprints.

Use the Lifecycle Definition and Revision Naming fields (in the Board Options dialog) to choose the type of lifecycle management to be used for the created PCB Component Item, and the naming scheme employed for its revisions, respectively.

Observing standard revision naming schemes and lifecycle definitions, across the various types of design item in a vault ensures smooth, consistent management of those items. At the lowest level, it's typical for models to use 1-level revision naming with basic lifecycle management – they’re either ready for design reuse or not!

After defining the link to the vault as required, clicking OK in the Board Options dialog will create the link and store it in the PCB Library document. You can view this information at any time, using the Library Options command from the main Tools menu.

Save the library file – the library is now ready to release.

Tips

  1. At the individual model level, evidence of the link can be seen in the PCB Library Component dialog (Tools » Component Properties), through addition of the Footprint Link region. For a new, unreleased model, this information will become populated once the model is released to the vault.
  2. With the link to the target vault (and folder therein) in place, you can now proceed to release the model in your library. The release process is performed from within the Release Manager dialog.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: