Altium Designer Documentation

PlaceCoordinate

Created: June 19, 2017 | Updated: June 19, 2017

Parent page: PCB Commands

The following pre-packaged resource, derived from this base command, is available:


Applied Parameters: None

Summary

This command is used to place a Coordinate object onto the active document. A coordinate is a group design object. It is used to mark the X (horizontal) and Y (vertical) distance of a point in the design workspace relative to the current origin. Coordinates can be placed on any layer.

For detailed information about this object type, see Coordinate.

Access

Coordinates are available for placement in both PCB and PCB Library Editors:

  • PCB Editor - the following methods of access are available:
    • Choose Place » Coordinate from the main menus.
    • Click the  button on the Utility Tools drop-down () of the Utilities toolbar.
  • PCB Library Editor - the following methods of access are available:
    • Click the  button on the PCB Lib Placement toolbar.
    • Right-click in the workspace and select Place » Coordinate from the context menu.

Use

After launching the command, the cursor will change to a cross-hair and you will enter coordinate placement mode. A coordinate will appear "floating" on the cursor:

  1. Position the cursor and click or press Enter to place a coordinate.
  2. Continue placing further coordinates, or right-click or press Esc to exit placement mode.

Additional actions that can be performed during placement are:

  • Press the L key to flip the coordinate to the other side of the board.
  • Press the + and - keys (on the numeric keypad) to cycle forward and backward through all visible layers in the design respectively – to change placement layer quickly.
  • Press the Tab key to access the Coordinate dialog, from where properties for the coordinate can be changed on-the-fly.
While attributes can be modified during placement (Tab to bring up associated properties dialog), bear in mind that these will become the default settings for further placement unless the Permanent option on the PCB Editor – Defaults page of the Preferences dialog is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.

Tips

  1. In the PCB Editor, the current origin can be set to be any point in the PCB workspace by selecting Edit » Origin » Set, and clicking on the location for the new origin. To set the current origin back to the absolute origin ((0,0) in the lower-left corner of the workspace), select Edit » Origin » Reset.
  2. The coordinate group object is comprised of a string specifying the actual X,Y position and a point marker (small cross of two tracks) . In the PCB Editor, a coordinate can be converted to its constituent primitive objects using the Tools » Convert » Explode Coordinate to Free Primitives command. Explode a coordinate to reposition the position string without changing the location of the marker.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: