Altium Designer Documentation

Release Notes for Altium Designer

Modified by Susan Riege on Apr 14, 2021
All Contents

The following sections list the release notes for publicly released versions of Altium Designer 21.

For a summary of new features and subsequent improvements in Altium Designer 21, see New in Altium Designer.

Version 21.2.2 (Update 2 Hot Fix 2)

Build: 38 Date: 19 March 2021

Schematic
44177 A regression caused a crash to occur after placing a Harness Entry if the "Enable Auto Pan" option was enabled.
Data Management
44280 A regression caused the software to slow down due to recurring duplicate requests sent to SettingService.

Version 21.2.1 (Update 2 Hot Fix)

Build: 34 Date: 11 March 2021

Schematic
44132 A selected item is invisible while using the Edit > Duplicate command.
44133 Dragging multiple items by Ctrl+Left mouse button leaves a copy of the items in the original location until the drag is completed.
44134  Zooming on a schematic document did not function properly if an object was Copy and Pasted in. (BC: 15471)
PCB
42633 A polygon did not respect the clearance rule for the board outline. (BC:15474)
42664 Error occurred after clicking Enter to commit tracks that have been dragged.

Version 21.2.0 (Update 2)

Build: 30 Date: 4 March 2021

Schematic
38596 Differential Pairs contained in Harness signals were disconnected in the PCB after updating the design.
39170 Duplicates of device sheets appear in the Projects panel. (BC:13706)
40587 The results of the Copy and Paste commands were not saved in the Variant Management dialog. (BC:14237)
42499 Changing the Font Size to "10 pt" was not possible in the Schematic document. (BC:15146)
42633 Port Cross-Reference error message was missing upon the failed attempt to add to the project. (BC:14810)
42664 Objects that were locked using the SCHList panel are not locked and the Locked option is unchecked when the schematic is closed then reopened. (BC:15107)
42920 Image files places from the network folder could not be placed on a schematic.
43010 Objects still follow the mouse cursor after releasing the left mouse button while moving objects using Ctrl+left mouse click.
43161 Redundant sheet numbers were added in Port Cross Reference values in repeated instances of the port.
43235 The Zooming level in the Highlight Methods region of the System - Navigation page of the Preferences dialog was not followed and did not take pinned panels into account. (BC:15017)
43245 A wire did not return to its initial state if moving a wire vertex was canceled using the Esc key. (BC:15038)
43248 Pin parameters that reference parameters from a database were not displayed correctly. (BC:14990)
43454 A generated PDF outjob did not add the correct variant parameters to the title.
43710 A schematic outjob did not update variant parameters. (BC:15229)
43718 An issue caused cross references to adopt signal names rather than port names if a few different ports were connected to the same signal.
43837 System is slow when pasting with the Shift key.
PCB
36537 The Top Solder Layer name was incorrectly replaced with the Top Flex Coverlay name in the ODB++ files.
39852 An issue caused an error to occur after the via hole size was changed and the width field data was applied.
40438 Internal layers were missing after generating PCB from an exported CAM file.
41218 Exporting ODB++ outputs resulted in the incorrect values for Copper weight when metric units were used.
42695 Performance degradation occurred when attempting to fold Rigid-Flex design.
42836 Components that contained incorrectly built circles were unselectable.
42889 If a PCB layer had two or more polygon pours with the same name, the checkboxes in the Polygon Pour Manager could not be easily selected.
42890 Connection Lines disappeared when the True Type text bounding box contained multi-line text.
43091 When ODB++ Fabrication outputs are generated, the text in the Drill Table and the Layer Stack Table is not displayed.
43150 Board Outline Clearance produced false violations when changing the Board Shape. (BC:15199)
43213 Added several improvements to the PCB Rectangle object.
43306 Teardrops settings were not saved in the system after configuration. (BC:7990)
43328 Added an aspect ratio option to the Rectangle mode of the Properties panel.
43373 Improvements were made to routing including pad stability support for round pads and the ability to create concentric arcs during retrace and dragging of differential pairs.
43451 The Rules and Violations panel incorrectly displayed several 'Net Antennae' violations.
43612 PCB is rendered without Solder Mask visible through semi-transparent 3D models. (BC:15261)
43623 An invalid Clearance Violation appeared after correcting the diameter size for the top layer Pad of a Via.
43638 Running the Design Rule Check with 'PCB.EngineX.Instancing' enabled took 60 times longer than with the disabled option.
43648 Certain PCB documents were not saving properly and resulted in an error message.
43664 Design Rule Checking resulted in Unrouted Net errors for uVias. (BC:15180)
43665 After placing a 3D Body component, the texture is not displayed in 3D Layout mode even though it is displayed in the PCBLIB. (BC:15399)
Draftsman
43611 Error occurred while importing changes from the board when the Route Tool Path was defined in the PCB but primitives have not been placed. (BC:15049)
43898 Error message populated when attempting to update templates. (BC:15342)
Platform
43453 Text scaling when not using a 4K display in the Properties panel resulted in missing text.
43705 An issue caused folders to disappear in the Explorer panel after changing the folder type to "ComponentTemplates" when connected to a Standard Workspace.
Data Management
37441 Incorrect Parameter values were shown for Variants in the Pick & Place dialog.
42936 Clicking the Search button in the File-based Libraries Search dialog when Footprints was selected in the 'Search' in drop-down resulted in the search being executed yet the search spinner remained.
43045 Improved Save to Server interface for version-controlled projects and file-less items.
43344 Two new violation types have been added to the Component Rule Checks to prevent duplicate components by Name and PCL in the Single Component Editor.
43634 The 'Remove from Project' command has been restored and renamed 'Exclude from Project'. (BC:15179)
43726 Error occurred when releasing a component.
43779 Using a UNC format for network paths on the Data Management - Templates page of the Preferences dialog resulted in an error. (BC:15275)
Import/Export
39692 Stackup and materials data from Altium Designer can now be imported to the ODB++ Design Viewer.
40909 The Hyperlynx Exporter now includes component values and part numbers.
Simulation
41400 Added generation of special symbols for SPICE components described by the .model command.
41602 All input fields in the Simulation Dashboard panel for DC, AC and Transient Analysis now contain default values.
43471 Simulation dashboard does not require verification on minor changes.
43512 Added support for *.cir files as SPICE library files.
43588 Improved component model storage to store only the necessary model description.
43671 Reference net name could be specified in Advanced simulation settings
43896 PSPICE library files *cir are now supported.

Version 21.1.1 (Update 1)

Build: 26 Date: 12 February 2021

Schematic
37746 Using the same Schematic document in multiple projects caused that Schematic document to be multiplied in the Projects panel. (BC:13281)
37979 Components and Nets sections were not displayed after Project Validation contained in the MultiBoard project.
38009 Harnesses nested by using a dot connection resulted in an invalid error message. (BC:13269)
38229 "Synchronize Sheet Entries and Port" option adds "repeat" string to port's name in cases when repeat function was used in sheet entry.
38231 Using "$Component$ChannelAlpha" with more than 26 channels generated a non-alpha index. (BC:13423)
38732 Numeric interpretation of Color was inconsistent between the Properties panel and the Find Similar Objects dialog. (BC:13657)
39107 Dynamic Compilation did not detect changes of alternate parameters added from the Variant Manager. (BC:13784)
39276 Transparency of objects did not display properly in Print preview or in printed PDF.
41201 Pin Swapping did not work in the Schematic.
41520 Using the Zoom command in the SCHList panel fails to work.
42324 ECO incorrectly transferred parts with the same footprint and detected differences from each launch.
42327 The Parameters for Multipart Alternate Variants did not display in the generated PDF.
42387 When "Snap to Electrical Objects Hotspots" was disabled, dragging a part resulted in a lost connection.
42618 NoERC directive suppressed violations that should not be affected.
42758 An extra extension separator dot (".") is added when using Save As to save *.dft files.
42784 Setting Project Variants resulted in an "Object reference not set to an instance of an object" error message.
42789 Copy (String, Index, Count) functions do not work if the Count value specifies more characters than are available.
42790 Copy functions - String, Index, and Count - did not work if the Index Value was greater than 1.
42793 When a schematic has been saved in binary 4.0 format, the schematic opens without any parts.
42796 In-place text editing resulted in a crash when the Enable Auto Pan option on the Schematic - Graphical Editing page of the Preferences dialog was disabled. (BC:12890)
42827 Placing a Harness connector on the Schematic sheet resulted in an error message. (BC:14880)
42941 Adding a SCHLIB file in the Library Splitter Wizard does not function.
42953 "Duplicates not allowed" error message popped up as a result of launching different commands in the Schematic.
42958 ECO incorrectly applied changes to Schematic documents after re-annotation instead of the existing annotation file.
42978 The user-defined parameters for Variants were not shown on the Schematic sheet.
43028 Alpha-Numeric Suffix options were incorrectly applied to single Parts.
43030 Crash occurred when attempting to place parts from the Database Library on the Schematic sheet.
43067 Parameter manager did not work with 'Selected Objects Only' selected in the Schematic Library document. (BC:14931)
43113 Smart Paste commands launched in Symbol Wizard dialog resulted in an error message. (BC:14974)
43149 The Schematic Default primitives from the Preferences dialog did not load. (BC:14886)
PCB
26366 Maximum zoom level was lower for PCB library documents and for PCB documents in 3D mode that are set to Perspective projection in the View Configuration panel. (BC:9409)
31695 The 'BoardOutlineClearance' rule disappears from the waived violations when the PCB is reopened. (BC:14162)
40476 The Component Rule Checks always point to the first footprint in the PcbLib file.
40910 The Unrouted Net violation was not detected for an unconnected pad.
41824 Width rule configured with Impedance Profile resulted in a false violation even when the actual width was equal to the target width. (BC:11506)
41866 Layers were configured incorrectly after placing components on the PCB. (BC:14245)
42184 Snap to Footprint Origin did not function properly in the Footprint Library editor.
42229 Selection in the PCB List panel did not work properly.
42590 Significant memory consumption resulted in a software delay when large designs were opened.
42819 "Unable to Save File" error message popped up as a result of editing/modifying objects in PCB document.
42857 It was not possible to add Snap Points on the 3D body with the speed of the double-mouse click. (BC:14637)
42944 The Top Paste Mask is not displayed in 2D mode until the layer properties are changed in the Layer Stack Manager.
42974 PCB document was incorrectly covered with the Top Overlay layer color in 2D and 3D view upon reopening PCB.
42980 When a polygon that had an unused pad shape removed was repoured, clearance rules were not obeyed. (BC:14891)
43224 The Region Shape Splitter displayed the wrong number of regions after splitting and the shapes were incorrect.
Draftsman
41471 Software crash as a result of opening certain Draftsman documents.
41841 The solder mask color changes after placing a Board Realistic View. (BC:11962)
42195 The incorrect weight units were displayed in the Layer Stack Legend.
42805 Notes placement and editing in the Draftsman document was fixed (BC:12181)
43147 Crash occurred after updating the Board Assembly View.
Platform
40216 Comments usability has been improved to be included in every aspect of the collaboration and review process.
42189 Added support for Single Sign-on.
42419 Software became unusable during the Altium 365 Server outage.
42593 Moving and opening panels resulted in a software crash.
42688 The collaboration notification pop-up dialogs are now blue.
42737 The screenshot quality of the Schematic sheets and PCB design has been improved.
42834 After attempting to share projects in Altium Designer, a message displays stating that the user does not belong to the team.
42872 When trying to create or open a project or file that resides in a shared network folder or network-mounted drive, Altium Designer closes.
43015 The Document Path location specified on the System - Default Locations page of the Preferences dialog is not followed. (BC:14950)
Data Management
38073 Crash occurred when generating BOM from the output job.
40566 Progress status indicator for file-based libraries search was not displayed in the Components panel. (BC:12731)
40853 The Project Releaser has been improved to better support Parameters.
40952 Multi-board schematic template selection did not use the folder specified on the Data Management - Templates page of the Preferences dialog. (BC:13545)
41114 Altium 365 registration is now recognized if a project was added to the external VCS manually after it was registered with the cloud.
41851 Incorrect error message popped up when using the Project Releaser. (BC:14609)
42270 After a failed library migration, the imported components are visible in the Components panel but cannot be edited.
42301 The 'Where Used' logic has been unified for the Explorer panel and the Components panel.
42346 Components used in Templates were not visible in the "Where Used" section.
42474 The deleted Component Template was still displayed on the Data Management - Component Types page of the Preferences dialog.
42533 Added possibility to copy and paste Comment thread as a link.
42686 The Collaboration pop-up dialogs have been restructured to demonstrate when a collaborator appears, when the first editor appears, when the document has been opened for the first time, and when there are changes in the collaborator list.
42694 Renaming a project group does not function properly. (BC:14840)
42795 BOM report had differences depending upon which document was active when the command was run (PCB or schematic).
42812 When using Cross Selection in the Constraints Manager, dark text appeared on a dark background, which made it unreadable.
42928 Nexus Client did not transfer the newly added documents via Version Control to the Project structure.
43050 SIM models are now supported in the Components panel.
43054 Made several improvements to the Project Releaser.
43121 ActiveBOM does not update stock data unless a new BomDoc is added.
43135 The system froze if a footprint had the same name as the component.
43141 Hidden Components prevented non-admin users from adding new components with the same CMP ID.
43146 Files in the Project subfolder lead the Version Control commital to fail.
43200 When the “Register Designator” command was run, an error displayed for the initial configuration of the GOSTBOM directory.
43360 Defined Generic Components will be used for the component search during component replacement.
43605 A crash occurred when a component was acquired from the Manufacturer Part Search panel. (BC:15243)
BOM
42460 Object reference was not set to an instance of an object in the Altium BOM report.
43008 An error occurred when opening a BOM configuration that had referenced a BOM template from another workspace.
Simulation
42048 The fields for the plot number in which the simulation data will be displayed are presented in the Add Output Expression dialog.
42052 Added new feature for renaming Simulation results.
42597 Added independent variable types for DCSweep Analysis in the Simulation Dashboard.
42669 Added F1 capability for the Simulation Dashboard panel.
42740 DDT Function in the Transient Analysis is now supported.
42756 The SDT function is now supported in Transient Analysis.
42903 The delay function for LTspice model is now supported in the Transient Analysis.

Version 21.0.9 (Hot Fix)

Build: 235 Date: 11 January 2021

Schematic
41253 User-defined variant parameter values were not displayed on the schematic document.
41983 Alpha Numeric Suffix was not applied for Numeric state.
42325 Variant parameters included in Special strings were not shown on the Schematic sheet.
42845 Parameter values with a dash (-) and zeroes display incorrectly. (BC:14889)
PCB
42726 Paste Masks are not displayed for primitives in the PCB library. (BC:14892)
42863 Dead copper around a Keepout was not removed when repouring Polygons. (BC:14952)
42973 Incorrect 3D models are displayed in the 3D view when the PCB document is opened.
Platform
42572 Access violation in ScriptingSystem.dll during component creation in Altium Library Loader script from Samacsys.

Version 21.0.8 

Build: 223 Date: 17 December 2020

Schematic
35995 The Comment Name is not visible while moving it.
36454 DM_CalculateParameterValue function resulted in an error during Script execution.
36952 Pad designators are now displayed rather than the Pin designator in the case of unsymmetrical pin to pad mapping.
37878 'Convert selected device sheet to schematic sheet' option did not remove the converted device sheet from the project. (BC:12665)
37958 Crash occurred when Schematic document and Schematic Filter panel were located on separate windows. (BC:13339)
37970 Components were displayed incorrectly. (BC:13297)
37977 Graphics pasted from Paint are not always added to the PDF. (BC:13351)
38072 "Add Template to Clipboard" option resulted in an exception error message.
38286 Net names were not overridden by Power Port names if Power Ports were connected via Bus. (BC:13449)
38598 Modification of the numeration of compiled sheets is not saved (BC:13586)
38717 Added ability to add parameters to Wires. (BC:11099)
38746 The order of parameters drawing is changed during updating from the library as well as after deleting and performing an undo. (BC:13719)
38929 The grid in the symbol editor is not always aligned to the origin.
39274 Parts with no pins do not snap to the grid when they are placed by dragging from the Components panel. (BC:14364)
40246 The Model Pin Designator was not saved after editing in the Model Map dialog. (BC:14182)
40477 The cutter box graphics in the "Break Wire" tool became invisible when placed over a harness signal object.
40737 'Not fitted' graphics were not centered over the component. (BC:24228,14209)
40871 The interactive PDF navigation for ports and offsheet connectors does not work in flat designs.
41161 Large grey rectangles were incorrectly displayed instead of grey bold net lines when generating the Schematic to PDF. (BC:13824)
41194 Schematic symbol graphics did not maintain rotation after reloading Schematic.
41239 Autocomplete naming function in the Schematic obstructed the ability to customize Port names.
41429 When a Library Report was generated, the graphics were incorrect.
42647 When multiple objects were selected and moved in the schematic library document, the selected objects disappeared. (BC:14832)
PCB
ROUTING-3530 An issue caused infinitely repeating error messages to occur when attempting to modify an existing accordion in some cases.
34900 Added support for component collision checking between component courtyards (objects placed on a component layer pair defined as Courtyard), these are used when there are no 3D Body objects in the components. (BC:3146)
37152 3D body created in SolidWorks 2020 SP1 could not be added in Altium Designer, with no warning message appearing when attempted.
37266 'Distribute Vertically' and 'Distribute Horizontally' commands from the Edit > Align sub-menu performed incorrect spacing between primitives. (BC:13572)
38592 Improved performance for Pad/Via selection with open properties panel and preview enabled.
38652 The delay value in the PCB panel did not change after the parameters that affected the xSignal value were changed, then saved in the Layer Stack Manager.
38875 Polygon Arc approximation creates unnecessarily narrow necks. (BC:4314)
39006 Added polar grid coordinates to Properties panel and Heads Up Display (HUD). (BC:590)
39008 Added the ability to place an image on PCB layer using the Place>Graphic command. PNG, BMP, JPG and SVG formats supported. (BC:10969)
39082 ActiveRoute command ignored 'No Net' Polygon and Region objects.
39159 DRC did not report two or more pins with no connected nets as short circuits. (BC:13783)
39180 Exception error occurred when saving a PCB Library after custom grid settings were changed.(BC:13713)
39247 View Configuration panel custom settings were not saved on certain PCBs.
39663 When multiple layer stacks are used and a 3D STEP model is generated, the flex region was not distinguishable from the rigid region. (BC:9822)
40241 Changing the line radius when placing a line does not work correctly. (BC:14137)
40279 Track width for hatched polygons is not working when hidden and the track width value in the preview differs from the hidden preview. (BC:14225)
40287 The Remove Unused Pad Shapes' command did not work correctly with offset holes. (BC:9744)
40298 When a selected object that has a room within the selected object was moved, the reference point was changed. (BC:371)
40410 Clearance miscalculation when running a Design Rule Check as a result of factoring slot size and ignoring hole length.(BC:11879)
40462 Interactive Routing resulted in a large memory leak when the Swapping option was enabled in the project design.
40618 An issue caused cutouts to be ignored by the Board Outline Clearance for silkscreens, resulting in a design rule violation to be generated. (BC:9144)
40773 Added the ability to save PCB 3D prints using the File>Export command in *.png, *.jpg, and *.bmp formats. (BC:1397)
40778 Mechanical layers are now displayed in the PCB 3D mode. (BC:301)
40782 The ability to orient with polar grids while moving or dragging rooms or multiple selected components has been added. (BC:9988)
40792 Added 'Remove Loops with Vias' option to Routing Properties panel. (BC:8781)
41122 Added an option in the Advanced Settings dialog to set layer sorting modes.
41182 The Copy All Objects Touching the Room command does not update polygon and via nets for a new channel. (BC:11653)
41348 The accuracy of the selection of tuning patterns has been improved.
41354 Invalid layers are no longer displayed in the layers list for Component placement. (BC:9114)
41425 3D bodies are missing in exported STEP files.
41502 Added "+/-" buttons for rotation to the 3D Body Properties panel. (BC:8583)
41503 Added number keyboard shortcuts for 3D view controls. (BC:7726)
41656 Improved the speed of saving PCB documents on network drive. (BC:2399)
41801 Added dedicated snapping to arc centers.
41826 Added ability to pour modified polygons during Design Rule Check.
42006 Added "Quick Routing" and "Quick Differential Pair Routing" commands to the Route menu.
42087 When trying to route on specific PCBs, the 'Simbeor error. Failed to add material' message is displayed. (BC:14645)
42146 Snapping on the current layer snaps to the Keep-Out layer.
42179 Optimal Void Rotation options was added for polygon. (BC:4314)
42403 In the Layer Stack Manager, added a top panel with modification buttons, the ability to add new types of layers, and in Draftsman, added new layers of support.
Draftsman
39519 Silkscreen primitives for the Board Assembly View were not correctly drawn. (BC:12405)
42061 The "VersionControl_ProjFolderRevNumber" and "VersionControl_RevNumber" special strings were not updated in the Draftsman PDF document after being released and instead displayed a "not in version control" error.
Platform
38800 UI themes support and high DPI support have been added in certain dialogs and editors.
39108 Context menus were not rendered on the second monitor if the main monitor had 4K resolution and High DPI.
40161 Error occurred when generating prints when no 'No-ERC Markers with Symbols' options in the Schematic Print Properties dialog were enabled.
41733 Outjob dialog popup window is now resizable horizontally. (BC:6227)
42008 Restored "Save As" command in right-click menu options for single documents in the Projects panel (BC:14701).
42570 Converting polygons to region objects resulted in a Scripting error.
Data Management
35873 When the Item Manager Automatch option was used, the correct footprint was not selected.
36764 PDF schematic output jobs generated by the Release Manager with the Version Control Revision number resulted in the PDF 'Not in Version Control'.
36880 'Description' parameter column has been added to the Single Component Editor. (BC:12077) (BC:7192)
38668 Added ability to save the component selection after the Refresh command has been used. (BC:13295)
39500 Added the ability to use the "Update to the Latest Revision" command for alternate parts in an ActiveBOM document.
40615 An error appeared after a BOM PDF that contained an image was generated through the PDF Output job container. (BC:14020)
40946 Nexus Client did not show server project templates when "Sign in automatically" and TC2 configuration was used.
40954 'Where Used' section from the Components panel did not display Project Template items.
40955 It was not possible to mouse scroll the scroll bar of the Template's drop-down menu.
41312 The Components panel now supports Simulation Model browsing.
41469 Catastrophic failure when columns grouping was enabled in the Components panel.
41599 Simulation Models Panel to browse the model from the Local libraries storage and Simulation Generic Component Library
41617 Mapping schemas are now supported for component references in DBLibs during Library Migration.
41799 Warning message regarding the disabled Data Management server continued to pop up unnecessarily during startup.
41811 The Manufacturer Part Search Panel now supports Simulation model browsing.
41835 Parameters' visibility in the Properties panel component area is now managed by the user.
41888 The 'VersionControl_ProjFolderRevNumber' and 'VersionControl_RevNumber' special strings were not updated for PDF documents that were generated during project release.
41950 Customize the browse model based on Components panel in Local libraries according to the model UI
42067 The Components panel has updated how Simulation models are previewed.
Import/Export
37344 Protel importer was not importing .DDB files. (BC:13078)
39372 Added the ability to import Pspice schematic files with connected models
40701 A new schematic and symbol library file format has been added to the KiCAD importer.
41034 Stroke Text was incorrectly exported to DXF/DXG as individual tracks. (BC:10437)
41594 Ansys exported .edb file resulted in incorrect layer assignment for single-layer pads.
Simulation
40088 Fourier Analysis has been added to the Simulation dashboard.
40102 Support has been added for switching between SPICE formats - LTSpice, PSpice, and MixedSim.
40542 Added output expressions window in the simulation dashboard.
41001 Added support for SPICE libraries in the Components panel.
41109 Transient Analysis UIC flag is now included in Mixed Simulation.
41110 The Run buttons are now disabled if the verification was unsuccessful or was not up-to-date.
41112 Added the ability to select the probe or source from the dashboard to open the Properties panel.
41214 A new feature automatically assigns models for R, L, C components from the Simulation dashboard.
41215 A feature has been added that allows you to choose the source of the included simulation model in the SimModel window.
41216 All simulation models of a project are now stored in a single model file.
41285 Simulation data is now shown on plots according to the type - Probe or Expression.
41299 The Simulation Properties panel has been updated with new features.
41309 Simulation profiles are now autoloaded.
41475 The Simulation profiles processing has been updated as project documents displayed in the Projects panel.
41483 The Component Library of the SimModel window has been updated to account for Altium 365 Simulation.
41505 The feature to sweep parameters in the Parameter sweep by Decade, Octave, and List has been added.
41600 Simulation global parameters, errors, and warnings have been added to the Simulation dashboard.
41749 The models of all placed components are now stored in a special cache library.
41810 The Simulation Model verification is now available in the Sim Model Window.
42047 The Simulation process has been sped up with interactive plotting data.
42051 A new feature allows you to set the color of the probe's plot in the Simulation Dashboard.
42114 The Simulation data of unlocked transient analysis is now displayed in the Probe Window.
42119 Global parameters defined in the NSX text blocks are now displayed in the Advanced Settings Window as disabled items.
42423 Improved Pin Mapping is released for the Simulation models.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.