Altium Designer Documentation

LinkDocumentToReleaseVault

Created: June 6, 2017 | Updated: June 6, 2017

Parent page: Schematic Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: None

Summary

This command is used to quickly access the Schematic Library Options dialog, from where you can enable and configure the link to the required target Altium Vault. A schematic symbol within a Schematic Library document (*.SchLib) is mapped to a Schematic Symbol Item in an Altium Vault. Each release of the library stores the symbol data into a new revision of that Item. The Schematic Library file needs to be linked to the required target vault, and a specific folder within that vault, before the symbol can then be released into the next planned revision of the corresponding target Item.

A schematic symbol can be edited and released into the initial revision of a newly-created Symbol Item, courtesy of the vault's support for direct editing. Direct editing frees you from the shackles of separate version-controlled source data. You can simply edit a supported Item type using a temporary editor loaded with the latest source direct from the vault itself. And once editing is complete, the entity is released (or re-released) into a subsequent planned revision of its parent Item, and the temporary editor closed. There are no files on your hard drive, no questioning whether you are working with the correct or latest source, and no having to maintain separate version control software. The Altium Vault handles it all, with the same great integrity you've come to expect, and in a manner that greatly expedites changes to your data. For more information, see Managed Schematic Symbols in an Altium Vault.

Access

This command is accessed from the Schematic Library Editor by choosing the File » Link Library to Vault command, from the main menus.

Use

After launching the command, the Schematic Library Options dialog will appear. Enable the Link To Vault option towards the bottom-left of this dialog to access link controls.

Use the Target Vault field to nominate the vault into which you want to store released data for the symbol within the library. The drop-down associated to the field displays all vaults that you currently have an active connection to. If you have not connected to a vault, click the Vault Admin button to access the Data Management – Vaults page of the Preferences dialog, from where you can make a connection to the required vault as necessary.

Use the Target Folder field to nominate the folder into which the corresponding Item for the symbol being released will be created. Click the Choose button to access the Choose Folder dialog. This dialog essentially provides you with a folder-specific view into the target vault. Either browse to, and select an existing folder in the vault, or add a new folder. (Using the Show in Explorer button will quickly access the Vaults panel, with the chosen folder made active).

When creating the folder in which to store the symbol, you can specify the folder's type. This has no bearing on the content of the folder – releasing schematic symbols will always result in Symbol Items. It simply provides a visual 'clue' as to what is stored in a folder and can be beneficial when browsing a vault for particular content. To nominate a folder's use as a container for Symbol Items, set its Folder Type as Symbols.

Use the Lifecycle Definition and Revision Naming fields (in the Schematic Library Options dialog) to choose the type of lifecycle management to be used for the created Schematic Symbol Item, and the naming scheme employed for its revisions, respectively.

Observing standard revision naming schemes and lifecycle definitions, across the various types of design item in a vault ensures smooth, consistent management of those items. At the lowest level, it's typical for symbols to use 1-level revision naming with basic lifecycle management – they’re either ready for design reuse or not!

After defining the link to the vault as required, clicking OK in the Schematic Library Options dialog will create the link and store it in the Schematic Library document. You can view this information at any time, using the Document Options command from the main Tools menu.

Save the library file – the library is now ready to release.

Tips

  1. At the individual symbol level, evidence of the link can be seen in the Schematic Symbol Properties dialog (Tools » Component Properties), through addition of the Vault Links region. For a new, unreleased symbol, this information will become populated once the symbol is released to the vault.
  2. With the link to the target vault (and folder therein) in place, you can now proceed to release the symbol in your library. The release process is performed from within the Release Manager dialog.


Applied Parameters: None

Summary

This command is used to quickly access the Document Options dialog, from where you can enable and configure the link to the required target Altium Vault. A defined schematic sheet on the design side is mapped to a Schematic Sheet Item in an Altium Vault. Each release of the sheet stores the data into a new revision of that Item. The schematic sheet needs to be linked to the required target vault, and a specific folder within that vault, before the sheet can then be released into the next planned revision of the corresponding target Item.

A schematic sheet can be edited and released into the initial revision of a newly-created Managed Schematic Sheet Item, courtesy of the vault's support for direct editing. Direct editing frees you from the shackles of separate version-controlled source data. You can simply edit a supported Item type using a temporary editor loaded with the latest source direct from the vault itself. And once editing is complete, the entity is released (or re-released) into a subsequent planned revision of its parent Item, and the temporary editor closed. There are no files on your hard drive, no questioning whether you are working with the correct or latest source, and no having to maintain separate version control software. The Altium Vault handles it all, with the same great integrity you've come to expect, and in a manner that greatly expedites changes to your data. For more information, see Managed Schematic Sheets in an Altium Vault.

Access

This command is accessed from the Schematic Editor by choosing the File » Link Sheet to Vault command, from the main menus.

Use

After launching the command, the Document Options dialog will appear, with the Link To Vault option already enabled - giving access to link controls.

Clicking the Choose button to the right of the Item Revision field will give access to the Choose Item dialog – essentially a trimmed incarnation of the Vaults panel. The field at the top-left of the dialog indicates which vault you are currently exploring. To select a different vault, click the vault name to access a menu of top-level vault management controls. This menu displays all vaults that you currently have an active connection to. If you have not connected to a vault, use the Vault Administration command on the menu to access the Data Management – Vaults page of the Preferences dialog, from where you can make a connection to the required vault as necessary.

With the required target vault active, you can either drill down through its folder hierarchy to select the required existing Item, or create the folder and/or Item as required, on-the-fly. Ensure that the Item-Revision chosen – which will receive the released data – is in the Planned state.

When creating the target Item, ensure that its Content Type is set to Managed Schematic Sheet.
When creating the folder in which to store the sheet, you can specify the folder's type. This has no bearing on the content of the folder – releasing schematic sheets will always result in Schematic Sheet Items. It simply provides a visual 'clue' as to what is stored in a folder and can be beneficial when browsing a vault for particular content. To nominate a folder's use as a container for Schematic Sheet Items, set its Folder Type as Managed Schematic Sheets.

When defining the Schematic Sheet Item, to which the source schematic sheet is linked, be sure to specify the type of lifecycle management to be used for the Item, and the naming scheme employed for its revisions, respectively.

Observing standard revision naming schemes and lifecycle definitions, across the various types of design item in a vault ensures smooth, consistent management of those items.
The filename under which the sheet is saved should ideally be entered into the managed sheet Item's Comment field, and the sheet title entered into its Description field. This information is used when searching the vault. And having the filename appear as the Item's comment enables quick identification of what that managed sheet offers, in terms of key component and therefore circuit functionality.

Once the required revision of the Schematic Sheet Item in the target vault is chosen, clicking OK in the Choose Item dialog will create the link between source sheet and target Item. Evidence of the link can be seen back in the Document Options dialog. Close the dialogs and save the source document – so that the link information is saved to the sheet.

Tips

  1. With the link to the target vault and Item-Revision in place, the process of releasing the source schematic sheet into the vault can proceed. This is performed using the Release to <TargetVault> command, available from the main File menu.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: