Shortcuts for the Altium Designer CAM Editor

Created: January 31, 2023 | Updated: January 31, 2023
Applies to Altium Designer versions: 23 and 24

The following sections present shortcut keys that are specific to the CAMtastic Editor. For general information regarding shortcut keys - including access and editing, general Altium environment shortcuts, and accelerator keys - see Altium Designer Shortcut Keys.

When looking at the shortcut key listings, keep in mind the following:

  • When referring to shortcuts, use of the plus (+) symbol denotes holding multiple keys down on the keyboard in the indicated sequence. For example, Shift+F1 means holding down the Shift key then pressing the F1 key. Likewise, Shift+Ctrl+PgUp means holding down the Shift key then holding down the Ctrl key at the same time and pressing the PgUp key.
  • Where use of the standard mouse buttons is made, Click refers to a single click of the left-hand mouse button, Double-Click refers to two clicks of the left-hand mouse button, and Right-Click refers to a single click of the right-hand mouse button.

Standard Shortcuts

The following shortcuts are standard to the CAMtastic Editor. They are available in general and do not require you to be performing an interactive process to access them.

General Editing

Right-Click Access context menu for the design space. If currently within an interactive command, will escape from the current operation.
Ctrl+C Copy the selected object(s) from the current document to the CAMtastic Editor's internal clipboard.
Ctrl+X Clear the selected object(s) from the current document and copy them to the CAMtastic Editor's internal clipboard.
Ctrl+V Paste the contents of the CAMtastic Editor's internal clipboard into the current document.
Ctrl+Z Undo.
Ctrl+Y Redo.

Selecting

Alt+C Select design objects within a user-defined area. The objects do not have to be wholly inside the defined boundaries of the area.
Alt+P Reselect the objects that were part of the previous selection.
Alt+O Select objects in the workspace one at a time.
Ctrl+F Toggle the Flash/Point selection mode On or OFF.
Ctrl+T Toggle the Draws selection mode On or OFF.

Viewing the CAM Document

Home Display all objects on all enabled layers in the current document.
Shift+P Redefine the display area about a specified point in the current document.
PgUp Zoom-in, relative to the current cursor location.
Ctrl+Mouse Wheel Up Zoom in by center of the main display window. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
PgDn Zoom-out, relative to the current cursor location.
Ctrl+Mouse Wheel Down Zoom out by center of the main display window. Use of the Ctrl key is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
Mouse Wheel Scroll vertically within the design space. This is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
Shift+Mouse Wheel Scroll horizontally within the design space. This is a default setting that can be changed from the System - Mouse Wheel Configuration page of the Preferences dialog.
Right-Click, Hold&Drag Pan the view within the main design window.
Shift+V Return the display to the previous view of the screen from having used the Zoom In (PgUp) or Zoom Out (PgDn) commands.
End Refresh the design space, in effect performing a redraw of the current document to remove any undesired drawing update effects.
D Enter Dynamic Panning mode, in which you can pan the document by clicking and holding the left mouse button.
Alt+Home View and highlight all objects drawn with the current Dcode.
Ctrl+Home Change the display of the main design window to show the current film box and its contents.
Shift+E Toggle the display of the Extents Box. This box is used to display the drawing extents within the main design space.
Shift+F Toggle the view of the document between active fill and outline sketch modes.
Shift+H Toggle the highlighting of objects based on the current Dcode. In this way, you can interrogate exactly with which objects a particular Dcode is associated.
N Toggle the display of the document between Negative and Standard views.
Shift+T Toggle translucent display mode ON or OFF. This mode displays objects in the document with a transparent effect, allowing you to see objects partially or entirely overlapped by other objects.
Shift+B Toggle the display of the current film box.

Working with Grids

Ctrl+G Set the X (horizontal) and Y (vertical) step values - for the Snap Grid - simultaneously to a chosen value (using the Enter Grid dialog).
Shift+S Toggle between the Off snap mode and the previously selected snap mode (other than Off).

Closed Polyline Conversion Tools

Shift+Y Convert a closed polyline to a solid polygon.
Shift+Z Convert a closed polyline to a CutOut polygon.
Shift+X Convert a closed polyline to a solid polygon region.

Working with Layers

Ctrl+L Align layers based on chosen layer objects (ensure that only the layers you wish to work with are enabled).
L Create a new layer by merging existing layers. The Select Layer for Merging dialog will appear with which to choose the layers to be merged.
K Access the Set Layers OFF dialog in which you can specify which layers you wish to turn OFF
Alt+K Access the Set Layers ON dialog in which you can specify which layers you wish to turn ON
+ (on numeric keypad) Change the current layer for the design to the next layer in the Layers list
- (on numeric keypad) Change the current layer for the design to the previous layer in the Layers list
* (on numeric keypad) Change the current layer for the design to the next signal layer in the Layers list

Working with Objects

Ctrl+A Copy selected objects and place them in a defined array within the document.
Ctrl+D Change the shape and/or layer for selected objects in the document.
Ctrl+I Set a new origin point for the document.
Ctrl+U Scale selected objects in the document based on a specified base point and scale factor.
Ctrl+M Mirror selected objects about a defined mirror line on the document.
Ctrl+R Rotate selected objects about a specified rotation 'base' point in the document.
Ctrl+E Delete selected objects from the document.

Analyzing

Q Obtain information with respect to a single selected object in the document.
Shift+N Obtain information with respect to a single selected net in the document.
Shift+M Measure and display the distance between any two points in the document.

Miscellaneous

Shift+G Access the CAM Editor - Drawing Modes page of the Preferences dialog.
Shift+A Access the Edit Apertures dialog in which you can create new aperture shapes and edit, or delete, existing ones.
Shift+Ctrl+R Repeat the previous placement/editing command.

Interactive Shortcuts

The following shortcuts become available when an interactive process has been launched, such as placing a new design object, or moving an existing one. Note that the shortcuts available will depend on the interactive command and the specific design object that is the focus of that command.

PgUp Zoom in.
PgDn Zoom out.
Right-Click Escape from the current command
Esc Escape from the current command. If the current command uses a dialog at any stage, this feature will only cancel out of the dialog. You will need to use the feature again to completely abort the command.

Pop-up Menu Shortcuts

The following shortcuts give access to specific pop-up menus of commands, directly from within the design space itself. Some of these will be familiar as they are sub-menus found within the main menus for the editor. Each of the main menus also have a defined pop-up key for quick access from within the design space, see Accelerator Keys for more information.

B The Toolbars sub-menu (from the main View menu).
C The Circle sub-menu (from the main Edit menu).
G A pop-up menu with snap grid commands
I The Import sub-menu (from the main File menu).
O The Objects sub-menu (from the main Edit menu).
S The Selection sub-menu (from the main Edit menu).
X The Export sub-menu (from the main File menu).
Z A pop-up menu with zoom commands.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: