Working with Schematic Libraries in Altium Designer

Created: June 20, 2022 | Updated: June 20, 2022

Parent page: Working with File-based Component Libraries

This document outlines the creation of schematic components using the schematic symbol editor.

The following topics are covered:

  • Creating new libraries.
  • Creating schematic components with single and multiple parts.
  • Checking the components using schematic symbol editor reports.

This information assumes you have a working knowledge of the schematic editor environment and are familiar with placing and editing components. 

Schematic Libraries, Models and Integrated Libraries

Schematic component symbols are created in schematic libraries (*.SchLib). The components in these libraries then reference footprints and other models defined in separate footprint libraries and model files. As a designer, you can place components from these discrete component libraries or you can compile the symbol libraries, footprint libraries and model files into integrated libraries (*.IntLib).

The advantages of integrated libraries are that they are portable (everything is in one file) and the components and models in them cannot be edited. The bulk of components (around 70,000 ISO-compliant components) are supplied in integrated libraries, which you will find in the Library folder of your Altium Designer installation. You can extract the source libraries out of an integrated library. To do this, open the integrated library and choose Extract Sources to extract the source libraries, which will then be opened for editing. For more information, refer to Working with Integrated Libraries.

You also can create a schematic library of all the components that have been placed in the schematic documents of the active project by clicking Design » Make Schematic Library.

Creating Schematic Components

The schematic symbol editor is used to create and modify schematic components and manage component libraries. It is similar to the Schematic Editor and shares the same graphical design objects, with the addition of the Pin tool. Components are created with the design objects in the schematic symbol editor. Components can be copied and pasted from one schematic library to another or from the schematic editor to the schematic symbol editor.

Creating a New Library Package and Schematic Library

Before we start creating components, we need a new schematic library in which to store them. This library could be created as a stand-alone library, referencing models in separate files. An alternate approach is to create the new schematic library with the intention of compiling it and the referenced models into an integrated library package. This means that before we create the library, we need to create a new library package. A library package (*.LibPkg) is the basis of an integrated library - it binds together the separate schematic libraries, footprint libraries and model files that are ultimately compiled into the single integrated library file.

The new library open at the default Component_1.
The new library open at the default Component_1.

To create a new integrated library package and an empty schematic library, complete the following steps:

  1. Select the File » New » Library command from the main menus and selecting the Integrated Library option from the File region of the New Library dialog that opens. After clicking Create, a new library package named Integrated_Library1.LibPkg is created and displayed in the Projects panel.
  2. Right-click on the library package name in the Projects panel then select Rename. In the dialog that opens, browse to a suitable location, type in the desired file name then click Save. Note that the extension will be added automatically if you do not enter it.
  3. To add an empty schematic library, select the File » New » Library command from the main menus and selecting the Schematic Library option from the File region of the New Library dialog. A new library named Schlib1.SchLib is created.
  4. Click File » Save As then save the library as Schematic Components.SchLib.

Creating a New Schematic Component

To create a new schematic component in an existing library, you would normally select Tools » New Component. However, since a new library always contains one empty component sheet, we will simply rename Component_1 to get started on creating our first component, an NPN transistor.

  1. Select Component_1 from the Design Item ID list in the panel then click the Edit button in the panel or double-click Component_1 to open the Properties panel in Component mode. Type the new component name that uniquely identifies it (for example, NPN) in the Design Item ID field then click Enter.
  2. If necessary, relocate the origin of the sheet to the center of the design window by selecting Edit » Jump » Origin (shortcut J, O). Check the Status line at the bottom left of the screen to confirm that you have the cursor at the origin. Components supplied by Altium are created around this point, marked with a crosshair through the center of the sheet. You should always create your components close to this origin. When you place a component on the schematic, the component will be 'held' by the electrical hot spot (pin end) that is nearest to this origin.
  3. The UnitsSnap Grid, and Visible Grid can be set in the Properties panel in Library Options mode (accessed by choosing Tools » Document Options from the main menus). If desired, enable the Show Comment/Designator option in the Properties panel to display the Comment/Designator strings for the current component in your library document. Rather than opening the Properties panel whenever you need to change the grid, you can press G on the keyboard to quickly cycle through and set the Snap Grid to 1, 5, or 10 units.

The Snap Grid and Visible Grid also can be configured on the Schematic - Grids page of the Preferences dialog.

If the schematic symbol editor grid is not visible, press Page Up to zoom in until it is visible. Note that zooming occurs around the cursor, so keep the cursor close to the origin as you zoom in.

  1. To create the NPN transistor, the component body needs to be defined. Select Place » Line (shortcut P, L), or click the Line button () located on the Active Bar and on the Utilities toolbar drop-down.

The Line button on the Active Bar (left) and the Utilities toolbar drop-down (right).
The Line button on the Active Bar (left) and the Utilities toolbar drop-down (right).
Using the following image and the grid lines as guides, place the vertical line. Click once to place the first end of the line then move the cursor to the location of the other end and click to place it, then right-click or press Esc to end placement of the line. Note that you are still in line placement mode as indicated by the crosshair on the cursor.

Placed NPN bodyPlaced NPN body

  1. For this transistor, the additional two lines are placed at an angle (the arrowhead will be placed in Step 6). Press Shift+Spacebar while you are placing a line to cycle through the different placement modes and find the angle mode that allows you to place the lines correctly. After defining the two angled lines, press Esc to exit placement mode.
The exact location of graphical lines is not critical. What is critical in component design is the pin location or more specifically what is referred to as the hot end of the pin. This is the point that creates the electrical connectivity, therefore, it is the pins you should always place on a grid that is suitable for wiring.
  1. To create the arrowhead, select Place » Polygon (shortcut P, Y) or click the Polygon button () located on the Active Bar and on the Utilities toolbar drop-down.

The Polygon button on the Active Bar (left) and Utilities toolbar drop-down (right) 

Before placing, press the Tab key to open the Properties panel to define the Polygon properties. Set Border to Smallest, ensure Transparent is not enabled and set the Fill Color and the Border color boxes to the same color as shown in the following image.

In the design space, click to place each vertex of the triangle (arrowhead) then right-click to end. Right-click or press Esc to end polygon placement mode. Double-click the placed polygon to open the Properties panel. In the Vertices region, set the vertices for the placed polygon.

  1. Save the component by clicking File » Save (shortcut Ctrl+S).

Adding Pins to the Schematic Component

Component pins give a component its electrical properties and define connection points on the component. They also have graphical properties. To place pins on the component:

  1. Select Place » Pin (shortcut P, P) or click on the Place Pin button (The Pin button on the Utilities toolbar drop-down (left) and the Active Bar (right)) located on the Utilities toolbar drop-down and the Active Bar.

    The Pin button on the Utilities toolbar drop-down (left) and the Active Bar (right)
    The Pin button on the Utilities toolbar drop-down (left) and the Active Bar (right)
    The pin appears floating on the cursor, held by the electrical end (also referred to as the hot end) that must be placed away from the component body.
  2. Before placing the pin, press the Tab key to open the Properties panel to edit the Pin properties.

If you define the pin attributes before it is placed, the defined settings become the defaults and the pin numbers and any numeric pin names will auto-increment when you place them, which makes placement much easier and quicker.
  1. In the Properties panel, enter a pin name in the Name field (1 for the first NPN pin), and a unique pin number (also 1) in the Designator field. Enable visibility by ensuring the visibility is set to  if you want the pin name and designator visible when you place the component on a schematic sheet.
  2. Set the Electrical Type of the pin from the drop-down list. This type is used when a project is compiled or when analyzing a schematic document to detect electrical connection errors in a schematic sheet. In this component example, all pins should have the Electrical Type set to Passive.
  3. Set the Pin Length to 200 mil (all pins in this component will be set to 200 mil), then click Enter.
  4. Press the Spacebar to rotate the pin in 90º increments while it is floating on the cursor. Only one end of a pin is electrical (the hot end) and you must place the pin with this end out from the component body. The non-electrical end of the pin has the pin name next to it.
  5. Continue to add the pins required to finish the component, making sure the pin names, numbers, symbols, and electrical types are as shown in the following image.

If you want to alter the distance (in hundredths of an inch) between the pin name or number and the body of the component, select Tools » Preferences and change the Pin Margin options on the Schematic - General page of the Preferences dialog.
  1. The drawing of your component is complete. Click File » Save to save it.

Notes on Adding Pins

  • To set pin properties after placing the pin, double-click on the pin to open the Properties panel in Pin mode. 
  • Use "\" (backslash) after a letter to define an over-scored letter in a pin name. 
  • You also can edit pin properties directly in the Properties panel in Component mode without having to edit each pin individually. On the Pins tab in the Properties panel, click  to open the Component Pin Editor dialog as shown in the following image.

Review and edit all pins in the Component Pin Editor dialog.
Review and edit all pins in the Component Pin Editor dialog.

  • For a multi-part component, the relevant pins for the selected part will be highlighted in the Component Pin Editor dialog. All pins of other parts are grayed out. 

Setting the Schematic Component's Properties

Each component has properties associated with it such as the default designator, the PCB footprint and/or other models, and any parameters that have been defined for the component. Perform the following steps to set the component's properties:

  1. Select the component in the Components list of the SCH Library panel then click the Edit button or double-click on the component name to open the Properties panel.
  2. Type "Q?" in the Designator field. Including the question mark allows the Designator to auto-increment upon placement (Q1, Q2, etc.,) if the designator is defined before placing the component (press Tab while placing to edit an object before placement).
  3. Enter a Comment that will display when the component is placed on a schematic sheet, e.g., NPN. Make sure the visibility option for the Designator and Comment fields is enabled (). If the Comment field is left blank it will automatically be populated with the Name in the Links region when the component is placed.
  4. Enter a string into the Description field that describes the transistor, e.g., Transistor, NPN Generic. This string is searched during a library search and is displayed in the Components panel.
  1. Leave the other fields at their default values while models and parameters are added, as required.

Adding Models to the Schematic Component

You can add any number of PCB footprint models to a schematic component, as well as model files that are used for circuit simulation and signal integrity analysis. If a component has multiple models (for example, multiple footprints), you can select the appropriate model in the Properties panel when you place the component on a schematic. In terms of sourcing the models, you can create your own or download a vendor's model file from the web. PCB libraries can include any number of PCB footprints.

Wherever possible, Spice models used for circuit simulation (.ckt and .mdl files) are included in the supplied integrated libraries in the Library folder of your Altium Designer installation. If you are creating a new component, you would typically source the Spice model from the device vendor's website. You can also use the XSpice Model Wizard (Tools » XSpice Model Wizard) to create certain Spice model types to add to the component.

The schematic symbol editor's Model Manager dialog (Tools » Model Manager) enables you to view and organize your component models. For example, you can add the same model to multiple, selected components. Alternatively, you can add models to the current component by using the Add drop-down in the Parameters region of the Properties panel in Component mode then selecting the model, or from the Model region of the design space (click the upside-down arrows/caret symbol on the bottom-right of the design space as shown in the following image).

Click the highlighted caret symbol to access the Model region of the design space.

Search Locations for Model Files

When you add a model to a component in the schematic symbol editor, the model is linked; the model data is not copied or stored in the schematic component. This means the linked models must be available both during library creation and when the component is placed on a schematic sheet. When you are working in the library editor, the link from the component to the model information is resolved using the following valid search locations:

  • Libraries that are included in the current library package project are searched first.
  • PCB libraries (not integrated libraries) that are available in the currently Installed Libraries list are searched next. Note: The list of libraries can be ordered.
  • Finally, any model libraries that are located on the project search paths are searched. Search paths are defined on the Project Options - Search Paths tab of the Project Options dialog (Project » Project Options). Note: Libraries that are on the search path cannot be browsed to locate a model, however, the compiler does include them when searching for a model.

In this document, we will use different methods of linking the components and its model files. When the library package is compiled to create the integrated library, the various models are copied from their source locations into the final integrated library.

Adding Footprint Models to a Schematic Component

First, we will add the model that represents the component in the PCB Editor, i.e. the footprint (also known as a 'pattern' or 'decal' in other design tools). The footprint we will use for our schematic component is named "BCY-W3". When linking a PCB footprint model to a schematic component in the schematic symbol editor, the model must exist in a PCB library, not an integrated library.

  1. In the Properties panel in Component mode, use the Add drop-down in the Parameters region then select Footprint to open the PCB Model dialog.

  1. Click the Browse button to open the Browse Libraries dialog to browse footprint libraries that have been added to your library project.

  1. If the desired footprint is not available in any of the current libraries, you will need to search for it using the Find button to open the File-based Libraries Search dialog.
  2. Set the Scope to Libraries on path and the Path to the appropriate folder. Ensure the Include Subdirectories option is enabled.
  3. In the query field at the top of the dialog, enter the appropriate Field and Value then click Search.

  1. Select the desired *.PcbLib file from the resulting Browse Libraries dialog then click OK to return to the PCB Model dialog.

Select the desired footprint in the Browse Libraries dialog.

  1. If this is the first time you have used this library, you will be asked to confirm the installation of this library, which will make it available for future use. Click Yes in the Confirm dialog. The PCB Model dialog is updated with the footprint model information.
  2. Click OK to add the model. It will appear in the Parameters region in the Properties panel and also in the Models region at the bottom of the design space.
  3. After you add the model, it is a good idea to check the Pin-Pad mapping. To do this, open the PCB Model dialog (select the footprint in the Parameters region of the Properties panel then click  or double-click the model in the Model region) then click Pin Map to open the Model Map dialog and make any necessary edits for the Pin-Pad pairs.

Adding Component Parameters

Component parameters are a means of defining additional information about the component. This could include data your company needs in the BOM, manufacturer's data, a reference to the component datasheet, or design instruction information, such as design rules or assignment to a PCB class, etc. Parameters can be used to add any useful information that you might need for a component and are configured in the Properties panel.

Use the following steps to add a parameter to a schematic component:

  1. Double-click on the component name in the SCH Library panel to open the Properties panel in Component mode.
  2. In the Parameters region, select Parameter from the Add drop-down.
  1. Enter the desired name of the parameter and a value.
  2. Ensure the Parameter's visibility option is set to enabled () if you want the name and value to display when the component is placed on a schematic sheet.
  3. Click the Font Link and Other at the bottom of the Parameters region to access additional options to configure parameters. 

You also can select the parameter in the design space to open the Properties panel in Parameter mode to configure the parameter.
To edit and manage parameters across all components in a library, use the Parameter Table Editor dialog. The dialog is accessed by enabling the required parameters in the Parameter Editor Options dialog (Tools » Parameter Manager) then clicking OK.

Parameters for Component-to-Datasheet Linking

Parameters can be used to create links from the component to reference material, such as data sheets. Linkage is established by adding specific component parameters. One approach is to use the F1 key to access a referenced document. The other, which caters to multiple references, uses the right-click context menu.

HelpURL

If a component includes a parameter with the reserved name HelpURL, then the URL will be resolved when the F1 key is pressed while the cursor is hovering over the component. The URL can actually be a web address, a text file, or a PDF file.

The second technique supports multiple links and naming of each link. In this situation, you add a pair of parameters: one that points to the linked document or URL and a second that defines a label (or description) for the link. The parameter pairs are defined as follows.

 

Parameter Name

Example Parameter Value

1 st parameter

ComponentLink1URL

C:_ _My Datasheets\XYZDatasheet.pdf

2 nd parameter

ComponentLink1Description

Datasheet for XYZ

1 st parameter

ComponentLink2URL

C:_ _My Datasheets_ _Alternate XYZDatasheet.pdf

2 nd parameter

ComponentLink2Description

Datasheet for Alternate XYZ

Any number of links can be defined using the same parameter pair with the number incremented. When you right-click on a component that uses datasheet linking, a Reference menu entry appears with an entry for each component link in the sub-menu.

String Indirection

There might be instances when you need to define a placeholder that will be populated with text at a later time. For example, you might want a parameter called DesignedBy on a schematic template whose value is defined when the template is used for a new schematic. Altium Designer uses a technique known as string indirection to support this requirement. At the schematic sheet level, you can add a document parameter whose value is left blank. You then place a standard string on the document, as an example, "=DesignedBy". The equal sign sets this string to be an indirection string. Instead of displaying the text, it will display the current value of the document parameter DesignedBy.

String indirection also can be used with components. As well as displaying any parameter that has been added to the component in its own right by enabling the  option, you also can indirect the string to the component's Comment field. One situation where string indirection is useful is for a component that is used for both PCB design and circuit simulation. During schematic-to-PCB design transfer, the schematic Comment field is mapped to the Comment field of the PCB component. However, for circuit simulation, the Comment field is not used since the simulator can require many properties for a component. For example, a BJT has five simulation properties and these five properties instead are defined as parameters. In this case, any of the circuit simulation parameters can be mapped to the Comment field using string indirection by entering the name of the parameter preceded by an equal sign ("="). For example, a resistor has one simulation parameter, called Value. If the resistor's Comment field is set to =Value , then the contents of the Value parameter will be displayed as the Comment. If you are tuning the resistance value during simulation, the correct resistance will be used when you transfer the design to the PCB layout.

Checking the Component and Generating Reports

To check that the new components have been created correctly, there are three reports that can be generated. Ensure the library file is saved before the reports are generated. 

Component Rule Checker

The Component Rule Checker tests for errors such as duplicates and missing pins.

  1. Select Reports » Component Rule Check (shortcut R, R) to open the Library Component Rule Check dialog.

  1. Set the attributes you want to check then click OK. A report titled <libraryname.ERR> displays in the design space that lists any components that violate the rule check.

  1. Make any adjustments necessary to the library then rerun the report.
  2. Save the schematic library. Close the report to return to the schematic editor design space.
Linkage from the component pins to the model is not checked by the Component Rule Checker. This level of linkage is checked, however, when a library package is compiled into an integrated library. Even if you do not intend to use the compiled integrated libraries, it is beneficial to create and manage your libraries using library packages.

Component Report

The Component Report lists all the information available for the active component.

  1. Select Reports » Component (shortcut R, C).
  2. A report titled <libraryname.cmp> displays in the design space and includes the number of parts with the pin details for each part in the component.

  1. Close the report to return to the schematic editor design space.

Library Report

To create an extensive report of each component in the library:

  1. Select Reports » Library Report to open the Library Report Settings dialog.

  1. Configure the report settings then click OK. The report will open in Microsoft Word or your web browser depending on the style chosen.

Copying Components from Other Libraries

You also can copy components to your schematic library from other open schematic libraries and then edit their properties as required. If the component is part of an integrated library, you will have to open the .IntLib file and choose Yes to extract the source libraries. Then open the generated source library (*.SchLib) from the Projects panel.

  1. Select the component that you want to copy in the Design Item ID list of the SCH Library panel so it displays in the design window.

  1. Select Tools » Copy Component to open the Destination Library dialog, which lists all currently open schematic library documents.

  1. Select the document to which you want to copy the component then click OK. A copy of the component will be placed in the destination library where you can edit it, if necessary.

Copying Multiple Components

You also can use the SCH Library panel to copy multiple components. Select the components in the panel using the standard Ctrl+Click or Shift+Click features, then right-click on one of the selected components and choose Copy from the pop-up menu. You can then right-click in the list and:

  • Paste the component(s) back into the same library.
  • Paste the component(s) into another open library.
  • Copy and paste components from a schematic into an open library using the same technique.

Creating a New Schematic Component with Multiple Parts

The transistor symbol that you have created represents the entire component - this symbol represents what is supplied in the physical package delivered by the device manufacturer. There are situations where one physical component is better represented as a collection of parts. For example, there are resistor networks that contain eight individual resistors and each can be used independently of the others. Another example would be a 74F08SJX quadruple 2-input AND gate - in this device, there are four independent 2 input AND gates. While the component could be drawn as a single symbol showing all four gates, it would be more useful if it is drawn as four separate gates, where each gate can be placed independently of the others anywhere on the schematic. This approach of drawing a component as a set of separate parts is referred to as a multi-part component.

This section outlines the steps to create a 74F08SJX Quad 2-IN AND gate. We also will create an alternate view mode for the component, i.e. an IEEE representation of the device.

  1. In the schematic symbol editor, click Tools » New Component (shortcut T, C) to open the New Component dialog.
  2. Type in the name of the new component, e.g., 74F08SJX, then click OK.

The new component name displays in the list in the SCH Library panel and an empty component sheet displays with a crosshair through the center (origin) of the sheet.

  1. Now we will create the first part of the new component including its pins as described in the following sections. The first part will then be used as the basis for the other parts since only the pin numbers need to change between the parts.

Creating the Body of the Component

The body of this component is constructed from a multi-segment line and a circular arc. Make sure the component sheet origin is in the center of the design space by selecting Edit » Jump » Origin (shortcut: J, O). Also, make sure the grid is visible (View » Grids).

Placing Lines

  1. Note the current grid setting displayed on the Status bar (bottom left). Set the grid to 5 by using the View » Grids » Set Snap Grid menu command.
  2. Select Place » Line (shortcut P, L) from the main menus, click the  on the Active Bar or the Utilities toolbar drop-down. The cursor changes to a crosshair and you are now in multi-segment line placement mode.
  3. Press the Tab key to open the Properties panel in Polyline mode to set the line's properties. Set Line to Small. Click Esc or the  in the design space to re-enter placement mode.
  4. Refer to the X, Y coordinates on the left side of the Status bar; position the cursor at 25, -5, then click or press Enter to anchor the starting point of the line. Then position the mouse and click to anchor a series of vertex points that define the segments of the line (at 0,-5; 0,-35 and 25,-35).
  5. When you have finished drawing the line, right-click or press Esc to exit line placement mode.
  6. The completed polyline is shown below. Save the document.

Drawing an Arc

Placing an arc is a four-step process that sets the center point, radius, start angle, and end angle of the arc. You can press Enter instead of click to place the arc.

  1. Select Place » Arc (Center) (shortcut P, A) or click  on the Active Bar. The last arc drawn appears on the cursor and you are now in arc placement mode. 
  2. Press Enter to accept the arc start angle; when the cursor jumps again, press Enter again to define the arc end angle.
  3. Press the Tab key to open the Properties panel in Arc mode to set the arc's properties. Set the Radius to 15, Start Angle to 270, End Angle to 90, and the Width to Small. Use the Location region to define the coordinates: X: 25, Y: -20.
  4. There is no need to move the mouse since the cursor will jump to the correct location to define the Radius of 15 as in the Properties panel. Press Enter to accept the radius setting.
  5. The cursor will then jump to the start point of the arc, as set in the panel.
  6. Without moving the mouse, right-click or press Esc to exit Arc placement mode.

Adding Signal Pins

Add the pins using the same technique described in the Adding Pins to a Schematic Component section earlier in this document. Configure Pins 1 and 2 with an Electrical Type of Input and Pin 3 is Output. Set the pin Length to 20. The completed part is shown below.

 

Creating Parts 2, 3, and 4

  1. Select the component by clicking Edit » Select » All (shortcut Ctrl+A) from the main menus.
  2. Click Edit » Copy (shortcut Ctrl+C) to copy to the clipboard.
  3. Click Tools » New Part. A blank component sheet displays. In the SCH Library panel, the 74F08SJX component has been updated to include Part A and Part B. Click on the triangle to the left of the component name in the Design Item ID list in the SCH Library panel to view the new parts.

  1. Click Edit » Paste (shortcut Ctrl+V). The outline of the component part will appear on the cursor. Place it at the same relative location to the sheet origin as Part A (the black cross-hair in the center of the sheet indicates the origin). If necessary, select and move the copied part until it is positioned the same as the original part.
  2. Update the pin information in the new part (Part B) by double-clicking on each pin and changing the pin name and number in the Properties panel. When complete, Part B will look like the image below.

  1. Repeat steps 3 through 5 to create the remaining two parts, Parts C and D. Save the library.

Adding Power Pins

To define the power pins, you can create a fifth part for the component and place the VCC and GND pins on that part. Remember to enable the  option in the Properties panel to ensure that it cannot be swapped with any of the gates during re-annotation.

Setting the Component's Properties

  1. Set the component's properties by clicking the Edit button in the SCH Library panel when the component is selected in the Design Item ID list. In the Properties panel, set the Designator to U? and the Description to Quad 2-Input AND Gate. In the Parameters region of the panel, use the Add drop-down then select Footprint to open the PCB Model dialog. Enter DIP14 in the Name region.
  2. Save the component in the library by selecting File » Save from the main menus.

Creating an Alternate View Mode for a Part

You can add many alternate view modes to a component part. These view modes can contain different graphical representations of the component, such as a DeMorgan or an IEEE representation. Each alternate view mode should always have the same set of pins as the Normal mode. If an alternate view of a part has been added, it is displayed for editing in the schematic symbol editor by selecting the alternate mode from the Mode drop-down in the Mode toolbar.

To add an alternate view mode, with the component part displayed in the design window of the schematic symbol editor:

  1. Select Tools » Mode » Add or click on the  button on the Mode toolbar. A blank sheet for Alternate 1 displays.
  2. Typically, you would copy the part you created in the Normal mode and paste it into the new Alternate mode. Use Edit » Copy and Edit » Paste to copy and paste the Normal mode to the Alternate mode. This gives you the correct set of pins and you can modify the graphical elements and position the pins as required.
  3. Click File » Save to save the library.

IEEE Representations

If a graphical IEEE representation needs to be added to the component, Altium Designer includes a selection of IEEE symbols. To access and place the symbols, use the IEEE Symbols toolbar (shown below) or click Place » IEEE Symbols.


SCH Library Panel

The SCH Library panel enables you to view and make changes to the components stored in the active schematic library document. The panel also offers the ability to pass on any changes made to components in the library directly to the schematic design document, and also to define model linking for a component.

Interactively browse, view and edit schematic library components and their pins.
Interactively browse, view and edit schematic library components and their pins.

Library Browsing

As you click on a component entry in the list, it will become the active part in the design editor window. The design editor window is editable, allowing you to change the symbol for the component and add, edit, or remove linked models for the component as required. Selecting a Pin object in the panel causes the corresponding graphical object to be highlighted (and zoomed) in the editor workspace. In this way, the SCH Library panel offers a fast and easy way to browse, view and access schematic library components and pins.

Filtering Content

The contents of the Components list can be filtered, enabling you to quickly find a particular component within the library. This is especially useful if the library contains a large number of items. Filtering can be applied using one of the methods described in the following sections.

Indirect Filtering

This filtering method uses the search field at the top of the panel to filter the contents of the list. The name masking is applied based on the entry in the field. Only those components in the list targeted by the scope of the entry will remain displayed.

To list all library component footprints again, clear (delete) the entry in the search field.

The filtering feature is not case sensitive and supports 'type-ahead' functionality, meaning that the content of the Components list is filtered as you type.

Use the * wild card operator for more elaborate filtering. For example, typing MN* will display only component footprints whose names begin with MN, or, as in the image below, typing *r34 will display only component footprints where the body of the name contains R34.

Direct Filtering

This method is available for all regions in the panel and allows you to quickly jump to an entry by directly typing within the area of the list. Masking is not applied, leaving the full content of the list visible at all times.

To use the feature for quickly finding a component footprint, click inside the Components section of the panel then type the first letter of the component footprint to which you want to jump. For example, if you wanted to quickly jump to component entries starting with the letter R, you would press R on the keyboard. The first component in the list starting with R would be made active.

If there are multiple Design Item IDs starting with the same letter and especially if the library is particularly large, type additional letters to target the specific entry you require. For example, type res to highlight the first of the RES series in the list.

To clear the current filtering to allow you to enter a different starting letter, press Esc. Use the Backspace key to clear the previously entered filter characters in sequence.

Combination Filtering

In some situations, it may be helpful to use indirect and direct filtering simultaneously. If, for example, you know that the component you want to locate has a sub-type variant of BRMZ and a prefix of AD74, this information can be used as Indirect (Mask) and Direct entries, respectively.

Panel Sections

Components 

As you click on a entry in the Components list, it will become the active part in the design editor window and for the four buttons located directly beneath the list. These buttons provide the following commands that can be used with respect to the list of components:

  • Place - click to place the active component onto a schematic design document. When clicked, the schematic document that is used will depend on whether or not any schematic documents are currently open.
    • If there are no schematic documents open, clicking the button will cause a new schematic document to be created that will be the active document in the design editor window. The active library component will appear floating on the cursor, ready for placement.
    • If one or more schematic documents are currently open, the last document to have been active (regardless of the project to which it belongs) will be made the active document in the design editor window and the active library component will appear floating on the cursor, ready for placement.
  • Add - click to add a new component to the library document. The New Component dialog will open. Enter the required name for the new component to be added to the list. A blank sheet will be opened in the design editor window ready for you to define the component.
  • Delete - click to permanently delete the selected component(s) from the library document. A confirmation dialog will open asking whether or not to proceed with the deletion.
  • Edit - click to open the Properties panel in which you can view/edit properties associated with the active component. The panel provides access to create links to new models or edit existing ones. Double-clicking on a Design Item ID entry will also open the Properties panel.

For more Component list options, see the Right-click Menus section below.

Right-Click Menus

Right-clicking on an entry in the Components list will open a menu of commands.

The commands are as follows:

  • Select all - quickly select all component entries in the list.
  • Update Schematic Sheets - click to pass on all changes made to components within the active library document to all open schematic design documents. All instances of changed components that exist on the design documents will be updated.
  • Model Manager - access the Model Manager dialog in which you can add, edit or remove models with respect to any of the components contained in the active library.

  • Copy - place a copy of the selected component(s) onto the schematic library editor's internal clipboard.
  • Cut - place a copy of the selected component(s) onto the schematic library editor's internal clipboard and permanently delete the component(s) from the library. A dialog will appear asking for confirmation to proceed with the deletion.
  • Paste - paste a component from the schematic library editor's internal clipboard into the active library document.
  • Delete - use to permanently delete the selected component(s) from the library document. A dialog will appear asking for confirmation of whether or not to proceed with the deletion.

Notes

  • Standard Ctrl+Click and Shift+Click functionality is supported for selection of multiple entries in a list.
  • The active component is the one that has its symbol and corresponding model information currently displayed in the design editor window. A component can be active without necessarily being selected in the Components list.
  • Ctrl+Click over a selected entry in a list to deselect it.
  • The keyboard shortcuts Up Arrow, Home, End, and Down Arrow can be used to display the previous, first, last, and next entry in a list region, respectively.
  • Multi-part components appear in the list with  (expand) next to them. Each part is listed as a sub-entry below.
  • In sections of the panel where multiple columns of data exist, the data may be sorted by any column by clicking on the header for that column. Click once to sort in ascending order; click again to sort in descending order.
  • You can change the order in which columns of data are displayed. To move a column, click on its header and drag it horizontally to the required position. A valid position is indicated by the appearance of two positional arrows.
  • The component that you paste into the active library document can originate from either a schematic design document or another schematic library document.
  • If multiple components have been copied to the clipboard from the main design in the schematic editor, all components in the selection will be pasted into the library document.
  • If the same component is pasted into the library more than once, or if more than one new component is added to the library without renaming, the copies are distinguished by the suffix _1, _2, _3, etc.
  • A schematic design document must be open in order to pass on changes made to components in the library document.
  • When a new schematic library document is created the panel will contain a single, blank component - Component_1.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: