Verifying a Component before Saving to a Workspace in Altium Designer

Created: January 31, 2023 | Updated: January 31, 2023
Applies to Altium Designer versions: 23 and 24

Parent page: Building & Maintaining Your Components and Libraries

Before saving a Workspace Library component defined/edited in the Component Editor (in its Single Component Editing or Batch Component Editing mode) to the connected Workspace and making the component be available for use in designs, it is essential to make sure that this component meets the requirements in accordance with the configured settings. When you attempt to save a component back to the Workspace, the Component Editor runs a validation – a Component Rule Check. This feature can also be run at any time, manually, by choosing the Tools » Component Rule Check command, from the main menus. Be sure to have saved your component locally (File » Save) before you do.

The Component Rule Check command is also available from the editor's main File menu and from the component entry's right-click menu in the Projects panel.

Just as a board project has the validation process to detect any violations, the Component Editor has a Component Validator. Any violations that are found are listed in the Messages panel.

Detecting issues with a component prior to saving to the Workspace. Shown here is running the Component Rule Check command from the Component Editor in its Single Component Editing mode. Hover the cursor over the image to see running the command from the Component Editor in its Batch Component Editing mode.
Detecting issues with a component prior to saving to the Workspace. Shown here is running the Component Rule Check command from the Component Editor in its Single Component Editing mode. Hover the cursor over the image to see running the command from the Component Editor in its Batch Component Editing mode.

The Component Validator tests for an array of potential issues with the component and its defined models – both hardwired tests, as well as a range of violation types that can be user-defined at the global level.

The following hardwired validation checks all carry a report mode of :

Summary

This violation occurs when a component being defined in the Component Editor has no added links to the domain models (Symbol, Footprint(s), Simulation Model(s)).

Notification

A notification will be displayed in the Messages panel in the following format:

Component is not linked to any models.

Recommendation for Resolution

  • In the Component Editor in its Single Component Editing mode, add links to saved (or created on-the-fly) domain models using the Model region of the editor, for use by the component.
  • In the Component Editor in its Batch Component Editing mode, add links to saved domain models listed in the Model Links region of the editor, for use by the component.

Summary

This violation occurs when a folder in the target Workspace where a component being defined in the Component Editor should be saved is not specified.

Notification

A notification will be displayed in the Messages panel in the following format:

Folder path not specified for component <ItemID>

where:

  • ItemID is the ID used for the component in the Workspace.

Recommendation for Resolution

  • In the Component Editor in its Single Component Editing mode, use the Folder field in the Component to specify a folder in the target Workspace where the component will be saved to. To manually specify a target folder, click the  button to access the Choose Folder dialog. Browse to, and choose an existing folder, or create a new one on-the-fly.
  • In the Component Editor in its Batch Component Editing mode, use the FolderPath field (in the Component column group) in the component definition region of the editor to specify a folder in the target Workspace where the component will be saved to. To manually specify a target folder, click once inside the FolderPath field for a component to reveal the  button, and click to access the Choose Folder dialog. Browse to, and choose an existing folder, or create a new one on-the-fly.

Summary

This violation occurs when the Item ID of a component being defined in the Component Editor is the same as the Item ID of another item in the connected Workspace.

Notification

A notification will be displayed in the Messages panel in the following format:

Duplicate Component Id: "<ItemID>"

where:

  • ItemID is the ID used for the component in the Workspace.

Recommendation for Resolution

  • In the Component Editor in its Single Component Editing mode, use the Id field in the Component region to specify another ID which is unique for the connected Workspace content.
  • In the Component Editor in its Batch Component Editing mode, use the Item ID field in the Component column group of the component definition region to specify another ID which is unique for the connected Workspace content.

Note

This violation typically occurs when an automatically assigned Item ID value of a component is manually overridden. For a new component created through the File » New » Component command or the Components panel, this field is populated in accordance with the component template defined for the component type chosen in the Create new component dialog. Where a template does not exist, or where the <Undefined> entry is chosen in the dialog, a default naming scheme is used; CMP-{00000}. For a new component created through the Explorer panel, this field is populated in accordance with the default naming scheme specified for that component's parent folder. If the parent folder has a component template attached, then defined Component Naming will be brought in from that template. The software will automatically assign the next available unique ID, based on that scheme, having scanned the entire Workspace and identifiers of existing content.

User-definable checks are configured on the Data Management – Component Rule Checks page of the Preferences dialog.

User-definable violation checks that can be configured as part of global preferences, for use with the Component Validator.
User-definable violation checks that can be configured as part of global preferences, for use with the Component Validator.

Any of the hardwired tests that fail, or user-defined checks at a level of Fatal Error, will prevent saving of the component to the Workspace.

The default settings of the user-defined checks may not suit your components and, therefore, it is important to become familiar with the options and how to configure them to suit your designs. Information about each user-defined error check can be found below.

Violations Associated with Components

Default report mode:

Summary

This violation occurs when the name of a component being defined in the Component Editor is the same as the name of a component in the connected Workspace.

Notification

A notification is displayed in the Messages panel in the following format:

Duplicate component by Name

Recommendation for Resolution

Assign different and unique name(s) to the component(s) as required.

  • In the Component Editor in its Single Component Editing mode, use the Name field in the Component region to specify another name which is unique for the components in the connected Workspace.
  • In the Component Editor in its Batch Component Editing mode, use the Item ID field in the Component column group of the component definition region to specify another name which is unique for the components in the connected Workspace.

Default report mode:

Summary

This violation occurs when a component being defined in the Component Editor has a Part Choice that is used by another component in the connected Workspace.

Notification

A notification is displayed in the Messages panel in the following format:

Duplicate component by Part Choice list

Recommendation for Resolution

Assign different and unique Part Choice(s) to the component(s) as required.

  • In the Component Editor in its Single Component Editing mode, use the Part Choices region to change the list of component Part Choices to which is unique for the components in the connected Workspace.
  • In the Component Editor in its Batch Component Editing mode, use the Part Choice n column group of the component definition region to change the list of component Part Choices to which is unique for the components in the connected Workspace.

Default report mode:

Summary

This violation occurs when a component being defined in the Component Editor has an ambiguous mapping between component symbol and footprint(s). For example, the violation occurs if the symbol has pins defined in their Designator fields as 1, 2, 3, while the footprint has pads defined in their Designator fields as B, C, E, or when the number of symbol pins is larger than the number of footprint pads.

Notification

A notification is displayed in the Messages panel in the following format:

Pin <PinDesignator> of the symbol <SymbolName> (<SymbolRevisionID>) does not have corresponding pad <PadDesignator> in footprint <FootprintName> (<FootprintRevisionID>)

where:

  • PinDesignator is the symbol pin's Designator.
  • SymbolName is the name of the symbol.
  • SymbolRevisionID is the Item-Revision ID of the symbol.
  • PadDesignator is the footprint pad's Designator.
  • FootprintName is the name of the footprint.
  • FootprintRevisionID is the Item-Revision ID of the footprint.

Recommendation for Resolution

Edit currently added or select another model to make sure that symbol pins have one-to-one matching to footprint pads.

  • In the Component Editor in its Single Component Editing mode:
    • click the  control at the top-right of model's preview to modify the model that is currently being used (referenced) by the component in the corresponding temporary editor for that model type;
    • click the  control at the top-right of model's preview and choose the Select Model entry from the menu to browse for and choose, a different model, or a different revision of that same model;
    • click the  control at the top-right of symbol's preview to access the Pins panel and change the mapped pad/pin targets directly by clicking on a cell of the model and entering the required value.
  • In the Component Editor in its Batch Component Editing mode:
    • right-click on the model entry in the Model Links region and choose the Edit command from the context menu to modify the model that is currently being used (referenced) by the component in the corresponding temporary editor for that model type;
    • click on the model's Item ID field in the Model Links region then click on the  button to browse for and choose, a different model, or a different revision of that same model.

Default report mode:

Summary

This violation occurs when the description of a component being defined in the Component Editor is not specified.

Notification

A notification is displayed in the Messages panel in the following format:

Component Description is not specified

Recommendation for Resolution

Specify a description for the offending component(s) as required.

  • In the Component Editor in its Single Component Editing mode, use the Description field in the Component region to specify a description.
  • In the Component Editor in its Batch Component Editing mode, use the Description field in the Component column group of the component definition region to specify a description for the offending component(s).

Default report mode:

Summary

This violation occurs when the name of a component being defined in the Component Editor is not specified.

Notification

A notification is displayed in the Messages panel in the following format:

Component Name is not specified

Recommendation for Resolution

Specify a name for the offending component(s) as required.

  • In the Component Editor in its Single Component Editing mode, use the Name field in the Component region to specify a name.
  • In the Component Editor in its Batch Component Editing mode, use the Name field in the Component column group of the component definition region to specify a name for the offending component(s).

Default report mode:

Summary

This violation occurs when the type of component being defined in the Component Editor is not specified.

Notification

A notification is displayed in the Messages panel in the following format:

Component Type is not specified

Recommendation for Resolution

Specify a type for the offending component(s) as required.

  • In the Component Editor in its Single Component Editing mode, use the Type field in the Component region to specify a type.
  • In the Component Editor in its Batch Component Editing mode, use the Type field in the Component column group of the component definition region to specify a type for the offending component(s).

Default report mode:

Summary

This violation occurs when a linked model that is being used (referenced) by a component definition is detected to be in an inapplicable state. For example, the model is currently Obsolete and should therefore not be used. Applicability is determined through the Allowed to be used in designs option in the State Properties dialog. From within the Edit Lifecycle Definitions dialog, access this dialog for the required state, either by double-clicking on the state's entry within the parent lifecycle definition or by selecting its entry and clicking the edit icon that appears (). When this option is enabled, a model in this state is permitted to be used in a component. It is deemed to be Applicable. If this option is disabled, a model in this state cannot be validly used and is deemed Inapplicable (or non-applicable).

The Edit Lifecycle Definitions dialog is itself accessed from the Data Management – Servers page of the Preferences dialog, by clicking the Properties button for the Workspace to which you are actively connected, then selecting Lifecycles from the drop-down menu.
When connected to an Altium 365 Workspace, note that configuration and use of lifecycle definitions are not supported with the Altium Designer Standard Subscription. As such, this violation check will not be available.

Notification

A notification is displayed in the Messages panel in the following format:

<ModeName> (<ModelRevisionID>) revision is in inapplicable state

where:

  • ModelName is the name of the model.
  • ModelRevisionID is the Item-Revision ID of the model.

Recommendation for Resolution

Choose a replacement model or revision of the same model that is valid for use in the component.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of model's preview and choose the Select Model entry from the menu to browse for and choose, a different model, or a different revision of that same model.
  • In the Component Editor in its Batch Component Editing mode, click on the model's Item ID field in the Model Links region then click on the  button to browse for and choose, a different model, or a different revision of that same model.

Default report mode:

Summary

This violation occurs when a linked model that is being used (referenced) by a component definition is detected to be out of date. If there is a later revision of the model available, the Revision State field will reflect this using the text Out of date, to the right of the current revision's lifecycle state under the model's preview (in the Component Editor in its Single Component Editing mode), or the Revision Status field in the Model Links region will be flagged by the text Out of date, shown in bold font (in the Component Editor in its Batch Component Editing mode).

Notification

A notification is displayed in the Messages panel in the following format:

<ModeName> (ModelRevisionID) revision is Out of Date

where:

  • ModelName is the name of the model.
  • ModelRevisionID is the Item-Revision ID of the model.

Recommendation for Resolution

Update the component model links that are out-of-date to use the latest revision of the models.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of the model's preview and choose the Update to Latest entry from the menu.
  • In the Component Editor in its Batch Component Editing mode, right-click anywhere on the model's entry in the Model Links region and choose Update to Latest Revision from the menu.

Default report mode:

Summary

This violation occurs when the component revision being edited in the Component Editor in its Single Component Editing mode is not the latest revision available in the connected Workspace.

Notification

A notification is displayed in the Messages panel in the following format:

<ComponentName> (<ComponentRevisionID>) revision is Out of Date

where:

  • ComponentName is the component's Name.
  • ComponentRevisionID is the Item-Revision ID of the component.

Recommendation for Resolution

Select the latest component revision for editing. To do this, browse for the component in the Components panel, right-click its entry in the panel and choose Edit.

Default report mode:

Summary

This violation occurs when an incorrect entry for a component's part choice is added, and the part can not be retrieved by the Workspace.

Notification

A notification is displayed in the Messages panel in the following format:

Manufacturer+Part Number combination was not found in the available Part Sources ("Part Choice <n>")

where:

  • n is the sequential number of the offending part choice.

Recommendation for Resolution

Specify valid part choice for the offending component(s).

  • In the Component Editor in its Single Component Editing mode, remove invalid part choices from the Part Choices region and add new, correct part choices.
  • In the Component Editor in its Batch Component Editing mode, enter correct values to the Part Choice n fields in the component definition region. Note that while a part choice field value has an incorrect entry, the text will appear greyed and in italics. Once both entries are correct, the text will appear as normal, white text.

Violations Associated with Footprints

Default report mode:

Summary

This violation occurs when a footprint model linked to a component being defined in the Component Editor has multiple Pad objects with the same value of the Designator property.

Notification

A notification is displayed in the Messages panel in the following format:

Duplicate Pad Designator On Pads Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>

where:

  • Identifier1 is the identifier for the first instance of the pad with a duplicated designator, represented by the net-designator pairing and pad coordinates.
  • Layer1 is the layer on which the first instance of the pad with a duplicated designator is placed.
  • Identifier2 is the identifier for the second instance of the pad with a duplicated designator, represented by the net-designator pairing and pad coordinates.
  • Layer2 is the layer on which the second instance of the pad with a duplicated designator is placed.

Recommendation for Resolution

Assign different and unique designators to the pads of the linked footprint model.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of footprint's preview.
  • In the Component Editor in its Batch Component Editing mode, right-click on the footprint entry in the Model Links region and choose the Edit command from the context menu.

The footprint model that is currently being used (referenced) by the component will open in the temporary PCB Footprint editor. Select offending pads and change values of their Designator property in the Pad mode of the Properties panel.

Default report mode:

Summary

This violation occurs when a footprint model linked to a component being defined in the Component Editor has identical objects placed in the same location on the same layer.

Notification

A notification is displayed in the Messages panel in the following format:

Duplicate Primitives: <ObjectType1> <Identifier1> on <Layer1> And <ObjectType2> <Identifier2> on <Layer2>

where:

  • ObjectType1 is the type of the first instance of the duplicate object.
  • Identifier1 is the identifier for the first instance of the duplicate object; the identifier representation depends on the object type.
  • Layer1 is the layer on which the first instance of the duplicate object is placed.
  • ObjectType2 is the type of the second instance of the duplicate object.
  • Identifier2 is the identifier for the second instance of the duplicate object; the identifier representation depends on the object type.
  • Layer2 is the layer on which the second instance of the duplicate object is placed.

Recommendation for Resolution

Remove duplicate objects from the footprint model.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of footprint's preview.
  • In the Component Editor in its Batch Component Editing mode, right-click on the footprint entry in the Model Links region and choose the Edit command from the context menu.

The footprint model that is currently being used (referenced) by the component will open in the temporary PCB Footprint editor. Select duplicate objects and remove them using the Delete shortcut.

Default report mode:

Summary

This violation occurs when a footprint model linked to a component being defined in the Component Editor has significant primitives (pads, tracks, arcs, fills, regions, rectangles, text strings, keepout objects) placed on the Bottom Layer but has no such primitives placed on the Top Layer.

In the PCB Footprint editor, the footprint is built for the top side of the board; it can be flipped to the bottom during the PCB design process if required.

Notification

A notification is displayed in the Messages panel in the following format:

Bottom Layer Component

Recommendation for Resolution

Flip footprint primitives from the Bottom Layer to the Top Layer.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of footprint's preview.
  • In the Component Editor in its Batch Component Editing mode, right-click on the footprint entry in the Model Links region and choose the Edit command from the context menu.

The footprint model that is currently being used (referenced) by the component will open in the temporary PCB Footprint editor. Select primitives on the Bottom Layer, and change their Layer property in the corresponding mode of the Properties panel to the Top Layer.

Selected objects can also be quickly flipped to the other side of the board using the L shortcut. To do this, select objects to be flipped, hold the left mouse button on one of the selected objects and press the L key, then release the left mouse button.

Default report mode:

Summary

This violation occurs when a footprint model linked to a component being defined in the Component Editor has a Pad object with no value of the Designator property specified.

Notification

A notification is displayed in the Messages panel in the following format:

Missing Pad Designator on Pad: Pad <Identifier> on <Layer>

where:

  • Identifier is the identifier for the pad with no designator specified, represented by the pad net and coordinates.
  • Layer is the layer on which the pad with no designator specified is placed.

Recommendation for Resolution

Specify designator values for the pads of the linked footprint model.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of footprint's preview to open the footprint that is currently being used (referenced) by the component in the temporary PCB Footprint editor.
  • In the Component Editor in its Batch Component Editing mode, right-click on the footprint entry in the Model Links region and choose the Edit command from the context menu.

The footprint model that is currently being used (referenced) by the component will open in the temporary PCB Footprint editor. Select an offending pad and specify the value of its Designator property in the Pad mode of the Properties panel.

Default report mode:

Summary

This violation occurs when a footprint model linked to a component being defined in the Component Editor has its reference point (origin) outside of the bounding rectangle formed by footprint objects.

Notification

A notification is displayed in the Messages panel in the following format:

Offset Component Origin

Recommendation for Resolution

Change the location of the reference point for it is inside the bounding rectangle formed by footprint objects.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of footprint's preview to open the footprint that is currently being used (referenced) by the component in the temporary PCB Footprint editor.
  • In the Component Editor in its Batch Component Editing mode, right-click on the footprint entry in the Model Links region and choose the Edit command from the context menu.

The footprint model that is currently being used (referenced) by the component will open in the temporary PCB Footprint editor. Use the commands of the Edit » Set Reference sub-menu of the main menus to change the current location of the footprint's reference.

Default report mode:

Summary

This violation occurs when a footprint model linked to a component being defined in the Component Editor has Pad objects which are connected with each other by objects on a copper layer.

Notification

A notification is displayed in the Messages panel in the following format:

Shorted Copper Connection Between Pad <Identifier1> on <Layer1> And Pad <Identifier2> on <Layer2>

where:

  • Identifier1 is the identifier for the first instance of the pad in the shorted pad pair, represented by the net-designator pairing and pad coordinates.
  • Layer1 is the layer on which the first instance of the pad in the shorted pad pair is placed.
  • Identifier2 is the identifier for the second instance of the pad in the shorted pad pair, represented by the net-designator pairing and pad coordinates.
  • Layer2 is the layer on which the second instance of the pad in the shorted pad pair is placed.

Recommendation for Resolution

Remove the copper layer objects which connect the pads of the linked footprint model.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of footprint's preview.
  • In the Component Editor in its Batch Component Editing mode, right-click on the footprint entry in the Model Links region and choose the Edit command from the context menu.

The footprint model that is currently being used (referenced) by the component will open in the temporary PCB Footprint editor. Select the copper layer objects which connect the pads then change them so they do not connect the pads, or remove these objects.

Default report mode:

Summary

This violation occurs when a footprint model linked to a component being defined in the Component Editor has objects on a copper layer, and these objects are not connected to any Pad objects. When such a footprint will be placed in a PCB design, a net will not be assigned to these copper layer objects, and they will become dead copper.

Notification

A notification is displayed in the Messages panel in the following format:

Unconnected Copper on primitive : <ObjectType> <Identifier> on <Layer>

where:

  • ObjectType is the type of instance of the object that is not connected to any Pad object in the footprint model.
  • Identifier is the identifier for the object that is not connected to any Pad object in the footprint model; the identifier representation depends on the object type.
  • Layer is the layer on which the instance of the object that is not connected to any Pad object in the footprint model is placed.

Recommendation for Resolution

Change the footprint model so the objects which are not currently connected to any Pad object in the footprint model are connected to pads.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of footprint's preview.
  • In the Component Editor in its Batch Component Editing mode, right-click on the footprint entry in the Model Links region and choose the Edit command from the context menu.

The footprint model that is currently being used (referenced) by the component will open in the temporary PCB Footprint editor. Place objects on copper layer(s) to form a connection between footprint pads and objects which are not currently connected to any Pad object, or remove these unconnected objects.

Violations Associated with Symbols

Default report mode:

Summary

This violation occurs when one of the display modes for a symbol has an extra pin.

Notification

A notification is displayed in the Messages panel in the following format:

Extra Pin in display mode <DisplayMode> of the symbol <SymbolRevisionID>. Part <PartDesignator>. Pin Name "<PinName>"

where:

  • DisplayMode is the specific graphical representation mode for the symbol in which the extra pin(s) has been found. A symbol has a Normal mode and can have up to 255 defined Alternate modes. Learn more about creating multiple graphical display modes of the same component symbol.
  • SymbolRevisionID is the Item-Revision ID of the symbol.
  • PartDesignator is the symbol part's Designator.
  • PinName is the offending pin's Name.

Recommendation for Resolution

This violation typically arises when an alternate graphical mode is defined for a symbol and either:

  • An extra pin has been added to a display mode that is not specified in another display mode, or
  • A pin has been specified with a different Designator and/or Name to a pin specified in another display mode.

Not only must there be an identical number of pins between graphical display modes, but the pins must be also identical in both Designator and Name. Learn more about creating multiple graphical display modes of the same component symbol.

Change the Designator and/or Name of offending pin(s) so the number of pins and their Designator and Name properties are the same between the symbol's display modes or remove an extra pin from a display mode.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of symbol's preview.
  • In the Component Editor in its Batch Component Editing mode, right-click on the symbol entry in the Model Links region and choose the Edit command from the context menu.

The symbol model that is currently being used (referenced) by the component will open in the temporary Schematic Library editor. Select offending pins and change values of their Designator and/or Name property in the Pin mode of the Properties panel, or remove these pins using the Delete shortcut.

Default report mode:

Summary

This violation occurs when two or more pins in the component's symbol model have the same designator.

Notification

A notification is displayed in the Messages panel in the following format:

Duplicate Pin Designator(s) (mode <DisplayMode>): <PinDesignatorList>

where:

  • DisplayMode is the specific graphical representation mode for the symbol in which the duplicated pin(s) has been found. A symbol has a Normal mode and can have up to 255 defined Alternate modes.
  • PinDesignatorList is the comma-separated list of pin designators that are duplicated in the offending symbol.

Recommendation for Resolution

Change the designator of the offending pin(s) accordingly, so that each has a unique assignment.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of symbol's preview.
  • In the Component Editor in its Batch Component Editing mode, right-click on the symbol entry in the Model Links region and choose the Edit command from the context menu.

The symbol model that is currently being used (referenced) by the component will open in the temporary Schematic Library editor. Select offending pins and change values of their Designator property in the Pin mode of the Properties panel, or remove these pins using the Delete shortcut.

Default report mode:

Summary

This violation occurs when the component's symbol model has no default designator specified.

Notification

A notification is displayed in the Messages panel in the following format:

Missing Default Designator

Recommendation for Resolution

Specify a default designator for the offending symbol model.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of symbol's preview.
  • In the Component Editor in its Batch Component Editing mode, right-click on the symbol entry in the Model Links region and choose the Edit command from the context menu.

The symbol model that is currently being used (referenced) by the component will open in the temporary Schematic Library editor. Open the Symbol mode of the Properties panel (active when no object is selected in the design space) and specify the required designator prefix followed by the '?' character in the Designator field (e.g., C?). The question marks in designators of components placed on a schematic sheet will be updated with actual numbers during the Design Annotation process.

Default report mode:

Summary

This violation occurs when a pin in the component's symbol model has no designator specified.

Notification

A notification is displayed in the Messages panel in the following format:

Missing Pin Designator of the symbol <SymbolRevisionID>

where:

  • SymbolRevisionID is the Item-Revision ID of the offending symbol.

Recommendation for Resolution

Specify a designator for each pin in the offending symbol model.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of symbol's preview.
  • In the Component Editor in its Batch Component Editing mode, right-click on the symbol entry in the Model Links region and choose the Edit command from the context menu.

The symbol model that is currently being used (referenced) by the component will open in the temporary Schematic Library editor. Select offending pins and specify values of their Designator property in the Pin mode of the Properties panel, or remove pins using the Delete shortcut.

Default report mode:

Summary

This violation occurs when a pin in the component's symbol model has no name specified.

Notification

A notification is displayed in the Messages panel in the following format:

Missing Pin Name of the symbol <SymbolRevisionID>. Pin Designator "<PinDesignator>".

where:

  • SymbolRevisionID is the Item-Revision ID of the offending symbol.
  • PinDesignator is the offending pin's Designator.

Recommendation for Resolution

Specify a name for each pin in the offending symbol model.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of symbol's preview.
  • In the Component Editor in its Batch Component Editing mode, right-click on the symbol entry in the Model Links region and choose the Edit command from the context menu.

The symbol model that is currently being used (referenced) by the component will open in the temporary Schematic Library editor. Select offending pins and specify values of their Name property in the Pin mode of the Properties panel, or remove these pins using the Delete shortcut.

Note

Only one violation instance will be listed in the Messages panel for each distinct component. A component may well have a symbol with more than one pin with no name defined.

Default report mode:

Summary

This violation occurs when missing pins have been detected in the numerical sequence of the offending symbol's pin designator values. For example, if the symbol has pins with designators 1, 2, 5, and there are no pins with designator 3 and 4.

Notification

A notification is displayed in the Messages panel in the following format:

Missing Pin Designator In Sequence : <PinDesignatorList> [<LowerPinDesignator>..<UpperPinDesignator>]

where:

  • PinDesignatorList is the comma-separated list of missing pin designators in the numerical sequence detected in the offending symbol.
  • LowerPinDesignator is the minimum numerical value of pin designators detected in the offending symbol.
  • UpperPinDesignator is the maximum numerical value of pin designators detected in the offending symbol.

Recommendation for Resolution

In the offending symbol model, add pins with missing pin designators in the sequence or change pin designators so the pin designators form a continuous sequence of integer values.

  • In the Component Editor in its Single Component Editing mode, click the  control at the top-right of symbol's preview.
  • In the Component Editor in its Batch Component Editing mode, right-click on the symbol entry in the Model Links region and choose the Edit command from the context menu.

The symbol model that is currently being used (referenced) by the component will open in the temporary Schematic Library editor. Using the Place » Pin command from the main menus, add the required number of pins and specify values of their Designator property in the Pin mode of the Properties panel so the pin designators in the symbol form a continuous sequence of integer values. You can also edit the Designator property of pins already placed in the symbol.

Note

There are components that do not use sequential pin numbering, for example, a BGA with non-sequential pin numbering; A1, A3, A5 (and so on). In this situation, it is suggested to release the component with this violation and note the reason in the Release Notes. Alternatively, set the Missing Pins in Sequence check on the Data Management – Component Rule Checks page of the Preferences dialog to No Report

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: