Defining the Layer Stack

Now reading version 3.0. For the latest, read: Defining the Layer Stack for version 5

This documentation page references Altium NEXUS/NEXUS Client (part of the deployed NEXUS solution), which has been discontinued. All your PCB design, data management and collaboration needs can now be delivered by Altium Designer and a connected Altium 365 Workspace. Check out the FAQs page for more information.

 

The PCB is designed and formed as a stack of layers. In the early days of printed circuit board (PCB) manufacturing, the board was simply an insulating core layer, clad with a thin layer of copper on one or both sides. Connections are formed in the copper layer(s) as conductive traces by etching away (removing) unwanted copper.

A single-sided PCB shown on the left, typical of early PCB design. On the right is a rigid-flex PCB, where rigid sections are connected via flexible sections of PCB.        
A single-sided PCB shown on the left, typical of early PCB design. On the right is a rigid-flex PCB, where rigid sections are connected via flexible sections of PCB.

Fast forward to today, where almost all PCB designs have multiple copper layers. Technological innovation and refinements in the processing technology have led to a number of revolutionary concepts in PCB fabrication, including the ability to design and manufacture flexible PCBs. By joining rigid sections of PCB together via flexible sections, complex, hybrid PCBs can be designed that can be folded to fit into unusually shaped enclosures.

In printed circuit board design, the layer stack defines how the layers are arranged in the vertical direction, or Z plane. Since it is fabricated as a single entity, any type of board, including a rigid-flex board, must be designed as a single entity. To do this, the designer must be able to define multiple PCB layer stacks and assign different layer stacks to different zones of the rigid-flex design.

To learn more about how a PCB is made, refer to The Board article.

The Layer Stack Manager

The definition of the PCB layer stack is a critical element of successful printed circuit board design. No longer just a series of simple copper connections that transfer electrical energy, the routing of many modern PCBs is designed as a series of circuit elements, or transmission lines.

Achieving a successful, high-speed PCB design is a process of balancing the material selection and layer stackup and assignment, against the routing dimensions and clearances required to achieve suitable single-sided and differential routing impedances. There are also numerous other design considerations that come into play when designing a modern, high-speed PCB, including: layer-pairing, careful via design, possible back drilling requirements, rigid/flex requirements, copper balancing, layer stack symmetry, and material compliance.

The Layer Stack Manager brings together all of these layer-specific design requirements into a single editor.

To open the Layer Stack Manager select Design » Layer Stack Manager from the main menus. The Layer Stack Manager opens in a document editor in the same way as a schematic sheet, the PCB, and other document types do.

All aspects of layer stack management are performed in the Layer Stack Manager.
All aspects of layer stack management are performed in the Layer Stack Manager.

As a standard document editor, the Layer Stack Manager (LSM) can be left open while the board is being worked on, allowing you to switch back and forth between the board and the LSM. All of the standard view behaviors, such as splitting the screen or opening on a separate monitor are supported. Note that a Save action must be performed in the Layer Stack Manager before changes are reflected in the PCB.

The functionality is divided over a number of tabs displayed across the bottom of the Layer Stack Manager:

Rigid-flex - rigid-flex boards are configured in the Stackups tab of the Layer Stack Manager. Refer to the Defining and Configuring the Rigid-Flex Substacks section.

Editing the Layer Properties

Panel page: Properties panel - Layer Stack Support

The Layer Stack Manager presents the layer properties in a spreadsheet-like grid. The properties can be edited directly in the grid or they can be edited in the Properties panel. The panel can be used in each of the Layer Stack Manager tabs, for example, giving access to the impedance profile and transmission line properties in the Impedance tab, or the µVia settings in the Via Types tab.

Some of the different modes of the Properties panel in the Layer Stack Manager.

Some of the different modes of the Properties panel in the Layer Stack Manager.

The Properties panel can be enabled/disabled via the  button, at the bottom-right of the software.

Defining the Layer Stack

The layers you add in the Stackup tab of the Layer Stack Manager are the layers that will be fabricated during the manufacturing process.

Layer properties can be entered directly into the grid, or selected from the Material Library.Layer properties can be entered directly into the grid, or selected from the Material Library.

The properties of a layer can be edited directly in the grid or in the Properties panel.

  • Use the Load Template and Save Template commands in the File menu to load a stackup template (*.stackup), or save the current stackup as a template.
  • Pre-defined layer stacks are also available, in the Tools » Presets menu.

Configuring the Layer Properties and Materials

The properties of each layer can be edited directly in the LSM grid, or a pre-defined material can be selected from the Material Library, by clicking the ellipsis button () in the Material cell for the selected layer. The Stackup Tab collapsible section earlier on this page summarizes the various techniques available for adding, removing, editing, and ordering the layers.

User-defined property columns can be added and the visibility of all columns configured in the Select columns dialog. To open the dialog, right-click on any column heading in the grid region then choose Select columns from the context menu.

Layer Types and their Properties

There is a large variety of materials used in the fabrication of a printed circuit board. The table in the collapsible section below gives a brief summary of the common materials used.

Materials Library and Library Compliance

Dialog page: Altium Material Library

Preferred layer stack materials can be pre-defined in the Material Library. In the Layer Stack Manager, select Tools » Material Library to open the Altium Material Library dialog, where existing materials can be reviewed, and new material definitions added.

The material for a specific layer is not selected in the Altium Material Library dialog. To use a specific material for a layer, click the ellipsis () for that layer in the Materials cell of the layer stack grid. This will open the Select Material dialog, which restricts the library to only show materials suitable for the layer that the ellipsis control was clicked.

If the Library Compliance checkbox is enabled in the Layer Stack Manager, then for each layer that has been selected from the Material Library, the current layer properties are checked against the values of that material definition in the library. Any property that is not compliant is marked with an error flag. Re-select the material () to update the values to the Material Library settings.

Layer Stack Symmetry

Dialog page: Stack is not symmetric

If you require the board layer stack to be symmetrical, enable the Stack Symmetry checkbox in the Substack Properties section of the Properties panel. When this is done, the layer stack is immediately checked for symmetry around the central dielectric layer. If any pair of layers that are equidistant from the central dielectric reference layer are not identical, the Stack is not symmetric dialog opens.

The upper section of the dialog details all detected conflicts in layer stack symmetry.

When Stack Symmetry is enabled:

  • An edit action applied to a layer property is automatically applied to the symmetrical partner-layer.
  • Adding layers will automatically add matching symmetrical partner-layers.
  • Use the Stack Symmetry option as a quick way of defining a symmetric board - define half of the layer stack, enable the Stack Symmetry option, then use one of the mirror whole stack options to replicate that set of layers.

Layerstack Visualization

An excellent way to verify the layer stack is to visualize it in 3D.

  • Select Tools » Layerstack Visualizer in the Layer Stack Manager to open the Layerstack Visualizer.
  • Use the controls to configure the presentation of the layer stack.
  • Right-click and drag to reorient the board in the visualizer.
  • Left-click on the image, then Ctrl+C to copy the image to the Windows clipboard.

Defining and Configuring the Rigid-Flex Substacks

Each separate zone or region of a rigid-flex design can be made up of a different number of layers. To achieve that you need to be able to define multiple stacks, referred to as substacks.

To achieve this:

  • Enable the Rigid-Flex option by selecting Tools » Features » Rigid/Flex or click the  button then select Rigid/Flex.
  • Additional controls will appear at the top of the grid of layers, including a Substack selector drop-down button displaying the default Substack name (  ).
  • There will also be an additional Substack section in the Properties panel, where the current substack name can be edited in the Stack Name field. 
  • To add a new Substack, click the  button next to the Substack selector, name that Substack in the Properties panel then enable the Is Flex option where required.
  • The layers grid always displays the entire set of available layers. For a rigid/flex layer stack, each layer includes a checkbox on the left; use this to configure which layers are to be available in each substack.
  • A layer can be used in multiple substacks (span across multiple regions of the rigid-flex board); this is controlled by the layer checkbox.
  • Flex-specific bikini coverlay layers can only be added in a Substack that has the Is Flex option enabled and no Soldermask layer enabled.

When the Rigid/Flex option has been enabled, the Substack Selector button appears. Click to select and configure each substack. Hover the cursor over the image to see the Flex substack.When the Rigid/Flex option has been enabled, the Substack Selector button appears. Click to select and configure each substack. Hover the cursor over the image to see the Flex substack.

Other Layer-related Design Tasks

The layers in the layer stack form the space on which you build up the design. There are a number of design tasks that are related to the layers that are not performed in the Layer Stack Manager. These tasks are summarized below, with links to more information.

Defining the Overall Board Shape

Main Article: Defining the Board Shape

Regardless of the final make-up of the board (single rigid area, or multiple rigid-flex sections), the overall outer shape is defined as the Board Shape.

The Board Shape can be:

  • Defined manually - by redefining the shape or moving the existing board vertices (corners). Switch to Board Planning Mode (View » Board Planning Mode) then use the commands in the Design menu.
  • Defined from selected objects - typically done from an outline on a mechanical layer. Use this option if an outline has been imported from another design tool. Switch to 2D Layout Mode (View » 2D Layout Mode) then use the command in the Design » Board Shape sub-menu.
  • Defined from a 3D body - use this option if the blank board has been imported as a STEP model from an MCAD tool into a 3D Body Object (Place » 3D Body). Switch to 3D Layout Mode (View » 3D Layout Mode) then use the command in the Design » Board Shape sub-menu to select the board shape.

The Layer Stack Manager is used to define the board structure in the vertical, or Z direction. Defining the board in the horizontal, or X-Y direction, is done by first defining the overall board shape. If it is a rigid-flex design, the shape is then divided into the required zones or board regions. Once the board regions have been defined, each region is assigned a layer stack.

Rigid-Flex - Defining the Board Regions and Assigning the Substacks

Main Article: Defining Board Regions and Bending Lines

If you are designing a rigid-flex board, once the board shape has been defined, divide it into rigid and split regions by placing split lines.

You can manage the assignment of substacks to regions in the Layer Stack Regions mode of the PCB panel.You can manage the assignment of substacks to regions in the Layer Stack Regions mode of the PCB panel.

  • Split lines can be placed when the PCB editor is in Board Planning Mode (View » Board Planning Mode, shortcut: 1).
  • Place a split line via the Design » Define Split Line command.
  • A split line must run from an outer edge to an outer edge, and can be adjusted after it has been placed.
  • Each region is named and assigned a layer stack in the Board Region dialog. The dialog can be accessed by double-clicking on region in the Layer Stack Regions mode of the PCB panel, or by switching to Board Planning Mode and double-clicking on the region of interest in the workspace.

The board is split into regions and stacks are assigned in Board Planning Mode.The board is split into regions and stacks are assigned in Board Planning Mode.

  • Note that the layer stacks are named in the Layer Stack Manager.
  • Each stack that is flexible must have the Is Flex option enabled in the Layer Stack Manager, so that required flex bending properties can be applied. Note that flex bending is defined by placing a Bending Line across the flex region (Design » Board Shape menu), refer to the Defining Board Regions and Bending Lines article for more information.

The assignment of layer stacks to regions can be checked and managed in the Layer Stack Regions mode of the PCB panel.

Assigning a Net to a Plane Layer

Panel page: Split Plane Editor

Assign a net to a plane layer, or a net to a split plane region, in the Split Plane Editor mode of the PCB panel.

The panel lists all plane layers. When a layer is selected in the Layers section, the section below will list all of the split plane zones on that layer (there will only be one if the plane is continuous with no splits defined). Double-click on a split plane zone to open the Split Plane dialog, where you can assign a net. You can also double-click on the layer in the workspace (when the plane layer is the active layer) to open the dialog.

Configuring the Layer Stack for Components Mounted on an Internal Signal Layer

Related article: Embedded Components

There are two situations where components can be mounted on an internal signal layer:

  1. when there are embedded components, or
  2. when there are components mounted on a flex region of a rigid-flex board, and that flex layer extends from a mid-layer in the rigid section of the board.

The software needs to know which way components are oriented for each layer they are mounted on so that it knows when the component primitives must be mirrored. For the Top and Bottom Layers, this is configured automatically; for other layers, the setting is configured by the designer. 

A component embedded on an internal signal layer (the component has been highlighted with blue outlines, the cavity with orange outlines).A component embedded on an internal signal layer (the component has been highlighted with blue outlines, the cavity with orange outlines).

  • Component orientation is configured for a layer in the Orientation column of the Stackup tab of the Layer Stack Manager.
  • If the Orientation column is not visible, enable it by right-clicking on an existing heading in the layers grid then selecting Select columns from the context menu.
  • The components on a layer can either point upwards (Top) or downwards (Bottom).

Documenting the Layer Stack

Object page: Layer Stack Table

Documentation is a key part of the design process and is particularly important for designs with a complex layer stack structure, such as a rigid-flex design. To support this, Altium NEXUS includes a Layer Stack Table, which is placed (Place » Layer Stack Table) and positioned alongside the board design in the workspace. The information in the layer stack table comes from the Layer Stack Manager.

Include a Layer Stack Table to document the design.
Include a Layer Stack Table to document the design.

  • To place a Layer Stack Table, select Place » Layer Stack Table.
  • The Layer Stack Table details the:
    • Layers used in the design
    • Material used for each layer
    • Thickness of each layer
    • The Dielectric Constant
    • The name of each stack and the layers used in that stack
  • Double-click anywhere on the placed table to open the Properties panel in Layer Stack Table mode.
  • The Layer Stack Table can also include an optional outline of the board showing how the various layer stacks are assigned to regions of the board. Use the Show Board Map option and slider bar to configure the map settings.
  • The Layer Stack Table is an intelligent design object, meaning it can be placed and updated as the design progresses. Double-click on the Layer Stack Table to edit it in the Properties panel.
  • An alternative approach to documenting the layer stack is to add a Draftsman document to the project, and add a Layer Stack Table in it. Learn more about Draftsman.

Including a Drill Table

Object page: Drill Table

Altium NEXUS includes an intelligent Drill Table that is placed like any other design object. The table displays the drills required for a specified layer pair, you will need to place a drill table for each layer pair used in the design.

An alternative approach to documenting the layer stack is to add a Draftsman document to the project, and add a Layer Stack Table in it. Learn more about Draftsman.

High Quality, Flexible Design Documentation

Main article: Draftsman

Altium NEXUS also provides a dedicated documentation editor - Draftsman. Draftsman has been built from the ground up as an environment for creating high-quality documentation that can include dimensions, notes, layers stack tables, and drill tables. Based on a dedicated file format and set of drawing tools, Draftsman provides an interactive approach to bringing together fabrication and assembly drawings with custom templates, annotations, dimensions, callouts, and notes.

Draftsman also supports more advanced drawing features including a Board Isometric View, a Board Detail View, and a Board Realistic View (3D view).

Place drawing views, objects and automated annotations on single or multi-page Draftsman documents. Place drawing views, objects and automated annotations on single or multi-page Draftsman documents.

Learn more about Draftsman

Content