PLM統合
Altium Designer と Altium 365 Workspace を組み合わせた統合設計ソリューションでは、設定可能な PLM Integration を利用でき、Windchill®、Arena®、Oracle® Agile™、Aras Innovator®、および Siemens Teamcenter®(追加セットアップが必要)をサポートしています。PLM 統合のセットアップは Altium 365 Workspace のブラウザーインターフェースから実行し、接続の構成、パラメーターデータのマッピング、データ同期方向の指定を簡単に行える自動化インターフェースが提供されます。インターフェースのセットアップと設定が完了すると、以下の明確に分かれた領域で PLM 統合の機能を利用できます。
-
Library(コンポーネント)– Altium 365 Workspace と PLM インスタンスの間で、コンポーネント、コンポーネントパラメーター、パートチョイスの単方向または双方向の同期に対応します。設定では、どのパラメーターをどちらのシステムでマスター管理するかを指定できます。さらに、アイテムパラメーターにより、その Component Item の新しいリビジョンを正式にリリースしなくても、Workspace 側のプロパティを更新できます(フィールドごとに設定可能)。また、専用の Part Request workflow も用意されており、PLM インスタンス内での Component の自動作成と、生成された PLM 部品番号の Workspace 側コンポーネントへの反映をサポートします。
-
Design(プロジェクト)– 専用の Project Creations workflow が用意されており、PLM インスタンス内での部品番号の自動作成と、それらのパラメーターを設計プロジェクトへ反映することをサポートします。これらのパラメーターは特別な文字列(例:シート枠注記)で使用できます。Altium Designer で Project Releaser を実行する際、その一部として設計を PLM インスタンスへ公開できます。公開処理では、PLM インスタンス統合設定の一部として定義される publishing template を使用して、PLM へどのようにデータを反映するかを制御します。また、初回公開時にプロジェクトへまだ部品番号(PLM 側)が関連付けられていない場合は、その初回公開の一部として PLM 内で部品番号が作成され、プロジェクトに関連付けられます。さらに、公開処理の一部として、PLM インスタンス内のコンポーネントに対するコンポーネントエントリを定義することも可能です(設定に応じた任意機能)。また、process workflow's history(History タブ)の一部として、PLM インスタンス内の部品番号など、何が作成されたかを常に正確に確認できます。
PLM サポート
Altium 365 Workspace は以下の PLM システムをサポートしています。
-
PTC Windchill® PLM バージョン 12、13、および PTC Windchill+(Windchill の SaaS variant)。
-
Arena® PLM。
-
Oracle® Agile™ PLM。
-
Aras Innovator® Release 30。
Additional Setup for Aras Innovator
Aras Innovator との PLM 統合を実現するには、Altium Workspace サーバーを Aras Authentication setup に登録する必要があります。これは、そのクライアントレジストリに新しいノードセクションを追加することで行います。登録が完了すると、接続された Workspace がアクセス認証を行うための一意の OAuth トークンが付与されます。
必要な Aras Innovator 構成の変更は、その OAuth クライアントレジストリファイルを編集して行います。
-
Aras ホストマシンで、
\OAuthServer\OAuth.configファイルを開いて編集します。 -
IOMApp セクションを見つけ、
<clientRegistry id="IOMApp" enabled="true">行から</clientRegistry>行までをコピーします。 -
コピーした IOMApp セクションを直後に貼り付けて、新しい(複製した)セクションを作成します。
-
この新しいノードセクションで、
IOMAppをNEXUSに変更し、<clientRegistry id="NEXUS" enabled="true">となるようにします。
-
保存してから Aras マシンを再起動します。
- Siemens Teamcenter®、追加の integration setup が必要です。
- Duro PLM はサードパーティ製 PLM インスタンスとして実装されます。詳細は以下の Third Party PLM Support を参照してください。
PLM セットアップインターフェースの選択
サポート対象の PLM システムへの Altium 365 Workspace 接続は、以下で詳しく説明する高度な半自動ユーザーインターフェース、または PLM 構成 XML ファイルの編集に基づく手動プロセスのいずれかで確立できます。後者では対象 PLM システムのデータ構造に関する知識と XML 形式への習熟が必要ですが、以下で紹介する更新済みシステムでは、PLM と Altium Workspace の両方から必要なデータを自動取得して、インターフェース内のメニュー選択肢を生成します。
Workspace インターフェースの Enable new PLM Configuration page オプションを Admin – Settings – PLM Integration page でオフにすると、XML ファイルの手動編集に基づく previous PLM interface を表示するよう Workplace を再構成できます。変更を保存し、その後サインアウトして再度サインインしてください。
PLM インスタンスへの接続
PLM Configuration は、Workspace ブラウザーインターフェースの Admin – PLM Integration ページで作成および管理します。PLM システムへの接続に成功すると、構成インターフェースには Workspace と接続先 PLM の両方から取得したデータに基づくさまざまな統合オプションが表示されます。
ボタンを使用して接続プロセスを開始し、以下のスライドショーに沿って進めてください。
接続エラーがある場合は、対象 PLM システムへのサインイン時に赤色で強調表示されます。強調表示ボックスの下枠にはエラー詳細が含まれます – view example。
PTC Windchill SSO Support
Windchill PLM システムへの接続時に Single Sign On(SSO)認証を使用する機能があり、Workspace インターフェースを通じて設定できます。これにより、Project Creation や Publish to PLM などの Workspace PLM プロセスを実行する際に、簡素で安全な接続認証方式が提供されます。実際には、この仕組みにより、OAuth delegation standard を使用して、identity provider サービス(例:PingFederate)経由で Windchill へのアクセス権を付与できます。
SSO セットアップへのアクセスは、Workspace の PLM Integration ページ(Admin - PLM Integration)の OAuth タブから利用でき、複数の OAuth プロバイダーインスタンスを追加できます。
OAuth プロバイダー認証設定は、構成済みの identity provider から取得できるデータを使用して完了します。名前と、Workspace が必要とする情報(ID、トークン、URL など)をページ内の各フィールドに入力し、設定を保存してください。
新しい OAuth Provider インスタンスは、Windchill PLM 構成で OAuth Connection オプションを有効にすると利用可能になります。複数のプロバイダーがある場合は、OAuth Provider ドロップダウンリストから選択します。
ボタンで接続設定を完了し、必要に応じてプロバイダーの指示に従ってください。
サードパーティ製 PLM サポート
Altium 365 Workspace は、サードパーティによって開発された「ネイティブでない」PLM システム構成も追加でサポートしています。このサポートは Altium の Generic Connector によって有効になり、Altium 365 PLM Generic Connector Addon ライセンスが必要です。
そのようなシステム用に Workspace PLM Instance を追加する際には、サードパーティが提供する事前構成済み XML ファイルを、PLM Integration interface を通じてその PLM Instance 構成にアップロードします。
構成セットアップ
PLM インスタンスへの接続に成功すると、Workspace PLM インターフェースには、コンポーネント同期の実行方法、コンポーネントパラメーターの相互マッピング、Part Choices データの転送方法を定義するための構成設定が表示されます。これらの同期オプションは、インターフェースの Configuration タブで利用できます。
利用可能な構成設定オプション(およびそのラベル/機能)は、PLM システムの種類と、Workspace および接続先 PLM インスタンスの両方から取得されたパラメトリックデータによって決まります。
同期パラメーター
この PLM インターフェースセクションでは、どのコンポーネントタイプを同期するか、新しいコンポーネントをどこでどのように作成/更新するか、またパラメーター条件に基づく制約を定義します。
コンポーネントの同期方法は個別に指定します。
- パラメーターリストで Altium Component Type を選択し、必要に応じてその Sync Direction オプション(To Altium/PLM または両方)を設定します。コンポーネントタイプのオプションは現在の Workspace コンポーネントデータから取得されます。
- 関連する PLM 属性名を PLM Type メニューから選択します。利用可能なオプションは接続先 PLM インスタンスから取得されます。
- Altium Target Folder フィールド(Sync to Altium の下)で、Workspace コンポーネントフォルダーを参照して選択し、このコンポーネントの同期先として指定します。
- Sync Mode を指定して、同期中に新しいコンポーネントを作成するか、既存のコンポーネントのみを更新するか、またはその両方を行うかを決定します。
-
このコンポーネントの同期時にコンポーネントパラメータータイプを定義するために使用する Component Template を設定します。関連する Workspace テンプレートが利用可能な場合、この設定は選択した Altium Component Type(例:
Capacitors)がデフォルトになります。 - Add Parameter Criteria オプションを使用して、同期の制約条件となるパラメーター値を指定します。コンポーネントはこの条件を満たさない限り同期されません。必要に応じて、さらにパラメーター条件を追加してください。
PTC Windchill PLM に接続している場合は、Windchill の PartsLInk system をサポートする追加オプションを利用できます。PartsLink システムでは、部品をグループに分類して、より便利かつ高速に対象指定でき、さらにその分類内を詳細化するための Attribute/Value ペアを関連付けることもできます。詳細は以下の折りたたみセクションを参照してください。
-
Filter Criteria メニューから Add Classification Name Criteria を選択して分類フィルターを追加します。名前メニューを使用して、同期をその分類グループでフィルタリングする対象を選択します。
-
さらに細かく制御するには、Add Classification Attribute Criteria オプションを選択し、分類の Attribute とその関連 Value を指定します。ここに示す例では、
102-Capacitorsクラスの Capacitors のうち、Capacitance値が10uFのものだけが同期されます。
More on Windchill PartsLink
Windchill 自体では、PartsLink Classification は、部品タイプに適用できる binding attribute を作成することで定義されます。次に、部品の Classification Attribute を定義済みの Classification クラスに追加します。
Windchill 内のコンポーネントエントリには、定義された Classification と指定された Classification Attribute パラメーターが組み込まれ、それらは Workspace の PLM コンポーネント同期プロセスから利用可能になります。
コンポーネントエントリが Windchill から Workspace に同期され、Workspace の PLM 構成で PartsLink 連携が指定されている場合、その部品に対する Windchill の Configuration Attributes が Altium Designer に反映されます。
Sync Direction が To PLM に設定されている場合、または双方向同期(To PLM & To Altium)の場合は、Sync To PLM の下に Add Filter Criteria オプションが表示されます。このオプションを使用して、Workspace コンポーネントのうちどれを PLM システムへ反映するかを制御する Parameter または Folder 条件を設定します。
複数の Parameter 条件を追加して、Workspace コンポーネントから PLM への同期を厳密に制限できます。利用可能な条件には、PLM への同期対象として受け入れるコンポーネントのフィルタリングをより正確に制御するための OR および NOT 句オプションも含まれます。
Sync to PLM セクションでは、Arena PLM システムを対象とする場合に、追加の部品番号および接頭辞/接尾辞オプションを利用できます。これらの事前定義済み PLM スキームは、Numbering Scheme および Code メニューで選択でき、Arena にアップロードされる部品の Item Number 形式を決定します。
コンポーネントパラメーターマッピング
PLM と同期したいすべてのコンポーネントについて、上記と同じ手順を続けて同期パラメーター構成を指定します。Workspace 側のコンポーネントパラメーターと PLM 側のパラメーターは必ずしも一致しないため、両者間でパラメーターをマッピングするには Component Parameter Mapping インターフェースセクションを使用できます。パラメーターがマッピングされると、それらは同じパラメーターであるかのように、一方から他方へ値が同期される点に注意してください。
このセクションの Add Parameter コマンドを使用して、現在選択されている Altium Component Type(Sync Parameters で選択)に適用される Workspace/PLM パラメーターのマッピングエントリを作成します。PLM と Altium の Parameter Name オプションは、それぞれのシステムで利用可能なものです。Item/Revision 列の Revision 設定では、そのパラメーターが変更されたときに新しいコンポーネントリビジョンが作成されます。一方、Item 設定では、同期中にコンポーネントパラメーターのみが更新されます。
関連する
アイコンを使用して、マッピングエントリを削除します。
この方法で任意数のパラメーターをマッピングできますが、すべてのコンポーネントに対してマッピングが必要な共通の Workspace/PLM パラメーター群が存在する場合があります。このグローバルマッピング方式は、All Types が Altium Component Type として選択されている場合に利用できます。
既知の共通パラメーター一致を含めて、すべてのコンポーネントに適用されるマッピングエントリ(Add Parameter)を作成し、必要に応じて Item/Revision および Sync Direction オプションを設定します。また、マッピングされたパラメーターエントリを Primary Key として指定することも重要です。これは 2 つのパラメトリックデータセット間の参照インデックスとなる共通パラメーターペアです。これが PLM Part Number(推奨)の場合、PLM 側で作成された番号が Altium 側へ反映され、同期されたコンポーネントデータ間に既知の参照リンクが作成されます。
PLM 分類属性
Classifications としてのコンポーネントグループ化をサポートする接続先 PLM システム(PTC Windchill など)では、このセクションで関連する PLM 属性と値を Workspace コンポーネントパラメーターにマッピングできます。
たとえば PTC Windchill では、特定の Classification Attribute 値(たとえば 102-Capacitor クラスの Capacitors に対する静電容量値)を抽出するには、その classification と値(Capacitance)を PLM Parameter Name として追加し、対象の Altium コンポーネントパラメーター(Value)を Altium Parameter Name として指定します。定義はすべての Component Types に対して追加でき、同じコンポーネントタイプに対して複数の定義を設定することもできます。
► Windchill の Classification の詳細については、上記の PartsLink information を参照してください。
Part Choices
Sync Direction ドロップダウンメニューを使用して、メーカーの Part Choices データを Workspace と PLM システム間でどの方向に同期するかを指定するか、OFF オプションで Part Choices の同期を無効にします。
接続先 PLM の種類によっては、Part Choice information オプションで、PLM 独自の承認済み製造部品(Native PLM Manufacturer Parts)と互換性のある形式、または通常のコンポーネントパラメーターデータ(PLM Part Attributes)としての同期を選択できます。後者は複数組の Manufacturer:PartNumber パラメーター属性になる場合があります – MFR1:MPN1、MFR2:MPN2 など。
「ネイティブ」(または組み込み)PLM メーカー部品の例としては、Arena の Vendor Parts や Windchill の Manufacturer Parts があります。
プロジェクト構成 XML
このセクションには、接続された PLM システムの初期 PLM 構成を定義するベース XML 構成の一覧が表示されます。このベースセットアップ XML のダウンロード版(Download Sample Configuration)には、ほとんどの Entity および Attribute セクションの機能を示す詳細なコメントが含まれています。
最終的に、PLM Integration インターフェースで定義した構成セットアップはシステム XML ファイルとして保存され、構成ページ上部の Export Configuration コマンドから、 Server Connection 詳細に関連付けてローカルに保存できます。
Import Configuration オプションも含まれています。これにより、既存の構成 XML ファイルを新規または編集済みの PLM 構成に適用でき、その PLM 構成セットアップを複製できます。また、既存の PLM 構成に特別な変更が必要な場合は、エクスポートした XML ファイルを手動で編集してから構成に再インポートできます。なお、構成ファイルに含まれる Parameters、Attributes、Values は大文字と小文字を区別します。
Publish Template Addition
PLM 構成では、XML ベースの Publishing Template を追加する必要があります。これは、設計ファイル、コンポーネント、および製造出力データを含む完全なプロジェクトデータを、単一の「publish」アクションで PLM システムに送信する Workspace プロセスをサポートするためです。これらのプロセスには、ユーザーが送信する出力データを指定する Publish to PLM と、Altium Designer の Project Release process の最終ステップとして生成データを PLM に送信する Project Releaser with Publish が含まれます。
PLM 構成を作成または編集するときに、Publish Template タブで適切な Publishing Template XML ファイルを追加してください。サポート対象の PLM システム用テンプレートのアーカイブコレクションは、Sample Project Configurations リンクからダウンロードできます。
Publishing Template には、プロジェクト詳細、コンポーネントデータ転送、データソースの場所、Design/Assembly/Fabrication データのファイル配布に関する参照が含まれます。ダウンロードしたサンプルには、サポートされているすべての PLM 向けテンプレートが含まれており、それぞれに特定の PLM タイプに適用される追加の Publishing Rules と、何をどのように構成すべきかを示す詳細なコメントが含まれています。
Publishing Folder Support for Windchill PLM
Workspace から公開されるドキュメントの公開先として使用する Windchill® PLM Integration インスタンスを Publish to PLM processes 用に構成する際には、対象の Windchill フォルダーを指定(および作成)することもできます。
関連する Windchill フォルダーパラメーターは、Workspace 内の Windchill PLM 統合エントリに適用される Publishing Template XML ファイルで定義します(上記参照)。フォルダー定義ノードは <pt:Folder>xxx</pt:Folder> というタグ形式で定義されます。ここで pt は現在の名前空間、xxx は完全なフォルダーパスです。これらは、各ドキュメントタイプ(たとえば PCB.zip Fabrication 出力など)の FileDistribution セクション内に Publishing Rule として配置されます。
Publishing XML 構造階層の例は次のようになります。
<pt:EntityRule id="FAB">
<pt:FileDistributions>
<pt:FileDistribution archiveName="PCB.zip">
<pt:Folder>PRODUCT/Projects/${project.name}/FAB data</pt:Folder>
最後のエントリー行では、PCB.zip Fabrication 出力用の公開先フォルダーを Windchill のフォルダー構造で指定(または作成)します(この例でのプロジェクト名は MyProject です)。
PRODUCT
Projects
MyProject
FAB data
Publishing XML ファイルで定義するフォルダーパスは相対ではなく絶対パスであり、プロジェクト名(${project.name})や Assembly Number(${project.PLM_ASSEMBLY_NUMBER})など、他のプロジェクトプロパティを含めることもできます。
Publish to PLM with ECO
Windchill、Agile、Arena の各 PLM インスタンス用セットアップファイルは、正式な Change Order(ECO)ワークフローにも対応しています。これは Publishing Template XML ファイルで有効化され、Configuration XML ファイルの altiumType="ProjectChangeOrder" エンティティセクションで定義されます。
PLM インスタンスに応じて、XML 構成定義には Change Order の識別(番号付け、場所、ID など)のスキーマ、Name/Title、Description、Change Complexity(Windchill のみ)などの特定の Change Order 属性、さらに Change Order 作成戦略(なし、新規、既存の再利用)や Lifecycle ステータス昇格(Windchill と Agile のみ)などのオプション設定が含まれます。定義された Change Order は、関連する Publishing Template 内でその publishId 参照を宣言することで、公開時に有効になります。
Publishing template は、リリース出力(プロジェクト、ソース、アセンブリ、およびファブリケーションデータ)をどのように、どこへ PLM に公開するかを定義する一連のルールもサポートします。
サーバーの Configuration および Publishing Template XML ファイルで定義されると、Change Order は、Altium Designer から、または Workspace PLM interface を通じて開始される Project Creation および Publishing to PLM プロセスワークフロー中に利用可能になります。フロー中には関連する Change Order Form が表示され、そこで Change Order のオプションを指定します。
Altium Designer の Change Order Required ダイアログには、初期の Project 作成ステップと、その後の ECO 対応 Project Release が表示されます。
ここで示す例では、Create Project with PLM Initialize プロセス(Arena PLM 向け)を使用してテンプレートから Altium Designer でプロジェクトを作成し、Create change order(ECO)オプションは無効になっています。その後、Publish to PLM (User selects) プロセスを使用して、Create change order オプションを有効にした状態(Yes)でプロジェクトを Released します。Arena 側では、その後アイテムが Change Order(ECO-00042)およびそれに固有の承認プロセスに対して公開されます。
この例で使用されている Arena Configuration XML および Publishing Template XML ファイルを含む ZIP アーカイブは、 からダウンロードできます。
必要に応じてサンプル XLM テンプレートを変更し、
ボタンから開く Add Publish Template ウィンドウを使用して、そのファイルを PLM 構成にアップロードしてください。PLM 構成では複数の Publish Templates をサポートしている点に注意してください。
コンポーネント同期
Altium 365 Workspace と接続された PLM システム間のコンポーネントデータ同期は、上記で説明した有効なパラメーターマッピングおよび方向によって決まり、同期プロセスが手動またはスケジュール時刻に自動でトリガーされると実行されます。同期プロセス自体は、組み込みの LibSync process Workflow によって駆動されます。
PLM 構成インスタンス内では、関連する同期オプションは Component Synchronization タブで利用できます。ここでは、プロセスを手動でトリガーするか、スケジュール設定できます。後者の場合は、Synchronize on a schedule オプションを有効にし、関連するドロップダウンメニューから時間間隔を選択します。
メニューオプションを使用すると、LibSync プロセスを Incremental または Full 同期イベントとして手動でトリガーできます。
-
Incremental – 最後に同期が実行されて以降に変更されたコンポーネントのみを適用します(つまり、そのタイムスタンプが前回の同期日時より新しいもの)。さらに、構成内の同期条件を満たしている必要があります。なお、これはメインの PLM Integration ページ上の
コントロールから同期イベントをトリガーした場合に使用されるモードです。以下を参照してください。
- Full – このモードでは完全同期を強制します。構成内の同期条件を満たすすべてのコンポーネントが含まれます。
コンポーネント同期の実行
コンポーネント(ライブラリ)同期は、Workspace の PLM Integration ページにある PLM インスタンスエントリから手動で実行することも、インスタンス設定で指定した自動サイクルとして実行することもできます(上記参照)。PLM インスタンスに関連付けられた
コントロールをクリックすると同期プロセスが手動で開始され、関連する PLM 構成で定義された設定を使用して LibSync ワークフローに従って進行します。
Actions コントロールは
に変わり、必要に応じて同期プロセスを停止できるようになります。また、Sync Status エントリにはプロセス進行中であることが示されます。同期プロセスが完了すると、Status は Completed に変わります。
コンポーネント同期が手動または時間指定イベントとして実行されると、LibSync プロセスは、完了するかエラーに遭遇するまで事前定義された Workflow を進みます。ブラウザーを更新(F5)すると、同期プロセスの現在の状態を表示できます。
完了した同期イベントの詳細にアクセスするには、 Last Sync 列の
アイコンをクリックして関連ログファイルをダウンロードするか(view example)、関連する日付を選択して Synchronization Status タブ内のイベントエントリを開いてください。なお、このビューでは、Closed オプションが選択されていると完了済み同期イベントが一覧表示され、実行中または一時停止中のイベントは Active ビューモードが選択されていると表示されます。
Status ビューのサブタブには、次の情報が表示されます。
- Diagram – プロセスワークフローを表すグラフィックで、現在のステップ位置が強調表示されます(完了またはエラー/失敗状態)。
- Data – プロセスアクションの情報サマリーで、各ステップの成功または失敗、および記録されたプロセスレポートへのリンクが含まれます – view example。
- History – 主な Workspace 同期イベントを順番に一覧化したタイムログ。
エラー発生時など、途中で停止した同期イベントは、ビューが Active モードのときに一覧表示されます。これらのエントリは Terminate コントロール(
)でリストから削除できますが、より適切には Workspace の Tasks view に作成された関連 Task タイルから評価および解決する必要があります。なお、終了/解決済みの同期イベントは、Synchronization Status ビューの Closed リストに、Status(たとえば Failed)のような状態表示付きで移動されます。
PLM 関連プロセスへのアクセス
接続された PLM システムに関連するサンプル Process Workflow は、Workspace Processes page のプロセステーマタブから利用できます。一般に、これらのサンプルはそのままでは使用できず、有効にするには別名で再保存する必要があります。
►詳細は Processes & Workflow のドキュメントを参照してください。
Workspace Administrator は、Processes ページのプロセス一覧から
コントロールをクリックして、有効化された任意のプロセス定義の新しいインスタンスを直接開始できます。管理者以外の Workspace ユーザーも、以下のように Workspace からアクティブな Process を開始できます。
-
Part Request page の
ボタンから開始する Part Request with PLM プロセス。
-
開いているプロジェクトの Tasks および Activities ページ上の
ボタンから開始する Publish to PLM プロセス。
-
メインの Projects page の
ボタンから開始する Publish to PLM プロセス。
-
メインの Projects page の
ボタンから、または
ボタンメニューから Cloning a project を行う際に開始する Project with Initialize in PLM プロセス。
ただし実際には、PLM 関連プロセスは通常、プロジェクトの設計および開発中に Altium Designer から起動されます。PLM 関連プロセスには、Altium Designer から次の方法でアクセスできます。
-
Part Request with PLM Part Create – Altium Designer の Explorer、Manufacturer Part Search、および Components パネルからアクセス。
►詳細は Process-based Part Requests を参照してください。 -
Publish to PLM (User selects) – アクティブな Altium Designer プロジェクトの Project » Project Activities サブメニューからアクセス。
►詳細は Publishing to a PLM – user-selects を参照してください。 -
Project Releaser with Publish – アクティブな Altium Designer プロジェクトの Project » Project Releaser サブメニューから、最終 Project Releaser ステージとしてアクセス。
►詳細は Design Project Release – publishing to PLM を参照してください。 -
Project with initialise in PLM – File » New » Project in <Workspace> サブメニューから新しい Altium Designer プロジェクトを作成する際、またはプロジェクトをクローンする際にアクセス。
►詳細は Publishing to a PLM – initialize in PLM を参照してください。
Process Workflows
PLM 統合をサポートするため、以下のプロセス定義(および基盤となるワークフロー)が Workspace で利用可能です。
-
Part Requests process theme:
- Part Request with PLM Part Create – PLM インスタンス内で Component を自動作成し、生成された部品番号を Workspace コンポーネントへ戻して反映することをサポートします。ワークフロー図を以下に示します。
重要な点として、このサンプル定義を変更して独自の定義を作成する場合、部品を作成する対象の PLM インスタンスを指定する必要があります。ワークフロー図で Create Part in PLM エンティティを選択し、PLM Instance フィールドに関連付けられたドロップダウンメニューから PLM インスタンスを選択してください。このメニューには、インターフェイスの PLM Integration ページで定義されているすべての PLM インスタンスが表示されます。
►プロセスワークフローの操作に関する詳細は、Creating and Managing Processes を参照してください。
- Project Activities process theme:
- Publish to PLM (User selects) – リリースされた管理プロジェクト出力を統合先 PLM インスタンスに公開します。ユーザーは、どの出力を公開するかを正確に選択できます。ワークフロー図を以下に示します。
- Project Releaser with Publish – Project Releaser の追加ステージとして統合先 PLM インスタンスに公開します。ワークフロー図を以下に示します。
-
Project Creations process theme:
- Project with initialise in PLM – PLM インスタンス内で部品番号を自動作成し、それらを Workspace 設計プロジェクトの Parameters として反映することをサポートします。ワークフロー図を以下に示します。
























内でその 












