ワークスペースへのリリース
概略
- ソース、製造、実装、バリアント、カスタムの各データセットのうち、リリースに含めるものを選択し、必要な出力ジョブを割り当てる方法を確認します。
- リリース先のオプション、Workspaceのアイテム命名規則、およびターゲットリビジョンの設定項目を理解します。
- リリースの各段階を順に確認し、自動リリースコマンドがレビュー、レポート作成、PLMへの公開にどのように影響するかを学びます。
Online ModeのReleaseビューでは、リリースプロセスが段階的に進みます。ビューの左側に表示される項目で、現在のステージを一目で確認できます。
-
Configure Server Release – このステージでは、生成するデータの種類を指定します。指定できるのは、ソースデータ(常に生成)、基板製造データ、実装データ(基本設計および検出された各バリアント用)です。
-
Validate Project – このステージは、割り当てられたOutJobファイルで検証タイプのレポートが1つ以上検出された場合に、自動的に実行されます。リリースするデータアイテムに割り当てられたOutput Jobファイル内の、定義済みの検証出力ジェネレーターがすべて実行されます。
-
Generate Data – このステージは自動的に実行されます。対象のデータアイテムに割り当てられたOutJobファイルで定義されている、その他すべての出力を実行し、Workspace内の対応するターゲットアイテムにリリースするデータを生成します。
-
Review Data – すべての検証チェックに合格し、出力データが生成されると、このステージで生成されたデータを確認できます。
-
Upload Data – 前のステージでリリースを確認すると、このステージに自動的に進みます。ここでは、ターゲットWorkspace内の対応するデータアイテムのリビジョンへの、データのアップロード状況が表示されます。
-
Execution Report – プロセスの最終ステージで、リリースの概要が表示されます。ナビゲーションリンクを使用して、Explorerパネルで生成されたアイテムリビジョンをすばやく参照できます。PLMへのリリースとパブリッシュを行うプロセスの一環としてProject Releaserにアクセスした場合は、
ボタンが表示されます。このボタンをクリックすると、プロセスの基となるワークフローが続行され、PLMにパブリッシュされます。
-
Publish to PLM – このステージは、該当する有効化済みプロセス(リリース後にPLMにパブリッシュするプロセス)でリリースを実行する場合にのみ表示されます。前のステージで
ボタンをクリックすると、このステージに自動的に進みます(
ボタンに関連付けられたメニューからPrepare & Release & Publish to PLMコマンドを使用した場合は、直接このステージに進みます)。Login Credentialsダイアログが表示されます。PLMインスタンスのUsernameとPasswordを入力し、使用するPLMテンプレート(<PLMInstance>:<PublishingTemplate>の形式で表示)を選択します。
オンラインステージ1 – サーバーリリースの設定
リリースプロセスのこのステージでは、生成するデータの種類を指定します。リリース可能なデータアイテムは次のとおりです。
- Source Data – ソース設計のスナップショット。
- Fabrication Data – 基板製造業者がベアボードを製造するために必要なデータ。
- Assembly Data for the Base Design (no variations) – 部品表に従って、バリアントを適用しない基本設計のすべての部品をベアボードに実装するために、実装業者が必要とするデータ。
-
Assembly Data for Design
Variant n– 部品表に従って、基本設計のVariant nの部品をベアボードに実装するために、実装業者が必要とするデータ。
実装データセットの数は、基本設計(バリアント未適用)と、その設計に定義されている検出済みのすべてのバリアントに対応します。

プロジェクトリリースプロセスのステージ1 – リリースに含める内容(生成するデータ)の設定。
Source Dataアイテムは、常にリリースに含まれます。その他のデータアイテムを含めるかどうかは任意です。
Output Jobの割り当て
Fabrication DataおよびAssembly Dataアイテムをリリースに含めるには、少なくとも1つのOutputJobファイルを割り当てる必要があります。名前が「fab」および「ass」という文字列で始まるOutput Jobファイルがある場合、Releaseビューに初めてアクセスしたときに、それらのOutJobがそれぞれFabrication DataおよびAssembly Dataセクションに自動的に割り当てられます。該当するファイルがない場合は、それぞれに適切なOutJobを手動で割り当てる必要があります。この操作は、Project Release OptionsダイアログのRelease Optionsタブで行えます(ビューの左下にある
ボタンをクリックしてアクセスします)。

必要に応じて、該当するデータセットにOutJobを割り当てます。
リリース先の切り替え
Project Release OptionsダイアログのRelease Optionsタブでは、リリース先を変更し、管理対象(Online)モードと非管理対象(Offline)モードを切り替えることもできます。次の3つのオプションを使用できます。
-
Unmanaged - Folder(Offline):生成したデータをローカルフォルダーにリリースするには、このオプションを設定します。ルートフォルダーのパスは、ダイアログのOutput Pathタブで指定します。デフォルトでは、[OutputPath]に設定されています(Project OptionsダイアログのOptionsタブにあるOutput Pathフィールドで定義されたパスを使用します)。 -
Unmanaged - Zip(Offline):生成したデータをローカルフォルダーにリリースするには、このオプションを設定します。データは1つのZipファイルにまとめられます。Zipファイルのパスと名前は、ダイアログのOutput Pathタブで指定します。デフォルトでは、[OutputPath][ProjectName].zipに設定されています(Project OptionsダイアログのOptionsタブにあるOutput Pathフィールド で定義されたパスを使用します)。 -
Managed - <WorkspaceName>(Online):現在接続しているWorkspace(WorkspaceNameを使用)にリリースするには、このオプションを設定します。

プロジェクトのリリースオプションの一環として、リリース先(生成されたデータの送信先)を切り替えます。
Workspaceアイテムの命名規則の設定
プロジェクトを対象のWorkspaceに初めてリリースする際、そのWorkspace内の対象データアイテム(生成されたデータを受け取るリビジョンを持つアイテム)の命名方法を定義できます。この設定は、Project Release OptionsダイアログのItem Namingタブで行います。このダイアログには、ビューの左下にある
ボタンを押すか、リリースするデータセットのTarget Revisionリンクをクリックし、コンテキストメニューからEditを選択してアクセスします。このタブでは、次の操作を行えます。
- プロジェクト名を定義します。デフォルトでは、実際のプロジェクト名が入力されます。
-
リリースの一環として生成できる各種データアイテムのデフォルトの命名規則を定義します。Item ID列のフィールド内をクリックし、フィールドの右側にある
ボタンをクリックすると、Choose Itemダイアログ(Explorerパネルの一形態)が開き、現在接続しているWorkspace内の既存のアイテムを対象として指定できます。
命名規則を変更するには、SettingsボタンをクリックしてNaming Template Settingsダイアログを開きます。

プロジェクト名を設定し、対象のWorkspaceに生成されるデータアイテムの命名規則を定義します。ここでは、プロジェクトがまだリリースされていないため、フィールドを編集できます。
命名テンプレートでは、次のマクロ形式がサポートされています。
-
Parameter-based – 角括弧で囲まれたパラメーターを使用できます(例:
[ProjectName]、[VariantName]、[ProjectParameter])。 -
Numeric-based – 波括弧で囲まれた数値の桁数指定を使用できます(例:
{0000}、{9000})。
対象リビジョンの制御
メインビューに戻り、Target Revisionエントリの横にあるリンクをクリックすると、次の画像に示すコマンドメニューにアクセスできます。

リリースの一環として生成されるデータセットの対象リビジョンを指定するコントロールにアクセスします。画像にカーソルを合わせると表示されます。
使用できるコマンドは、アイテムが初回リリース済みかどうかによって異なります。使用可能なすべてのコマンドを以下に示します。
-
Auto <RevisionID> – このエントリでは、システムがリビジョンを管理するため、予定リビジョンがまだ存在しない場合でも、自分で作成する必要はありません。
RevisionIDには、割り当てられたリビジョン命名規則の同じレベルにおける、アイテムの次のリビジョンが表示されます(たとえば、現在のリビジョンがA.1の場合、このコマンドでは対象がA.2と表示されます)。 -
Next <RevisionID> – このエントリは、アイテムの初回リリース後にのみ使用できます。割り当てられたリビジョン命名規則の次のレベルで、対象リビジョンをすばやく繰り上げることができます。
RevisionIDには次のリビジョンが表示されます(たとえば、現在のリビジョンがA.1の場合、このコマンドは対象をB.1に切り替えます)。 -
Custom – このエントリを使用すると、 Custom Revision IDダイアログでカスタムのリビジョンIDを定義し、対象アイテムの特定のリビジョンを指定できます。 使用するリビジョン命名規則に応じて、ダイアログには最大3つのレベルIDフィールドが表示されます。アイテムの最初の予定リビジョンのIDは、アイテムの作成後から、その初期リビジョンにデータがリリースされるまでの間(つまり、まだ
Planned状態にある間)は、いつでも変更できます。 - Browse – このエントリを使用すると、リリース先となる既存の対象アイテムリビジョンを指定できます。そのためのChoose Target Itemダイアログ(Explorerパネルの一形態)が表示されます。
- Edit – このエントリを使用すると、Project Release OptionsダイアログのItem Namingタブにアクセスし、作成される対象アイテム(および初期リビジョン)の名前を変更できます。
- Navigate – このエントリを使用すると、Explorerパネル内のアイテムにすばやく移動できます(アイテムがすでにリリースされ、次のリビジョンが予定状態で存在する場合)。
メニューの最上部のエントリには、現在選択または定義されている対象リビジョンが反映されます。
データ生成の詳細へのアクセス
データセットのヘッダーの右端にあるDetailsコントロールをクリックすると、そのデータセットによって具体的に何が生成されるかの詳細を確認できます。Hide Detailsコントロールをクリックすると、この展開表示を折りたたむことができます。Source Dataセットを除き、データは割り当てられた1つ以上のOutput Jobファイルから生成されます。Configureコントロールをクリックすると、生成元のOutJobにすばやくアクセスできます。

データセットの詳細ビューにアクセスして、生成されるデータを確認します。画像にカーソルを合わせると表示されます。
追加設定
PreferencesダイアログのData Management – Serversページでは、プロジェクトのリリースに関する追加設定を定義できます。
-
現在接続しているWorkspaceにアップロードする前に生成ファイルを一時保存するフォルダーは、自動設定の場所(デフォルトのインストールでは
\Users\<ProfileName>\AppData\Local\Temp\Releases)に設定することも、任意のフォルダーを手動で指定することもできます。 - Delete contents after exiting release modeオプションを有効にすると、リリース処理の完了後に一時保存フォルダーの内容が消去されます。
- 生成される各出力の名前には、必要に応じてアイテムIDとリビジョンIDを接頭辞として付けることができます(例:
[FAB-Kame_FMU-A.1] Validation.PDF)。これを行うには、Prepend revision HRID to file namesオプションを有効にします。
リリースの一部として作成するデータアイテムを必要に応じて設定したら、ビューの右下にある
ボタンをクリックして次に進みます。
準備の一環として、次のようなリリース前チェックが実行されます。
- プロジェクトとすべてのファイルが保存されていることを確認します。
- 該当する場合、プロジェクトとすべての関連ファイルがVCSにコミットされていることを確認します。
- 有効になっている各データアイテムに名前が付けられていることを確認します。
- ユーザーにターゲットアイテム(およびリビジョン)を作成する権限があることを確認します。
- 必要なターゲットアイテム(および予定リビジョン)がWorkspaceに存在しない場合は作成し、すでに存在するアイテムについては次のリビジョンが使用されることを確認します。
問題が見つかった場合は、それを解決するための方法が提示されます(ローカルで変更されたファイルの保存やVCSへのコミットなど)。
この時点でSource Dataアイテムが生成され、ソース設計プロジェクトファイルのスナップショットがターゲットアイテムのリビジョンにリリースされます。
オンライン ステージ2 – プロジェクトの検証
ステージ1が問題なく完了すると、割り当てられたOutJobファイルで検証タイプのレポートが1つ以上検出された場合、リリースプロセスの次のステージが自動的に実行されます。リリース対象のデータアイテムに割り当てられた出力ジョブファイルで定義されている、すべての検証出力ジェネレーターが実行されます。これには、次の処理が含まれます。
- Differences Report – コンパレーターを使用して、ソースとPCBの設計ドキュメントが正しく同期しているかどうかを確認します。
- Electrical Rules Check – 作成されたソース設計の電気的および製図上の妥当性をチェックします。
- Design Rules Check – 指定された基板レベルの設計制約に照らして、PCBドキュメントの妥当性をチェックします。
-
BOM Checks – ソースBOMドキュメント(
*.BomDoc)がある場合、その中の設計アイテムまたは代替部品候補に関連する違反の可能性をチェックします。 - Footprint Comparison Report – 基板上のフットプリントを元のライブラリと比較し、最新の状態で一致していることを確認します。
- Component State Checking – 使用が制限される状態にあるコンポーネントをチェックします。設定の一環として、ターゲットWorkspaceで現在定義されている各ライフサイクル定義の各状態に対して実行するアクション(何もしない、警告を出す、エラーを生成する)を指定します。エラーを生成する場合、設計はリリースできません。また、このチェックを実行すると便利なHTML形式のレポートが生成され、どの設計コンポーネントが有効な状態にないかを一目で確認できます。
- Environment Configuration Compliance Check – 割り当てられたロールで利用可能な環境設定によって許可されたデータアイテムのみが使用されていることをチェックします(該当する場合)。このチェックでは、すべての設計アイテムがWorkspaceから取得されていることも確認できます。
検証が成功すると、
アイコンとPassedというテキストが表示されます。成功しなかった場合は、
アイコンとFailedというテキストが表示されます。
オンライン ステージ3 – データの生成
ステージ2が問題なく完了すると、リリースプロセスの次のステージが自動的に実行されます。このステージでは、対象のデータアイテムに割り当てられたOutJobファイルで定義されているその他すべての出力処理が実行され、Workspace内の対応するターゲットアイテムにリリースするデータが生成されます。
他のステージと同様に、生成の進行状況はアイコンで表示されます。このステージは実行に時間がかかるため、特にその表示が目立ちます。
– 未実行/未生成。
– 実行中/生成中。
– 正常に生成されました。
– 生成に失敗しました。
オンライン ステージ4 – データのレビュー
すべての検証チェックに合格し、出力データが生成されると、リリースプロセスのこのステージで生成されたデータをレビューできます。

リリースを確定してデータをWorkspaceにアップロードする前に、生成されたデータをレビューし、すべてが意図どおりであることを確認します。
このページでは、デフォルトで生成データが簡易(コンパクト)表示されます。対象のセクションにあるDetailsコントロールをクリックすると、より詳細な表示に切り替わります。

Detailsコントロールをクリックすると、対応するセクションの生成データが簡易表示から詳細表示に切り替わります。Hide Detailsコントロールをクリックすると、元の表示に戻ります。
詳細表示での出力生成状態
次の表は、データの生成時に詳細表示で確認できる出力の状態を示しています。
状態 |
説明 |
|---|---|
|
出力がまだ生成されていないか、存在しません。 |
|
出力は生成されていますが、その後に設計側で変更が加えられたため、このデータの有効性は最新の設計に対応していません。 |
|
出力は現在生成中です。 |
|
検証ベースの出力で、エラーのないレポートが生成されています。ERCレポートの場合は、エラーがないか、エラーのレベルがそのレポートに指定された最大許容エラーレベルの範囲内に収まっています。 |
|
出力(検証ベースの出力を除く)が正常に生成されました。 |
|
出力が正常に生成されませんでした。検証ベースの出力の場合、ソース設計ドキュメントにエラーがあり、そのために特定のチェックに合格しなかったことを意味します。標準の出力の場合は、出力を正常に生成できなかったことを意味します。生成前の検証で致命的なエラーが発生したか、出力ジョブファイル内の対応する出力ジェネレーターの設定に問題がある可能性があります。 |
生成されたデータのコンパクト表示で、View リンクをクリックすると、関連するデータファイルまたはファイルセットが、Altium Designer内の対応するエディター(Gerberファイルや圧縮/非圧縮のODB++ファイルの場合はCAMエディターなど)、または対応する外部アプリケーション(部品表の場合はMicrosoft Excelなど)で開きます。詳細表示では、エントリーをダブルクリックすると、そのファイルだけを表示できます。
多くの設計者がリリース準備の確認に用いる一般的なテストは、今回のリリースで生成されたGerberファイルと、前回のリリースのGerberファイルを比較することです。Gerber出力の横にある Compare Gerber リンクをクリックし、ドロップダウンメニューから過去のリリースを選択すると、準備したGerberデータと、選択したリリースのデータを比較できます。既定のブラウザーで自社のWorkspaceが開き、結果が表示されます。

Workspaceにデータをリリースする前に、Project Releaser からGerber比較機能にアクセスします。
► Gerber Comparison 機能の詳細はこちら(Altium 365 Workspace、Enterprise Server Workspace)。
データを確認した結果、修正が必要な場合は、ビュー右下の
ボタンをクリックします。生成されたすべてのデータが失われることを知らせる確認ダイアログが表示されます。OK をクリックするとリリースがキャンセルされ、プロセスのステージ1に戻ります。
生成されたすべてのデータに問題がなければ、
ボタン(同じくビューの右下)をクリックしてリリースを進めます。Confirm Release ダイアログが表示され、Workspaceにリリースされるプロジェクトの構成の概要を確認できます。ここでは、Name(既定の入力値は [ProjectName])、Description、および関連するリリースノートを追加することもできます。

生成されるアイテムリビジョンの観点からリリース内容を確認し、名前/説明の変更やリリースノートの追加を行えます。
オンラインステージ5 – データのアップロード
前のステージでリリースを確認すると、このステージに自動的に進みます。ここでは、Workspace内の関連データアイテムのリビジョンへのデータアップロードの進捗が表示されます。

このステージでは、生成されたデータをWorkspace内のリンク先アイテムリビジョンにアップロードする進捗が表示されます。
オンラインステージ6 – 実行レポート
これはプロセスの最終ステージで、リリースの概要が表示されます。
ナビゲーションリンクを使用すると、Workspaceへのポータルである Explorerパネルで、リリースされたデータ(製造データ、実装データ、およびカスタムデータセット)を含む関連アイテムリビジョンにすばやくアクセスできます。

Explorer パネルを使用して、プロジェクトのリリース済みデータをWorkspaceで直接表示します。
リリース済みプロジェクトの表示
Workspaceプロジェクトでは、リリース完了後に追加の機能を利用できます。Execution Report ページ上部にあるナビゲーションリンクの最後のリンク、Project Page をクリックすると、Explorer パネルが開き、プロジェクトが Project View に表示されます。この機能はWorkspaceプロジェクトでのみ利用できます。

Project View を使用すると、Explorer パネルでWorkspaceプロジェクトをさらに詳しく確認できます。
Releases 領域(ビューの左下)には、プロジェクトに関連付けられたリリースの一覧が表示され、各リリースとその構成パッケージの概要が含まれます。この領域の
ボタンをクリックすると、一括状態変更ダイアログが開きます。このダイアログを使用すると、同じリリースに関連する複数のアイテムのライフサイクル状態を、1回のバッチ処理でまとめて変更できます。
プロジェクトのリリース情報には、対象WorkspaceのWeb Viewerからもアクセスできます。Web Viewerは、Explorerパネルの
ボタンから開きます。WorkspaceのWeb Viewerでは、プロジェクトに関連するすべてのリリースに Releases ビューからアクセスできます。オンサイトサーバーで提供されるWorkspaceの場合は、Manufacture ビューからアクセスできます。このページにはすべてのプロジェクトリリースが新しい順に表示され、各リリースの開くボタン(
)からWorkspaceの Manufacturing Portalでそのリリースを開くことができます。Manufacturing Portal ビューには、選択したリリースの詳細情報が表示されます。これには、リリースを構成するパッケージファイル、設計ドキュメント一式、部品のメーカーおよびサプライヤーの詳細が含まれます。なお、Send to Manufacturer 機能はAltium 365 Workspaceでのみ利用できます。► 詳細については、Altium 365 Workspaceのリリースビューページを参照してください。
これで完了です。プロジェクトのリリースが完了したら、Release ビューを閉じるだけです(ビュー右下の
ボタンを使用します)。将来、同じプロジェクトを再リリースする必要が生じた際には、Project Releaser を使用してすばやく簡単に実行でき、対象のアイテムリビジョンも自動的に更新されます。
PLMインスタンスへのパブリッシュ
Related pages: PLM連携(Altium 365 Workspace、Enterprise Server Workspace)、PLMへのパブリッシュ
Altium DesignerでProject Releaserを実行する際に、その一環として設計をPLMインスタンスにパブリッシュできます。パブリッシュ操作では、そのPLMインスタンスの連携設定の一部として定義されたパブリッシュテンプレートを使用して、PLMへのデータの反映方法を制御します。この機能は、適切に設定されたプロセスを通じて利用できます。インストール時にはサンプルのプロセス定義(Project Releaser with Publish)が提供されます。このプロセス定義のワークフローでは、Project Releaserの追加ステージとして、連携先のPLMインスタンスへのパブリッシュが可能になります。ワークフロー図を以下に示します。

デフォルトの Project Releaser with Publish サンプルプロセス定義のワークフロー図
有効化すると、Project Releaserの一環としてPLMインスタンスにパブリッシュするプロセスに、Altium Designer内からアクセスできるようになります。アクティブなプロジェクトのProject » Project Releaserサブメニュー、またはProjectsパネルで設計プロジェクトのエントリを右クリックして表示される Project Releaserコンテキストサブメニューからアクセスできます。
の一環としてPLMインスタンスにパブリッシュするプロセスへのアクセスProject Releaserが表示され、追加ステージの7. Publish to PLMが含まれます。また、生成されたデータや実行レポートの確認のために停止せずにProject Releaserを実行したい場合は、
ボタンに関連付けられたメニューからPrepare & Release & Publish to PLMコマンドを使用できます。

生成されたデータや実行レポートの確認のために停止せずにProject Releaserを実行するための追加コマンド
標準のPrepareコマンドでProject Releaserを実行した場合は、データを確認してリリースした後、Execution Reportステージで
ボタンが表示されます。このボタンをクリックすると、プロセスのワークフローが続行され、PLMへのパブリッシュが行われます。Login Credentialsダイアログが表示されます。PLMインスタンスのUsernameとPasswordを入力し、使用するPLMテンプレート(<PLMInstance>:<PublishingTemplate>の形式で表示されます)を選択します。

PLMインスタンスへの初回パブリッシュ時に表示されるLogin Credentialsダイアログ。
Diagramタブをクリックすると、プロセスのワークフローを確認できます。

Login CredentialsダイアログのDiagramタブ
ボタンをクリックすると、そのワークフローに従ってパブリッシュ処理が進みます。

)が表示されます。潜在的な問題を避けるため、プロジェクトに関連するすべてのドキュメントをプロジェクトフォルダーまたはそのサブフォルダーに保存することをお勧めします。



