Altium NEXUS Documentation

InsertObject

Modified by Jason Howie on Apr 11, 2017

Parent page: WorkspaceManager Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: ObjectKind=Netlist|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Netlist Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Netlist Outputs sub-menus.
  • From the menus associated with the [Add New Netlist Output] control, at the bottom of the Netlist Outputs region, in the main job configuration window.
Each sub-menu relates to a specific format of netlist, n, while each entry on a netlist format sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Netlist Output, with chosen Data Source, will be added to the bottom of the list of Netlist Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Documentation|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Documentation Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Documentation Outputs sub-menus.
  • From the menus associated with the [Add New Documentation Output] control, at the bottom of the Documentation Outputs region, in the main job configuration window.
Each sub-menu relates to a specific type of document, n, while each entry on a document type sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Documentation Output, with chosen Data Source, will be added to the bottom of the list of Documentation Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Assembly|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Assembly Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Assembly Outputs sub-menus.
  • From the menus associated with the [Add New Assembly Output] control, at the bottom of the Assembly Outputs region, in the main job configuration window.
Each sub-menu relates to a specific type of assembly output, n, while each entry on an assembly output type sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Assembly Output, with chosen Data Source, will be added to the bottom of the list of Assembly Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Fabrication|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Fabrication Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Fabrication Outputs sub-menus.
  • From the menus associated with the [Add New Fabrication Output] control, at the bottom of the Fabrication Outputs region, in the main job configuration window.
Each sub-menu relates to a specific type of fabrication output, n, while each entry on a fabrication output type sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Fabrication Output, with chosen Data Source, will be added to the bottom of the list of Fabrication Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Report|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Report Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Report Outputs sub-menus.
  • From the menus associated with the [Add New Report Output] control, at the bottom of the Report Outputs region, in the main job configuration window.
Each sub-menu relates to a specific type of report, n, while each entry on a report type sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Report Output, with chosen Data Source, will be added to the bottom of the list of Report Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Validation|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Validation Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Validation Outputs sub-menus.
  • From the menus associated with the [Add New Validation Output] control, at the bottom of the Validation Outputs region, in the main job configuration window.
Each sub-menu relates to a specific type of validation, n, while each entry on a validation type sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Validation Output, with chosen Data Source, will be added to the bottom of the list of Validation Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=Export|Index=n|DataSource=m (where n is in the range 1 to 20, and m is in the range 1 to 99)

Summary

This command is used to add the indicated Export Output, with the indicated Data Source, to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Export Outputs sub-menus.
  • From the menus associated with the [Add New Export Output] control, at the bottom of the Export Outputs region, in the main job configuration window.
Each sub-menu relates to a specific export format, n, while each entry on an export format sub-menu relates to a specific Data Source, m.

Use

After launching the command, the indicated Export Output, with chosen Data Source, will be added to the bottom of the list of Export Outputs in the main job configuration window.

The output will initially be added with all configuration options set to defaults. Rename the new output and/or configure its setup (where applicable) as required.

Tips

  1. The Data Source can be changed at any time after addition - simply click on the Data Source field to access a drop-down menu of sources from which to choose.
  2. The output can be configured (where possible) through an associated dialog. Quick access to this dialog can be made simply by double-clicking on the output's entry. Alternatively, right-click on the output's entry, and choose the Configure command from the context menu.


Applied Parameters: ObjectKind=OutputMedium|Index=n (where n is in the range 1 to 20)

Summary

This command is used to add the indicated output container to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Output Medium sub-menu.
  • From the menu associated with the [Add New Output Container] control, at the bottom of the Output Containers region, in the main job configuration window.

Use

After launching the command, the indicated output container will be added to the bottom of the list of containers, in the Output Containers region within the main job configuration window.

The output container will initially be added with all configuration options set to defaults. Rename the new container and/or configure its setup as required.

Tips

  1. An output container can be configured through its associated settings dialog. Quick access to this dialog can be made simply by double-clicking on the container's entry, or by clicking the Change control, at the top-right of the container. Alternatively, right-click on the output container's entry, and choose the Properties command from the context menu.


Applied Parameters: ObjectKind=PrintJob|Index=n (where n is in the range 1 to 20)

Summary

This command is used to add the indicated print job to the active Output Job Configuration file.

Access

The related indexed commands can be accessed from the Output Job Editor:

  • From the Edit » Add Print Job sub-menu.
  • From the menu associated with the [Add New Print Job] control, at the bottom of the Hard Copy region, in the main job configuration window.

Use

After launching the command, the indicated print job will be added to the bottom of the list of print jobs, in the Hard Copy region within the main job configuration window.

The print job will initially be added with all configuration options set to defaults. Rename the new job and/or configure its setup as required.

Tips

  1. A print job can be configured through the Printer Configuration dialog. Quick access to this dialog can be made simply by double-clicking on the job's entry, or by clicking the Change control, at the top-right of the job. Alternatively, right-click on the print job's entry, and choose the Properties command from the context menu.


Applied Parameters: ObjectKind=OutputDuplicate

Summary

This command is used to make an identical copy (duplicate) of the selected output, in the active Output Job Configuration file. This enables you to quickly define a new output that may differ only slightly from an existing one.

Access

With the required output selected, this command can be accessed from the Output Job Editor by:

  • Choosing the Edit » Duplicate command, from the main menus.
  • Clicking the  button on the Job Manager Toolbar toolbar.
  • Using the Ctrl+D keyboard shortcut.
  • Right-clicking on the entry for the output and choosing the Duplicate command from the context menu.
This command can only be used to duplicate an individual selected output. If multiple outputs are selected, the command will be grayed-out.

Use

First, ensure that the output that you wish to duplicate is selected in the main job configuration window.

After launching the command, the duplicate output will be created and added to the bottom of the associated outputs list. It will have a default name in the format Copy of <NameofOriginal>. Edit the name and configuration of this new output as required.


Applied Parameters: ObjectKind=CreateProjectsFromPath

Summary

This command is used to create one or more Altium NEXUS projects based on documents that are found in the folder(s) along a specified search path.

Access

This command can be accessed from any editor by:

  • Clicking the Workspace button in the Projects panel, then choosing the Create Projects from Path command, from the context menu.
  • Choosing the Project » Design Workspace » Create Projects from Path command, from the main menus (requires a project document to be open).

Use

After launching the command, the Browse for Folder dialog will appear. Browse to the required folder which contains the document(s) you wish to create a project from. After clicking OK a confirmation dialog will appear, asking whether or not you want to include sub-folders in the search. Answer as required - the folder(s) found along the path, and containing appropriate documents (e.g. schematic documents, PCB documents, library documents), will have a project created based on the folder name. A Design Workspace will also be created using the name of the top-level folder for the specified search path. This can be seen in the entry of the top field in the Projects panel.

The type of project created will depend on the document(s) contained in a folder, but is generally one of the following:

  • PCB project (*.PrjPcb) - created if a folder contains one or more schematic, PCB, or PCB library documents, or any combination of these three. If schematic library documents exist alongside schematic and/or PCB documents, they will also be included in the project.
  • Integrated Library Package (*.LibPkg) - created if a folder contains one or more schematic library documents only, or a mixture of schematic and PCB library documents (only the schematic libraries will be taken into the project).

For example, consider two folders found along a specified path - one a sub-folder of the other - named Folder A and Folder B respectively:

  • Folder A
    • Folder B

Say Folder A contains one or more schematic documents and a PCB document, and Folder B contains a single schematic library document.

This command will create:

  • The Design Workspace Folder A.DsnWrk
  • A PCB project, from the schematics and PCB in Folder A. The name of the project will be Folder A.PrjPcb.
  • An Integrated Library Package, from the schematic library document in Folder B. The name of the project will be Folder B.LibPkg.

All projects that are created will be added to the Projects panel, with the first created becoming the focused project.

Tips

  1. The Design Workspace is created first and saved to the hard disk in the top-level folder (defined by the search path). Each project is then created and saved in the folder above that in which the relevant document(s) reside. The relevant documents are then added to each of the projects.
  2. Even though a new Design Workspace is being opened, all currently open projects will remain open as part of that new Design Workspace.


Applied Parameters: ObjectKind=Project

Summary

This command is used to add one or more existing design documents to the active project.

Access

This command is accessed from the active document's editor by choosing the Project » Add Existing to Project command, from the main menus.

Use

First, ensure that the project to which you wish to add documents to, is made active. Do this by opening one of its source documents as the active document in the main design window.

After launching the command, the Choose Documents to Add to Project dialog will appear. Navigate to, and select, the document(s) that you wish to add, and click Open. The selected documents will be added to the project, and the Projects panel will be updated accordingly.

Tips

  1. The project will be marked as modified. A modified project is flagged by an asterisk suffix next to its entry in the Projects panel. In addition, modified projects are distinguished in the Projects panel through use of the icon. To see this icon, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.


Applied Parameters: ObjectKind=FocusedProject

Summary

This command is used to add one or more existing design documents to the focused project.

Access

This command can be accessed from the Projects panel by:

  • Right-clicking on the entry for the required project and choosing the Add Existing to Project command, from the context menu.
  • Clicking to focus the required project, then clicking the Project button and choosing the Add Existing to Project command from the context menu.

Use

First, ensure that the project to which you wish to add documents to, is focused the Projects panel.

After launching the command, the Choose Documents to Add to Project dialog will appear. Navigate to, and select, the document(s) that you wish to add, and click Open. The selected documents will be added to the project, and the Projects panel will be updated accordingly.

Tips

  1. The project will be marked as modified. A modified project is flagged by an asterisk suffix next to its entry in the Projects panel. In addition, modified projects are distinguished in the Projects panel through use of the icon. To see this icon, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.


Applied Parameters: ObjectKind=FocusedDocument

Summary

This command is used to add a currently open free document to the active project.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required free document, and choosing the Add to Project <ActiveProjectName> command from the context menu.

Use

First, ensure that the project to which you wish to add the free document to, is made active. Do this by opening one of its source documents as the active document in the main design window.

After launching the command, the free document will be added to the active project, and the Projects panel updated accordingly.

Tips

  1. You can also drag-and-drop a free document into any open project in the Projects panel. Similarly, you can drag-and-drop any document between open projects in the panel.


Applied Parameters: ObjectKind=DatabaseLink

Summary

This command is used to add a new component record to the currently selected table in the active DBLib/SVNDbLib file.

Access

This command is accessed from the Database Library Editor, and SVN Database Library Editor, by right-clicking on the required part on the Table Browser tab, and choosing the Add New Component command, from the context menu.

Use

First, ensure that the database table, to which you wish to add a new component, is selected in the Tables region of the main document window. Also, ensure that the Table Browser tab is the active tab.

After launching the command, the New Component dialog will appear. The dialog lists all of the fields defined in the parent database table. You now need to define the component, by supplying information for each of these fields if/as required. Simply click on a Field Value entry to edit it. After defining values for all required fields, click OK - the new component will be committed to the table in the external database, and reflected back on the Table Browser tab.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。