Определение логической структуры устройства из нескольких электронных модулей

This documentation page references Altium NEXUS/NEXUS Client (part of the deployed NEXUS solution), which has been discontinued. All your PCB design, data management and collaboration needs can now be delivered by Altium Designer and a connected Altium 365 Workspace. Check out the FAQs page for more information.

Translation is available for NEXUS Client 3.1: Go to the page
 

Advanced electronic product designs are generally composed of multiple PCB designs that are interconnected to create a complete, functional system. From a design with a main board and a front panel LCD module to a complex active back-plane system with plug-in cards, all are implemented as a system of multiple board designs.

This requires a high-level design system that allows multiple ‘child’ PCB designs to be electrically and physically connected together while maintaining the integrity of their Pin and Net connectivity. Integrated system-level design is supported by Altium NEXUS in the form of a dedicated Multi-board Design environment that features both the logical (schematic) and physical (PCB) aspects of system design.

A system-level Multi-board Design is hosted in Altium NEXUS by a dedicated Multi-board project type (*.PrjMbd) and its constituent schematic-based logical design document (*.MbsDoc) and physical PCB-based documents (*.MbaDoc). The document types bring existing Altium NEXUS project designs into the Multi-board design environment where they are interconnected, edited and checked as a complete system.

The essential steps for creating a Multi-board system Schematic design from child PCB project designs are:

  1. Create an Altium NEXUS Multi-board project and add a Multi-board schematic document to the project.
  2. Place graphical blocks (Modules) in the Schematic to logically represent the child projects.
  3. Link each Module to its appropriate child project.
  4. Import the child project connectivity data into the system design.
  5. Add connections between Modules to create the logical system design.

The physical counterpart to the logical system design in a Multi-board Schematic document is a Multi-board Assembly document, which is populated with imported PCB data from the Multi-board Project. Each PCB project Module in the Multi-board system design Schematic is represented by a physical PCB in the matching Multi-board Assembly document.

See the Multi-board Assembly documentation for information on creating and working with a Multi-board Assembly.

Multi-board projects and their associated sub-projects can be saved to a connected Workspace, where they can benefit from the version control, sharing and management capabilities provided by an Altium 365 Workspace or  Enterprise Server Workspace.

See Sharing a Multi-board Project for information on storing and sharing a Multi-board project in an Altium 365 Workspace.

Enabling PCB Projects for Multi-board Design

Altium NEXUS PCB projects that represent the child board designs in a Multi-board system design will contain specific connections, such as edge connectors or header plugs/sockets, that are included as the electrical and physical interface to other PCBs in the system design.

These connections and their associated electrical Nets need to be detected and processed by a Multi-board schematic (logical) design document to establish the inter-board connectivity in the system-level design. This functionality is enabled by the presence of a specific component parameter for the PCB project connectors – a System parameter with Connector as an attribute value.

For each connector in a PCB project design that is intended for a system-level interconnection, select the connector part then add the special component parameter under the Parameters tab of the Properties panel.

Multi-board Design Project

An Altium NEXUS system-level design is formed in a Multi-board project, which like any other project type is created through File » New » Project. The Create Project dialog opens; select an option under the Multiboard heading in the Project Type region. 

The core design element in a Multi-board project is the logical connection design, which is developed in a Multi-board schematic document (*.MbsDoc). Add this file type to the Multi-board project from the Projects panel by right-clicking on the project entry then selecting Add New to Project » Multi-board Schematic from the context menu.

For both the Multi-board Project and its (open) schematic documents, right-click on their entries in the Projects panel then select the File » Save As option to rename the document files accordingly.

Multi-board Schematic Design

The connectivity between PCB projects that make up a Multi-board system design is established by placing representative blocks (Modules) on the schematic and connecting their exposed connectors (Entries) together using virtual connections and/or wires.

Modules, representing child PCB project designs, are placed in the workspace from the Place » Module menu or by selecting the Module button () in the editor's Active Bar – see below.

Altium NEXUS includes an Active Bar at the top of each editor’s workspace that provides shortcut buttons for object placement commands.

A small triangle shape in the lower area of a button indicates that a drop-down menu is available for accessing other related commands. Click and hold the button to open its menu.

To assist repeated object placement, the button icon and function will actively change to show the last used menu option.

Double-click a placed Module and use the Properties panel to define its Designator and Title, and also the source PCB design project to which the Module is linked. Use the  associated with the Source field to set to a local or server-based managed project, and the desired board design within that project specified (Assembly/Board).

Add further modules and their child project links to the multi-board schematic design, as required for the complete system design.

To cross probe back to, and open, a Module's source project Schematic or PCB, select the module in the workspace then use the Design » Crossprobe to Schematic/PCB commands. These commands are also available on a module's right-click context menu.

The Modules are populated with design data from their linked PCB project designs by importing the project data using the Design » Import From Child Projects command or the Design » Import From Selected Child Projects command. Most importantly, this processes the Pin and Net data from each connector in the Child Projects that have the special System:Connector parameter (i.e. parameter named System with a value of Connector) attached.

After the import is complete, a module Entry is automatically created for each of these connectors on their respective Module block graphic. The connector Entry is actively associated with Pins and Nets on the connector in the Child Project.

Select an Entry graphic in the workspace to see its details, such as its connector Pins/Nets, in the Properties panel. Until connected to the Entry on another module, the Entry's Part/Pin listing in the panel will show the connector and pins as not mated.

Project Structure

An established Multi-board Project features a hierarchical document structure that includes Source documents (Multi-board Schematic and Assembly), and the child PCB sub-projects linked to Modules in the schematic system design. The structure of a child project is immediately added to the Multi-board Project when a system design Module has been linked to that external project.

Expand the project structure in the Projects panel to expose the constituent files in the multi-board project and its child projects. To ensure that the Multi-board project extracts and processes the correct data from its sub-projects, the PCB of each project should be synchronized with its Schematic and free of design or drafting errors. To validate a sub-project, right-click on its name in the panel and select the Validate PCB Project <name> command – any issues will be listed in the Messages panel.

Graphical Objects

The multi-board schematic editor provides a range of graphical element tools that can be used to place basic, free-form drawing elements in a multi-board schematic sheet. For information on multi-board schematic editor graphical objects, and their associated settings in the Properties panel, refer to the collapsible sections below:

Content