Schematic Placement & Editing Techniques

This documentation page references Altium NEXUS/NEXUS Client (part of the deployed NEXUS solution), which has been discontinued. All your PCB design, data management and collaboration needs can now be delivered by Altium Designer and a connected Altium 365 Workspace. Check out the FAQs page for more information.

 

Electronic design is the process of capturing a logical design in the schematic then representing that design as a set of objects in the PCB design space. Even for a small circuit, the schematic can include many components, each with numerous models and parameters. The PCB design space can also contain a large number of design objects that make up the board. During the course of the design process, the placement and properties of these objects need to change as you work to balance out the various design requirements.

Object Placement and Editing Commonality

In Altium NEXUS, the process of placing an object is roughly the same regardless of the object being placed. At its simplest level, the process is as follows:

  1. Select the object to be placed from one of the toolbars or the Place menu.
  2. Use the mouse to define the location of the placed object in the schematic editor design space and its size (where applicable).
  3. Right-click (or press Esc) to terminate the command and exit placement mode.

Placing Design Objects

The basic steps for placing schematic design objects are outlined below.

  1. Select the object type that you want to place by selecting an object type from the Place menu (e.g., Place » Wire) or by clicking on one of the icons on the Active toolbar. Shortcut keys for placement are also available (e.g., P, W to place a wire). To place components (parts), you can also click the Place button in the Components panel, or select the component name from an available library in the Components panel and drag it into the document.
  2. When an object is selected for placement, the cursor will change to a crosshair, indicating that you are in editing mode, and if relevant, the object will appear "floating" under the cursor.
  3. Press the Tab key to edit the properties of the object before placing it. This will open the Properties panel for that particular object, allowing you to change various options. Once you have finished setting the properties, click  to return to placement mode. The advantage of editing during placement is that objects that have a numeric identifier, such as a designator, will auto-increment.
  4. Position the cursor then left-click or press Enter to place the object. For complex objects, such as wires or polygons, you must continue the position-and-click procedure to place all vertices of the object.

    Note: The options on the Schematic - AutoFocus page of the Preferences dialog control the state of the schematic display. For example, the schematic can be configured to automatically zoom in when placing or editing connected objects or dim all wiring not related to the wire currently being placed. Other zooming and panning options are available using the shortcut keys or mouse wheel. Use the Ctrl key and scroll the wheel mouse to zoom in and out, push the wheel button down and move the mouse up to zoom in or move the mouse down to zoom out when placing. You can set up the behavior of your mouse on the System - Mouse Wheel Configuration page of the Preferences dialog.
  5. After placing an object, you will remain in placement mode (indicated by the crosshair cursor), allowing you to immediately place another object of the same type. To end placement mode, right-click or press the Esc key. In some cases such as placing a polygon, you may need to do this twice; once to finish placing the object and once to exit placement mode. When you exit placement mode, the cursor will return to its default shape.

Editing Prior to Placement

The default properties for an object (those that can logically be pre-defined) can be changed at any time on the Schematic – Defaults page of the Preferences dialog. These properties will be applied when placing subsequent objects.

Use the Primitive List column to access properties for objects and edit default values as required.
Use the Primitive List column to access properties for objects and edit default values as required.

Default values for the objects are saved, by default, in the file Advsch.dft. Optionally, values can be saved in a .dft file with a different name. Controls are available to save and load .dft files, enabling you to create favorite default object value 'sets'. All settings saved in and loaded from .dft files are user-defined defaults. Should it be necessary, original default values can be brought back at any time using the Set To Defaults or Reset All options. The original default values are hard-coded.

Editing During Placement

A number of attributes are available for editing at the time an object is first placed. To access these attributes, press the Tab key while in placement mode to open the associated Properties panel. Pressing the Tab key pauses placement in order for you to make any required edits for the object.

Example Properties panel for a Net Label object. 
Example Properties panel for a Net Label object.

After edits have been made, click the design space pause button overlay ( ) to resume placement.

Attributes that are set in this manner will become the default settings for further object placement unless the Permanent option on the Schematic – Defaults page of the Preferences dialog is enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement session.

Editing After Placement

Once an object has been placed, there are a number of ways in which it can be edited. These are described below.

The Associated Properties Panel or Dialog

This method of editing uses the associated Properties panel mode and dialog to modify the properties of a placed object.

After placement, the associated dialog can be accessed by:

  • Double-clicking on the placed object.
  • Placing the cursor over the object, right-clicking then choosing Properties from the context menu.

After placement, the associated mode of the Properties panel can be accessed in one of the following ways:

  • If the Properties panel is already active, select the object.
  • After selecting the object, select the Properties panel from the Panels button at the bottom right of the design space or select View » Panels » Properties from the main menus.
If the Double Click Runs Interactive Properties option is disabled (default) on the Schematic - Graphical Editing page of the Preferences dialog, when the primitive is double-clicked or you right-click on a selected primitive then choose Properties, the dialog will open. When the Double Click Runs Interactive Properties option is enabled, the Properties panel will open.
While the options are the same in the dialog and the panel, the order and placement of the options may differ slightly.
Press Ctrl+Q to toggle the units of measurement currently used in the panel/dialog between metric (mm) and imperial (mil). This only affects the display of measurements in the panel/dialog; it does not change the measurement unit specified for the sheet, which is configured in the Units setting in the Properties panel when there are no objects selected in the design space.

Graphical Editing

This method of editing allows you to select a placed object directly in the design space and change its size, shape, or location graphically. Modification of shape and/or size (where applicable) is performed through the use of editing 'handles' that appear once the object is selected.

Example editing handles for a selected Sheet Symbol object.
Example editing handles for a selected Sheet Symbol object.

When an object is selected, you can move the object or edit its graphical characteristics. Click on an object to select it; its 'handles' or vertices are displayed. To graphically change a selected object, click and hold on an editing handle. That point of the object will then become attached to the cursor. Move the mouse to a new location and release to resize. Click anywhere on a selected object to move it or press the Delete key to delete it.

Moving selected objects:

  • Selected schematic or PCB objects can be 'nudged' by the current snap grid value by pressing the arrow keys while holding down the Ctrl key.
  • Selected objects can also be 'nudged' by the snap grid value x10 by pressing the arrow keys while holding down the Ctrl+Shift keys.
  • For the schematic objects, the current Snap Grid is displayed on the status bar. The available Snap Grids are configured on the Schematic - Grids page of the Preferences dialog. Press G to cycle through the available grid values as you work.
  • For the PCB objects, the current Snap Grid is displayed on the status bar and is defined in the Grid Editor dialog. Press Ctrl+G to open the dialog and enter a new value.
  • You can select multiple PCB components and reposition them individually (in the order in which you selected them) using the Reposition Selected Components command (Tools » Component Placement » Reposition Selected Components or shortcut T, O, C). The components can be selected directly on the PCB using the PCB panel, or in the Schematic Editor if Cross Select Mode is enabled (Tools menu).

Repositioning an Object

Click and hold on an object to reposition it. When you do, the cursor may snap to a different location on the object from where you clicked. This is intentional and is controlled by the following options. Note that the electrical objects (such as a net label, sheet symbol, or component) behave differently from non-electrical objects (such as a rectangle, or line) because the Always Drag option is on by default.

  • Center of Object - when enabled, for a graphical object move the cursor and hold at the geometric center of the object. For an electrical object, hold at the click location if the Always Drag option is enabled. If Always Drag is off, hold at the geometric center. For text strings, hold by the string reference point (determined by the string's current Justification property setting).
  • Object's Electrical Hot Spot - when enabled, if the object is an electrical object, hold at its Hot Spot (the Hot Spot is the point where connectivity is created). When enabled, this option overrides the Center of Object option for electrical objects.
  • When Always Drag is enabled, the software attempts to maintain the connectivity currently defined in that net. Always Drag can be temporarily inhibited by holding Ctrl as you click and drag.
  • Press the G key during object movement to cycle through the available Grid Preset settings. These are configured in the Schematic - Grids page of the Preferences dialog.
  • Press the Ctrl key during object movement to temporarily inhibit the current Grid Preset. This feature is useful when you need to carefully adjust the location of a string.

Alignment Commands

Objects can also be moved by changing their alignment. To align objects with other objects, right-click on a selected object, then select Align. The alignment sub-menu contains a number of options for distributing selected objects.

Using Copy and Paste

In the schematic editor, you can copy and paste objects within or between Schematic Documents, e.g. component(s) from a schematic can be copied into another Schematic Document. You can copy objects to the Windows clipboard and paste them into other documents. Text can be copied from the Windows clipboard into a schematic text frame. You can also directly copy/paste a table-type selection from another application such as Microsoft Excel or from any grid style control within Altium NEXUS.

More advanced copy/paste actions can be performed using the Smart Paste feature.

Select the object(s) you want to copy, click Edit » Copy (Ctrl+C) then click to set a copy reference point on the object that will be used to accurately position the object during pasting. You will only be prompted to click to set a reference point if the Clipboard Reference option is enabled on the Schematic - Graphical Editing page of the Preferences dialog.

When pasting copied component objects, their designators will reset if the Reset Parts Designators on Paste option is enabled on the Schematic - Graphical Editing page of the Preferences dialog.

Re-Entrant Editing

The Schematic Editor includes a powerful feature called re-entrant editing that allows you to perform a second operation using the keyboard shortcuts without having to quit the operation you are currently carrying out. For example, pressing the Spacebar when placing a part will rotate the object but will not disrupt the placement process. Once you place the part, another part will appear ready at the cursor already rotated.

Re-entrant editing is also very useful if you start placing a wire that needs to be connected to a port that you have not placed yet. There is no need to exit Place Wire mode; just press the Place Port shortcut keys (P, R), place the port, press Esc to exit Place Port mode and then connect the wire to the port.

Measuring the Distance on a Schematic Document

The Schematic Editor has a distance tool located in the Reports menu (Reports » Measure Distance as well as the Ctrl+M shortcut keys). You can use this tool to measure the distance between two points on a schematic document. After launching the command, you are prompted to click on two points on the schematic document. Once you have chosen two points, an Information dialog appears with an overall Distance value, with the X Distance and Y Distance values displayed accurate to two decimal places.

The measurement units are determined by the Units chosen for the schematic document in the General region of the Document Options mode of the Properties panel. You also can switch to Imperial or Metric units by toggling the System units (View » Toggle Units).

Editing Group Objects

A group object is any set of primitives that has been defined to behave as an object. For example, a component on a schematic is a collection of drawing objects, strings, parameters, pins, and references to models. The primitive objects that belong to a group object are sometimes referred to as the child objects and the group object is their parent object.

Let's look at a typical group object edit that you might want to perform. Your design includes several capacitors. Currently, the voltage is specified as part of the components' comment string. You need to change this and specify the voltage as a component parameter instead and make this parameter visible on the schematic.

The steps we need to perform are (described in detail below):

  1. Select capacitors with a value of 100uF 16V.
  2. Change their comment to be 100uF (remove the 16V text).
  3. Add a new parameter to these components with a name of Voltage and a value of 16V.
  4. Change the visibility of this parameter so it's displayed on the schematic.

While this might seem like a complex set of edits to perform, it is actually quite straightforward.

Step 1. Selecting the Capacitors

To select all the 100uF 16V capacitors, right-click on the component symbol of one of them then select Find Similar Objects from the context menu.

We will use the approach covered in the previous example, except this time you want to match on components that have the same Comment and the same Current Footprint as shown in the image above.

Note that we can also match on components that have a designator starting with the letter C. This is done by changing the Component Designator to C*. Click OK to select the matching capacitors.

Step 2. Changing the Comment String

After clicking OK, the Properties panel opens (if the Open Properties option in the Find Similar Objects dialog was enabled). Behind it will be the schematic sheet displaying the matching objects selected on that sheet. If the Zoom Matching and Mask Matching options were enabled, the view will be zoomed and all the objects that did not match are faded or masked out.

You can check the status line at the bottom of the Properties panel to see if the same capacitors exist on other sheets. 

To change the comment string, delete 16V from the string then press Enter to apply the change. 

Step 3. Adding a New Parameter to the Component

The next change that we need to make is to add a new parameter. To do this, click Add in the Parameters region of the Properties panel in Component mode then select Parameter from the drop-down. A Parameter 1 entry will be added to the grid in the region. Enter the new parameter Name and Value

Click   to delete a selected parameter.

Step 4. Setting the Voltage Parameter to be Visible

The last step is to make the new Voltage parameter visible. Click the   icon to make the parameter visible (displays as ).

We have now updated the comment string for all 100uF capacitors. We have also added a new parameter called Voltage, set its value to 16V, and made this parameter visible.

Working with Components

A component within a library represents the physical device that is placed on the actual printed circuit board. On a schematic sheet, a component is represented by its schematic symbol model. Each component can contain one or more parts.

Managing Footprints Across the Entire Design

Altium NEXUS's Schematic Editor includes a powerful Footprint Manager. Launched from the Schematic Editor's Tools menu (Tools » Footprint Manager), the Footprint Manager lets you review all the footprints associated with every component in the entire project. Multi-select support makes it easy to edit the footprint assignment for multiple components, change how the footprint is linked, or change the current footprint assignment for components that have multiple footprints assigned. Design changes are applied through the ECO system, updating both the schematic and the PCB if required.

Working with Design Object Parameters

Parameters are general purpose text strings that are child objects of a parent object. They identify and add additional information to that parent object and are accessed directly in the Properties panel when selected in a schematic sheet.

Content