Altium NEXUS Documentation

SaveObject

Последнее изменение: Susan Riege; 11.12.2020

Parent page: WorkspaceManager Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: ObjectKind=Document|SaveMode=Standard

Summary

This command is used to save the currently active document.

Access

This command can be accessed from the active document's editor by:

  • Choosing the File » Save command, from the main menus.
  • Clicking the  button on the editor's main toolbar.
  • Using the Ctrl+S keyboard shortcut.

Use

After launching the command, the active document will be saved.

Tips

  1. A modified document is flagged by an asterisk suffix next to its entry in the Projects panel. A modified document also has an asterisk next to its name in its open document tab (or on the associated pop-up menu if documents are grouped). In addition, modified documents are distinguished in the Projects panel through use of the  icon. To see this icon, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.
  2. For schematic documents, if the current file format is not Binary Version 5.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in SCH Binary Version 5.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.
  3. For PCB documents, if the current file format is not Binary Version 6.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in PCB Binary Version 6.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.
  4. The active document can also be saved (if in a modified state) by using the corresponding command from its document tab - right-click on the tab to access a context menu of commands. Note that this command will not be available if multiple documents of the same type are open and currently grouped.


Applied Parameters: ObjectKind=Document|SaveMode=SaveAs

Summary

This command is used to save a copy of the currently active document with a new name and/or different format (where available), to a specified location on the hard disk.

Access

This command is accessed from the active document's editor by choosing the File » Save As command, from the main menus.

Use

After launching the command, the standard Windows Save As dialog appears. Use this dialog to browse to a particular destination in which to save the file, give the file a new name (if required) and also to select the format in which to store the file (where available).

The newly saved file will be opened in place of the original file as the active document.

Tips

  1. The parent project must be saved in order to point to the copy of the document the next time the project is opened, otherwise the project will include the original document still.


Applied Parameters: ObjectKind=Document|SaveMode=SaveCopyAs

Summary

This command is used to save a copy of the currently active document with a new name and/or different format (where available), to a specified location on the hard disk.

Access

This command is accessed from the active document's editor by choosing the File » Save Copy As command, from the main menus.

Use

After launching the command, the standard Windows Save A Copy Of dialog appears. Use this dialog to browse to a particular destination in which to save the file, give the file a new name (if required) and also to select the format in which to store the file (where available).

The newly saved file will not be opened in place of the original file.


Applied Parameters: ObjectKind=FocusedDocument|SaveMode=Standard

Summary

This command is used to save the currently focused document in the Projects panel.

Access

This command can be accessed from the Projects panel by:

  • Right-clicking on the entry for the required document and choosing the Save command, from the context menu.
  • Clicking to focus the required document, then clicking the Project button and choosing the Save command from the context menu.
The command will only be available provided the focused document is actually open, or open and hidden.

Use

First, ensure that the document you wish to save is actually open as one of the available tabbed documents in the main design window - it does not need to be made the active document.

After launching the command, the focused document will be saved.

Tips

  1. A modified document is flagged by an asterisk suffix next to its entry in the Projects panel. A modified document also has an asterisk next to its name in its open document tab (or on the associated pop-up menu if documents are grouped). In addition, modified documents are distinguished in the Projects panel through use of the  icon. To see this icon, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.
  2. For schematic documents, if the current file format is not Binary Version 5.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in SCH Binary Version 5.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.
  3. For PCB documents, if the current file format is not Binary Version 6.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in PCB Binary Version 6.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.
  4. A non-active document can also be saved (if in a modified state) by using the corresponding command from its document tab - right-click on the tab to access a context menu of commands. Note that this command will not be available if multiple documents of the same type are open and currently grouped.


Applied Parameters: ObjectKind=FocusedDocument|SaveMode=SaveAs

Summary

This command is used to save a copy of the currently open document with a new name and/or different format (where available), to a specified location on the hard disk.

Access

This command can be accessed from the Projects panel by:

  • Right-clicking on the entry for the required document and choosing the Save As command, from the context menu.
  • Clicking to focus the required document, then clicking the Project button and choosing the Save As command from the context menu.
The command will only be available provided the focused document is actually open, or open and hidden.

Use

First, ensure that the document you wish to save is actually open as one of the available tabbed documents in the main design window - it does not need to be made the active document.

After launching the command, the standard Windows Save As dialog appears. Use this dialog to browse to a particular destination in which to save the file, give the file a new name (if required) and also to select the format in which to store the file (where available).

The newly saved file will be opened in place of the original file.

Tips

  1. The parent project must be saved in order to point to the copy of the document the next time the project is opened, otherwise the project will include the original document still.


Applied Parameters: ObjectKind=FocusedCategory|SaveMode=Standard

Summary

This command is used to save all documents that are currently open within the focused category (sub-folder) in the Projects panel.

Access

This command can be accessed from the Projects panel by:

  • Right-clicking on the entry for the required category (sub-folder) and choosing the Save All command, from the context menu.
  • Clicking to focus the required category (sub-folder), then clicking the Project button and choosing the Save All command from the context menu.
The command will only be available provided the focused category contains at least one document that is actually open, or open and hidden.

Use

First, ensure that the sub-folder whose documents you wish to save is focused in the Projects panel. Focus is given simply by clicking once on the folder's entry.

After launching the command, all documents residing within the focused sub-folder or descendant folders thereof, and that are currently open and/or open and hidden, will be saved.

Tips

  1. A modified document is flagged by an asterisk suffix next to its entry in the Projects panel. A modified document also has an asterisk next to its name in its open document tab (or on the associated pop-up menu if documents are grouped). In addition, modified documents are distinguished in the Projects panel through use of the  icon. To see this icon, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.
  2. The affected documents are saved, irrespective of whether they have been modified or not.


Applied Parameters: ObjectKind=Project|SaveMode=SaveAs

Summary

This command is used to save a copy of the currently active project, with a new name (if required), and to a specified location on the hard disk.

Access

With a document for the required project open as the active document, this command is accessed from that document's editor by choosing the File » Save Project As command, from the main menus.

Use

First, ensure that one of the target project's associated design documents is open as the active document in the main design window.

After launching the command, the standard Windows Save As dialog appears. Use this dialog to browse to a particular destination in which to save the project file, and give the file a new name (if required).

The newly saved project will be opened in place of the original project as the active project.

Tips

  1. Only the project document is saved. The constituent design documents are not saved by this command.
  2. The project document can be placed anywhere on the hard disk - the paths to the constituent design files will be updated accordingly.


Applied Parameters: ObjectKind=FocusedProject|SaveMode=Standard

Summary

This command is used to save the currently focused project in the Projects panel.

Access

This command can be accessed from the Projects panel by:

  • Right-clicking on the entry for the required project and choosing the Save Project command, from the context menu.
  • Clicking to focus the required project, then clicking the Project button and choosing the Save Project command from the context menu.

Use

First, ensure that the project you wish to save is focused in the Projects panel.

After launching the command, the project will be saved.

Tips

  1. A modified project is flagged by an asterisk suffix next to its entry in the Projects panel. In addition, modified projects are distinguished in the Projects panel through use of the icon. To see this icon, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.
  2. Only the project document is saved. The constituent design documents are not saved by this command.


Applied Parameters: ObjectKind=FocusedProject|SaveMode=SaveAs

Summary

This command is used to save a copy of the currently focused project in the Projects panel, with a new name (if required), and to a specified location on the hard disk.

Access

This command can be accessed from the Projects panel by:

  • Right-clicking on the entry for the required project and choosing the Save Project As command, from the context menu.
  • Clicking to focus the required project, then clicking the Project button and choosing the Save Project As command from the context menu.

Use

First, ensure that the required project is focused in the Projects panel.

After launching the command, the standard Windows Save As dialog appears. Use this dialog to browse to a particular destination in which to save the project file, and give the file a new name (if required).

The newly saved project will be opened in place of the original project.

Tips

  1. Only the project document is saved. The constituent design documents are not saved by this command.
  2. The project document can be placed anywhere on the hard disk - the paths to the constituent design files will be updated accordingly.


Applied Parameters: ObjectKind=Workspace

Summary

This command is used to save the current Design Workspace (*.DsnWrk).

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Save Design Workspace command, from the context menu.
  • Choosing the Project » Design Workspace » Save Design Workspace command, from the main menus.

Use

After launching the command, the active Design Workspace will be saved.

Tips

  1. A modified design workspace is flagged by an asterisk suffix next to its entry in the Projects panel.
  2. The currently open Design Workspace is identified in the top field of the Projects panel.
  3. Only the Design Workspace document is saved (*.DsnWrk). The constituent projects and their design documents are not saved by this command.
  4. A default Design Workspace (Workspace1.DsnWrk) is assigned to the Projects panel when:
    1. No specific Design Workspace has been opened.
    2. The creation of a new Design Workspace is specified.
    3. When all open projects and documents - part of a specific Design Workspace or not - are closed.

This default Design Workspace is initially unsaved and so use of this command will behave like the Save Design Workspace As command. Its name is used as the default entry in the Save As dialog, when you proceed to save the Design Workspace.


Applied Parameters: ObjectKind=Workspace|SaveMode=SaveAs

Summary

This command is used to save a copy of the currently active Design Workspace in the Projects panel, with a new name (if required), and to a specified location on the hard disk.

Access

This command can be accessed by:

  • Clicking the Workspace button in the Projects panel, then choosing the Save Design Workspace As command, from the context menu.
  • Choosing the Project » Design Workspace » Save Design Workspace As command, from the main menus.

Use

After launching the command, the standard Windows Save As dialog appears. Use this dialog to browse to a particular destination in which to save the Design Workspace file, and give the file a new name (if required).

The newly saved Design Workspace will be opened in place of the original Design Workspace.

Tips

  1. Only the Design Workspace document is saved (*.DsnWrk). The constituent projects and their design documents are not saved by this command.
  2. The Design Workspace document can be placed anywhere on the hard disk - the paths to the constituent project files will be updated accordingly.


Applied Parameters: ObjectKind=All|ModifiedOnly=True

Summary

This command is used to save all open projects and documents that have been modified. If an existing Design Workspace is open, this will be saved too, if its project membership has changed.

Access

This command can be accessed by:

  • Choosing the File » Save All command, from an editor's main menus.
  • Choosing the Project » Design Workspace » Save All command, from an editor's main menus.
  • Clicking the Workspace button in the Projects panel, then choosing the Save All command, from the context menu.

Use

After launching the command, all open projects and documents that are detected as having been modified, will be saved.

If the open projects are part of an existing (previously saved) Design Workspace, and project membership has changed (projects added or removed since last save), then the Design Workspace document (*.DsnWrk) will also be saved.

Tips

  1. A modified entity (document, project, design workspace) is flagged by an asterisk suffix next to its entry in the Projects panel. A modified document also has an asterisk next to its name in its open document tab (or on the associated pop-up menu if documents are grouped). In addition, modified documents and projects are distinguished in the Projects panel through use of the  and  icons respectively. To see these icons, click the drop-down part of the  button on the Projects panel, and enable the Show open/modified status option (part of the General cluster of options). This option can also be enabled from the System - Projects Panel page of the Preferences dialog.
  2. Saving is carried out in the order: Documents in project ---> Project documents ---> Design Workspace document.
  3. For schematic documents, if the current file format is not Binary Version 5.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in SCH Binary Version 5.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.
  4. For PCB documents, if the current file format is not Binary Version 6.0, the File Format dialog will appear, from where you can choose the format in which to save. It is recommended to choose the option to save in PCB Binary Version 6.0. If you have used features that were not available in previous versions of Altium NEXUS, saving in an earlier format may result in loss of data.

 

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.