Chuẩn bị thiết kế của bạn cho quá trình sản xuất
Sơ lược
- Tìm hiểu cách thêm và cấu hình đầu ra trong OutJob, bao gồm cách chọn nguồn dữ liệu hỗ trợ tái sử dụng giữa các dự án.
- Nắm được cách ánh xạ đầu ra tới các vùng chứa hoặc tác vụ in và kiểm soát vị trí lưu các tệp được tạo.
- Thực hiện theo quy trình phát hành dự án, bao gồm các tùy chọn phát hành, kiểm tra tính hợp lệ khi được cấu hình, tạo dữ liệu và rà soát.
Giai đoạn cuối cùng của chu trình thiết kế là tạo các tệp đầu ra cần thiết để sản xuất sản phẩm. Để thực hiện việc này, bạn cần tạo nhiều loại tệp đầu ra ở nhiều định dạng khác nhau. Là người thiết kế, bạn có thể chọn cấu hình và tạo riêng từng đầu ra thông qua trình biên tập sơ đồ nguyên lý và PCB, hoặc thêm tất cả các đầu ra cần thiết vào một OutputJob rồi tạo chúng trong quy trình phát hành dự án.

Mục tiêu cuối cùng là sản xuất sản phẩm – chẳng hạn như chế tạo và lắp ráp PCB.
Chuẩn bị dữ liệu sản xuất bằng Output Job
Bạn có thể cấu hình và tạo riêng từng đầu ra trực tiếp thông qua các menu File và Reports của trình biên tập tương ứng. Trong trường hợp này, các đầu ra được tạo trực tiếp khi bạn nhấp vào OK trong hộp thoại thiết lập liên quan và được ghi vào vị trí chỉ định trong trường Output Path trên tab Options của hộp thoại Project Options.
Tuy nhiên, các tệp Output Job giúp đơn giản hóa việc chuẩn bị đầu ra cho thiết kế và sau đó tạo các đầu ra này bằng quy trình phát hành dự án có tính toàn vẹn cao. Output Job, gọi tắt là 'OutJob', về cơ bản là một tập hợp các đầu ra được cấu hình sẵn, lưu trữ thiết lập cho các đầu ra này và xác định vị trí ghi các đầu ra được tạo.
Để thêm OutJob mới vào dự án thiết kế, hãy nhấp chuột phải vào mục của dự án trong bảng Projects và chọn lệnh Add New to Project » Output Job File từ menu ngữ cảnh. Một OutJob mặc định sẽ mở trong không gian thiết kế.

OutJob mới tạo sẽ là tài liệu đang hoạt động trong không gian thiết kế.
Bạn có thể thêm và cấu hình nhiều loại đầu ra phục vụ các mục đích khác nhau ở phía bên trái của OutJob. Các đầu ra được nhóm theo chức năng, chẳng hạn như đầu ra lắp ráp, đầu ra chế tạo và đầu ra báo cáo.
Thêm đầu ra mới thuộc loại cần thiết bằng cách nhấp vào dòng chữ Add New <Type> Output tương ứng ở cuối một nhóm rồi chọn loại đầu ra cần thiết từ menu bật lên. Mỗi mục loại đầu ra có một menu con để bạn chỉ định nguồn dữ liệu, tức là tài liệu nguồn nào sẽ được sử dụng khi tạo đầu ra. Bạn có thể thêm số lượng đầu ra tùy ý.
Đối với một số loại đầu ra cụ thể, bạn có thể cấu hình đầu ra đã thêm bằng cách nhấp chuột phải vào đầu ra trong danh sách và chọn lệnh Configure từ menu ngữ cảnh. Hộp thoại cấu hình tương ứng sẽ mở để bạn xác định các tùy chọn cho đầu ra. Ví dụ, hộp thoại Gerber X2 Setup sẽ mở cho đầu ra Gerber X2 Setup.

Cấu hình đầu ra theo yêu cầu trong hộp thoại thiết lập tương ứng.
Để xác định vị trí và định dạng tạo đầu ra, bạn sử dụng các bộ chứa đầu ra và tác vụ in. Đầu ra có thể được ghi (nếu áp dụng) vào ba loại bộ chứa đầu ra – PDF, video hoặc cấu trúc thư mục (chứa tệp đầu ra ở định dạng cụ thể, chẳng hạn như tệp Gerber). Một số đầu ra cũng có thể được gửi trực tiếp đến thiết bị in để in ra giấy bằng cách thêm và cấu hình một tác vụ in.
Một OutJob mới chứa một bộ chứa đầu ra cho mỗi loại và một tác vụ in dành cho máy in mặc định. Các mục này được hiển thị ở phía bên phải của OutJob. Nếu cần, bạn có thể thêm bộ chứa đầu ra hoặc tác vụ in mới bằng cách nhấp vào nút Add New Output Container rồi chọn loại bộ chứa cần thiết, hoặc nhấp vào nút Add New Print Job rồi chọn máy in cần thiết.

Thêm các bộ chứa đầu ra và/hoặc tác vụ in mới theo yêu cầu.
Để chỉ định đầu ra nào sẽ được tạo bằng bộ chứa đầu ra / tác vụ in nào, hãy chọn một bộ chứa/tác vụ rồi đánh dấu Enabled cho từng đầu ra cần thiết trong danh sách đầu ra. Sau khi được bật, một đường màu xanh lá sẽ nối đầu ra với bộ chứa đầu ra / tác vụ in đã chọn. Các đầu ra có thể được liên kết với những bộ chứa đầu ra / tác vụ in riêng biệt hoặc dùng chung.

Liên kết các đầu ra đã thêm với bộ chứa đầu ra và tác vụ in tương ứng bằng các dấu chọn Enabled.
Để cấu hình bộ chứa đầu ra / tác vụ in, hãy chọn mục tương ứng rồi nhấp vào nút Change. Hộp thoại tương ứng sẽ mở – ví dụ, khi chọn bộ chứa đầu ra dạng cấu trúc thư mục, hộp thoại Folder Structure settings sẽ mở để bạn cấu hình vị trí xuất của các tệp sẽ được tạo và các tùy chọn khác liên quan đến việc tạo tệp.

Cấu hình các thiết lập của bộ chứa đầu ra / tác vụ in trong hộp thoại tương ứng.
Các đầu ra đã cấu hình trong OutJob có thể được tạo trực tiếp từ OutJob hoặc, đối với dự án thiết kế PCB, trong quy trình phát hành dự án có tính toàn vẹn cao. Để tạo trực tiếp từ OutJob các đầu ra liên kết với bộ chứa đầu ra / tác vụ in, hãy chọn bộ chứa/tác vụ rồi nhấp vào nút Generate content hoặc Print tương ứng.

Bạn có thể tạo hoặc in đầu ra trực tiếp từ OutJob.
Phát hành thiết kế bo mạch
Với quy trình phát hành thiết kế bo mạch, bạn có thể tạo đồng thời toàn bộ dữ liệu sản xuất đã cấu hình trong các tệp OutJob của dự án PCB. Quy trình này có nhiều ưu điểm so với việc tạo riêng từng đầu ra hoặc tạo trực tiếp từ OutJob, bao gồm khả năng kiểm tra tính hợp lệ của thiết kế như một phần không thể tách rời của quy trình phát hành và tránh can thiệp thủ công trong quá trình phát hành. Ngoài ra, khi phát hành lên Workspace được kết nối, quy trình còn được tích hợp chặt chẽ với hệ thống quản lý phiên bản của Workspace.
Để bắt đầu phát hành dự án, hãy nhấp chuột phải vào mục của dự án trong bảng Projects rồi chọn lệnh Project Releaser từ menu ngữ cảnh. Chế độ xem Release sẽ mở trong một tab riêng.

Truy cập chế độ xem Release – giao diện người dùng của Project Releaser.
Quy trình phát hành diễn ra theo từng giai đoạn; các mục ở phía bên trái của chế độ xem Release cho biết bạn hiện đang ở giai đoạn nào.
Ở giai đoạn đầu của quy trình phát hành, bạn có thể nhấp vào nút Options ở góc dưới bên trái của chế độ xem để mở hộp thoại Project Release Options và cấu hình các tùy chọn cho quy trình phát hành theo nhu cầu. Các tùy chọn bao gồm chọn đích phát hành (Workspace, thư mục hoặc tệp zip) và chỉ định các OutJob.

Cấu hình các tùy chọn phát hành trong hộp thoại Project Release Options.
Tùy thuộc vào đích phát hành đã chọn, các giai đoạn của quy trình phát hành sẽ có đôi chút khác biệt. Ví dụ dưới đây minh họa việc phát hành lên một Workspace đã kết nối.
|
Ở giai đoạn Configure Server Release, bạn có thể chỉ định (các) loại dữ liệu muốn tạo: dữ liệu nguồn (bản chụp thiết kế nguồn, luôn được đưa vào bản phát hành), dữ liệu chế tạo và dữ liệu lắp ráp. Số lượng bộ dữ liệu lắp ráp sẽ tương ứng với thiết kế cơ sở (không có biến thể) và tất cả biến thể thiết kế được phát hiện. Khi đã sẵn sàng, hãy nhấp vào nút Prepare ở góc dưới bên phải của chế độ xem để tiếp tục. Nếu phát hiện vấn đề, bạn sẽ được đề xuất các giải pháp để khắc phục. Giai đoạn Validate Project được chạy tự động khi phát hiện một hoặc nhiều báo cáo kiểm tra xác thực, chẳng hạn như báo cáo Kiểm tra quy tắc thiết kế, trong (các) tệp OutJob đã chỉ định, đồng thời các đầu ra kiểm tra xác thực tương ứng được chạy. Quá trình phát hành sẽ thất bại nếu có bất kỳ bước kiểm tra xác thực nào không đạt. Giai đoạn Generate Data được chạy tự động khi giai đoạn trước hoàn tất mà không gặp vấn đề. Ở giai đoạn này, tất cả các đầu ra khác được xác định trong (các) tệp OutJob đã chỉ định đều được chạy để tạo dữ liệu cần phát hành. Sau khi tất cả các bước kiểm tra xác thực đều đạt và dữ liệu đầu ra đã được tạo, giai đoạn Review Data cho phép bạn xem lại dữ liệu đã tạo. Tiếp tục phát hành bằng cách nhấp vào nút Release ở góc dưới bên phải của chế độ xem và xác nhận việc phát hành trong hộp thoại xuất hiện. Sau khi xác nhận việc phát hành ở giai đoạn trước, hệ thống tự động chuyển sang giai đoạn Upload Data. Giai đoạn này hiển thị tiến trình tải dữ liệu lên. Giai đoạn cuối cùng Execution Report của quy trình cung cấp thông tin tóm tắt về bản phát hành. Khi dự án đã được phát hành, bạn có thể đóng chế độ xem Release bằng cách nhấp vào nút Close ở góc dưới bên phải của chế độ xem. |






