Kiểm tra dữ liệu chế tạo bằng Trình chỉnh sửa CAM
Sơ lược
- Tìm hiểu cách chọn, thực thi, lặp lại và hủy lệnh trong trình biên tập CAM.
- Hiểu sự khác biệt giữa chế độ CAM và NC khi hiển thị hình ảnh chế tạo, điểm khoan và đường phay.
- Khám phá cách quản lý khả năng hiển thị của các lớp, chọn lớp hiện hành và truy cập các lệnh thao tác với lớp thông qua bảng CAMtastic.
Trình biên tập CAMtastic (CAM) của Altium Designer cung cấp nhiều công cụ, trong đó cơ bản nhất là các công cụ xem và chỉnh sửa dữ liệu CAM. Sau khi nhập các tệp hình ảnh và tệp khoan, bạn có thể thiết lập loại lớp và cấu trúc xếp lớp trong trình biên tập CAM, từ đó trích xuất netlist và so sánh với netlist IPC được tạo từ phần mềm thiết kế PCB ban đầu. Các netlist này không chỉ xử lý linh kiện xuyên lỗ mà còn cả via mù và via chôn. Trình biên tập CAM cũng cung cấp các công cụ kiểm tra quy tắc thiết kế, ghép bảng và phay theo biên dạng NC (cùng với phay).
Thao tác CAM cơ bản
Môi trường trình biên tập CAM sử dụng một số phương thức thực hiện thao tác và quy trình hơi khác so với những gì bạn có thể đã quen.
Chọn thao tác trước khi chọn đối tượng
Cách thực hiện thao tác trong trình biên tập CAM có thể có vẻ ngược đối với người dùng mới vốn quen chọn đối tượng before yêu cầu chương trình thực hiện thao tác với chúng. Tương tự các công cụ CAM khác, trình biên tập CAM đảo ngược quy trình này: trước tiên, bạn chọn thao tác, sau đó chọn các đối tượng cần tác động, rồi kết thúc bằng một lệnh thực thi.
Nếu chưa quen với cách làm việc này, bạn có thể dựa vào một vài dấu hiệu hỗ trợ cho đến khi thành thạo. Trước tiên, hãy nhìn con trỏ. Khi con trỏ hiển thị dưới dạng tâm ngắm chữ thập trên vùng làm việc thiết kế, điều đó có nghĩa là nó không ở chế độ chọn (trong chế độ chọn, con trỏ hiển thị dưới dạng ô vuông). Việc tất cả các nút chọn đều bị làm mờ có thể nhắc bạn rằng bạn chưa chọn thao tác nào, ít nhất là chưa chọn thao tác yêu cầu chọn đối tượng thông thường. Thanh trạng thái, nằm ở cuối cửa sổ chỉnh sửa chính, đặc biệt hữu ích trong các quy trình nhiều bước khi bạn thắc mắc vì sao không có gì xảy ra; thanh trạng thái sẽ cho biết trình biên tập CAM đang chờ bạn làm gì.
Thực thi bằng nhấp chuột phải
Trước tiên, bạn chọn một lệnh, sau đó chọn một tập hợp đối tượng. Sau bước này, trình biên tập CAM chờ lệnh thực thi. Điều này cho phép bạn thoải mái xây dựng vùng chọn một cách cẩn thận trên nhiều lớp và nhóm đối tượng. Cách cơ bản để gửi lệnh thực thi là nhấp chuột phải. Các lời nhắc trong Status Bar sẽ cho biết khi nào có thể sử dụng thao tác nhấp chuột phải theo cách này. Bạn cũng có thể sử dụng phím tắt Shift+F9 để thực thi chức năng hiện tại sau khi đã chọn tất cả các đối tượng cần thiết liên quan đến chức năng đó.
Bạn có thể nhận thấy rằng sau khi thực thi một chức năng, con trỏ không trở về trạng thái không hoạt động. Thay vào đó, ô vuông chọn vẫn còn và thanh trạng thái nhắc bạn bắt đầu chọn lại. Điều này xảy ra khi tùy chọn Auto Repeat Functions được bật trên trang CAM Editor - General của hộp thoại Preferences.
Đôi khi, nút chuột phải có thể được dùng để hủy các quy trình hiện tại. Cách này có tác dụng khi bạn chưa hoàn tất một bước bắt buộc, chẳng hạn như chọn đối tượng. Tuy nhiên, nhìn chung, phím Esc là lựa chọn an toàn hơn để hủy thao tác.
Các chế độ chỉnh sửa
Trình biên tập CAM hỗ trợ hai chế độ chỉnh sửa: CAM và NC (phay theo biên dạng). Các chế độ này được bật bằng các lệnh CAM Editor và NC Editor tương ứng, có sẵn khi chọn View » CAM Editor hoặc View » NC Editor từ menu chính. Ngoài ra, bạn có thể đặt chế độ chỉnh sửa trực tiếp từ danh sách thả xuống trong bảng CAMtastic . Về cơ bản, các chế độ này khác nhau ở cách hiển thị dữ liệu. Chế độ CAM Editor hiển thị hình ảnh đúng như khi chúng được vẽ hoặc chiếu chớp lên phim quang dùng trong sản xuất PCB. Chế độ NC Editor bổ sung các dấu đánh dấu cho lỗ khoan và đường phay theo biên dạng.
Một đường phay theo biên dạng được hiển thị ở chế độ NC Editor.
CAM Editor sẽ luôn ở một trong hai chế độ chỉnh sửa này. Khi ở chế độ CAM Editor, các công cụ phay theo biên dạng sẽ bị làm mờ trong menu. Tương tự, khi chế độ NC Editor đang hoạt động, các công cụ chỉnh sửa CAM thông thường sẽ bị vô hiệu hóa. Khi chế độ CAM Editor đang hoạt động, bảng CAMtastic cho phép bạn truy cập nhanh các DCode được định nghĩa trong Danh sách khẩu độ thông qua danh sách thả xuống. Khi chế độ NC Editor đang hoạt động, danh sách thả xuống này sẽ hiển thị bộ công cụ khoan, phay theo biên dạng và phay. Quan trọng nhất, không gian thiết kế sẽ tương ứng với chế độ chỉnh sửa hiện tại. Chế độ NC Editor biểu thị các điểm khoan và đường phay theo biên dạng bằng các dấu đánh dấu đặc biệt: mỗi điểm khoan được đánh dấu bằng chữ X, còn các đường phay theo biên dạng chứa các điểm hạ dao và rút dao, cùng với dấu chỉ hướng khi cần thiết. Các dấu chỉ dẫn này không hiển thị khi làm việc ở chế độ CAM Editor.
Bảng CAMtastic
Bảng này có sẵn bất cứ khi nào một tài liệu CAM đang hoạt động, chứa các thông tin quan trọng của tài liệu CAM đó, bao gồm các lớp, Dcode hoặc dao cụ hiện tại, thiết lập lưới/đơn vị và vị trí tuyệt đối của con trỏ trong không gian thiết kế. Bạn cũng có thể chuyển đổi giữa các vùng Info, DRC, Nets và Steps của bảng để xem các thông tin khác dành riêng cho thiết kế.
Vùng Layers hiển thị tất cả các lớp đã tạo/nhập và trạng thái hiển thị của chúng. Lớp hiện tại sẽ có một X màu trắng đi qua ô màu tương ứng, đồng thời cũng được hiển thị ở đầu vùng này. Bạn có thể nhấp đúp vào tên một lớp khác để đặt lớp đó làm lớp hiện tại.
Khi đã có các lớp, nhấp chuột phải vào bất kỳ đâu trong vùng này sẽ cho phép bạn truy cập nhanh các lệnh dành cho lớp, bao gồm khóa, đổi tên hoặc thêm lớp. Nếu bạn vừa tạo một tài liệu mới và muốn bắt đầu thêm lớp, hãy sử dụng lệnh Edit » Layers » Add để thêm lớp đầu tiên.
Bạn có thể tô sáng bất kỳ lớp nào trong danh sách này rồi sử dụng các phím Up Arrow và Down Arrow trên bàn phím để duyệt dữ liệu CAM ở chế độ một lớp. Phím Right Arrow sẽ hiển thị tất cả các lớp, còn phím Left Arrow sẽ chỉ hiển thị lớp được tô sáng. Bạn có thể chọn nhiều lớp bằng các tính năng Shift+Click và Ctrl+Click tiêu chuẩn, cho phép hiển thị, ẩn hoặc xóa nhiều lớp cùng lúc. Bạn có thể sử dụng các phím +/- và * trên bàn phím số để lần lượt chuyển qua tất cả các lớp đang hiển thị hoặc chỉ các lớp tín hiệu/lớp mặt phẳng, tương ứng.
Bạn có thể xóa các lớp khỏi bảng điều khiển, nhưng thao tác này không thể hoàn tác. Lệnh Undo trong menu Edit sẽ không khôi phục các lớp đã xóa.
Bạn có thể chuyển qua lại giữa bảng điều khiển CAMtastic và tài liệu CAM đang hoạt động bằng phím tắt Shift+F5. Phím F4 sẽ bật/tắt trạng thái hiển thị của tất cả các bảng điều khiển nổi.
Nội dung và cách sử dụng bảng điều khiển CAMtastic
Các tính năng của bảng điều khiển
Danh sách thả xuống ở đầu bảng điều khiển cho phép bạn nhanh chóng chuyển đổi giữa chế độ CAM Editor và NC Editor. Phần ngay bên dưới trường này liệt kê tất cả các lớp có sẵn trong tài liệu CAM hiện tại (*.cam). Các lớp được liệt kê theo cùng thứ tự xuất hiện trong hộp thoại Layers Table, có thể mở bằng cách chọn Tables » Layers từ menu chính.
Với mỗi lớp trong danh sách, tên và số của lớp được hiển thị cùng với tùy chọn điều khiển trạng thái hiển thị của lớp (bật hoặc tắt). Ngoài ra còn có một ô màu cho biết màu hiện được gán cho lớp. Nhấp vào ô màu sẽ mở hộp thoại Change Layer Color , cung cấp nhiều màu sắc để lựa chọn.
Ở đầu danh sách lớp là tên của lớp hiện hành. Lớp hiện hành là lớp được dùng để đặt các đối tượng mới, chẳng hạn như đường thẳng, đường đa đoạn và điểm khoan. Lớp hiện hành cũng được đánh dấu bằng một dấu chữ thập màu trắng trong ô màu của mục tương ứng. Để đặt một lớp làm lớp hiện hành, hãy nhấp đúp vào mục của lớp đó trong danh sách.
Nhấp chuột phải vào một mục lớp trong danh sách sẽ mở menu chứa các lệnh liên quan đến lớp sau đây:
- Type - dùng lệnh này để hiển thị loại lớp đã được gán cho lớp trong hộp thoại Layers Table.
- ON - dùng để bật/tắt trạng thái hiển thị của lớp. Khi lớp được bật (tức là hiển thị trong không gian thiết kế), một dấu kiểm sẽ xuất hiện bên trái lệnh và tùy chọn hiển thị tương ứng của lớp sẽ được bật.
- Current - dùng để đặt lớp đã chọn làm lớp hiện hành. Một dấu kiểm sẽ xuất hiện bên trái lệnh, tên lớp sẽ xuất hiện trong trường Current Layer (ở đầu danh sách lớp) và một dấu chữ thập màu trắng sẽ xuất hiện trong ô màu tương ứng của lớp.
- Lock / Lock Selected - dùng để khóa các lớp đã chọn, ngăn mọi thao tác vẽ trên các lớp đó. Khi được bật, một dấu kiểm sẽ xuất hiện bên trái lệnh.
- RESCan / RESCan Selected - dùng để so sánh ngày của dữ liệu (Gerber/ODB ++ Feature) hiện có trong tài liệu CAM đang hoạt động với dữ liệu được tạo gần đây nhất từ cùng tài liệu PCB nguồn, đối với lớp đã chọn. Nếu dữ liệu được tạo gần đây nhất mới hơn dữ liệu hiện có, lệnh Reload sẽ được bật.
- Reload / Reload Selected - dùng để tạo lại dữ liệu cho lớp đã chọn mà quy trình Rescan phát hiện là đã thay đổi. Tất cả thay đổi đối với lớp sẽ được đưa vào tài liệu CAM đang hoạt động để đồng bộ lại với tài liệu PCB nguồn.
- All On - dùng để hiển thị (bật) tất cả các lớp trong không gian thiết kế.
- All Off - dùng để ẩn (tắt) tất cả các lớp trong không gian thiết kế.
- Isolate - dùng để ẩn (tắt) tất cả các lớp trong không gian thiết kế, ngoại trừ lớp đã chọn (bật).
- Scroll Up - dùng để lần lượt chuyển lên từng lớp trong danh sách, bắt đầu từ lớp đang được chọn. Mỗi lớp khi được chọn sẽ trở thành lớp hiện hành và tất cả các lớp khác sẽ bị ẩn trong không gian thiết kế.
- Scroll Down - dùng để lần lượt chuyển xuống từng lớp trong danh sách, bắt đầu từ lớp đang được chọn. Mỗi lớp khi được chọn sẽ trở thành lớp hiện hành và tất cả các lớp khác sẽ bị ẩn trong không gian thiết kế.
- Compare - dùng để mở hộp thoại Compare Layers, nơi bạn có thể so sánh hai lớp, thay đổi dung sai của lớp và điều chỉnh độ phân giải của lớp ánh xạ.
- Compress Layers - dùng để gộp các lớp có cùng loại được chỉ định trong bảng lớp thành một lớp duy nhất. Lệnh này chỉ áp dụng cho các loại lớp chỉ nên có một lớp trong mỗi thiết kế (ví dụ: lớp trên, lớp dưới, lớp mặt nạ, lớp in lụa, lớp khoan trên, lớp khoan dưới).
- Rename - dùng để đổi tên lớp đang được chọn. Sau khi gọi lệnh, hộp thoại Enter Value sẽ xuất hiện. Nhập tên mới cho lớp (chỉ dùng chữ thường) rồi nhấp OK - tên mới sẽ thay thế tên cũ.
-
Add Layer - dùng để tạo một lớp mới và thêm vào danh sách. Sau khi gọi lệnh, hộp thoại Enter Value sẽ xuất hiện. Nhập tên cho lớp mới (chỉ dùng chữ thường) rồi nhấp OK - lớp sẽ được thêm vào cuối danh sách.
Nếu nhiều lớp được chọn trong danh sách, mục Type trong menu sẽ hiển thị Multiple Selection và các lệnh sau sẽ không khả dụng: On, Current, Lock, Scroll Up, Scroll Down và Add Layer. - Turn On / Turn On Selected - dùng để hiển thị (On) tất cả các lớp đã chọn trong không gian thiết kế. Lệnh này chỉ khả dụng nếu ít nhất một lớp trong vùng chọn hiện đang tắt.
- Turn Off / Turn Off Selected - dùng để ẩn (Off) tất cả các lớp đã chọn trong không gian thiết kế. Lệnh này chỉ khả dụng nếu ít nhất một lớp trong vùng chọn hiện đang bật.
- Lock / Lock Selected - dùng để khóa các lớp đã chọn, ngăn mọi thao tác vẽ trên các lớp đó. Khi lớp bị khóa, một dấu kiểm sẽ xuất hiện bên phải lệnh để biểu thị trạng thái này. Để mở khóa, hãy nhấp lại vào các lớp đã khóa.
- Delete / Delete Selected - dùng để xóa các lớp đã chọn khỏi tài liệu CAM.
Thẻ Info
Thẻ Info
Thẻ Info hiển thị thông tin sau khi chạy bất kỳ lệnh truy vấn nào (Object, Group, Net, Minimum Annular Ring), có thể truy cập từ menu Analysis .
Thẻ DRC
Tab DRC
Tab DRC liệt kê các vi phạm còn tồn tại sau khi chạy Kiểm tra quy tắc thiết kế (DRC) trên tài liệu hiện tại. Khi có vi phạm, một thư mục cấp cao nhất cho phép kiểm tra thiết kế tương ứng sẽ được liệt kê, bên dưới là các thư mục con dành cho từng đối tượng vi phạm. Nhấp vào một thư mục con sẽ chọn, thu phóng và đưa các đối tượng vi phạm vào giữa cửa sổ trình biên tập thiết kế.
Nếu lỗi DRC có thể được khắc phục bằng tính năng Auto Fix, bạn có thể nhấp chuột phải vào thư mục con của lỗi đó và chọn Fix DRC Error từ menu bật lên.
Tab Nets
Tab Nets
Tab Nets hiển thị các net có trong thiết kế sau khi netlist được trích xuất bằng cách chọn lệnh Tools » Netlist » Extract. Tổng chiều dài net cũng được liệt kê cho từng mục. Nhấp vào một mục net sẽ chọn, thu phóng và đưa tất cả các đối tượng liên quan đến net đó vào giữa cửa sổ trình biên tập thiết kế.
Tab Steps
Tab Steps
Tab Steps hiển thị các Step ODB hiện được định nghĩa cho tài liệu. Tên của Step hiện tại được hiển thị ở đầu tab. Nhấp đúp vào một mục Step sẽ đặt Step đó làm Step hiện tại.
Nhấp chuột phải vào một mục Step trong tab để truy cập menu bật lên chứa các lệnh sau:
- Current - dùng để đặt Step đã chọn làm Step hiện tại. Một dấu kiểm sẽ xuất hiện ở bên trái mục lệnh.
- Delete - dùng để xóa Step đã chọn khỏi tài liệu thiết kế. Không thể xóa Step hiện tại hoặc Step đã được chèn vào một Step khác.
- Rename - dùng để đổi tên Step đã chọn. Sau khi chạy lệnh, hộp thoại Enter Value sẽ xuất hiện. Nhập tên mới cho Step (chỉ dùng chữ thường) rồi nhấp vào OK - tên mới của Step sẽ thay thế mọi chỗ xuất hiện của tên hiện tại.
-
Add Insert - dùng để chèn một Step vào bên trong một Step khác. Hộp thoại Add Insert to ODB Step sẽ xuất hiện. Sử dụng hộp thoại này để chọn Step cần chèn (từ danh sách các Step có sẵn) và xác định vị trí, kích thước mảng cũng như hướng. Nhấp vào OK sẽ thêm Step được chèn dưới dạng Step con của Step cha đã chỉ định trong tab - được hiển thị theo định dạng: n: TênStep (Hàng, Cột), trong đó [n] là số khả dụng tiếp theo được gán cho Step được chèn, bắt đầu từ 1.
Trong cửa sổ trình biên tập thiết kế, Step được chèn sẽ xuất hiện dưới dạng các hình chữ nhật rỗng màu trắng, với số lượng được xác định bởi kích thước mảng đã chọn trong hộp thoại Add Insert to ODB Step. Các dấu chữ thập màu trắng cũng được hiển thị, mỗi Step trong mảng có một dấu, trong đó dấu chữ thập ở góc dưới bên trái nằm tại tọa độ Điểm gốc đã chọn, cũng được xác định trong hộp thoại. Các dấu chữ thập này xác định vị trí đặt nội dung đối tượng của Step được chèn nếu bạn chọn tách mảng Step. Bạn có thể tìm thấy lệnh tách mảng Step bằng cách nhấp chuột phải vào mục Step con trong tab. Menu bật lên sau đó cũng chứa các lệnh để chỉnh sửa và xóa mảng Step được chèn. - Add Step - dùng để tạo một Step mới. Hộp thoại Enter Value sẽ xuất hiện. Nhập tên cho Step mới (chỉ dùng chữ thường) rồi nhấp vào OK - Step sẽ được thêm vào cuối danh sách và được đặt làm Step hiện tại.
-
Move Objects - dùng để di chuyển các đối tượng từ Step này sang Step khác. Lệnh này chỉ khả dụng nếu Step nguồn của thao tác di chuyển là Step hiện tại.
Sau khi chạy lệnh, con trỏ sẽ chuyển thành một hình vuông nhỏ và bạn sẽ được nhắc chọn các đối tượng cần di chuyển. Đặt con trỏ lên từng đối tượng rồi nhấp để chọn, hoặc sử dụng một trong nhiều công cụ chọn có sẵn.
Sau khi chọn xong, nhấp chuột phải sẽ mở hộp thoại New Step for Objects. Chọn Step mà bạn muốn chuyển các đối tượng đến rồi nhấp vào OK - các đối tượng sẽ được xóa khỏi Step hiện tại và thêm vào Step đích. - Copy Objects - dùng để sao chép các đối tượng từ Step này sang Step khác. Lệnh này chỉ khả dụng nếu Step nguồn của thao tác sao chép là Step hiện tại. Lệnh này tương tự lệnh Move Objects, điểm khác biệt duy nhất là các đối tượng được chọn không bị xóa khỏi Step nguồn mà chỉ được sao chép.
- Add Venting - dùng để thêm mẫu thông thoáng xung quanh các PCB được ghép trong một panel. Lệnh này chỉ khả dụng nếu các PCB được ghép panel bằng lệnh Tools » Panelize PCB hoặc bằng cách tải dữ liệu ODB++ có chứa panel.
- Remove Venting - dùng để xóa mọi mẫu thông thoáng khỏi PCB đã ghép panel. Ví dụ, lệnh này được sử dụng nếu đường biên PCB đã được chỉnh sửa sau khi thêm mẫu thông thoáng.
- Refresh Inserts - dùng để làm mới các mục chèn hiện có nhằm phản ánh các thay đổi.
Vùng dưới cùng của bảng chứa các trường sau:
- 1 - Tùy vào việc bạn đang sử dụng chế độ CAM Editor hay NC Editor, điều khiển này cho phép bạn chọn mã D hoặc công cụ khoan hiện tại tương ứng.
- 2 - Điều khiển này cho phép bạn chọn chế độ bắt dính đối tượng hiện tại.
- 3 - Điều khiển này cho phép bạn thay đổi đơn vị của không gian thiết kế hiện tại. Chọn milimét hoặc inch.
- 4 - Trường này trong bảng hiển thị tọa độ X-Y của vị trí con trỏ trong không gian thiết kế chính. Trường sử dụng đơn vị đã được chọn trong điều khiển 3.
Thông tin bổ sung về Step
- Mỗi Step ODB được định nghĩa trong thiết kế đều chứa cùng một danh sách lớp. Sự khác biệt giữa các Step nằm ở các đối tượng mà chúng chứa trên những lớp đó.
- Phải định nghĩa ít nhất hai Step cho tài liệu hiện tại thì mới có thể chèn một Step vào Step khác.
- Không giống mảng Step & Repeat thông thường, khi một Step được chèn vào Step khác, mảng tạo thành chỉ bao gồm các phần tử được biểu diễn bằng đường viền. Phần tử ở góc dưới bên trái không hiển thị đầy đủ các đối tượng của Step. Nếu bạn nhấp vào mục cấp cao nhất của Step được chèn (không phải mục của nó bên dưới Step cha đã định nghĩa), các đối tượng chứa trong Step được chèn sẽ hiển thị tại vị trí được đánh dấu bằng dấu chữ thập màu trắng ở góc dưới bên trái. Step cha và tất cả các phần tử mảng khác trong Step được chèn sẽ không được hiển thị.
-
Tab Steps tự động được làm mới mỗi khi bạn nhấp vào OK trong hộp thoại Steps Table, được mở bằng cách chọn Tables » Steps từ menu chính.
Có thể thay đổi mã D, chế độ bắt dính đối tượng và đơn vị không gian thiết kế trong khi đặt các đối tượng vẽ (ví dụ: đường thẳng, đường đa đoạn, hình chữ nhật, v.v.). Ví dụ, bạn có thể đặt một đường với các đoạn được vẽ bằng các mã D khác nhau, tất cả trong cùng một lần đặt. Bạn có thể vẽ một đường đa đoạn, thay đổi mã D trong quá trình đặt và khi hoàn tất, mã D hiện tại sẽ được áp dụng cho toàn bộ đường đa đoạn.
Ghi chú
- Theo mặc định, màu Draw và Flash được gán cho một lớp là giống nhau. Khi thay đổi màu được gán cho lớp trong bảng điều khiển, cả màu Draw và Flash trong hộp thoại Layers Table đều sẽ được cập nhật. Nếu muốn thay đổi riêng màu Draw hoặc Flash, bạn phải chỉnh sửa mục tương ứng trong hộp thoại. Khi chỉnh sửa màu qua hộp thoại, chỉ màu được gán cho Draw mới được phản ánh trong bảng điều khiển.
- Chọn một mục trong danh sách lớp rồi nhấn phím Left Arrow để tắt tất cả các lớp ngoại trừ lớp đó. Chọn một mục trong danh sách lớp rồi nhấn phím Right Arrow để bật tất cả các lớp.
- Các lệnh dựa trên Rescan và Reload chỉ khả dụng nếu tùy chọn Reset auto-load options after generation được bật trước khi tạo dữ liệu đầu ra Gerber/ODB++ lần đầu. Bạn có thể tìm thấy tùy chọn này trong hộp thoại Output Job Options, được truy cập từ menu Tools khi tệp Output Job liên quan (*.OutJob) đang hoạt động. Việc bật tùy chọn này sẽ ngăn dữ liệu đầu ra được tải vào tài liệu CAM mới khi dữ liệu được tạo lại từ tài liệu PCB nguồn.
- Sau khi trích xuất danh sách kết nối từ thông tin Gerber có trong tài liệu hiện tại, các net sẽ được liệt kê trong tab Nets của bảng điều khiển với tên mặc định. Các tên này có định dạng $Netn (trong đó n là số nguyên tiếp theo được gán theo thứ tự trích xuất). Nếu đã nhập danh sách kết nối ở định dạng IPC-D-356 được tạo từ tài liệu PCB, bạn có thể đổi tên các net thành những tên có ý nghĩa hơn đã được gán trong thiết kế PCB gốc. Để thực hiện việc này, hãy chọn Tools » Netlist » Rename Nets từ các menu chính.
- Bạn có thể chọn nhiều net trong tab Nets — sau đó tất cả các net này cũng sẽ được chọn trong cửa sổ trình chỉnh sửa thiết kế.
- Khi kiểm tra lỗi DRC, việc chọn một mục trong tab DRC sẽ chỉ bật những lớp chứa các đối tượng vi phạm. Tất cả các lớp khác sẽ bị tắt. Khi kiểm tra các net, bạn phải bật trước các lớp liên quan; nếu không, bạn có thể không nhìn thấy gì.
